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FlexNet Operations 2021 R1 On-
Premises User Guide

FlexNet Operations is a Web-based application that supports the integration of software license delivery into the 
business operations of software publishers and device manufacturers. This section provides a high-level 
overview of FlexNet Operations, a brief discussion of its environments, and previews the concepts and 
information covered in other sections of the online help.

The remainder of the user guide is organized into the following sections.

Table 1-1 • FlexNet Operations User Guide

Section Description

Using FlexNet 
Operations

Discusses the tasks associated with using FlexNet Operations to manage the 
licensing of software products and devices.

• Packaging Products

• Entitling Customers and Activating Licenses

• Supporting Licenses

• Managing Devices

• Managing Usage

• Managing Accounts and Users

• Branding the End-User Portal
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Introduction to FlexNet Operations
FlexNet Operations is a Web-based application that supports the integration of software license delivery into the 
business operations of software publishers and device manufacturers. It allows vendors to automate the stages 
of the software license lifecycle, which is illustrated in the following figure:

Getting Started This section explains fundamental concepts, and provides exercises to help you get 
started using the basic features of FlexNet Operations.

• Getting Started with FlexNet Embedded Licensing

• Getting Started with FlexNet Publisher Trusted Storage-Based Licensing

• Getting Started with FlexNet Publisher License File-Based Licensing

• Getting Started with Non-FlexNet Licensing Technologies

• Getting Started with Cloud Licensing Service

• Getting Started with Entitlement Management

• Getting Started with Electronic Software Delivery

• Getting Started with Usage Management

• Getting Started with FlexNet Customer Growth

• Getting Started with Advanced Organization Management

Administrator 
Reference

This section identifies FlexNet Operations administration processes—such as 
managing system configuration, license technologies, device and license server 
setup, and email templates—and describes how to perform those administration 
tasks.

• Configuring FlexNet Operations

• Performing Administrative Tasks

Table 1-1 • FlexNet Operations User Guide

Section Description
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Figure 1-1: Software License Lifecycle Stages 

The following table describes the stages of the software license lifecycle.

Table 1-2 • Stages of the Software License Lifecycle

Stage Description

Create Products Create product definitions that are used to generate licenses. 

Order/Entitle Define an account’s rights to obtain licenses for your products.

Deliver⁄Install Deliver the application software to the customer and install that software.

Activate Deliver licenses to the customer.

Return/Rehost Manage license transfers from one user or system to another. 

Maintain/Update Deliver software updates to the customer.

Upsell/Renew Renew the customer’s licenses, or sell the customer additional product functionality.
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FlexNet Operations Home Page
The home page for FlexNet Operations displays the following information: 

FlexNet Operations Environments
FlexNet Operations has two environments:

• User Acceptance Testing (UAT)

• Production (PROD)

About Your Site ID
The URLs for the entry points into the FlexNet Operations systems use a site ID, which is supplied by Revenera. 
This ID is usually your organization's DNS name, but can also be the Tenant ID that was assigned to your 
organization when FlexNet Operations was first implemented, and would have the format flexNNNN.

For example, the URL for the FlexNet Operations Producer Portal for the company ABCD with the tenant ID of 1234 
might appear as follows:

Table 1-3 • FlexNet Operations Home Page

Widget Description

Alerts A list of the most recent alert activity. Click See All to go to the Alerts page to see all 
the alerts.

Announcements A list of any announcements regarding the FlexNet Operations portal.

QuickSearch Enables quick access to searches for Entitlements, Licenses, Devices, Customer 
Users, Customer Accounts and Products. Once you have selected a search type, use 
the drop down boxes and text box to further define your search criteria.

Account Health Provides an at-a-glance view of over all Account Health, Renewal Risk and 
Consumption Health for all accounts. For details on the features of the Account 
Health information, see Account Health. Click Health Dashboard to go to the Health 
Dashboard page.

Method Site ID in URL

Using the DNS name https://ABCD-fno.flexnetoperations.com/flexnet/operations

Using the Tenant ID https://flex1234-fno.flexnetoperations.com/flexnet/operations
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User Acceptance Testing (UAT)
The UAT environment is a place to perform configuration, integration development, testing, and training. The 
following URLS are entry points into the FlexNet Operations system.

Note • For more information on <siteID>, see About Your Site ID.

Production (PROD)
The Production instance is for customer entitlement management and licenses, usage, and delivery activities. 
The following URLS are entry points into the FlexNet Operations system.

Table 1-4 • FlexNet Operations UAT Environment URLs

Use URL

Producer Portal (you) https://<siteID>-fno-uat.flexnetoperations.com/flexnet/operations

End User Portal 
(end customers and channel 
partners)

https://<siteID>-uat.flexnetoperations.com/flexnet/operationsportal

FlexNet Embedded Activation 
Endpoint

https://<siteID>-uat.compliance.flexnetoperations.com/deviceservices

Cloud Licensing Service Module 
Endpoint

https://<siteID>-uat.compliance.flexnetoperations.com/instances/<CLS 
instance ID>/request

Download Packaging Service https://<siteID>-fno-uat.flexnetoperations.com/flexnet/services/v2/
DownloadPackagingService

Electronic Software Delivery 
FTP Site

uploaduat.flexnetoperations.com

Notification Server https://<siteID>-ns-uat.flexnetoperations.com/

Table 1-5 • FlexNet Operations Production Environment URLs

Use URL

Producer Portal (you) https://<siteID>-fno.flexnetoperations.com/flexnet/operations

End User Portal (end customers 
and channel partners)

https://<siteID>.flexnetoperations.com/flexnet/operationsportal

FlexNet Embedded Activation 
Endpoint

https://<siteID>.compliance.flexnetoperations.com/deviceservices
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Note • For more information on <siteID>, see About Your Site ID.

About Download Management and FlexNet 
Electronic Software Delivery

FlexNet Electronic Software Delivery (requires the Software Delivery module) adds electronic download support 
to FlexNet Operations. Producers who use FlexNet Operations with FlexNet Electronic Software Delivery define 
their downloads as part of the product packaging process. The downloads they specify are available to entitled 
end users in the End-User Portal.

Downloads are specified as download packages. A download package describes a group of files and relates that 
group with a product, a producer, and, optionally, a license agreement. 

Cloud Licensing Service Module 
Endpoint

https://<siteID>.compliance.flexnetoperations.com/instances/
<CLS instance ID>/request

Download Packaging Service https://<siteID>-fno.flexnetoperations.com/flexnet/services/v2/
DownloadPackagingService

Electronic Software Delivery 
FTP Site

upload.flexnetoperations.com

Notification Server https://<siteID>-ns.flexnetoperations.com/

Table 1-5 • FlexNet Operations Production Environment URLs

Use URL
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Figure 1-2: Download packages

A product can have many download packages, and download packages can be associated with one or more 
products. Download packages collect files into groups that might comprise a software release, a component, or 
any other grouping that fits your account’s needs.

For producers who use FlexNet Operations with FlexNet Electronic Software Delivery, the Producer Portal 
includes features for managing download packages, files, agreements, and producers. The Products menu 
includes links for creating and managing these items. Also, product lines, which are otherwise optional, are 
required for producers who use FlexNet Electronic Software Delivery. 

For more information about download management, see the following sections in Packaging Products: 

• Managing Download Packages

• Managing Download Files

• Managing License Agreements

• Managing Producers

Tip • Export compliance prevents the delivery of files to residents of certain countries, in keeping with U.S. 
restrictions on the sale of regulated technologies to these countries. The user-configurable export compliance 
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settings are managed at the download package level. For more information about export compliance, see About 
Export Compliance.

About FlexNet Usage Management
FlexNet Usage Management adds usage management support to FlexNet Operations. In conjunction with FlexNet 
Embedded licensing, FlexNet Usage management includes the ability to set up usage-enabled license models, 
products, license servers and view usage history reports in the FlexNet Operations Producer Portal.

FlexNet Operations and FlexNet Usage Management help application producers maximize software revenues and 
eliminate revenue leakage through new support of increasingly popular usage-based trust but verify, pay-for-use, 
and pay-for-overage models. FlexNet Usage Management provides application producers the flexibility to 
implement any software licensing model across the entire spectrum—from strict enforcement to usage-based, 
trust but verify.

In FlexNet Operations, usage management functionality is integrated with license models, features, products, 
and other components, and supported on FlexNet Embedded hosts, devices, and license servers. In the Producer 
Portal, usage reports are available from the Usage menu. (See Managing Usage.) In the End-User Portal, users in 
customer accounts can view usage reports for their account. 

Product Support Resources
The following resources are available to assist you with using this product:

• Revenera Product Documentation

• Revenera Community

• Revenera Learning Center

• Revenera Support

Revenera Product Documentation
You can find documentation for all Revenera products on the Revenera Product Documentation site:

https://docs.revenera.com

Revenera Community
On the Revenera Community site, you can quickly find answers to your questions by searching content from other 
customers, product experts, and thought leaders. You can also post questions on discussion forums for experts 
to answer. For each of Revenera’s product solutions, you can access forums, blog posts, and knowledge base 
articles. 

https://community.revenera.com

Revenera Learning Center
The Revenera Learning Center offers free, self-guided, online videos to help you quickly get the most out of your 
Revenera products. You can find a complete list of these training videos in the Learning Center.

https://learning.revenera.com

https://learning.revenera.com
https://docs.revenera.com
https://docs.revenera.com
https://community.revenera.com
https://community.revenera.com
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Revenera Support
For customers who have purchased a maintenance contract for their product(s), you can submit a support case 
or check the status of an existing case by first logging into the Revenera Community and then making selections 
on the Get Support menu, including Open New Case and other options.

Figure 1-3: Get Support Menu of Revenera Community

Contact Us
Revenera is headquartered in Itasca, Illinois, and has offices worldwide. To contact us or to learn more about our 
products, visit our website at:

http://www.revenera.com

You can also follow us on social media:

• Twitter

• Facebook

• LinkedIn

• YouTube

• Instagram

https://twitter.com/getrevenera
https://www.facebook.com/flexera/
https://www.linkedin.com/company/revenera/
https://www.youtube.com/c/GetRevenera
https://www.instagram.com/weareflexera/
http://www.revenera.com
https://community.revenera.com
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Part 1
Using FlexNet Operations

This part of the FlexNet Operations User Guide includes the following sections:

• Packaging Products

• Entitling Customers and Activating Licenses

• Supporting Licenses

• Managing Devices

• Managing Usage

• Managing Accounts and Users

• Branding the End-User Portal
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Packaging Products

Packaging products is the process of creating product definitions that are used to generate licenses. 

Products are built up from features and feature bundles and linked to one or more license models to define how 
they can be used. Products can also be assembled into groups of products called suites. 

During the product packaging process, you create features, feature bundles, products, and suites, and when 
doing so specify upgrade, upsell, and other relationships between those products and suites to capture your 
overall product hierarchy within FlexNet Operations.

Note • Maintenances are special types of products. Maintenance products define maintenance or support plans 
that can be tied to regular products.

See the following sections for details about the tasks involved with the product packaging process: 

Table 2-1 • 

Topic Description

About Packaging 
Products

Discusses general product packaging concepts. This section also includes 
subtopics dedicated to trial product and download management concepts. 

• About Trial Products

• About Download Management: FlexNet Electronic Software Delivery 
Components

Working with Features Includes information about viewing, adding, and managing features. 

Working with Feature 
Bundles

Describes creating and managing feature bundles. 

Working with Products Discusses product creation and management. 

Working with Suites Explains how to build and manage a group of products. 
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About Packaging Products
In FlexNet Operations, you define your products as a collection of features that can be licensed and ordered as a 
set. This process of defining your products is referred to as product packaging. The product packaging process is 
highly flexible and many of the steps are particular to the licensing technology and models you support. Please 
first read the getting-started section specific to your licensing technology and follow the exercises there before 
packaging your products. 

Discussion of the product packaging process is divided into the following groups: 

• Product Packaging Concepts

• Example Product Definition

• Product Packaging Overview

• Before You Begin

• Product Packaging Wizard

For a discussion of trial products and how to make products available on the End-User Portal’s Trial Registration 
page, see the subtopic, About Trial Products.

For a discussion of download package and download file concepts, see the subtopic, About Download 
Management: FlexNet Electronic Software Delivery Components. 

Working with 
Maintenances

Discusses the use of maintenance products. 

Managing Part Numbers Discusses the optional use of part numbers to tie your products to your  accounting 
system. 

Managing Product Lines Discusses the optional use of product lines to help organize your products into 
groups. 

Managing Download 
Packages

Discusses how download packages are used, how they interact with products and 
files, and how they are rendered to End-User Portal users. 

Managing Download 
Files

Addresses adding and uploading of files, associating files with download packages, 
and other file management concepts and tasks. 

Managing License 
Agreements

Covers the creation and maintenance of licensing agreements and how they are 
related to download packages. 

Managing Producers Explains how to add producers in the Producer Portal and how producers are 
related to download packages.

Table 2-1 • 

Topic Description
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Product Packaging Concepts
In FlexNet Operations, a product represents a unit that can be ordered and licensed. The product hierarchy is 
designed to enable modularity and re-use, and to minimize duplication:

• A feature represents a licensable capability defined in a software application, and is the basic building block 
for a product. An example of a feature would be the Add function in a calculator, or the Print function in a 
word processing program.

• A feature bundle is an aggregation of features. Feature bundles are primarily of interest to Product Managers 
because they facilitate modularity and easy re-use of features across products. In FlexNet Operations, you 
map features to feature bundles, and then to products. 

• A product is packaged from individual features or feature bundles and is associated with one or more license 
models. One or more part numbers can be assigned to a product. 

• A suite is packaged from individual products that are functionally complementary, and is associated with one 
or more license models. One or more part numbers can be assigned to a suite. 

• A maintenance represents the rights to get updates and upgrades to a product. A maintenance can be 
related to one or more products. One or more part numbers can be assigned to a maintenance product. 

To help keep the number of product definitions as low as possible, values of many product attributes can be set 
at one of several times in the license lifecycle.

Note • Producers who use FlexNet Operations and FlexNet Electronic Software Delivery (requires the Software 
Delivery module) can also create download package, files, and agreements. For more information, see About 
Download Management and FlexNet Electronic Software Delivery.

Example Product Definition
Consider an application called Sample App 3000. Its features might include, for example:

• Print

• Convert

• Save

The features of your program correspond to features expressed in your license rights as defined by product 
management. One common practice is to prefix feature names with the product name, as in:

• SampleApp.print

• SampleApp.convert

• SampleApp.save

Another common practice is to define a feature that represents the entire application, checking out this feature 
when the application initializes, and checking it back in when the application exits. Such a feature might be called 
SampleApp.primary.
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Product Packaging Overview
Once you have created and deployed your license technology and license models, you can begin defining your 
products. Packaging a product is the process of creating a product definition that is used to create entitlements 
and to generate licenses. The product packaging process includes 

• Creating one or more transaction keys (if you use any trusted license models) 

• Creating a product line (required for producers who use FlexNet Operations for software delivery) 

• Creating the hierarchy of features, feature bundles, products, and suites 

• Creating maintenance products 

• Associating license models (and transaction keys) with products and suites 

• Associating part numbers with products and suites (optional) 

• Relating products to other products, suites, or maintenance (optional) 

• Associating product lines with products and suites (optional)

Also, in the interface, an optional, four-step product packaging wizard can lead you through creating features, 
features bundles, products, and suites. (See Product Packaging Wizard.) License models and optionally, part 
numbers and product lines, are associated with a product in the flow of the wizard, but they must be created 
outside the steps of the wizard. Creating maintenance products also occurs outside the steps of the wizard. 

Before You Begin
Before you start the product packaging process, it is important that you deploy your license technology and at 
least one license model. 

It is also valuable to carefully consider the best way to define and combine your features and products and the 
best way to license your products. 

Please read the FlexNet Operations getting started section particular to your license technology before you 
package your products. 

Product Packaging Wizard
The product packaging wizard is a four-step flow that walks users through pages for 

1. Adding features

2. Adding feature bundles

3. Adding products

4. Adding suites

Each step in the product packaging wizard includes a number of sub-steps that are contained in an entity-
specific sub-wizard. Even so, the product packaging wizard includes most, but not all, product packaging 
activities. Some license technology-specific or optional activities are not part of the wizard, but the pages for 
those activities can be accessed directly from the Products menu. For example, when the product lines feature is 
enabled, you can map your product to a product line as part of the product sub-wizard; creating the product lines, 
though, must be done separately by clicking Products > Product Lines and then following the instructions in 
Managing Product Lines. 

The steps and all the tasks each step contains are shown at the bottom of the Package Products page. 
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Tip • To open the Package Products page, click Products > Products.

Move from one step to the other using the Next button at the bottom of each page.

About Trial Products
Producers can provide free trial registrations for their products. Trial registration allows your customers to 
acquire temporary license rights to designated products by providing their email address and, optionally, other 
contact information in the End-User Portal. 

How Does It Work?
To support free trials, producers create a custom content page to be a destination where trial users can find your 
trial products and opt-in to try out those products. This trial registration page shows a list of products that have 
been made available for trials and requests (at minimum) an email address from the trial user. (Other contact 
information can also be gathered but is not required, by FlexNet Operations, for the trial registration process.) 

After a user selects a trial product, supplies the required contact information, and clicks Complete, the End-User 
Portal sends them an email message with their End-User Portal login information and entitles them to a trial of 
the selected product. (The trial period is determined by the product’s license model.)

Steps for Supporting Trial Registrations
Supporting trial registrations requires planning and preparation. Producers who want to support trial 
registrations must perform the following steps to make their products available to trial users: 

• Create and deploy the products and license models you want to offer for trial registrations. These can be 
existing products and license models, but the trial period is based on the expiration in the license model.

• Map part numbers—with Available for Trial—to these product/license model combinations. 

• Create custom content for the Trial Registration page using the TrialRegistration template. This custom 
content is customizable and brand-able. When published, it shows the trial products and contact information 
input controls. See About Product Trial Registration Support for details about creating the Trial Registration 
page.

• Optionally create a trial registration-specific variation of the Welcome Email for End Users email template. 
The Trial Registration custom content page identifies the template variation to use. Without alterations, trial 
users receive a message based on the default Welcome Email for End Users template.  

• Link prospective trial customers to your Trial Registration page using the Custom Content ID value of your 
trial registration page.

About Download Management: FlexNet Electronic 
Software Delivery Components

Producers who use FlexNet Operations and FlexNet Electronic Software Delivery may also create download 
packages and add files for their users and channel partners to download from the End-User Portal. When 
packaging products, these producers also create the following: 
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• Download packages

• Download files

• License agreements

• Producers

• Product lines

The Products menu includes links for creating and managing these items. 

Tip • Some attributes of these electronic software delivery components are localizable in the Producer Portal. 
Localizable attributes are easy to identify because have show a Show Languages button. When editing a 
download package or file, click Show Languages to show the fields in which you provide localized values. 

For more information about download management, see About Download Management and FlexNet Electronic 
Software Delivery.

For more about software-delivery management tasks, see Managing Download Packages, Managing Download 
Files, Managing License Agreements, and Managing Producers.

Working with Features
This section explains what a feature is and what role it plays in the product packaging and licensing process. The 
following topics are included:

About Features
A feature represents a licensable capability defined in a software application, and is the basic building block for a 
product. A feature could represent any of the following: 

• a product consisting of one or more components 

• a specific version of a product 

• a part of a product

• one or more pieces of data (restricted through the access routines) 

Table 2-2 • 

Topic Description

About Features Discusses what features are and how they are used in FlexNet Operations.

Viewing Features Provides basic information about viewing, creating, deleting, printing, and changing 
the state of a feature.

Creating a Feature Covers the feature creation process in greater detail.

Reviewing Features Describes how to review a feature.
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An example of a feature would be the Add function in a calculator, or the Print function in a word processing 
program.

Viewing Features 
Features can be viewed on the Feature page. 

Task To open the Feature page

• Click Products > Features.

The Feature page automatically displays recently accessed feature bundles, if applicable. To view all features, 
select Features from the Search For choice list, and click the Simple Search button. You can also search for 
feature based on specific criteria. The table below describes some of the actions you can perform from the 
Feature page.

Creating a Feature
You can create a new feature in the Producer Portal from the Feature page of the Package Products pages.

Tip • Save time by starting with a copy of an existing feature. Select the feature you want to copy, click Copy, type 
a new feature name, make any other necessary changes, and save the new feature. This approach can save time 
and reduce the chance for errors.

Table 2-3 • View Features Capabilities

Capability Description

Add a new feature from 
scratch

To add a new feature, click Add New Feature. (See Creating a Feature.)

Make a new feature from a 
copy of an existing feature 

To copy a feature, select exactly one feature and click the Copy button. Then, 
follow the guidelines in Creating a Feature.

Delete a feature To delete a feature, select one or more features and click the Delete button. 

Note • Deployed features and features used in device series cannot be deleted.

Change the state of a feature To change the state of one or more features, select the features, click the 
Change State choice list, and select a state. Features can be in one of the 
following states: draft or deployed. A feature is created and can be edited in 
the draft state. When a feature bundle or product is deployed, all the features it 
contains are also deployed.

Print a feature To print a feature, select one or more features and click the Print button. 
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Task To create a feature

1. Click Products > Features. This link opens the Feature page.

2. Click Add New Feature. 

3. Provide values for the following fields: 

Table 2-4 • Feature Creation Fields

Field Description

Feature Name  Name to uniquely identify the feature. The name can contain 30 characters or 
less when using FlexNet Licensing technology, or 64 characters or less for 
other licensing technologies. The name cannot contain spaces. The characters 
can be ASCII characters, numbers, periods, underscores, or hyphens. 

Important • For FlexNet Publisher, the supported character set is restricted to 
lowercase alphabet (a-z), uppercase alphabet (A-Z), digits (0-9), and 
underscore (_). Other than for legacy applications still in production, the 
hyphen (-) is no longer supported. 

Version Format Type  Select a Fixed or Date-Based version format. 

See Creating a FlexNet Publisher Licensing Toolkit License Generator (VCG) 
Configuration for more information about this property. 

Version  If a Fixed version format is selected, enter the latest (highest-numbered) 
version of this feature that is supported by a generated license certificate. For 
FlexNet Licensing technology, the version consists of numbers and at most one 
decimal point, with a ten character maximum, for example, 1 or 1.5. For 
custom license technologies, this is a string with a maximum length of 64 
characters.

Description Describe the characteristics of this feature that make it unique. 

Units For FlexNet Usage Management users, Units specifies the units to be used for 
usage reporting. For example, if your usage-capture clients are capturing 
usage of data, you may want to label the reported counts as bytes or kilobytes 
or gigabytes.

Units and Scale (below) work together to describe what the metered feature is 
counting.
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Scale For FlexNet Usage Management users, Scale is the feature scale. It represents 
how much is a unit for usage reporting purposes. For example, if your usage-
capture clients are capturing usage of data in bytes but you want to report 
usage in kilobytes, enter 1024 for Scale. 

Units (above) and Scale work together to describe what the metered feature is 
counting.

State  A feature can be in one of two states—Draft or Deployed. 

• Draft: A feature is created as a draft that can be modified or deleted. Both 
draft and deployed features can be added to a feature bundle or a product 
in a draft state. 

• Deployed: A deployed cannot be modified or deleted. If a feature bundle or 
product is deployed, all the draft features it contains are also deployed. 
After a feature is deployed to use in production, it cannot be deleted or 
modified.

New features start out in a Draft state. A feature’s state cannot be changed on 
the Create a Feature page. To change a feature’s state after it has been 
created, use the Change State control on the Feature page (Products > 
Features). 

Vendor String  Used to override for specifically this feature, a vendor string defined in a 
license model. In addition to accepting an explicitly specified string, this field 
can accept, enclosed in curly braces, one of several pre-defined substitution 
variables or the name of a custom attribute. Use of this field is controlled by the 
FlexNet Operations license, and a user must be assigned a role that includes 
the Set Feature Override permission. 

Notice    Used to override for this feature, a notice string defined in a license model. In 
addition to accepting an explicitly specified string, this field can accept, 
enclosed in curly braces, one of several pre-defined substitution variables or 
the name of a custom attribute. Use of this field is controlled by the FlexNet 
Operations license, and a user must be assigned a role that includes the Set 
Feature Override permission. 

Serial Number    Used to override for this feature, a serial number defined in a license model. In 
addition to accepting an explicitly specified string, this field can accept, 
enclosed in curly braces, one of several pre-defined substitution variables or 
the name of a custom attribute. Use of this field is controlled by the FlexNet 
Operations license, and a user must be assigned a role that includes the Set 
Feature Override permission. 

Table 2-4 • Feature Creation Fields

Field Description
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Counted Determines whether a feature is counted. Choose from 

• Yes

• No

• Do Not Override

Choosing a value, other than Do Not Override, overrides the value set in the 
license model.

Reusable Determines whether this feature is reusable (only applies to metered features). 
Choose from 

• Yes

• No

• Do Not Override

Choosing a value, other than Do Not Override, overrides the value set in the 
license model.

Table 2-4 • Feature Creation Fields

Field Description
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Note • If necessary, click the Reset button to reset all the feature fields.

4. Complete the feature creation process by clicking either Save, Next, or Add New Feature. 

• Click Save to save the feature. 

• Click Next to save the feature and show the Feature Bundles page.

• Click Add New Feature to save the feature and start to create another feature.

Tip • After a feature has been saved, the history of its state changes can be viewed by clicking the View History 
button. 

Client Uniqueness This property allows you to specify which combination of unique identifiers 
defines a group. This capability allows multiple members of same group can 
check out this feature and the checkout count is incremented by 1 only. This 
property must be used with counted licenses only. 

For example, if you set this to Group Mask = User, the user can check the 
feature out as many times as they are required to and they only increment the 
checkout count by 1. The first time the user checks out the feature, the 
checkout count is incremented by 1, but subsequent checkouts of that feature 
on different machines do not affect the checkout count. 

As another example, if you set this Group Mask = Host, then when the first user 
checks out a feature from Machine A, the checkout count is incremented by 1. 
Subsequent checkouts by different users from that same machine do not affect 
the checkout count.

This configuration overrides the value set for the FlexNet license model. 
Choices include: 

• Do Not Override (default): Do not override the configuration defined for the 
associated license model.

• Group Mask (User, Host, Display, Vendor Defined): Define the combination 
of criteria that create a unique group.

• None: Each checkout request is uniquely counted. 

These fields are only valid for FLEX licenses. See also Creating a License Model.

Note • For users of the FlexNet Publisher Licensing Toolkit, consult the 
documentation on the DUP_GROUP keyword.

Table 2-4 • Feature Creation Fields

Field Description
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Reviewing Features
After you create features, you can review the features that have been recently created and perform the same 
operations on them as you can when viewing features. 

Working with Feature Bundles
Feature bundles are intended to simplify the packaging process. For example, suppose you provide multiple 
applications, and every application contains common library, help, and graphics features. Instead of manually 
adding all three features to each of your products, you can create a feature bundle (perhaps giving it the name 
sampleapp.common) containing the three features, and then add the feature bundle to each product.

About Feature Bundles
A feature bundle is a collection of features. Feature bundles are primarily of interest to product managers 
because they facilitate modularity and easy reuse of features across products. In FlexNet Operations, you map 
features to feature bundles, and then to products.

Viewing Feature Bundles
Feature bundles can be viewed on the Feature Bundle page. 

Task To open the Feature Bundle page

• Click Products > Feature Bundles.

Table 2-5 • 

Topic Description

About Feature Bundles Describes feature bundles and their purpose. 

Viewing Feature 
Bundles

Briefly discusses how to view, create, delete, print, and change the state of a 
feature bundle. 

Creating a Feature 
Bundle

Covers the feature bundle creation process in detail.

Reviewing Feature 
Bundles

Describes the review step in the feature bundle creation process.

Deploying a Feature 
Bundle

Describes how to deploy a feature bundle.
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The Feature Bundle page automatically displays recently accessed feature bundles. To view all feature bundles, 
select Feature Bundles from the Search For choice list, and click the Simple Search button. You can also search 
for feature bundles based on specific criteria. The table below describes some of the actions you can perform 
from the Feature Bundles page.

Creating a Feature Bundle
You can create a new feature bundle in the Producer Portal from the Feature Bundle page of the Package 
Products pages.

Tip • Save time by starting with a copy of an existing feature bundle. Select the feature bundle you want to copy, 
click Copy, type a new feature bundle name, make any other necessary changes, and save the new feature 
bundle. This approach can save time and reduce the chance for errors.

Task To create a feature bundle

1. Click Products > Feature Bundles. This link opens the Feature Bundle page.

2. Click Add New Feature Bundle. 

Table 2-6 • Viewing Feature Bundles Capabilities

Capability Description

Add a new feature bundle 
from scratch

To add a new feature bundle, click Add New Feature Bundle. (See Creating a 
Feature Bundle.)

Make a new feature bundle 
from a copy of an existing 
feature bundle 

To copy a feature bundle, select exactly one feature bundle and click the Copy 
button. Then, follow the guidelines in Creating a Feature Bundle. 

Delete a feature bundle To delete a feature bundle, select one or more feature bundles and click the 
Delete button.

Note • Deployed feature bundles cannot be deleted.

Change the state of a feature 
bundle 

Feature bundles can be in one of the following states: draft or deployed.

Print a feature bundle To print a feature bundle, select one or more feature bundles and click the 
Print button.
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3. Provide values for the following fields: 

4. To add features to the feature bundle, click the Add Features button. A pop-up window appears in which you 
can search for and select one or more of the Available Features. Note that the list of features may be large 
enough to appear on multiple pages in the pop-up window. 

a. Select the features you want to add.

b. Click the right arrow to move those features to the Selected Features list. 

c. When the Selected Features list is complete, click the Add button to add the features to the feature 
bundle. 

Note • To remove one or more features from the list of features in the feature bundle, select the features and 
click the Remove Features button. 

5. On the Create a Feature Bundle page, if necessary, modify the Quantity to change the count of the feature in 
the feature bundle. 

For example, say the count of a Feature A is 3 in feature bundle FB1. When one unit of FB1 is added to a 
product, a license generated for the product contains 3 counts of Feature A. 

6. Complete the feature bundle by clicking Save, Next, or Add New Feature Bundle. 

• Click Save to save the feature bundle.

• Click Next to save the feature bundle and show the Products page.

• Click Add New Feature Bundle to save the feature bundle and start to create another feature bundle. 

Note • If necessary, click the Reset button to reset all the feature bundle fields.

Table 2-7 • Feature Bundle Values

Value Description

Feature Bundle Name Name to uniquely identify the feature bundle. The name can contain spaces. 

Description Describe the characteristics of this feature bundle that make it unique. 

State A feature bundle can be in one of two states: 

• Draft: A feature bundle is created as a draft that can be modified or 
deleted; draft feature bundles can contain draft or deployed features. A 
draft or deployed feature bundle can be added to a product in the draft 
state. 

• Deployed: If a product is deployed, all the draft features and feature 
bundles it contains are also deployed. After a feature bundle is deployed to 
use in production, it cannot be deleted or modified.
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Tip • After a feature bundle has been saved, you can view the history of its state changes by clicking the View 
History button. 

Reviewing Feature Bundles
After you create feature bundles, you can review the feature bundles that have been recently created and perform 
the same operations on them as you can when viewing feature bundles. 

Deploying a Feature Bundle
Feature bundles can be deployed from the Feature Bundle page (Products > Feature Bundles). 

A feature bundle is created in the Draft state. Feature bundles in the Draft state can be edited. Once a feature 
bundle is deployed, it can no longer be altered. When a feature bundle is deployed, all the features it contains are 
also deployed. Likewise, when a product is deployed, all the features and features bundles it contains are also 
deployed. 

Task To deploy one or more feature bundles

1. On the Feature Bundle page, select the feature bundles to deploy. 

2. Click Change State > Deploy, and confirm your choice by clicking OK. The Deploy Feature Bundles page 
displays the list of feature bundles, and the undeployed features they contain that will deployed. 

3. Click the Deploy button to deploy the feature bundles and all their features. 

Working with Products
A product is packaged from individual features or feature bundles and is associated with one or more license 
models. Before you create a product, it is important to create its features and to create the license model used for 
it. 

Product is also used to refer collectively to any of the entities that can be ordered: a product, a suite, or 
maintenance. 

Table 2-8 • 

Task Description

About Products Discusses products and product creation concepts.

Viewing Products Explains how to view and search for products on the Package Products page. 

Creating a Product Describes how create a product—either by creating it from scratch or starting with a 
copy of an existing product.
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About Products
Products are a collection of features linked to a license model. They represent the basic orderable unit in FlexNet 
Operations. The figure below depicts the relationships among products, features, license models, product lines, 
and part numbers.

Adding Features or 
Feature Bundles to a 
Product

Shows how to add existing features or feature bundles to a product.

Linking License Models 
to a Product

Discusses how to link one or more license models to a product. A product must be 
linked to at least one license model before a license can be generated for that 
product. 

Mapping a Product to a 
Part Number

Discusses how to map products to part numbers.

Relating Products to 
Other Products

Explains how to create relationships between products. Product relationships are 
typically used to facilitate upgrade and upsell operations. 

Mapping a Product to a 
Product Line

Describes how to assign products to product lines. Product lines can be used to 
define access rights to product information as well as for search and reporting 
purposes.

Reviewing Products Describes the review step in the product creation process. 

Deploying a Product Discusses how to change a product’s state from Draft (initial state for new 
products) to Deployed (available for entitlements). 

Reviewing New Product 
Hierarchy

Explains how to review the features, feature bundles, and products that comprise 
the product hierarchy.

Table 2-8 • 

Task Description
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Important • Prior to creating a product, you must deploy your license technology and at least one license model. 
You must also create the features that will make up your product. 

A product’s attributes vary by the licensing you use and by your needs. There are a number of attributes that are 
particular to one license technology. There are also a number of optional FlexNet Operations features, such as 
part numbers and product relationships, that are included in the product creation steps. 

Adding a product is the third step in the four-step product packaging wizard. The product creation steps include 

• Set product attributes. 

• Add features and feature bundles. 

• Link license models. 

• Map part numbers (optional). 

• Specify product relationships (optional). 

• Map product lines (see note, below).

• Review product creation. 

Note • Product lines are optional for most producers but required for producers who use FlexNet Operations for 
electronic software delivery. Product lines tie products to download packages, files, license agreements, and 
producers. See Managing Product Lines and About Download Management and FlexNet Electronic Software 
Delivery for more information.



Chapter 2 Packaging Products
Working with Products

54 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Viewing Products  
This Package Products page automatically displays recently accessed products, if applicable. 

To view all products, select Products from the Search For choice list, and click the Simple Search button. (Empty 
searches match all products.) You can also search for products based on specific criteria by 

• Specifying some particular value in the search criteria

• Changing the Search For setting to a more specific choice, like Products with Part Number

• Clicking Advanced Search to specify multiple product attributes as search criteria

From the Package Products page, you can also perform the following tasks:

Creating a Product
There are several ways to navigate to the page where a new product is created. When creating a new product 
from the Package Products page, you can either start a new product from scratch or create a new product from a 
copy of another product. 

Task To create a new product

1. Click Products > Products. This opens the Package Products page.

2. Click the Add a new product button. 

Table 2-9 • Viewing Products Options

Capability Description

Add a new product from scratch To add a new product, click Add New Product. For details, see Creating a 
Product.

Make a new product from a 
copy of an existing product 

To copy a product, select exactly one product and click Copy. Follow the 
guidelines to add a new product. 

Edit a product To edit a product, click its name. The product is opened in the wizard. 

Delete a product To delete a product, select one or more products and click the Delete 
button. 

Change the state of a product Products can be in one of the following states: Draft, Deployed, Inactive, or 
Obsolete.

Print a product To print a product, select one or more products and click the Print button.

Export a product Products can be exported as .jar files for importing into another instance of 
FlexNet Operations. For details about the export process, see Importing and 
Exporting Entities. 
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Follow the steps below to create the product.

Task To copy an existing product

1. Click Products > Products. This opens the Package Products page.

2. Search for a product to copy. 

3. Select the product and click the Copy button. 

Follow the steps below to create the product.

Note • Required fields are indicated with a red asterisk. 

Task To create the new product

Provide values for the following fields: 

Table 2-10 • 

Field Description

Product Name Name to uniquely identify this product. The name can contain spaces. 

Description The characteristics of this product that make it unique. The description can be 
edited at any time.

Version A string that can contain any characters up to a maximum of 64, for example, 1.2.3 
or SP1. 
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State A product can be in one of four states: draft, deployed, inactive, or obsolete. 

• Draft: A product is created as a draft that can be modified or deleted; draft 
products can contain draft or deployed features and feature bundles. Draft or 
deployed products can be added to a suite in the draft state. 

• Deployed: If the suite is deployed, all the draft features, feature bundles, and 
products it contains are also deployed. After a product is deployed to use in 
production, it cannot be deleted or modified, except to change the transaction 
key and to add or remove license models, part numbers, or relationships. A 
deployed product can be used to create an entitlement. 

• Inactive: If a product is made inactive, its features and feature bundles are not 
made inactive. An inactive product cannot be deleted or modified. An inactive 
product cannot be used to create an entitlement or to be the parent of a 
maintenance product, but an inactive product can be activated, upgraded, 
upsold, or renewed from an existing entitlement item. 

• Obsolete: Deployed and inactive products can be made obsolete. Obsolete 
products behave like inactive products, but can be deleted if they have no 
entitlements associated with them. 

Package For FlexNet licenses only, specify that this product is a package if you want to: 

• Provide a way of distributing one line for a license file that has a large number 
of features, which share most of the same feature line arguments 

• License this product as a suite 

Even if a product is specified as a package, if a license model is specified for the 
product that does not support PACKAGEs (that is, Package Specification is None), 
the license model takes precedence and individual feature lines are generated. 

The count of unique features in a package must be the same. For example, if a 
feature bundle containing three counts of FeatureA and six counts of FeatureB is 
added to a product, then for that product to be licensed with a PACKAGE line, three 
more counts of FeatureA must be added to the product to make the count of 
FeatureA and FeatureB the same (six).

Package Name Name to uniquely identify the package: The name must contain 30 characters or 
less and cannot contain spaces. (The Package Name setting is only shown when 
Package is set to Yes.)

Package Version Format Select a Fixed or Date Based version format. See Creating a FlexNet Publisher 
Licensing Toolkit License Generator (VCG) Configuration for more information about 
this property. (The Package Version Format setting is only shown when Package is 
set to Yes.)

Table 2-10 • 

Field Description
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Package Version If a Fixed version format is selected, enter the latest (highest-numbered) version of 
this package that is supported by a generated license certificate. The version 
consists of numbers and at most one decimal point, with a ten character maximum, 
for example, 1 or 1.5. (The Package Version setting is only shown when Package is 
set to Yes.)

License Technology The license technology with which this product is licensed. The license technology 
you choose affects the set of controls you see on the Create a Product page. If you 
choose FlexNet Licensing, the next control in the list is Can Be Used on a Device. If 
you choose a custom (non-FlexNet) license technology, the next control in the list is 
Host Type. 

Can Be Used on a Device Shown when you choose FlexNet Licensing as the license technology, this control 
allows the user to select usage models. 

Yes—displays a drop-down list of available usage models 

No—no usage models are displayed 

Host Type The appearance of the Host Type control depends upon the license technology you 
chose: 

• Shown as a drop-down list when you choose a custom (non-FlexNet) license 
technology, Host Type lists of host types defined for the license technology you 
specified. Choose one host type from the list.

• Shown as a collection of check boxes when you choose FlexNet Licensing as 
the license technology, Host Type shows a separate check box for each host 
type defined for FlexNet Licensing. Click the check boxes for the host types this 
product will support.

Table 2-10 • 

Field Description
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Usage Models The Usage Models attribute is available when you choose Yes for Can be Used on a 
Device.

Usage Models shows a drop-down list of possible usage models. These determine 
the statement interval and reset period for usage reports. (See About Usage 
Models.)

Important • Products using the same feature must be configured with the same 
usage model per account. For an account, the usage model that is specified for a 
product containing a specific feature will be the usage model that is used for 
subsequent entitlements or products containing that specific feature.

Example:

• Product A (feature f1) and product B (features f1 and f2)
• Account C is first entitled to product A (feature f1) with usage model Monthly 

Statements (No Reset)
• Account C is then entitled to product B (features f1 and f2) with usage model 

Monthly Statements (Reset Monthly)
• Account C will use usage model Monthly Statements (No Reset) for both 

products A and B because they both contain feature f1 which was included in 
the first entitlement.

If Account C was first entitled to product B (features f1 and f2) with usage model 
Monthly Statements (Reset Monthly), this usage model would be used for both 
products/entitlements for the account.

License Generator The license generator used to generate licenses for this product

Header Resource 
Bundle Key 

If you are creating a certificate-based license, this key allows you to identify certain 
text that appears as a comment at the beginning of the .lic file that is generated 
when you fulfill the license. 

The value entered here is the key portion of the key-value pair stored in the 
PublisherDefinedAttributesText_en.properties file. This properties file is 
packaged in the ops_install_dir\site\webapps\flexnet\WEB-INF\classes\ sub-
directory. The value in the PublisherDefinedAttributesText_en.properties for this 
key will be propagated to the .lic file. 

This field is hidden if the Allow license headers and trailers flag is disabled. 
Configure this flag in System > Configure > FlexNet Operations.

Header Text This is the value assigned to the key specified in the Header Resource Bundle Key 
field.  This field only displays the value; you cannot edit the value. 

The key-value pair relationship is defined using the 
PublisherDefinedAttributesText.properties file. The value can be edited in the 
PublisherDefinedAttributesText.properties file. 

Table 2-10 • 

Field Description
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Trailer Resource Bundle 
Key

If you are creating a certificate-based license, this key allows you to identify certain 
text that will appear as a comment at the end of the .lic file which is generated 
when you fulfill the license. This field is hidden if the Allow license headers and 
trailers flag is disabled. Configure this flag in System > Configure > FlexNet 
Operations.

The value entered here is the key portion of the key-value pair stored in the 
PublisherDefinedAttributesText.properties file. This properties file is packaged in 
the ops_install_dir\site\webapps\flexnet\WEB-INF\classes\ sub-directory. The 
value in the PublisherDefinedAttributesText.properties for this key will be 
propagated to the .lic file.

Trailer Text This is the value assigned to the key specified in the Trailer Resource Bundle Key 
field. This field only displays the value; you cannot edit the value. 

The key-value pair relationship is defined using the 
PublisherDefinedAttributesText.properties file. The value can be edited in the 
PublisherDefinedAttributesText.properties file. 

FNP Version The FNP Version check boxes allow you to specify the cross-version signature 
support required by your product. 

Cross-version signatures are required when the product must use the same license 
for product binaries built with different versions of the FlexNet Publisher Licensing 
Toolkit, if you want to add license keywords to the product license that are not 
supported by all the licensing toolkit versions with which your product binaries are 
built. 

Cross-version signatures permit versions of your product built with a license kit that 
predates the introduction of a keyword to run successfully using the same license 
and license server as the newer versions of your product that use that keyword. 
(However, they do not permit the older versions of your product to use the 
functionality of the newer keyword.) 

Select the FNP Version based on the older version of the toolkit used to build the 
product binaries. 

For example, if you are required to use the same license to support the 
SUPERSEDE_SIGN keyword in product binaries built with toolkit versions 11.5 (when 
SUPERSEDE_SIGN was introduced) and 11.0, select FNP Version 11.4.

For more information about choosing the FNP Version values and using cross-
version signatures, see FlexNet Publisher Versions for Cross-Version Signature 
Support. 

Allow Obsolete 
Fulfillment Download in 
Producer Portal

Permits or prohibits the download of obsolete (zero count) fulfillments from the 
Producer Portal. By default, licenses cannot be emailed or saved for obsolete 
fulfillments. Click Yes to permit the downloading of obsolete fulfillments from the 
Producer Portal. Click No to prohibit it.

Table 2-10 • 

Field Description
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Allow Obsolete 
Fulfillment Download in 
End-User Portal

Permits the download of obsolete fulfillments from the End-User Portal. By default, 
licenses cannot be emailed or saved for obsolete fulfillments. Click Yes to permit 
the downloading of obsolete fulfillments from the End-User Portal. Click No to 
prohibit it.

Start Date Only used for automatic upgrade jobs, the Start Date value defines the beginning of 
a date range for which this product qualifies as an upgrade-to product, based on 
the upgrade relationships as defined when the upgrade job runs. The date range 
defined by Start Date and End Date has no impact on manually generated upgrades 
nor on bulk operations.

Start Date is only available for products; it is not available for maintenance products 
nor for product suites.

End Date Only used for automatic upgrade jobs, the End Date value defines the end of the 
date range for which this product qualifies as an upgrade-to product, based on the 
upgrade relationships as defined when the upgrade job runs. The date range 
defined by Start Date and End Date has no impact on manually generated upgrades 
nor on bulk operations.

End Date is only available for products; it is not available for maintenance products 
nor for product suites.

Email Template to Use 
for Product Upgrade

Specify the variation of the Product Upgrade Job Email template to use when 
FlexNet Operations automatically creates upgrade lines as a result of running the 
Product Version Upgrade job. Producers can choose the default variation, another 
active variation, or none: 

• DEFAULT—FlexNet Operations uses the default variation of the Product 
Upgrade Job Email template for automatic upgrades to this product. 

• None—FlexNet Operations does not send emails for automatic upgrades to this 
product. 

• Another variation—FlexNet Operations uses the selected variation of the 
Product Upgrade Job Email template for automatic upgrades to this product. 
(Only active variations of the Product Upgrade Job Email template are available 
for selection. Draft variations are not shown.) 

When automatic upgrade emails are sent, FlexNet Operations sends the upgrade 
email to the end-customer contact address in the parent entitlement (if one is 
available). If no end-customer contact address exists, FlexNet Operations sends the 
upgrade email to any addresses in the Ship To Email field in the parent entitlement 
as well as to all channel partner contacts in the parent entitlement (if any). 

For information about the Product Upgrade Job Email template, see Email Template 
Types in About Email Templates. 

For information about the Product Version Upgrade job, see FlexNet Operations 
Alert Types.

Table 2-10 • 

Field Description
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Continue the product packaging process by adding features (recommended) on this page or moving on to link a 
license model to the product. Or you can save the product in its current state. 

• To add features, click Add Features or Add Feature Bundles. These buttons open a pop-up window for 
selecting features or feature bundles to add. See Adding Features or Feature Bundles to a Product for 
instructions. 

• To move on to link license models to this product, click Next. The Producer Portal shows the Link License 
Models to Product page. See Linking License Models to a Product for instructions. 

• To save the product in its current state, click Save.

FlexNet Publisher Versions for Cross-Version Signature Support
This topic applies to the product creation and suite creation process only for FLEXenabled applications that use a 
certificate license model administered via a license server. For such applications, it may be necessary to select 
one or more FlexNet Publisher Versions for cross-version signature support when you are creating the product or 
suite in FlexNet Operations. 

Who Needs Cross-Version Signature Support?
The purpose of a cross-version signature is to allow developers to use newer license keywords (such as 
SUPERSEDE_SIGN or TZ) without breaking the license for older versions of their product, when the older and 
newer versions of the product must use the same license. 

Normally, an application built with a particular version of the FlexNet Publisher Licensing Toolkit cannot 
authenticate a license that includes keywords introduced in a newer version of FlexNet Publisher. Cross-version 
licenses enable you to issue license files containing new licensing keywords to customers who will continue to 
use older versions of your FLEXenabled application alongside newer versions of your application.

When a FLEXenabled application checks out a feature from a license server, it authenticates the information in 
the feature line against the signature. Typically, it must recognize all keywords present in the feature line in order 
to authenticate this information. Cross-version signatures allow the older application to ignore the newer 
keywords. When an older FLEXenabled application authenticates the feature line, it ignores the newer keyword 
and uses the FlexNet Publisher version-specific signature.

Determining which FNP Version Values are Required
The table, below, cross-references the keyword with the version of the FlexNet Publisher Licensing Toolkit client 
libraries your FLEXenabled application uses. Where a cross-version signature can be used, the table shows the 
correct FlexNet Publisher Version value. (Empty cells mean no cross-version signature is necessary.) For 
example, to use the VM_PLATFORMS keyword with a FlexEnabled application that uses toolkit version 11.0, use 11.4 
for the FlexNet Publisher Version value.

Table 2-11 • FlexNet Publisher Versions for Cross-Version Keyword Support 

Keyword

Toolkit Version in the FlexEnabled Application

7.1-7.2 8.0 8.1-8.3 8.4
9.0-
10.8.n

11.0-
11.4.1

11.5-
11.6.1

BORROW 7.1
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Keyword Support in Deployed License Servers
When publishers choose to support the newer keywords with the same license and within the same environments 
used by prior versions of the same product or suite, they must also ship updated license servers (or vendor 
daemons) to their customers. License servers built with toolkit versions prior to the version in which a keyword 
was introduced cannot understand the keyword. (Product binaries are not required to be changed. The older 
products are still able to check-out/check-in licenses from a FlexNet Publisher license server.) 

Adding Features or Feature Bundles to a Product  
Products are collections of features. Use the controls on the Create a Product page to add features and feature 
bundles to a product.

Task To add a feature or feature bundles to a product

1. A pop up window appears in which you can search for and select one or more of the Available Features/
Feature Bundles. Note that the list may be large enough to appear on multiple pages in the pop-up window. 

2. Click the right arrow to move those features to the Selected Features/Feature Bundles list. 

3. When the list is complete, click the Add button to add the features or feature bundles to the product. 

4. On the Create a Product page, if necessary, modify the Quantity to change the count of the feature or feature 
bundle in the product.

• For example, say the count of Feature A is 3 in feature bundle FB1. When 2 units of FB1 are added to a 
product, a license generated for the product contains 6 counts of Feature A. 

• To remove one or more features or feature bundles from the product, select the features or feature 
bundles and click the Remove Features or Feature Bundles button. Click the Reset button to reset all the 
product fields. 

COMPOSITE 7.1 8.0 8.1

FLOAT_OK 7.1

SUITE_RESERVED 7.1 8.0

SUPERSEDE_SIGN 7.1 8.0 8.1 8.4 10.8 11.4

TZ 7.1 8.0 8.1 8.4 10.8 11.4 11.6

VM_PLATFORMS 7.1 8.0 8.1 8.4 10.8 11.4 11.6

Table 2-11 • FlexNet Publisher Versions for Cross-Version Keyword Support  (cont.)

Keyword

Toolkit Version in the FlexEnabled Application

7.1-7.2 8.0 8.1-8.3 8.4
9.0-
10.8.n

11.0-
11.4.1

11.5-
11.6.1
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5. On the Create a Product page, click the Save button to save the product or click the Add New Product button 
to save the product and start to create another product. 

Note • After a product has been saved, the history of its state change can be viewed by clicking the View 
History button. 

6. Click the Next button to link license models to a product. 

Linking License Models to a Product  
Before a license can be generated for a product, the product must be associated with one or more license 
models.  Only license models linked to a product can be used in an entitlement for the product.

Task To link a license model with a product

1. Select a product.

2. After the product is selected, click the Link License Models button. This button opens the Link License 
Models page in a pop-up window. License models can be added or removed from draft or deployed 
products. 

a. In the Link License Models pop-up window, select one or more license models from the Available 
License Models list. Note that the list of license models may be large enough to appear on multiple 
pages in the pop-up window. 

b. Click the right arrow to move selected license models to the Selected License Models list. 

c. When the Selected License Models list is complete, click Add. This button associates the selected 
license models with the specified product and closes the pop-up window.

3. If you selected a trusted license model, specify Transaction Keys; otherwise, skip to the next step. Use the 
Default and Virtual controls to identify one default transaction key or one virtualization-aware transaction 
key, or both a default transaction key and a virtualization-aware transaction key.

4. Click the Save button to save the association of license models with the product. 

5. Click the Next button to map a product to a part number. 

Table 2-12 • Linking a License Model with a Product

Item Description

Product or Suite Name of the product or suite to associate with one or more license models: 

• If you arrived at this page by clicking through the product packaging 
wizard, a name is loaded automatically into the Product or Suite field. 

• Otherwise, click the Search button to open a pop-up window in which you 
can search for the product or suite to associate with license models. 

• Alternatively, type the name of the product or suite into the Product or 
Suite field.
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Note • On the Link License Models to Product page, click the Reset button to reset the linked license models. To 
remove the link between selected license models and this product, select those license models and click the 
Remove License Models button.

Mapping a Product to a Part Number  
A product can be mapped to one or more part numbers. Part numbers are optional and are selected from a group 
of unassigned part numbers that have been imported into FlexNet Operations. 

A part number can also be mapped to a particular license model linked with a product. When a part number is 
mapped to a license model, only that license model can be used in the entitlement. 

Task To map a product to a part number

1. Select a product. 

2. After the product is selected, click the Map to Part Numbers button. 

a. A pop-up window appears in which you can search for and select one or more of the Available Part 
Numbers. Note that the list of part numbers may be large enough to appear on multiple pages in the 
pop-up window. 

b. Click the right arrow to move those part numbers to the Selected Part Numbers list. 

c. When the Selected Part Numbers list is complete, click the Add button to map the part numbers to the 
product. 

3. If you want to map this part number to a specific license model that is already linked with this product, select 
that license model. This means that if the part number is used to specify a product in an entitlement, only this 
license model can be used. 

• Click the Reset button to reset the mapped part numbers. To remove the link between selected part 
numbers and this product, select those part numbers and click the Remove Part Numbers button.

4. Click Save to save the mapping of part numbers to the product. 

5. Click Next to relate a product to other products. 

Table 2-13 • Mapping a Product to a Part Number

Item Description

Product, Suite, or 
Maintenance 

Name of the product, suite, or maintenance to map to one or more unassigned 
part numbers:

• If you arrived at this page by clicking through the product packaging 
wizard, a name is loaded automatically into the Product, Suite, or 
Maintenance field. 

• Otherwise, click the Search button to open a pop-up window in which you 
can search for the product, suite, or maintenance to map to part numbers.
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Relating Products to Other Products  
A product can be related to one or more products, including itself. To use the upgrade and upsell operations on 
entitlement line items, upgrade and upsell relationships must be defined. Demo and production relationships 
between products can also be defined, and demo relationships can be used to upgrade entitlements. Products 
can be related in draft or deployed states. 

Tip • Upgrade relationships are essential for the automatic creation of upgrade line items by the Product Version 
Upgrade job. See FlexNet Operations Alert Types.

Task To relate products to other products

1. Select a product.

2. After the product is selected, navigate to the Relate to Different Products page. 

3. On the Relate to Different Products page, click Select Related Products. The Producer Portal shows the 
Select Product page in a pop-up window. There, you can search for and select one or more available 
products to relate to the current product. 

Note • The list of products may be large enough to span multiple pages in the pop-up window. You can limit 
the number of products using the search controls.

a. In the pop-up window, click one or more check boxes to select products for which you want to define 
product relationships.

b. When you have selected all related products, click OK. The Producer Portal adds the relationships and 
closes the pop-up window. 

4. On the Relate to Different Products page, specify the relationships between the current product and the 
related products. 

Table 2-14 • Relating Products to Other Products

Item Description

Product, Suite, or 
Maintenance 

Name of the product, suite, or maintenance to relate to a product, suite, or 
maintenance:

• If you arrived at this page by clicking through the product packaging 
wizard, a name is loaded automatically into the Product, Suite, or 
Maintenance field. 

• Otherwise, click the Search button to open a pop-up window in which you 
can search for the product, suite, or maintenance to specify product 
relationships.

• Alternatively, type the name of the product, suite, or maintenance into the 
Product, Suite, or Maintenance field.
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• Specify the relationships between the current product and the related products. 

If the current product is maintenance, the relationship Is Maintenance is chosen automatically. 

If the related product is maintenance, the relationship Has Maintenance is chosen automatically. 

Otherwise, choose from one of the following relationships: 

• Production Version Of

• Demo Of

• Upgrade From

• Upgrade To

• Upsell From

• Upsell To

The relationship setting defines how the related product is tied to the current product. For example, if 
the current product is a newly created version 2.0 of a product and, in the pop-up window, you selected 
version 1.0 of the same product, you would set the relationship to Upgrade From. If the current product 
is version 1.0 of the product and, in the pop-up window, you selected version 2.0 as a related product, 
you would set the relationship of Upgrade To. 

• Optionally specify a default license model for the Product Version Upgrade job. 

If, for the product relationship, you chose either Upgrade To or Upgrade From, the Producer Portal shows 
an Upgrade Default Model setting for the Upgrade-To product. 

The license model choices available in Upgrade Default Model depend on the license models linked to 
the Upgrade-To product. (The Upgrade-To product is the product to which users can upgrade; 
depending on whether you chose Upgrade To or Upgrade From for the relationship, the Upgrade-To 
product will be either the related product or the current product.) If only one license model is linked to 
the Upgrade-To product, the Producer Portal automatically selects that license model. If multiple license 
models are linked to the Upgrade-To product, Upgrade Default Model allows you to choose from those 
license models or None. 

• If you do not use the Product Version Upgrade job, leave Upgrade Default Model set to None. 

• If you do use the Product Version Upgrade job, set Upgrade Default Model to the default license 
model to use in upgrade entitlements created by that job. 

The default license model is only used in upgrade entitlements for the product relationship on which it is 
set. FlexNet Operations only applies the default license model if the related product is not linked to the 
license model on the entitlement to be upgraded. 

For more information about the Product Version Upgrade job, see More About the Product Version 
Upgrade Job under FlexNet Operations Alert Types. 

Tip • Click the Reset button to reset the product relationships. To remove the relationship between related 
products and the current product, select those related products and click the Remove Relationship button.

5. Click the Save button to save the relationship to the product. 

6. Click the Next button to review the products that have been recently created. 
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Mapping a Product to a Product Line
You can assign products to product lines, which can be used to group products for search and reporting 
purposes. In addition, product lines can be used to define access rights to product information for users.

Note • If product lines are disabled, follow the instructions in Managing Product Lines to enable product line 
functionality.

Task To assign a product to a product line

1. Locate the product for which you want to map a product line, and click the product to open its Create a 
Product page. 

2. On the Create a Product page, navigate to the Map Product to Product Line page. 

3. On the Map Product to Product Line page, specify the product line to be assigned to the product. Do one of 
the following: 

• Type the name of the product line.

• Click the Product Line search button to search for a product line to be assigned to the product. The 
Select Product Line for Product window opens. Select a product line, then click OK. On the Map Product 
to Product Line page, the selected product line appears in the Product Line field followed by any defined 
product line attributes. 

4. Click a product line, then click OK. On the Map Product to Product Line page, the selected product line 
appears in the Product Line field followed by any defined product line attributes. 

5. Enter values for any required product line attributes (marked with a red asterisk). Optionally, enter values for 
any optional attributes.

6. Click Save to save the mapping, or click Next to review recently created products.

To grant a user access to a product line, link the product line to the user’s account. See Linking Product Lines to 
User Accounts.

Reviewing Products  
After you create products, you can review the products that have been recently created and perform the same 
operations on them as you could when viewing products. 

Deploying a Product  
Before a product is deployed, all license models with which it has been linked must first be deployed. When a 
product is deployed, all the features and feature bundles it contains are also deployed. 
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Task To change the state of one or more products: 

1. Select the products. 

2. Click the Change State choice list, and select a state. Products can be in one of the following states: Draft, 
Deployed, Inactive, or Obsolete. A product is created and can be edited in the Draft state. 

3. If you choose Deploy, the Deploy Products page appears displaying the list of products and the undeployed 
feature bundles and undeployed features they contain that will deployed. Click the Deploy button to deploy 
the products and all of their feature bundles and features. 

Reviewing New Product Hierarchy
After creating products, you can review the features, feature bundles, and products you have created. To do this, 
select Show Product Definition under Step 3, Add Product, on the Package Products page.

Working with Suites
A suite is packaged from individual products that are functionally complementary, and is associated with one or 
more license models. One or more part numbers can be assigned to a suite.

Table 2-15 • 

Topic Description

Viewing Suites Briefly describes viewing, adding, deleting, printing, and changing the state of 
suites.

Creating a Suite Covers the suite creation process more thoroughly.

Adding Products to a 
Suite

Describes how to add products to a suite. 

Linking License Models 
to a Suite

Explains how to link a suite to one or more license models.

Mapping a Suite to a 
Part Number

Shows how to map a suite to one or more part numbers.

Relating Suites to Other 
Products

Shows how to define relationships between a suite and one or more different 
products. 

Deploying a Suite Explains how to change a suite’s state from Draft to Deployed. 
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Viewing Suites
This Package Products page automatically displays recently accessed suites, if applicable. To view all suites, 
select Suites from the Search For choice list, and click the Simple Search button. You can also search for suites 
based on specific criteria. 

From this page, you can:

Creating a Suite  
There are several ways to navigate to the page where a new suite is created. 

Task To create a new suite

1. Click Products > Suites. This opens the Package Products page.

2. Click the Add New Suite button. 

Follow the steps below to create the suite. 

Task To copy an existing suite

1. Click Products > Suites. This opens the Package Products page.

2. Search for a suite to copy. 

3. Select the suite and click the Copy button. 

Follow the steps below to create the suite.

Table 2-16 • Viewing Suites Capabilities

Capability Description

Add (create) a new 
suite from scratch

To add a new suite, click Create a Suite.

Make a new suite from 
a copy of an existing 
suite 

To copy a suite, select exactly one suite and click the Copy button. Follow the 
guidelines in Creating a Suite.

Delete a suite To delete a suite, select one or more suites and click the Delete button. 

Change the state of a 
suite 

Suites can be in one of the following states: Draft, Deployed, Inactive, or Obsolete.

Print a suite To print a suite, select one or more suites and click the Print button. 
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Note • Required fields are indicated with a red asterisk. 
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Task To create the new suite

1. Provide values for the following fields: 

Table 2-17 • New Suite Field

Field Description

Suite Name Name to uniquely identify this suite. The name can contain spaces. 

Description The characteristics of this suite that make it unique. 

Version A string that can contain any characters up to a maximum of 64, for example, 
1.2.3 or SP1.

State A suite can be in one of four states: draft, deployed, inactive, or obsolete. 

• Draft: A suite is created as a draft that can be modified or deleted; draft 
suites can contain draft or deployed products. 

• Deployed: If the suite is deployed, all the draft features, feature bundles, 
and products it contains are also deployed. After a suite is deployed to use 
in production, it cannot be deleted or modified, except to change the 
transaction key and to add or remove license models, part numbers, or 
relationships. A deployed suite can be used to create an entitlement. 

• Inactive: If a suite is made inactive, its products are not made inactive. An 
inactive suite cannot be deleted or modified. An inactive suite cannot be 
used to create an entitlement or to be the parent of a maintenance 
product, but an inactive product can be activated, upgraded, upsold, or 
renewed from an existing entitlement line item. 

• Obsolete: Deployed and inactive suites can be made obsolete. Obsolete 
suites behave like inactive suites, but can be deleted. 

Package Specify that this suite is a package if you want to: 

• Provide a way of distributing one line for a license file that has a large 
number of features, which share most of the same feature line arguments 

• License this suite as a suite 

Even if a suite is specified as a package, if a license model is specified for the 
suite that does not support PACKAGEs (that is, Package Specification is None), 
the license model takes precedence and individual feature lines are generated. 

The count of unique features in a package must be the same. For example, if a 
feature bundle containing 3 counts of FeatureA and 6 counts of FeatureB is 
added to a product, then for that product to be licensed with a PACKAGE line, 3 
more counts of FeatureA must be added to the product to make the count of 
FeatureA and FeatureB the same (6).
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Package Name Name to uniquely identify the package. The name must contain 30 characters 
or less and cannot contain spaces. 

Package Version Format Select a Fixed or Date Based version format. See Creating a FlexNet Publisher 
Licensing Toolkit License Generator (VCG) Configuration for more information 
about this property.

Package Version If a Fixed version format is selected, enter the version of the latest (highest-
numbered) version of this package that is supported by a generated license 
certificate. The version consists of numbers and at most one decimal point, 
with a ten character maximum, for example, 1 or 1.5. 

License Technology The license technology with which this suite is licensed. The license technology 
you choose affects the set of controls you see on the Create a Suite page. If you 
choose FlexNet Licensing, the next control in the list is Can Be Used on a 
Device. If you choose a custom (non-FlexNet) license technology, the next 
control in the list is Host Type. 

Can Be Used on a 
Device?

Shown when you choose FlexNet Licensing as the license technology, this 
control allows the user to select usage models. 

Yes—displays a drop-down list of available usage models 

No—no usage models are displayed 

Host Type The appearance of the Host Type control depends upon the license technology 
you chose: 

• Shown as a drop-down list when you choose a custom (non-FlexNet) 
license technology, Host Type lists of host types defined for the license 
technology you specified. Choose one host type from the list.

• Shown as a collection of check boxes when you choose FlexNet Licensing 
as the license technology, Host Type shows a separate check box for each 
host type defined for FlexNet Licensing. Select the check boxes for the 
host types this suite supports.

License Generator The license generator used to generate licenses for this product. 

Table 2-17 • New Suite Field

Field Description
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2. Click the Add Products button to continue creating the suite. 

Continue the product packaging process by adding products on this page or moving on to link a license model to 
the suite. Or you can save the product in its current state. 

• To add products, click Add Products. This button opens a pop-up window for selecting products to add to the 
suite. See Adding Products to a Suite for instructions. 

• To move on to link license models to this suite, click Next. The Producer Portal shows the Link License 
Models to Suite page. See Linking License Models to a Suite for instructions. 

• To save the suite in its current state, click Save.

FNP Version Only shown if the newer FlexNet Publisher keywords are used for renewals and 
upgrades. The FNP Version check boxes allow you to specify the cross-version 
signature support required by your suite. 

Cross-version signatures are required when the suite must use the same 
license to support the use of newer keywords (such as SUPERSEDE_SIGN and 
TZ) on binaries built with different versions of the FlexNet Publisher Licensing 
Toolkit. Cross-version signatures permit versions of your suite built with a 
license kit that predates the introduction of a keyword to be successfully 
activated under the same license and license server as the newer versions of 
your suite that use that keyword. (However, they do not permit the older 
versions of your suite to utilize the functionality of the newer keyword.) 

Select the FNP Version based on the older version of the toolkit used to build 
the suite binaries. 

For example, if you must use the same license to support the SUPERSEDE_SIGN 
keyword in binaries built with toolkit versions 11.5 (when SUPERSEDE_SIGN 
was introduced) and 11.0, select FNP Version 11.4.

For more information about choosing the FNP Version values and using cross-
version signatures, see FlexNet Publisher Versions for Cross-Version Signature 
Support.

Allow obsolete 
fulfillment download in 
Producer Portal?

Permits or prohibits the download of obsolete (zero count) fulfillments from the 
Producer Portal. By default, licenses cannot be emailed or saved for obsolete 
fulfillments. Click Yes to permit the downloading of obsolete fulfillments from 
the Producer Portal. Click No to prohibit it.

Allow obsolete 
fulfillment download in 
End-User Portal?

Permits the download of obsolete fulfillments from the End-User Portal. By 
default, licenses cannot be emailed or saved for obsolete fulfillments. Click Yes 
to permit the downloading of obsolete fulfillments from the End-User Portal. 
Click No to prohibit it.

Table 2-17 • New Suite Field

Field Description
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Adding Products to a Suite  
Use the controls on the Create a Suite page to add products to a suite.

Task To add products to a suite

1. In the Add Products pop-up window, select one or more check boxes to select products.

Note that the list of products may be large enough to appear on multiple pages in the pop-up window. 

2. When the list is complete, click the OK button to add the products to the suite. 

3. On the Create a Suite page, if necessary, modify the Quantity to change the count of the product in the suite. 

• To remove one or more products from the list of products in the suite, select the products and click the 
Remove Products button. Click the Reset button to reset all the suite fields. 

4. Continue the product packaging process by moving on to link a license model to the suite or saving the suite 
in its current state. 

• To move on to link license models to this suite, click Next. The Producer Portal shows the Link License 
Models to Suite page. See Linking License Models to a Suite for instructions. 

• To save the suite in its current state, click Save.

Note • After a suite has been saved, the history of its state change can be viewed by clicking the View History 
button.

Linking License Models to a Suite
Before a license can be generated for a suite, the suite must be associated with one or more license models. Only 
license models linked to a suite can be used in entitlements for the suite. 

Note • License models linked to products in a suite are ignored when an entitlement is created for the suite. 
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Task To associate a suite with a license model

1. Select a suite. 

2. After the suite is selected, click the Link License Models button. 

a. A pop-up window appears in which you can search for and select one or more of the Available License 
Models. Note that the list of license models may be large enough to appear on multiple pages in the 
pop-up window. 

b. Click the right arrow to move those license models to the Selected License Models list. 

c. When the Selected License Models list is complete, click the Add button to associate the license models 
with the suite. 

3. Continue with the product packaging process by saving the suite with its current settings or moving on to 
map part numbers. 

• Click the Save button to save the association with the suite.

• Click the Next button to map a suite to a part number. (See Mapping a Suite to a Part Number for 
instructions.)

Note • On the Link License Models to Suite page, click the Reset button to reset the linked license models. To 
remove the link between selected license models and this suite, select those license models and click the 
Remove License Models button. 

Mapping a Suite to a Part Number  
A suite can be mapped to one or more part numbers. Part numbers are optional and are selected from a group of 
unassigned part numbers that have been imported into FlexNet Operations. A part number can be mapped to a 
particular license model linked with a suite. 

Table 2-18 • Link License Models

Item Description

Suite Name of the suite to associate with one or more license models:

• If you arrived at this page by clicking through the product packaging 
wizard, a suite name is loaded automatically into the Suite field. 

• Otherwise, click the Search button to open a pop-up window in which you 
can search for the suite to associate with license models

• Alternatively, type the name of the suite into the Suite field.  
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Task To map a suite to a part number

1. Select a suite.

2. After the suite is selected, click the Map to Part Numbers button. 

a. A pop-up window appears in which you can search for and select one or more of the Available Part 
Numbers. Note that the list of part numbers may be large enough to appear on multiple pages in the 
pop-up window. 

b. Click the right arrow to move those part numbers to the Selected Part Numbers list. 

c. When the Selected Part Numbers list is complete, click the Add button to map the part number to the 
suite. 

3. If you want to map this part number to a specific license model that is already linked with this suite, select 
that license model. 

• Click the Reset button to reset the mapped part numbers. To remove the link between selected part 
numbers and this suite, select those part numbers, and click the Remove Part Numbers button.

4. Continue with the product packaging process by saving the suite in its current state or moving on to relate 
the suite to other products. 

• Click the Save button to save the mapping of part numbers to the suite. 

• Click the Next button to relate a suite to other products. (See Relating Suites to Other Products for 
instructions.)

Relating Suites to Other Products 
A suite can be related to one or more products, including itself. Products can be related in draft or deployed 
states. 

Tip • Upgrade relationships are essential for the automatic creation of upgrade line items by the Product Version 
Upgrade job. See FlexNet Operations Alert Types.

Table 2-19 • Mapping a Suite to a Part Number

Item Description

Suite Name of the suite to map to one or more unassigned part numbers:

• If you arrived at this page by clicking through the product packaging 
wizard, a suite name is loaded automatically into the Suite field. 

• Otherwise, click the Search button to open a pop-up window in which you 
can search for the suite to map to part numbers.

• Alternatively, type the name of the suite into the Suite field.
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Task To relate a suite to another product

1. Select a suite.

2. After the suite is selected, click the Select Related Products button. 

a. A pop-up window appears in which you can search for and select one or more of the available products. 
Note that the list of products may be large enough to appear on multiple pages in the pop-up window.

b. Select one or more check boxes to select suites. 

c. When the list is complete, click the OK button to add the related products.

d. On the Relate to Different Products page, select the relationship between the suite and the related 
product. Choose from one of the following relationships: Production Version Of, Demo Of, Upgrade 
From, Upgrade To, Upsell From, Upsell To. 

3. Continue by saving the suite in its current state or moving on to review the suite settings. 

• Click the Save button to save the relationship to the suite. 

• Click the Next button to review the suites that have been recently created.

Note • On the Relate to Different Products page, click the Reset button to reset the suite relationships. To remove 
the relationship between selected products and this suite, select those products and click the Remove 
Relationship button.

Deploying a Suite
Before a suite is deployed, all license models with which it has been linked must first be deployed. When a suite 
is deployed, all the products it contains are also deployed. 

Table 2-20 • Relating Suites to Other Products

Item Description

Suite Name of the suite to relate to a product, suite, or maintenance:

• If arrived at this page by clicking through the product packaging wizard, a 
name is loaded automatically into the Suite field. 

• Otherwise, click the Search button to open a pop-up window in which you 
can search for the suite to relate.

• Alternatively, type the name of the suite into the Suite field.
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Task To change the state of one or more suites

1. Select the suites. 

2. Click the Change State choice list, and select a state. Suites can be in one of the following states: Draft, 
Deployed, Inactive, or Obsolete.

3. If you choose Deploy, the Deploy Suites page appears displaying the list of suites and the undeployed 
products, feature bundles, and features they contain will also deployed. Click the Deploy button to deploy the 
suites and all of their products, feature bundles, and features. 

Working with Maintenances
A maintenance is an unlicensed product that represents additional rights that a customer can purchase. For 
example, maintenance may give the customer the right to technical support, upgrades, updates, or new 
platforms for the duration of maintenance. 

A maintenance product may be associated with one or more part numbers and can be related to one or more 
products or suites. 

Creating a Maintenance
You can create maintenances from the Producer Portal’s Administer menu.

Tip • To reset all the fields on the Create Maintenance page to their defaults at any time, click the Reset button. 

Table 2-21 • 

Topic Description

Creating a Maintenance Explains how to create a maintenance. 

Mapping a Maintenance 
to a Part Number

Shows how to map a maintenance to one or more part numbers. 

Relating Maintenance 
to Other Products

Describes how to define relationships between a maintenance and other products.
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Task To create a new maintenance product

1. Click Products > Create Maintenance. This opens the Create Maintenance page.

2. Provide values for the following fields. Required fields are indicated with a red asterisk. 

3. Complete the maintenance creation process by clicking Save, Add New Maintenance, or Next. 

• Click Save to save the maintenance and remain on the current page. 

• Click Add New Maintenance to save this maintenance and start to create another maintenance. 

• Click Next to map a maintenance to a part number. (See Mapping a Suite to a Part Number for 
instructions.)

A maintenance product is created as a draft that can be modified. After a maintenance product is deployed 
to use in production, it cannot be modified. 

Tip • After a maintenance product has been saved, the history of its state changes can be viewed by clicking the 
View History button. 

Table 2-22 • Creating Maintenance Fields

Field Description

Name Name of the maintenance

Version A string that can contain any characters up to a maximum of 64, for example, 
1.2.3 or SP1. 

State A maintenance product can be in one of four states: draft, deployed, inactive, 
or obsolete. 

• Draft: A maintenance product is created as a draft that can be modified or 
deleted. After a maintenance product is deployed to use in production, it 
cannot be deleted or modified, except to add or remove part numbers. 

• Deployed: A deployed maintenance product can be added to an 
entitlement. 

• Inactive: An inactive maintenance product cannot be deleted or modified. 
An inactive maintenance product cannot be added to an entitlement. 

• Obsolete: Deployed and inactive maintenance products can be made 
obsolete. Obsolete maintenance products behave like inactive 
maintenance products, but can be deleted. 

Description Describe the characteristics of this maintenance that make it unique.
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Mapping a Maintenance to a Part Number
A maintenance product can be mapped to one or more part numbers. Part numbers are optional and are selected 
from a group of unassigned part numbers that have been added or imported into FlexNet Operations. 

Note • If you are already on the Map Part Numbers to Maintenance page, skip to step 4. 

Task To map a maintenance to a part number

1. Click Products > Products. This opens the Products page. (Existing maintenances are shown, by default, on 
the Products page.)

2. Search, as necessary, to show the maintenance for which you want to map part numbers. Then click the 
name of the maintenance product. This opens the Create Maintenance page for that maintenance.

3. On the Create Maintenance page, click Next. This opens the Map Part Numbers to Maintenance page. 

4. Click Map to Part Numbers. A pop-up window appears in which you can search for and select one or more of 
the Available Part Numbers. (Note that the list of part numbers may be large enough to appear on multiple 
pages in the pop-up window.)

a. Click the part numbers you want to map to the maintenance.

b. Click the right arrow to move those part numbers to the Selected Part Numbers list. 

c. When the Selected Part Numbers list is complete, click OK to map the part numbers to the maintenance 
product. 

If necessary, click the Reset button to reset mapped part numbers. 

To remove the mapping between selected part numbers and this maintenance, select those part numbers 
and click the Remove Part Numbers button.

5. Complete the mapping process by clicking either Save or Next. 

• Click Save to save the mapping of part numbers to the maintenance product. 

• Click Next to relate a maintenance product to other products. (See Relating Suites to Other Products for 
instructions.)

Relating Maintenance to Other Products 
Maintenance can be related to one or more products. Products can be related in draft or deployed states. 

Note • If you are already on the Map Part Numbers to Maintenance page, skip to step 4. 
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Task To relate maintenance to other products

1. Click Products > Products. This opens the Products page. (Existing maintenances are shown, by default, on 
the Products page.)

2. Search, as necessary, to show the maintenance for which you want to map part numbers. Then click the 
name of the maintenance product. This opens the Create Maintenance page for that maintenance.

3. On the Create Maintenance page, click Next. This opens the Map Part Numbers to Maintenance page. 

4. On the Map Part Numbers to Maintenance page, click Next. This button opens the Relate to Different 
Products page.

5. Click the Select Related Products button. A pop-up window appears in which you can search for and select 
one or more of the available products. (Note that the list of products may be large enough to appear on 
multiple pages in the pop-up window.)

a. Click one or more check boxes to select products. 

b. When the list is complete, click the OK button to add the related products.

c. On the Relate to Different Products page, select the relationship Is Maintenance between the 
maintenance and the related product. 

If necessary, click the Reset button to reset the maintenance relationships. 

To remove the relationship between selected products and this maintenance, select those products and click 
the Remove Relationship button.

6. Complete the product relationship process by clicking Save or Complete. 

• Click Save to save the relationship to the maintenance product and remain on the current page. 

• Click Complete to save the relationship to the maintenance product and return to the Products page. 

Managing Part Numbers
Many publishers use part numbers to identify their products. Part numbers are also instrumental in making 
products available for free trials in the End-User Portal. 

During product packaging in FlexNet Operations, part numbers can be mapped to products, suites, and 
maintenance. A product, suite, or maintenance can be mapped to one or more part numbers; a part number can 
be mapped to only one product, suite, or maintenance. 

Part numbers can be added into FlexNet Operations, or imported from a properly-formatted text file. 

You can search for existing part numbers by number, product, license model, part numbers mapped to products, 
or part numbers mapped to license models. 

Table 2-23 • 

Topic Description

Adding Part Numbers Describes how to manually input individual part numbers.
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Adding Part Numbers 
You can add part numbers on the Part Numbers page.

Task To add a new part number

1. Click Products > Part Numbers. This link opens the Part Numbers page. 

2. On the Part Numbers page, click Add. 

3. In Part Number, enter the new part number.

4. In Description, enter a brief description of this part number.

5. In Product Name, search for a product and select a license model. 

6. For Available for Trial, select the check box to indicate whether you want this part number to be part of a trial 
registration program. 

Tip • The Available for Trial check box is not active until the part number has been mapped to a deployed 
product and a deployed license model.

7. Click Save to save the number, or click Add New Part Number to continue adding part numbers.

FlexNet Operations associates the new part number with the product and license model you chose.

Deleting Part Numbers
You can delete part numbers on the Part Numbers page. 

Task To delete a part number

1. Select the part number to delete and click Delete. 

2. Click OK to confirm deletion.

Deleting Part Numbers Shows how to delete existing part numbers. 

Mapping Part Numbers Explains how to map a part number to a product.

Importing Part Numbers Redirects producers to the Importing and Exporting Entities topic for information 
about importing part numbers. 

Table 2-23 • 

Topic Description
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Mapping Part Numbers
Existing part numbers can be mapped to a product and a license model directly from the Part Numbers page 
(Products > Part Numbers). You can also map part numbers to products on the Create a Part Number page.

Task To map a part number to a product and a license model

1. On the Part Numbers page, select the part number and click Map to Product. 

2. On the Select Product page, select the product you want to map to. 

3. In the License Model drop-down, select the license model. 

4. Click OK. The part number is now mapped to the product.

Importing Part Numbers
With FlexNet Operations, you can use the Import/Export functionality to import part numbers.

See Importing and Exporting Entities for more information.

Managing Product Lines
Product lines allow you to group, classify, and describe products. 

Depending on your system configuration settings, product lines can also be used to define access rights to 
product information for internal users in large accounts with diverse product offerings. For example, a product 
manager for a CRM product might be authorized to view products and entitlements for only CRM products, 
instead of viewing products across an account’s entire product set. Likewise, product lines can be used on End-
User Portal sites to ensure that customer users see only the items related to the product lines to which their 
accounts are linked. 

For many producers, product lines are completely optional. However, there are two scenarios where product lines 
are required: 

• For producers who use FlexNet Electronic Software Delivery, product lines are a high-level organizer for 
download files. In the End-User Portal, download files are grouped by producer, then product line, and then 
download package. 

• For producers who use FlexNet Usage Management, product lines play a functional role in searching for and 
rendering usage history reports. 
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Enabling Product Lines
For most producers, product lines are optional. They must be enabled in the Producer Portal via the FlexNet 
Operations system configuration settings. There are two configuration settings that can be used. The one you 
choose depends on how your account uses product lines. 

1. Product lines are available for use as product groups without restricting the visibility of products to different 
users or accounts. (This product line functionality is enabled by default.) 

2. Product lines are available for use as product groups and also restrict visibility of products to different users 
and accounts. 

Enabling Product Lines for Products

The default product line functionality can be enabled via the system configuration setting, Enable Product Lines 
for Products. 

Task To enable product lines for products

1. Click System > Configure. 

2. Click FlexNet Operations to open the configuration page for FlexNet Operations-specific settings. 

3. Locate the Enable Product Lines for Products setting and select its check box. 

Note • This setting is only effective if the check box for Enable Product Lines for Products, Users, and 
Accounts is not selected. 

4. Click Save Configs to save changes. 

Enabling Product Lines for Products and Visibility Restrictions

The addition of visibility restrictions to product line functionality can be enabled via the system configuration 
setting, Enable Product Lines for Products, Users, and Accounts. 

Task To enable product lines for products

1. Click System > Configure. 

2. Click FlexNet Operations to open the configuration page for FlexNet Operations-specific settings. 

3. Locate the Enable Product Lines for Products setting and unselect its check box. 

4. Locate the Enable Product Lines for Products, Users, and Accounts setting and select its check box. 

5. Click Save Configs to save changes. 

You define access rights by mapping products to product lines and then product lines to producer accounts or to 
customer users.

Two special product lines are automatically defined by FlexNet Operations: 
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• All—Applied to all customer users by default, this product line includes all products. When implementing 
product lines, FlexNet Operations includes All as the default to preserve product access for backward 
compatibility. Later, this product line can be removed and appropriate product lines linked to implement 
selective product line access for customer users. 

• Uncategorized—Collects the set of products that have not been mapped to a product line. FlexNet 
Operations treats Uncategorized as a separate product line. Customer user accounts that have not been 
linked to the Uncategorized line cannot see uncategorized products.

Product lines can be the object of searches. In addition, product lines can include descriptive attributes that can 
be used to characterize them. 

Adding Product Lines and Product Line Attributes
You can add product lines in the Producer Portal and add product line attributes to those product lines. 

Task To add a product line

1. In the Producer Portal, click Products > Product Lines. This link opens the Product Lines page.

2. Click Add Product Line. This button opens the Create Product Line page.

3. On the Create Product Line page, in Name, enter the name of the product line.

4. In Description, enter an optional product line description.

5. Click Save.

Product lines can have product attributes. A product line’s product attributes can be added or deleted on the 
Create Product Line page. (Recall, though, that FlexNet Operations limits alterations to a product line and its 
attributes after the product line is linked to a product.) 

Task To add a product attribute to a product line

1. On the Create Product Line page, click Add Product Attribute. This button opens the Create Product Line 
Attribute page. 

2. On the Create Product Line Attribute page, in Name, enter the name of the attribute.

3. Indicate whether the attribute is required for the product line.

4. In Type, select the attribute type, then specify any additional details as needed.

• Boolean: A pair of options for mutually exclusive choices, such as Yes or No.

• Long Text: A text value that can be up to 16384 characters. The value can be typed or pasted into the 
text box. (The Display Type setting controls how a long text value is displayed: Text Area or Text Field.)

• Text: An alphanumeric string. Specify Max Length (a number of characters), Text Type (Single Select, 
Free Form, or Multi Valued Text), and Display Type (Text Area or Text Field).

• Date: A calendar date.

• Number: A numeral, for example, 33452. (Value must be an integer.)

5. Click Save.
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Deleting Product Lines or Product Line Attributes
Product lines that have not yet been mapped to a product can be deleted. Likewise, product line attributes can be 
added to or deleted from a product line provided that product line has not yet been mapped to a product. After a 
product line is mapped to a product, it cannot be deleted, and alterations to its product line attributes are highly 
restricted—only the addition of optional attributes is permitted. 

Task To delete a product line

1. In the Producer Portal, click Products > Product Lines. This link opens the Product Lines page.

2. Select a product line, and click Delete.

3. Click OK to confirm the deletion.

Task To delete a product line attribute from a product line

1. On the Create Product Line page, select the attributes you want to remove, and click Delete.

2. Click OK to confirm the deletion.

Managing Download Packages
Producers who use FlexNet Operations for electronic software delivery can create download packages on the 
Producer Portal and associate those download packages with products and download files.

Important • For the instructions in this section, it is expected that you are working on the Producer Portal with 
sufficient permissions to perform the tasks described. 

Table 2-24 • 

Topic Description

About Download 
Packages

Describes what download packages are and how they are used by producers.

• About Download Package Attributes

• About Download Package Restrictions

• About Physical Distribution and Order Media Requests

• About Export Compliance

Creating a Download 
Package

Explains how to add a download package. 

Searching for a 
Download Package

Describes how to search for a download package using download package 
attributes.



Chapter 2 Packaging Products
Managing Download Packages

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 87

About Download Packages
Download packages are groups of files that can be related to one or more products and tied to a producer and a 
product line. Optionally, a download package can be associated with a license agreement as well. The figure 
below depicts the relationships among download packages, download files, and products. 

Viewing Download 
Package Information

Explains how to view a download package, see where it is used, its restrictions, its 
email notifications, its transactions, and its short-code transactions. 

• Viewing this Download Package

• Viewing Where a Download Package Is Used

• Viewing Download Package Restrictions

• Viewing Emails Related to a Download Package

• Viewing Download Package Transactions

• Viewing Download Packages of a Product

Editing Download 
Package Information

Covers the options presented in the Edit menu on the View Download Package 
page. 

• Editing a Download Package

• Editing a Download Package File List

• Reidentifying a Download Package

• Restricting a Download Package

• Creating an Email Notification for a Download Package

Copying Download 
Packages

Covers copying a download package with its files or without its files.

• Copying a Download Package with Files

• Copying a Download Package without Files

Managing Download 
Package Associations

Covers the management of download package associations with products and files. 

• About Download Package Associations

• Associating a Download Package to a Product

• Disassociating a Download Package from a Product

• Associating a Download Package to Files

• Disassociating a Download Package from Files

Table 2-24 • 

Topic Description
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It is through a download package’s relationship to products that FlexNet Operations determines which download 
packages an end user is entitled to.

On the End-User Portal, download packages are grouped by producer and product line so that entitled users can 
navigate hierarchically through the producer, product line, product, and version to find the downloads they 
require. And when optional license agreements are associated with a download package, the End-User Portal 
shows the agreement before allowing end users to download files. 

Download packages are also where producers specify export compliance settings that define how download 
delivery is controlled internationally.

Table 2-25 • 

Topic Description

About Download 
Package Attributes

Describes the attributes of download packages. These attributes apply to download 
package searches and to download package creation and editing. 

About Download 
Package Restrictions

Discusses the optional restriction of end user access to download packages.

About Physical 
Distribution and Order 
Media Requests

Describes how to use download package attributes and End-User Portal 
configuration settings to support requests for download files on physical media in 
the End-User Portal. 

About Export 
Compliance

Discusses export compliance concepts. Export compliance prevents the delivery of 
files to residents of certain countries, in keeping with U.S. restrictions on the sale of 
regulated technologies to these countries. The user-configurable export compliance 
settings are managed at the download package level.
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About Download Package Attributes
Download package attributes describe the download package, express its availability dates, specify its export 
compliance settings, and so forth. 

Table 2-26 • 

Attribute Description

Download Package ID A unique ID used to associate the download package with products and files.

Download Package 
Name

The name of the download package to be displayed to users in the End-User 
Portal. It should be brief but descriptive, for example, Enterprise Server 2.4 
Solaris or Enterprise Server 2.4 Documentation.

Extended Description An optional, additional description attribute for the download package. 
Maximum: 1000 characters.

Version The version of the download package.

Release Group An optional attribute to help sort the download package’s appearance in the 
End-User Portal. Maximum: 20 characters. 

Effective Date The date when the download package becomes available on the End-User 
Portal. Accounts have access to the download package if the download 
package’s effective date occurs within their entitlement’s effective and 
expiration dates on the line item for that download package.

Expiration Date The date when the download package moves to the archive (Previous 
Versions) tab or becomes inaccessible from entitlement lines with start dates 
later than this expiration date.

If the expiration date is in the future, the download package appears on the 
new versions section of the End-User Portal. If the expiration date is in the 
past, the download package moves to the release archives section. Accounts 
have access to the download package from the release archives section even 
if the download package is expired, provided there is an overlap between the 
download package’s effective and expiration dates and the entitlement's 
effective and expiration dates.

Archive Date The date on which the download package moves to the archive (Previous 
Versions) tab. Users may still download it if they have access through an 
overlap with their entitlement dates, but must find it on the archive tab on the 
End-User Portal. (New entitlements with beginning dates after the expiration 
date will not have access to this product at all.)

Download Package 
Producer

The producer of the product and the download package. (See Managing 
Producers.)

Product Line The product line in which the download package appears.
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Note • A download package’s editable attributes may also include the values for any custom download package 
attributes you have defined. To learn more about custom attributes, including custom download package 
attributes, see Administering Custom Attributes.

Many attributes support localization. For localizable attributes, click Show Languages to reveal additional, locale-
specific fields for those attributes. 

About Download Package Restrictions
Producers can set up download package restrictions to either permit or deny End-User Portal access to the 
download package for the specified accounts.

Download package restrictions can be useful in situations where a producer is delivering a beta release only to 
accounts who are participating in the beta test process or selectively make a hotfix available only to designated 
accounts. 

By default, a download package is unrestricted. If no restrictions are created for a download package, it is 
accessible to all entitled accounts. 

End User License 
Agreement

An optional, click-through license agreement. (See Managing License 
Agreements.) 

Physical Distribution 
Available

Specifies whether users on the End-User Portal have the option to request a 
copy of the download package on physical media. FlexNet Operations offers 
customizations to integrate with a physical distribution facility. When your site 
is integrated, this attribute shows whether or not end users have the option to 
request a physical copy of the download package. (See About Physical 
Distribution and Order Media Requests.) 

Restrict to US/Canada Specifies whether to restrict delivery to users in the United States or Canada or 
to permit delivery outside those countries. 

Yes—Restricts delivery to users within the United States or Canada. 

No—Permits delivery to users outside the United States and Canada. 

If you choose No, ECCN, ENC, and CCATS attributes are required. Otherwise, 
they are not used. See About Export Compliance for more information. 

ECCN, ENC, CCATS See About Export Compliance.

Download Instructions Directions to End-User Portal users. Download instructions can be plain text or 
HTML content and are shown to users along with the list of files in the 
download package. For example, Please refer to the release notes for 
installation instructions.

Table 2-26 • 

Attribute Description
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Accounts can be added to the Restrict Download Package list one at a time. The process starts with a search for 
the account to permit or deny access by its account ID or its account name. Search results are shown on the Find 
an Account page in a pop-up window. When you choose to restrict a previously unrestricted download package, 
the Find an Account page provides the option of specifically permitting (Restrict Allow) or denying (Restrict Deny) 
access to the selected account. From that point on, any other accounts you add to the restrictions list must follow 
the choice (Restrict Allow/Restrict Deny) you made for the first account. 

• Restrict Allow—Creates a file access “allow list” that stipulates the accounts that are permitted to access the 
download package. Any account not on the list is not permitted to access the package in the End-User Portal, 
even if they are otherwise entitled to the product. 

• Restrict Deny—Creates a file access “block list” that stipulates the accounts that are not permitted to access 
the download package. None of the accounts on the list are permitted to access the package in the End-User 
Portal, even if they are otherwise entitled to the product. 

Multiple accounts can be removed from the restrictions list on the Restrict Download Package page by selecting 
their check boxes in the Remove this Account column and then clicking Remove Selected Accounts. 

For instructions about restricting files, see Restricting a Download Package.

About Physical Distribution and Order Media Requests
For producers who want their end users to be able to request download files on physical media, the End-User 
Portal includes an Order Media control. Configuring the End-User Portal to handle these requests requires some 
configuration in the Producer Portal. 

Download packages for which orders for physical media are supported must have the Physical Distribution 
Available attribute set to Yes. 

The system configuration settings allow the End-User Portal to show the Order Media control and set a target 
email address for order media requests. The following settings must be configured on the End-User Portal Setup 
page. 

• Show Order Media Button—selected

• Order Media Destination Email Address—email address to receive order media requests specified

Tip • To show the End-User Portal Setup page in the Producer Portal, click System > Configure > End-User Portal 
Setup.

About Export Compliance
A download package’s export compliance settings are defined on its Add Download Package or Edit Download 
Package page. These settings play a role in determining whether or not a collection of files can be delivered to a 
given End-User Portal user. Download packages that are not restricted to the United States and Canada must 
have valid ECCN, ENC, and CCATS values to be properly delivered to users in countries outside of the United 
States and Canada. 

• Export Compliance Requirement

• Export Compliance Evaluation
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• Export Compliance Codes: ECCN, ENC, and CCATS

Export Compliance Requirement
Deliveries of software outside the United States are subject to the Export Administration Regulations, which are 
administered by the Department of Commerce Bureau of Industry and Security. In addition to embargoed or 
terrorist countries, to which no products may be sold or delivered, a number of United States government 
agencies maintain lists of individuals and entities to which software sales and delivery are barred. Revenera is 
prohibited from delivering to parties appearing on these lists, whether we are delivering from or to the United 
States or from or to another country.

Export Compliance Evaluation
FlexNet Operations distinguishes and acts on the different BIS-approved processes, depending on the product 
classification of a particular software product.

FlexNet Operations checks the following data elements for any individual who initiates a download using the 
service:

• User name on denial list

• User email address domain—check for country of origin/government

• User profile address—check for country of origin/government

• Account Name on denial list

• IP address lookup

• Domain from DNS lookup for IP address (only used if the user profile address check fails)

If any of these checks fail, access is denied—the export is not allowed. When a compliance check fails, FlexNet 
Operations automatically generates and sends an email message to an internal email alias and, optionally, also 
forwards it directly to a customer-designated email address. Contact Revenera, if necessary, to follow up for 
information relevant to the denial.

Export Compliance Codes: ECCN, ENC, and CCATS
The chart, below, displays the valid ECCN, ENC, and CCATS code combinations to comply with the Bureau of 
Industry and Security's (BIS) export rules. In the chart, "######" indicates that any six digits following D, G, or Z 
are valid. All characters are upper-case. The Z###### CCATS numbers may also have -P appended to them to 
indicate that the temporary classification has expired and the final CCATS number is pending.

You can restrict downloads to the US and Canada by setting Restrict to US/CANADA (NLR) to Yes.
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Use “TSR+” for 5D001 products with a TSR license exception, except for those products with "software" 
controlled by 5D001.a and specially designed for items controlled by 5A001.b.5.

Table 2-27 • Valid code combinations based on BIS compliance taxonomy

Encrypted? ECCN ENC CCATS Export Rules

Encryption 5D002 Unrestricted 
(RETAIL)

D######
G######
SELF
Z######-P

Broad export. No embargoed countries 
or “terrorist-supporting states.” 

Z###### Limited export. No countries outside 
U.S., Canada, and EU+8 (EU+8 referred 
to in BIS regulations as “Supplement 3 
Countries”). 



Chapter 2 Packaging Products
Managing Download Packages

94 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Encryption 
(cont.)

5D002 (cont.) Restricted 
(NON_RETAIL)

D######
G######
Z######-P

Limited export. No foreign 
governments outside the EU+8 (EU+8 
referred to in BIS regulations as 
“Supplement 3 Countries”). No 
embargoed countries or “terrorist-
supporting states.” Special click-
through must be accepted by end 
user. 

Z###### Limited export. No countries outside 
U.S., Canada, and EU+8 (EU+8 referred 
to in BIS regulations as “Supplement 3 
Countries”). 

TSU --- Broad export. No embargoed countries 
or “terrorist-supporting states.” 
Available for “publicly available” 
encryption source code. 

TMP_BETA --- Broad export. No embargoed countries 
or “terrorist-supporting states.” 
Available for beta testing only. Certain 
terms must be agreed to by beta 
tester. 

UNKNOWN --- Limited export. No countries outside 
U.S. and Canada. 

5D992 --- ---
D######
G######
SELF
Z######-P
Z######

Broad export. No embargoed countries 
or “terrorist-supporting states.” 
CCATS=SELF available only for 
encryption that does not exceed 56 
bits, or encryption that is limited to 
password protection or authentication. 

Table 2-27 • Valid code combinations based on BIS compliance taxonomy

Encrypted? ECCN ENC CCATS Export Rules
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No Encryption EAR99 --- ---
SELF

Broad export. No embargoed 
countries. 

3E201 --- --- No license required. Nuclear 
Nonproliferation. 

3D002 --- --- Limited export. No countries outside 
U.S. and Canada. 

TSR --- Limited export. Group B countries only. 
Special click-through must be 
accepted by end user (written 
assurance). 

3D991 --- --- Broad export. No embargoed countries 
or “terrorist-supporting states.” 

3E991 --- ---

4D993 --- ---

4D994 --- ---

4E992 --- ---

4E993 --- ---

5D001 --- --- Limited export. No countries outside 
U.S. and Canada. 

TSR --- Limited export. Subset of Group B 
countries only. Special click-through 
must be accepted by end user (written 
assurance). 

TSR+ --- Limited export. Group B countries only. 
Special click-through must be 
accepted by end user (written 
assurance). 

5D991 --- --- Broad export. No embargoed countries 
or “terrorist-supporting states.” 

5E991 --- ---

5E992 --- ---

Table 2-27 • Valid code combinations based on BIS compliance taxonomy

Encrypted? ECCN ENC CCATS Export Rules
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Creating a Download Package
You can create a download package in the Producer Portal. 

Note • Before creating a download package, you must have defined at least one deployed product and a product 
line. (For instructions about creating products and product lines, see Creating a Product and Managing Product 
Lines, respectively.)

A download package contains one or more files for users to download from the End-User Portal. A typical use of 
download packages is as a container for the files that comprise, say, the installer, documentation, and release 
notes for a particular software release, but your account can group files together in any way that makes sense for 
its product offerings. Download packages must exist before they can be associated to products or have files 
associated to them. 

Task To create a download package

1. Click Products > Create Download Package. This link opens the Create Download Package page. 

2. Enter download package attributes.

Unknown NO_EXPORT UNKNOWN --- No export. U.S. only. 

UNKNOWN UNKNOWN --- No export. U.S. only. 

Attribute Description

Download Package ID A unique ID used to associate the download package with products and files.

Download Package 
Name

The name of the download package to be displayed to users in the End-User 
Portal. 

Extended Description An optional, additional description attribute for the download package. 
Maximum: 1000 characters.

Version The version of the download package.

Release Group An optional attribute to help sort the download package’s appearance in the 
End-User Portal. Maximum: 20 characters. 

Effective Date The date when the download package becomes available on the End-User 
Portal. Accounts have access to the download package if the download 
package’s effective date occurs within their entitlement’s effective and 
expiration dates on the line item for that download package.

Table 2-27 • Valid code combinations based on BIS compliance taxonomy

Encrypted? ECCN ENC CCATS Export Rules
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3. Optionally, add Download Instructions. Download instructions are directions for End-User Portal users that 
can be entered as plain text or as HTML content. These instructions are shown to users along with the list of 
files in the download package. For example, “Please refer to the release notes for installation requirements.”

4. Complete or continue the download package creation process: 

• Click Save Download Package to save with current settings. The Producer Portal shows the download 
package’s View Download Package page.

Expiration Date The date when the download package moves to the archive (Previous 
Versions) tab or becomes inaccessible from entitlement lines with start dates 
later than this expiration date.

If the expiration date is in the future, the download package appears on the 
new versions section of the End-User Portal. If the expiration date is in the 
past, the download package moves to the release archives section. Accounts 
have access to the download package from the release archives section even 
if the download package is expired, provided there is an overlap between the 
download package’s effective and expiration dates and the entitlement's 
effective and expiration dates.

Archive Date The date on which the download package moves to the archive (Previous 
Versions) tab. Users may still download it if they have access through an 
overlap with their entitlement dates, but must find it on the archive tab on the 
End-User Portal. (New entitlements with beginning dates after the expiration 
date do not have access to this product at all.)

Download Package 
Producer

The producer of the product and the download package. (See Managing 
Producers.)

Product Line The product line in which the download package appears.

End User License 
Agreement

An optional, click-through license agreement. (See Managing License 
Agreements.) 

Physical Distribution 
Available

Specifies whether users on the End-User Portal have the option to request a 
copy of the download package on physical media. FlexNet Operations offers 
customizations to integrate with a physical distribution facility. When your site 
is integrated, this attribute shows whether or not end users have the option to 
request a physical copy of the download package. .

Restrict to US/Canada Specifies whether to restrict delivery to users in the United States or Canada or 
to permit delivery outside those countries. 

Yes—Restricts delivery to users within the United States or Canada. 

No—Permits delivery to users outside the United States and Canada. 

If you choose No, ECCN, ENC, and CCATS attributes are required. Otherwise, 
they are not used. See About Export Compliance for more information. 

Attribute Description
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• Click Save & Add Another to save the current download package and begin creating another download 
package. 

• Click Save & Add File to save the current download package and upload a file image for it.

• Click Save & Associate File to save the current download package and associate it with a file. 

• Click Save & Copy to Product to save the current download package and associate it with a product.

Searching for a Download Package
Existing download packages can often be most easily located by performing a quick search based on some 
attribute of the download package you want to see. 

Tip • To return a list of all download packages, leave the search criteria blank and click Search. Empty searches 
match all download packages. 

Task To search for a download package

1. Click Products > Search Download Packages. The Search Download Packages page opens. 

2. Enter your download package search criteria and click Search. The Producer Portal shows a list of the 
download packages that match your search criteria on the Search Results: Download Packages page.

From the Search Results: Download Packages page, you can click: 

• Search Again to run another download package search 

• Mass Update to edit the download packages listed on the Search Results: Download Packages page 

• Export to export a set of download packages as a Data Import Template file (see Importing and 
Exporting Entities) 

See About Download Package Attributes for more information about attributes available in the search 
criteria. 

3. Click the Download Package ID for the download package you want to view. 

The Producer Portal shows the View Download Package page for the download package you selected.

On the View Download Package page, you can perform any of the download package management activities—
such as associating the download package to a product or to one or more files—that are permitted by your user 
account permissions.

Viewing Download Package Information
Users typically search for a download package they want to view and then click that download package’s name to 
open the View Download Package page. The View menu on the View Download Package page includes several 
commands to get more details about the download package, where it is used, how it has been managed, who it 
has been delivered to, and so on. With the commands in the View menu, you can perform the following tasks.
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In addition, users can access the download packages associated with a product from the Create A Product page 

Viewing this Download Package
When working with download packages, you can return to the basic View Download Package page by clicking 
View this Download Package. Download package-related operations might be checking where the download 
package is used, associating the package to a product, and so forth. On these download package-related pages, 
View this Download Package is a link in the View menu. 

The Producer Portal also shows the View Download Package page when you add a download package. 

Task To return to the basic View Download Package page

• Click View > View this Download Package. 

Viewing Where a Download Package Is Used
You can display a list of the products that use a download package from the download package’s View Download 
Package page. 

Task To view where the current download package is used

• On the View Download Package page, click View > View Where Used. 

Table 2-28 • 

Topic Description

Viewing this Download 
Package

Explains how to return to the basic View Download Package page when performing 
other download package-related operations. 

Viewing Where a 
Download Package Is 
Used

Shows how to determine which products a download package is associated with. 

Viewing Download 
Package Restrictions

Describes how to view a list of accounts that are permitted or denied access to a 
download package. Restricting download package access to designated accounts 
is optional. By default, download packages are accessible to all entitled accounts. 

Viewing Emails Related 
to a Download Package

Shows how to view email messages sent for a download package. 

Viewing Download 
Package Transactions

Shows how to view transaction history related to a download package. 

Viewing Download 
Packages of a Product

Explains how to access the download packages associated with a specific product 
from the Create A Product page.
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The Producer Portal opens the Where Download Package Used page. This page lists the products with which the 
download package is associated. Clicking on the name of a product in the Products list opens the View Product 
page for that product.

Viewing Download Package Restrictions
Describes how to view a list of accounts that are permitted to see a download package in the End-User Portal. 
Restricting download package access to designated accounts is optional. By default, download packages are 
accessible to all entitled accounts. 

Task To view download package restrictions

• On the View Download Package page, click View > View Restrictions. 

The Producer Portal opens the View Download Package Restrictions page. Depending on how restrictions were 
defined, this page either lists the accounts that are permitted or denied access the current download package. 
(Download package restriction lists can be lists of permitted accounts or denied accounts.) 

If no accounts appear in the Download Package Restricted To list, then the download package is accessible by all 
accounts.

Viewing Emails Related to a Download Package
You can view email messages sent for a download packages from its View Download Package page. These 
messages appear in a list on the Search Results: Email page. The email messages are sorted from newest (most 
recently sent) to oldest.

Task To view emails related to a download package

• On the View Download Package page, click View > View Emails. 

The Producer Portal opens the Search Results: Email page. Click the System Email ID to show the View Email page 
for that email message. 

If no emails have been sent for products to which the current download package is associated, the Producer 
Portal shows an error message that reports: No email messages found.

Viewing Download Package Transactions
You can view transactions related to a download package from the download package’s View Download Package 
page. These transactions appear in a list on the Search Results: Transactions page.

Task To view transactions related to a download package

• On the View Download Package page, click View > View Transactions. 
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The Producer Portal opens the Search Results: Transactions page. Transactions are ordered by date with the most 
recent Transaction first. Click on the System Transaction ID to open its View Transaction page. 

A transaction is recorded by the Producer Portal as users make changes to the system. Download Package 
transactions are recorded for changes like adding a download package or associating a download package with a 
product. 

Viewing Download Packages of a Product
You can view the download packages associated with a specific product from the Create A Product page.

Task To view the download packages of a specific product

1. In FlexNet Operations go to Products > Products.

2. In the Package Products page, click on the name of the product.

3. In the Create A Product page, click on the Download Packages tab. A table of download packages appears.

4. Click on the ID of the download package to open the View Download Package page.

Editing Download Package Information
Users typically search for a download package they want to view and then click that download package’s name to 
open the View Download Package page. The Edit menu on the View Download Package page includes several 
commands for actions like altering, restricting, or creating an email message for an existing download package. 
With the commands in the Edit menu, you can perform the following tasks. 

Table 2-29 • 

Topic Description

Editing a Download 
Package

Describes how to change a download package’s details. 

Editing a Download 
Package File List

Shows how to use Edit File List to modify the sort order of the files associated with a 
download package and optionally exclude selected files from download limit 
enforcement.

Reidentifying a 
Download Package

Discusses how to reidentify a download package to change the download package 
ID of an existing download package. 

Restricting a Download 
Package

Explains how to restrict access to a download package to designated accounts.

Creating an Email 
Notification for a 
Download Package

Describes how to create an email notification for a download package. 



Chapter 2 Packaging Products
Managing Download Packages

102 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Editing a Download Package
You can edit download package details from the View Download Package page. Most of the download package 
information that you enter when you add a download package can be edited on the Edit Download Package page. 

Some commonly edited download package details include

• Download Package Description—The name of the download package that End-User Portal users see. It 
should be brief but descriptive, for example, Enterprise Server 2.4 Solaris or Enterprise Server 2.4 
Documentation.

• Download Package Name—The name of the download package as it will appear in the Producer Portal.

• Extended Description—An optional, additional description field that can show more information about the 
download package to your End-User Portal users. Maximum: 1000 characters. 

• Download Instructions—Additional information that is displayed above the file list on the download page of 
the End-User Portal. For example, Please refer to the release notes for installation instructions.

Note • A download package’s editable attributes may also include the values for any custom download package 
attributes you have defined. To learn more about custom attributes, including custom download package 
attributes, see Administering Custom Attributes.

Many attributes support localization. For localizable attributes, click Show Languages to reveal additional, locale-
specific fields for those attributes.

For more information about download package attributes, see About Download Package Attributes.

Task To edit download package details

1. On the View Download Package page, click Edit > Edit this Download Package. This link opens the Edit 
Download Package page for the current download package. 

2. Make your changes to one or more download package details. 

3. Click Save. 

The Producer Portal saves your changes and returns to the View Download Package page for the current 
download package. 

Tip • Some download package details, such as its Download Package ID, cannot be altered on the Edit Download 
Package page. To change a download package’s ID, you must reidentify the download package (Edit > 
Reidentify). 

Editing a Download Package File List
You can edit the file list for a download package from the package’s View Download Package page. 



Chapter 2 Packaging Products
Managing Download Packages

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 103

The Edit File List page shows all of the files associated with the current download package and allows you to 
create and edit the file sort order. On the End-User Portal, the files that are part of this package are sorted in 
ascending order according to the numeric values you enter here. If no sort order is specified or when more than 
one file has the same Sort Order number, the files are sorted in the alphabetical order by their file description. 

The file sort order only applies to the current download package. Therefore, the same file used in more than one 
download package may have a different sort order value in different packages.

Task To edit the file list of a download package

1. On the View Download Package page, click Edit > Edit File List. This command opens the Edit File List page.

2. In the Files in this Download Package list, specify Sort Order values for each file. 

Tip • The Edit File List page also allows you to indicate which, if any, of the files in this download package 
should ignore download limits inherited from the product. To control whether a file can be downloaded more 
times than the download limit, in the Ignore Download Limit column, select Yes or No. 

3. Click Save File List.

The Producer Portal saves the file list with the specified sort order values. 

Reidentifying a Download Package
You can change the download package ID of an existing download package from that download package’s View 
Download Package page.

Task To reidentify a download package

1. On the View Download Package page, click Edit > Reidentify. This link opens the Reidentify Download 
Package page. 

2. In the Download Package ID field, type a new download package ID value. 

3. Click Reidentify.

The Producer Portal changes the download package ID of the current download package and returns to the 
download package’s View Download Package page. Other download package details are preserved, including its 
associated products and files. 

Restricting a Download Package
You can restrict access to a download package in the Producer Portal to the users of designated accounts. 
Download packages are not restricted by default. When you restrict access to a download package, you use a 
search function to locate and identify the account to which you want to permit or deny download package access. 
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Note • When no accounts are listed a download package’s Restrict Download Package page, access to the 
download package is not restricted. See About Download Package Restrictions for more information about how 
the restriction process works.

Task To set download package restrictions

1. On the View Download Package page, click Edit > Restrict. This link opens the Restrict Download Package 
page.

2. Type search criteria and click Search Accounts. The Producer Portal opens the Find an Account page in a 
pop-up window. This page shows a list of accounts that match your search criteria.

3. On the Find an Account page, click Restrict Allow or Restrict Deny for an account. 

• If you choose Restrict Allow, only the accounts you choose are permitted to access the download 
package. 

• If you choose Restrict Deny, the accounts you choose are expressly denied access to the download 
package. 

The Producer Portal closes the Find an Account window and returns to the Restrict Download Package page. 

The Restrict Download Package page shows the account you chose in the Accounts Restricted to Download 
Package list. 

Tip • To remove an account from the Accounts Restricted to Package list, select the account’s check box in the 
Remove this Account column and then click Remove Selected Accounts.

Creating an Email Notification for a Download Package
You can create an email notification for the download packages from the View Download Package page.

Tip • To successfully send an email notification for a download package, the default variation of the Update 
Notification Email template must be active and permitted to send messages (Will Email Be Sent set to Yes). 

Task To create a notification email for a download package

1. On the View Download Package page, click Edit > Notify. This link opens the Create Notification Email by 
Download Package page.

2. Set Distribution List Options for the email message. 

Setting Description

Effective Date The first date (inclusive) that this entitlement is available to the end user.
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3. Choose an Email Template variation for this message. 

Download Package notification messages use the Update Notification Email template. Select any active 
variation of that template for the download package notification. 

Tip • You can manage your email templates in the Producer Portal. For more information about email 
templates, see Managing Email Templates. 

4. Click Create. The Producer Portal creates the email message for the download packages you specified, using 
the settings you provided, and shows the View Email page.

5. On the View Email page, click Edit > Send Email. The Producer Portal opens the Send Email page. 

6. On the Send Email page, choose to send the email or schedule its delivery. 

• To send immediately, click Send. 

• To schedule delivery for a later date, 

1. Click Queue to be sent at. 

2. Set the Send Date. 

3. Specify the Send Time (24-hour format). 

Include Expired 
Entitlements

Determines whether or not to include expired entitlements in the distribution 
list. By default, only users with active entitlements are included in the 
distribution list.

Exclude Email Filters Allows you to identify specific email addresses or email address ranges to 
exclude from the distribution list. For a single address, type the address in the 
space provided. For multiple addresses, add a comma-separated list of email 
addresses in the space provided. Use an asterisk as a wildcard to exclude 
ranges of email addresses. For example, *@somedomain.com, *.edu. 

Limit to Countries Restricts the delivery of notifications to countries identified by their two-
character country code. Use a comma-separated list of country codes to 
permit delivery to multiple countries. For example, specifying US,FR permits 
notification delivery to users in the United States and France.

When no country codes are specified, FlexNet Operations places no 
notification delivery restrictions based on the recipient’s country.

Send Separate Email for 
Each Download Package

Determines whether to send a single message for all download packages 
(when multiple download packages have been selected) or to send a separate 
message for each download package. 

Send Email Immediately Determines whether the message is sent as soon as it is created or sent later. 
If you select this check box, the Producer Portal sends the message as soon as 
you click Create on this page. Do not use this option if you want to modify the 
message before it is sent.

Setting Description
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4. Click Send.

The Producer Portal sends the email notification. 

Note • For more information about managing email messages and email templates, see Managing Email and 
Email Templates.

Copying Download Packages
You can create a copy of an existing download package using the controls on its View Download Package page. 

Tip • Often, the quickest way to create a new download page for a product update or service pack, for example, is 
to start with a copy of the original product’s download package. 

Copying a Download Package with Files
Use the following instructions to create a copy of a download package that includes the file associations in the 
original download package. 

Task To copy a download package

1. On the View Download Package page, click Copy > Copy with Files. The Producer Portal shows the Add 
Download Package page with product detail values that match those of the original download package.

2. On the Add Product page, make your changes to the product details. (See Creating a Download Package for 
information about the product detail fields or download instructions.)

3. Edit the download instructions, as necessary. 

4. Click Save Download Package.

The Producer Portal creates the new download package and shows its View Download Package page. 

Table 2-30 • 

Topic Description

Copying a Download 
Package with Files

Describes how to create a copy of a download package that includes the files 
currently associated with that download package. 

Copying a Download 
Package without Files

Describes how to create a copy of a download package that excludes the files 
associated with the original download package.
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Copying a Download Package without Files
Use the following instructions to create a copy of a download package that excludes the file associations in the 
original download package. 

Task To copy a download package

1. On the View Download Package page, click Copy > Copy without Files. The Producer Portal shows the Add 
Download Package page with product detail values that match those of the original download package.

2. On the Add Product page, make your changes to the product details. (See Creating a Download Package for 
information about the product detail fields or download instructions.)

3. Edit the download instructions, as necessary.

4. Click Save Download Package.

The Producer Portal creates the new download package and shows its View Download Package page. 

Managing Download Package Associations
The download packages you add to the Producer Portal can be associated with one or more existing products and 
to one or more files from the package’s View Download Package page. 

Users typically search for a download package they want to view and then click that download package’s name in 
the search results to open the View Download Package page. The Associate menu on the View Download 
Package page includes commands for adding and removing both product and file associations. With the 
commands in the Associate menu, you can perform the following tasks.

Table 2-31 • 

Topic Description

About Download 
Package Associations

Discusses the relationships you can create between files, download packages, and 
products. 

Associating a Download 
Package to a Product

Explains how to set up relationships between download packages and products. 
Two commands in the Associate menu facilitate making download package-product 
associations: 

• Associate to Products

• Associate Where

Disassociating a 
Download Package from 
a Product

Explains how to remove a previously built relationship between a download package 
and one or more products. 

Associating a Download 
Package to Files

Explains how to build relationships between files and the download package.
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About Download Package Associations
Download packages tie products and together with their download files. A download package can be associated 
with multiple products. Likewise, a download package can be associated with one or more files. 

When you associate a download package to a product, you can either specify the product ID or, if you do not know 
the ID, you can search for products and select it from a list. (In both cases, you can specify or select multiple 
products, as necessary.) 

One potential difficulty in identifying products to associate arises due to the way FlexNet Operations identifies 
products. A product ID is a combination of the product name and version. The syntax for product IDs is <product 
name>::<product version>. For example, SalesView Standard::1.0. 

Associating a Download Package to a Product
You can associate a download package to one or more products from the download package’s View Download 
Package page. The Associate menu on the View Download Package page includes two different commands for 
building download package-product associations: 

• Associate to Products—Allows you to identify one or more products by providing a product ID or searching 
for products to associate.

• Associate Where—Allows you to quickly associate a number of products with the current download package 
by copying the product associations from one or more other download packages. 

Using Associate to Products to Build Download Package-Product Associations
When you associate a download package to a product, you are indicating that the download package is included 
within the product. The Associate to Product command allows you to associate this download package to one or 
more products. Enter the product IDs or search for the products you want to associate with this download 
package. An existing customer with access to the product has immediate access to new download packages 
associated to the product.

Task To associate a download package to products

1. On the View Download Package page, click Associate > Associate to Products. This link opens the Associate 
Download Package to Products page.

2. Identify the products to associate. Choose whether to enter product IDs or to search for products: 

• Enter product IDs when you already know the product IDs or system product IDs of the products you 
want to associate. 

Disassociating a 
Download Package from 
Files

Explains how to remove a previously built relationship between a download package 
and one or more files. 

Table 2-31 • 

Topic Description
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1. In the Product IDs field, type the product IDs as a comma-separated list or enter them one per line. 
Note: If you enter system product IDs, remember to select the Use System IDs check box.

2. Click Associate Products.

• Search for products by entering search criteria if you do not know the IDs of the products you want to 
associate.

1. Type your search criteria into the product search fields. 

2. Click Search. The Producer Portal shows a list of products that match your criteria. 

3. Select the products to associate and click Associate Download Package to Selected Products.

Important • A product ID is a combination of the product name and product version with a syntax like the 
following: <product name>::<product versions>. For example, SalesView Standard::1.0. One ramification of the 
product ID syntax is that a search for the product by its product name does not match the product ID. For best 
results, use an asterisk as a wildcard character to be sure your product search captures the product you are 
looking for. For example, SalesView Standard*.

The Producer Portal creates associations between the current download package and the products you identified 
and opens the Where Download Package Used page for the current download package. 

Using Associate Where to Copy Product Associations from Other Download Package
Associate Where copies the product associations of one or more existing download packages. This approach 
allows you to quickly associate the current download package with all the products to which one or more other 
download packages are already associated. 

Task To associate a download package with another download package’s files

1. On the View Download Package page, click Associate > Associate Where. This link opens the Associate this 
Download Package to Files Where Other Download Packages Are Found page.

2. Identify the download packages from which to copy product associations. Choose whether to enter 
download package IDs, directly, or to search for download packages: 

• Enter download package IDs when you already know the download package IDs or system IDs of the 
download packages from which you want to copy associations.

1. In the Download Package IDs field, type the download package IDs as a comma-separated list or 
enter them one per line. Note: If you enter system IDs, remember to select the Use System IDs check 
box.

2. Click Associate.

• Enter file search criteria if you do not know the IDs of the download packages you want to associate.

1. Type your search criteria into the download package search fields. 

2. Click Search. The Producer Portal shows a list of download packages that match your criteria. 

3. Select the download package to associate and click Associate to Files of Selected Download 
Packages.
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The Producer Portal creates associations based on the product associations of the download packages you 
identified and opens the Where Download Package Used page for the current package. All products associated 
with the download packages you identified are now also associated with the current download package.

Disassociating a Download Package from a Product
You can remove a download package’s product associations from its View Download Package page. 

Task To disassociate a download package from a product

1. On the View Download Package page, click Associate > Disassociate from Products. This link opens the 
Disassociate this Download Package from Products page. 

2. Choose the products to disassociate and click Disassociate from Selected Products. 

The Producer Portal removes associations from the selected products and refreshes the Disassociate this 
Download Package from Products page to show the current download package-product associations, if any.

Tip • If a download package is associated with multiple products and you intend to remove all product 
associations, you can skip the step in which you choose the products and just click Disassociate from All 
Products. 

Associating a Download Package to Files
You can associate a download package to one or more files from the View Download Package page. The products 
to which you associate the download package can be identified by their product IDs, their system IDs, or located 
via a file search. 

Task To associate a download package to files

1. On the View Download Package page, click Associate > Associate Files. This link opens the Associate 
Download Package to Files page.

2. Identify the files to associate. Choose whether to enter file IDs or to search for files: 

• Enter file IDs when you already know the file IDs or system IDs of the files you want to associate. 

a. In the File IDs field, type the file IDs as a comma-separated list or enter them one per line. Note: If 
you enter system file IDs, remember to select the Use System IDs check box.

b. Click Associate Files.

• Search for files by entering search criteria if you do not know the IDs of the files you want to associate.

a. Type your search criteria into the file search fields. 

b. Click Search. The Producer Portal shows a list of files that match your criteria. 

c. Select the files to associate and click Associate File to Selected Files.
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The Producer Portal creates associations between the current download package and the files you identified and 
opens the Where Download Package Used page for the current download package. 

Disassociating a Download Package from Files
You can remove a download package’s file associations from its View Download Package page. 

To remove a bad file from a download package or correct a file association that was made in error, follow the 
instructions below. 

Task To disassociate a download package from a file

1. On the View Download Package page, click Associate > Disassociate Files. This link opens the Disassociate 
this Download Package from Files page. 

2. Choose the files to disassociate and click Disassociate from Selected Files. 

The Producer Portal removes associations from the selected files and refreshes the Disassociate this Download 
Package from Files page to show the current download package-file associations, if any.

Tip • If a download package is associated with multiple files and you intend to remove all file associations, you 
can skip the file choosing step and just click Disassociate from All Files. 

Managing Download Files
Producers who use FlexNet Operations for electronic software delivery can add files and upload file images on 
the Producer Portal. Producers can add files in the Producer Portal and associate them to products via download 
packages.

This section discusses download file management activities and concepts.

Important • For the instructions in this section, it is expected that you are working on the Producer Portal with 
sufficient permissions to perform the tasks described. 

Table 2-32 • 

Topic Description

About Files and File 
Images

Discusses the Producer Portal’s approach to files and file images and how those 
concepts are related to download packages, producers, and products. It also 
explains some important file management concepts, such as file restrictions and 
file aliases. Additionally, this section includes the following subtopics: 

• About File Attributes

• About Aliases

• About File Restrictions
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About Files and File Images
On the Producer Portal, you can add and manage the files you want to make available for your customers to 
download. You can add a file and then upload a file image. Adding a file is little more than creating a placeholder 
for the actual file and specifying a file description and file ID. Uploading the file image copies the actual file from 

Adding Files Describes how to add files. Once a file has been added, you can perform file-
management activities like uploading a file image for it and associate it with 
download packages. 

Searching for Files Shows how to search for files.

Viewing File 
Information

Shows how to view information related to the files in FlexNet Operations. Users 
typically search for a file they want to view and then click that file’s name to open 
the View File page. The following options are available from the View File page:

• Viewing this File

• Viewing Where a File Is Used

• Viewing File Restrictions

• Viewing Emails Related to a File

• Viewing File Transactions

• Viewing File Downloads

Editing File Information Shows how to edit, delete, or otherwise manipulate files in FlexNet Operations. 

• Editing a File

• Aliasing a File

• Uploading a File Image

• Deleting a File Image

• Reidentifying a File

• Restricting a File

• Creating an Email Notification for a File

Managing File 
Associations

Discusses the methods of associating download files with products. 

• About File Associations

• Associating a File to Download Packages

• Using Associate Where to Copy Associations from Another File

• Disassociating a File from a Download Package

Table 2-32 • 

Topic Description
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your local system into FlexNet Operations. Without the file image upload, the file in FlexNet Operations has no 
payload when a customer or channel partner tries to download it from the End-User Portal. For instructions, see 
Adding Files and Uploading a File Image.

This section provides a brief overview of file management concepts and options and provides additional 
information on the upload manager and other file upload methods as well as a discussion of supported file 
hosting options.

Download File Management Overview
The creation of a download file adheres, at least, to the following sequence: 

1. Add the file—Create a placeholder for the file image in FlexNet Operations and give the file, at minimum, a 
file ID. Other file details are optional at this point.

2. Upload the file image—Copy the actual file bits into FlexNet Operations. The file bits are what gets delivered 
to End-User Portal users when they download the file. 

3. Associate the file with one or more download packages—Download packages collect one or more files and 
tie them to a product. Without any association to a download package, the file will never appear for 
download on the End-User Portal. 

Once a file has been added and associated with a download package, it is available for End-User Portal users to 
download from any product to which the download package is associated and to which the End-User Portal user 
is entitled. No further actions are necessary; however, there are a number of options in the Producer Portal for 
editing a file’s details, changing its associations, restricting access to it, and sending email notifications to users 
who are entitled to the products that include it. 

• Editing file information and reidentifying a file—Most file details can be edited on the Edit File page, but to 
change a file’s ID, you must reidentify the file. (See Editing a File and Reidentifying a File, for instructions.)

• Aliasing a file creates a duplicate of an existing file that points to the same file image but can be managed 
separately. File aliases allow you to avoid uploading multiple copies of the same file image. (See About 
Aliases and Aliasing a File.)

• Restricting access to a file—controls whether a file is shown to specified customers in the End-User Portal. 
(See About File Restrictions and Restricting a File.)

• Sending a notification email for users who have access to the file—Initiate an email message to all End-User 
Portal users who have access to the file. (See Creating an Email Notification for a File.)

• Adding and removing download package associations—Reuse the file in other download packages by 
making additional associations or disassociate the file from a currently associated download package. (See 
Managing File Associations.)

These file management activities are covered in greater detail in this section. Likewise, instructions are 
presented in this section for researching a file’s associations and restrictions as well as its transaction and 
download history. See Viewing File Information for instructions.

Anonymous File Download
You can also make files available for users to download without requiring users to log in to the End-User Portal. 
This enables you as the producer to post a link to a file on your own website, or you can send a URL in an email to 
your end-users. Typically you would use the anonymous file download for informational files, but not actual 
software files.
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The following instructions describe the sequence for creating an anonymous download. The result is a URL that 
you can make available to customers. Customers who click on this URL can download the associated file without 
providing credentials. Note that these instructions assume that you already created a download package and 
associated it with a file (containing a file image) for the anonymous download. 

Task To make a file available for anonymous download:

1. Create a custom attribute called ANONYMOUS_ALLOWED. This involves the following steps: 

a. Click Administer > Custom Attributes. The Custom Attributes page opens.

b. On the Custom Attributes page, click Add Attribute.

c. On the Create Custom Attribute page, specify the following custom attribute settings:

• Name: ANONYMOUS_ALLOWED (in capital letters)

• Entity type: File

• Status: Active

• Type: Text

• Text type: Single select. Add the valid values TRUE and FALSE.

For more information about custom attribute settings, see Custom Attribute Settings.

d. Click Save to save the custom attribute.

2. Assign the ANONYMOUS_ALLOWED custom attribute that you created to the file that you want to make 
available to your customers. 

For information about adding attributes to a file, see Editing a File.

3. Open the View Download Package page and make note of the export compliance values assigned to the 
download package. This information is required to build the URL.

For more information, see Viewing Download Package Information.

4. Build the download URL. The format of the URL depends on whether export controls apply to the file, and 
whether you use the system file ID or file ID to identify the file.

• When no export controls apply, use either of the following formats:

• https://<siteID>-esd.flexnetoperations.com/flexnet/operations/
AnonymousDownload?systemFileID=<systemFileID>

• https://<siteID>-esd.flexnetoperations.com/flexnet/operations/
AnonymousDownload?fileID=<fileID>

Replace <siteID> with your organization’s DNS name or the specific site ID supplied by Revenera, 
<systemFileID> with the system file ID, and <fileID> with the file ID. You find the system file ID and file ID 
on the View File page. For more information about the site ID, see FlexNet Operations Environments.

• When export controls apply, use either of the following formats:

• https://<siteID>-esd.flexnetoperations.com/flexnet/operations/
AnonymousDownload?fileID=<fileID>&eccnNum=<ECCNcode>&leEnc=<ENCcode>&ccats=<CCATScode>&nlr=
<T/F>
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• https://<siteID>-esd.flexnetoperations.com/flexnet/operations/
AnonymousDownload?systemFileID=<systemFileID>&eccnNum=<ECCNcode>&leEnc=<ENCcode>&ccats=<CCA
TScode>&nlr=<T/F>

Replace <siteID> with your organization’s DNS name or the specific site ID supplied by Revenera, 
<systemFileID> with the system file ID, and <fileID> with the file ID. You find the system file ID and file ID 
on the View File page. For more information about the site ID, see FlexNet Operations Environments.

Replace <ECCNcode>, <ENCcode>, and <CCATScode> with the relevant export compliance codes. 
Replace <T/F> with the value selected for Restrict to US/CANADA (NLR). You obtain these values from 
the View Download Package page for the download package that is associated with the file that you 
want to make available.

5. Use the URL to make the file available to your customers. 

About Enabling Channel Partners to Download Files
A producer can enable a channel partner to download files, on behalf of end users, for product demonstration 
and support purposes.  

After the product is deployed and associated with a download package, the producer creates the channel partner 
user, creates an entitlement line item for the product for the channel partner user’s account, and assigns an end 
customer user account to the entitlement. 

Important • This option is limited to entitlements with end customer and channel partner user accounts. It does 
not work for entitlements with only channel partner users.

The channel partner user logs in to the FlexNet Operations End-User Portal with the line item’s activation ID, 
navigates to the List Entitlements page, and locates the entitlement in the table. From there, the file can be 
downloaded using the standard download procedure. 

About File Localization
Some aspects of a file can be localized: File Description, Extended Description, and Content Detail. To show the 
locale-specific fields for a localizable attribute, click Show Languages. 

About File Attributes
The following attributes apply to files, and are especially important when you are adding files or editing file 
information. 

Table 2-33 • 

Attribute Description

File ID A unique ID used to associate the file with its file image and with download 
packages.

System File ID A unique internal numeric identifier of the file.
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File Description The name of the file to be displayed to users in the End-User Portal (maximum 
500 characters). The file description is required when adding a new file. It 
should be brief but descriptive, for example, Enterprise Server 2.4 Solaris or 
Enterprise Server 2.4 Documentation.

Alias A read-only attribute that indicates if the current file is an alias of another file 
or if any aliases have been created for the current file. If aliases exist for the 
current file, their IDs are listed here. If the current file is an alias, the ID of the 
original file appears here. Click a file ID to go to the View File page for that file. 

Extended Description An optional attribute for providing additional information about the file 
(maximum 1000 characters).

Delivery Source Indicates if the file is an external source or uploaded to FlexNet Operations.

External Source If the External delivery source is selected, the URL where the file is located.

File Size (bytes) The file size in bytes. For files with a FlexNet Operations delivery source, this is 
automatically calculated and cannot be changed by the user. For files with an 
External delivery source, this field can be changed by the user either manually 
or using the calculator icon to automatically calculate the file size.

Note • The calculator icon only works on external sources that use either the 
HTTP or HTTPS protocols. Any other protocol returns a file size of 0.

MD5 CheckSum A 32-character hash algorithm used for validating data integrity. For files with 
a FlexNet Operations delivery source, this field is maintained by the 
Application and cannot be changed by the User. For files with an External 
delivery source, this field is manually entered by the user.

SHA2 CheckSum The 64-character hash algorithm used for validating data integrity. For files 
with a FlexNet Operations delivery source, this field is maintained by the 
Application and cannot be changed by the User. For files with an External 
delivery source, this field is manually entered by the user.

Execute Upon 
Download?

When selected, the FlexNet Embedded client will execute it as part of the 
software update download process.

Table 2-33 • 

Attribute Description
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File Name The name of the file image to be uploaded, for example filename.zip 
(maximum 255 characters). 

When you add a file, the file name is optional and, when the file image is 
uploaded, its filename overwrites any value in the File Name field. (The file 
name is required after a file image has been uploaded.) After the file image is 
uploaded, the file name can be edited to show a different file name to End-
User Portal users.

Non-ASCII characters are not allowed in the file name.

File Status A read-only attribute that shows the status of a file. A file’s status can be 

• Loaded—A file image has been uploaded for the file.

• Not Loaded—No file image is currently related to the file because no 
image has been uploaded or because the upload process has not 
completed. 

• Deleted—A previously uploaded file image has been deleted. (If you 
successfully upload a new file image, the file’s status changes to Loaded.)

Download Available The status of the download. 

• No—Download not available

• Yes—Download available.

Akamai Sync The status of the Akamai sync process. 

• No—Not synced.

• Yes—Akamai sync process complete.

Refresh the page to see the current status. 

Note: Sync times are affected by the size of the file, the load on Akamai 
servers, and the volume of Internet traffic. 

Owner A read-only attribute that shows whether or not your account is the owner of 
the file. (Files can be shared with other accounts, but only the file’s owner can 
change the file and only one account can be the owner.)

Restricted Indicates whether or not the file has any restrictions.

File Size The size of the uploaded file image in bytes. 

MD5 CheckSum The MD5 checksum value for the file.

SHA2 CheckSum The SHA2 checksum value for the file.

Last Uploaded The most recent date a file image was uploaded for the file.

Table 2-33 • 

Attribute Description
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Files can also have custom (Producer-defined) attributes. To learn more about custom attributes, including 
custom file attributes, see Administering Custom Attributes.

About Aliases
Aliases behave just like separate files after they have been created, with one exception: they always use the same 
file image as their original file. At creation time, an alias is a copy of the original file and includes its file 
associations and other file attributes. After it is created, any changes made to the alias apply only to the alias 
itself; they have no impact on the original file. Therefore, an alias can be altered to have attributes and download 
package associations that differ from the original file. However, all the aliases of a file share the file image of the 
original file. And if you change the file image uploaded for the original file, all that file’s aliases also use the new 
file image. (You cannot otherwise change the file image for an alias.) 

An alias can be edited, reidentified, aliased, restricted independently of its original file. Likewise, you can send 
notification emails specifically for the alias file. 

Note • When you choose Edit > Alias this File on the View File page of an alias, you create a new alias based on 
the current alias. This alias takes the attributes and associations of the current alias and uses the file image from 
the original file. 

When viewing files on the Producer Portal, notice that the Alias field in the file details indicates whether or not the 
file is an alias. 

• If a file is an alias file, the Alias field shows  Yes (Alias of System FileID <fileID>), where <fileID> is the 
system file ID for the original file. 

• If the file is an original, non-alias file, the Alias field shows one or more system file IDs. These file IDs are links 
to the file’s aliases. 

Note • For instruction on creating an alias, see Aliasing a File.

Last Retrieved From 
Location

The location from which the most recent file image upload originated.

Content Detail An optional attribute for additional details to be shown to End-User Portal 
users when they click the Content Detail expansion for this file. If the file image 
is a ZIP or JAR file, the zipinfo data is added to this field during the file image 
upload. 

If necessary, you can edit the information in Content Detail, after the file image 
has been uploaded, to change what End-User Portal users see when they 
expand the Content Detail. 

Table 2-33 • 

Attribute Description
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About File Restrictions
Producers can set up file restrictions to either permit or deny End-User Portal access to the file for the specified 
accounts. 

Note • By default, a file is unrestricted. If no restrictions are created for a file, it is accessible to all entitled 
accounts. 

Accounts can be added to the Restrict File list one at a time. The process starts with a search for the account to 
permit or deny access by its account ID or its account name. Search results are shown on the Find an Account 
page in a pop-up window. When you choose to restrict a previously unrestricted file, the Find an Account page 
provides the option of specifically permitting (Restrict Allow) or denying (Restrict Deny) access to the file for the 
selected account. For that file, any accounts you add to the restrictions list must follow the choice (Restrict 
Allow/Restrict Deny) you made for the first account. 

• Restrict Allow—Creates a file access “allow list” that stipulates the accounts that are permitted to access the 
file. Any account not on the list is not permitted to access the file in the End-User Portal, even if they are 
otherwise entitled to the product. 

• Restrict Deny—Creates a file access “block list” that stipulates the accounts that are not permitted to access 
the file. None of the accounts on the list are permitted to access the file in the End-User Portal, even if they 
are otherwise entitled to the product. 

Multiple accounts can be removed from the restrictions list on the Restrict File page by selecting their check 
boxes in the Remove this Account column and then clicking Remove Selected Accounts. 

Note • For instructions about restricting files, see Restricting a File.

Adding Files
The first step in making files available to your customers in the End-User Portal is to add the files to FlexNet 
Operations.

After a file is added, you can upload a file image and associate the file with one or more download packages. See 
Editing File Information and Managing File Associations for more information about the actions you can take once 
a file has been added.

Task To add a file

1. Click Products > Create File. This link opens the Add File page.

2. On the Add File page, enter file-related details for the file you want to add.

• File Description—(required) The name the End-User Portal displays for the file. Maximum length: 500 
characters.

• File ID—(required) Your account’s unique identifier for the file. Maximum length: 100 characters.

If External is selected as a Delivery Source, enter the following details:
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• External Source—(required) The URL for the externally sourced file.

• File Size (bytes)—(required) Enter a number or use the calculator icon to automatically calculate the file 
size.

Note • The calculator icon only works on external sources that use either the HTTP or HTTPS protocol. All 
other protocols will return a value of 0.

• MD5 CheckSum and/or SHA2 CheckSum—(required) At least one of these must be entered, though, 
optionally both may be.

Other fields are optional. For more information about file attributes, see About File Attributes. 

3. Complete the file addition process by clicking Save, Save and Add Another, or Save and Upload File.

• Click Save to add the file and upload the file image later. The Producer Portal saves the file and shows its 
View File page.

• Click Save and Add Another to save the current file and start adding a new download file. The Producer 
Portal saves the current file and resets the Add File page fields for new input.

• Click Save and Upload File to add the file and upload the file image. The Producer Portal saves the file 
and shows the Upload File page. See Uploading a File Image for file image upload instructions.

Searching for Files
Producers can use the file search feature to locate previously uploaded files on the Producer Portal. Files have a 
several attributes which you can use to locate the files you are interested in. Some of these searchable attributes 
include

• File ID—Unique value by which your company identifies individual files. The File ID may come from a release 
management or source code control system.

• System File ID—Unique identifier assigned by the Producer Portal when a new file object is created.

• File Description—A more descriptive name of the file. The File Description functions as the file name that 
users see on the End-User Portal download page.

• File Name—Actual system level name of the file. For example, installer_2_7.zip.

• File Status—You can search all files, files for which an image has been loaded, or files for which an image 
has not been loaded.

• Created in Date Range (Begin)—Specifies the start of the date range in which the file was created. Used in 
conjunction with Created in Date Range (End) to express the beginning date of that range. 

• Created in Date Range (End)—Specifies the end of the date range in which the file was created. Used in 
conjunction with Created in Date Range (Begin) to express the ending date of that range. 

• Last Uploaded (Begin)—Specifies the start of the date range in which the file was last uploaded. Used in 
conjunction with Last Uploaded (End) to express the beginning date of that range. 

• Last Uploaded (End)—Specifies the end of the date range in which the file was last uploaded. Used in 
conjunction with Last Uploaded (Begin) to express the ending date of that range. 
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Note • A file’s searchable attributes may also include the values for any custom file attributes you have defined. 
To learn more about custom attributes, including custom file attributes, see Administering Custom Attributes.

For more information about file attributes, see About File Attributes.

Tip • To return a list of all files, leave the search criteria blank and click Search. Empty searches match all files. 

Task To search for a file

1. Click Products > Search Files. The Search Files page opens. 

2. Enter your file search criteria and click Search. The Producer Portal shows a list of the files that match your 
search criteria on the Search Results: Files page.

From the Search Results: Files page, you can click: 

• Search Again to run another file search. 

• Export to export a set of files as a Data Import Template file (see Importing and Exporting Entities). 

• Upload files to upload the files to FlexNet Operations so they are available for your customers to 
download from the End-User Portal. 

3. Click the File ID for the file you want to view. 

The Producer Portal shows the View File page for the file you selected.

Note • The file search is not case sensitive and supports the use of the asterisk character as a wildcard. 
(Wildcards cannot be used for System ID values.)

Click on the file ID of a file to show its View File page. On a file’s View File page, you can

• View file details, restrictions, transactions, emails, and downloads. 

• Find all the products where this file is used (View > Where Used).

• Edit the file information.

• Upload a file (that is, upload the actual bits associated with this file object).

• Associate the file with one or more download packages.

• Associate the file with all the download packages to which some other file is associated. (For example, use 
Widget_2_1.ReadMe.txt wherever Widget_2_1.exe is found.)

See the table of topics in Managing Download Files for a list of tasks you can perform on a file. 
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Viewing File Information
Users typically search for a file they want to view and then click that file’s name to open the View File page. The 
View menu on the View File page includes several commands to get more details about the file, where it is used, 
how it has been managed, who it has been delivered to, and so on. With the commands in the View menu, you 
can perform the following tasks.

Viewing this File
When working with files, you can return to the basic View File page by clicking View this File. File-related 
operations might be checking where the file is used, associating the file to download packages, and so forth. On 
these file-related pages, View this File is a link in the View menu. 

The Producer Portal also shows the View File page when you add a file. 

Task To return to the basic View File page

• Click View > View this File. 

Viewing Where a File Is Used
You can display a list of the download packages that use a file from the View File page.

Table 2-34 • 

Topic Description

Viewing this File Explains how to return to the basic View File page when performing other file-
related operations. 

Viewing Where a File Is 
Used

Shows how to determine which products a file is associated with. 

Viewing File 
Restrictions

Describes how to view a list of accounts that are permitted or denied access to a 
file. Restricting file access to designated accounts is optional. By default, files are 
accessible to all entitled accounts. 

Viewing Emails Related 
to a File

Illustrates how to view email messages related to a file—email messages sent for 
products to which the current file is associated. 

Viewing File 
Transactions

Shows how to view transactions related to a file. 

Viewing File Downloads Explains how to view download activity for a file. 
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Task To view where the current file is used

• On the View File page, click View > View Where Used. 

The Producer Portal opens the Where File Used page. This page lists the download packages with which the file is 
associated. Clicking on the name of a download package in the list opens its View Download Package page.

Viewing File Restrictions
You can view a list of accounts that are permitted to access a file in the End-User Portal. Restricting file access to 
designated accounts is optional. By default, files are accessible to all accounts. 

Task To view file restrictions

• On the View File page, click View > View Restrictions. 

The Producer Portal opens the View File Restrictions page. Depending on how the file restrictions were specified, 
this page lists the accounts that are permitted or denied access to the current file. (File restriction lists can be 
lists of permitted or denied accounts.) 

If no accounts appear in the File Restricted To list, then the file is accessible by all accounts.

Viewing Emails Related to a File
You can view email messages sent for products to which the current file is associated. These messages appear in 
a list on the Search Results: Email page. The email messages are sorted from newest (most recently sent) to 
oldest.

Task To view emails related to a file

• On the View File page, click View > View Emails. 

The Producer Portal opens the Search Results: Email page. Email messages are shown in order of recency (most 
recently sent first). Click the System Email ID to show the View Email page for that email message. 

If no emails have been sent for products to which the current file is associated, the Producer Portal shows an 
error message that reports: No email messages found.

Viewing File Transactions
You can view transactions related to a file from the file’s View File page. These transactions, such as adding a file, 
associating it to a download package, and uploading its file image, appear in a list on the Search Results: 
Transactions page. 
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Task To view transactions related to a file

• On the View File page, click View > View File Transactions. 

The Producer Portal opens the Search Results: Transactions page. Transactions are ordered by date with the most 
recent Transaction first. Click on the System Transaction ID to open its View Transaction page. 

A transaction is recorded by the Producer Portal as users make changes to the system. File transactions are 
recorded for changes like adding a file or associating a file with a product. 

Viewing File Downloads
You can view download activity for a file from the file’s View File page. 

Task To view a downloads for a file

• On the View File page, click View > View Downloads. 

The Producer Portal opens the File Downloads page for the current file. The File Downloads page shows file 
details and lists the download history for that file. Each entry in the Download History list shows the date of the 
download, the account and user who downloaded the file, and the user’s email address, as well as the IP address 
where the file was downloaded, the country where the download request originated, and the download method 
used.

By default, the File Downloads page shows download activity within the last 180 days. 

Editing File Information
Users typically search for a file they want to view and then click that file’s name to open the View File page. The 
Edit menu on the View File page includes several commands for actions like altering, restricting, or creating a 
notification for an existing file. With the commands in the Edit menu, you can perform the following tasks. 

Table 2-35 • 

Topic Description

Editing a File Describes how to change a file’s details. 

Aliasing a File Shows how to create an alias of a file. In FlexNet Operations, an alias for a file uses 
the same file image as an existing file but has its own meta data. 

Uploading a File Image Explains how to upload a file image for an existing file.

Deleting a File Image Explains how to delete a file image.

Reidentifying a File Discusses how to reidentify a file to change the file ID of an existing file. 

Restricting a File Explains how to restrict access to a file for designated accounts.
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Editing a File
You can edit file details from the View File page. Most of the file information that you enter when you add a file 
can be edited on the Edit File page. 

Some commonly edited file details include

• File Description—(required) The name of the file that End-User Portal users see. It should be brief but 
descriptive, for example, Enterprise Server 2.4 Solaris or Enterprise Server 2.4 Documentation.

• File Name—(required) The name of the file as it will appear in the Producer Portal. Please note that during 
the upload of a file whose delivery source is FlexNet Operations, this field is overwritten with the name of the 
file that is being uploaded.

• Content Detail—Additional information that is displayed when the end user clicks the + to see additional file 
information in the End-User Portal. If the file is a ZIP or JAR file, the Producer Portal automatically sets 
Content Detail to the file’s zipinfo during the file upload process. 

If the Delivery Source is External, several additional fields are displayed:

• External Source —(required) The URL where the file is located

• File Size (bytes)—(required) The size of the file. This can be manually entered or calculated using the 
calculator icon.

Note • The calculator icon only works on external sources that use either the HTTP or HTTPS protocols. Any 
other protocol will return a file size of 0.

• MD5 CheckSum—(required if SHA2 CheckSum is empty) A 32-character hash algorithm for validating data 
integrity.

•  SHA2 CheckSum—(required if MD5 CheckSum is empty) A 64-character hash algorithm for validating data 
integrity.

Either MD5 or SHA2 CheckSum is required for externally sourced files. Optionally, both can be populated.

Note • A file’s editable attributes may also include the values for any custom file attributes you have defined. To 
learn more about custom attributes, including custom file attributes, see Administering Custom Attributes.

Many attributes support localization. For localizable attributes, click Show Languages to reveal additional, locale-
specific fields for those attributes.

For more information about file attributes, see About File Attributes. 

Creating an Email 
Notification for a File

Describes how to create an email notification for a file. 

Table 2-35 • 

Topic Description
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Task To edit file details

1. On the View File page, click Edit > Edit this File. This link opens the Edit File page for the current file. 

2. Make your changes to one or more file details. 

3. Click Save. 

The Producer Portal saves your changes and returns to the View File page for the current file. 

Tip • Some file details, such as Alias, File Status, Owner, Restricted, and File ID cannot be altered on the Edit File 
page. To change a file’s ID, you must reidentify the file. To change a whether a file is restricted you must use the 
Restrict File page (Edit > Restrict). To create an alias for the current file, use Edit > Alias this File. 

Aliasing a File
You can create an alias of an existing file from the file’s View File page. In FlexNet Operations, an alias for a file 
uses the same file image as an existing file but has its own attributes. Initially, the file ID, file description, and 
other attributes are copied from the current file. 

The main benefit of creating an alias is that you can maintain a separate file, with its own description, 
restrictions, and download package associations, without the need to upload redundant file images.

Task To add a file alias

1. On the View File page, click Edit > Alias this File. This link opens the Add File Alias page. 

2. Edit the details for the file alias. The File ID must be unique; hence, you must at least provide a different File 
ID.

3. Click Save. 

The Producer Portal adds the file alias and opens the View File page for the file alias. 

Note • The Alias field value is Yes (Alias of System FileID <fileID>), where fileID is the system file ID for the 
original file (the file on which this file alias was based). If you want to view or make changes to the original file, 
click its system file ID.

Uploading a File Image
You can upload a file image for an existing file. During the upload process, you select a file from your local file 
system to upload it to the Producer Portal. 

Note • Uploaded files cannot be downloaded until the Download Available? field of the View File page indicates 
Yes. This action is only available when the delivery source is FlexNet Operations.
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Task To upload a file image

1. On the View File page, click Edit > Upload File. This link opens the Upload File page. 

2. On the Upload File page there are four upload options. Select the tab for the option you want to use and do 
the following:    

Note • For MD5 checksums, the value must be a 32 character hexadecimal value. When you enter a value in 
this field, the Producer Portal checks that the file it received has the same checksum as the value you enter.

The Producer Portal initiates the file image upload process and returns to the View File page for the current file. 
Once the upload is complete and successful, the file is available for end users to download (provided the file is 
properly associated to products and download packages to which the end user is entitled).

Upload Option Procedure

HTTP Upload 1. Click Browse and navigate to the file located on your PC to upload. (The 
user experience varies depending on the web browser you are using.) The 
Producer Portal shows the name of the upload file.

2. Optionally, type the expected MD5 checksum value. 

3. Click Upload. 

FTP Upload 1. Click Browse to select a file that has been uploaded to the Revenera FTP 
Server. A window appears with the list of files that are available. Select the 
box of the desired file.

2. Optionally, type the expected MD5 checksum value. 

3. Click Upload. 

Remote FTP Server 1. Enter the FTP Hostname, Username and Password as well as the path and 
filename of the file located on the remote FTP server.

2. Optionally, type the expected MD5 checksum value. 

3. Click Upload. 

High Speed Upload 1. Click Upload to select a file on your PC to begin a high-speed upload.

Note • You must have the Aspera Connect high-speed plug-in to use this 
option. If it is not already installed on your computer, click the link on the tab to 
access the download file.

2. Optionally, type the expected MD5 checksum value.
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Note • It is possible to upload files without using the Producer Portal. For example, files can be uploaded via web 
services to automate the process or upload files into FlexNet Operations from your account’s system.

Deleting a File Image
You can delete a file image previously uploaded for a file from the file’s View File page. 

Note • This action is only available when the delivery source is FlexNet Operations.

Task To delete a file

1. On the View File page, click Edit > Delete File Image. This link opens the Delete File Image page. 

2. Click Delete. 

The Producer Portal deletes the file image and returns to the View File page for the current file. 

Reidentifying a File
You can change the file ID of an existing file from that file’s View File page. 

A file might have to be reidentified if it was entered in error, or if your account wants to change its file ID naming 
conventions. 

Task To reidentify a file

1. On the View File page, click Edit > Reidentify. This link opens the Reidentify File page. 

2. In the File ID field, type a new file ID value. 

3. Click Reidentify.

The Producer Portal changes the file ID of the current file and returns to the file’s View File page. Other file details 
are preserved, including relationships with the original file’s aliases as well as its associated download packages.

Restricting a File
You can restrict access to a file in the Producer Portal for the users of designated accounts. Files are not 
restricted by default. When you restrict access to a file, you use a search function to locate and identify the 
account for which you want to grant or deny file access. 

Note • When no accounts are listed on a file’s Restrict File page, access to the file is not restricted. See About File 
Restrictions for more information about how the file restriction process works.
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Task To set file restrictions

1. On the View File page, click Edit > Restrict. This link opens the Restrict File page.

2. Type search criteria and click Search Accounts. The Producer Portal opens the Find an Account page in a 
pop-up window. This page shows a list of accounts that match your search criteria.

3. On the Find an Account page, click Restrict Allow or Restrict Deny for an account. 

• If you choose Restrict Allow, only the accounts you choose are permitted to access the file. 

• If you choose Restrict Deny, the accounts you choose are expressly denied access to the file. 

The Producer Portal closes the Find an Account window and returns to the Restrict File page. 

The Restrict File page shows the account you chose in the Accounts Restricted to File list. 

Tip • To remove an account from the Accounts Restricted to File list, select the account’s check box in the 
Remove this Account column and then click Remove Selected Accounts.

Creating an Email Notification for a File
You can create an email notification for the download packages that include the current file. (You cannot create 
an email notification for a file that is not associated with a download package.) 

Task To create a notification email for a file

1. On the View File page, click Edit > Notify. This link opens the Create Notification Email by File page, which 
lists the download packages with which the file is associated.

2. In the Download Packages and Files list, select the check box for the download packages for which you want 
to create the notification email. 

3. Click Create. The Create Notification Email by File page shows Distribution List Options and Choose an Email 
Template sections. 

4. Set Distribution List Options for the notification email message.

Setting Description

Effective Date The first date (inclusive) that this email notification is available to entitled end 
users.  

Include Expired 
Entitlements

Determines whether or not to include expired entitlements in the distribution 
list. By default, only users with active entitlements are included in the 
distribution list.
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5. Choose an Email Template variation for this message. 

File notification messages use the Update Notification Email template. Select any active variation of that 
template for the file notification message. 

Tip • You can manage your email templates in the Producer Portal. For more information about email 
templates, see Managing Email Templates. 

6. Click Create. The Producer Portal creates the email message for the files you specified, uses the settings you 
provided, and shows the View Email page.

7. On the View Email page, click Edit > Send Email. The Producer Portal opens the Send Email page. 

8. On the Send Email page, choose to send the email or schedule its delivery. 

• To send immediately, click Send. 

Download Status Limits message delivery according to whether the file has been downloaded: 

• All users—Deliver to all entitled users regardless of whether they have 
downloaded the file.

• Users with Download Activity—Deliver to entitled users who have 
downloaded the file.

• Accounts with Download Activity—Deliver to entitled users who are part 
of an account in which at least one user has downloaded the file.

Exclude Email Filters Allows you to identify specific email addresses or email address ranges to 
exclude from the distribution list. For a single address, type the address in the 
space provided. For multiple addresses, add a comma-separated list of email 
addresses in the space provided. Use an asterisk as a wildcard to exclude 
ranges of email addresses. For example, *@yourdomain.com, *.edu.

Limit to Countries Restricts the delivery of notifications to countries identified by their two-
character country code. Use a comma-separated list of country codes to 
permit delivery to multiple countries. For example, specifying US,FR permits 
notification delivery to users in the United States and France.

When no country codes are specified, FlexNet Operations places no 
notification delivery restrictions based on the recipient’s country.

Send Separate Email for 
Each Download Package

Determines whether to send a single message for all download packages 
(when multiple download packages have been selected) or to send a separate 
message for each download package. 

Send Email Immediately Determines whether the message is sent as soon as it is created or sent later. 
By default, Send Email Immediately is not selected, and email notifications are 
queued for sending. If you select this check box, the Producer Portal sends the 
message as soon as you click the Create button. Do not use this option if you 
want to modify the message before it is sent.

Setting Description
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• To schedule delivery for a later date, 

1. Click Queue to be sent at. 

2. Set the Send Date. 

3. Specify the Send Time (24-hour format). 

4. Click Send.

The Producer Portal sends the email notification. 

Note • For more information about managing email messages and email templates, see Managing Email and 
Email Templates.

Managing File Associations
The files you add to the Producer Portal can be associated with or disassociated from download packages on the 
file’s View File page. 

Users typically search for a file they want to view and then click that file’s name in the search results to open the 
View File page. The Associate menu on the View File page includes commands for adding and removing file-
download package associations. With the commands in the Associate menu, you can perform the following tasks. 

About File Associations
A file can be associated with multiple download packages or with none at all. A file only appears in the End-User 
Portal within the download packages with which it has been associated. Therefore, you can control the visibility 
of a file and your customers’ access to it (in part) by managing the file’s associations with your download 
packages.

Table 2-36 • 

Topic Description

About File Associations Discusses the relationships you can create between files, download packages, and 
products and addresses the use of Associate Where in more detail.

Associating a File to 
Download Packages

Explains how to build relationships between a file and one or more download 
packages by specifying the download packages to associate with the file. 

Using Associate Where 
to Copy Associations 
from Another File

Explains how to build relationships between a file and one or more download 
packages by copying the download package associations from one or more other 
files.

Disassociating a File 
from a Download 
Package

Explains how to remove a previously built relationship between a file and one or 
more download packages.
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You can manage a file’s download package associations from the file’s View File page. There, you can see which 
download packages a file is associated to, make new associations, or remove existing associations. Use the 
following commands on the View File page: 

• View > View Where Used—To see existing download package associations. See Viewing Where a File Is Used. 

• Associate > Associate to Download Packages—To make new download package associations. See 
Associating a File to Download Packages.

• Associate > Associate Where—To make download package associations that match the associations from 
one or more existing files. See Using Associate Where to Copy Associations from Another File. 

Persistence of Associations
A file’s download package associations remain even if the file is edited, reidentified, or if its file image is deleted. 

Aliases behave just like separate files after they have been created with one exception: they always use the same 
file image as their original file. At creation time, an alias is a copy of the original file and includes its file 
associations and other file attributes. After it is created, any changes made to the alias apply only to the alias 
itself; they have no impact on the original file. Therefore an alias can be altered to have download package 
associations that differ from the original file. 

The Association Where Command
Typically, simple download package associations can be quickly defined using the Associate to Download 
Packages command—explicitly specifying one or more download packages. In some cases, though, it may be 
cumbersome to itemize all the download packages to which you want this file associated. Associate Where is a 
shortcut that copies the download package associations of another file. That is, the Producer Portal associates 
the current file with all the download packages with which another file is already associated. 

Associating a File to Download Packages
You can associate a file to one or more download packages from the file’s View File page. The download 
packages to which you associate the file can be identified by their download package IDs, their system IDs, or 
located via a download package search. 

Note • If your existing files have the same download package associations you want to make for the current file, it 
may save time to use the Associate Where command instead. See Using Associate Where to Copy Associations 
from Another File.

Task To associate a file to download packages

1. On the View File page, click Associate > Associate to Download Packages. This link opens the Associate File 
to Download Packages page.

2. Identify the download packages to associate. Choose whether to enter download package IDs or to search 
for download packages: 

• Enter download package IDs when you already know the download package IDs or system download 
package IDs of the download packages you want to associate. 
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a. In the Download Package IDs field, type the download package IDs as a comma-separated list or 
enter them one per line. Note: If you enter system IDs, remember to select the Use System IDs check 
box.

b. Click Associate Download Packages.

• Search for download packages by entering search criteria if you do not know the IDs of the download 
packages you want to associate.

a. Type your search criteria into the download package search fields. 

b. Click Search. The Producer Portal shows a list of download packages that match your criteria.

c. Select the download packages to associate and click Associate File to Selected Download 
Packages.

The Producer Portal creates associations between the current file and the download packages you identified and 
opens the Where File Used page for the current file. 

Using Associate Where to Copy Associations from Another File
You can use the Associate Where command to quickly build associations between a file and a number of 
download packages by copying the associations of one or more existing files. 

When you click Associate Where, the Producer Portal shows a file search page. If you know the IDs of the files 
from which you want to copy associations, you can enter them manually. If not, you can search for them based on 
their file attributes. (You can use an asterisk as a wildcard to search for and select the files from which to copy 
download package associations.) 

Task To associate a file with another file’s download packages

1. On the View File page, click Associate > Associate Where. This link opens the Associate this File to Download 
Packages Where Other Files Are Found page.

2. Identify the files from which to copy download package associations. Choose whether to enter file IDs, 
directly, or to search for files: 

• Enter file IDs when you already know the file IDs or system file IDs of the files from which you want to 
copy associations.

a. In the File IDs field, type the file IDs as a comma-separated list or enter them one per line. Note: If 
you enter system file IDs, remember to select the Use System IDs check box.

b. Click Associate.

• Enter file search criteria if you do not know the IDs of the files you want to associate.

a. Type your search criteria into the file search fields. 

b. Click Search. The Producer Portal shows a list of files that match your criteria.

c. Select the download packages to associate and click Associate to Download Packages of Selected 
Files.
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The Producer Portal creates associations based on the download package associations of the files you identified 
and opens the Where File Used page for the current file. All download packages associated with the files you 
identified are now also associated with the current file.

Note • The Associate Where function updates all download packages that contain the files you identified. 

Disassociating a File from a Download Package
You can remove associations between a file and one or more download packages from the View File page. You 
might need to disassociate a file from a download package to replace it with a new version of the file for a hotfix 
or to correct a file-download package that had been made in error.

Note • Remember that a file must be associated with a download package for it to appear in the End-User Portal. 
Therefore, you can effectively cease distribution of an existing file by disassociating it from all download 
packages. 

Task To disassociate a file from a download package

1. On the View File page, click Associate > Disassociate from Download Packages. This link opens the 
Disassociate this File from Download Packages page.

2. Choose the download packages to disassociate and click Disassociate from Selected Download Packages.

The Producer Portal removes associations from the selected download packages and refreshes the Disassociate 
this File from Download Packages page to show the current file-download package associations, if any.

Tip • If a file is associated with multiple download packages and you intend to remove all download package 
associations, you can skip the step in which you choose the download packages and just click Disassociate from 
All Download Packages.

Managing License Agreements
Producers can use the Producer Portal to create license agreements to show to their users in the End-User Portal. 
On the End-User Portal, users must accept the terms of the agreement before they are permitted to access your 
download packages.

Tip • For the instructions in this section, it is expected that you are working on the Producer Portal with sufficient 
privileges/permissions to perform the tasks described.
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End-user license agreements (EULAs) can be defined by Producer Portal users and are related to product lines 
and download packages. A license agreement commonly contains content supplied by your legal department. 
End-users are prompted to agree to the terms before proceeding to the download page. The agreement is an 
attribute of a download package.

About Agreements
In FlexNet Operations, producers can add agreements that can be tied to one or more download packages.

A click-through or end-user license agreement (EULA) commonly contains content supplied by your legal 
department. The license agreement is an optional attribute of a download package.

In the Producer Portal, producers add agreements by providing an agreement name and the content for the 
agreement text. (The agreement content can be plain text or HTML.) Then, the agreement can be linked to a 
download package on the Edit Download Package page.

When an agreement is connected to a download package, the End-User Portal prompts users to agree to the 
terms of that agreement before proceeding with the download. 

Note • Once created, a license agreement cannot be deleted. To ensure an existing license agreement is not 
shown in the End-User Portal, you must remove any references to it in your download packages. (On the Search 
Download Packages page, you can search for download packages by their license agreement.)

Listing Agreements
You can show a list of your account’s agreements in the Producer Portal. 

Task To list agreements

• Click Products > List Agreements. 

The Producer Portal shows a list of agreements in a table. There you can see the agreement’s ID and name. Click 
an agreement ID to see its View Agreement page. 

Table 2-37 • 

Topic Description

About Agreements Discusses agreements and their use in FlexNet Operations.

Listing Agreements Shows how to list your account’s agreements. 

Creating an Agreement Explains how to add an agreement to FlexNet Operations. 

Viewing an Agreement’s 
Transactions

Describes how to display a transaction history list for a selected agreement.

Editing an Agreement Shows how to change an agreement’s name or content. 
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Creating an Agreement
You can create an agreement, such as an end-user license agreement (EULA) or a support agreement, on the 
Producer Portal.

Task To create an agreement

1. Click Products > Create Agreement. This opens the Add Agreement page. 

2. Type an Agreement Name. 

3. Type the content for the agreement in Agreement Content. 

Note • The Producer Portal accepts HTML content and plain text as input for Agreement Content. 

4. Click Save.

The Producer Portal saves the agreement. This agreement is now available for use in download packages. 

Viewing an Agreement’s Transactions
You can see the transaction history of an agreement from its View Agreement page. Transactions are recorded 
when an agreement is created or edited. 

Task To view transactions related to an agreement

• On the View Agreement page, click View > Transactions. 

The Producer Portal opens the Search Results: Transactions page with a list of all the transactions that have 
occurred for the current agreement. You can view details about a listed transaction by clicking its transaction ID. 

Editing an Agreement
You can change the name of an existing agreement on its View Agreement page. 

Task To edit an agreement

1. On the View Agreement page, click Edit > Edit this Agreement. This opens the Edit Agreement page.

2. Edit the Agreement Name. 

3. Click Save.

The Producer Portal saves the agreement with the new name you provide. The agreement name is the display 
name shown to your users in the End-User Portal.
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Managing Producers
Producers can be created, modified, deactivated, and reactivated on the Producer Portal. The following topics 
provide information about producers and instructions on how to manage them. 

About Producers
A producer typically identifies an account that creates the software presented for download on the End-User 
Portal. You can create any number of producers your account requires. To facilitate the creation of download 
packages, you must have at least one producer, as it is a required attribute of download packages. 

Many companies only use a single producer. Others use the Producer attribute to distinguish between different 
product groups or families. When you click List Producers in the Products menu, the Producer Portal displays a 
list of all the producers your account has created. Click a producer name to view the producer information, and if 
necessary, modify it.

On the End-User Portal, the producer acts as the top level category for the files your users can download. Users 
who are entitled to products of more than one producer see a list of producers when they look for downloads. For 
example, users who click Downloads > List All in the End-User Portal must first choose from a list of producers 
and then from a list of product lines and then product versions to show a list of download packages. So, in normal 
situations, the producer serves only as a method of grouping products, download packages, and files for display 
on the End-User Portal.  

Listing Producers
You can show a list of producers on the Producer Portal.

Table 2-38 • 

Topic Description

About Producers Discusses how producers are used in the Producer Portal and how they appear to 
End-User Portal users. 

Listing Producers Shows how to display all producers.

Creating a Producer Explains how to add a producer. 

Viewing a Producer’s 
Transactions

Explains how to view the transaction history of a selected producer. 

Editing a Producer Describes how to change a producer’s name. 

Reidentifying a 
Producer

Describes how to use the Reidentify command to change a producer’s ID.

Deactivating a Producer Shows how to change an active producer’s status to Inactive. 

Reactivating a Producer Shows how to change a deactivated producer’s status back to Active.
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Task To list producers

• Click Products > List Producers. 

The Producer Portal shows a list of producers in a table. There you can see the producer’s ID, name, and status. 
Click a producer ID to see its View Producer page. 

Creating a Producer
You can create a producer on the Producer Portal. 

Task To create a producer

1. Click Products > Add Producer. This opens the Add Producer page. 

2. Type a Producer ID. 

3. Type a Producer Name. This value is what the End-User Portal shows to your users when they are choosing 
among producers. 

4. Click Save.

The Producer Portal saves the producer with the ID and name you provide and shows the List Producers page. 
This producer is subsequently available as an option for setting a producer when you create or edit a download 
package. 

Note • New producers are automatically set to Active status. 

Viewing a Producer’s Transactions
You can see the transaction history of a producer from its View Producer page. Transactions are recorded when a 
producer is created, edited, or reidentified, and when its status is changed. 

Task To view transactions related to a producer

• On the View Producer page, click View > Transactions. 

The Producer Portal opens the Search Results: Transactions page with a list of all the transactions that have 
occurred for the current producer. You can view details about a listed transaction by clicking its transaction ID. 

Editing a Producer
You can change the name of an existing producer on its View Producer page. 
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Note • You cannot change the producer ID on the Edit Producer page. To change the ID value, you must use the 
Reidentify command. See Reidentifying a Producer.

Task To edit a producer

1. On the View Producer page, click Edit > Edit this Producer. This opens the Edit Producer page.

2. Edit the Producer Name. 

3. Click Save.

The Producer Portal saves the producer with the new name you provide. The producer name is the display name 
shown to your users in the End-User Portal.

Reidentifying a Producer
Reidentifying a producer is how you change its producer ID. This is a separate process from editing a producer. 

Task To reidentify a producer

1. On the View Producer page, click Edit > Reidentify. This opens the Reidentify Producer page.

2. Edit the Producer ID. 

3. Click Reidentify.

The Producer Portal saves the producer with the new ID value you provide and shows the List Producers page.

Deactivating a Producer
You can deactivate an active producer from its View Producer page. All newly created producers start out with 
Active status. 

Task To deactivate a producer

1. On the View Producer page, click Edit > Inactivate. This opens the Inactivate Producer page. 

2. Click Inactivate.

The Producer Portal changes the producer’s status to Inactive. 

Reactivating a Producer
You can reactivate an inactive producer from its View Producer page. 
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Task To reactivate a producer

1. On the View Producer page, click Edit > Reactivate. This opens the Reactivate Producer page. 

2. Click Reactivate.

The Producer Portal changes the producer’s status to Active. 
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Entitling Customers and 
Activating Licenses

This section describes how to entitle customers to licenses and activate licenses. 

Entitling Customers to Licenses
Entitling a customer to a license is the process of a software producer giving a customer account the right to 
obtain a license for a product: 

• Identifying the customer account that is entitled to the product licenses

• Adding products for which the account is entitled to obtain licenses

• Associating an order ID and line item on that order with an entitlement line item (optional)

• Specifying values for license model attributes that are set at entitlement time 

This section includes the following main topics. 

Table 3-1 • 

Topic Description

Entitling Customers to 
Licenses

Defines entitlement terms and explains how to view entitlements, create 
entitlements, manage bulk operations, merge entitlements, and transfer 
entitlements.

Activating Licenses Defines activation terms and describes how to view entitlements to activate, email 
entitlement line items, activate licenses, transfer entitlement line items, email 
licenses, perform manual activations, and manage short code activations.

Table 3-2 • 

Topic Description

Entitlement Terms Defines terms related to entitlement. 
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Entitlement Terms
The following terms are referred to when entitling customers to licenses:

• What is an Entitlement?

• What is an Entitlement Line Item?

• What is an Upgrade?

• What is a Test Upgrade?

• What is an Upsell?

• What is a Test Upsell?

• What is a Renewal?

• What is a Test Renewal?

• What is a Merge?

• What is a Transfer?

Viewing Entitlements Describes how to view entitlements.

Creating an Entitlement Explains how to create an entitlement and configure entitlement line items and 
maintenance line items.

Creating a Bulk 
Entitlement

Describes how to create a bulk entitlement, configure a bulk entitlement line item, 
and manage web register keys.

Bulk Operations: 
Upgrade, Upsell, or 
Renew a Product

Discusses bulk upgrades, upsells, and renewals.

Emailing Bulk Operation 
Notifications

Describes how to initiate the sending of email notifications for bulk operations.

Merging Entitlements Explains how to merge entitlements.

Transferring 
Entitlements

Explains how to transfer entitlements.

Viewing Fulfillment 
History

Describes how to view fulfillment history of a line item.

Viewing Entitlement 
History

Describes how to view the transaction history of an entitlement.

Table 3-2 • 

Topic Description
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What is an Entitlement?
An entitlement represents your customers’ rights to use your software. An entitlement acts as a container for the 
licenses purchased in a single order. It is analogous to a bank account: an entitlement contains rights to one or 
more licenses, and the customer can redeem licenses from or return licenses to this account. The figure below 
depicts the relationships among entitlements, customers, and line items. 

Entitlements are created through the Producer Portal or imported using the Entitlement Order Web service. 
Entitlements are associated with: 

• Multiple tiers of an account

• One or more products

What is an Entitlement Line Item?
Each line item in an entitlement is an activatable unit and has an activation ID. 

The details of an entitlement line item specify the product and its options, the quantity, and the duration of the 
license rights; for example, “15 copies of MyApplication and selected options for two years.”

What is a Bulk Entitlement?
A Bulk Entitlement can be created when licenses are distributed through a reseller or channel. The producer 
creates a bulk entitlement for a single product and generates one or more Web register keys that each provides 
rights to one or more licenses. The reseller then gives one or more Web register keys to the consumer that 
purchases the software.
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The consumer registers the software with the producer or manufacturer using the Web register key. This allows 
software producers and device manufacturers to track two pieces of information:

• who purchased the bulk entitlement (the reseller)

• who registered the license (the consumer)

In addition, the reseller can access the End-User Portal to view the bulk entitlements that they purchased, the 
Web register keys for these bulk entitlements that have not yet been allocated, and the Web register keys that 
were registered from these bulk entitlements.

What is an Upgrade?
A product is upgraded when a customer replaces an older version of the product with a newer version, such as 
moving from MyProgram Version 4.5 to MyProgram Version 5.0. The figure below depicts an upgrade of Product 
A from version 1.0 to version 2.0. 

To enable an upgrade in the Producer Portal, both versions of the product must have been added, and a 
relationship between them (such as Upgrade To or Upgrade From) must be defined on the Relate to Different 
Products page. Then, go to the Entitle Customers page and select Upgrade or Test Upgrade.

Tip • FlexNet Operations can automatically create upgrade line items for qualifying products and line items with 
the Product Version Upgrade job. See FlexNet Operations Alert Types.

What is a Test Upgrade?
A test upgrade can be created using a draft product and draft license models for testing purposes. It remains in 
TEST state only. A test upgrade lets software producers and device manufacturers ensure that the products, 
license models, and relationships are defined properly before deploying them into production. 

To enable a test upgrade in the Producer Portal, both versions of the product must have been added, and a 
relationship between them (such as Upgrade To or Upgrade From) must be defined on the Relate to Different 
Products page. You can then open the Entitle Customers page and upgrade the entitlement line item.
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Tip • FlexNet Operations can automatically create upgrade line items for qualifying products and line items with 
the Product Version Upgrade job. See FlexNet Operations Alert Types.

What is an Upsell?
A product is upsold when a customer replaces the product with another product that provides a superset of the 
original’s functionality, such as moving from the MyProgram Standard Edition to the MyProgram Professional 
Edition. The figure below depicts an upsell of Product A version 1.0 to Product B version 1.0. 

To enable an upsell in the Producer Portal, both “editions” of the product must have been added, and a 
relationship between them (such as Upsell To or Upsell From) must be defined on the Relate to Different 
Products page. 

What is a Test Upsell?
A test upsell can be created using a draft product and draft license models for testing purposes. A test upsell 
operation enables software producers and device manufacturers to ensure that the products, license models, 
and product relationships are defined correctly before deploying them into production. To define a test upsell 
entitlement, you can use draft products and license models. 

To enable a test upsell in the Producer Portal, both “editions” of the product must have been added, and a 
relationship between them (such as Upsell To or Upsell From) must be defined on the Relate to Different 
Products page. 

What is a Renewal?
A renewal is used when you want to extend the expiration date of a product’s original entitlement, or its version 
date, to a date further in the future. It is not necessary to define a relationship for a renew operation because the 
product involved does not change. 
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What is a Test Renewal?
A test renewal can be created for testing purposes. A Test Renewal operation lets software producers and device 
manufacturers use draft products and license models to renew entitlements. This ensures that products and 
license models are defined correctly before deploying them into production. It is not necessary to define a 
relationship for a renew operation because the product involved does not change. 

What is a Merge?
If Company A acquires Company B and wants to move all license entitlements, fulfillments, and users belonging 
to Company B over to Company A, a Merge is used. Mergers of company license assets can be accomplished 
using the FlexNet Producer Portal and Web services. 

What is a Transfer?
If a company spins off a division and sets up a separate company, it can transfer some of its license entitlements 
to the new company by using the Transfer facility in the Producer Portal. Using Web services and the Producer 
Portal, the producer can transfer the entitlement, or one line item of an entitlement, to the new company. 
However, an entitlement can be transferred only if there are no active fulfillments against any of its line items. 
Unfulfilled copies of a line item can be transferred to a different company or entitlement. 

Viewing Entitlements
The List Entitlements by Order page displays entitlements. To view all entitlements, select Entitlement ID from 
the Search for drop-down, and click the Simple Search icon. You can also search for entitlements based on 
specific criteria by

• Specifying some particular values in the simple search, like Entitlement ID Starts With

• Clicking Advanced Search, which lets you specify multiple search attributes.

Tip • When an entitlement has been upgraded, upsold, or renewed, the Map Entitlements page shows only the 
most recent entitlement in its lifecycle chain. Earlier entitlements are grouped under the most recent entitlement 
but initially hidden. These entitlement groups have a Show Upgrades button to reveal earlier entitlements in the 
list. 

From this page, you can:

Table 3-3 • Viewing Entitlements

Action Description

Edit an entitlement To edit an entitlement, click its entitlement ID. This opens the entitlement’s 
Create an Entitlement (or Create a Bulk Entitlement) page.

Add a new entitlement To add a new entitlement, click Add > Add entitlement.

Add a new bulk entitlement To add a new bulk entitlement, click Add > Add bulk entitlement.
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Copy To create a copy of an entitlement, select one entitlement and click Add > 
Copy. A new entitlement is created. Copies of all line items in the selected 
entitlement are also created.

Transfer To transfer an entitlement to a different company, select the entitlement and 
click Transfer.

Change the state of an 
entitlement 

To change the state of one or more entitlements, select the entitlements, 
click the Change state drop-down, and select a state. Entitlements can be in 
one of the following states: Draft, Deployed, Test, Inactive, or Obsolete.

• Draft: Draft entitlements can be created only from deployed products 
and suites. 

• Deployed: Deploying a draft entitlement automatically deploys all line 
items on the entitlement and allows the line items to be activated, 
upgraded, upsold, or renewed. Line items added to a deployed 
entitlement must be manually deployed before they can be activated.

• Inactive: If an entitlement is made inactive, all of the line items in the 
entitlement are made inactive and cannot be activated, upgraded, 
upsold, or renewed. Existing fulfillments against an inactive line item 
cannot be returned, repaired, or rehosted. 

• Obsolete: An entitlement can be made obsolete if it is no longer required 
or it was created and deployed in error. An obsolete line item cannot be 
fulfilled. Fulfillments of an obsolete entitlement line item cannot be 
rehosted. 

• Test: Test entitlements cannot be changed to any other state. They can 
be created from draft products and suites. Test entitlement line items 
can be activated, upgraded, upsold, renewed, or deleted. Test 
fulfillments created from test entitlements can be returned, repaired, 
rehosted, and deleted. 

Note • An entitlement that has been activated on a device can have its state 
changed to Inactive or Obsolete only if the configuration option Allow used 
entitlement/line item state change to Inactive or Obsolete is selected. 

When this configuration option is selected, an entitlement or line item that 
has been activated on a device can still be used until the license expires, 
even if the entitlement or line item has been deactivated or made obsolete.

For more information, see General Options in Configuring System Settings.

Activate licenses for an 
entitlement 

To activate licenses for an entitlement, select the entitlement and click 
Activate. The activatable line items on the entitlement are displayed. 

Table 3-3 • Viewing Entitlements

Action Description
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Creating an Entitlement 
In the Entitle Customers view, you can create a new entitlement or test entitlement. 

Test entitlements allow testing of draft products and license models before they are deployed. All entitlement 
actions can be performed on test entitlements, but test entitlements cannot be moved to any other state. When a 
test entitlement is deleted, any fulfillments against it are also deleted. (The fulfillment records in FlexNet 
Operations are deleted; however, any client-side fulfillment records created in trusted storage as a result of the 
activation of a test entitlement cannot be deleted.) 

Task To create a new entitlement

1. Click Entitlements > Create. This link opens the Create an Entitlement page. (Click Entitlements > Create 
Test to create a test entitlement.)

2. Required fields are indicated by a red asterisk. Provide values for the following fields:

Delete an entitlement To delete an entitlement, select one or more entitlements and click Delete. 

Export entitlement(s) To export an entitlement or entitlements, click Export and select an export 
option from the drop-down menu. 

Options displayed on the drop-down menu are controlled by a user’s Export 
and Import permission. Users without Export and Import permission see only 
data export options with low impact, such as Selected Items, on an entity’s 
Export drop-down menu. Users with Export and Import permission see the 
complete list of data export options, including those with high impact, such 
as All Items.

Print an entitlement To print an entitlement, select one or more entitlements and click Print. 

Table 3-4 • Creating an Entitlement Fields

Field Description

Entitlement ID The entitlement identifier uniquely identifies the entitlement. Select Auto 
Generate to let FlexNet Operations assign an entitlement ID, or select Specify 
to enter an entitlement ID of your choice.

If the entitlement is in the draft or test state, you can regenerate the activation 
IDs of draft line items or the entitlement ID by clicking Regenerate IDs. 

If the IDs are based on characteristics of the entitlement that were not set 
when the entitlement was created, you can use Regenerate IDs to regenerate 
these IDs after you have set the characteristics. 

Table 3-3 • Viewing Entitlements

Action Description
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3. Configure line items and maintenance line items for this entitlement. 

• To configure a new line item, click the Line Items tab. Then, click New line item. See Configuring an 
Entitlement Line Item. 

• To configure a new maintenance line item, click the Maintenance Line Items tab. Then, click New 
Maintenance Line Item. See Configuring a Maintenance Line Item. 

Existing line items and maintenance line items can be linked: 

• To link to an existing line item to one or more existing maintenance line items, click the Line Items tab, and 
select a line item. Then, click Link Maintenance Line Items. Select one or more maintenance line items and 
click Save. 

• To link an existing maintenance line item to one or more existing line items, click the Maintenance Line Items 
tab, and select a maintenance line item. Then, click Link Line Items. Select one or more line items and click 
Save. 

Allow Portal Login? If Yes is selected, the end customer can use the entitlement ID or activation ID 
to log into the End-User Portal. 

State An entitlement is created in a draft or test state. Entitlements in draft or test 
states can be modified or deleted. 

When the entitlement is ready for use, it can be changed to a deployed state. 
See Viewing Entitlements for more information about changing the state of an 
entitlement.

Description A brief, optional description of the entitlement.

Ship to email Email address that FlexNet Operations sends the license to.

Ship to mail Postal address that FlexNet Operations sends the license to.

Email Template 
variation

Optional. Select an email template from the drop-down menu. If not specified, 
then the email template configured for the license technology is used. If there 
is no email template configured for the license technology, then the default 
email template is chosen. If the chosen template is not active or the send 
indicator is not switched on, no email is sent.

Channel Partners Under End Customer and Channel Partners

1. Click Add to assign a channel partner to the entitlement. 

2. On the Channel Partner page, select a Distribution Tier Type for the partner. 

3. Under Accounts, select the partner account. Click Next.

4. Under Contacts, select a contact to assign to the entitlement.

5. Click Save.

Table 3-4 • Creating an Entitlement Fields

Field Description
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For each entitlement line item, it is possible to show its fulfillment history and transaction history.

Configuring an Entitlement Line Item
When you click New line item on the Create an Entitlement page, FlexNet Operations opens the Configure Line 
Item wizard in a pop-up window. Continue configuring the settings for each entitlement line item. You configure 
entitlement line items using Configure Line Item wizard. 

Task To configure an entitlement line item

1. Select Product: Select a product for the line item. You can select multiple products if they have a common 
license model assigned. Click Next.

2. Select Part Number and License Model: Enter values for the following, then click Next.

• The entitlement’s part number, if any.

• Select a license model from the drop-down list, then specify any entitlement-time license model 
attributes. (Attributes from all license models are displayed.)

• For FlexNet licensing technologies, an entitlement line item can contain, at most, 1 certificate, 1 trusted 
storage, and 1 embedded license model. The same line item can be activated using a certificate license, 
trusted storage activation request, or embedded activation request from a hardware device.

• Optionally, set the Notice value (customer name and Purchase order number) and Serial Number of the 
license.

3. Configure Product: Enter values for the following, and then click Next.

• Quantity Per Copy: Quantity per copy of each line item. This is a multiplier. So, for example, if one copy of 
the line item is fulfilled, the specified quantity of the product is shown in the license.

• Description: enter a brief description of the product line item. 

• Order ID: enter the order ID. (This may be imported from your ERM/CRP application.) 

• Order Line Number: enter the order line number. (This may be imported from your ERM/CRP application.)

• Number of Copies: specify the number of copies for the entitlement.

• Start Date: The start date of the entitlement line item is the start date of the licenses that are generated 
against the line item. Select a start date option from the drop-down list:

• Specify at each activation: (not available for FlexNet Embedded licensing) the user is prompted to 
specify a start date each time the line item is activated. Each fulfillment record gets a new start 
date, and for duration-based entitlements, each fulfillment record’s expiration date is set to start 
date specified + duration.

• Specify value now: select the start date value now. All fulfillment records of this line item get this 
start date. To specify a start date, click the Calendar next to the Start Date field and select a date. 

• Use first activation date: the date of the first activation is used as the start date. All fulfillment 
records for this line item get the same start date.
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• Specify at first activation: (not available for FlexNet Embedded licensing) the user is prompted to 
specify a start date when first activating the line item. This start date is used for all fulfillment 
records.

• Use each activation date: every time the line item is activated, the activation date is used as the 
start date. Each fulfillment record gets a new start date. As a result, for duration-based 
entitlements, each fulfillment record’s expiration date is set to activation date + duration.

• Expiration: Specify when the line item expires.

• Permanent: the line item never expires.

• Specify Expiration Date: the line item expires on the indicated date.

• Specify Duration: the line item is valid for this period of time after activation.

Note that if this entitlement line item is delivering usage, then setting or changing the expiration date to 
a date in the past does not propagate to the usage functionality. This means that the entitled count does 
not reflect in the usage report user interface. Usage does not allow changes to the past. In this case, the 
earliest you can set the expiration date to is today. 

4. Order Type: select an order type from the drop-down list: Upsell, Upgrade, Renewal, or New. For Upsells, 
Upgrades and Renewals, if the parent line item is being upgraded, specify it here.

5. Click Save or Complete to save the entitlement line item.

An entitlement line item is created as a draft or a test that can be modified. After a draft entitlement is 
deployed to allow activation, existing line items cannot be modified. After an entitlement is saved, the history 
of its state change can be viewed by clicking View History.

Configuring a Maintenance Line Item
When you click New maintenance line item on the Create an Entitlement page, FlexNet Operations opens the 
Configure Line Item wizard in a pop-up window. Continue configuring the settings for maintenance line items. 
You configure maintenance line items using the Configure Line Item wizard.

A maintenance line item must be linked to one or more product line items for it to be effective during bulk 
operations. 

Task To configure a maintenance line item

1. Select Maintenance: Select a maintenance product for the line item. Click Next.

2. Configure Maintenance: Enter values for the following, and then click Next.

• Part Number, if any. 

• Description: enter a brief description of the product line item. 

• Order ID: enter the order ID. (This may be imported from your ERM/CRP application.) 

• Order Line Number: enter the order line number. (This may be imported from your ERM/CRP application.)

• Number of Copies: specify the number of copies for the entitlement.
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• Start Date: The start date of the entitlement line item is the start date of the licenses that are generated 
against the line item. 

• Expiration: Specify when the line item expires.

3. Click Save or Complete to save the maintenance line item.

Changing the State of a Line Item
You can change the state of entitlement line items and maintenance line items on an existing entitlement’s 
Create an Entitlement page. (In the Entitle Customers view, click on an entitlement ID to see that entitlement’s 
Create an Entitlement page.) 

There are five possible states for a line item: 

• Draft: An entitlement line item is created and can be edited in the draft state. 

• Deployed: An entitlement line item must be deployed to be activated. Deploying a draft line item allows it to 
be activated, upgraded, upsold, or renewed. 

• Inactive: Existing fulfillments against an inactive entitlement line item cannot be returned, repaired, or 
rehosted. Inactive line items can be changed back to a deployed state as necessary.

• Test: Test entitlement line items can be defined for draft products and license models. This helps the 
producer ensure that products and license models are defined correctly.

• Obsolete: An entitlement line item can be made obsolete if it is no longer required, or it was created and 
deployed in error. An obsolete entitlement line item cannot be fulfilled. Fulfillments of an obsolete 
entitlement line item cannot be rehosted. The obsolete state is permanent, but the inactive state is not. After 
you make a line item obsolete, you cannot change it back to a deployed state.

Note • An entitlement that has been activated on a device can have its state changed to Inactive or Obsolete only 
if the configuration option Allow used entitlement/line item state change to Inactive or Obsolete is selected. 

When this configuration option is selected, an entitlement or line item that has been activated on a device can 
still be used until the license expires, even if the entitlement or line item has been deactivated or made obsolete. 

For more information, see General Options in Configuring System Settings.

Task To change the state of one or more entitlements

1. On the Create an Entitlement page, click the tab for the type of line items you want to change. 

• For entitlement line items, click the Line Items tab (default). 

• For maintenance line items, click the Maintenance Line Items tab.

2. Click check boxes to select line items.

3. Click Change State, and then click the state you want to assign to the selected line items. 

4. Click OK to confirm the state change. 
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Creating a Bulk Entitlement
If you want to create an entitlement for a single product against which multiple end users can generate licenses, 
create a bulk entitlement. A bulk entitlement can be sold to a retailer that distributes Web register keys to 
customers.

No licenses can be generated using the entitlement ID of a bulk entitlement; licenses are generated using one of 
the Web register keys associated with the entitlement. When a Web register key is redeemed, a simple 
entitlement is created with a configurable entitlement ID (default value is web_register_keyENT). Subsequent 
lifecycle operations are performed on the simple entitlement line item. 

Follow the instructions, below, to create a bulk entitlement. Then, continue with the instructions in Configuring a 
Bulk Entitlement to add a product. Then, add one or more Web register keys by following the steps in Loading 
Web Register Keys or Adding a Web Register Key.

Task To create a bulk entitlement

1. Click Entitlements > Create Bulk. This link opens the Create a Bulk Entitlement page. (Click Entitlements > 
Create Test Bulk to create a test bulk entitlement.)

2. Required fields are indicated by a red asterisk. Provide values for the following fields:

Table 3-5 • Creating an Entitlement Fields

Field Description

Entitlement ID The entitlement identifier uniquely identifies the entitlement. Select Auto 
Generate to let FlexNet Operations assign an entitlement ID, or select Specify 
to enter an entitlement ID of your choice.

If the entitlement is in the draft or test state, you can regenerate the activation 
IDs of draft line items or the entitlement ID by clicking Regenerate IDs. 

If the IDs are based on characteristics of the entitlement that were not set 
when the entitlement was created, you can use Regenerate IDs to regenerate 
these IDs after you have set the characteristics. 

State An entitlement is created in a draft or test state. Entitlements in draft or test 
states can be modified or deleted. 

When the entitlement is ready for use, it can be changed to a deployed state. 
See Viewing Entitlements for more information about changing the state of an 
entitlement. 

Description A brief, optional description of the entitlement.

Ship to email Email address that FlexNet Operations sends the license to.

Ship to mail Postal address that FlexNet Operations sends the license to.
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3. To configure a bulk entitlement, click Add Product. (See Configuring a Bulk Entitlement.)

Configuring a Bulk Entitlement
When you click Add Product on the Create a Bulk Entitlement page, FlexNet Operations opens the Configure Line 
Item wizard in a pop-up window. Continue configuring the settings for this entitlement line item. You configure 
entitlement line items using the wizard. 

Task To configure a bulk entitlement

1. Under Select Product, select one or more products from the list. You can search for a product, a suite, or 
search for all products. Click Next.

2. Specify Quantities: For each product, enter the quantity to be included in each line item. Click Next.

3. Select License Model: Select one of the license models that is associated with the selected product. Only 
deployed license models appear in the drop-down list. Specify any entitlement-time license model attributes. 
The existing model is displayed, if one was previously assigned. In addition, custom attributes specified at 
entitlement time are shown here.

4. Configure Product: For each product, specify the following values: 

Channel Partners Under Channel Partners, 

1. Click Add to assign a channel partner to the entitlement. 

2. On the Channel Partner page, select a Partner Tier for the partner. (Bulk 
entitlements are typically sold to a distributor. Thus, the values for End 
Customer and Tier1 partner are set to the same account for bulk 
entitlements.)

3. Under Accounts, select the partner account. (If necessary, a new account 
can be created.) Click Next.

4. Under Contacts, select a contact to assign to the entitlement. (If 
necessary, a new contact can be created.) 

5. Click Save.

Table 3-6 • Select Product Fields

Field Description

Description Describe the characteristics of this entitlement that make it unique.

Table 3-5 • Creating an Entitlement Fields

Field Description
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5. After the bulk entitlement is configured, you can save it in its current state, go to the Load Web Register Keys 
page to add Web register keys to the bulk entitlement, or deploy it: 

• Click Save or Complete to save the entitlement. This saves the bulk entitlement in a draft state to allow 
further editing. After an entitlement is saved, the history of its state change can be viewed by clicking 
View History.

• Click Next to load Web register keys into the bulk entitlement. 

• Click Deploy to deploy a draft bulk entitlement. Deploying a bulk entitlement allows activation but, after 
deploying, a bulk entitlement’s existing line items cannot be modified. 

Loading Web Register Keys
Each bulk entitlement has a set of Web register keys that end users use to turn on license rights for their 
software. Web register keys can be added in more than one set and can be added after the bulk entitlement is 
deployed. 

The total number of Web register keys that were added to the entitlement and the number that were already 
activated are displayed. 

Start Date The start date of the entitlement is the start date of the licenses that are 
generated against the line item. Select a start date option from the drop-down 
list:

• Use each activation date as start date: (not recommended for use with 
FlexNet Embedded licensing) every time the line item is activated, the 
activation date is used as the start date. Each fulfillment record gets a new 
start date. As a result, for duration-based entitlements, each fulfillment 
record’s expiration date is set to activation date + duration.

• Specify at first activation: the user is prompted to specify a start date when 
first activating the entitlement. This start date is used for all fulfillment 
records.

• Use first activation date: the date of the first activation is used as the start 
date. All fulfillment records for this entitlement get the same start date.

• Specify at each activation: (not recommended for use with FlexNet 
Embedded licensing) the user is prompted to specify a start date each 
time the entitlement is activated. Each fulfillment record gets a new start 
date, and for duration-based entitlements, each fulfillment record’s 
expiration date is set to start date specified + duration.

Expiration Specify when the entitlement expires.

Permanent: the entitlement never expires.

Specify Expiration Date: the entitlement expires on the indicated date.

Specify Duration: the entitlement is valid for this period of time after activation.

Table 3-6 • Select Product Fields

Field Description
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Select Auto Generate to let FlexNet Operations create Web register keys for the specified number of copies, or 
select User Supplied to specify a file that contains Web register keys. (Web register keys can also be imported 
using a FlexNet Operations Web service.)

Important • Whether using the Auto Generate or User Supplied option, you must configure the alert, Importing 
Bulk Entitlement Web Register Keys, before loading Web register keys. This alert runs a job that periodically 
checks whether there are any Web register keys to import, and it can be configured to send an email with the 
status of the import. See Configuring Alert Behavior for instructions. 

Note • To show the Load Web Register Keys page, open the Create Bulk Entitlement page for the bulk 
entitlement to which you want to add Web register keys and click Next.

Task To load Web register keys

1. On the Load Web Register Keys page, choose either Auto Generate or User Supplied: 

• Select Auto Generate to automatically generate Web register key values. Then enter the number of Web 
register keys to generate for this entitlement.

• Select User Supplied to supply Web register key, yourself, from an XML file. Then use the on-page 
controls to choose the XML file that contains the Web register key values. (See Specifying User-Supplied 
Web Register Keys for details about the format and syntax of the XML file.)

2. Click Save to submit the request to load Web register keys. 

If the Importing Bulk Entitlement Web Register Keys alert is configured, FlexNet Operations processes the 
import request and notifies you of the status of the import request. 

3. Click Complete when you are done creating or editing the bulk entitlement. The bulk entitlement must be 
deployed before any activations can be done against it. 

Tip • To manually add individual Web register keys, follow the instructions in Adding a Web Register Key.

Adding a Web Register Key
You can manually add web register keys, one by one, to an existing bulk entitlement. 

Note • To show the Load Web Register Keys page, open the Create Bulk Entitlement page for the bulk 
entitlement to which you want to add Web register keys and click Next.
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Task To add a web register key

1. On the Load Web Register Keys page, click Add.

2. Enter the web register key and click OK. The web register key is added. 

3. Click Save. 

Tip • To load several Web register keys at the same time, either from a user-supplied file or by allowing FlexNet 
Operations to automatically generate the Web register key values, follow the instructions in Loading Web Register 
Keys.

Deleting a Web Register Key
You can delete web register keys from bulk entitlements.

Note • To show the Load Web Register Keys page, open the Create Bulk Entitlement page for the bulk 
entitlement from which you want to delete Web register keys and click Next.

Task To delete a web register key

1. On the Load Web Register Keys page, select the web register key you want to delete (or multiple keys) by 
selecting the corresponding check box. 

2. Click Delete.

3. Click Yes to confirm deletion.

Specifying User-Supplied Web Register Keys 
When loading Web register keys from a user-supplied file, you must provide the key values in an XML file. Enter 
Web register keys into a text file with the following format and save it on the machine on which you are running a 
browser. 

<?xml version="1.0" encoding="UTF-8"?>
<webregkeys>

<webregkey>web_reg_1</webregkey>
<webregkey>web_reg_2</webregkey>
<webregkey>web_reg_3</webregkey>
...

</webregkeys>

Use the controls on the Load Web Register Keys page to specify this file. (See Loading Web Register Keys.)

Web register keys can also be imported using the Entitlement Order Web service. See the createWebRegKey 
operation in the FlexNet Operations SOAP Web Services Guide for instructions. 
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Bulk Operations: Upgrade, Upsell, or Renew a Product
This wizard allows you to create new entitlements for a customer that has purchased either:

• An upgraded version of a product. This allows a customer to move from an older version of a product to a 
newer version. 

• An upsold version of a product. This allows the customer to move from a product with fewer features to one 
with more features.

• A renewal of a product. This allows a customer to extend an existing entitlement for a licensed product.

The Bulk Operations process allows an Upgrade, Upsell, Renew, Test Upgrade, Test Upsell, or Test Renew of an 
entire set of entitlements. You are presented with a wizard that prompts you for information about the type of 
action that you want to perform. Many of the steps for completing each of these processes are identical and are 
outlined here. You can perform these operations in bulk, for multiple accounts, line items, and products all at 
once.

Note • Before performing an upgrade or upsell action, you must create the appropriate upgrade and upsell 
relationships between products. In addition, you can perform a Renew only when one of the following conditions 
is met:

• The entitlement line item has an Expiration Term that is temporary. (That is, the Expiration value is not set to 
Permanent.)

• If the Expiration Term for the entitlement line item is Permanent, it specifies a Product containing at least one 
Feature with the Version Format Type set to Date Based.

Important • FlexNet Operations does not evaluate the count of available copies when an upgrade is created. 
Therefore, it is possible to create an upgrade count that exceeds the number of available copies; however, the 
count is evaluated at fulfillment time. On fulfillment, upgrades that exceed the available count are rejected. To 
avoid errors at fulfillment time, users can invoke the method getExactAvailableCount(), which returns the exact 
number of copies available for upgrade fulfillment. This method is available as a web service call and also as part 
of public API.

Task To use the Bulk Operations wizard 

1. Click Entitlements > Bulk Operations. This link opens the Bulk Operations page.

2. Select your operation by clicking the corresponding button: Upgrade, Upsell, Renew, Test upgrade, Test 
upsell, or Test renew. (The Test version of each operation only shows draft and deployed entitlements.)

3. Basic Information: Enter the basic information about the operation, and then click Next.

• Name: The name of the upgrade, upsell, or renewal. You can use this for tracking purposes.

• Description: A short description of the bulk operation you are performing.

• (For Upgrades or Upsells Only) Check Maintenance: Select whether or not any maintenance line items 
are included in the upgrade or upsell. If Yes, select an expiration date for the maintenance using the 
calendar control. Line items linked to maintenances expiring after this date are displayed later.
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• Obsolete Line Items: Indicate whether or not the parent line item of this item will be made obsolete.

• (For Renewals Only) Support Version Date Renewals: For renewals, select whether or not to support 
version date renewals. 

• If yes, then permanent line items are shown during the renewal process. Only line items that have 
products with a date-based feature are shown. 

• If no, then you cannot renew permanent line items.

4. Select Product: For upgrades and upsells, a list of products is presented that can be upgraded or upsold. 
These are products that have been entitled to this account and that either have an Upgrade To relationship or 
an Upsell To relationship. Select the product (or products, all of which must be in the same entitlement line 
item) you want to upgrade or upsell and then click Next. 

5. Select Accounts: If you want to perform the process for all accounts, select Yes. If not, select No and then 
select the accounts for which you want to perform the process. When complete, click Next.

6. Select Line Items: Select the entitlement line items you are upgrading, upselling, or renewing. These are 
entitlement line items that contain products entitled to the selected accounts. In Count, type the number of 
copies in the entitlement line item you want to upgrade, upsell, or renew. For Test operations, only Test line 
items are displayed. Then, click Next.

7. Select Product: For upgrades and upsells, a list of products is presented that can be upgraded or upsold. 
(The products being operated upon in Step 4 must have a common license model for you to select them in 
this step.) Select the products you want to upgrade, upsell, or renew and then click Next. 

8. Configure Product Quantities: Enter the quantities of the products being upgraded, upsold, or renewed.

9. Configure Part Number and License Model: Select the part number and license model for the product being 
upgraded, upsold, or renewed. 

10. Line Item Attributes: Specify the version date and auto fulfill option, and enter values for any additional 
entitlement line item attributes for which you are prompted. 

Specify version date as follows:

• Version Date: Define how the version date is determined. In the drop-down menu, select either:

• Use Start Date to compute Version Date: the Version Date is computed using the duration entered 
here and the Start Date. Enter a value for a duration of time that is added to the Start Date value. The 
Start Date Value can be defined on this page or can be defined at the time the Entitlement Line Item 
is activated. 

• Specify Value Now: specify a static date.

• Specify the Version Start Date Later: the Version Date is computed using the duration entered here 
and the Version Start Date. Enter a value for the duration that is added to the Version Start Date 
value. The Version Start Date value is defined at the time the entitlement line item is activated.

• Specify Version Date Later: the Version Date is specified at the time the entitlement line item is 
activated.

• Use Activation Date to compute Version Date: the Version Date is computed using the duration 
entered here and the Activation Date. Enter a value for the duration that is added to the Activation 
Date value. The Activation Date is the date when the entitlement line item is activated.

• Permanent: Specify whether this license is Permanent or Temporary.
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• Duration: If the license is temporary, specify the duration that it is valid.

• Date: If the license is temporary, specify a static date when the license expires.

For Auto Fulfill, specify Yes or No: 

• Click Yes to automatically fulfill the line items. All the line items in the bulk operation are automatically 
fulfilled after the operation is submitted. Example: For a bulk upgrade operation in which the parent line 
item is already fulfilled, FlexNet Operations creates the new, child (upgrade) line items and automatically 
activates them. 

• Click No if you want to manually fulfill the line items. Line items in the bulk operation must subsequently 
be manually fulfilled as a support action.

11. Configure Policies: Set policies for the following items, and then click Save & Next.

• Number of Rehosts: How many times and how often can your customers move (or rehost) licenses from 
one computer to another? Choose from Ignore Policy or Specify Value Now. If you choose Specify Value 
Now, the Producer Portal reveals controls for setting the number and frequency of rehosts.

• Number of Returns: How many times and how often can your customers return licenses to the pool of 
available licenses? Choose from Ignore Policy or Specify Value Now. If you choose Specify Value Now, 
the Producer Portal reveals controls for setting the number and frequency of returns.

• Number of Repairs: How many times and how often can your customers repair licenses? Choose from 
Ignore Policy or Specify Value Now. If you choose Specify Value Now, the Producer Portal reveals 
controls for setting the number and frequency of repairs.

• Number of Extra Activations: How many extra seats (or activations) do you want to enable for each 
entitlement? Choose from Ignore Policy or Specify Value Now. If you choose Specify Value Now, the 
Producer Portal reveals a field for the extra activations value.

Note • For additional information about configuring license policies, see Setting License Model Policies.

12. Submit Job: Select whether to submit the bulk operations job for processing now or later. You may want to 
select this time based on your system capabilities.

• Jobs submitted now are processed within 2 minutes. 

• If submitted for later, specify the time FlexNet Operations should process the job. Typically, you should 
choose a time when demand for processing time is low. 

When complete, click Submit. Your bulk operations job is submitted for processing at the specified time. You 
can check job status on the Bulk Operations page. Failed jobs are displayed on the page as well, along with 
any errors encountered. More information on failed jobs is contained in the application log.

Tip • FlexNet Operations can automatically create upgrade line items for qualifying products and line items with 
the Product Version Upgrade job. See FlexNet Operations Alert Types.
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Emailing Bulk Operation Notifications
When a bulk operation processes an upgrade for entitlements, you can initiate that end users are sent an email 
for each upgraded line item.

Note • Email notifications can only be sent for completed bulk operations. In addition, ensure that the Ship To 
Email field on the Create a Bulk Entitlement page has been populated with the recipient email (see Creating a 
Bulk Entitlement).

Task To send an email notification for a bulk operation

1. Click Entitlements > Bulk Operations. This link opens the Bulk Operations page.

2. Select a completed operation (where the Status field shows Completed). 

3. Click Email. This link opens the Email Bulk Operations page. The Name field shows the name of the upgrade 
operation.

4. Enter the following information:

• Email Type: Select if you want to send emails for entitlements or fulfillment, or both.

• Language for email: Select the language of the email that will be sent.

• Submit Job: Select Now if the notification should be sent immediately, or select Later and provide the 
date and time to schedule the sending of the email.

5. Click Submit.

You can check the email bulk operation job status in the Email Status column on the Bulk Operations page. A 
submitted job can have the status Success, Failed, or Pending. The Notes column shows additional information.

If an email job for a bulk operation has already been submitted, emails will be sent for any records for which an 
email could not be sent earlier.

Note • When entitlements are upgraded during a bulk operation and the same product exists on multiple line 
items of the upgraded entitlement, a customer will receive a single email notification instead of a notification for 
every upgraded line item.

Merging Entitlements
This capability allows you to reassign entitlements and users to another account. When you merge an 
entitlement, everything in the entitlement remains the same, except the Sold To value. This is changed to reflect 
the new account. When you merge users, all users and contacts that are associated with the source account are 
reassigned to the target account.

Any channel partners that are assigned to an account’s entitlements are included in the merge.



Chapter 3 Entitling Customers and Activating Licenses
Entitling Customers to Licenses

162 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

The following selections are defined when merging entitlements from one account to another.  

Transferring Entitlements
You can transfer the license rights in a single entitlement from one account to another. All entitlement line items 
for that entitlement are transferred. Transfer of entitlement is possible only if there are no fulfillments. The 
system provides an option to return all existing fulfillments automatically during the process of performing the 
transfer. 

Bulk entitlements cannot be transferred. Also, entitlements with line items on an auto-provisioned license server 
cannot be transferred.

After the license rights are transferred, the status of the entitlement for the origin account changes to Obsolete 
and a new entitlement is created for the target account.

To transfer individual entitlement line items, see Transferring Entitlement Line Items.

Task To transfer activatable entitlements to accounts

1. Click Entitlements > List Entitlements. This link opens the List Entitlements page. 

2. Search for a line item by Activation ID and then select the item you want to transfer. 

3. Click Transfer. The line item is displayed on the next page if it is transferable. 

4. Fill in the number of copies of the line item you want to transfer. The total number sold and the number 
available for transfer is displayed, along with the source account.

5. Click Search to select the target account to which the copies are to be transferred, and click OK. 
Alternatively, type the account name in the Target Account field.

6. Select whether the target account is to use the original Activation ID. Yes causes the system to generate the 
Activation ID; No requires you to provide the Activation ID.

Table 3-7 • Merge Wizard Selections

Field Description

Source Account The company that currently own the assets. This can be either a customer 
account or a self-registered account.

Target Account The company that receives the assets. Only customer accounts can be 
specified.

Assets to be Transferred Select either or both: 

• Entitlements and Fulfillments: all entitlements, fulfillments, and host ID 
values are associated with the Target Account.

• Users: all users and contacts that are associated with the Source Account 
are associated with the Target Account. 
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7. If you selected No, enter the new Activation ID, and select which parent entitlement the new line item is to 
belong to: Existing or New. 

8. If you selected No in Step 7, select whether you want the system to auto generate the Entitlement ID. If you 
select No, you must provide the Entitlement ID, and you must fill in the new entitlement details. 

9. If you selected Yes in Step 8, the system auto generates the Entitlement ID. You are prompted to provide the 
address where email is to be sent, and the address where mail is to be sent.

10. Click Transfer to transfer the line item to the target account.

11. If you selected Yes in Step 7, select which parent entitlement the new line item is to belong to: Existing or 
New. If no parent entitlements exist, select New.

12. Select whether you want the system to auto generate the Entitlement ID. If you select No, provide the 
Entitlement ID, and fill in the new entitlement details.

13. If you select Yes in Step 13, the system auto generates the Entitlement ID and you are prompted to provide 
the address where email is to be sent, and the address where mail is to be sent.

14. Click Transfer to transfer the line item to the target account.

Transfer Entitlements Wizard
Required fields are indicated by a red asterisk.

1. Click Entitlements > List Entitlements by Order. This link opens the List Entitlements by Order page.

2. Select the entitlement from the list. You can also search for entitlements based on specific criteria by 

• Specifying some particular values in the simple search, like Entitlement ID Starts With

• Clicking Advanced Search, which lets you specify multiple search attributes.

3. Click Transfer.

4. Target Account: click Search to select the account that is to receive the entitlement, or directly type in the 
account name. If there are unreturned licenses, continue with Step 5. If there are no activated licenses, 
continue with Step 6.

5. There are some active fulfillments for line items in this entitlement. Would you like the system to 
automatically return them? 

• Yes: Operations returns all of the activated licenses. Continue with Step 6.

• No: The entitlement (or entitlement line item) cannot contain activated licenses. These existing 
fulfillments must be returned before transferring the entitlement (or entitlement line item). Click Cancel 
and go to Supporting Licenses to return the Fulfillments associated with this entitlement (or entitlement 
line item).

6. Will the Target Account use the same entitlement ID and activation IDs that the source account used? 

• Yes: If you select this option, the new entitlement retains the values defined for the entitlement ID and 
activation IDs. The entitlement ID and activation IDs values defined in the originating entitlement are 
changed to reflect the action taken. 

Click Transfer. You are prompted that the entitlement is to be transferred to the new account. Continue 
with Step 8.
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• No: You are provided the opportunity to change the information. Continue with Step 7.

7. Would you like the system to generate the entitlement ID and activation IDs? 

• Yes: Operations generates a new entitlement ID and activation IDs. Click Transfer and then continue with 
Step 8.

• No: Operations generates a new entitlement ID and activation IDs, but gives you the ability to change 
these values. Click Transfer and then continue with Step 8.

8. The Creating an Entitlement page is displayed with the Entitlement ID and Activation ID fields populated with 
values based on your selections. You can either accept the values as they are or you can change them. The 
account defined in the Account field contains the name of the new account. Click Deploy to complete this 
action.

Viewing Fulfillment History
The fulfillment history of an entitlement identified with an activation ID can be displayed when viewing an 
entitlement order. 

Task To see the fulfillment history of a line item: 

1. Click Entitlements > List Entitlements by Order. This link opens the List Entitlements by Order page.

2. Locate the entitlement. You can search for entitlements based on specific criteria by 

• Specifying some particular values in the simple search, like Entitlement ID Starts With

• Clicking Advanced Search, which lets you specify multiple search attributes.

3. Click the entitlement ID to open it in the Create an Entitlement page. 

4. Find the entitlement line item whose history you want to view and click its Fulfill History link. A pop-up 
window is displayed with the fulfillment history.

5. Click OK to close the pop-up window. 

Viewing Custom Attributes
Custom Attributes appear on the Maintenance Entitlement Details pop up.

Task To view custom attributes

• On the List Entitlements page, under Maintenance tab, you can click the maintenance hypertext to view the 
custom attributes in the Maintenance Entitlement Details pop up.

Note • You can also view the custom attributes on the List Entitlements By Order page.
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Viewing Entitlement History
The transaction history of an entitlement including a summary of what was changed and who changed it can be 
displayed when viewing an entitlement order.

Task To see the change detail of an entitlement:

1. Click Entitlements > List Entitlements by Order. This link opens the List Entitlements by Order page.

2. Search for an entitlement. 

3. Click the entitlement ID to open it in the Create an Entitlement page. 

4. Click View Transaction at the bottom of the page. The Search Transactions: Results page opens and list of 
updates is displayed. See Viewing Transaction Histories for more information.

Activating Licenses 
An activation represents what the customer installed or redeemed against an entitlement. The activation process 
generates the actual license rights used by the software application you sell to customers, based on the license 
models you defined earlier. 

When activating licenses, the software producer turns on license rights for a product or set of products for a 
customer account by performing the following tasks:

• Selecting an entitlement line item, identified by an activation ID, that refers to a specific product name and 
version 

• Specifying values for license model attributes that are set at fulfillment time 

• Generating a license 

This section includes the following main topics.

Table 3-8 • 

Topic Description

Activation Terms Defines terms used to discuss activations.

Viewing Entitlements to 
Activate

Explains how to show all activatable line items.

Emailing an Entitlement 
Line Item

Shows how to email an entitlement line item.

Activating a License Describes how to activate licenses with either the Activate Licenses wizard or 
Trusted Activate wizard.

Transferring 
Entitlement Line Items

Explains how to transfer entitlement line items and use the Transfer Entitlement 
Line Item Wizard.
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Activation Terms
The following topics define the terminology used for activations:

• What is a License?

• What is Activation?

• What is the Activatable Line Item Type?

• What is an Activation ID?

• What is Batch Activation?

• What is License Consolidation?

What is a License?
A license allows the use of software capability. FlexNet licenses are delivered as license certificates or delivered 
into trusted storage on a machine. License delivery for custom license technologies may vary.

What is Activation?
Activation is the entire process of requesting, generating, delivering, and installing license rights. Generating a 
license certificate and activating a license in trusted storage using FlexNet Operations are different activation 
processes. 

What is the Activatable Line Item Type?
The activatable line item type, which is displayed in the Type column on the List Entitlements page, indicates 
whether an entitlement is certificate-based, trusted storage-based, or custom.

What is an Activation ID?
The activation ID is the unique identifier of an activatable item. An activatable item is either an entitlement line 
item in a simple entitlement or a Web register key in a bulk entitlement. 

Activation ID in FlexNet Operations corresponds to entitlement ID in FlexNet Publisher Licensing Toolkit. In trusted 
storage, Entitlement ID is the identifier of the entitlement that contains the activatable item. 

Emailing a License Shows how to email a license.

Manual Activations Discusses manual activations and how to view a manual activation response. 

Short Code Activations Discusses short code activations and how to view a short code activation response.

Table 3-8 • 

Topic Description
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The activation ID is listed in the Activation ID column on the List Entitlements page. A customer can log in to the 
End-User Portal with an activation ID.

What is Batch Activation? 
To simplify activation, FlexNet Operations supports simultaneous activation of multiple entitlement line items, 
provided the following are all true:

• All line items are sold to the same account.

• All line items pertain to the same certificate-based license model, that is, node-locked uncounted, node-
locked counted, floating uncounted, or floating counted.

OR

• All line items pertain to the same custom license technology.

In other words, licenses for different customer accounts, trusted storage-based license models, or different 
certificate-based license models cannot be activated together. Products in the line items can vary. The line items 
need not share the same entitlement ID.

You can consolidate licenses generated during batch activation.

What is License Consolidation? 
License consolidation is the process of combining multiple licenses into a single license file. Consolidating 
licenses can simplify subsequent rehosting tasks because it allows you to convert several separate licenses into 
a consolidated license.

Note • The license consolidation feature is not available by default. To enable this feature, the producer must 
select the Show Consolidate Licenses Functionality check box in System > Configure > FlexNet Operations.

License consolidation can take place during batch activation or post-activation.

License Consolidation Limitations
License consolidation is only possible for certificate licenses, and for custom (non-FlexNet) licenses when a 
custom consolidation class has been implemented. (See Creating a License Technology for more information.) 

It is not possible to consolidate trusted storage licenses.

To be consolidated, licenses must belong to the same customer account. The licenses you consolidate can be 
based on different license models, use different license generator configurations, or even belong to different 
license technologies; however, when license technologies are different the consolidation process does not result 
in a single license. One consolidated license is created for each license technology. 
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License Consolidation Processing
For certificate licenses, a separate consolidated license is generated for each host. A separate consolidated 
license file is generated for floating or node-locked licenses on each license server. For example, floating 
counted and floating uncounted certificates can be consolidated on a single server. Also floating counted and 
node-locked counted certificates can be consolidated on a single server. (This is because the node-locked 
counted model requires a license server system.) 

Note • For custom license technologies, the result of license consolidation depends on how the producer codes 
the consolidator class, where custom consolidation rules are defined.

Viewing Entitlements to Activate
The List Entitlements page displays all activatable line items (entitlement line items and Web register keys), in 
order of modification date, most recently modified first. Line items using trusted license models are marked with 
an icon that looks like a letter T in a blue square. 

By default, the following columns are included. 

Note • Display of these columns can be configured using the OPS_PORTAL_CONFIG table. See the FlexNet 
Operations On-Premises Installation & Implementation Guide for more information.

Table 3-9 • List Entitlements Page

Column Description

Type Identifies the license type—Certificate, Trusted, or Embedded—for the activatable line 
item.

Activation ID The unique identifier of the activatable item. An activatable item is either an entitlement 
line item in a simple entitlement or a Web register key in a bulk entitlement. Activation ID in 
FlexNet Operations corresponds to entitlement ID in FlexNet Publisher Licensing Toolkit.

Entitlement ID The identifier of the entitlement that contains the activatable item. Before a Web register 
key is activated, its entitlement ID identifies its bulk entitlement. 

Parent Bulk After the Web register key is activated, the ID of the bulk entitlement moves to the Parent 
Bulk column, and the entitlement ID of the simple entitlement created when the Web 
register key is redeemed replaces it. The ID of the new simple entitlement is 
web_register_keyENT. (Column is hidden by default.) 

Sold to The Sold to account has the right to receive licenses generated against this entitlement. 
The account information is presented in the format Account ID (Account Name).

State Activatable entitlements must be in the Deployed state. Other entitlement states are Test, 
Draft, Inactive. (Column is hidden by default.) 
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To view all activatable line items, select Entitlement ID, Parent bulk entitlement ID, Activation ID, Product, Part 
number, Sold-to Account name, or Sold-to Account ID from the Search for drop-down, and click the Simple 
Search icon. You can also search for entitlement line items based on specific criteria. Line items in this page can 
be sorted by the following columns: Activation ID, Entitlement ID, Sold to, Available quantity, and Maintenance. 

From this page, you can do the following:

Product All products defined for the line item, including version numbers.

Available 
quantity 

Number of activatable copies remaining in the line item: note that this number may be 
subject to policies.

Total quantity Total number of activatable copies in the line item. 

Expiration Expiration date or duration of licenses issued from this line item, specified during 
entitlement creation

Order ID The entitlement’s order ID. 

Maintenance The entitlement’s maintenance product. 

Table 3-10 • Viewing Activatable Line Items

Action Description

See the details of an 
activatable item 

To see the details of a line item, click its activation ID.

Activate licenses for an 
entitlement line item or 
Web register key 

To activate a license, select one or more activation IDs and click Activate or 
Trusted Activate, depending on the license type. Use Activate for certificate-
based and custom activations. Use Trusted Activate for trusted-storage-based 
activations. 

Print an entitlement To print an entitlement line item, select one or more entitlement line items and 
click Print.

View an entitlement 
certificate

To view an entitlement certificate as it would appear when emailed to a customer, 
select the box next to a line item and click View certificate.

Email an entitlement To email an entitlement line item, select the box next to it and click Email.

View fulfillment history To view an entitlement’s fulfillment history, select the box next to it and click 
Fulfill history. When complete, click OK. 

Table 3-9 • List Entitlements Page

Column Description
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Emailing an Entitlement Line Item 
Use the Email button to send an entitlement to a specified email address or contact in a customer account.

Task To email an entitlement line item to a customer

1. Navigate to the List Entitlements page. 

2. Select the box next to the line item you want to email; click Email.

3. Enter the email address you want the entitlement sent to. Use the search icon to look for contacts in the 
customer account. All contacts defined in the channel partners of the entitlement are automatically selected.

4. Click Send; click Cancel to cancel the operation and return to the List Entitlements page.

Activating a License 
All activatable items are displayed in the List Entitlements page: items that generate certificate licenses and 
items that cause licenses to be written to trusted storage. By default, only line items that have any remaining 
copies are shown in this page. To see line items that do not have any copies remaining, perform an advanced 
search. 

1. Click Entitlements > List Entitlements. 

2. Search for an activation ID (entitlement or Web register key) against which to generate a license. 

3. Select one or more activation IDs and click Activate or Trusted Activate, depending on the license type of the 
line item. You can select two entitlement line items that specify the same license model type (node-locked 
counted, floating counted, etc.) and activate licenses against them using the same wizard. You cannot do 
this with upgrade, upsell, or renewal entitlement line items.

4. Complete the steps in the Activate Licenses wizard (certificate) or Trusted Activate wizard (trusted storage).

The following topics provide more detailed instructions for activation wizard tasks. 

Table 3-11 • 

Topic Description

Activate Licenses 
Wizard

Describes the fields that comprise the first page of the Activate Licenses wizard.

Trusted Activate Wizard Describes the fields that comprise the first page of the Trusted Activate wizard. 

Specifying Host IDs Discusses the use of host IDs to provide tighter control over the environments in 
which the license can be legitimately used. (This is step 2 of the Activate Licenses 
wizard.)

Configuring Hosts in the 
Trusted Activate Wizard

Explains how to add a host for the activation. (This is step 2 of the Trusted Activate 
wizard.)
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Activate Licenses Wizard
Required fields are indicated by a red asterisk. Provide values for the following fields and any fulfillment-time 
license model attributes. Then click Next to specify server or node-locked host IDs. 

Special Host ID Types Identifies the host ID types that can be differentiated by the Vendor Certificate 
Generator.

Configuring Counts Explains how to configure counts for entitlement line items for certificate-based 
activation.

Configuring Counts for 
Trusted Activation

Explains how to configure counts for entitlement line items for trusted-storage 
activation.

Reviewing Activations 
and Generating 
Licenses

Describes how activations are presented for review and how to generate licenses 
for those activations.

Table 3-12 • License Generation - Required and Optional Fields

Field Description

Sold to This field is automatically populated unless the Activation ID was created using a 
bulk entitlement. When activating a Web register key of a bulk entitlement, the user 
must specify the Sold To field. This allows the producer to identify company that 
actually activated the Web register key.

Owner Optional field. Shows the user who actually bought the web register key. 

ActivationID This field is automatically populated.

Product Product name and version. This field is automatically populated. 

Version This field is automatically populated. 

Expiration Date This field is automatically populated.

Table 3-11 • 

Topic Description
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Version Date This field is displayed only in the following case: 

• the product defined in this entitlement line item contains a feature that 
specifies a date-based version format type, and

• you selected Specify Version Date Later when you created the entitlement for 
this product. 

If Specify Version Start Date Later is set in a line item, a duration is specified in the 
line item. In this case, a version start date is set at activation time and the version 
date is computed as version start date + duration. 

 Start Date After the entitlement is activated, the start date is the date that the license becomes 
valid and the user can begin using the software. 

• If the start date option was set in the entitlement line item, it is displayed. 
Whether it is editable depends on the Allow Editing of Deployed Entities 
configuration setting. 

• If the start date was not set in the entitlement line item, it must be set when the 
first license is activated against the line item. This start date is written back to 
the line item. Whether it is editable depends on the Allow Editing of Deployed 
Entities configuration setting. (This bullet is true for Specify at First Activation 
or Use First Activation Date; Specify at Each Activation and Use Each Activation 
Date are not covered.) 

When activating several line items together, you are prompted to specify the start 
date for those items without one. This date, once set at activation time, applies to all 
items that did not have a start date set during entitlement creation.

Ship to email The email address to which a license generated against this entitlement is to be 
sent: It can be the email address of an account contact or an address already 
entered in the entitlement. 

• Click Search to select an email address for one of the contacts in the sold-to 
account.

• Additional email addresses can be entered in a comma-separated list that 
contains no spaces.

Ship to address The mailing address to which a license generated against this entitlement is to be 
sent: It can be the mailing address of an account contact or an address already 
entered in the entitlement.

Vendor String Enter the producer-specific vendor string. 

Table 3-12 • License Generation - Required and Optional Fields

Field Description
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Trusted Activate Wizard
Required fields are indicated by a red asterisk. Provide values for the following fields and any fulfillment-time 
license model attributes. Then click Next to configure a host. (See Configuring Hosts in the Trusted Activate 
Wizard.)

Note • This page also shows custom attributes (if any) defined and set at fulfillment time.

Do you want to 
consolidate generated 
licenses? 

Select Yes (default setting) if you are activating two or more line items together, and 
would like to consolidate multiple licenses into a single license file. When activating 
a single license, this option does not appear. 

This is displayed if the Show Consolidate Licenses Functionality flag is enabled in 
System > Configure > FlexNet Operations.

Table 3-13 • License Generation - Required and Optional Fields

Field Description

Sold to This field is automatically populated unless the Activation ID was created using 
a bulk entitlement. When activating a Web register key of a bulk entitlement, 
the user must specify the Sold To field. This allows the producer to identify the 
company that actually activated the Web register key.

Owner Optional field. Shows the user who actually bought the web register key. 

ActivationID This field is automatically populated.

Product Product name and version. This field is automatically populated. 

Version This field is automatically populated. 

Expiration Date This field is automatically populated.

Ship to email The email address to which a license generated against this entitlement is to be 
sent: It can be the email address of an account contact or an address already 
entered in the entitlement. 

• Click Search to select an email address for one of the contacts in the sold-
to account.

• Additional email addresses can be entered in a comma-separated list that 
contains no spaces.

Table 3-12 • License Generation - Required and Optional Fields

Field Description
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Specifying Host IDs 
When a license file (certificate) is issued to the customer, it can contain information to validate that it is being 
used on only a specific license server. In addition, it can be configured to allow only a specific client to check out 
the feature. Host IDs are used to define this information.

Note • Depending on the license model defined for this product, you are prompted for one or more of the 
following attributes. If host IDs were implemented for this license model, you see a set of options: 

• Select Existing Host: Select a host ID that has been already defined for this account.

• Add New Host: Create a host ID that has not been already defined for this account.

• Remove: This allows you remove a host ID value from this list.

Depending on how the license model is defined for this product, there are two types of hosts you can define. You 
are provided with the same selections for each host type you must define (Server or Nodelocked). The page 
displays a label indicating the type of host you are defining.

• Server host: this information is used to identify the license server that can serve these licenses.  

For example, when you define the Server host to be HOSTNAME=dogma, the license can only be served from 
a system with the hostname ‘dogma’. The license cannot be used on a system with a different hostname. 

Each license server machine is identified by a host ID.

If you specify multiple server host IDs, then multiple license files are created: one for each host ID (that is, 
each license server system). 

In the case of the nodelocked counted license model, you must define nodelocked host IDs for each server 
host ID (or three-server configuration) specified.

• Nodelocked Host: this information is used to identify the client that is checking out the feature. This creates 
a restriction that a product can only check out a feature if it is run on a specific client system.   

Enter a host ID value identifying the machine to which the application is to be locked. 

• To lock an application to more than one machine, click Add Nodelocked Host and enter multiple host ID 
values. 

Ship to address The mailing address to which a license generated against this entitlement is to 
be sent: It can be the mailing address of an account contact or an address 
already entered in the entitlement.

Reinstall For server activation requests, select the check box for reinstalls. The effect of 
the Reinstall check box is that it prevents the activation from consuming the 
line item count. For retail (client) requests, the Reinstall check box is not 
shown. (Any repeat retail activation is automatically treated as a reinstall.) 

Vendor String Enter the producer-specific vendor string. 

Table 3-13 • License Generation - Required and Optional Fields

Field Description



Chapter 3 Entitling Customers and Activating Licenses
Activating Licenses

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 175

In the case of the nodelocked counted license model, you must define nodelocked host IDs for each server 
(or three-server configuration) specified.

The following table explains the type of host IDs that you are prompted for based on the license model type. 

1. In the Generate Licenses page, specify the necessary Host IDs (Nodelocked or Server) for the License 
and then click Next.

2. If the License model is counted (nodelocked or floating), you are prompted to specify a fulfill count for 
each server host ID, then click Next. If you are not required to specify a fulfill count (for example, for 
uncounted license models) do one of the following: 

• To check that the parameter values you have entered are valid, click Verify. 

• To generate a license certificate, click Generate. 

After a license is generated, it can be saved to disk or sent by email. For unconsolidated licenses, a certificate is 
issued for each product on each server. For consolidated licenses, one file is issued per server. For more 
information about viewing a consolidated license, see Consolidating Licenses. If you have selected more than one 
file to view, you can choose among license files by selecting the appropriate Consolidated License ID from the 
drop-down list provided.

Configuring Hosts in the Trusted Activate Wizard
After identifying the ship-to and specifying any fulfillment-time custom attributes for the activation, you must 
configure one or more hosts. In this step, you must upload one or more valid retail (client) or server request files 
(XML).

Task To add a host

1. On the Configure Host page of the Trusted Activate wizard, click Add host. This opens the Create Host page in 
a pop-up window. 

2. Click Browse, select a valid request file, and click Save. The Create Host page closes and the host identified 
by the request file is added to the Host list on the Configure Host page. 

You can add multiple hosts in this step. Click Next to configure counts for the trusted activation.

Table 3-14 • Definition of Hosts based on License Model

If the license type is: 

Nodelocked 
Counted

Nodelocked 
Uncounted

Floating 
Counted

Floating 
Uncounted

You are 
prompted to 
define the:

Server Host Not Required Server Host Server Host

Nodelocked Host Nodelocked Host Not Required Not Required
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Special Host ID Types
The following FlexNet Publisher host ID types can be differentiated by the Vendor Certificate Generator (VCG): 

Table 3-15 • Host ID Types

Host ID Type Description

ANY Special FlexNet Publisher Licensing Toolkit host ID ANY. Allows the license to run on any 
machine. 

DEMO Special FlexNet Publisher Licensing Toolkit host ID DEMO: Can be used only for node-
locked licenses, never for Server host IDs. Allows the license to run on any machine. 

Ethernet Ethernet address and also called MAC address. This is the hardware address from the 
Network Interface Card (NIC). This value consists of 12 hexadecimal digits (a 48-bit 
number).

TPM ID The Trusted Platform Module host ID adds an additional layer of security for Windows 
platform certificate based licensing to minimize software piracy. This feature is available 
with VCG kit 16.2.2.0. The length of the TPM ID should be in the following format: xxxxx-
xxxxx-xxxxx-xxxxx (4 sequences of 5 characters and 3 hyphens for a total of 23 
characters). TPM ID can be used in conjunction with other host ID types in case of 
redundant servers.

Long Used only with Solaris machines. It is the Solaris 32-bit hardware machine ID. This value 
consists of 8 hexadecimal digits (a 32-bit number).

User User name: Enter as USER=user_name in the Activate Licenses page. The FlexNet C/C++ 
Licensing toolkit uses the login name. FlexNet Publisher Licensing Toolkit for Java uses 
the username environment variable. 

Host Name This can a simple host name or a fully qualified DNS name. Host name: Enter as 
HOSTNAME=host_name in the Activate Licenses page. 

Display On Unix, this is the X display name. On Windows, it is the display adapter. Display name: 
Enter as DISPLAY=display_name in the Activate Licenses page. 

Routable IP 
Address 

This setting allows you to define the host ID as a routable, public IP address. Use the 
format INTERNET=w.x.y.z, where each letter represents an octet with a decimal value 
between 0 and 255.

FlexNet Operations validates that the address is not among the private, non-routable 
sets. The routable address cannot be an address in the primary three reserved, private 
network address ranges: 10.0.0.0-10.255.255.255, 172.16.0.0-172.31.255.255, and 
192.168.0.0-192.168.255.255. In addition, the address cannot be 127.0.0.1 (localhost). 

Note • FlexNet Operations IP address validation can be disabled by unselecting Enable 
Basic IP Address Host ID Validation in the system configuration settings. (See Configuring 
System Settings.)
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Routable IP 
Address with 
Wildcards 

This setting allows you to define the host ID as a routable, public IP address with a 
wildcard (*) as one or more octets. Use the format INTERNET=w.x.y.z, where each letter 
represents an octet with a decimal value between 0 and 255.

FlexNet Operations validates that the address is not among the private, non-routable 
sets. The routable address cannot be an address in the primary three reserved, private 
network address ranges: 10.0.0.0-10.255.255.255, 172.16.0.0-172.31.255.255, and 
192.168.0.0-192.168.255.255. In addition, the address cannot be 127.0.0.1 (localhost). 

The wildcard rules for routable IP addresses also apply. For an IP address of w.x.y.z

• If w is less than or equal to 127, then x, y, and z can be wildcards.

• If w is between 127 and 192, then only y and z can be wildcards.

• If w is greater than or equal to 192, then only z can be a wildcard.

Note • FlexNet Operations IP address validation can be disabled by unselecting Enable 
Basic IP Address Host ID Validation in the system configuration settings. (See Configuring 
System Settings.)

Non-routable IP 
Address 

This setting allows you to define the host ID as a non-routable, private IP address. Use the 
format INTERNET=w.x.y.z, where each letter represents an octet with a decimal value 
between 0 and 255.

The address you specify must be an address within the primary three reserved, private 
network address ranges: 10.0.0.0-10.255.255.255, 172.16.0.0-172.31.255.255, and 
192.168.0.0-192.168.255.255.

Note • FlexNet Operations IP address validation can be disabled by unselecting Enable 
Basic IP Address Host ID Validation in the system configuration settings. (See Configuring 
System Settings.)

Table 3-15 • Host ID Types

Host ID Type Description
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Non-routable IP 
Address with 
Wildcards 

This setting allows you to define the host ID as a non-routable, private IP address with a 
wildcard (*) as one or more octets. Use the format INTERNET=w.x.y.z, where each letter 
represents an octet with a decimal value between 0 and 255.

FlexNet Operations validates that the address is among the permitted, non-routable sets. 
The address you specify must be an address within the primary three reserved, private 
network address ranges: 10.0.0.0-10.255.255.255, 172.16.0.0-172.31.255.255, and 
192.168.0.0-192.168.255.255.

The wildcard rules for non-routable IP addresses also apply. For an IP address of w.x.y.z

• If w is less than or equal to 127, then x, y, and z can be wildcards.

• If w is between 127 and 192, then only y and z can be wildcards.

• If w is greater than or equal to 192, then only z can be a wildcard.

Note • FlexNet Operations IP address validation can be disabled by unselecting Enable 
Basic IP Address Host ID Validation in the system configuration settings. (See Configuring 
System Settings.)

Disk SN This is used with Windows systems only and is the disk serial number.

Locks the software to a PC with this C:/ drive serial number. Enter as DISK_SERIAL_NUM=sn 
in the Activate Licenses page. 

FLEXid This is for Windows, Mac, and Linux systems only. Locks the software to a PC with a 
hardware dongle (hardware key) with serial number id_string. The format of this 
identifier depends on the brand of dongle used. 

Enter as FLEXID=id_string in the Activate Licenses page. 

Composite A composite host ID combines multiple FlexNet Publisher Licensing Toolkit host IDs 
together to provide a more secure host ID. For instance, you can use USER and Disk SN to 
identify a host ID. A composite host ID is a hashed 12-character hexadecimal value 
formed by combining the values of multiple simple host IDs types. 

If you select the Composite format, you must provide your end user with a program to 
calculate the Composite host ID for the host machine. Enter as COMPOSITE=comp_id in the 
Activate Licenses page. For more information about using Composite host IDs, see the 
FlexNet Publisher Licensing Toolkit documentation. 

Table 3-15 • Host ID Types

Host ID Type Description
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Vendor Defined The user must select the VENDOR_DEFINED item from the drop-down list and then enter the 
vendor-defined host as <name>=<string>

Note • If you specify a vendor-defined host ID, you must build your VCG to support your 
vendor-defined host ID type. 

Note • You can use a completely new entity to validate the host. The host ID for this entity 
is defined in Operations as <name> = <string>, where <name> is the entity name you 
want to use. You must define a list of allowable name values in the VCG. You must also 
create the code in the application or vendor daemon that obtains the string value.

Virtualization-
Aware

Virtualization-aware host ID prefixes define server host ID types that permit or restrict the 
kind of virtual environments, if any, on which a license server can run. These new host ID 
types begin with PHY_, VM_, VMW_, HPV_, or LMB_.

• Use the PHY_ prefix with ETHER, INTERNET, HOSTNAME, DISPLAY, USER, 
DISK_SERIAL_NUMBER, or FLEXID to restrict license operation to physical machines. 

• Use the VM_ prefix with UUID to restrict license server operation to any supported 
virtual environments: Xen, Hyper-V, and VMWare. VM_UUID supersedes VMW_UUID and 
HPV_UUID.

• Use the VMW_ prefix with UUID, ETHER, INTERNET, and HOSTNAME to restrict license server 
operation to VMWare Workstation and ESX Server virtualizations. VMW_UUID is still 
supported, but has been superseded by VM_UUID.

• Use the HPV_ prefix with UUID, ETHER, INTERNET, HOSTNAME, and VSN to restrict license 
server operation to Microsoft Hyper-V virtualizations. HPV_UUID is still supported, but 
has been superseded by VM_UUID.

• Use the LMB_ prefix with ETHER, INTERNET, HOSTNAME, or FLEXID (9 or 10) to permit 
license server operation with bare metal binding. This permits operation in a 
virtualization but binds the license to the physical host machine.

Note • VMW_HOSTNAME, HPV_HOSTNAME, and LMB_HOSTNAME host IDs cannot contain 
wildcards (asterisks).

Note • When used with three-server redundancy, virtualization-aware host ID types for all 
servers in the triad must use the same prefix: PHY_, VW_, VMW_, HPV_, or LMB_.

Table 3-15 • Host ID Types

Host ID Type Description
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Configuring Counts
If the entitlement line item contains a certificate-based, counted license model (nodelocked or floating), you are 
prompted to specify a fulfill count for each server host ID. If the entitlement line item contains a

• nodelocked uncounted license and you define multiple node-locked host IDs, then:

• multiple licenses files are created, one for each node-locked host ID.

• the Copies value for the entitlement line item decrements by the number of node-locked hosts you 
define.

• nodelocked counted license and you define multiple server host IDs, each with multiple node-locked hosts, 
then:

• multiple licenses files are created, one for each server host ID.

• the Copies value for the entitlement line item decrements by the sum of the fulfillment counts for each 
server.

• floating counted license and you define multiple server host IDs, then:

• multiple licenses files are created, one for each server host ID.

• the Copies value for the entitlement line item decrements by the sum of the fulfillment counts for each 
server.

• floating uncounted license and you define multiple server host IDs, then:

• multiple licenses files are created, one for each server host ID.

• the Copies value for the entitlement line item decrements by the number of server hosts you define.

If this is an upgrade, upsell, or renewal entitlement line item, the available information and options in the 
Configure Counts page are different, depending on the product’s license model. 

Cloud-Specific Cloud-specific host ID types permit the kinds of cloud-hosted environments, if any, in 
which the product can operate. There are two server host ID type options and two 
nodelocked host ID type options: 

• AMZN Routable EIP Address and AMZN Routable EIP Address with Wildcards—The 
AMZN_EIP host ID types permit license server operation in Amazon EC2 (public cloud) 
environments with binding to an elastic IP address. Routable and Routable with 
Wildcard addresses are supported. Non-routable addresses are not supported. This 
host ID type cannot be used with three-server redundancy.

• AMZN AMI Template ID and AMZN IID Instance ID—The AMZN_AMI and AMZN_IID host ID 
types permit nodelocked licensing in Amazon EC2 environments with binding to the 
AMI template ID or AMI instance ID, respectively. Template ID binding is typically 
used in virtual appliance scenarios. Instance ID binding supports more generic cloud-
based usage such as running software in the public cloud or in a virtual private cloud.

Table 3-15 • Host ID Types

Host ID Type Description
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Important • FlexNet Operations does not evaluate the count of available copies when an upgrade is created. 
Therefore, it is possible to create an upgrade count that exceeds the number of available copies; however, the 
count is evaluated at fulfillment time. On fulfillment, upgrades that exceed the available count are rejected. To 
avoid errors at fulfillment time, users can invoke the method getExactAvailableCount(), which returns the exact 
number of copies available for upgrade fulfillment. This method is available as a webservice call and also as part 
of public API.

1. Review the prepopulated fields on the Configure Counts page. The number of data fields that are displayed 
varies, depending on how the license model is defined. An important value in this list is: 

Total Remaining Copies: The number of copies in the entitlement line item that can be activated. This is the 
maximum number of licenses that the customer can fulfill against this entitlement line item, regardless of 
whether the fulfillment is a new or is an upgrade, upsell, or renewal of another product. 

2. Copies Available to Activate Without Upgrading Previous Fulfillments: 

Use these fields to define the number of copies you to activate without upgrading an existing product.  

3. Copies Available To Upgrade From Previous Fulfillments on host <Host ID> 

Table 3-16 • Configure Count Fields

Property Description

Available Copies The number of copies in the entitlement line item that can be fulfilled as a new 
activation. It does not include the number of copies that are available as an upgrade 
to another product. This does not include Extra Activations.

Extra Activations 
Available

This number is set when you define the license model. This is the number of extra 
copies of the product (beyond those purchased) that are available to be activated.

Pending Copies If you have defined multiple server host IDs, this value is the number of copies that 
have already been assigned to the other Hosts IDs in this activation action.

Fulfill Count     The total number of licenses you want to fulfill for this server host ID. Specify a fulfill 
count for each of the fulfillments you are generating. In the case of the floating 
counted license model, you must specify a count for each server or three-server 
configuration on which you want licenses activated. In the case of the node-locked 
counted license model, you must provide counts for each server (or three-server 
configuration) specified, and the nodelocked hosts attached to that server.

Remaining 
Overdraft

The number of remaining unused Overdraft Licenses.

Overdraft Enter the number of Overdraft licenses you want to allow for this server host ID.
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Use these fields to define the number of copies you want to activate as part of upgrading an existing product. 
This question is displayed for each server host ID defined on the previous page. 

4. What kind of Activation do you want to perform on this host?

This is displayed only when the license model is uncounted and is displayed for each server host ID defined 
on the previous page. When the license model is uncounted, you activate one copy at a time. The answer to 
this question tells the system how that single copy is to be activated. 

• <Upgrade/Upsell>: you activate this copy by upgrading or upselling an existing product (that is, 
fulfillment). If you select this, you are presented with a list of entitlement line items that references 
fulfillments products previously activated for that server host ID and that can be upgraded or upsold to 
this new product. You can choose which product you want to be upgraded/upsold. 

• Activate: you activate this copy by creating a new fulfillment for this server host ID.

• None: you do not activate any copies of this product for this server host ID. 

5. Finish specifying the Configure Counts properties. Then click Next to go to the Generate Licenses - Review 
page.

Note • When the activation includes multiple host IDs, an arrow in the Hosts list indicates the current host ID. 
Clicking Next on the Configure Counts page advances to the next host ID. When counts are configured for the 
last host ID, clicking Next advances you to the Review step.

Configuring Counts for Trusted Activation
If the entitlement line item contains a counted license model (trusted, server), you are prompted to define a fulfill 
count for each server host. If the entitlement line item contains a

• retail license (uncounted) and you define multiple host IDs, then:

• multiple licenses files are created, one for each host ID.

• the Copies value for the entitlement line item decrements by the number of hosts you define.

Table 3-17 • Configure Count Types

Property Description

Available 
<Upgrade/Upsell/
Renew> Count

This value is not editable and displays the total number of copies previously fulfilled 
for this server host ID that can be upgraded, upsold, or renewed to this new product. 

Upgrade Count This field is displayed when you are activating licenses for an upgrade, upsell, or 
renewal entitlement line item. 

The number of copies of earlier products that have been activated for this server host 
ID. Define the number of copies that you want to upgrade/upsell/or renew for this to 
this new product. 

This entry allows the upgrade to occur on licenses that have already been fulfilled. 
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• server license (counted) and you define multiple host IDs, then:

• multiple licenses files are created, one for each host ID.

• the Copies value for the entitlement line item decrements by the sum of the fulfillment counts for each 
server.

Whether the entitlement line item is an upgrade, upsell, or renewal, the available information and options in the 
Configure Counts page are the same. 

Important • FlexNet Operations does not evaluate the count of available copies when an upgrade is created. 
Therefore, it is possible to create an upgrade count that exceeds the number of available copies; however, the 
count is evaluated at fulfillment time. On fulfillment, upgrades that exceed the available count are rejected. To 
avoid errors at fulfillment time, users can invoke the method getExactAvailableCount(), which returns the exact 
number of copies available for upgrade fulfillment. This method is available as a web service call and also as part 
of public API.

1. Review the prepopulated fields on the Configure Counts page. The number of data fields that are displayed 
varies depending on how the license model is defined. An important value in this list is: 

Total Remaining Copies: The number of copies in the entitlement line item that can be activated. This is the 
maximum number of licenses that the customer can fulfill against this entitlement line item, regardless of 
whether the fulfillment is a new or is an upgrade, upsell, or renewal of another product.

2. Finish specifying the Configure Counts properties for the current host. 

3. Click Next to go to the Generate Licenses - Review page. 

Table 3-18 • Configure Count Fields

Property Description

Available Copies The number of copies in the entitlement line item that can be fulfilled as a new 
activation. It does not include the number of copies that are available as an upgrade 
to another product. This does not include Extra Activations.

Extra Activations 
Available

This number is set when you define the license model. This is the number of extra 
copies of the product (beyond what was purchased) that is available to be activated.

Pending Copies If you have defined multiple server host IDs, this is the number of copies that have 
already been assigned to the other Hosts IDs in this activation action.

Fulfill Count     The total number of licenses you want to fulfill for this server host ID. Specify a fulfill 
count for each of the fulfillments you are generating.

Remaining 
Overdraft

The number of remaining unused Overdraft Licenses.

Overdraft Enter the number of Overdraft licenses you want to allow for this server host ID.



Chapter 3 Entitling Customers and Activating Licenses
Activating Licenses

184 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Note • When the activation includes multiple hosts, an arrow in the Hosts list indicates the current host. 
Clicking Next on the Configure Counts page advances to the next host. When counts are configured for the 
last host, clicking Next advances you to the Review step. 

Reviewing Activations and Generating Licenses
Prior to generating licenses, the Producer Portal allows you to review the activations. (This step is the same in 
both the Activate License wizard and the Trusted Activate wizard.) 

Task To review activations and generate licenses

1. On the Generate Licenses - Review page, click either:

• Verify: This option evaluates properties defined and determines whether the license is valid. (Not 
available for trusted activations.) 

• Generate: This option activates the license and opens the Generated Licenses page. 

2. On the Generated Licenses page

a. For unconsolidated licenses, a certificate is issued for each product on each server. 

b. For consolidated licenses, one file is issued per server. 

c. For trusted licenses, there is one response/license per host.

Note • For more information about viewing a consolidated license, see Consolidating Licenses. If you have 
selected more than one file to view, you can choose among license files by selecting the appropriate 
Consolidated License ID from the drop-down list provided.

On the Generated Licenses page, you can choose to Save to File or Print one or more licenses. (For certificate-
based licenses, you can also choose to Email License or see Shipment Records.) 

Transferring Entitlement Line Items
You can transfer unfulfilled copies of an entitlement line item from one account to another.

To do this, the account that is to receive the entitlement must be defined in FlexNet Operations. This is done 
using the Producer Portal’s account management capabilities. (See Managing Accounts.)

As part of this transfer process, you can choose to either create a new entitlement for the transferred entitlement 
line item or to add it to an existing entitlement for that target account. You can also maintain the Activation ID or 
create a new one. The Transfer Entitlement Line Item Wizard walks you through each of these choices. 

After the license rights are transferred, the Activation ID may change (depending on your wizard selections). A 
new entitlement line item is created for the target account. 

To transfer an entire entitlement, see Transferring Entitlements.
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Transfer Entitlement Line Item Wizard
Required fields are indicated by a red asterisk. To proceed through the wizard:

1. Click Entitlements > List Entitlements. This link opens the List Entitlements page.

2. Select an entitlement line item from the list, and then click Transfer. 

3. Enter the Transfer Amount.

4. Target Account: Search for and select the account that is to receive the line item.

5. Do you want to transfer to a similar line item owned by the target account?

• Yes: The system searches for similar line items. 

• No: A new entitlement and line item is created for the target account. 

Emailing a License 
A new or previously generated license certificate or custom license can be sent as an email attachment to one or 
more email addresses. The email attachment is sent as a file, by default called licensexxxxx.lic, where xxxxx is 
a random number. The default subject line is License.

The Ship to email field contains the email address where the license is to be sent. This field contains email 
addresses that were specified in the entitlement or during license generation. Click Search to select an email 
address for one of the contacts in the sold-to account. Additional email addresses can be entered, and multiple 
email addresses are formatted in a comma-separated list with no spaces. 

After the email is sent, a confirmation message is displayed on the page.

You must configure FlexNet Operations before you can successfully email a license certificate: 

• If you are emailing license certificates to customers, in the FlexNet Platform Server configuration settings, 
set the Outbound Mail Server Host to your organization’s mail server and From-Address for Outbound Mail to 
the email address you want to use as the sending address for license emails. 

• You may want to edit the license file base name, which is license by default. The License File Name can be 
changed in the FlexNet Operations system configuration settings. Note that a random number is added to 
this base name and a .lic extension is added.

Manual Activations 
Trusted activations are normally done programmatically as transactions between a client or server activation 
utility and the FlexNet Operations server. The activation utility generates a request that is submitted 
programmatically and the FlexNet Operations server generates a response that is used to complete the 
activation. 

However, an activation request can also be generated and written to a file by a FlexNet Publisher Licensing 
Toolkit activation utility running on the machine where the license is to be activated. Such a manual activation is 
useful when there is no internet connectivity on the host.

• The file containing the request is sent to the producer and loaded into FlexNet Operations to generate a 
response. 
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• The response is saved to a file; the file is sent to the customer and is used by the FlexNet Publisher Licensing 
Toolkit activation utility to process the response. The response is processed differently, depending on 
whether a license has ever been generated on that machine using the transaction key associated with the 
product to be activated. If a license has never been activated on the target machine using this transaction 
key, the first response just configures trusted storage. A second request and response must be generated to 
actually activate the license. This two-step process is handled automatically by programmatic activation. 

• If the first response is used to configure trusted storage, the activation utility prompts the customer to 
generate a second request to activate the license. 

Task To generate a response to an activation request submitted in a file

1. Click Licenses > Manual Activation. 

2. Browse to, and select the XML file that contains the activation request. 

3. Click Submit to generate and view the activation response. 

Viewing a Manual Activation Response  
Follow the instructions below to view a manual activation response.

Task After an activation response is generated manually

1. Verify the Activation ID, Product, Version, Fulfillment ID, and Sold To account. 

2. Click Save To File to save this response to a file. The default file name is responseXML.xml. 

3. Send the file to the customer with instructions for using the activation utility to process the response and 
activate the license. 

Short Code Activations 
Trusted activations are normally done programmatically as transactions between a client or server activation 
utility and the FlexNet Operations server. Usually, the activation utility generates a request that is submitted 
programmatically and the FlexNet Operations server generates a response that is used to complete the 
activation. 

However, if a customer’s environment does not support communication with the FlexNet Operations server, 
FlexNet Operations can generate a short code activation specification record (ASR) that can be used to generate 
an activation request. Short code activations are typically used in activations performed over the phone.

• A producer uses FlexNet Operations to generate a short code ASR and bundles it with the product.

• A FlexNet Publisher Licensing Toolkit activation utility running on the machine where the license is to be 
activated uses the short code ASR bundled with the product to generate a short request code. 

• The short request code is sent to the producer and loaded into FlexNet Operations to generate a short 
response code. 
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• The response code is saved to a file; the file is sent to the customer and is used by the FlexNet Publisher 
Licensing Toolkit activation utility to process the activation response and activate the license. 

Task To allow a customer to activate a license using a short response code

1. Create a short code ASR for a product. 

2. Bundle the short code ASR with the product or send the customer the short code ASR in a file. 

3. Instruct the customer to use the FlexNet Publisher Licensing Toolkit activation utility that you provide to 
generate a short request code from the short code ASR file. 

4. Receive the generated short request code from the customer, along with the customer’s activation ID. 

5. In FlexNet Operations, click Licenses > Short Code Activation. 

6. Enter values in the following fields.

7. Click Next to generate and view the short response code. 

Viewing a Short Code Activation Response 
Follow the instructions below to view a short code activation response.

Task After a short response code is generated manually

1. Save the short response code to a file. 

2. Send the file to the customer with instructions for using the activation utility to process the response and 
activate the license. 

Table 3-19 • Short Code Activation Fields

Field Description

Short Request Code Short request code generated by the FlexNet Publisher Licensing Toolkit 
activation utility and sent by the customer. 

Activation ID Activation ID of the line item or web register key that you want to activate.
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Supporting Licenses

Supporting licenses covers additional license lifecycle processes: 

• Support Licenses Terminology

• Viewing Fulfillment Records

• Returning a License

• Repairing a License

• Rehosting a License

• Generating an Emergency License

• Correcting a Publisher Error in a License

• Upgrade, Upsell, or Renew a Fulfillment

• Generating a Stop Gap License

• Consolidating Licenses

• Transferring Licenses

• Manual Return

• Manual Repair

• Short Code Return

• Short Code Repair

• Supporting Hosts

• Supporting Embedded Licenses

• Supporting Offline Device Activation

For trusted licenses, these lifecycle processes are usually handled by FlexNet Operations without publisher 
intervention. However, manual returns and manual repairs can be performed on activations. 
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Support Licenses Terminology 
The following terms are referred to when supporting licenses:

• What is a Fulfillment?

• What is a License Return?

• What is a License Repair?

• What is a License Rehost?

• What is an Emergency License?

• What is a Stop Gap License?

• What is Support Type?

• What is License Consolidation?

What is a Fulfillment? 
A fulfillment is a transaction against an entitlement line item in which some portion of the entitlement is assigned 
to a specific license server system or to a specific FLEXenabled application’s machine. A fulfillment can be 
generated in FlexNet Operations in one of the following ways: 

• Through the FlexNet Operations Producer Portal on behalf of an end user 

• Through the End-User Portal by an end user 

• Using the License Web service 

In addition, trusted activations can be performed programmatically.

What is a License Return? 
A license return involves removing the license rights from a system and transferring the license rights back to an 
entitlement line item, generally to allow a different license to be created. The number of allowed license returns 
per unit time per entitlement line item can be governed by a policy on the license model or entitlement line item. 

Most trusted returns are done programmatically, but they can also be done through the FlexNet Operations 
Producer Portal or End-User Portal.

What is a License Repair? 
A repair operation is used to repair a license that does not work for a customer. The meaning of a license repair is 
different for trusted and certificate licenses:

• For a certificate license, a repair is a customer-initiated change to a license to change a license parameter 
other than a host ID. A repair initiates a license return, then generates a modified license certificate. 

• For a trusted license, a repair is necessary when a license becomes invalid because the machine hardware 
configuration has been changed enough that the anchor is broken. 
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Most trusted repairs are done programmatically, but they can also be done through the FlexNet Operations 
Producer Portal or the End-User Portal. 

The number of allowed license repairs per unit time per entitlement line item can be governed by a policy on the 
license model or entitlement item.

What is a License Rehost? 
For a certificate license, a re-host operation is a customer-initiated change to a license to transfer a license from 
one host ID to another. No license properties other than the host ID are modified for a re-host operation. A rehost 
initiates a license return, then generates a modified license certificate. 

The number of allowed license rehosts per unit time per entitlement line item can be governed by a policy on the 
license model or entitlement line item. 

What is an Emergency License? 
An emergency certificate license is a short-term license that a publisher can provide as a courtesy to a customer 
who has a license that has not expired, but is not functioning. 

When generating an emergency license, you can change only the license duration and host ID relative to the 
original license. An emergency license is intended to be a short-term license, with a default expiration period of 
30 days. 

What is a Stop Gap License? 
A stop gap certificate license is a short-term license that a publisher can provide as a courtesy a customer whose 
license has expired, but who has not yet completed the process of updating or renewing an entitlement. 

This can occur, for example, during the contract-negotiation period for a license renewal. Similar to an emergency 
license, for a stop-gap license you can modify only the license duration or license expiration date.

What is Support Type? 
The support type is listed on the Support Licenses page and identifies the type of fulfillment that is generated. 
The following support types are available:

• EMERGENCY: A fulfillment generated by the Emergency operation. An emergency license is a short-term 
license generated to cover an emergency situation when a customer’s license has not expired, but isn’t 
working. 

• PUBLISHER ERROR: A fulfillment generated by the Publisher Error operation. If a publisher makes an error 
when generating a license for a customer, it can be corrected and does not count against a customer’s 
return, repair, or rehost policy limits.

• STOP GAP: A fulfillment generated by the Stop Gap operation. If a customer’s license has expired and the 
customer has not formally renewed its entitlement, the publisher can generate a short-term stop gap license.

• MASTER: A fulfillment record that is created when a license is activated. When any portion of that fulfillment 
is returned, repaired, upgraded, upsold, or rehosted, the MASTER record is marked as obsolete. In addition:
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Note • For returns, if the entire fulfill count is returned, there is no additional fulfillment record created 
because the count goes back to the entitlement line item. If only a partial amount is returned, the partial 
return count is credited to the entitlement line item and and the obsolete fulfillment record is marked as 
returned. 

Viewing Fulfillment Records 
The Support Licenses and Maintenance page displays all active fulfillments, certificate and trusted, in order of 
modification date, most recently modified first. Trusted fulfillments are marked with an icon with a blue key. 

To view fulfillment records, select Activation ID, Product, Sold To, Hostid, or Fulfill ID from the Search For drop-
down, and click Simple Search. You can also search for fulfillment records based on specific criteria. 

From this page, you can:

Table 4-1 • Fulfillment Capabilities

Action Description

See the details of an 
fulfillment 

To see the details of a fulfillment, click its fulfillment ID. 

Return a license A license is returned to allow it to be activated again at a later time. The number 
of returns against an entitlement line item can be limited by a return policy. To 
return a certificate license, select exactly one fulfillment record and click 
Support Actions > Return. 

Repair a license A certificate license is repaired to change license parameters other than a host 
ID. The number of repairs against an entitlement line item can be limited by a 
repair policy. Repairing a license in trusted storage means something different 
and is done differently. To repair a certificate license, select exactly one 
fulfillment record and click Support Actions > Repair. 

Rehost a license A license is rehosted to change one or more host IDs. The number of rehosts 
against an entitlement line item can be limited by a rehost policy. To rehost a 
certificate license, select exactly one fulfillment record and click Support 
Actions > Rehost. 

Generate an emergency 
license 

An emergency license is a short-term license generated to cover an emergency 
situation when a customer’s license has not expired, but isn’t working. To 
generate an emergency certificate license that is related to a non-working 
license, select the fulfillment record of the non-working license and click 
Support Actions > Emergency. Generating an emergency license does not 
return the original license.
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Returning a License  
The number of allowed license returns per unit time per entitlement line item can be governed by a policy on the 
license model or entitlement line item. 

Correct a publisher error If a publisher makes an error when generating a license for a customer, it can 
be corrected and does not count against a customer’s return, repair, or rehost 
policy limits. To correct an error the publisher made to a certificate license, 
select exactly one fulfillment record and click Support Actions > Publisher 
Error. 

Generate a stop gap license If a customer’s license has expired and the customer has not formally renewed 
its entitlement, the publisher can generate a short-term stop gap license. To 
generate a stop gap certificate license that is related to an expired license, 
select the fulfillment record for the expired license and click Support Actions > 
Stop Gap.

Consolidate licenses You can consolidated the license lines from different certificates into a single 
file, provided the certificates belong to the same licensing technology and 
customer account. For FlexNet technology, only certificate licenses can be 
consolidated.

Upgrade a license A customer replaces an older version of a product with a newer version, such as 
moving from MyProgram Version 4.5 to MyProgram Version 5.0. 

Upsell a license A customer replaces a product with another product that provides a superset of 
the original’s functionality, such as moving from the MyProgram Standard 
Edition to the MyProgram Professional Edition.

Renew a license Extending the expiration date of a product’s original entitlement, or its version 
date, to a date further in the future. It is not necessary to define a relationship 
for a renew operation because the product involved does not change. 

Save To File A certificate license can be saved to a file. 

Email License A certificate license can be sent as an email attachment. 

View consolidated licenses You can view a list of consolidated license files and also view the contents of 
individual files.

Print a fulfillment record Select one or more fulfillment records on the Support Licenses page and click 
Print. 

Table 4-1 • Fulfillment Capabilities

Action Description
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Task To return a license to regenerate it at a later time

1. Click Licenses > Licenses. This link opens the Support Licenses and Maintenance page. 

2. Search for a fulfillment for which a license is to be returned. Search by Activation ID, Product, Sold To, 
Hostid, or Fulfill ID. 

3. Select one fulfillment ID. Click Support Actions, and then click Return.

4. Enter a Ship to Email or a Ship To Mail address, if applicable. 

5. The Return Count shows the entire fulfill count of the returned fulfillment. If you want to return only part of 
the original fulfill count, specify the Return Count to return. 

6. The Return Overdraft Count shows the entire overdraft count of the returned fulfillment. If you want to return 
only part of the original overdraft count, specify the Return Overdraft Count to return. 

7. Click Return to return the specified fulfillment. 

When the license has been successfully returned, if the cancel policy allows it, the entitlement line item 
against which the license was created is credited. 

When a Web register key was redeemed, a simple entitlement was created with an entitlement ID and its 
fulfill count. Therefore, if a license generated against a Web register key is returned, its simple entitlement 
line item is credited, not the original bulk entitlement. 

When the license has been successfully returned, the return count entered by the user is credited for the 
entitlement line item against which the license was created. Therefore, if a license generated against a Web 
register key is returned, the return count for its simple entitlement line item is credited. 

The new fulfillment generated by the return operation is displayed with the Support Type MASTER. The original 
returned fulfillment record is displayed in the Support Licenses page as Obsolete with support action as RETURN.

Repairing a License  
From time to time, customers may require support for license keys. Requests for support of certificate licenses 
are processed as repairs and involve the change of a license parameter other than a host ID. 

A publisher can set policies on how many repairs are allowed on a particular line item in a given duration. 

Task To repair a license because a customer wants to change a license parameter other than a host ID

1. Click Licenses > Licenses. This link opens the Support Licenses and Maintenance page.

2. Search for a fulfillment for which a license is to be repaired. Search by Activation ID, Product, Sold To, 
Hostid, or Fulfill ID. 

3. Select one fulfillment ID and click Repair from the Support Actions drop-down menu. 

4. Enter a Ship To Email or a Ship To Mail address, if applicable. 

5. Replace the original attribute value with the one to be used for the new license. Hostid values cannot be 
changed with a repair. The entire count of the fulfillment is repaired. 
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6. To check that the parameter values can be used to generate a valid license before actually generating a 
license, click Verify. To generate a license certificate, click Repair. 

7. After a license is generated, the license text is displayed. The license text can be saved to a file on disk by 
clicking Save to File or it can be sent as an email attachment by clicking Email License. 

For information about the file naming conventions, see FlexNet Operations system configuration settings. 
The license certificate can be saved to a file on disk by clicking Save to File. 

The shipment history of this license can be displayed by clicking Shipment Records. 

The new fulfillment generated by the repair operation is displayed with the Support Type MASTER. The original 
returned fulfillment record is displayed in the Support Licenses and Maintenance page as Obsolete with support 
action as REPAIR.

Rehosting a License  
Rehosting is defined as the process of moving a license from one machine to another. A publisher can define 
policies to control the number of rehosts in a given duration of time per line item. This policy can be defined on 
the license model or the entitlement line item.

Task To rehost a license because a customer wants to change a host ID

1. Click Licenses > Licenses. This link opens the Support Licenses and Maintenance page.

2. Search for a fulfillment for which a license is to be rehosted. Search by Activation ID, Product, Sold To, 
Hostid, or Fulfill ID. 

3. Select one fulfillment ID and click Rehost from the Support Actions drop-down menu.

4. Enter a Ship to Email or a Ship To Mail address, if applicable. 

5. Replace the original host ID with the one to be used for the new license. No other license model attributes 
can be changed. 

6. The Rehost Count shows the entire fulfill count of the returned fulfillment. If you want to rehost only part of 
the original fulfill count, specify the Rehost Count to return. 

7. The Rehost Overdraft Count shows the entire overdraft count of the returned fulfillment. If you want to rehost 
only part of the original overdraft count, specify the Rehost Overdraft Count to return. 

8. To check that the parameter values can be used to generate a valid license before actually generating a 
license, click Verify. To generate a rehosted license certificate, click Rehost. 

9. After a license is generated, the license text is displayed. The license text can be saved to a file on disk by 
clicking Save to File or it can be sent as an email attachment by clicking Email License. The shipment history 
of this license can be displayed by clicking Shipment Records. 

For information about the file naming conventions, see Configuring System Settings.

The new fulfillment generated by the rehost operation is displayed with the Support Type MASTER. The original 
returned fulfillment record is displayed in the Support Licenses and Maintenance page as Obsolete with support 
action as REHOST.
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Generating an Emergency License  
An emergency license is a short-term license generated to cover an emergency situation when a customer’s 
license has not expired, but isn’t working. Generating an emergency license does not return the original license.

Task To generate an emergency license because a customer cannot use unexpired licenses

1. Click Licenses > Licenses. This link opens the Support Licenses and Maintenance page.

2. Search for a fulfillment for which an emergency license is to be generated. Search by Activation ID, Product, 
Sold To, Hostid, or Fulfill ID. 

3. Select one fulfillment ID and click Emergency. Generating an emergency license does not cause the original 
fulfillment to be returned. 

4. Enter a Ship to Email or a Ship To Mail address, if applicable. 

5. By default, the Start Date of an emergency license is the Fulfill Date of the original fulfillment. You can set a 
different Start Date and can set the expiration to be after a set Duration or to a specific Expiration Date. 

6. Replace license parameters for the emergency license. The entire count of the fulfillment is used for the 
emergency license.

7. To check that the parameter values can be used to generate a valid license before actually generating a 
license, click Verify. To generate an emergency license certificate, click Emergency. 

8. After a license is generated, the license text is displayed. The license text can be saved to a file on disk by 
clicking Save to File or it can be sent as an email attachment by clicking Email License. The shipment history 
of this license can be displayed by clicking Shipment Records. 

For information about the file naming conventions, see Configuring System Settings.

Emergency fulfillments appear in the Support Licenses and Maintenance page as Support Type EMERGENCY. 

Correcting a Publisher Error in a License  
If a publisher makes an error when generating a license for a customer, it can be corrected and does not count 
against a customer’s return, repair, or rehost policy limits. 

Task To regenerate a license because the publisher made an error generating the original license

1. Click Licenses > Licenses. This link opens the Support Licenses and Maintenance page. 

2. Search for a fulfillment for which a license is to be repaired. Search by Activation ID, Product, Sold To, 
Hostid, or Fulfill ID. 

3. Select one fulfillment ID and click Publisher Error in the Support Actions drop-down menu. 

4. Verify that you want to return the license to correct it.

5. Enter a Ship to Email and a Ship To Mail address, if applicable. 
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6. By default, the Start Date is the Fulfill Date of the original fulfillment. You can set a different Start Date and 
can set the expiration to be after a set Duration or to a specific Expiration Date. 

7. Replace the incorrect values with those to be used for the new license. You can choose to correct a 
publisher-generated error for the entire fulfill count, or a partial amount. 

8. To check that the parameter values can be used to generate a valid license before actually generating a 
license, click Verify. To generate a license certificate, click Generate New License. 

9. After a license is generated, the license text is displayed. The license text can be saved to a file on disk by 
clicking Save to File or it can be sent as an email attachment by clicking Email License. The shipment history 
of this license can be displayed by clicking Shipment Records. 

For information about the file naming conventions, see Configuring System Settings. 

Corrected fulfillments appear in the Support Licenses and Maintenance page as Support Type MASTER and the 
Original fulfillment record is marked as Obsolete with a support Type PUBLISHER ERROR. 

Upgrade, Upsell, or Renew a Fulfillment
You can upgrade, upsell, or renew one or more seats in a fulfillment. The new license is created for the currently 
defined server host. 

This process is similar to activation of an upgrade, upsell, or renewal entitlement line item. The difference is that 
this process allows you to control which fulfillments are upgraded, upsold, or renewed.

Important • Before upgrading or upselling a fulfillment, you must upgrade, upsell, or renew the customer’s 
entitlement line item for the product that this fulfillment references.

Important • Some conflicts can prevent the successful activation of upgrade line items. See Avoiding the Creation 
of Upgrade Line Items with Incompatible License Models for details.

Tip • FlexNet Operations can automatically upgrade line items for qualifying products and line items with the 
Product Version Upgrade job. See FlexNet Operations Alert Types.

When you upgrade, upsell, or renew a fulfillment, the status of the original fulfillment is changed to Obsolete and 
the Support Type is changed to either UPGRADE, UPSELL, or RENEW accordingly. A new fulfillment is created and 
the Support Type is MASTER. If you upgrade or upsell only a portion of the total Count in a fulfillment, then two 
fulfillments are created. The status of the original fulfillment is changed to Obsolete and the Support Type is 
changed to either UPGRADE, UPSELL, or RENEW accordingly.

For example, F1-P1 is a fulfillment for ten seats of product P1 (the Count property equals 10). You upgrade only 
two seats from that fulfillment to product P2. The status of fulfillment F1-P1 is changed to Obsolete and the 
Support Type is changed to UPGRADE. Two new fulfillments are created:

• F2-P1 is a fulfillment for the remaining eight seats of product P1.

• F3-P2 is a fulfillment for the two seats of product P2.
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If you are upgrading or upselling a product with a floating counted, floating uncounted, and nodelocked counted 
license model and the entitlement line item for the new product specifies a nodelocked uncounted license model, 
the user is prompted to define either the server host ID or the nodelocked host ID (see the following table for 
details).

For example, in case 3 of the following table, the license model changes from floating counted to nodelocked 
counted, the new fulfillment record requires that nodelocked host IDs be defined. The server host ID is obtained 
from the original fulfillment record, but the user is prompted to define the nodelocked host IDs. If there is no 
change in the license model type, then all the information is retained from the original entitlement line item. 

Table 4-2 • 

Original License 
Model

Upgrade or Upsell 
License Model

User is prompted to define the following host IDs (Server or 
Nodelocked): 

1 FC FC None

2 FC FU None

3 FC NC Nodelocked host ID

4 FC NU Nodelocked host ID1

5 FU FC None

6 FU FU None

7 FU NC Nodelocked host ID

8 FU NU Nodelocked host ID

Note • In this case, the SUPERSEDE keyword is not used in the 
upgraded license, even if you enabled the Use SUPERSEDE 
Keyword for Upgrade and Renewal Licenses property in the 
System > Configure > FlexNet Operations page.

9 NC FC None

10 NC FU None

11 NC NC None

12 NC NU Nodelocked host ID

Note • In this case, the SUPERSEDE keyword is not used in the 
upgraded license, even if you enabled the Use SUPERSEDE 
Keyword for Upgrade and Renewal Licenses property in the 
System > Configure > FlexNet Operations page.
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Upgrade Process 
The following steps describe the upgrade process:

1. Upgrade Products for the Activation ID... page.

If there are multiple products (or entitlement line items) that this product can be upgraded or upsold to, you 
are presented with a list of entitlement line items that you can choose from. If there is only one entitlement 
line item that meets this requirement, you are not prompted to select anything. 

2. In the <Upgrade/Upsell/Renew> Fulfillment... page, define the required properties.

3. Click:

• Verify to check whether the values entered generate a valid license.

• Generate <Upgrade/Upsell/Renew> License to create the new license and complete the process.

13 NU FC Server host ID

Note • In this case, the SUPERSEDE keyword is not used in the 
upgraded license, even if you enabled the Use SUPERSEDE 
Keyword for Upgrade and Renewal Licenses property in the 
System > Configure > FlexNet Operations page.

14 NU FU Server host ID

Note • In this case, the SUPERSEDE keyword is not used in the 
upgraded license, even if you enabled the Use SUPERSEDE 
Keyword for Upgrade and Renewal Licenses property in the 
System > Configure > FlexNet Operations page.

15 NU NC Server and nodelocked host ID

Note • In this case, the SUPERSEDE keyword is not used in the 
upgraded license, even if you enabled the Use SUPERSEDE 
Keyword for Upgrade and Renewal Licenses property in the 
System > Configure > FlexNet Operations page.

16 NU NU None

FC=floating counted; FU=floating uncounted; NC=node-locked counted; NU=node-locked uncounted.

Table 4-2 • 

Original License 
Model

Upgrade or Upsell 
License Model

User is prompted to define the following host IDs (Server or 
Nodelocked): 
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Important • FlexNet Operations does not evaluate the count of available copies when an upgrade is created. 
Therefore, it is possible to create an upgrade count that exceeds the number of available copies; however, the 
count is evaluated at fulfillment time. On fulfillment, upgrades that exceed the available count are rejected. To 
avoid errors at fulfillment time, users can invoke the method getExactAvailableCount(), which returns the exact 
number of copies available for upgrade fulfillment. This method is available as a web service call and also as part 
of public API.

Avoiding the Creation of Upgrade Line Items with Incompatible License Models
Some license technology and license model conflicts can prevent the successful activation of upgrade line items. 
(FlexNet Operations does not prevent the creation of these upgrade line items, but the resulting line items cannot 
be successfully activated.) The following upgrade paths result in upgrade line items that cannot be activated: 

Using the SUPERSEDE and SUPERSEDE_SIGN Keywords
The SUPERSEDE keyword, available in FlexNet Operations 8.2 and later, is an optional attribute of an INCREMENT 
line. Normally, INCREMENT lines in certificate licenses are additive: each INCREMENT line adds to the total 
number of licenses. However, if SUPERSEDE appears in a line, all licenses issued for the listed features earlier 
than the date specified in ISSUED= or START= are superseded by the contents of the line.

If f1, f2, and f3 are features of a product, an example of the use of SUPERSEDE would be:

INCREMENT f1 ... 1 ... ISSUED=1-jan-2008
INCREMENT f1 ... 4 ... SUPERSEDE ISSUED=1-jan-2009

The second line supersedes the first, and the first line is ignored.

FEATURE f1 ... 1 ... ISSUED=1-jan-2008
FEATURE f2 ... 1 ... ISSUED=1-jan-2008
FEATURE f3 ... 4 ... SUPERSEDE="f1 f2" ISSUED=2-jan-2009

Table 4-3 • 

Upgrading From Upgrading To Notes

Custom licensing FlexNet Publisher 
Trusted Licensing

Sharing counts between a license model from a custom 
license technology and retail activation license model is 
not supported.

FlexNet Publisher 
Certificate Licensing

FlexNet Publisher 
Trusted Licensing

Sharing counts between a floating, counted license 
model and a retail activation license model is not 
supported.

FlexNet Embedded 
Licensing

FlexNet Publisher 
Certificate Licensing

Sharing counts between an embedded counted license 
model and a node-locked, uncounted license model is 
not supported.

FlexNet Embedded 
Licensing

FlexNet Publisher 
Trusted Licensing

Sharing counts between an embedded, counted license 
model and a retail activation license model is not 
supported.
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In this example, f3 supersedes f1 and f2 and causes the license file to support only f3.

Specifying a start date with the ISSUED= keyword makes this date explicit (such as ISSUED=1-jan-2009). If the 
ISSUED date is not set, then SUPERSEDE uses the START= date.

Multiple INCREMENT lines for the same feature, specifying SUPERSEDE with the same ISSUED= date, are pooled 
together rather than superseding one another. The resulting license pool collectively SUPERSEDEs the older 
feature. For example:

INCREMENT f1 ... 1 ... ISSUED=1-jan-2008
INCREMENT f1 ... 4 ... SUPERSEDE ISSUED=1-jan-2009
INCREMENT f1 ... 3 ... SUPERSEDE ISSUED=1-jan-2009

results in a license pool containing seven licenses for f1, collectively superseding the first INCREMENT line.

SUPERSEDE_SIGN works similarly to SUPERSEDE, but the supersede is based on signatures available in FlexNet 
Operations 11.5 or later. 

Note • You cannot use both the SUPERSEDE and SUPERSEDE_SIGN keywords on the same feature definition line 
(or package line). Do not use both the SUPERSEDE keyword and the SUPERSEDE_SIGN to override the license 
model for the same feature name or package name. This may produce unexpected results. SUPERSEDE_SIGN is 
explained in the FlexNet Publishing Licensing Toolkit documentation.

Considerations When Using SUPERSEDE or SUPERSEDE_SIGN
This section explores issues to consider when using the SUPERSEDE keyword.

Server-based License Model to a Client-based License Model
An upgraded entitlement line item may refer to a different type of license model than the original line item; that is, 
server-based or client-based. For example, one line item could refer to a floating counted license model and a 
second line item could refer to a nodelocked uncounted model. As a result, the hosts necessarily are different. 
This operation is almost like rehosting the license from a server to a client.

Even if FlexNet Operations used the SUPERSEDE keyword in this case, it is not effective if the user chooses not to 
install the superseded license on the server. As a result, the SUPERSEDE keyword is not generated.

The same problem exists for upgrading from a client-based license model to a server-based license model.

Because SUPERSEDE overrides all features in that server ISSUED prior to the ISSUED date of the SUPERSEDE line, 
caution must be exercised when using it. Consider these situations before implementing SUPERSEDE.

Different Identifiers for the Same Host
A host can be identified using an IP address or a DNS name in FlexNet Operations, but there is no way to confirm 
that this is the same host. As a result, FlexNet Operations may not regenerate the licenses for certain fulfillments 
on that host, causing some features to be superseded inadvertently.

Using host ID policies can help mitigate this problem. Most publishers restrict how a host can be defined. For 
example, some of them may allow their users to use only DNS names. 
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Trusted Storage Licensing
Trusted storage licensing currently supports both returns and repairs. Currently, an upgrade operation is 
implemented as returning the previous license and activating a new one. As a result, FlexNet Operations cannot 
track that a new fulfillment was created due to upgrading another fulfillment and the SUPERSEDE keyword is not 
generated for trusted storage licenses. 

Also, the SUPERSEDE solution depends on the fact that FlexNet Operations records all the licenses ISSUED for a 
particular host. If there is a trusted activation on that host, FlexNet Operations only has the Machine Identifier of 
that host (which is not the same as the host name). As a result, FlexNet Operations does not regenerate the 
trusted storage license and it can be superseded. Mixing trusted storage and certificate licenses on the same 
host can cause problems if the SUPERSEDE keyword is used. 

Start Date of the Upgraded License
Note that the upgraded license is generated from a new entitlement line item. As a result, that entitlement line 
item can have a different start date than the original line item. 

Original and Upgraded Fulfillment on the Same Day
If a user fulfills a license for a product and gets the upgraded license on the same day, the SUPERSEDE keyword 
does not override the original product license, as both license lines have the same ISSUED date.

If the host contains any fulfillments ISSUED on the same day with similar features, SUPERSEDE licenses need not 
be generated for these fulfillments.

HOSTID as ANY
If ANY (or DEMO) is used as the hostname, the license works on any machine. If such a license is upgraded, then 
regenerating all ANY licenses with the SUPERSEDE keyword is problematic. As a result, FlexNet Operations does 
not generate the SUPERSEDE keyword for ANY (or DEMO) host ids. 

Multiple VCGs
If the publisher supports multiple VCGs, SUPERSEDE does not supersede feature lines from another vendor 
daemon. As a result, FlexNet Operations does not regenerate licenses belonging to another vendor daemon.

Different Organization Units (Accounts) Using the Same Host
A host is identified by its name and the organization unit (account) in FlexNet Operations. When a license is 
generated for the first time on a host, the organization unit of the logged-in user is set as the organization unit of 
the host. 

Consider two users who belong to the same company and use the same machine to host their licenses, but 
identify themselves to FlexNet Operations using two different organization units. (This case is common with the 
channel sales model, when end customers buy from resellers and come to the publisher separately.) In this case, 
FlexNet Operations treats the host names defined by these two users as different hosts, but in reality, they may 
be the same machine. Licenses of one or the other user may become ineffective.
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Self-Registered Users
Self-registered users are FlexNet Operations Portal users who do not belong to an organization unit (account). 
Internally, all self registered users belong to a dummy organization unit called PORTAL_ORG_UNIT. Because a 
self-registered user name is not used to identify the host, the SUPERSEDE keyword cannot be used if self-
registered users are supported. Licenses may be accidentally inactivated if two self-registered users use the 
same hostname.

Signature Length
SUPERSEDE_SIGN supersedes previous increment lines on a host based on their signatures. As signatures are 
quite long, sometimes, when a number of signatures are included in the SUPERSEDE_SIGN setting, the limit of the 
license line length can be equaled or exceeded. 

If this occurs, the VCG returns the following error: Feature <name> has count zero. Increase count for the 
feature or decrease superseded sign list, where <name> is the feature for which the license line length 
is reached.

To resolve this issue, click System > Configuration > FlexNet Operations > Override older fulfillments on the host 
using SUPERSEDE_SIGN keyword. This decreases the number of signatures being added to the increment line.

Example of Using SUPERSEDE
The following is an illustration of the use of the SUPERSEDE keyword. 

Consider a product, P1, with 3 features (f1, f2, and f3), and these attributes:

Product Name: P1 (F1, version 1.0) (F2, version 1.0) (F3, version 1.0) 

Activation ID: Activation1

Entitlement ID: EL1

Account Name: Org1 

Hostname: Mymachine

A user activates 5 out of 10 counts of the product, resulting in this license key: 

SERVER this_host HOSTNAME=mymachine
VENDOR demo
USE_SERVER
INCREMENT F1 demo 1.0 26-dec-2008 5 ISSUER="My Corporation" \

ISSUED=3-oct-2008 START=2-oct-2008 SIGN="002A 20C2 A452 8B82 \
7CF9 0A2D 1003 CB00 2BFC AC9B B59E D0C9 6CE6 5813 566A"

INCREMENT F2 demo 1.0 26-dec-2008 5 ISSUER="My Corporation" \
ISSUED=3-oct-2008 START=2-oct-2008 SIGN="00F0 9DFD 1320 33D9 \
63B1 FF49 3A87 9400 4A69 C389 E117 9D40 96D2 7578 0E97"

INCREMENT F3 demo 1.0 26-dec-2008 5 ISSUER="My Corporation" \
ISSUED=3-oct-2008 START=2-oct-2008 SIGN="005F 56FB 63A7 A359 \
C40B 5C7B C3BA 2D00 DE42 3BCA FF74 D606 6208 25F1 EB2D"

Now consider product P2, with 3 features, which is an upgrade of product P1. Product P2 has these attributes:

Product Name: P2 (F1, version 2.0) (F2, version 1.0) (F4, version 1.0)

Activation ID: upgraded-Act
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Entitlement ID: upgraded-EL

Account Name: Org1 

Hostname: Mymachine

Now, if the user upgrades 3 copies of P1 to P2, FlexNet Operations would generate the following licenses using 
the SUPERSEDE keyword:

Fulfillment license text for P2 (the upgraded product):

SERVER this_host HOSTNAME=mymachine
VENDOR demo
USE_SERVER
INCREMENT F2 demo 1.0 8-feb-2009 3 ISSUER="My Corporation" \

ISSUED=3-oct-2008 START=31-oct-2008 SIGN="0025 879F C7B4 798B \
66B5 262B 9D90 AE00 E62F FF09 2F83 2FBF E75C BA1A 2EC0"

INCREMENT F4 demo 1.0 8-feb-2009 3 ISSUER="My Corporation" \
ISSUED=3-oct-2008 START=31-oct-2008 SIGN="0069 4F14 9B2A 94F4 \
DB26 B912 801C 4400 CA61 4D94 78D6 1D1C A080 C8DB B744"

INCREMENT F1 demo 2.0 8-feb-2009 3 ISSUER="My Corporation" \
ISSUED=3-oct-2008 START=31-oct-2008 SIGN="00C6 6180 7299 E091 \
8DFD CFB1 497D D400 A1C0 D22F 18C4 54DE 9F45 34DA 4D1C"

Fulfillment license text for P1 (the old product): 

Note the SUPERSEDE keyword in the license key.

SERVER this_host HOSTNAME=mymachine
VENDOR demo
USE_SERVER
INCREMENT F1 demo 1.0 26-dec-2008 2 SUPERSEDE="F3 F1 F2" ISSUER="My \

Corporation" ISSUED=3-oct-2008 START=2-oct-2008 SIGN="009F \
996A EA12 7504 32FE 3C14 5910 8300 5B4E 8600 57E1 EB1C A774 \
AC01 22A3"

INCREMENT F2 demo 1.0 26-dec-2008 2 SUPERSEDE="F3 F1 F2" ISSUER="My \
Corporation" ISSUED=3-oct-2008 START=2-oct-2008 SIGN="002F \
1350 4898 5A94 223E 93E2 A2AA 5400 4487 DD7A F305 9D94 87D2 \
6172 821B"

INCREMENT F3 demo 1.0 26-dec-2008 2 SUPERSEDE="F3 F1 F2" ISSUER="My \
Corporation" ISSUED=3-oct-2008 START=2-oct-2008 SIGN="0069 \
210A 84EA 4DD1 1C87 3999 88EB 2000 8D03 A3C4 ACC1 B783 6CD0 \
816F 0E7C"

As can be seen from these license files, the user would receive:

• 5 copies of F1 (2 copies of the F1, 1.0 feature and 3 copies of the F1, 2.0 feature)

• 5 copies of F2 

• 2 copies of F3 

• 3 copies of F4

If users later activate 2 copies of an upgradable line item from the Activate License page on the same host, 
FlexNet Operations generates the following license without using the SUPERSEDE keyword:

SERVER this_host HOSTNAME=mymachine
VENDOR demo
USE_SERVER
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INCREMENT F2 demo 1.0 8-feb-2009 2 ISSUER="My Corporation" \
ISSUED=3-oct-2008 START=31-oct-2008 SIGN="001D 82E1 DAA5 E0FD \
88A9 F261 AD14 8900 AB02 9BCC F774 E196 12EF DD5B 20CD"

INCREMENT F4 demo 1.0 8-feb-2009 2 ISSUER="My Corporation" \
ISSUED=3-oct-2008 START=31-oct-2008 SIGN="00B0 26BD FD33 FBC4 \
68FE C9B5 C38E 3300 33F3 521F 2588 B763 9470 E2EA C1AE"

INCREMENT F1 demo 2.0 8-feb-2009 2 ISSUER="My Corporation" \
ISSUED=3-oct-2008 START=31-oct-2008 SIGN="0080 1869 FA9D 2B87 \
920B 16DF 0636 E200 30FE D8E8 954A 2D16 3685 7722 E64C"

Example of Using SUPERSEDE_SIGN
The following is an illustration of the use of the SUPERSEDE_SIGN keyword. 

Product Name: P1 (F1, version 1.0) (F2, version 1.0) (F3, version 1.0) 

Activation ID: Activation1

Entitlement ID: EL1

Account Name: Org1 

Hostname: Mymachine

A user activates 5 out of 10 counts of the product, resulting in these license keys: 

License Key for Product P1:

SERVER this_host HOSTNAME=Mymachine

VENDOR opsqa

USE_SERVER

INCREMENT F1 opsqa 1.0 permanent 5 2575363D2F8A ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=6-oct-2008 SIGN="004E \
5318 9887 61FF 6F2F 9039 210E 2D00 29C0 41D9 5B9A ADBE F33E \
1FF2 CB16" SIGN2="0099 75D7 B158 0059 9AE5 650C 977C AE00 AE32 \
56A9 FC6C 6831 23C8 951E 7489"

INCREMENT F2 opsqa 1.0 permanent 5 25AE6544D8E1 ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=6-oct-2008 SIGN="0061 \
68BC 9E59 962F 36AD 014B 0A52 A500 220C F2A2 50F8 B7FB C06D \
4007 6615" SIGN2="001F E152 80F2 1858 053B D75B 3710 5500 9B82 \
BADA 4D5C D39D 50A2 B2D3 4E56"

INCREMENT F3 opsqa 1.0 permanent 5 2DFA5C27ED28 ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=6-oct-2008 SIGN="0013 \
8996 1A1D 84EF D0E1 C0EC 7B32 0600 1B07 3E12 7413 36FE 585E \
E9C0 580E" SIGN2="00B2 4E2B 4C49 DABC 2EFC 503E A6A0 9F00 D931 \
106C 0E1E 4605 489B 2410 C638"

Product Name: P2 (F1, 2.0) (F2, 1.0) (F4, 1.0)

Activation ID: upgraded-Act

Entitlement ID: upgraded-EL

Account Name: Org1 

Hostname: Mymachine
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Now, if the user upgrades 3 copies of P1 to P2, then the old license of Product P1 become obsolete, and FlexNet 
Operations generates the following license using the SUPERSEDE_SIGN keyword:

Fulfillment license text for Product P2 (Upgraded Product)

SERVER this_host HOSTNAME=Mymachine
VENDOR opsqa
USE_SERVER
INCREMENT F2 opsqa 1.0 7-feb-2009 3 B16BDF658A55 ISSUER="My \

Corporation" ISSUED=7-oct-2008 START=30-oct-2008 SIGN="008F \
8BE8 4D9E 5EF5 B5F7 1037 F882 8B00 CA90 C2C3 DE1F B29F 5D71 \
CEF8 4C05" SIGN2="0016 6763 55B6 CF4C 3659 02BA BE89 8300 DF02 \
36FE EB6B 133F CE15 F849 B22D"

INCREMENT F4 opsqa 1.0 7-feb-2009 3 4072393334B7 ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=30-oct-2008 SIGN="00DC \
10B8 CBAE 2B32 8EE5 7ECF 8744 7C00 9E54 0C40 7621 0697 36B4 \
EF21 555A" SIGN2="0005 84B2 3B51 D9C7 6D20 3CA0 1B47 9C00 DE53 \
C962 CC1B 745A B4E0 C962 6854"

INCREMENT F1 opsqa 2.0 7-feb-2009 3 43026EA5EC87 ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=30-oct-2008 SIGN="00A5 \
CF1B E66A 3D04 5679 B3F4 E4C6 2D00 DE42 95B4 DC62 E752 B5AC \
04AC 77AB" SIGN2="0056 719E D96A D643 51C9 3EF5 65DE E100 00E2 \
5C55 16E5 8415 EFB5 6AE5 47C5"

Fulfillment license text for P1 (the old product). Note the SUPERSEDE SIGN keyword in the license key.

SERVER this_host HOSTNAME=Mymachine
VENDOR opsqa
USE_SERVER
INCREMENT F1 opsqa 1.0 permanent 2 6BD0062092EC ISSUER="My \

Corporation" ISSUED=7-oct-2008 START=6-oct-2008 \
SUPERSEDE_SIGN={"F1:004E 5318 9887 61FF 6F2F 9039 210E 2D00 \
29C0 41D9 5B9A ADBE F33E 1FF2 CB16" "F2:0061 68BC 9E59 962F \
36AD 014B 0A52 A500 220C F2A2 50F8 B7FB C06D 4007 6615" \
"F3:0013 8996 1A1D 84EF D0E1 C0EC 7B32 0600 1B07 3E12 7413 \
36FE 585E E9C0 580E"} SIGN="0029 3648 50D1 9BD1 EE19 1182 6B1D \
6800 CB0E FFD6 A951 0378 518D B381 A59D" SIGN2="00DC 766F A4CB \
7FCD D1DA CB78 9C1F A400 CC6B 3060 2AC8 6823 FADF E653 21CF"

INCREMENT F2 opsqa 1.0 permanent 2 C2B2737DA117 ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=6-oct-2008 \
SUPERSEDE_SIGN={"F1:004E 5318 9887 61FF 6F2F 9039 210E 2D00 \
29C0 41D9 5B9A ADBE F33E 1FF2 CB16" "F2:0061 68BC 9E59 962F \
36AD 014B 0A52 A500 220C F2A2 50F8 B7FB C06D 4007 6615" \
"F3:0013 8996 1A1D 84EF D0E1 C0EC 7B32 0600 1B07 3E12 7413 \
36FE 585E E9C0 580E"} SIGN="0000 937B A809 AF06 5AB3 883A AEA2 \
9600 79F5 432B AF02 5722 6B16 F093 43E9" SIGN2="0046 C582 FBB5 \
E97A 8B4B D48B 6720 FE00 7BC3 AFA1 5D6D 5DCC CB1F 8561 CF2A"

INCREMENT F3 opsqa 1.0 permanent 2 8FB794EE24AA ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=6-oct-2008 \
SUPERSEDE_SIGN={"F1:004E 5318 9887 61FF 6F2F 9039 210E 2D00 \
29C0 41D9 5B9A ADBE F33E 1FF2 CB16" "F2:0061 68BC 9E59 962F \
36AD 014B 0A52 A500 220C F2A2 50F8 B7FB C06D 4007 6615" \
"F3:0013 8996 1A1D 84EF D0E1 C0EC 7B32 0600 1B07 3E12 7413 \
36FE 585E E9C0 580E"} SIGN="002A EEEB AFE4 2002 D145 4082 0FAA \
7A00 CF17 2073 B7A8 BC70 EA1F 664E CB04" SIGN2="00B9 91E6 C380 \
4CF9 F1A1 660E 7C8C AB00 E511 994F 3CBE 2E71 5A1D F687 A65D"

A user can consolidate both of the above licenses into a single license file for convenience.
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Consolidated License: CID_33c0d5d6_11cd97c2d8e__7fff

Sold To: Account

Consolidation Criteria: Server HOSTNAME=Mymachine

Consolidated License 

SERVER this_host HOSTNAME=Mymachine
VENDOR opsqa
USE_SERVER
INCREMENT F1 opsqa 1.0 permanent 2 6BD0062092EC ISSUER="My \

Corporation" ISSUED=7-oct-2008 START=6-oct-2008 \
SUPERSEDE_SIGN={"F1:004E 5318 9887 61FF 6F2F 9039 210E 2D00 \
29C0 41D9 5B9A ADBE F33E 1FF2 CB16" "F2:0061 68BC 9E59 962F \
36AD 014B 0A52 A500 220C F2A2 50F8 B7FB C06D 4007 6615" \
"F3:0013 8996 1A1D 84EF D0E1 C0EC 7B32 0600 1B07 3E12 7413 \
36FE 585E E9C0 580E"} SIGN="0029 3648 50D1 9BD1 EE19 1182 6B1D \
6800 CB0E FFD6 A951 0378 518D B381 A59D" SIGN2="00DC 766F A4CB \
7FCD D1DA CB78 9C1F A400 CC6B 3060 2AC8 6823 FADF E653 21CF"

INCREMENT F2 opsqa 1.0 permanent 2 C2B2737DA117 ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=6-oct-2008 \
SUPERSEDE_SIGN={"F1:004E 5318 9887 61FF 6F2F 9039 210E 2D00 \
29C0 41D9 5B9A ADBE F33E 1FF2 CB16" "F2:0061 68BC 9E59 962F \
36AD 014B 0A52 A500 220C F2A2 50F8 B7FB C06D 4007 6615" \
"F3:0013 8996 1A1D 84EF D0E1 C0EC 7B32 0600 1B07 3E12 7413 \
36FE 585E E9C0 580E"} SIGN="0000 937B A809 AF06 5AB3 883A AEA2 \
9600 79F5 432B AF02 5722 6B16 F093 43E9" SIGN2="0046 C582 FBB5 \
E97A 8B4B D48B 6720 FE00 7BC3 AFA1 5D6D 5DCC CB1F 8561 CF2A"

INCREMENT F3 opsqa 1.0 permanent 2 8FB794EE24AA ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=6-oct-2008 \
SUPERSEDE_SIGN={"F1:004E 5318 9887 61FF 6F2F 9039 210E 2D00 \
29C0 41D9 5B9A ADBE F33E 1FF2 CB16" "F2:0061 68BC 9E59 962F \
36AD 014B 0A52 A500 220C F2A2 50F8 B7FB C06D 4007 6615" \
"F3:0013 8996 1A1D 84EF D0E1 C0EC 7B32 0600 1B07 3E12 7413 \
36FE 585E E9C0 580E"} SIGN="002A EEEB AFE4 2002 D145 4082 0FAA \
7A00 CF17 2073 B7A8 BC70 EA1F 664E CB04" SIGN2="00B9 91E6 C380 \
4CF9 F1A1 660E 7C8C AB00 E511 994F 3CBE 2E71 5A1D F687 A65D"

INCREMENT F2 opsqa 1.0 7-feb-2009 3 B16BDF658A55 ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=30-oct-2008 SIGN="008F \
8BE8 4D9E 5EF5 B5F7 1037 F882 8B00 CA90 C2C3 DE1F B29F 5D71 \
CEF8 4C05" SIGN2="0016 6763 55B6 CF4C 3659 02BA BE89 8300 DF02 \
36FE EB6B 133F CE15 F849 B22D"

INCREMENT F4 opsqa 1.0 7-feb-2009 3 4072393334B7 ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=30-oct-2008 SIGN="00DC \
10B8 CBAE 2B32 8EE5 7ECF 8744 7C00 9E54 0C40 7621 0697 36B4 \
EF21 555A" SIGN2="0005 84B2 3B51 D9C7 6D20 3CA0 1B47 9C00 DE53 \
C962 CC1B 745A B4E0 C962 6854"

INCREMENT F1 opsqa 2.0 7-feb-2009 3 43026EA5EC87 ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=30-oct-2008 SIGN="00A5 \
CF1B E66A 3D04 5679 B3F4 E4C6 2D00 DE42 95B4 DC62 E752 B5AC \
04AC 77AB" SIGN2="0056 719E D96A D643 51C9 3EF5 65DE E100 00E2 \
5C55 16E5 8415 EFB5 6AE5 47C5"

As can be seen from the above license files, the user receives:

• 5 copies of F1 (2 copies of the F1, 1.0 feature and 3 copies of the F1, 2.0 feature)
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• 5 copies of F2 

• 2 copies of F3 

• 3 copies of F4

Note that if a user activates 2 copies of an upgradable line item on the same host, FlexNet Operations generates 
the following license without using the SUPERSEDE SIGN keyword:

SERVER this_host HOSTNAME=Mymachine
VENDOR opsqa
USE_SERVER
INCREMENT F2 opsqa 1.0 7-feb-2009 2 882127379F59 ISSUER="My \

Corporation" ISSUED=7-oct-2008 START=30-oct-2008 SIGN="008A \
0A65 CAD8 DDC4 85AA 48A7 A9CA BD00 17AB 7BF8 9F2E 666A 7A53 \
E700 5375" SIGN2="0068 A545 B631 9773 9017 24BC C1C9 8D00 F062 \
1ACE 8C33 BE7C 4995 C091 2478"

INCREMENT F4 opsqa 1.0 7-feb-2009 2 09B95D118D97 ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=30-oct-2008 SIGN="00F5 \
C68F 4978 FC24 ECC6 9A2D 4BAB 8300 A09B 3332 4CF3 E00C 4D9F \
4C95 2719" SIGN2="004C 09FF 27E8 B631 9320 C85E 329C 4F00 6E38 \
CCC7 81D7 9D22 1EE0 48EC 51E8"

INCREMENT F1 opsqa 2.0 7-feb-2009 2 AACDA415B7B9 ISSUER="My \
Corporation" ISSUED=7-oct-2008 START=30-oct-2008 SIGN="0041 \
7961 1A8F A373 767F B5AC BBA7 4400 18AE 38B7 296D 8038 0D16 \
4DA3 36CE" SIGN2="0013 FA4B FBA6 1CF2 39A6 D8D4 5D6D 7A00 FEED \
80E8 6765 8E56 3044 B52B F6CE"

Configuring the SUPERSEDE or SUPERSEDE_SIGN Keyword
Configure the SUPERSEDE keyword in the Producer Portal (System > Configure). Click FlexNet Operations, then 
under Use SUPERSEDE or SUPERSEDE_SIGN keyword, select the circumstances under which you want to use 
either keyword: for upgrades, renewals, or both. You can use SUPERSEDE or SUPERSEDE_SIGN, but not both at 
the same time.

Generating a Stop Gap License  
If a customer’s license has expired and the customer has not formally renewed its entitlement, the publisher can 
generate a short-term stop gap license. 

Task To generate a stop gap license because a customer has not yet renewed an expired license

1. Click Licenses > Licenses. This link opens the Support Licenses and Maintenance page. 

2. Search for a fulfillment for which a stop gap license is to be generated. Search by Activation ID, Product, Sold 
To, Hostid, or Fulfill ID. 

3. Select exactly one fulfillment ID and click Stop Gap. Generating a stop gap license does not cause the original 
fulfillment to be returned.

4. Enter a Ship to Email or a Ship To Mail address, if applicable. 
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5. By default, the Start Date of a stop gap license is the Fulfill Date of the original fulfillment. You can set a 
different Start Date and can set the expiration to be after a set Duration or to a specific Expiration Date. 

6. No license parameters can be modified for the stop gap license. The entire count of the fulfillment is used for 
the stop gap license.

7. To check that the parameter values can be used to generate a valid license before actually generating a 
license, click Verify. 

8. To generate an stop gap license certificate, click Stop Gap. 

9. After a license is generated, the license text is displayed. The license text can be saved to a file on disk by 
clicking Save to File, or it can be sent as an email attachment by clicking Email License. The shipment history 
of this license can be displayed by clicking Shipment Records. 

For information about the file naming conventions, see Configuring System Settings. 

Stop gap fulfillments appear in the Support Licenses and Maintenance page as Support Type STOP GAP. 

Consolidating Licenses
License consolidation, or the generation of a single license file for several certificate-based or custom licenses, 
can be done during batch activation, or post-activation, from the Support Licenses page.

To enable this capability, the Show Consolidate Licenses Functionality flag must be enabled. This is configured 
under System > Configure > FlexNet Operations. 

Task To consolidate a license

1. Click Licenses > Licenses. This link opens the Support Licenses and Maintenance page. 

2. Select the boxes next to the fulfillments you want to consolidate. Ensure that these records meet the 
consolidation criteria.

3. Click Consolidate to view the consolidated license file. One file is generated for each group of floating or 
nodelocked licenses on each server.

Consolidated Licenses Page 
The Consolidated Licenses lists all consolidated license files. The files are listed with the following information:

Table 4-4 • Consolidated License File Information

Information Description

Type Shows if the license is active or not.

Consolidated License ID Machine-generated unique identifier for each consolidated license file. 

Consolidation Criteria Mostly lists the host ID of the machine on which node-locked or floating 
licenses have been consolidated.



Chapter 4 Supporting Licenses

210 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

From this page you can do the following:

• Click a consolidated license ID. 

• View Shipment History for the license.

• View Fulfillments contained with the consolidated license.

• Click Rehost to rehost a consolidated license.

• Save or email the license.

• If you have selected more than one file to view, you can choose among license files by selecting the 
appropriate Consolidated License ID from the drop-down list provided.

• The license text can be saved to a file on disk by clicking Save to File or it can be sent as an email attachment 
by clicking Email. 

For information about the file naming conventions, see FlexNet Operations system configuration settings. 

Rehosting a Consolidated License
Rehosting a consolidated license reassigns it from one host ID to another.

Task To rehost a consolidated license

1. Click Licenses > Consolidated Licenses. 

2. On the Consolidated Licenses page, search for the fulfillment for the license by, for example, Consolidated 
License ID or Consolidation Criteria (usually, a server host ID). 

3. Select the box next to the fulfillment ID you want to rehost. 

4. Select a new Host ID for the consolidated license. Alternatively, add a new host ID to rehost this license by 
creating a new host on the Create License Host page.

5. Click Rehost. The license is assigned to the new Host ID.

Batch Rehosting
Using the Batch Rehost feature, you can use redistribute licenses for a group of products among various license 
servers and change the license count of products on different servers. For example, you can change 20 licenses 
for Product 1 on Server A, to 10 licenses on Server A and 10 on Server B. Batch rehosting only works for counted 
licenses – that is, floating counted or node-locked counted models.

Sold To Name of the customer account that owns the consolidated licenses.

Consolidation Date Date on which licenses were consolidated: not necessarily the same as 
activation date.

Table 4-4 • Consolidated License File Information

Information Description



Chapter 4 Supporting Licenses

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 211

Task To batch rehost a group of products

1. Click Licenses > Batch Rehost. This link opens the Batch Rehost - Select Customer Account Unit and 
Hosts page.

2. In Account, select the account for which you want to redistribute licenses.

3. Select the products whose licenses you want to redistribute, and click Next.

4. If desired, enter the common attributes you want to assign to each of the redistributed licenses, and 
click Next.

5. Add new hosts as needed.

6. In Final Count, enter the number of copies to assign to each selected host. (The green arrow indicates 
the current host assignment. The green check mark indicates that the count has been changed.) Click 
Next.

7. Review the summary page for your redistribution. If necessary, click Back to correct any incorrect 
entries. If correct, click Generate. The licenses are redistributed.

Transferring Licenses
When you transfer licenses, you move all licenses for one account from one host to another. This is typically used 
when a host crashes and licenses on it must be moved to a new machine. 

Task To transfer licenses from one account to another

1. Click Licenses > Transfer Licenses. This link opens the Transfer Licenses page. 

2. In Account, select the account from which you want to transfer licenses.

3. In Source Host, select the host of the source licenses.

4.  In Target Host, select the host that you will transfer licenses to.

5. Select whether or not you want to consolidate the licenses into a single file.

6. Click Next.

7. On the summary page, review the details of your transfer. If necessary, click Back to correct any 
incorrect entries. If correct, click Transfer. The licenses are transferred to the specified host.

Manual Return 
Trusted returns are normally done programmatically as transactions between a client or server activation utility 
and the FlexNet Operations server. The activation utility generates a request that is submitted programmatically 
and the FlexNet Operations server generates a response that is used to complete the return. 

However, when there is no internet connection, a return request can also be generated and written to a file by a 
FlexNet Publisher Licensing Toolkit activation utility running on the machine from which the license will be 
returned. 
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• The file containing the request is sent to the publisher and loaded into FlexNet Operations to generate a 
response. 

• The response is saved to a file; the file is sent to the customer and is used by the FlexNet Publisher Licensing 
Toolkit activation utility to process the response and return the license. 

Task To generate a response to a return request submitted in a file

1. Instruct the customer to use the FlexNet Publisher Licensing Toolkit activation utility that you provide to 
generate and save to a file a return request. The activation utility requires the fulfillment ID of the license. 

2. Click Licenses > Manual Return. This link opens the Manual Return page. 

3. Browse to the XML file that contains the return request. 

4. Click Submit to generate and view the return response.

Viewing a Manual Return
Follow this procedure to view a return after you manually generate a return response.

Task After a return response is generated manually

1. Verify the Activation ID, Product, Version, Fulfillment ID, and Sold To.

2. Click Save to File to save this response to a file. The default file name is responseXML.xml. 

3. Send the file to the customer with instructions for using the activation utility to process the response and 
return the license. 

Manual Repair  
Trusted repairs are normally done programmatically as transactions between a client or server activation utility 
and the FlexNet Operations server. The activation utility generates a request that is submitted programmatically 
and the FlexNet Operations server generates a response that is used to complete the repair. 

However, a repair request can also be generated and written to a file by a FlexNet Publisher Licensing Toolkit 
activation utility running on the machine on which the license will be repaired. 

• The file containing the request is sent to the publisher and loaded into FlexNet Operations to generate a 
response. 

• The response is saved to a file; the file is sent to the customer and is used by the FlexNet Publisher Licensing 
Toolkit activation utility to process the response and repair the license. 
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Task To generate a response to a repair request submitted in a file

1. Instruct the customer to use the FlexNet Publisher Licensing Toolkit activation utility that you provide to 
generate and save to a file a repair request. The activation utility requires the fulfillment ID of the license. 

2. Click Licenses > Manual Repair. 

3. Browse to the XML file that contains the repair request. 

4. Click Submit to generate and view the repair response. 

Viewing a Manual Repair 
Follow this procedure to view a repair after you manually generate a repair response.

Task After a repair response is generated manually

1. Verify the Activation ID, Product, Version, Fulfillment ID, and Sold To.

2. Click Save to File to save this response to a file. The default file name is responseXML.xml. 

3. Send the file to the customer with instructions for using the activation utility to process the response and 
repair the license. 

Short Code Return  
Trusted returns are normally done programmatically as transactions between a client or server activation utility 
and the FlexNet Operations server. The activation utility generates a request that is submitted programmatically 
and the FlexNet Operations server generates a response that is used to complete the return. 

However, some customer environments do not support communication with the FlexNet Operations server. If the 
publisher created a short code ASR that was packaged with the software, whether the license was activated with 
short code or programmatically, it can be repaired using a short code. 

A FlexNet Publisher Licensing Toolkit activation utility, running on the machine from which the license is to be 
returned, uses the short code ASR to generate a short request code. 

• The short request code is sent to the publisher, who loads it into FlexNet Operations to generate a short 
response code. 

• The response code is saved to a file and sent to the customer, who uses the FlexNet Publisher Licensing 
Toolkit activation utility to process the response and return the license. 

Task To allow a customer to return a license with a short response code

1. The customer’s license must have been activated with a short code ASR, the short code ASR must have been 
packaged with the product, and the activation utility must be able to generate a short code return request 
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and process a short code return response. The license to be returned may have been originally activated 
online or with a short code request. 

2. Instruct the customer to use the FlexNet Publisher Licensing Toolkit activation utility, which you provide, to 
generate a short code return request using the short code ASR file. 

3. Receive the generated short code from the customer, along with the activation ID (or web register key) used 
to activate the original license. 

4. Click Licenses > Short Code Return. 

5. Enter values in the following fields.

6. Click Generate to generate and view the short response code. 

Viewing a Short Code Return 
Follow this procedure to view a short code return after you manually generate a short code return response.

Task After a short code return response is generated manually

1. Save the response code to a file. 

2. Send the file to the customer with instructions for using the activation utility to process the response and 
return the license. 

Short Code Repair  
Trusted storage repairs are normally done programmatically as transactions between a client or server activation 
utility and the FlexNet Operations server. The activation utility generates a request that is submitted 
programmatically and the FlexNet Operations server generates a response that is used to complete the repair. 

However, some customer environments do not support communication with the FlexNet Operations server. If the 
publisher created a short code ASR that was packaged with the software, the customer who originally activated 
the license with that short code ASR can use the short code ASR file to generate a short code request to repair the 
license. 

Table 4-5 • Short Code Return Fields

Field Description

Short Request Code Short code return request generated by the FlexNet Publisher Licensing Toolkit 
activation utility and sent by the customer.

Activation ID Activation ID or a Web register key associated with the short code ASR’s bulk 
entitlement.

Reason for Return Reason for the short code return, if any: REHOST, UPGRADE, UPSELL, UPGRADE, 
RENEW. 
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A FlexNet Publisher Licensing Toolkit activation utility, running on the machine on which the license is to be 
repaired, uses the short code ASR to generate a short request code. 

• The short request code is sent to the publisher, who loads it into FlexNet Operations to generate a short 
response code. 

• The response code is saved to a file and sent to the customer, who uses the FlexNet Publisher Licensing 
Toolkit activation utility to process the response and repair the license. 

Task To allow a customer to repair a license with a short response code

1. The customer’s license must have been activated with a short code ASR, the short code ASR must have been 
packaged with the product, and the activation utility must be able to generate a short code repair request 
and process a short code repair response. The license to be repaired may have been originally activated 
online or with a short code request. 

2. Instruct the customer to use the FlexNet Publisher Licensing Toolkit activation utility, which you provide, to 
generate a short code repair request using the short code ASR file. 

3. Receive the generated short code from the customer, along with the activation ID (or Web register key) used 
to activate the original license. 

4. Click Licenses > Short Code Repair. 

5. Enter values in the following fields.

6. Click Generate to generate and view the short response code. 

Viewing a Short Code Repair
Follow this procedure to view a short code repair after you manually generate a short code repair response.

Task After a short code repair response is generated manually

1. Save the response code to a file. 

2. Send the file to the customer with instructions for using the activation utility to process the response and 
repair the license. 

Table 4-6 • Short Code Repair Fields

Field Description

Short Request Code Short code repair request generated by the FlexNet Publisher Licensing Toolkit 
activation utility and sent by the customer.

Activation ID Activation ID or a Web register key associated with the short code ASR’s bulk 
entitlement.
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Supporting Hosts
You can view fulfillment or license information associated with previously-defined hosts.

Task To manage host information

1. Click Licenses > Hosts.

2. Select the host you want to view or manage information for.

3. Do one of the following:

• Click View Fulfillments to view fulfillments associated with the host.

• Click Download License to download license files associated with the host. Choose a location to save the 
license file to, then click OK.

• For a manual, replacement license technology, click Set License to set the license file information for the 
host. Then complete the requested information for your license file.

• Click Delete to delete the host from FlexNet Operations.

• Click Transfer to move the selected hosts (and their entitlements) to a different account. (See 
Transferring Hosts.)

Transferring Hosts
Transfer Hosts allows you to transfer fulfillments from one or more hosts to a related account.

Note • When a host is moved, entitlements that belong to devices assigned to that host are moved as well. The 
result of the move is to either create new entitlements for the target account or to pool the line items—
incrementing the counts of the target account's existing (and matching) entitlements by the counts on the hosts' 
entitlements that were moved.

Task To transfer hosts

1. In the Producer Portal, click Licenses > Hosts. On the Hosts page you can select hosts to transfer.

2. On the Hosts page, select the hosts you want to transfer and click Transfer. This button opens the Transfer 
Hosts page. 

3. On the Transfer Hosts page, set the Target Account:

a. Click the Search Account button to open the Select Account page in a pop-up window.

b. Select the customer account to which you want to move the selected hosts.

c. Click OK. This button closes the Select Account window and returns you to the Transfer Hosts page. Note 
that the Target Account is now set to the account you selected.

4. Next, choose a setting for Pool Line Items:
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• Yes—If matching entitlements exist in the target account, those entitlements are incremented by the 
counts in the hosts’ entitlements. Otherwise, if no matching entitlements exist, new entitlements are 
created at the target account. 

• No—FlexNet Operations creates new entitlements at the target account, even if matching entitlements 
already exist. 

5. Click Transfer. FlexNet Operations queues the transfer for processing. 

6. Click Complete.

Note • You can check the status of the host transfer job by its Job ID on the Host Transfer Jobs page. To go to the 
Host Transfer Jobs page, click Licenses > Host Transfer Jobs. 

Supporting Embedded Licenses
To support embedded licenses, you can easily add or delete additional licenses, or re-allocate them between 
devices, in response to customer demands, maintenance, or market conditions. Some of the operations you can 
perform include:

• RMAs: Return material authorization

• Upgrades

• Transfers

• Temporary (emergency or stop-gap, for example) licenses 

Task To edit additional licenses for a particular device

1. Click Devices > Search Devices. The Producer Portal opens the Search Devices page. 

2. Specify search criteria to locate the device you want to change and click Search.

3. From the list of devices, select a device to manage.

4. Under Entitlements, edit the entitlements for the selected device.

Changes to additional licenses are not performed in real time, but take effect on each device the next time the 
affected devices connect to FlexNet Operations, or the next time the license is copied by a user to a given device. 

Pre-installed licenses are not transferable between devices.

Return Material Authorizations (RMAs)
A customer might be required to return a malfunctioning device to a manufacturer or reseller, and get a new 
device. The existing license is transferred to the new device. This process is known as a return material 
authorization (RMA).

After you have determined that a device must be replaced, you can process the RMA in FlexNet Operations.
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Task To process an RMA

1. Click Devices > Search Devices. The Producer Portal opens the Search Devices page. 

2. Specify search criteria to locate the device you want to change and click Search.

3. From the list of devices, click the ID for the old device. This link opens the View Device page.

4. Click Edit > Make Obsolete.

5. Click Devices > Create Device and create a new device with the same characteristics as the old, but a new 
Device ID.

6. Click Licenses > Map Entitlements. The Producer Portal opens the Map Entitlements page where you select 
the entitlement line items for the new device (which is the same as the old device). 

7. Under Entitlements Available, specify the amount to add in Qty to Add for the entitlements you want to map, 
and click Save. 

A newly authorized device has been created in FlexNet Operations.

Upgrades, Renewals, and Upsells
upgrade — Transferring a customer from a specified version of a product to a more recent version of the same 
product, with potentially new features. 

renewal — Extending the expiration date of a license to a later date. 

upsell — Transferring a customer to an expanded version of the same product that provides more functionality. 

These three processes are supported for FlexNet Embedded licenses and work the same way. 

Task To process an upgrade, renewal, or upsell manually 

1. Create an entitlement representing the upgraded/renewed/upsold product. For example, if the regular 
entitlement gives access to a feature, the upgrade entitlement would represent the new or expanded 
feature.

2. Click Devices > Search Devices. The Producer Portal opens the Search Devices page. 

3. Specify search criteria to locate the device you want to change and click Search.

4. From the list of devices, click the ID for device to upgrade/renew/upsell. This link opens the View Device 
page.

5. Click Licenses > Remove Licenses. 

6. Under Licenses Currently Mapped, specify the amount to remove in Qty to Remove, and click Save. The 
previously assigned counts are added back to the entitlement. The entitlements can now be assigned to new 
devices.

7. Click Licenses > Map Entitlements. The Producer Portal opens the Map Entitlements page, where you select 
the upgraded/renewed/upsold entitlement line items for the device. 
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8. Under Entitlements Available, specify the amount to add in Qty to Add for the entitlements you want to map, 
and click Save. 

About Automatic Version Upgrades, Renewals, and Upsells for Devices and Servers
For FlexNet Operations to apply the automatic upgrade, renewal, or upsell process, you must create relationships 
between the two product versions and between the two entitlement line items for those product versions. 

When mapping an upgrade entitlement to a device that already has copies of the related pre-installed 
entitlement, FlexNet Operations automatically reduces the copies of the pre-installed entitlement by the number 
of copies of the upgrade entitlement being mapped. This is particularly helpful as the copies are shared between 
the pre-installed entitlement and the upgrade entitlement, and frequently the upgrade entitlement cannot be 
mapped until copies of the pre-installed entitlement are unmapped (to free up available copies). 

The return of the pre-installed copies skips the normal confirmation process, as the returned copies are 
immediately consumed by the upgrade being mapped. Also, for the same reason, potential limitations for 
duration based entitlements do not apply. 

Limitations: 

• You are not permitted to mix the different relationship types within a single parent-child chain of product 
relationships. 

• The type of relationship—upgrade, renewal, or upsell—you use in the product relationship must be the same 
as the type of relationship between the entitlement line items. 

• The application does not support multiple upgraded products that have the same parent. 

• The application does not support a child entitlement having a higher license quantity than its parent. In this 
case, you must create two entitlement lines: one that is for the same quantity as the parent and one that is 
for the remaining extra quantity. 

• If there are no copies currently available for an upgrade entitlement, the Map Entitlements page does not 
show the upgrade entitlement as an option to map, even if there are copies of the pre-installed entitlement 
mapped to the device being acted on (that could be automatically returned to enable the operation to 
succeed). Activation via capability request does not have this limitation. 

• If both pre-installed and upgrade entitlements are specified in a capability request, the order in which they 
are listed matters. If the pre-installed entitlement is listed first, the mapped copies are unmapped by the 
upgrade item listed second (if the upgrade copies requested are greater or the same; some are left if the pre-
installed request is for more copies). If the pre-installed entitlement is listed second, it is successfully 
mapped in addition to the upgrade listed first. When the same is done from the user interface, the result is 
not well defined. 

• If a device has a device series limiting the copies of a feature in the upgrade/pre-installed entitlement, the 
feature-limiting logic does not properly take into account the copies being returned in the pre-installed 
entitlement and may prevent mapping via the user interface. 

Tip • FlexNet Operations can automatically upgrade line items for qualifying products and line items with the 
Product Version Upgrade job. See FlexNet Operations Alert Types.
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Transfers
Transferring licenses is defined as the process of moving licenses from one device to another. A publisher can 
define policies to control the number of rehosts in a given duration of time per line item. This policy can be 
defined on license model or the entitlement line item.

Task To process a transfer

1. Click Devices > Search Devices. The Producer Portal opens the Search Devices page. 

2. Specify search criteria to locate the device you want to change and click Search.

3. From the list of devices, click the ID for the old device. This link opens the View Device page.

4. Click Licenses > Remove License. 

5. Under Licenses Currently Mapped, specify the amount to remove in Qty to Remove, and click Save. The 
previously assigned counts are added back to the entitlement. The entitlements can now be assigned to new 
devices.

6. Click Devices > Create Device and create a new device with the same characteristics as the old, but a new 
Device ID.

7. Click Licenses > Map Entitlements. The Producer Portal opens the Map Entitlements page where you select 
the entitlement line items for the new device (which is the same as the old device). 

8. Under Entitlements Available, specify the amount to add in Qty to Add for the entitlements you want to map, 
and click Save. 

A newly authorized device has been created in FlexNet Operations.

Temporary (Emergency and Stop-Gap) Licenses
Temporary licenses are limited in duration for a specific purpose. A temporary license can be issued in the 
following circumstances:

• An emergency license allows a customer to temporarily move features from an old device to a new device. 

• A stop-gap license allows a customer to temporarily use an expiring license until another license can be 
issued.

• A temporary license allows a customer to demonstrate a product for trial purposes, and expires after a short 
trial period. 

Task To issue a temporary license

1. Create a limited-duration entitlement representing the upgraded product.

2. Click Devices > Search Devices. The Producer Portal opens the Search Devices page. 

3. Specify search criteria to locate the device you want to change and click Search.

4. From the list of devices, click the ID for device to change. This link opens the View Device page.
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5. Click Licenses > Map Entitlements. The Producer Portal opens the Map Entitlements page where you select 
the temporary entitlement line items for the device. 

6. Under Entitlements Available, specify the amount to add in Qty to Add for the entitlements you want to map, 
and click Save. 

The Producer Portal maps the entitlement line items to the current device and shows its View Device page.

Supporting Offline Device Activation
If necessary, FlexNet Operations can be used to upload license requests (Generate License) and download both 
pre-installed and additional licenses. 

Offline Activation: Generating a License
Some devices may follow an offline activation model in which the device generates a binary license request file 
(for an additional license) that can be manually uploaded on the FlexNet Operations Producer Portal or the End-
User Portal. FlexNet Operations processes the request file to generate a license appropriate for the request. 

If the license request is made for an existing device, FlexNet Operations generates a regenerative license. If the 
request is made for a new device, FlexNet Operations enters the device into the system, adds the corresponding 
entitlement, and generates a license for it.

Task To upload a license request file for an existing device

1. Click Devices > Search Devices. The Producer Portal opens the Search Devices page. 

2. Specify search criteria to locate the device you want to change and click Search.

3. From the list of devices, click the ID of the device for which you want to upload a license request. This link 
opens the View Device page.

4. Click Browse and locate the license request file on your local system. (Button names vary depending on the 
web browser you are using.) 

Table 4-7 • 

Topics Description

Offline Activation: 
Generating a License

Steps through the process of uploading a binary license request file.

Offline Activation: 
Downloading a Pre-
Installed License

Describes how to download a previously generated, pre-installed license. 

Offline Activation: 
Downloading an 
Additional License

Describes how to download a previously generated, additional license. 
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5. Click Upload Capability Request.

The Producer Portal uploads the request file. FlexNet Operations generates a regenerative license. 

Task To upload a license request file for an existing license server

1. Click Devices > Search License Servers. The Producer Portal opens the Search License Servers page. 

2. Specify search criteria to locate the server you want to change and click Search.

3. From the list of devices, click the ID of the server for which you want to upload a license request. This link 
opens the View Server page.

4. Click Browse and locate the license request file on your local system. (Button names vary depending on the 
web browser you are using.) 

5. Click Upload Request.

The Producer Portal uploads the request file. FlexNet Operations generates a regenerative license. 

Task To upload a license request file for a new device

1. Click Licenses > Offline Device Activation. The Producer Portal opens the Generate License page. 

2. On the Generate License page, click Browse. (Button names vary depending on the web browser you are 
using.) 

3. Click Upload Request.

The Producer Portal uploads the request file. FlexNet Operations enters the device into the system, adds the 
corresponding entitlement, and generates a license for it. 

Offline Activation: Downloading a Pre-Installed License
You can download a license response file for a pre-installed license after the pre-installed license has been 
generated.

Task To download a pre-installed license

1. Click Devices > Search Devices. The Producer Portal opens the Search Devices page. 

2. Specify search criteria to locate the device you want to change and click Search.

3. From the list of devices, click the ID of the device for which you want to download a license. This link opens 
the View Device page.

4. Click View > Download License File. 

The Producer Portal downloads the license response file (license.bin) to your local machine. 
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Offline Activation: Downloading an Additional License
You can download a license response file for an additional license after the license has been generated.

Task To download an additional license

1. Click Devices > Search Devices. The Producer Portal opens the Search Devices page. 

2. Specify search criteria to locate the device you want to change and click Search.

3. From the list of devices, click the ID of the device for which you want to download a response. This link opens 
the View Device page.

4. Click View > Download Response. 

The Producer Portal downloads the license response file as a binary (typically <device ID>.bin) to your local 
machine. 



Chapter 4 Supporting Licenses
Supporting Offline Device Activation

224 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide



5

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 225

Managing Devices

Producers who use FlexNet Embedded licensing can manage their devices from the Devices menu. 

Use the topics in this section to learn more about managing FlexNet Embedded devices.  

Table 5-1 • 

Topic Description

About Device 
Management

Introduces FlexNet Embedded licensing concepts and discusses device and server 
attributes, management, and support.

Listing Devices Shows how to list existing devices.

Filtering the Devices 
List

Explains how to filter the devices list by device type and activation status.

Previewing Licenses on 
a Device

Explains how to quickly view which licenses are on a device.

Searching for Devices Shows how to search for devices.
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Viewing Devices Explains how to view a device, its device history, and so on. The tasks described 
here explain how to use the commands in the View menu on the default view for a 
device or server page.

• Viewing this Device

• Viewing a Server’s Served Devices

• Viewing Device History

• Viewing Device Requests

• Viewing a Vendor Dictionary for a Device

• Downloading a License File for a Device

• Viewing a License File for a Device

• Downloading a Response for a Device Request

• Viewing a Response for a Device Request

Creating Devices Explains how to create a device.

Editing Devices Explains how to edit a device’s attributes, assign it to an account, and so on. The 
tasks described here explain how to use the commands in the Edit menu on the 
default view for a device or server page.

• Editing Device Attributes

• Adding a Pre-installed Product to a Device

• Assigning an Account to a Device

• Associating a Device with a Device User

• Returning a Device

• Moving a Device

• Making a Device Obsolete

Working with Licenses 
on a Device

Describes how to add entitlements to, and remove licenses from devices.

• Mapping an Entitlement

• Mapping Entitlements by Activation IDs

• Removing Licenses

Supporting Devices Shows how to generate license files and capability responses, and how to manually 
upload capability requests for devices.

• Generating a License File

• Generating a Capability Response

• Uploading a Capability Request from the Device Page 

Table 5-1 • 

Topic Description
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About Device Management 
The following topics discuss FlexNet Embedded licensing concepts.  

About Standalone Devices, Servers, and Served Devices 
A device is a hardware component that has its features licensed using FlexNet Embedded (FNE). Examples of 
devices include high-end medical equipment, routers, and microchip ID scanners. 

A device is identified by a device ID and its type. Device types are: 

• Standalone—FlexNet Embedded device that connects to FlexNet Operations, which manages device 
ownership, state, features, and more. See Creating Devices for more information.

Offline Device 
Management

Describes offline device management activities. 

• Uploading a Capability Request from the Offline Device Management Page

• Uploading Synchronization History

Table 5-2 • 

Topic Description

About Standalone 
Devices, Servers, and 
Served Devices

Introduces the concepts of FlexNet Embedded devices, servers, and served devices.

About Device Ownership Discusses how ownership originates and flows with transactions in FlexNet 
Operations. 

About Device Attributes Describes the attributes of standalone and served devices. These attributes are 
important when creating or editing devices, as well as for device searches.

About Server Attributes Describes attributes of servers. These attributes are important when creating or 
editing servers, as well as for server searches.

About Device Status Discusses the possible states for devices. 

About Overriding the 
Expiration Date of an 
Entitlement

Discusses the conditions under which a license expiration date can be overridden 
on a device and the limitations of doing so.

About the Device–
Device User Association

Describes what a device user is, the system configuration options, and the user 
permissions required to view and edit device users.

Table 5-1 • 

Topic Description
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• Server—FlexNet Embedded server that communicates with FlexNet Operations to manage device ownership, 
state, and features for a collection of served devices. (When a FlexNet Embedded server is used, its served 
devices connect with the FlexNet Embedded server rather than connecting directly to FlexNet Operations.)

• Served—FlexNet Embedded device that is managed via a FlexNet Embedded server. In FlexNet Operations, 
served devices are essentially read-only entities.

For more information about FlexNet Embedded licensing, see your FlexNet Embedded documentation.

About Device Ownership
For any device that exists in the Producer Portal, producers can perform all device management actions that are 
possible for a user with their roles and permissions. Typically, producers can create devices, view a device, map 
entitlements, remove licenses, and so forth. However, by default, mapping entitlements to a device involves an 
ownership check. 

In the End-User Portal, the device owner always retains full control over the device and the licenses on it. But for 
users in other accounts, the visibility and control of devices depends upon multiple factors, mainly related to the 
end user’s accounts, the accounts that are on entitlements, and the accounts that own the device. 

These factors, along with expected behavior in both the Producer Portal and End-User Portal, are discussed in 
detail in the following subsections:

• Ownership Account Check

• Skip Account Check

• Assignment of Ownership for Unowned Devices

• Device Visibility in the End-User Portal

Note • In all cases, users working with devices must have the appropriate permissions to interact with them. For 
example, users who do not have roles with the Manage Devices permission cannot make changes to FlexNet 
Embedded devices.

Tip • In the Producer Portal, producers can directly assign device ownership to an end user or partner account 
from the default view for a device or server page. For instructions, see Assigning an Account to a Device. 

Ownership Account Check
By default, FlexNet Operations performs an account check when entitlements are mapped to a device. Different 
factors are considered for this account check, depending on whether entitlements are being mapped in the 
Producer Portal or the End-User Portal. 

In the Producer Portal, producers can map entitlements from the device owner’s account or its sub-accounts to 
any device that account owns (or any unowned device). Entitlements that belong to other accounts outside the 
device owner’s sub-account hierarchy cannot be mapped. 

In the End-User Portal, the account check compares the user’s accounts, entitlement accounts, and device owner 
accounts when entitlements are mapped to a device. Specifically, in the End-User Portal, 
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• Users can map any entitlement owned by their accounts to any device they can see in the End-User Portal. 
(See Device Visibility in the End-User Portal, below, to learn about which devices a user can see in the End-
User Portal.) 

• Users with roles that include the View Child Devices permission can also map entitlements owned by sub-
accounts of their accounts. 

• Users with roles that include the Claim Device and Activate permission can also map their entitlements to 
unowned devices if they can identify the device by its device ID.

Producers can configure FlexNet Operations to permit mapping of entitlements from unrelated accounts on the 
same device by enabling the Skip Account Check system configuration setting. 

Skip Account Check
The ownership check that FlexNet Operations performs by default can be ignored by enabling the Skip Account 
Check system configuration setting. This setting removes the account check ordinarily performed when an 
entitlement is mapped to a device. Because the account check is not performed, FlexNet Operations permits 
entitlements that belong to accounts unrelated to the device owner to be mapped. 

Note • The Skip Account Check system configuration setting applies to certain activations (End-User Portal, Web 
Service activations, and capability requests) that map new activation IDs or increase quantities. 

In the Producer Portal, skipping the account check allows producers to map any entitlement to a device 
regardless of which account owns the device. The account check is not used.

In the End-User Portal, skipping the account check permits users to map entitlements to devices that are owned 
by unrelated accounts. With Skip Account Check turned on, End-User Portal users can perform all the operations 
permitted when the account check is run. But they can also map any of their entitlements to any device as long as 
they know its device ID and the activation IDs of the entitlements. (Standard permission requirements apply.) 

End users with entitlements on a device owned by an unrelated account can only manage their own entitlements 
(removing licenses or reducing quantities) on that device. 

Channel partner users can only manage entitlements for which they are a distribution partner. 

Important • Channel partners cannot map entitlements to devices unless the Skip Account Check system 
configuration setting is enabled. 

Note • In the End-User Portal, skipping the account check applies only to mapping methods for which the user is 
free to specify device IDs and activation IDs: capability requests, mapping by activation ID, and claiming and 
activating. It does not apply for methods in which the system pre-determines the list of available entitlements 
(based on account check rules), such as mapping an entitlement to a device. 

Tip • To enable this system configuration setting, click System > Configure > FlexNet Operations and, in the 
Embedded Device Settings group, select the check box for Skip Account Check.
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Assignment of Ownership for Unowned Devices
As new devices are created, the account that owns the device is determined by a number of different factors. 
Devices can be created in FlexNet Operations manually or programmatically. For example, producers can 
manually create a device via the Producer Portal, as described in the instructions in Creating Devices. 

In some cases, such as when a device is manually created in the End-User Portal, ownership is assigned when 
the device is created. In other cases, devices are created without an owner.

Unowned devices can be claimed by end users in the End-User Portal or can be assigned an owner by the 
producer in the Producer Portal. 

• For producers, the process of assigning an owner account to an unowned device is relatively simple and 
direct. (See Assigning an Account to a Device for instructions.) The specified account becomes the device 
owner. 

• In the End-User Portal, the process of claiming and activating a device can also assign an owner to an 
unowned device. When an end user clicks Devices > Claim and Activate, the End-User Portal shows the Claim 
and Activate page. On this page, the user identifies the device—typically by specifying its device ID—and 
then lists one or more activation IDs for licenses to activate on that device. In this process, for an unowned 
device, the account to which the first activation ID belongs becomes the owner of the device. 

Tip • Claim and Activate only appears in the Devices menu of the End-User Portal for users with roles 
specifically granted the End-User Portal permissions, Claim Device and Activate and Generate Licenses. (By 
default, only the Producer Portal system administrator role has this permission; no End-User Portal roles 
have this permission.) See FlexNet Operations Permissions for more information about these permissions.

Device Visibility in the End-User Portal
A user’s ability to see a device in the End-User Portal depends on the accounts he or she belongs to and the 
user’s relationship (if any) with the account that owns the device. The visibility of devices to End-User Portal users 
also depends on whether or not one of the user’s accounts (or sub-accounts thereof) has an entitlement mapped 
to the device. 

Device Visibility Guidelines

The following organizational and entitlement factors determine which devices are visible to an end user:

• Devices that are owned by an account to which a user belongs are visible. 

• Devices that are owned by a sub-account of the accounts to which a user belongs are also visible, if the user 
has a role with View Child Devices permission.

• Devices with an entitlement that belongs to one of the user’s accounts are visible to that user. 

• Devices with an entitlement that belongs to a sub-account of the user’s accounts are also visible, if the user 
has a role with View Child Devices permission. (This is true even if the device itself is not owned by any of the 
user’s related accounts.)

• For channel partner users, devices with an entitlement for which the channel partner account is a 
distribution partner are visible. 
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• For channel partner users, devices with an entitlement for which one of the sub-accounts to the user’s 
account is a distribution partner are also visible, if the user has a role with the View Child Devices 
permission.

Devices that are visible to an end user appear in search results for devices. 

Restricted Information on the View Device and View Server Pages

The end user can see these devices, but not all details about the device are shown in cases where none of the 
end user’s related accounts is the device owner. In particular, while the activation IDs of licenses owned by an 
end users accounts (or their sub-accounts) are shown, the activation IDs of unrelated accounts are masked—all 
but the last three characters of the activation ID are replaced with asterisks. 

Similarly, channel partner users can see all the entitlements on a visible device, but the End-User Portal masks 
the activation IDs of the entitlements for which the channel partner is not a distribution partner. And, for greater 
privacy among producers, distributors, resellers, and end customers, entitlements that belong to accounts other 
than the channel partner account or its sub-accounts do not show the account that owns the entitlement. In 
these cases, instead of the owner account, they see Name Withheld.

(For more information about channel partner accounts, see Account Types and Partners and Distribution Tiers in 
the About Accounts section.)

About Device Attributes
The following attributes are used when creating, editing, and searching for standalone and served devices.   

Table 5-3 • 

Attribute Description

Activation ID An activation ID associated with the device.  

Device ID The device’s unique identity. 

Device ID Type One of several possible device host ID types. 

• Ethernet

• Internet

• Internet IPV6

• FlexID 9

• FlexID 10

• String

• User

• VM UUID

• Container Id

• Extended

• Publisher defined 
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Device Model The device’s model. When creating a device, you can choose from existing device 
models or keep the default setting: Use Default Device Model. See Managing Device 
Models for more information about models. 

Device Name A short, alternate name for the device. 

Entitlement ID An entitlement ID associated with the device. 

Identity The publisher identity to use for the current device. When creating a device, you can 
choose from existing identities or keep the default setting: As Defined by Device 
Model. See Managing Publisher Identities for more information about identities.

Last Modified The last date that the device was changed, or had entitlements mapped or licenses 
removed. For served devices, the date is updated when a sync record is processed.

Notes Additional information about the device for internal use by the producer’s account. 

Account ID The ID of the customer or partner account that owns the device. 

Account Name The name of the customer or partner account that owns the device. 

Part Number The part number of the device. 

Pre-installed
Product

The product that determines the features included in the pre-installed license for 
the device. Pre-installed product settings also determine the license model, license 
model attributes, and expiration terms used for the pre-installed product on the 
device.

If no pre-installed product is specified, the device inherits the pre-installed product 
that was added to its device model. If no pre-installed product is specified in the 
device model, the device includes no built-in features in its pre-installed license.  

Product,
Product Name

The name of a product on the device. 

Served by Server ID The ID of the server for a device whose type is SERVED_CLIENT. 

Site Name The device’s site name.

Status The status of the device. See About Device Status for information about possible 
status values.

Type CLIENT for standalone devices, SERVED_CLIENT for served devices. 

User The device user associated with the device. See About the Device–Device User 
Association for more information about device users.

Table 5-3 • 

Attribute Description
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About Server Attributes
The following attributes are used when creating, editing, and searching for servers.  

Updates The update activity for a device. In the Devices grid view, the Updates column 
displays either Updates with a link to the Updates tab for that device or No updates. 
Hovering over the Updates link triggers a pop-up that contains the update name, 
update ID, the status of the update and the date of the last activity. See Creating 
Devices for more information.

Table 5-4 • 

Attribute Description

Backup License
Server ID

The ID of the server’s backup server. 

Deployment The deployment type for the server. Choose from Local License Server and Cloud 
Licensing Service. 

Device Name A short, alternate name for the server. 

Host ID Type One of several possible device host ID types. 

• Ethernet

• Internet

• Internet IPV6

• FlexID 9

• FlexID 10

• String

• User

• VM UUID

• Container ID

• Tolerant

• Extended

• Publisher defined

Host ID Type is not shown for servers with the Cloud Licensing Service deployment 
type. In this case, the host ID type is set by the Server Host Type.

Table 5-3 • 

Attribute Description
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Identity The publisher identity to use for the current server. When creating a server, you can 
choose from existing identities or keep the default setting: As Defined by Server 
Host Type. See Managing Publisher Identities for more information about identities.

Last Modified The last date that the server was changed, had entitlements mapped, or had 
licenses removed.

License Server ID A unique identity for the server. 

License Server ID is not shown for servers with the Cloud Licensing Service 
deployment type. In this case, FlexNet Operations automatically generates a License 
Server ID. (The License Server ID serves as the instance ID to identify this server in 
endpoint URLs.) 

Notes Additional information about the device for internal use by the producer’s account. 

Account The name of the account specified in Account ID. 

Account ID The account ID for the owner, enterprise, or other account that currently holds the 
device. 

Pre-installed Product The product that determines the features included in the pre-installed license for 
the server. Pre-installed Product settings also determine the license model, license 
model attributes, and expiration terms used for the pre-installed product on the 
server.

If no pre-installed product is specified, the server inherits the pre-installed product 
that was added to its server host type. If no pre-installed product is specified in the 
server host type, the server includes no built-in features in its pre-installed license. 

Server Host Type The server host type for the device. When creating a server, you can choose from 
existing server host types or keep the default setting: Use Default Server Host Type. 
See Managing Server Host Types for more information about server host types. 

Site Name Site Name is optional for local license servers but required for servers that use the 
Cloud Licensing Service deployment type. The Site Name is a label used to 
distinguish between different servers when a customer account is given multiple 
Cloud Licensing Service servers.

Status The status of the server. See About Device Status for information about possible 
status values.

Type SERVER for a license server.

User The device user associated with the server. See About the Device–Device User 
Association for more information about device users.

Table 5-4 • 

Attribute Description
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About Device Status 
FlexNet Embedded device status is indicated on various pages of the Producer Portal. 

Device Status for Standalone Devices and Servers
The state of a device or server is indicated by its status in the devices list of the search results, and its default 
view for a device or server page. A device or server’s status can be ACTIVE, RETURNED, or OBSOLETE.

The status of a device affects the types of operations you can perform on that device. 

• Active—An active device can be the target for any normal operation (like activation, download, and return). 

• Returned—When a device is returned, its licenses can be moved to a designated device or, if no target device 
is provided, those licenses are returned to the pool. The returned state is permanent; returned devices 
cannot be made active again.

• Obsolete—When a device is made obsolete, its licenses are unmapped and returned to the pool, and the 
device is unable to acquire licenses. The device ID of a device that is made obsolete also changes to reflect 
its status. FlexNet Operations appends -OBSOLETE-<datetime> to the end of the device ID value. The obsolete 
state is permanent; obsolete devices cannot be made active again. 

Device Status for Served Devices
The status of served devices appears in the same locations on the Producer Portal, but it is not managed on the 
Producer Portal. (You cannot manually make a served device obsolete.) The possible status values for a served 
device include normal, returned, dropped, and expired.

• Normal—Served device is operating and currently managed by its parent FlexNet Embedded server.

• Returned—Served device still belongs to the FlexNet Embedded server, but has returned all its licenses to 
the entitlement pool.

• Dropped—Served device has been manually dropped by a user on the FlexNet Embedded server. (Dropped 
device licenses return to the entitlement pool.)

• Expired—Served device’s features have expired and the device has not checked in with its parent FlexNet 
Embedded server. 

About Overriding the Expiration Date of an Entitlement
FlexNet Operations enables End-User and Producer Portal users to override an entitlement’s configured 
expiration date with an earlier, user-specified expiration date when the entitlement is mapped to a device as an 
additional product. This feature allows finer control of license expiration, and makes licenses available for other 
hosts in a more planned and automated way.

To enable this capability in the End-User and Producer Portals, select the Override license expiration date setting 
(in the Producer Portal, click System > Configure > FlexNet Operations > Embedded Devices Settings). When it is 
enabled, both portals display the License expiration date field—in which the user can enter a short-term 
expiration date—on their Map Entitlements page.

The user-specified expiration date must be later than the current date and earlier than the configured license 
expiration date. For example: 
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• If the license is configured to be a permanent license, the user can set the expiration to any date later than 
the current date.

• If the license is configured with an expiration date such as 31 December 2025, the user can set the 
expiration to any date later than the current date and before 31 December 2025.

• If the license is configured with a duration-based expiration and a “Use Each Activation Date” start, the start 
date (license generation date) is the current date.

• If the license is configured with a duration-based expiration and a “Use First Activation Date” start, the start 
date is the first license generation date. In other words, the current date is the start date if no licenses have 
been generated for the entitlement on that device yet. However, after licenses have been generated, the 
actual activation date is the start date. 

A user-specified expiration date can be set for each entitlement (however, additional copies of an entitlement are 
assigned the same user-specified expiration date) and can be different for each host with the same entitlement. 
After it is set, the date is displayed in the Expiration Date column of the default view for a device or server page of 
both portals.

Licenses with user-specified expiration dates are automatically removed from a host when that date has passed. 
An automated process removes licenses with a user-specified expiration date when they expire,

• regardless of other rules about license removal,

• once a day at 10 AM Coordinated Universal Time (UTC)

• and does not require confirmation from the host (in other words, the licenses are returned directly to the pool 
and are available for other hosts).

Limitations
A user-specified expiration date can be set only in the End-User or Producer Portal interface; it cannot be set in 
capability requests or Web Services. 

Because of the risk for license abuse, the user-specified expiration date cannot be changed. If the wrong user-
specified expiration date is entered, it can be changed using standard license removal and entitlement mapping 
procedures.

About the Device–Device User Association
A FlexNet Operations device can be associated with an end user or a contact called the Device User. Associating 
a device with a device user allows an End-User Portal administrator to communicate with someone regarding the 
licenses on that device. For example, if the End-User Portal administrator needs a license for a new device but 
there are no licenses available, the administrator can search for all existing devices using that license and 
request that one of those device users return their license so it can be used on the new device.

With the proper combination of system configuration and user permission settings, a device user can be added, 
edited, or deleted via capability request, sync request, the End-User Portal, the Producer Portal, or Web Services. 
The same device user can be associated with multiple devices, but a device can only be associated with one 
device user. 
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System Configuration 
Use the Device User Option (click System > Configure > FlexNet Operations > Embedded Device Settings) to 
enable and configure this capability. Values are: 

• Off – The User field is not visible in either portal, and device user data sent in a capability request, sync 
request, or Web Service is ignored.

• On with no validation – The User field is shown in both portals, and with the correct permission (refer to 
User Permissions) can be edited by the user. The value entered is not validated, so it can be anything. For 
example, it can be an email address or a phone number. 

• On with validation – The User field is shown in both portals, and with the correct permission (refer to User 
Permissions) can be edited by the user. The value can only be set to an active user or a contact chosen from 
the Select User window.

Important • When the device is a license server, the device User field is not validated. 

When the Device User Option is set, the User field appears on the default view for a device or server page in the 
End-User and Producer Portals. A validated device user is displayed as an email address that links to the Users 
page. Device user is also returned in Web Services and capability responses. Device users who are not active 
FlexNet Operations users are identified as inactive.

User Permissions 
An End-User Portal user with Edit user on device permission can edit the User field of a device. 

A Producer Portal user with Manage devices permission can view and edit the User field (Edit user on device 
permission is not required).

When Device User Option is ON with validation, an End-User Portal user with Manage User permission can click 
the user name link—located below the User name—to display the View/Edit Device User page. Similar 
functionality is available in the Producer Portal. 

Listing Devices
Use the following instructions to list existing standalone devices, servers, and served devices on the Producer 
Portal. 

Task To list devices

1. Click Devices > Devices. The Devices page opens. 

2. On the Devices page, you can filter the device list by device type and status. 

3. To view a particular device, click its Name. On the default view for a device or server page, you can perform 
device editing and support activities. 
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Filtering the Devices List
To quickly reduce the size of the devices list displayed on the Devices page, filter it by device type and activation 
status.

Task To filter the devices list 

1. On the Devices page, hover the cursor over the  filter icon to display the filter selection list.

2. On the selection list, select the device Type (or types) and Status you want to view.

3. Click Apply to filter the devices according to your selection(s). The number in the red bubble indicates how 
many filters are active. 

4. You can also search a filtered devices list.

Previewing Licenses on a Device
In the Devices page list, the Licenses column enables you to quickly view the licenses on a device and decide 
whether to view that device in more detail. A preview pane shows up to ten of the licenses on the device, and 
includes a link to view the rest of the licenses if there are more than ten on that device. Served devices have 
features only; their licenses reside on a server, so no license information is available for them. If there are no 
licenses on a device, that is also indicated.

Task To preview licenses on a device

• In the Devices page list, hover the cursor over the License info link in the Licenses column cell for the device 
whose licenses you want to preview. 

Searching for Devices
Existing devices can be easily located by performing a search of the Devices page list based on an attribute of the 
device you want to see. You can perform a simple search on a single attribute, or an advanced search on multiple 
attributes. For both searches, you can use the * wild card to match zero or more characters in the text string. 

Task To search for a device

1. Optionally, to reduce the size of your devices list, you can filter it by device type and activation status before 
you search: 

a. On the Devices page, hover the cursor over the  filter icon to display the filter selection list.

b. On the selection list, select the device Type (or types) and Status you want to view.

c. Click Apply to filter the devices according to your selection(s). The number in the red bubble indicates 
how many filters are active. 
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2. Perform a simple search or an advanced search for a device: 

Simple Search

a. On the Devices page, click the drop-down list next to the filter icon and select the search criterion.

b. Type the search string in the text field next to the drop-down list.

c. Click Search.

Advanced Search

a. On the Devices page, click the + icon (next to the Search button) to open the Advanced Search window.

b. Type search criteria in the attribute text fields. 

c. Click Search.

The Producer Portal shows a list of the devices that match your search criteria on the Devices page.

Note • FlexNet Operations tenants configured with a Device user option setting other than Off, listed below, can 
enter these User search criteria with wildcards:

• On with no validation – free-form string

• On with validation – email address 

The Producer Portal shows a list of the devices that match your search criteria on the Device Search Results 
page. See About Device Attributes or About Server Attributes for more information about attributes available in 
the search criteria. 

You can also locate served devices from the View Server page of their server. See Viewing a Server’s Served 
Devices for instructions. 

Note • Searches that include Account as a search criterion may return devices that are not owned by an account 
that matches the search criteria. When Account is part of the search criteria, search results include 

• Devices owned by an account that matches the search criteria

• Devices with licenses that belong to an account that matches the search criteria

Tip • To view a particular device, click on its device Name. On the default view for a device or server page, you can 
perform device editing and support activities—such as changing device or server attributes, or moving a device—
that are permitted by your user account permissions. See Viewing Devices.
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Viewing Devices
Users typically search for a device they want to view and then click that device’s Name to open the default view 
for a device or server page. The View menu on the device’s page includes several commands to get more details 
about the device, the device history, device requests, and so on. With the commands in the View menu, you can 
perform the following tasks. 

Viewing this Device 
When working with a device, you can return to the default view for a device or server page by clicking View this 
Device/Server/Served Device. Device-related operations are downloading a capability response, viewing device 
requests, assigning an account to the device, mapping entitlements, and so forth. On these device-related pages, 
View this Device/Server/Served Device is a command in the View menu. 

The Producer Portal also shows the default view for a device or server page after you create a device on the 
Create Device/Server page.

Table 5-5 • 

Topic Description

Viewing this Device Explains how to return to the default view for a device or server page when 
performing other device-related operations. 

Viewing a Server’s 
Served Devices

Shows how to see devices that are served by a license server. 

Viewing Device History Explains how to view the device history for a selected device. 

Viewing Device 
Requests

Explains how to view requests made by a device.

Viewing a Vendor 
Dictionary for a Device

Shows how to see vendor dictionary entries for a device. 

Downloading a License 
File for a Device

Describes how to download a license file for a device. 

Viewing a License File 
for a Device

Shows how to see a license file for a device.

Downloading a 
Response for a Device 
Request

Describes how to download a response for a capability request. 

Viewing a Response for 
a Device Request

Shows how to see a response generated for a capability request.
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Task To return to the default view for a device or server page

• Click View > View this Device/Server/Served Device. 

The default view for a device or server page opens. For standalone devices, the Overview tab is selected.

Viewing a Server’s Served Devices 
Producers can view the devices served by a particular server from the server’s View Server page.

Task To view the served devices of a server

• Click View > View Served Devices. 

The Served Devices Search Results page opens. 

Viewing Device History 
You can view a device’s history from its default view for a device or server page. The Host History page shows a 
history of device management events such as device creation, ownership changes, transfers, and device status 
changes. 

Task To view the history of a device

• Click View > View Device/Server/Served Device History. 

The Host History page opens. 

Viewing Device Requests 
You can view the history of all device activation requests, as well as the sync message records (for servers and 
served devices), from a device’s default view page. 

Task To view device request history

• Click View > View Device/Server Requests. 

The View Host Requests page opens. 

Viewing a Vendor Dictionary for a Device 
You can view vendor dictionary entries for a device from its default view page. 
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Task To view vendor dictionary entries

• Click View > View Vendor Dictionary.

The View Vendor Dictionary page opens. 

Downloading a License File for a Device 
If a license has been generated for a device, you can download its license file from the default view for a device or 
server page.

Task To download a license file

• Click View > Download License File.

The Producer Portal sends the license file (typically, license.bin). The download experience depends on the web 
browser you are using. 

Tip • A device’s license format settings determine which, if any, of its features are included in a license file. 
Devices inherit their license format settings from their device model. You can download a license file for a device 
that stores either its pre-installed license or its pre-installed license plus additional licenses in a license file. 
(Devices that store both the pre-installed license and additional licenses in trusted storage use capability 
requests and responses rather than license files.) 

Viewing a License File for a Device
If a license has been generated for a device, you can view its license file from the default view page. 

Task To view a license file

• Click View > View License File.

The View License File page opens. This page shows the text of the license file that was generated for the device. 

Tip • A device’s license format settings determine which, if any, of its features are included in a license file. 
Devices inherit their license format settings from their device model. You can view a license file for a device that 
stores either its pre-installed license or its pre-installed license plus additional licenses in a license file. (Devices 
that store both the pre-installed license and additional licenses in trusted storage use capability requests and 
responses rather than license files.) 
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Downloading a Response for a Device Request
If a capability response has been generated for a device, you can download that response from the default view 
for a device or server page. 

Task To download a capability response

• Click View > Download Response.

The Producer Portal sends the capability response (typically <device ID>.bin for a device, <license server 
ID>.bin for a server). The download experience depends on the web browser you are using. 

Tip • A device’s license format settings determine which, if any, of its features are described in capability 
responses. Devices inherit their license format settings from their device model. You can download a response 
for a device that stores either its pre-installed license or its pre-installed license plus additional licenses in 
trusted storage. (Devices that store both the pre-installed license and additional licenses in a license file do not 
have response files to download.) 

Viewing a Response for a Device Request
If a capability response has been generated for a device, you can view the response from the default view for a 
device or server page. 

Task To view a capability response

• Click View > View Response.

The View Response page opens. This page shows the a human-readable representation of the capability 
response that was generated for the device. 

Tip • A device’s license format settings determine which, if any, of its features are described in capability 
responses. Devices inherit their license format settings from their device model. You can view a response for a 
device that stores either its pre-installed license or its pre-installed license plus additional licenses in trusted 
storage. (Devices that store both the pre-installed license and additional licenses in a license file do not have 
response files to view.)

Creating Devices
You can create new devices in the Producer Portal. Each device is identified by a device ID (typically, a serial 
number) and its host type. You can create a set of devices for which licenses can be generated, as well as 
generate pre-installed licenses for the device. Entitlements can be linked to devices.

A new server can submit its own capability requests to FlexNet Operations and serve its own licenses to separate 
FlexNet Embedded served devices. 
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Producers who use FlexNet Cloud Licensing Service can choose from two Server deployment options to create a 
server as a Local (default) or as a Cloud license server. If auto provisioning is permitted by the license model, 
Cloud Licensing Service servers can be automatically created when the entitlement is deployed. 

Note • You are permitted to create a server and a nodelocked device with the same Device ID and ID Type. 

Task To create a device

1. Click Devices > Create Device. The Device | New Device page opens. 

2. On the Device | New Device page, type a device Name (required). 

3. Select an ID Type from the drop-down menu; below it, type the device’s ID (required). 

4. Select an Account to specify which account owns the device: 

a. Click the search icon next to Account. The Assign Device Owner window appears. 

b. In the Assign Device Owner window, click the Customers or Partners tab, as appropriate. 

c. Choose an account and click Select. The Assign Device Owner window closes and the Account field on 
the Device | New Device page is populated. 

5. Optionally, specify values for Model, Identity, Site name, and Notes. (See About Device Attributes for details 
about these attributes.) 

Important • Be aware that the device model you specify may include a default pre-installed product. In this 
case, adding a pre-installed product to the device overrides the device model’s pre-installed product. 

6. Click Save. 

The Producer Portal creates the new device and opens its default view page. 

Task To create a local license server

1. Click Devices > Create Device. The Device | New Device page opens. 

2. On the Device | New Device page, type a device Name (required). 

3. Select the Runs license server? check box. For Server deployment, choose Local. 

4. Select an ID Type from the drop-down menu; below it, type the server’s ID (required). 

5. Select an Account to specify which account owns the device (required): 

a. Click the search icon next to Account. The Assign Device Owner window appears. 

b. In the Assign Device Owner window, click the Customers or Partners tab, as appropriate. 

c. Choose an account and click Select. The Assign Device Owner window closes and the Account field on 
the Device | New Device page is populated. 
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6. Optionally, specify values for Model, Identity, Site name, and Notes. (See About Server Attributes for details 
about these attributes.) 

Important • Be aware that the device model you specify may include a default pre-installed product. In this 
case, adding a pre-installed product to the device overrides the default pre-installed product in the device 
model. 

7. Click Save. 

The Producer Portal creates the new server and opens its View Server page. 

Task To create a Cloud Licensing Service license server

1. Click Devices > Create Device. The Device | New Device page opens. 

2. On the Device | New Device page, type a device Name (required). 

3. Select the Runs license server? check box. For Server deployment, choose Cloud. 

4. Select an Account to specify which account owns the device (required): 

a. Click the search icon next to Account. The Assign Device Owner window appears. 

b. In the Assign Device Owner window, click the Customers or Partners tab, as appropriate. 

c. Choose an account and click Select. The Assign Device Owner window closes and the Account field on 
the Device | New Device page is populated. 

5. Optionally, specify values for Model, Identity, Site name, and Notes. (See About Server Attributes for details 
about these attributes.) 

Important • Be aware that the device model you specify may include a default pre-installed product. In this 
case, adding a pre-installed product to the device overrides the default pre-installed product in the device 
model. 

6. Click Save. 

The Producer Portal creates the new server and opens its View Server page. 
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Editing Devices
Users typically search for a device they want to edit and then click its device Name to open its default view for a 
device or server page. The Edit menu on the default view for a device or server page includes several commands 
for actions—like editing device attributes, assigning an account, or making a device obsolete—for an existing 
device. With the commands in the Edit menu, you can perform the following tasks.  

Some device changes are made as part of support activities. These are described in Supporting Devices.

Editing Device Attributes
You can edit a device’s details from the default view for a device or server page. Most of the device information 
that you enter when you create a device can be edited on the Edit Device /Server/Served Device page. 

Note • A device’s editable attributes may also include the values for any custom device attributes you have 
defined. To learn more about custom attributes, including custom device attributes, see Administering Custom 
Attributes. 

For more information about device attributes, see About Device Attributes. For more information about server 
attributes, see About Server Attributes. 

Table 5-6 • 

Topic Description

Editing Device 
Attributes

Explains how to edit a device’s changeable attributes. (Some attributes are read-
only after a device has been created.)

Adding a Pre-installed 
Product to a Device

Explains how to add a pre-installed product to a device to define a set of built-in 
features. 

Assigning an Account to 
a Device

Describes how to change the current account that holds a device. 

Associating a Device 
with a Device User

Explains how to associate a device with a device user.

Returning a Device Explains how to return a device. 

Moving a Device Shows how to change the account of a device that has not yet been assigned to a 
customer account. 

Making a Device 
Obsolete

Describes how to make a device obsolete. 
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Task To edit device attributes

1. On the default view for a device or server page, click Edit > Edit this Device/Server/Served Device. The 
default edit page for a server or device page opens for the current device. 

2. Make changes to one or more device attributes. 

3. Click Save. 

The Producer Portal saves your changes and returns to the default view for a device or server page for the current 
device. 

Adding a Pre-installed Product to a Device
You can add pre-installed products to a device from the default view for a device or server page. A pre-installed 
product defines a set of built-in features for a device. A device with no pre-installed products is a device with no 
built-in features; all features would be additional features. 

Important • Be aware that a device model may include a default pre-installed product. In this case, adding 
another pre-installed product to the device overrides the device model’s pre-installed product. 

Task To add a pre-installed product 

1. On the default view for a device or server page, click Edit > Edit this Device/Server. The default Edit page for 
a device or server  appears. 

2. In the Pre-installed Licenses section of the page, click Add. The Add Pre-installed Product window opens.

3. In the Add Pre-installed Product window, click By product. The Select Product window opens. The Select 
Product window lists products with features permitted by the restrictions imposed (if any) by the device 
model’s device series. 

4. In the Select Product window, select the pre-installed product and then click OK. The Select Product window 
closes, and the product name and product version of the selected product are shown on the Add Pre-
installed Product page. 

5. In the Add Pre-installed Product window, specify a license model, license model attributes (optional), and 
expiration terms.  

Setting Description

License Model Choose a License Model for the pre-installed product. The license models that 
are available are determined by the license models that are linked to the 
selected pre-installed product.

License Model 
Attributes

Optionally, provide settings for license model attributes (such as Notice and 
Vendor String).
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6. Click Add. The Add Pre-installed Product window closes and the default edit page for a device or server is 
displayed. Notice that the Pre-installed Licenses settings show the product you selected, as well as its 
expiration terms.

7. Click Save. 

The Producer Portal saves your changes and returns to the default view for a device or server page for the current 
device. 

Assigning an Account to a Device
You can assign a customer or partner account to an existing device from the device’s default view for a device or 
server page. (See About Accounts for more information about customer and partner accounts.)

Note • The following limitations exist for auto-provisioned license servers that have entitlements mapped for 
metered features: 

• License servers cannot be moved to another account.

• Only unused licenses for metered features can be removed using Licenses > Remove Licenses.

• License servers can be made obsolete, which will remove all licenses mapped to the server. However, this is 
not recommended, because future line items will not be mapped automatically to the auto-provisioned 
license server. 

Task To assign an account to a device

1. Click Edit > Assign Account. The Assign Account page opens. 

2. For Account ID, click the search icon. The End Customer and Channel Partners window opens. 

a. Choose an account. 

b. Click Save. 

The End Customer and Channel Partners window closes, the Account ID is set to the ID of the account you 
chose, and the Account Name is populated.

3. Click Assign account. 

The Producer Portal changes the account of the device and opens its default view for a device or server page. 

Devices that do not have a customer account assigned to them can also be moved to a partner account. (See 
Moving a Device.)

Expiration Terms Set the Start Date and Expiration for the pre-installed product. 

Setting Description
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Associating a Device with a Device User
When the Device User Option is enabled, the User field is visible and a device can be associated with an end user 
or contact called the Device User. Associating a device with a device user allows an End-User Portal administrator 
to communicate with someone regarding licenses on the device. 

Note • When the Device user option is enabled (not set to Off), device user is in one of these formats: 

• Free-form string for On with no validation – see To associate a device with a device user—no user validation 

• Email address link for On with validation – see To associate a device with a device user—validated user 

You can associate a device with a device user from the default view for a device or server page. 

Task To associate a device with a device user—no user validation

1. Click Edit > Edit this Device/Server. The default edit page for a device or server opens. 

2. In the User field, type the device user information for the device. 

To remove an associated user, clear the User field. 

3. Click Save to save the change. The default view for a device or server page opens, showing the updated User. 

Task To associate a device with a device user—validated user

1. Click Edit > Edit this Device/Server. The default edit page for a device or server opens. 

2. In the User field, click the search icon to display a list of available users. 

To remove an associated user, clear the User field. 

3. Select one user, then click Select to close the list and set the device user. 

4. Click Save to save the change. The default view for a device or server page opens, showing the updated User. 

Returning a Device

Important • Returning a device is an irreversible action. It is intended for devices that no longer receive capability 
responses or license files, or servers that no longer serve devices or communicate with the FlexNet Operations 
back office.

A customer may be required to return a malfunctioning device to a manufacturer or reseller. During the return 
process, you have the option to move all of the malfunctioning device’s licenses to a replacement device. If you 
do not move a license, the license is returned to the pool of unused licenses and you can allocate it to another 
device.

You can return a device from the default view for a device or server page. 



Chapter 5 Managing Devices
Editing Devices

250 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Task To return a device

1. Click Edit > Return Device/Server. The default return page for a device or server opens. 

2. Optionally, identify the device to receive the current device’s licenses in Destination Device/License Server 
ID. 

• Type the ID of the device to receive the current device’s licenses.

• Click the search icon to open the Find Device or Search License Servers window. 

a. Choose a device. 

b. Click Submit. 

The Find Device/License Servers window closes and the default destination ID page for a device or 
license server value is set to the device you chose.

3. Optionally, type an RMA number for Return Material Authorization (RMA) Number. RMA number values are 
recorded by the Producer Portal but are not required by FlexNet Operations.

4. Click Confirm. 

The Producer Portal returns the device and shows its default view for a device or server page. The status of a 
returned device is RETURNED.

Moving a Device
A device that does not have a customer account assigned to it can be moved from one account to a related 
account. For example, the parent account can move the device from one of its child accounts (a regional division, 
for example) to another child account.

When a device is moved, any entitlements that belong to that device are moved as well. The result of such a move 
is to either create new entitlements for the receiving account, or to increment the count of that account’s existing 
(and matching) entitlements by the count on the device that was moved. 

Note • The following limitations exist for auto-provisioned license servers that have entitlements mapped for 
metered features: 

• License servers cannot be moved to another account.

• You cannot remove licenses using Licenses > Remove Licenses.

• License servers can be made obsolete, which will remove all licenses mapped to the server. However, this is 
not recommended, because future line items will not be mapped automatically to the auto-provisioned 
license server. 

You can move a device from the default view for a device or server page. 



Chapter 5 Managing Devices
Editing Devices

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 251

Task To move a device

1. Click Edit > Move Device/Server. The Move Host page opens. 

2. In the Target Account section, click the System Account ID search icon. The End Customer and Channel 
Partners window opens. 

a. Choose an account. 

b. Click Save. 

The End Customer and Channel Partners window closes, the System Account ID is set to the ID of the 
account you chose, and the Account ID and Account Name fields are populated.

3. Click Move Device/Server. 

The Producer Portal changes the account of the device and opens its default view for a device or server page. 

Making a Device Obsolete
You can make an active device obsolete from its default view for a device or server page. When a device is made 
obsolete, its licenses are unmapped and returned to the pool, and it becomes unable to acquire new licenses.

Important •  Obsolete status is permanent. Obsolete devices cannot be re-activated. 

Note • The following limitations exist for auto-provisioned license servers that have entitlements mapped for 
metered features: 

• License servers cannot be moved to another account.

• You cannot remove licenses using Licenses > Remove Licenses.

• License servers can be made obsolete, which will remove all licenses mapped to the server. However, this is 
not recommended, because future line items will not be mapped automatically to the auto-provisioned 
license server. 

Task To make a device obsolete

1. Click Edit > Make Obsolete. The Producer Portal warns that this process is irreversible and asks you to 
confirm before changing the current device’s status to OBSOLETE.

2. Click OK. 

The Producer Portal changes the status of the device to OBSOLETE and shows its default view for a device or 
server page.
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Working with Licenses on a Device
Additional features are capabilities that can be mapped (added) to or removed from a device. (Pre-installed 
capabilities, on the other hand, are features included with a device or server.) The following topics describe how 
to manage additional capabilities in the Producer Portal.  

For more information about creating additional capabilities as features for your FlexNet Embedded devices, see 
Working with Features. 

Mapping an Entitlement
Devices often include pre-installed licenses but also permit the addition of new features or more capacity via 
additional entitlements. 

When the current account of a device is entitled to additional capabilities, you can manually map those 
entitlements to it via the Producer Portal. (Entitlements can also be mapped programmatically from the device 
using an activation ID.) 

You can map entitlements from the default view for a device or server page. 

Task To map an entitlement

1. Click Licenses > Map Entitlements. The Map Entitlements page opens. The table lists entitlements that can 
be mapped to the current device. 

Tip • When an entitlement has been upgraded, upsold, or renewed, the Map Entitlements page shows only 
the most recent entitlement in its lifecycle chain. Earlier entitlements are grouped under the most recent 
entitlement but initially hidden. These entitlement groups have a Show Upgrades button to reveal earlier 
entitlements in the list.

2. In the table, type values into Qty to add for the entitlements you want to map. 

3. (Optional) If the capability is enabled, you can override an entitlement’s configured Expiration, as shown in 
the Licenses table, with a shorter-term expiration. (Refer to About Overriding the Expiration Date of an 
Entitlement for details.) 

To override an entitlement’s expiration, 

Table 5-7 • 

Topic Description

Mapping an Entitlement Shows how to map additional entitlements to a device. 

Mapping Entitlements 
by Activation IDs

Shows how to map additional entitlements by activation ID (for users who know the 
activation IDs of the capabilities they want to add). 

Removing Licenses Shows how to remove previously mapped licenses from a device. 
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a. Click the pencil icon next to its expiration. The Producer Portal opens a calendar control.

b. In the calendar control, select the shorter-term expiration. 

After the change is saved, the new expiration appears in the Licenses table of the default view for a device or 
server page, and is denoted by an asterisk in the table on the device’s Map Entitlements page. 

4. Click Save. 

The entitlement is mapped to the current device and its default view for a device or server page is shown. 

Mapping Entitlements by Activation IDs
Devices often include pre-installed capabilities, but also permit the addition of new features or more capacity via 
additional entitlements. 

When the current account of a device is entitled to additional capabilities, and you know the activation IDs for 
those entitlements, you can manually map those entitlements to the device via the Producer Portal, as shown 
below. (Entitlements can also be mapped programmatically from the device or server using an activation ID.) 

First locate the device or server to which you want to map new activation IDs. (See Searching for Devices or 
Viewing Devices for instructions.) Then you can map entitlements by activation ID from the default view for a 
device or server page.

On the Map by Activation IDs page, you can type the activation IDs to map to the current device. 

Note • This operation is for producers who know the activation IDs for the entitlements they want to map. 

Task To map an entitlement by activation ID

1. Click Licenses > Map by Activation IDs. The Map by Activation IDs page opens. 

2. In the Activation IDs field, type one or more activation IDs (one activation ID per line) to map to the current 
device. 

3. Click Validate. The Producer Portal evaluates the activation IDs you provided and shows whether they can be 
mapped to the current device. 

• If all activation IDs provided can be mapped to the device, proceed to Step 4.

• If one or more activation IDs cannot be mapped to the device, the Producer Portal highlights the 
activation IDs that did not pass validation and allows you to either remove them from the list or cancel 
the mapping operation. 

• To continue without the activation IDs that failed validation, first remove the failed activation IDs and 
then click Re-validate. When the re-validation passes successfully, proceed to Step 4.

• To cancel the mapping, click Cancel.

4. After the activation IDs have been validated, type values into Qty to Add for the entitlements you want to 
map. 

5. Click Save. 
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The activation ID is mapped to the current device and its default view for a device or server page is shown. 

Removing Licenses
Licenses already mapped to a device can be manually removed via the default view for a device or server page. 
Licenses that are unmapped are returned to the pool of unused licenses. 

Note • The following limitations exist for auto-provisioned license servers that have entitlements mapped for 
metered features: 

• License servers cannot be moved to another account.

• You cannot remove licenses using Licenses > Remove Licenses.

• License servers can be made obsolete, which will remove all licenses mapped to the server. However, this is 
not recommended, because future line items will not be mapped automatically to the auto-provisioned 
license server. 

Task To remove a license

1. Click Licenses > Remove Licenses. The Remove Licenses page opens. On this page, the Licenses Currently 
Mapped table lists licenses that can be removed from the current device. 

2. In the Licenses Currently Mapped table, type values into Qty to remove for the licenses you want to remove. 

3. Click Save. 

The Producer Portal removes the licenses from the current device and shows its default view for a device or 
server page. 

Supporting Devices
Device support activities, like generating license files and capability responses or manually uploading capability 
requests, are covered here.   

Table 5-8 • 

Topic Description

Generating a License File Describes how to generate a license file for a device. 

Generating a Capability 
Response

Explains how to generate a capability response for a device. 

Uploading a Capability Request 
from the Device Page

Explains how to upload a capability request for a device from the Device 
page. 
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Some device support activities, such as assigning accounts and returning devices, are covered in the Editing 
Devices topic. For instructions on manually downloading a generated license file or capability response, see 
Viewing Devices. 

Generating a License File
You can generate a license file for a device from its Device | <device name> page. 

Task To generate a license file for a device

• In the Pre-installed Licenses section of the Device | <device name> page, click Generate license file. 

The license file is generated and a confirmation message is shown. 

After a license has been generated, you can download it by clicking View > Download License File. See 
Downloading a License File for a Device for details.

Generating a Capability Response
You can generate a capability response for a device from its default view for a device or server page. 

Task To generate a capability response for a device

• In the Model Details section of the default view for a device or server page, click Generate capability 
response (Generate response). 

The response is generated and a confirmation message is shown.

After a response has been generated, you can download it by clicking View > Download Response. See 
Downloading a Response for a Device Request for details.

Uploading a Capability Request from the Device Page
Capability requests can be manually uploaded by producers on the Producer Portal. You can upload a capability 
request from a device’s default view for a device or server page. 

Task To upload a capability request for a device

1. In the Model Details section of the default view for a device or server page, click Browse and locate the 
capability request on your local system. (The exact controls vary depending on the browser you are using.) 

2. Click Upload capability request (Upload request). 

The capability request is processed. 
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After the capability request is processed, download the capability response and process it on your device. (See 
Generating a Capability Response.) In offline activation scenarios, for example, the producer communicates the 
capability response to the end user of a device that cannot connect directly to the Internet, and the end user 
applies it to their device to activate the capabilities to which they are entitled.

Offline Device Management
Offline device management activities are covered here.  

Uploading a Capability Request from the Offline Device 
Management Page

Capability requests can be manually uploaded by producers on the Producer Portal. You can upload a capability 
request from the Offline Device Management page. 

Task To upload a capability request for a device from the Offline Device Management page 

1. On the Offline Device Management page, for Upload type, select Generate license. 

2. Click Browse and locate the capability request on your local system. (The exact controls vary depending on 
the browser you are using.) 

3. Click Upload. 

The capability request is processed. 

After the capability request is processed, download the capability response and process it on your device. (See 
Generating a Capability Response.) In offline activation scenarios, for example, the producer communicates the 
capability response to the end user of a device that cannot connect directly to the Internet, and the end user 
applies it to their device to activate the capabilities to which they are entitled.

Uploading Synchronization History
Synchronization history can be manually uploaded by producers on the Producer Portal. You can upload 
synchronization history from the Offline Device Management page. 

Table 5-9 • 

Topic Description

Uploading a Capability Request 
from the Offline Device 
Management Page

Explains how to upload a capability request for a device from the Offline 
Device Management page. 

Uploading Synchronization 
History

Explains how to upload synchronization history from the Offline Device 
Management page. 
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Task To upload synchronization history 

1. On the Offline Device Management page, for Upload type, select Upload synchronization history. 

2. Click Browse and locate the sync history (.syncreq) files on your local system; up to 100 files per submission 
can be selected. (The exact controls vary depending on the browser you are using.) 

Important • All files uploaded as part of one submission must be located on the same license server. 

3. Click Upload. The sync history files are uploaded, device details are displayed, and a confirmation message is 
shown.

4. The application offers you a response file (sync acknowledgment) to download and process on your license 
server. 
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Managing Usage

Producers who use FlexNet Operations with FlexNet Usage Management and FlexNet Embedded licensing can 
create software and devices that support usage-based, pay-for-use and pay-for-overage models. The following 
topics cover the management of usage data and reporting in the Producer Portal. 

For information about creating license models that support usage-based licensing, see Administering License 
Models. For information about usage functionality in products and features, see Packaging Products. 

Table 6-1 • 

Topic Description

About Usage 
Management

Discusses usage management concepts in the following subsections: 

• Usage Management Concepts

• About Usage Models

• About Usage Reports

Viewing Usage Reports Explains how to show usage history reports for your product lines.

Listing Usage Models Shows how to list usage models. 

Uploading Usage Data Describes how to upload historical usage data for internal testing purposes. 
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About Usage Management
This section describes general concepts involved in working with FlexNet Usage Management in FlexNet 
Operations.

Usage Management Concepts
Software and devices that incorporate usage-based licensing make use of the same features and capability 
requests and responses as other FlexNet Embedded software and devices. This section discusses the use of 
features and capability requests and responses in the context of FlexNet Usage Management.

Features
The smallest unit for which usage can be captured is a feature. You define the feature or features that make up 
your products in FlexNet Operations, and your usage-capture code sends information about these features. In 
addition, feature-clipping code checks for the availability of certain features to determine a product’s 
functionality.

During execution, your capped-usage or feature-clipping code uses FlexNet Embedded functions that attempt to 
acquire a license. The FlexNet Embedded libraries validate such conditions as the feature not having expired. If 
the license acquisition succeeds, your code would then enable the corresponding capability.

Capability Requests and Responses
When your usage-capture code communicates with FlexNet Operations, the communications involve capability 
requests and capability responses. A capability request is generated by the client (either a client reporting usage 
or requesting features that it will acquire). The request data contains some combination of a host identifier, one 
or more desired features, and other optional data to pass to FlexNet Operations.

The hosted server instance then processes the request, reading the various identifiers, desired features, and 
custom data. If FlexNet Operations determines that the client requires a response, it generates a capability 
response. The response data contains current license rights available for the client. The capability response is 
then conveyed back to the client, which processes the response, after which the features in the response can be 
queried for the sake of detecting if a quota has been exceeded or for feature clipping (programmatically 
restricting access to features based on the capability response).

Your usage-capture code specifies one or more desired features, which represent features whose usage is being 
reported or features desired for the sake of feature clipping, in the capability request. 

Table 6-2 • 

Topics Description 

Usage Management 
Concepts

Discusses the way features, capability requests, and capability responses are 
used in software and devices that use usage-based licensing.

About Usage Models Describes usage models and how they are used to designate the statement 
interval and reset period (if any) for usage history reports.

About Usage Reports Covers the usage history reporting available in the Producer Portal: usage 
gauges, tables, timelines, and comparisons.
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Your code also specifies an operation in the capability request, which indicates whether it is simply reporting 
feature usage, or whether a response is expected. The “report” operation is used in uncapped-usage scenarios, 
when no response is needed; and the “request” operation is used in capped-usage and feature-clipping 
scenarios, where a response is needed. The request operation can also be used in untrusted environments to 
report uncapped usage to force a confirmation response from the server, ensuring that the usage has been 
reported. (There is also an “undo” operation, which enables recent information to be undone, in case of error or 
canceled usage.)

Hosted Servers
Your usage-capture clients send usage data to a FlexNet Embedded license server referred to in this guide as a 
hosted server. The hosted server can be a local license server or a license server instance in FlexNet Cloud 
Licensing Service that captures the metered usage data your usage-capture clients send. 

About Usage Models
Usage models designate the statement interval and reset period for usage-enabled products. 

Statement interval describes how usage history data is summarized. Usage models support monthly, quarterly, 
and yearly statements.

Reset period defines whether or not usage history data is reset. When the usage model includes no reset, usage 
counts accumulate over time and across reporting interval statements. When the usage model includes a reset 
period, usage counts that accumulate during the statement interval are reset monthly or yearly. 

Table 6-3 • 

Usage Model ID Description

1 Quarterly Statements (Reset yearly)

Usage history data is summarized by quarter in usage reports. Counts are accumulated 
across quarters but reset annually.

2 Quarterly Statements (No Reset)

Usage history data is summarized by quarter in usage reports. Counts are accumulated 
across quarters with no automatic reset.

3 Yearly Statements (Reset yearly)

Usage history data is summarized by year in usage reports. Counts are reset each year so 
that multi-year usage reports show only the usage for each individual year.

4 Yearly Statements (No Reset)

Usage history data is summarized by year in usage reports. Counts are accumulated across 
years with no automatic reset.

5 Monthly Statements (Reset monthly)

Usage history data is summarized by month in usage reports. Counts are reset each month 
so that multi-month usage reports show only the usage for each individual month.



Chapter 6 Managing Usage
About Usage Management

262 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

When you create or edit a product, you specify the usage model to identify how usage history data is summarized 
in usage reports, whether or not usage data is reset and, if so, how often.

Important • Products using the same feature must be configured with the same usage model per account. For an 
account, the usage model that is specified for a product containing a specific feature will be the usage model 
that is used for subsequent entitlements or products containing that specific feature.

Example:

• Product A (feature f1) and product B (features f1 and f2)

• Account C is first entitled to product A (feature f1) with usage model Monthly Statements (No Reset)

• Account C is then entitled to product B (features f1 and f2) with usage model Monthly Statements (Reset 
Monthly)

• Account C will use usage model Monthly Statements (No Reset) for both products A and B because they both 
contain feature f1 which was included in the first entitlement.

If Account C was first entitled to product B (features f1 and f2) with usage model Monthly Statements (Reset 
Monthly), this usage model would be used for both products/entitlements for the account.

About Usage Reports
FlexNet Operations enables you to view end users’ current usage data in the Producer Portal. Similarly, your 
enterprise customers can view their current usage data in Usage Management in the enterprise portal you set up.

The following types of reports are supported with respect to usage capture. Usage data can also be downloaded 
as a text file in CSV format. After selecting what usage data to display—as described in Viewing Usage Reports—
and selecting the desired usage period, you can select the type of graph in which to display the usage data.

Figure 6-1: Buttons for selecting the usage report type

These report type buttons correspond to Usage Gauges, Usage Tables, and Usage Timelines and Comparisons.

Usage Gauges
This type of graph shows usage data as a graphical gauge representing the percentage of usage compared to the 
overall entitled amount. The green region of the gauge indicates usage of none to 75 percent of the available 
count; the yellow region indicates 75 percent to 100 percent of the available count; and the red region indicates 
over 100 percent (overage) of the entitled amount.

6 Monthly Statements (No Reset)

Usage history data is summarized by month in usage reports. Counts are accumulated 
across months with no automatic reset.

Table 6-3 • 

Usage Model ID Description
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Figure 6-2: Usage gauge

Details of the usage information are displayed beneath the gauge.

Usage Tables
Usage information can also be displayed in a textual table.

Figure 6-3: Usage table

Usage Timelines and Comparisons
Usage information can also be displayed in an interactive Flash-based timeline. Commands in the upper left 
corner enable zooming in to different time periods, and you can click and drag the graph left and right to control 
the dates for which data are being displayed.
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Figure 6-4: Interactive usage timeline

A similar interactive option is the Compare Meters graph, which simultaneously displays multiple features’ usage 
information over the same period of time.

Viewing Usage Reports
Producers who use FlexNet Usage Management can view usage history reports in the Producer Portal. You first 
search for reports on your usage-enabled products by usage search criteria. The search results show matching 
usage reports primarily by the associated account ID. You can click the account ID for a particular report to view 
usage gauges (default), tables, and timelines for that account’s report.

Usage Search Criteria
The table below describes the usage search criteria available on the Usage Search page. 

Table 6-4 • 

Attribute Description

Account ID The ID of the customer account for which you want to see usage reports. 

Usage Threshold Specifies a minimum usage percentage for any usage meter. To see 
usage reports for accounts that meet or exceed fifty percent of their 
entitled counts, for example, set Usage Threshold to 50. To see only 
accounts that are at or over their entitled limits, set Usage Threshold to 
100. Only accounts for which at least one meter that meets or exceeds 
the specified threshold are included in the search results.
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Searching for Usage Reports
The following steps explain how to obtain usage reports for your customer accounts.

Task To view a usage report

1. In the Producer Portal, click Usage > Usage Search. The Producer Portal opens the Usage Search page. 

2. Specify search criteria for the usage reports you want to see. 

3. Click Search. The Producer Portal shows a list of usage reports that match your search criteria. 

4. Click the Account ID value for a report to see the usage report page for that account. 

The Producer Portal opens the View Usage for Account: <customer account> page. This page includes usage 
gauges, tables, and timelines for the designated product line and date. Click the report type buttons to switch 
between report types. 

This page also allows you to select different product lines and to alter the dates for which usage history data is 
shown. 

• Click the Product Family control to choose from the product families to which the current customer account 
is entitled. 

• Click the As of Date control to set a different date limit for the usage reports. 

Listing Usage Models
Producers who use FlexNet Usage Management can view available usage models in the Producer Portal. Usage 
models are selected when you create or edit a usage-enabled product. They mainly define the reporting interval 
for usage history reports. 

Task To list usage models

• Click Usage > List Usage Models. 

As of Date The date limit for usage reports. Reports that occur after the specified As 
of Date value are excluded from the search results.

Product Line The product line for which you want to see usage reports. Only reports 
that include usage history for products in the specified product line are 
included in the search results.

Meter Name The name of the meter (usually a feature name) for which you want to 
see usage reports. 

Table 6-4 • 

Attribute Description
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The Producer Portal opens the List Usage Models page. 

Uploading Usage Data
Mainly for internal testing, producers can upload raw usage data to the Producer Portal. This option allows you to 
see how usage data captured by your usage-enabled FlexNet Embedded clients is rendered in usage history 
reports without waiting for the clients to report data over long periods. 

To upload historical usage data, you must create a comma-separated value file in which each line follows the 
syntax shown below: 

ISO 8601 date,count,feature name,activation code[,requestor ID,acquisition ID,key=value, ...]

Additional file content and format requirements appear on the Upload Historical Usage page. 

Task To upload usage data

1. In the Producer Portal, click Usage > Upload Historical Usage. The Producer Portal opens the Upload 
Historical Usage page. 

2. On the Upload Historical Usage page, use the browser controls to specify a CSV file on your system to upload. 
(The exact controls vary in different web browsers.)

3. Click Upload.

The Producer Portal uploads the usage data. 
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Managing Accounts and Users

You can manage accounts and users using the commands in the Accounts & Users menu. See the following 
sections for instructions on account and user management: 

The figure below depicts relationships among accounts, sub-accounts, and users. 

Table 7-1 • 

Topic Description

Managing Users Manage users and roles (sets of permissions) of an account.

Managing 
Accounts

Manage accounts and contacts.

Account Health View account health parameters including overall health, renewal health, and 
consumption.
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Managing Users
This section is organized into the following topics.

Table 7-2 • Managing Users

Topic Description

About Users Discusses users as they exist in FlexNet Operations. 

FlexNet Operations 
Default Users

Describes the built-in, default users included with FlexNet Operations. 

Managing Your Profile Explains how to edit your profile and how to change your password. 

Browsing Users Shows how to browse existing users in the Producer Portal.

Creating a User Explains how to create new users manually and how to import a new user from a 
directory service.

Editing a User Covers editing existing users and resetting a user password.

Linking Product Lines to 
User Accounts

Describes how to link user accounts to product lines. 

Deleting a User Shows how to delete users from FlexNet Operations.
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About Users 
A user can belong to one of four types. On the Manage Users page, each of these types has a tab as described 
below.

• Customer Users – End users of a producer’s software or device.

• Producer Users – Software producer or intelligent device manufacturer users.

• Partner Users – Distribution partner users like wholesalers, distributors, resellers, and retailers.

• Self Registered Users – Users who self-register by logging in to the End-User Portal with an entitlement ID or 
activation ID and set up their own user account. Optionally, users can select to be associated with an existing 
Self-Registered account by providing the account ID upon self-registration, instead of creating a new 
account.

To log in to FlexNet Operations, a user must provide a user name and password. Revenera creates the initial user 
account for a producer’s FlexNet Operations system administrator. Then that system administrator creates any 
additional users required for the producer’s account and for the producer’s customers (end users). 

Beyond the ability to simply log in, the activities a user can perform are based on the permissions that user has 
been granted. However, permissions are not assigned to users directly. Instead, permissions are grouped into 
roles and FlexNet Operations users are assigned one or more roles. FlexNet Operations users belong to either a 
producer account or a customer account. Users who self-register through the End-User Portal belong to the 
accounts for Portal Accounts. If a self-registered user supplies a company name while registering, a new account 
is created for the new company name and the user assigned to it.

Some user names are intended to be shared logins. A shared login is intended as a proxy user, not as a user that 
logs in directly. For example, when any customer logs in to the End-User Portal with an activation ID, a shared 
login, portaluser, logs in on behalf of the customer. Shared logins are indicated on the Users page with an icon. 
They do not appear in the Logged-In Users page, their last login date is not recorded, nor are they deactivated 
automatically after a number of bad logins. The profile of a shared login cannot be edited. 

Both shared and non-shared users can log in to FlexNet Operations from multiple browsers simultaneously. 

Deactivating and 
Reactivating a User

Explains how to set a user’s status to active or inactive.

Working with Roles and 
Permissions

Includes a discussion about the use of roles and permissions as well as instructions 
about adding, editing, activating and deactivating, and deleting roles.

Table 7-2 • Managing Users

Topic Description
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FlexNet Operations Default Users
By default, the following users are provided with FlexNet Operations:

Managing Your Profile
The following topics cover how to manage your own user profile and password settings.

Editing Your User Profile
You can edit your profile using the User menu. (The User menu is near the System menu at the top of the Producer 
Portal page. It shows the user name of the current user.) 

If you are not a shared user, you can edit your user profile. A shared user can only view the profile. 

Table 7-3 • FlexNet Operations Users

User Name Description

admin Non-shared login with the System Administrator role. This user cannot be made 
inactive. 

portaluser Shared login for users of the End-User Portal who log in with entitlement ID or 
activation ID. This user is assigned the Portal User role. 

trustedstorageuser Shared login that does not appear in any of the user management pages. It is 
displayed in the fulfillment history as the user who performs trusted 
transactions. 

legacyuser Shared login that does not appear in any of the user management pages. It is 
displayed in the fulfillment history as the user who imported legacy fulfillments 
from another system.

Table 7-4 • 

Topic Description

Editing Your User Profile Discusses how to change your user profile settings.

Changing Your FlexNet 
Password

Explains how to change your password.

If You Forget Your 
FlexNet Password

Explains how to follow the password recovery procedure when you forget your 
password. 
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Task To view your profile or edit your profile

1. In the User menu, click your user name and then click My Profile. 

2. Edit any of the following fields: 

• First Name

• Last Name 

• Email Address

• Receive Email Messages (No, Yes) 

• Old Password

• New Password

• Confirm Password

• Secret Question and Secret Answer 

• Phone Number and Fax Number

• Street

• City

• State/Province

• Zip/Postal Code

• Country

• Time Zone 

Your user name, accounts, and whether the user name is a Shared Login cannot be edited through the user 
profile. 

Note • The roles assigned to you are not displayed in the Edit Profile page.

3. Click Save. 

Note • To change your password, enter the old password; then enter and confirm the new password. No email 
message is sent reminding you of your new password. The next time you log in, enter your new password. 

Changing Your FlexNet Password
The Change Password page appears when you enter your user name and a system-generated FlexNet Operations 
password the first time you log in to FlexNet Operations. Use this page to change your system-assigned password 
to one that you choose. 
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Task To change your FlexNet Operations password

1. Enter your old password, the system-generated password that you entered when you logged in. 

2. Enter and confirm a new password of your choice. 

3. Select a secret question and the answer in case you forget your password. You must define a secret question 
and answer to reset your password yourself if you forget it. 

4. Click Continue to complete the login process.

Note • You can change your password or add a secret question and answer at a later time by editing your user 
profile.

If You Forget Your FlexNet Password
If you forget your password in the future and have specified a secret question and its answer, you can have your 
password sent to you by email.

Task To have your FlexNet Operations password sent to you by email

1. On the FlexNet Operations login page, click Forgot your password?

2. On the Password Reset page, enter your FlexNet Operations user ID and click Continue. 

If FlexNet Operations recognizes your account, it displays your secret question and prompts you to enter the 
answer you specified when the account was created. This is required.

3. Enter the answer to your secret question and click Continue.

If you correctly answer the security question, FlexNet Operations sends an email containing a system-generated 
password to your email address. When you log in with that password, FlexNet Operations prompts you to change 
your password.

Note • If you did not specify a secret question and answer, you must contact the FlexNet Operations administrator 
to have a new password sent to you.

Browsing Users
FlexNet Operations users are displayed in the Users page. Users assigned roles with the View Users, View and 
Manage Users, View and Manage Customer Users, or View and Manage Partner Users permissions can view 
users in the Producer Portal.
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Task To browse existing users

• Click Accounts & Users > All Users. 

The Producer Portal shows the Manage User page. On the Manage Users page, you can view the following 
information: 

• Whether a user is a shared user. (Shared users are marked with an icon showing several people.) 

• Display Name: Full name of user.

• User Name: Login name of the user.

• Email Address: The user’s email address.

• Type: Select either User or Contact. A contact is a user account that cannot log in, and is maintained for 
account contact purposes.

• Account: All accounts to which the user belongs.

 Click on a user to view user details, edit the user, view the transaction history for the user account, and so forth. 

Creating a User
FlexNet Operations users appear in the Users page of FlexNet Operations. 

Note • To perform tasks using FlexNet Operations, a user is required to have one or more permissions that are 
defined by the application. Permissions are not assigned to users directly. Instead permissions are grouped into 
roles and FlexNet Operations users are assigned one or more roles. Users assigned a role with View and Manage 
Users permission can view, add, and edit all types of users. Users assigned roles with the View and Manage 
Customer Users permission or View and Manage Partner Users permission can view all users but can add and 
edit only  customer users or partner users, respectively.

Task To add a FlexNet Operations user

1. Click Accounts & Users > Create User. This link opens the Create a User page. 

2. On the Create a User page, select FlexNet User, and click Next.

3. In User Details 

a. End-User Portal Access?: A user who can log in is able to access FlexNet Operations. If not, the user 
account is maintained for contact purposes only. Such users are sometimes referred to as contacts. 

b. User Name: Specify a login name for the user. 

c. Time Zone: If the user can log in, select the user’s time zone from the drop-down list.

d. Status: Leave the user status set to Active. (The records of an Inactive user remain on file, but the user 
no longer has access to FlexNet Operations.) 
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Note • Multiple entries of an incorrect password automatically set the user’s status to Inactive. The user 
can be reactivated by an administrator after the user’s legitimacy is confirmed.

e. Shared Login: Select Shared Login if this user account is to be shared by multiple people. A shared login 
can be useful for setting up proxy or group user accounts, such as a user who submits web service 
requests.

4. In Contact Details 

a. Enter the First Name and Last Name of the user (required). 

b. Enter the Email Address of the user (required). If this is a shared login, specify the email address of a 
FlexNet Operations administrator in this field.  

c. Opt-in to receive email: Select whether the user receives marketing email messages.

d. Expiring Entitlements Email: Select whether the user receives renewal reminders about expiring and 
expired entitlements (only for customer users). 

e. Enter the user’s contact information: Phone Number, Fax Number, Street, City, State/Province, ZIP/
Postal Code, and Country.

f. Select the Locale of the user. This setting is applied when using the option View As End User (see View 
End-User Portal as End-User). This setting will be overwritten by the default locale or the locale explicitly 
selected by the user when logging in to the End-User Portal. In addition, the Locale setting specifies the 
language of some of the emails sent by FlexNet Operations (such as the Reset Password email).

5. Link the user to one or more accounts. Each user must be linked to one or more accounts. If the user must 
log in to the Producer Portal (an internal user), link the user account with a producer account. If the user 
must log in to the End-User Portal, either as a customer or a partner, link the user account to a customer or 
partner account. A user can belong to multiple accounts but all of those accounts must be of the same type. 
After a user is saved as a member of a customer account, the account can be changed only to another 
customer account. 

To link users to an account, click Link Existing Accounts to link existing accounts to the user. Select the 
accounts you want to link and click OK.

Note • When linking a user to an account, an optional expiration date can be set if the Enable User Expiration 
is enabled in the system configuration. See Configuring System Settings for more information. 

6. Optionally, for customer users, link the user to one or more product lines now, or product lines can be linked 
later. See Linking Product Lines to User Accounts. 

Note • Linking of product lines is available only when product lines functionality is enabled in the system 
configuration page (System > Configure > FlexNet Operations). See Managing Product Lines for details.

7. Click Save.

When a new user account is saved, an email containing a system-generated password and login instructions is 
sent to the user’s email address. To log in the first time, the user logs in using the system-generated password 
and is immediately prompted to change the password. 
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Editing a User
Users assigned a role with the View and Manage Users permission can view, add, and edit all types of users. 
Users assigned roles with the View and Manage Customer Users permission or View and Manage Partner Users 
permission can edit only customer users or partner users, respectively. The Create a User page displays the date 
the user was created and last logged in (if a non-shared user) and is also used to reset the user’s password. 

Edit User Information
Use the following instructions to modify a user’s details, contact information, or account. Remember: To locate a 
difficult to find user, use the search feature on the Manage Users page. 

Task To edit an existing FlexNet Operations user

1. Click Accounts & Users > All Users. This link opens the Manage Users page. 

2. On the Manage Users page, locate the user you want to edit. Note: Users can appear on different tabs. Be 
sure you are looking at the right tab for the user. 

3. In the Users list, click a user name to view the Create a User page. 

4. Edit the values of any of the editable fields. Email address is never editable. At least one account must be 
linked to the user. If the user must log in to the End-User Portal or Producer Portal, at least one role must be 
assigned. 

5. Click Save to save your changes to the user. 

Reset a Password
Use the following steps to reset the password of a user. 

Task To reset a user’s password

1. Click Accounts & Users > All Users. This link opens the Manage Users page. 

2. On the Manage Users page, locate the user you want to edit. Note: Users can appear on different tabs. Be 
sure you are looking at the right tab for the user. 

3. In the Users list, click a user name to view the Create a User page. 

4. On the Create a User page, click Reset Password. 

If the user is not shared, an email is sent to the user with a new system-generated password. The user logs in 
with the system-generated password and is immediately prompted to change the password.

If the user is shared, the email containing a system-generated password is sent to a FlexNet Operations 
administrator (if you specified the administrator’s email address when the user was created). The administrator 
must log in to FlexNet Operations with the system-generated password, then change the password and keep a 
record of it. The administrator must send this new password to all users of the shared login.
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View End-User Portal as End-User
Users assigned a role with the View As End User permission can access the End-User Portal as a selected end-
user in view-only mode. Any data that is updated when acting as end-user does not persist.

Task To view the End-User Portal as end-user

1. Click Accounts & Users > All Users. This link opens the Manage Users page. 

2. On the Manage Users page, locate the user you want to act as. Note: Users can appear on different tabs. Be 
sure you are looking at the right tab for the user. 

3. In the Users list, click a user name to view the Create a User page.

4. On the Create a User page, click View As End User.

Set or Clear an Expiration Date
Use the following instructions to control how long a user is linked to an account. 

Version • This option is only available if the Enable User Expiration field is enabled in the System Configuration. 
See Configuring System Settings for more information.

Task To set or clear the expiry date for a user

1. Click Accounts & Users > All Users. This link opens the Manage Users page.

2. On the Manage Users page, locate the user you want to edit. Note: Users can appear on different tabs. Be 
sure you are looking at the right tab for the user. 

3. In the Users list, click a user name to view the Create a User page. 

4. Under Accounts, find the account you want to limit the user’s access to.

5. Under Expiry date for an Account, either enter a date to set an expiration date or clear the field to remove an 
expiration date. To disable the expiration date for all users, unselect the Enable User Expiration in the System 
Configuration. If the expiration date is cleared or disabled, a user’s access to the account does not expire. 
See Configuring System Settings for more information. 

Linking Product Lines to User Accounts
When the product lines functionality (with visibility restrictions) is enabled, FlexNet Operations filters what 
customer users see based on the product lines linked to the users’ accounts. Only line items that include 
products in product lines to which the user account is linked are visible. 

Important • A user account cannot be linked to product lines until the user has been linked to accounts.

The required product lines functionality can be enabled in System > Configure > FlexNet Operations > 
Enable Product Lines for Products, Users, and Accounts. (See Managing Product Lines for details.)
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Task To link product lines to a user account

1. On the Create a User page, click Link Product Lines. The Select Product Lines for the User page opens in a 
pop-up window.

2. On the Select Product Lines for the User page, select the product lines you want to link, and click OK. 

Product lines are linked to the current user account when you click OK. It is only necessary to save the user 
account if you have made other changes to the user.

Task To remove product lines from a user account

1. On the Create a User page, select the product lines you want to remove and click Remove Product Lines.

2. Click OK to confirm the removal.

Deleting a User
You can delete users from FlexNet Operations if users have no dependencies (such as, for example, line items, 
entitlements, or alert subscriptions). Deleted users are removed permanently from the database. If you want to 
keep the user in the database but restrict access, consider deactivating the user instead.

You cannot permanently delete a user who has dependencies. However, you can perform a force delete by 
confirming that you want to remove a user, when prompted by a dialog. The force delete ensures that the user 
record and its dependencies are retained but placed in an inactive state. In this state, all fields on the user record 
are rendered obsolete, login-credential resets for the user are prohibited, and no further access to the user 
record is allowed.

Note that his option applies only to the forced deletion of non-producer users with dependencies.

Task To delete a user

1. Click Accounts & Users > All Users. The Manage Users page opens. 

2. On the Manage Users page, select the user you want to delete. 

3. Click Delete. 

4. Click OK to confirm deletion. 

5. If the user has dependencies, click Delete to confirm the force delete.

Deactivating and Reactivating a User 
User status is displayed in the Create a User page. Both shared and non-shared users can be deactivated 
manually or automatically. A non-shared user can be reactivated only manually; a shared user can be reactivated 
manually or automatically.
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Users assigned a role with the View and Manage Users permission can deactivate and reactivate all types of 
users manually. Users assigned roles with the View and Manage Customer Users permission or View and Manage 
Partner Users permission can deactivate and reactivate only customer users or partner users, respectively. 

Task To deactivate a user manually

1. Click Accounts & Users > All Users. The Manage Users page opens. 

2. In the Users list, click a user name to deactivate. 

3. In the Status drop-down list, select Inactive. 

4. Click Save. 

A user is deactivated automatically after more incorrect consecutive login attempts than allowed. For non-shared 
users, the default number of consecutive failed authentications is 3; for shared users, the default number of 
consecutive failed authentications is 6. This number can be configured in the FlexNet Platform Server 
configuration (setting Consecutive Failed Authentications). When a user is deactivated automatically, the User 
Deactivated alert is triggered (if that alert is configured).

A deactivated non-shared user must be reactivated manually. 

Task To reactivate a user manually

1. Click Accounts & Users > All Users. The Manage Users page opens. 

2. In the Users list, click a user name to reactivate. 

3. In the Status drop-down list, select Active. 

4. Click Save. 

A reactivated user is informed by email. Reactivation does not affect a user’s password. If the reactivated user is 
shared, an administrator receives the email stating that the user is reactivated.

Automatically Reactivating Shared Users
When a shared user account is deactivated due to too many failed consecutive login attempts, it can be 
automatically reactivated after a specified time. You can set this time in the FlexNet Platform Server configuration 
(setting Minutes for re-enabling a shared login after deactivation). The default is 3 minutes.

Reactivating Using Google reCAPTCHA
The Google reCAPTCHA mechanism enables a shared user whose account is locked (due to too many consecutive 
failed login attempts) to have their account reactivated before the timeout (set in the FlexNet Platform Server 
configuration) has elapsed. In this case, the login screen of the End-User Portal shows the “I’m not a robot” check 
box which enables the shared user to validate their account. To use Google reCAPTCHA, you need to provide the 
site key and the secret key in the FlexNet Platform Server configuration. 

Working with Roles and Permissions
You can administer roles and permissions for user access.
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Important • Regarding FlexNet Operations roles and permissions, keep in mind the following:

• Permissions do not have hierarchies. For one user to manage another user, the managing user must have at least all 
of the permissions of the user they want to manage.

• A permission can only be assigned to a user if that assignee has that permission themselves.

Assigning a Role to a User
You can assign a role to a user on the user’s Create a User page. These assignments are made per account in the 
Account table near the end of the page. 

Note • Not all users have sufficient permissions to assign or remove roles. 

Table 7-5 • Working with Roles and Permissions

Topic Description

Assigning a Role to a 
User

Shows how to assign one or more roles to an existing user.

Browsing Roles Explains how to browse roles from the Administer Roles and Permissions page.

Browsing Users with a 
Role

Describes how to view users who are assigned a particular role.

Adding a Role Shows how to add a user-defined role. 

Editing a Role Describes how to edit an existing role. 

Deleting a Role Explains how to delete a role.

Deactivating and 
Reactivating a Role

Shows how to manually deactivate or reactivate a role.

FlexNet Operations 
Permissions

Describes FlexNet Operations permissions. Permissions are grouped into roles.

FlexNet Operations 
Roles

Describes FlexNet Operations roles. Permissions are grouped into roles. Roles are 
assigned to user accounts.
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Task To assign a role to a user

1. On the Create a User page, select the check boxes for the roles you want to assign to the current user. The 
user must have at least one role assigned for each account to which they are linked. (Possible roles appear in 
the Roles column of the Accounts table—one set per account.)

2. Click Save. 

The Producer Portal saves the role modifications and refreshes the Create a User page.

Task To remove a role from a user

1. On the Create a User page, select the check boxes for the roles you want to remove from the current user. 

2. Click Save. 

The Producer Portal saves the role modifications and refreshes the Create a User page.

Browsing Roles 
Roles for FlexNet Operations are displayed in the Roles page. Users assigned a role with the View Roles or View 
and Manage Roles permission can view a summary of roles. 

Task To view a summary of existing roles

1. Click Accounts & Users > All Roles. 

2. In the Roles page, you can view the following information: 

• Role Name: Name of the role. 

• Status: Whether the role is active or inactive and whether it is a system-defined role. 

• Mapped Users: Shows links to users who are assigned to this role. 

Browsing Users with a Role 
It is possible to view all of the users who have been assigned a particular role. Users assigned a role with the 
View Users and View Roles permissions can view users with a particular role. 

Task To view the users who have been a assigned a particular role

1. Click Accounts & Users > All Roles. 

2. To see the users with a specific role, click the Users link for that role under Mapped Users. 

3. In the Users for Role page, you can view the list of users who are assigned this role. In addition, you can 
determine whether a user is shared. Shared users are marked with an icon showing several people. The 
following summary information is displayed.
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• User Name: Login name of the user (typically, an email address). 

• Display Name: Full name of the user. 

• Date Created: Date the user was created. 

• Date of Last Login: Date of last login by the user; this date is not recorded for shared users. 

• Status: Whether the user is active or inactive. 

Adding a Role 
To perform tasks using FlexNet Operations, a user must have the appropriate permissions defined by the 
application. Permissions are not assigned to users directly; permissions are grouped into roles and FlexNet 
Operations users are assigned one or more roles. 

Roles are either system-defined or user-defined. System-defined roles cannot be edited by any users; users 
assigned a role with the View and Manage Roles permission can view, add, and edit user-defined roles. 

Task To add a user-defined role

1. Click Accounts & Users > All Roles. 

2. Click Add Role. 

3. In the Add Role page: 

a. Enter the Name of the role, for example, User Management Administrator. A role is usually given the 
name of a type of user. 

b. Enter the Description of the role. 

c. In Type, select Producer if the role is intended for producer users, or Portal if the role is intended for End-
User Portal users. 

d. Leave the Status of the role Active. 

e. Assign one or more permissions to the role. 

4. Click Save. 

5. Verify in the Roles page that the role was added. 

Editing a Role 
Roles are either system-defined or user-defined. System-defined roles cannot be edited; users assigned a role 
with the View and Manage Roles permission can view, add, and edit user-defined roles.

Task To edit an existing role

1. Click Accounts & users > All Roles. 

2. In the Roles table, click a role name to view the Edit Role page. 
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3. Edit the values of any of the editable fields. At least one permission must be assigned to a role. 

4. Click Save to save your changes to the role. 

Deleting a Role 
Roles can be deleted from FlexNet Operations.

Task To delete an existing role

1. Click Accounts & Users > All Roles. 

2. In the Roles table, click the name of the role you want to delete. 

3. Click Delete. 

4. Click OK to confirm deletion. 

Deactivating and Reactivating a Role 
A role can be deactivated or reactivated manually. Users assigned a role with the View and Manage Roles 
permission can deactivate and reactivate roles. 

Task To deactivate or activate an existing role

1. Click Accounts & Users > All Roles. 

2. In the Roles table, click a role name to view the Edit Role page. 

3. Set the Status to Inactive or Active. 

4. Click Save to save your changes to the role. 

FlexNet Operations Permissions
Permissions are grouped into roles, and roles are assigned to users. The following permissions are available in 
FlexNet Operations: 

• Alert Management

• System Administration

• Operations Feature Bundles

• Operations License Models

• Operations Entitlements (Producer Portal)

• Accounts (End-User Portal)

• Trusted Storage Licensing (End-User Portal)

• Operations Web Services
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• Operations Export Import

• User Management

• Account Management

• Operations Features

• Operations Products, Suites, and Maintenance

• Operations Part Numbers (Producer Portal)

• Operations License Management (Producer Portal)

• Operations Policies

• Operations Trusted Storage Licensing (Producer Portal)

• Reporting

• Child Account (End-User Portal)

• License Technologies

• FlexNet Embedded

• FlexNet Embedded (End-User Portal)

• Customer Growth

• Usage

• Updates

• Producer User Roles

• End-User Customer Roles

Alert Management
The following Alert Management permissions are available: 

Table 7-6 • Alert Management Permissions

Permission Description

View and Subscribe Alerts Allows a user to browse available alerts and subscribe to them. 

View and Manage Alert 
Configurations

Allows administrator to configure alerts and access the alert cleanup service. 
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System Administration
The following System Administration permissions are available:

Operations Feature Bundles
The following FlexNet Operations Feature Bundles permissions are available:

Table 7-7 • System Administration Permissions

Permission Description

View System Information View system information displayed in the System Information page (click 
System > About Advanced Lifecycle Management Module). 

View and Manage 
Configurations 

Configure the database connection, the behavior of the FlexNet Platform Server, 
the behavior of the Producer Portal, and the behavior of different portions of 
FlexNet Operations. Access to all functionality of the System Configuration page 
(click System > Configure). 

View and Manage Custom 
Content

Create and maintain custom content, including the ability to enable/disable its 
visibility on the End-User Portal.

View and Manage Email 
Templates

Maintain email templates, including enabling/disabling and creating variations.

Create Custom Attribute Create and edit generic custom attributes.

Merge Entitlements from 
Self-Registered Account to 
Customer Account

Merge data (entitlements and users) from self-registered account to customer 
accounts.

Table 7-8 • Operations Feature Bundles Permissions

Permission Description

View Feature Bundles View feature bundles in read-only mode. 

Update Feature Bundles Edit feature bundles. 

Important • If Update Feature Bundles is assigned to a role, also assign View 
Feature Bundles. 

Create Feature Bundles Add feature bundles. 

Important • If Create Feature Bundles is assigned to a role, also assign Update 
Feature Bundles.
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Operations License Models
The following FlexNet Operations License Models permissions are available:

Change Feature Bundle 
State 

Change the state of feature bundles, such as deploying a feature bundle. 

Important • If Change Feature Bundle State is assigned to a role, also assign 
Update Feature Bundles.

Delete Feature Bundles Delete feature bundles. 

Important • If Delete Feature Bundles is assigned to a role, also assign View 
Feature Bundles.

Table 7-9 • Operations License Models Permissions

Permission Description

View License Models View license models in read-only mode.

Create License Models Add license models. 

Important • If Create License Models is assigned to a role, also assign View 
License Models.

Update License Models Edit license models. 

Important • If Update License Models is assigned to a role, also assign View 
License Models. 

Delete License Models Delete license models. 

Important • If Delete License Models is assigned to a role, also assign View 
License Models.

Table 7-8 • Operations Feature Bundles Permissions

Permission Description
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Operations Entitlements (Producer Portal)
The following FlexNet Operations Entitlements permissions are available: 

Change License Model 
State 

Change the state of license models. 

Important • If Change License Model State is assigned to a role, also assign 
Update License Models.

Table 7-10 • Operations Entitlements (Producer Portal) Permissions

Permission Description

View Entitlements View entitlements in read-only mode. 

Update Entitlements Edit entitlements. This includes changing any attributes of the entitlement, 
adding line items to the entitlement, upgrading an entitlement, renewing an 
entitlement, merging entitlements and fulfillments, and upselling an 
entitlement. 

Important • If Update Entitlements is assigned to a role, also assign View 
Entitlements. 

Upsell Entitlements Upsell entitlements. 

Important • If Upsell Entitlements is assigned to a role, also assign Update 
Entitlements.

Upgrade Entitlements Upgrade entitlements. 

Important • If Upgrade Entitlements is assigned to a role, also assign Update 
Entitlements.

Renew Entitlements Renew entitlements. 

Important • If Renew Entitlements is assigned to a role, also assign Update 
Entitlements.

Table 7-9 • Operations License Models Permissions

Permission Description
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Accounts (End-User Portal)
The following End-User Portal account permissions are available:

Create Entitlements Add entitlements. 

Important • If Create Entitlements is assigned to a role, also assign Update 
Entitlements. 

Change Entitlement State Change the state of entitlements. 

Important • If Change Entitlement State is assigned to a role, also assign 
Update Entitlements. 

Delete Entitlements Delete entitlements. 

Important • If Delete Entitlements is assigned to a role, also assign View 
Entitlements. 

Edit Sent Emails Allows email content to be updated after the message has been sent. Used to 
correct errors.

Edit Unsent Emails Allows the user to copy an email, and edit email content and distribution list.

Create Email Notifications Send email to users entitled to download packages or files.

Queue Email Allows the user to schedule email delivery after approving the message 
content.

Table 7-11 • Accounts (End-User Portal) Permissions

Permission Description

View Entitlements View entitlements for user’s accounts in read-only mode.

Table 7-10 • Operations Entitlements (Producer Portal) Permissions

Permission Description
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Generate Licenses Generate a certificate license through the End-User Portal. 

Important • If Generate Licenses is assigned to a role, also assign View 
Entitlements.

For FlexNet Embedded, when Generate Licenses permission is assigned to a 
role, an end user can map add-ons to a device. 

Rehost Rehost a certificate license through the End-User Portal. 

Important • If Rehost is assigned to a role, also assign Generate Licenses.

Repair Repair a certificate license through the End-User Portal. 

Important • If Repair is assigned to a role, also assign Generate Licenses.

Return Return a certificate license through the End-User Portal. 

Important • If Return is assigned to a role, also assign Generate Licenses.

For FlexNet Embedded, when Return permission is assigned to a role, an end 
user can remove add-ons from a device. 

Manage Users Manage users through the End-User Portal. 

Important • This permission does not work for external domain (LDAP) users. 
For LDAP users, assign the separate, Manage Accounts and Users by Domain 
Users permission instead. 

Manage Accounts Manage accounts through the End-User Portal. 

Important • This permission does not work for external domain (LDAP) users. 
For LDAP users, assign the separate, Manage Accounts and Users by Domain 
Users permission instead. 

View Licenses View licenses for a user’s accounts in read-only mode.

Transfer Line Items Transfer entitlement line items through the End-User Portal.

Table 7-11 • Accounts (End-User Portal) Permissions

Permission Description
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Trusted Storage Licensing (End-User Portal)
The following End-User Portal trusted storage licensing permissions are available:

View Devices View devices for a user’s accounts in read-only mode. 

Split Line Items or Bulk 
Entitlements

Split line items or bulk entitlements through the End-User Portal. 

View Accounts View accounts in read-only mode. 

View Users View users in read-only mode. 

Transfer Hosts/Move 
Devices

Transfer hosts or move devices through the End-User Portal. 

Get Downloads Get downloads through the End-User Portal. 

View Expiring Entitlements View the Expiring Entitlements page, subscribe to renewal reminders, receive 
Renewal Reminder email messages. The View Expiring Entitlements covers both 
expiring entitlement and expired entitlement features. 

Table 7-12 • Trusted Storage Licensing (End-User Portal) Permissions

Permission Description

Short Code Activation Enable short code activation in End-User Portal.

Manual Activation Allow manual activation of trusted storage rights in End-User Portal.

Manual Return and Repair Allow manual return and repair of trusted storage rights in End-User Portal.

Short Code Return and 
Repair 

Allow short code return and repair of trusted storage rights in End-User Portal. 

Table 7-11 • Accounts (End-User Portal) Permissions

Permission Description
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Operations Web Services
The following FlexNet Operations Web Services permission is available:

Operations Export Import
The following FlexNet Operations Export Import permission is available: 

User Management 
The following User Management permissions are available:

Table 7-13 • Operations Web Services Permissions

Permission Description 

Execute Web Services The authenticated Web services user must have this permission to perform any 
FlexNet Operations task through the public Web services. 

Important • In addition to this permission, the user must have task-specific 
permissions as well. 

Table 7-14 • Operations Export Import Permissions

Permission Description 

Export and Import This permission allows the user to import legacy fulfillments using the 
Importing and Exporting Entities page. For more information about how to 
export fulfillments from a previous version of FlexNet Operations and import 
them into this version, refer to Importing and Exporting Entities. 

It also enables producers to control user access to data export options for a 
FlexNet Operations entity to prevent inexperienced users from exporting large 
amounts of data and negatively impacting system performance or causing an 
outage. Users without Export and Import permission see only data export 
options with low impact, such as Selected Items, on an entity’s Export drop-
down menu. Users with Export and Import permission see the complete list of 
data export options, including those with high impact, such as All Items and 
Data Import Template.

Table 7-15 • User Management Permissions

Permission Description

View Users View the list of users. 
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View and Manage Users View, add, and edit all types of users (customer users, producer users, partner 
users, and self-registered users). Reset a user’s password. Access to all 
functionality of the Manage Users page. 

Important • If View and Manage Users is assigned to a role, the role 
automatically also has the permissions defined in View and Manage Customer 
Users and View and Manage Partner Users.

View Roles View the list of users and view the definition of a role in read-only mode. 

View and Manage Roles View, add, and edit roles. Access to all functionality of the Administer Roles 
pages.

View Logged-In Users View the list of logged in users in the system. 

View Domains View the list of user domains and view the configuration of a domain in read-
only mode.

View and Manage Domains View, add, and Manage Users domains. Access to all functionality of the 
Administer Domains pages.

View As End User Allows the producer to act as the end user in view-only mode. The end-user role 
remains unchanged, but updated data does not persist.

View and Manage 
Customer Users

View, add, and edit customer users. Reset a customer user’s password. Access 
to all functionality of the Customer Users tab on the Manage Users page. 

Important • If you want to only assign permissions to view and manage 
customer users (but not producer users), do not assign View and Manage Users 
as well as  View and Manage Customer Users.

View and Manage Partner 
Users

View, add, and edit partner users. Reset a partner user’s password. Access to all 
functionality of the Partner Users tab on the Manage Users  page. 

Important • If you want to only assign permissions to view and manage partner 
users (but not producer users), do not assign View and Manage Users as well as 
View and Manage Partner Users.

Table 7-15 • User Management Permissions

Permission Description



Chapter 7 Managing Accounts and Users
Managing Users

292 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Account Management 
The following Account Management permissions are available:

Operations Features
The following FlexNet Operations Features permissions are available:

Table 7-16 • Account Management Permissions

Permission Description

View Accounts View the list of accounts and view an account and its contacts in read-only 
mode. 

View and Manage Accounts View, add, and edit accounts and their contacts. Access to all functionality of 
the Accounts pages. 

Table 7-17 • Operations Features Permissions

Permission Description

View Features View features in read-only mode. Features are the bottom level in the product 
hierarchy.

Update Features Edit features. 

Important • If Update Features is assigned to a role, also assign View Features.

Create Features Add new features. 

Important • If Create Features is assigned to a role, also assign Update 
Features. 

Change Feature State Change the state of features, such as deploying a feature. 

Important • If Change Feature State is assigned to a role, also assign Update 
Features.

Delete Features Delete features. 

Important • If Delete Features is assigned to a role, also assign View Features. 
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Operations Products, Suites, and Maintenance
The following FlexNet Operations Product, Suite, and Maintenance permissions are available:

Set Feature Override View and set the following license strings on an individual feature, overriding 
the license string values specified for a license model: Vendor String, Notice, 
and Serial Number. To see these fields, the FlexNet Operations license file must 
contain the FlexNet_Ops.FeatureOverride feature. 

Table 7-18 • Operations Products, Suites, and Maintenance Permissions

Permission Description

View Products, Suites, and 
Maintenance 

View products, suites, and maintenance in read-only mode. 

Update Products, Suites, 
and Maintenance 

Edit products, suites, and maintenance. 

Important • If Update Products, Suites, and Maintenance is assigned to a role, 
also assign View Products, Suites, and Maintenance. 

Create Products, Suites, 
and Maintenance 

Add products, suites, and maintenance. 

Important • If Create Products, Suites, and Maintenance is assigned to a role, 
also assign Update Products, Suites, and Maintenance.

Change Products, Suites, 
and Maintenance State 

Change the state of products, suites, and maintenance. 

Important • If Create Products, Suites, and Maintenance is assigned to a role, 
also assign Update Products, Suites, and Maintenance.

Delete Products, Suites, 
and Maintenance 

Delete products, suites, and maintenance. 

Important • If Delete Products, Suites, and Maintenance is assigned to a role, 
also assign View Products, Suites, and Maintenance.

Table 7-17 • Operations Features Permissions

Permission Description
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Operations Part Numbers (Producer Portal)
The following FlexNet Operations Part Numbers permission is available:

Assign Product Lines Link product lines to user accounts in a customer account. (The FlexNet 
Operations administrator must enable product lines functionality in system 
configuration settings.) This permission is provided only to accounts with the 
administrator or portal administrator user roles by default. 

Permission to link product lines to user accounts can be granted to other user 
accounts by an administrator. In all cases, a user with this permission can 
assign only those product lines to which he or she is currently linked.  

Note • The ability to map products to product lines operates independently from 
the Assign Product Lines permission. 

Delete File Images Remove the physical file; only the metadata remains. 

Download File Images Download the file from the Producer Portal. 

Deliver to Account Subset of View and Manage Download Packages permission: creating/
updating/uploading files, associating files/download packages, and restricting 
files to accounts.

View and Manage 
Download Packages

Manage download packages and files: creating/updating/uploading files, 
creating/updating download packages, associating files/download packages, 
associating download packages/products, EULA management, restricting 
download packages to accounts, and restricting files to accounts.

Table 7-19 • Operations Part Numbers (Producer Portal) Permissions

Permission Description 

Create Part Numbers Import part numbers. 

Table 7-18 • Operations Products, Suites, and Maintenance Permissions

Permission Description
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Operations License Management (Producer Portal)
The following FlexNet Operations License Management permissions are available:

Table 7-20 • Operations License Management (Producer Portal) Permissions

Permission Description

View Licenses View licenses in read-only mode. 

Important • If View Licenses is assigned to a role, also assign View 
Entitlements.

Generate Licenses Generate a license. 

Important • If Generate Licenses is assigned to a role, also assign View 
Licenses. 

Rehost Licenses Transfer a license from one host ID to another. 

Important • If Rehost Licenses is assigned to a role, also assign Generate 
Licenses. 

Repair Licenses Modify license attributes other than the supported host IDs. 

Important • If Repair Licenses is assigned to a role, also assign Generate 
Licenses.

Correct Publisher Error Regenerate a license because the publisher made an error generating the 
original license. 

Important • If Correct Publisher Error is assigned to a role, also assign Generate 
Licenses.

Stop Gap Renewal Generate a license to provide to a customer whose license has expired and has 
not yet completed the process of updating or renewing an entitlement. 

Important • If Stop Gap Renewal is assigned to a role, also assign Generate 
Licenses.
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Operations Policies
The following FlexNet Operations Policies permission is available:

Operations Trusted Storage Licensing (Producer Portal)
The following FlexNet Operations Trusted Storage Licensing permissions are available. Additional permissions 
must also be assigned to view the Package Products, Activate Licenses, and Support Licenses pages to access 
the trusted storage licensing functionality.

Generate Emergency 
Licenses 

Generate an emergency license: a short-term license to provide to a customer 
whose license has not expired but is not functioning. 

Important • If Generate Emergency Licenses is assigned to a role, also assign 
Generate Licenses.

Return Licenses Return licenses. 

Important • If Return Licenses is assigned to a role, also assign Generate 
Licenses. 

Email Licenses Email a license. 

Important • If Email Licenses is assigned to a role, also assign View Licenses. 

Table 7-21 • Operations Policies Permissions

Permission Description 

Override Policies Override any policies. 

Important • If Override Policies is assigned to a role, also assign Generate 
Licenses, Rehost Licenses, Repair Licenses, and Return Licenses. 

Table 7-22 • Operations Trusted Storage Licensing (Producer Portal) Permissions

Permission Description

View Transaction Keys View transaction keys in read-only mode.

Table 7-20 • Operations License Management (Producer Portal) Permissions

Permission Description
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Create Transaction Keys Create transaction keys. 

Important • If Create Transaction Keys is assigned to a role, also assign View 
Transaction Keys.

Delete Transaction Keys Delete transaction keys. 

Important • If Delete Transaction Keys is assigned to a role, also assign View 
Transaction Keys. 

View Activation 
Specification Records 
(ASRs) 

View Local Trial and Short Code Activation Specification Records (ASRs).

Create Local Trial ASRs Create Local Trial ASRs. 

Important • If Create Local Trial ASRs is assigned to a role, also assign View 
Activation Specification Records (ASRs).

Delete Local Trial ASRs Delete Local Trial ASRs. 

Important • If Delete Local Trial ASRs is assigned to a role, also assign View 
Activation Specification Records (ASRs). 

Create Short Code ASRs Create Short Code ASRs. 

Important • If Create Short Code ASRs is assigned to a role, also assign View 
Activation Specification Records (ASRs).

Delete Short Code ASRs Delete Short Code ASRs. 

Important • If Delete Short Code ASRs is assigned to a role, also assign View 
Activation Specification Records (ASRs).

Manual Activations Activate a trusted storage license.

Manual Returns Return a trusted storage license.

Table 7-22 • Operations Trusted Storage Licensing (Producer Portal) Permissions

Permission Description
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Reporting
The following FlexNet Operations Reporting permissions are available.  

Child Account (End-User Portal)
The following sub-accounts permissions are available: 

Manual Repairs Repair a trusted storage license.

Short Code Activations Activate a trusted storage license using a short code.

Short Code Returns Return a trusted storage license using a short code.

Short Code Repairs Repair a trusted storage license using a short code.

Table 7-23 • Reporting Permissions

Permission Description 

View Reports Allows viewing, creating and editing of any report. 

Data Api Grants access to the Data API.

Table 7-24 • Child Account (End-User Portal) Permissions

Permission Description 

View Child Line Items View entitlement line items belonging to all sub-accounts of the user’s 
accounts. 

Return Child Fulfillments Perform returns on fulfillments belonging to all sub-accounts of the user’s 
accounts.

Rehost Child Fulfillments Perform rehosts on fulfillments belonging to all sub-accounts of the user’s 
accounts.

Upgrade Child Fulfillments Perform upgrades on fulfillments belonging to all sub-accounts of the user’s 
accounts.

Renew Child Fulfillments Perform renewals on fulfillments belonging to all sub-accounts of the user’s 
accounts.

Transfer Child Line Items Perform transfers of entitlement line items belonging to all sub-accounts of the 
user’s accounts.

Table 7-22 • Operations Trusted Storage Licensing (Producer Portal) Permissions

Permission Description
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License Technologies
The following FlexNet Operations License Technologies permission is available: 

FlexNet Embedded
The following FlexNet Embedded permissions are available: 

View Child Licenses View licenses belonging to all sub-accounts of the user’s accounts.

Generate Licenses for Child 
Line Items

Generate licenses for all sub-accounts of the user’s accounts.

Repair Child Fulfillments Perform repairs on fulfillments belonging to all sub-accounts of the user’s 
accounts.

Manage Child Users Create, manage and delete users for all sub-accounts of the user’s accounts.

Manage Child Accounts Create, manage and delete accounts for all sub-accounts of the user’s 
accounts.

View Child Devices View devices belonging to all sub-accounts of the user’s accounts.  

View Child Accounts View all sub-accounts of the user’s accounts. 

View Child Users View users for all sub-accounts of the user’s accounts. 

Table 7-25 • License Technologies Permissions

Permission Description 

License Technologies This permission allows the user to manage license technologies using the 
License Technologies page in FlexNet Operations.

Table 7-26 • FlexNet Embedded Permissions 

Permission Description 

Manage Devices This permission allows the user to manage hardware devices using the Manage 
Devices page. See also: FlexNet Embedded permissions Generate Licenses and 
Return.

Manage Publisher Identities This permission allows the user to manage publisher identities using the 
Manage Publisher Identity page.

Table 7-24 • Child Account (End-User Portal) Permissions

Permission Description 
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FlexNet Embedded (End-User Portal)
The following FlexNet Embedded-specific permissions affect the functionality available to End-User Portal users: 

Customer Growth
The following Customer Growth permissions are available:  

Create Server This permission allows the user to create a FlexNet Embedded license server.

Table 7-27 • FlexNet Embedded (End-User Portal) Permissions

Permission Description 

Map by Activation IDs This permission allows the user see the Map by Activation IDs page in the End-
User Portal. On this page, an end user can map one or more entitlements to an 
existing device or license server. 

Important • To succeed for users who are not in the account that owns the 
device or license server, this process also requires that the Skip Account Check 
system configuration setting be enabled.

Claim Device and Activate This permission allows the user to see the Claim and Activate page in the End-
User Portal. Users who can view the Claim and Activate page can potentially 
map entitlements to devices that are owned by unrelated accounts. 

Important • To succeed, this process also requires that the Skip Account Check 
system configuration setting be enabled. 

Edit User on Device This permission allows the user to update the device user. 

Table 7-28 • Customer Growth Permissions

Permission Description 

Manage and View Customer 
Growth

This permission allows users to view and manage customer growth menus and 
pages.

Table 7-26 • FlexNet Embedded Permissions 

Permission Description 
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Usage
The following Usage permissions are available:   

Updates
The following Update permissions are available:  

FlexNet Operations Permission Dependencies
This section lists only the FlexNet Operations permissions that have dependencies on other permissions or 
system configuration settings. For the complete list of permissions and their descriptions, including any 
dependencies, refer to FlexNet Operations Permissions. 

Operations Feature Bundles
The following FlexNet Operations Feature Bundles permission dependencies exist: 

Table 7-29 • Usage Permissions

Permission Description 

View Usage This permission allows users to view usage menus and pages.

Edit Usage Allows users to view the Usage Model drop down in the Create Product page 
and the ability to create Metered Usage model.

Table 7-30 • Updates Permissions

Permission Description 

Manage and View Updates This permission allows users to view and manage update menus and pages.

Table 7-31 • 

Permission Dependency

Update Feature Bundles If Update Feature Bundles is assigned to a role, also assign View Feature 
Bundles. 

Create Feature Bundles If Create Feature Bundles is assigned to a role, also assign Update Feature 
Bundles.

Change Feature Bundle 
State 

If Change Feature Bundle State is assigned to a role, also assign Update 
Feature Bundles.

Delete Feature Bundles If Delete Feature Bundles is assigned to a role, also assign View Feature 
Bundles.



Chapter 7 Managing Accounts and Users
Managing Users

302 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Operations License Models
The following FlexNet Operations License Models permission dependencies exist: 

Operations Entitlements - Producer Portal
The following FlexNet Operations Entitlements permission dependencies exist: 

End-User Portal 
The following End-User Portal permission dependencies exist: 

Table 7-32 • 

Permission Dependency

Create License Models If Create License Models is assigned to a role, also assign View License Models.

Update License Models If Update License Models is assigned to a role, also assign View License 
Models. 

Delete License Models If Delete License Models is assigned to a role, also assign View License Models.

Change License Model 
State 

If Change License Model State is assigned to a role, also assign Update License 
Models.

Table 7-33 • 

Permission Dependency

Update Entitlements If Update Entitlements is assigned to a role, also assign View Entitlements. 

Upsell Entitlements If Upsell Entitlements is assigned to a role, also assign Update Entitlements.

Upgrade Entitlements If Upgrade Entitlements is assigned to a role, also assign Update Entitlements.

Renew Entitlements If Renew Entitlements is assigned to a role, also assign Update Entitlements.

Create Entitlements If Create Entitlements is assigned to a role, also assign Update Entitlements. 

Change Entitlement State If Change Entitlement State is assigned to a role, also assign Update 
Entitlements. 

Delete Entitlements If Delete Entitlements is assigned to a role, also assign View Entitlements. 

Table 7-34 • 

Permission Dependency

Generate Licenses If Generate Licenses is assigned to a role, also assign View Entitlements. 
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Web Services
The following FlexNet Operations Web Services permission dependency exists: 

Operations Features
The following FlexNet Operations Features permission dependencies exist: 

Operations Products, Suites, and Maintenance
The following FlexNet Operations Product, Suite, and Maintenance permission dependencies exist: 

Rehost If Rehost is assigned to a role, also assign Generate Licenses.

Repair If Repair is assigned to a role, also assign Generate Licenses.

Return If Return is assigned to a role, also assign Generate Licenses.

Table 7-35 • 

Permission Dependency 

Execute Web Services In addition to this permission, the user must have task-specific permissions as 
well. 

Table 7-36 • 

Permission Dependency

Update Features If Update Features is assigned to a role, also assign View Features.

Create Features If Create Features is assigned to a role, also assign Update Features. 

Change Feature State If Change Feature State is assigned to a role, also assign Update Features.

Delete Features If Delete Features is assigned to a role, also assign View Features. 

Table 7-37 • 

Permission Dependency

Update Products, Suites, 
and Maintenance 

If Update Products, Suites, and Maintenance is assigned to a role, also assign 
View Products, Suites, and Maintenance. 

Create Products, Suites, 
and Maintenance 

If Create Products, Suites, and Maintenance is assigned to a role, also assign 
Update Products, Suites, and Maintenance.

Table 7-34 • 

Permission Dependency
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Operations License Management
The following FlexNet Operations License Management permission dependencies exist: 

Operations Policies
The following FlexNet Operations Policies permission dependency exists: 

Change Products, Suites, 
and Maintenance State 

If Create Products, Suites, and Maintenance is assigned to a role, also assign 
Update Products, Suites, and Maintenance.

Delete Products, Suites, 
and Maintenance 

If Delete Products, Suites, and Maintenance is assigned to a role, also assign 
View Products, Suites, and Maintenance.

Table 7-38 • 

Permission Dependency

View Licenses If View Licenses is assigned to a role, also assign View Entitlements.

Generate Licenses If Generate Licenses is assigned to a role, also assign View Licenses. 

Rehost Licenses If Rehost Licenses is assigned to a role, also assign Generate Licenses. 

Repair Licenses If Repair Licenses is assigned to a role, also assign Generate Licenses.

Correct Publisher Error If Correct Publisher Error is assigned to a role, also assign Generate Licenses.

Stop Gap Renewal If Stop Gap Renewal is assigned to a role, also assign Generate Licenses.

Generate Emergency 
Licenses 

If Generate Emergency Licenses is assigned to a role, also assign Generate 
Licenses.

Return Licenses If Return Licenses is assigned to a role, also assign Generate Licenses. 

Email Licenses If Email Licenses is assigned to a role, also assign View Licenses. 

Table 7-39 • 

Permission Dependency 

Override Policies If Override Policies is assigned to a role, also assign Generate Licenses, Rehost 
Licenses, Repair Licenses, and Return Licenses. 

Table 7-37 • 

Permission Dependency
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Operations Trusted Storage Licensing
The following FlexNet Operations Trusted Storage Licensing permission dependencies exist: 

FlexNet Embedded - End-User Portal
The following FlexNet Embedded-specific permission dependencies exist: 

FlexNet Operations Roles
The figure below depicts relationships among users, product lines, and user roles. 

Table 7-40 • 

Permission Dependency

Create Transaction Keys If Create Transaction Keys is assigned to a role, also assign View Transaction 
Keys.

Delete Transaction Keys If Delete Transaction Keys is assigned to a role, also assign View Transaction 
Keys. 

Create Local Trial ASRs If Create Local Trial ASRs is assigned to a role, also assign View Activation 
Specification Records (ASRs).

Delete Local Trial ASRs If Delete Local Trial ASRs is assigned to a role, also assign View Activation 
Specification Records (ASRs). 

Create Short Code ASRs If Create Short Code ASRs is assigned to a role, also assign View Activation 
Specification Records (ASRs).

Delete Short Code ASRs If Delete Short Code ASRs is assigned to a role, also assign View Activation 
Specification Records (ASRs).

Table 7-41 • 

Permission Dependency 

Map by Activation IDs To succeed for users who are not in the account that owns the device or license 
server, this process also requires that the Skip Account Check system 
configuration setting be enabled.

Claim and Activate To succeed, this process also requires that the Skip Account Check system 
configuration setting be enabled. 
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The following producer and end-user roles are available by default in FlexNet Operations. 

Producer User Roles
These FlexNet Operations producer user roles are available: Customer Support Representative, Executive, IT Back 
Office Manager, Order Entry, Product Manager, Sales Operations Manager, and System Administrator. 

Customer Support Representative
The Customer Support Representative processes activation requests and provides post-activation support for 
licenses, such as processing license returns and repairs. 

Table 7-42 • 

Customer Support Representative Permissions

Operations Feature Bundles

View Feature Bundles

Operations License Models

View License Models

Operations Entitlements – Producer Portal

View Entitlements

Change Entitlement State

Update Entitlements
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Account Permissions – Producer Portal

View Entitlements

Return

Repair

Rehost

Generate License

View Licenses

View Devices

Trusted Storage Permissions

Short Code Activation

Manual Activation

Manual Return and Repair

Short Code Return and Repair

Access to Trusted Storage Licensing Functionality in Producer Portal

View Activation Specification Records (ASRs)

Manual Activations

Manual Returns

Manual Repairs

Short Code Activations

Short Code Repairs

Short Code Returns

Usage

View Usage Edit Usage

User Management

View As End User

Account Management

View Accounts

Operations Features

View Features

Operations Products, Suites and Maintenance

View Products, Suites and Maintenance Download File Images

Operations License Management – Producer Portal

View Licenses

Return Licenses

Rehost Licenses

Repair Licenses

Correct Publisher Error

Stop Gap Renewal

Generate Emergency Licenses

Generate Licenses

Email Licenses

Table 7-42 • 

Customer Support Representative Permissions



Chapter 7 Managing Accounts and Users
Managing Users

308 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Executive
The Executive role is for upper management personnel who want to view product definitions, associated license 
models, and existing entitlements. 

Customer Growth

Manage and View Customer Growth

Updates

Manage and view Updates

Table 7-43 • 

Executive Permissions

Operations Feature Bundles

View Feature Bundles

Operations License Models

View License Models

Operations Entitlements – Producer Portal

View Entitlements

Account Permissions – End-User Portal

View Entitlements

View Licenses

View Devices

Access to Trusted Storage Licensing Functionality in Producer Portal

View Transaction Keys View Activation Specification 
Records

Usage

View Usage Edit Usage

Account Management

View Accounts

Operations Features

View Features

Table 7-42 • 

Customer Support Representative Permissions
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IT Back Office Manager
The IT Back Office Manager is responsible for integrating FlexNet Operations with an ERP or CRM application. 

Operations Products, Suites and Maintenance

View Products, Suites and Maintenance

Operations License Management – Producer Portal

View Licenses

Customer Growth

Manage and View Customer Growth

Updates

Manage and view Updates

Table 7-44 • 

IT Back Office Manager Permissions

System Administration

View System Information View and Manage Configurations

Operations Feature Bundles

View Feature Bundles

Operations License Models

View License Models

Operations Entitlements – Producer Portal

View Entitlements

Edit Unsent Emails

Queue Email

Account Permissions – End-User Portal

View Entitlements

View Licenses

View Devices

Access to Trusted Storage Licensing Functionality in Producer Portal

View Activation Specification Records (ASRs)

Table 7-43 • 

Executive Permissions
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Order Entry
Order Entry personnel convert order information into entitlements and fulfillments. They can also provide post-
fulfillment support. 

Usage

View Usage Edit Usage

User Management

View Users View As End User

Account Management

View Accounts

Operations Features

View Features

Operations Products, Suites and Maintenance

View Products, Suites and Maintenance

Delete File Images

Download File Images

Deliver to Account

View & Manage Download Packages

Operations License Management – Producer Portal

View Licenses

Customer Growth

Manage and View Customer Growth

Updates

Manage and view Updates

Table 7-45 • 

Order Entry Permissions

Operations Feature Bundles

View Feature Bundles

Operations License Models

View License Models

Table 7-44 • 

IT Back Office Manager Permissions
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Operations Entitlements – Producer Portal

View Entitlements

Change Entitlement State

Update Entitlements

Create Entitlements

Upsell Entitlements

Upgrade Entitlements

Renew Entitlements

Account Permissions – End-User Portal

View Entitlements

Return

Repair

Rehost

Generate License

View Licenses

View Devices

Trusted Storage Permissions

Short Code Activation

Manual Activation

Manual Return and Repair

Short Code Return and Repair

Access to Trusted Storage Licensing Functionality in Producer Portal

View Activation Specification Records (ASRs)

Manual Activations

Manual Returns

Manual Repairs

Short Code Activations

Short Code Repairs

Short Code Returns

Usage

View Usage Edit Usage

User Management

View As End User

Account Management

View Accounts

Operations Features

View Features

Operations Products, Suites and Maintenance

View Products, Suites and Maintenance

Table 7-45 • 

Order Entry Permissions
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Product Manager
The Product Manager is responsible for defining and packaging products. 

Operations License Management – Producer Portal

View Licenses

Return Licenses

Rehost Licenses

Repair Licenses

Correct Publisher Error

Stop Gap Renewal

Generate Emergency Licenses

Generate Licenses

Email Licenses

Customer Growth

Manage and View Customer Growth

Updates

Manage and view Updates

Table 7-46 • 

Product Manager Permissions

System Administration

View and Manage HTML Content View and Manage Email Templates

Create Custom Attributes

Operations Feature Bundles

Delete Feature Bundles

Create Feature Bundles

View Feature Bundles

Change Feature Bundle State

Update Feature Bundles

Operations License Models

Update License Models

Delete License Models

Change License Model State

Create License Models

View License Models

Operations Entitlements – Producer Portal

View Entitlements Edit Unsent Emails

Table 7-45 • 

Order Entry Permissions
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Account Permissions

View Entitlements

View Licenses

View Devices

Create Email Notifications

Queue Email

Access to Trusted Storage Licensing Functionality in Producer Portal

View Transaction Keys

Create Transaction Keys

Delete Transaction Keys

View Activation Specification Records (ASRs)

Create Local Trial ASRs

Delete Local Trial ASRs

Create Short Code ASRs

Delete Short Code ASRs

Usage

View Usage Edit Usage

Account Management

View Accounts

Operations Features

Delete Features

Create Features

View Features

Change Feature State

Update Features

Set Feature Override

Operations Products, Suites and Maintenance

View Products, Suites and Maintenance

Update Products, Suites and Maintenance

Change Products, Suites and Maintenance State

Delete Products, Suites and Maintenance

Create Products, Suites and Maintenance

Delete File Images

Download File Images

Deliver to Account

View & Manage Download Packages

Operations Part Numbers – Producer Portal

Create Part Numbers

Operations License Management – Producer Portal

View Licenses

Reporting

Create and Edit Reports View Reports

Table 7-46 • 

Product Manager Permissions
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Sales Operations Manager
The Sales Operations Manager is a supervisory role above Order Entry personnel and Customer Support 
Representatives. The Sales Operations Manager has complete entitlement and fulfillment permissions. 

Customer Growth

Manage and View Customer Growth

Updates

Manage and view Updates

Table 7-47 • 

Sales Operations Manager Permissions

System Administration

View and Manage Email Templates

Operations Feature Bundles

View Feature Bundles

Operations License Models

View License Models

Operations Entitlements – Producer Portal

View Entitlements

Change Entitlement State

Update Entitlements

Delete Entitlements

Create Entitlements

Edit Unsent Emails

Create Email Notifications

Queue Email

Account Permissions – End-User Portal

View Entitlements

Return

Repair

Rehost

Generate License

View Licenses

View Devices

Trusted Storage Permissions

Short Code Activation

Manual Activation

Manual Return and Repair

Short Code Return and Repair

Table 7-46 • 

Product Manager Permissions
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Access to Trusted Storage Licensing Functionality in Producer Portal

View Activation Specification Records (ASRs)

Manual Activations

Manual Returns

Manual Repairs

Short Code Activations

Short Code Repairs

Short Code Returns

Usage

View Usage Edit Usage

User Management

View As End User

Account Management

View Accounts

Operations Features

View Features

Operations Products, Suites and Maintenance

View Products, Suites and Maintenance

Operations License Management – Producer Portal

View Licenses

Return Licenses

Rehost Licenses

Repair Licenses

Correct Publisher Error

Stop Gap Renewal

Generate Emergency Licenses

Generate Licenses

Email Licenses

Operations Policies

Override Policies

Customer Growth

Manage and View Customer Growth

Updates

Manage and view Updates

Table 7-47 • 

Sales Operations Manager Permissions
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System Administrator
System Administrator Permissions are: 

Table 7-48 • 

System Administrator Permissions

Alert Management

View and Subscribe Alerts View and Manage Alert 
Configurations

System Administration

View System Information

View and Manage Configurations

Merge Entitlements from Self-Registered Account to Customer Account

View and Manage HTML Content

View and Manage Email Templates

Create Custom Attribute

Operations Feature Bundles

Delete Feature Bundles

Create Feature Bundles

View Feature Bundles

Change Feature Bundle State

Update Feature Bundles

Operations License Models

Update License Models

Delete License Models

Change License Model State

Create License Models

View License Models

Operations Entitlements – Producer Portal

View Entitlements

Change Entitlement State

Update Entitlements

Delete Entitlements

Create Entitlements

Upsell Entitlements

Upgrade Entitlements

Renew Entitlements

Edit Sent Emails

Edit Unsent Emails

Create Email Notifications

Queue Email

Account Permissions – End-User Portal

View Entitlements

Return

Repair

Rehost

View Expiring Entitlements

Generate License

View Licenses

Transfer Line Items

View Devices
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Trusted Storage Permissions

Short Code Activation

Manual Activation

Manual Return and Repair

Short Code Return and Repair

Access to Trusted Storage Licensing Functionality in Producer Portal

View Transaction Keys

Create Transaction Keys

Delete Transaction Keys

View Activation Specification Records (ASRs)

Create Local Trial ASRs

Delete Local Trial ASRs

Create Short Code ASRs

Delete Short Code ASRs

Manual Activations

Manual Returns

Manual Repairs

Short Code Activations

Short Code Repairs

Short Code Returns

License Technologies

License Technologies

Child Account Permissions

View Child Line Items

Return Child Fulfillments

Rehost Child Fulfillments

Upgrade Child Fulfillments

Renew Child Fulfillments

Transfer Child Fulfillments

View Child Licenses

Generate License for Child Line 
Items

Repair Child Fulfillments

View Child Devices

View Child Accounts

Manage Child Accounts

View Child Users

Manage Child Users

Usage

View Usage Edit Usage

Table 7-48 • 

System Administrator Permissions
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User Management

View Users

View and Manage Users

View Roles

View and Manage Roles

View Logged-In Users

View Domains

View and Manage Domains

View As End User

View and Manage Customer Users

View and Manage Partner Users

Account Management

View Accounts View and Manage Accounts

Operations Features

Delete Features

Create Features

View Features

Change Feature State

Update Features

Set Feature Override

Operations Products, Suites and Maintenance

View Products, Suites and Maintenance

Update Products, Suites and Maintenance

Change Products, Suites and Maintenance State

Delete Products, Suites and Maintenance

Create Products, Suites and Maintenance

Delete File Images

Download File Images

Deliver to Account

View & Manage Download Packages

Assign Product Lines

Operations Part Numbers – Producer Portal

Create Part Numbers

Operations License Management – Producer Portal

View Licenses

Return Licenses

Rehost Licenses

Repair Licenses

Correct Publisher Error

Stop Gap Renewal

Generate Emergency Licenses

Generate Licenses

Email Licenses

Operations Policies

Override Policies

Table 7-48 • 

System Administrator Permissions
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End-User Customer Roles
These FlexNet Operations end-user customer roles are available: Portal Administrative User and Portal User. 

Portal Administrative User
Portal Administrative User is an end-user customer role. Permissions are: 

Operations Web Services

Execute Web Services

Operations Export Import

Export and Import

Reporting

Create and Edit Reports View Reports

FlexNet Embedded

Manage Devices Manage Publisher Identities

Customer Growth

Manage and View Customer Growth

Updates

Manage and view Updates

Table 7-49 • 

Portal Administrative User Permissions

Operations Feature Bundles

View Feature Bundles

Operations License Models

View License Models

Operations Entitlements – Producer Portal

Change Entitlement State Update Entitlements

Table 7-48 • 

System Administrator Permissions
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Account Permissions – End-User Portal

View Entitlements

Return

Repair

Rehost

Generate License

View License

Transfer Line Items

View Devices

Split Line Items or Bulk Entitlements

View Accounts

Manage Accounts

View Users

Manage Users

Transfer Hosts / Move Devices

Get Downloads

View Expiring Entitlements

Trusted Storage Permissions

Short Code Activation

Manual Activation

Manual Return and Repair

Short Code Return and Repair

Access to Trusted Storage Licensing Functionality in Producer Portal

View Transaction Keys View ASRs

Child Account Permissions

View Child Line Items

Return Child Fulfillments

Rehost Child Fulfillments

Upgrade Child Fulfillments

Renew Child Fulfillments

Transfer Child Fulfillments

View Child Licenses

Generate License for Child Line 
Items

Repair Child Fulfillments

View Child Devices

View Child Accounts

Manage Child Accounts

View Child Users

Manage Child Users

Usage

View Usage Edit Usage

User Management

View Users

View and Manage Users

View Roles

View and Manage Customer Users

View and Manage Partner Users

Table 7-49 • 

Portal Administrative User Permissions
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Portal User
Portal User is an end-user customer role. Permissions are: 

Account Management

View Accounts View and Manage Accounts

Operations Features

View Features

Operations Products, Suites and Maintenance

View Products, Suites and Maintenance Assign Product Lines

Operations License Management – Producer Portal

View Licenses

Return Licenses

Repair Licenses

Generate Licenses

Email Licenses

Customer Growth

Manage and View Customer Growth

Updates

Manage and view Updates

Table 7-50 • 

Portal User Permissions

Operations Feature Bundles

View Feature Bundles

Operations License Models

View License Models

Operations Entitlements – Producer Portal

Change Entitlement State Update Entitlements

Table 7-49 • 

Portal Administrative User Permissions
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Account Permissions – End-User Portal

View Entitlements

Return

Repair

Rehost

Generate License

View Licenses

View Devices

View Accounts

Get Downloads

Trusted Storage Permissions

Short Code Activation

Manual Activation

Manual Return and Repair

Short Code Return and Repair

Access to Trusted Storage Licensing Functionality in Producer Portal

View Transaction Keys View ASRs

Usage

View Usage Edit Usage

Account Management

View Accounts

Operations Features

View Features

Operations Products, Suites and Maintenance

View Products, Suites and Maintenance

Operations License Management – Producer Portal

View Licenses

Return Licenses

Repair Licenses

Generate Licenses

Email Licenses

Customer Growth

Manage and View Customer Growth

Updates

Manage and view Updates

Table 7-50 • 

Portal User Permissions
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Managing Accounts
FlexNet Operations provides a set of flexible tools for defining and managing accounts, sub-accounts, and 
distribution tiers. These tools allow you to define account relationships that mirror your customer and distribution 
partner relationships.

Note • Not all users have access to the account pages. 

This section explains account concepts and includes instructions for account management tasks.

About Accounts
An account is an entity in FlexNet Operations. Accounts can represent the structure of a customer enterprise, the 
internal structure of your software publisher or device manufacturer and, optionally, the relationships between 
the publisher and its distribution chain. Each entitlement is tied to at least one account 

Accounts can have sub-accounts, which can be used to reflect the hierarchical nature of corporate structures. 
Accounts and sub-accounts are defined in a parent-child relationship. For example, you could define Acme Global 
as the main account, and set up Acme US and Acme EMEA as sub-accounts.

An account hierarchy can have multiple levels to flexibly accommodate different models. For example, a single 
account can have multiple sub-accounts, which would share a sibling relationship. Sub-accounts can themselves 
have sub-accounts. In addition, accounts can have multiple parents. 

Note • It is recommended that the total number of associated sub-accounts for any given account does not 
exceed 1000.

Table 7-51 • 

Topic Description

About Accounts Discusses concepts related to accounts: default accounts, account types, and 
account tiers. 

Browsing Accounts or 
Sub-accounts

Describes how to navigate to the Manage Accounts page and browse different 
account types. Not all users have access to the account pages. 

Creating a New Account Explains how to create a new account, sub-account, or partner account and link 
users and other accounts to the new account.

Editing an Account or 
Sub-account

Explains how to alter an existing account or sub-account.

Deleting an Account Describes the process of deleting an account.
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The following topics provide more information about account concepts.

Default Accounts
The following accounts are available in FlexNet Operations by default:

Table 7-52 • 

Topic Description

Default Accounts Identifies the accounts that FlexNet Operations supports without any additional 
configuration: MYORG, UNKNOWN_ORG_UNIT, and PORTAL_ORG_UNIT. 

Account Types Describes the different account types possible in FlexNet Operations: Producer, 
Customer, Partner, and Self-Registered.

Partners and 
Distribution Tiers

Explains how FlexNet Operations handles partner accounts and distribution tiers.

Table 7-53 • FlexNet Operations Accounts

Account Description

My Organization (MYORG) The producer account. Only the account name (My Organization) can be updated 
on the Edit Account page. 

This account cannot be deleted.

Information Not Available 
UNKNOWN_ORG_UNIT

The account set as Sold To for any web register keys when account information 
is not provided and as the End Customer or Channel Partner for entitlements and 
devices that have not been assigned an owner account. 

UNKNOWN_ORG_UNIT is a temporary holding account used by FlexNet 
Operations, internally, when no owner account is assigned. When 
UNKNOWN_ORG_UNIT is the owner of an entitlement or a device, the Producer 
Portal shows Information Not Available for End Customer or Channel Partner.

This account cannot be updated or deleted.

Account ID for Portal 
Accounts 
(PORTAL_ORG_UNIT) 

The account that maps to end users who choose to self-register through the 
End-User Portal: Users who log in to the portal with an entitlement ID or 
activation ID can subsequently choose to self-register, set up a user account, or 
be associated with an existing Self-Registered account.

This account cannot be updated or deleted. 
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Account Types
FlexNet Operations categorizes accounts into four account types. On the Manage Accounts page, each of these 
account types has its own tab: Producer, Customer, Partner, and Self Registered. 

Partners and Distribution Tiers

Version • Channel partner and distribution tier functionality is only available to producers who purchase FlexNet 
Operations with FlexNet Advanced Account Management. 

Partner accounts identify accounts in your distribution chain—those accounts that act as distributors of your 
products and entitlements. Partner accounts exist in a distribution tier between your producer account and your 
end customers. You can add multiple partner accounts on the Manage Accounts page. These partner accounts all 
occupy the default distribution tier.

By default, FlexNet Operations provides a Distributor tier and an End Customer tier for entitlements and devices. 
The distribution chain allows entitlements and devices to move from the producer account to a distributor 
(partner account) to an end user (customer account). However, you can customize the distribution chain and add 
multiple tiers. Changes to the tiers in the distribution chain require customizations to the FlexNet Operations 
database and related properties files. For details, see the FlexNet Operations On-Premises Installation & 
Implementation Guide.

Unique to partner accounts is their relationship to the parent, producer account. Information about the 
transactions in the partner accounts flows up through the distribution chain so that these transactions are visible 
on the Producer Portal.

Some FlexNet Operations features are only available to the producer account and partner accounts. For example, 
only partner accounts can move a device to other distribution tiers on the End-User Portal site.

Table 7-54 • Account types

Type Description

Producer The account for the software publisher or intelligent device manufacturer. 
Producers can also create sub-accounts to their producer account.

Customer The category of accounts that are the end users of your software or device. This 
category includes PORTAL_ORG_UNIT—the default account that maps to users who 
choose to self-register through the End-User Portal. 

Partner The category of accounts that are distribution partners, like wholesalers, 
distributors, resellers, and retailers. Producers can map their distribution tiers by 
defining their distribution partners as partner accounts. These accounts then play a 
special role in FlexNet Operations. 

Self Registered This category includes users who self-register by logging in to the portal with an 
entitlement ID or activation ID and set up a their own user account. Optionally, users 
can select to be associated with an existing Self-Registered account by providing 
the account ID upon self-registration, instead of creating a new account. 
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Browsing Accounts or Sub-accounts
Accounts and sub-accounts are displayed in the Accounts page. Users assigned roles with the View Accounts or 
View and Manage Accounts permission can browse accounts in the Producer Portal. 

You can also view an account hierarchy, viewing the parent account and any sub-accounts associated with it. 

The Manage Accounts page shows the following information: 

• Account ID: Unique identifier of the account 

• Account Name: User-friendly name of the account

• Description, City, State, Country: If included in the account settings, these columns are also populated in the 
Manage Accounts list.

Task To browse existing accounts

1. Click Accounts & Users > All Accountss. The Producer Portal opens the Manage Accounts page.

2. Click the tab for the account type of the accounts you want to see. Choose from 

• Producers

• Customers (default)

• Partners

• Self Registered

Note • You can also use the search feature to rapidly locate a specific account, especially when there are 
several pages of accounts to browse. 

3. To view details about any existing account, click its  Account ID.

To view any sub-accounts of an account, click the + icon to expand the tree view in the Manage Accounts list.

Creating a New Account
To be associated with an entitlement, a company must be entered as an account in FlexNet Operations. This 
procedure includes tasks that explain how to create a new account, sub-account, or partner account.

Users assigned a role with the View and Manage Accounts permission can view, add, and edit accounts. 

Task To create a new account

1. Click Accounts & Users > All Accounts. The Producer Portal opens the Manage Accounts page.

2. Choose an Account Type tab, and then click Create an Account. 

3. On the Create Account page:

a. Enter the Account ID (required). 
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b. Enter the Account Name of the account (required).

c. Add additional address information as desired.

Note • Producers who use download packages and who want to restrict end-users access to download 
packages by geographical location should populate the Country and Region fields.

d. Set the Visible to Others check box (it is selected by default). 

• To prevent partners in different distribution tiers from seeing information about this account, un-
select Visible to Others. 

• To allow partners to see information about this account, select Visible to Others. 

4. Optionally, for producer accounts, link product lines to the account. Click Link Product Lines. Then, select the 
product lines to link and click OK. All members of the account have access to the linked product lines.

Note • Link Product Lines appears on this page only when product lines functionality is properly enabled in 
the system configuration page (System > Configure > FlexNet Operations). See Managing Product Lines for 
details.

5. To link users to the account, do one of the following:

• Click Create a User to link a new user to the account. Then follow the steps outlined in Creating a User to 
create the new user account.

• Click Link Existing Users to link existing users to the account. Select the users (and roles, if applicable) 
you wish to link and click OK.

6. Click Next. On the Linked Sub-accounts page, select any sub-accounts you want to link to this account.

7. Click Complete.

After you have created an account, you can create sub-accounts for it. 

Task To create a new sub-account

If you use the optional Advanced Organization Management module you can create new sub-accounts associated 
with a parent account. 

1. Click Accounts & Users > All Accounts. The Producer Portal opens the Manage Accounts page.

2. On the Manage Accounts page, choose an Account Type tab. 

3. Select the account with which you want to associate a sub-account, then click Create a Sub-account.

4. On the Create an Account page:

a. Enter the Account ID (required) of the sub-account. 

b. Enter the Account Name of the sub-account (required).

c. Add additional information as desired.

5. Click Save.
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You can add additional sub-accounts by repeating Step 3 through Step 5.

Note • It is recommended that the total number of associated sub-accounts for any given account does not 
exceed 1000.

Task To create a new partner account

Partners are special accounts in FlexNet Operations. (See Partners and Distribution Tiers for more information.)

Users assigned a role with the View and Manage Accounts permission can view, add, and edit accounts.

1. Click Accounts & Users > All Accounts. The Producer Portal opens the Manage Accounts page.

2. Click the Partners tab, and then click Create an Account. 

3. On the Create an Account page:

a. Enter the Account ID (required). 

b. Enter the Account Name of the account (required).

c. Add additional address information as desired.

d. Set the Visible to Others check box (it is selected by default). 

• To prevent partners in different distribution tiers from seeing information about this account, un-
select Visible to Others. 

• To allow partners to see information about this account, select Visible to Others.

4. If you want to link users to the account, do one of the following:

• Click Create a User to link a new user to the account. Then follow the steps outlined in Creating a User to 
create the new user account.

• Click Link Existing Users to link existing users to the account. Select the users (and roles, if applicable) 
you want to link and click OK.

5. Click Next. On the Linked Sub-accounts page, select any sub-accounts you want to link to this account. 

6. Click Next. On the Relate Accounts page, select any partners you want to relate to this account. 

7. Click Complete.

Editing an Account or Sub-account
An account or sub account can be edited to change its name or to add, edit or delete users.
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Task To edit an existing account

1. Click Accounts & Users > All Accounts. The Producer Portal opens the Manage Accounts page.

2. Click the tab for the Account Type (Producers, Customers, Partners, or Self Registered) of the account you 
want to edit.

3. In the Manage Accounts list, click the account you wish to edit. The Create an Account page is displayed.

4. Edit the account name and identifier, or create or edit existing users.

5. Click Save. 

Deleting an Account
An account or sub-account can be deleted from FlexNet Operations. You can use the Delete Account or the Delete 
Subtree buttons on the Manage Accounts page to delete accounts. 

• Delete Account—removes the selected accounts. If the account has sub-accounts, those sub-accounts no 
longer have a parent account. The sub-accounts are retained but become top-level accounts. (For example, 
any sub-accounts of a deleted customer account become regular customer accounts.) Any sub-accounts 
that were also parents of sub-accounts also retain the hierarchy of sub-accounts beneath them. 

• Delete Subtree—removes the selected account and all the sub-accounts in its hierarchy. 

Task To delete an account

1. Click Accounts & Users > All Accounts. The Producer Portal opens the Manage Accounts page.

2. Click the tab for the Account Type (Producers, Customers, Partners, or Self Registered) of the accounts you 
want to delete.

3. In the Manage Accounts list, select the accounts or sub-accounts you want to delete.

4. Click Delete Account. 

5. Click OK to confirm deletion. 

The Producer Portal deletes the selected accounts and refreshes the Manage Accounts page. 

Task To delete an account and all its sub-accounts

1. Click Accounts & Users > All Accounts. The Producer Portal opens the Manage Accounts page.

2. Click the tab for the Account Type (Producers, Customers, Partners, or Self Registered) of the accounts you 
want to delete.

3. In the Manage Accounts list, select the parent account to delete. 

Remember that this operation deletes the selected account and all its sub-accounts.

4. Click Delete Subtree. 
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5. Click OK to confirm deletion. 

The Producer Portal deletes the selected account along with its account hierarchy and refreshes the Manage 
Accounts page. 

Account Health
Account health indicators provide users with insight into the key indicators that FlexNet Operations provides for 
accounts. These include:

• Service consumption (counts of total entitled vs. consumed)

• Renewal Health

• Total account health

 

Customer Growth Dashboard
Health Indicators
Visible from both the FlexNet Operations Home page and the Customer Growth Dashboard page (by going to 
Accounts & Users > Dashboard), the Health Indicators provide an at-a-glance view of overall health scores. This 
information is an aggregation of all accounts and displays the number of healthy, warning and at risk items for 
account health, renewal health, and consumption in a donut chart. 

Table 7-55 • 

Topic Description

Customer Growth 
Dashboard

Displays aggregated score for all accounts, alerts and selected individual accounts.

Accounts Detailed health data for an account’s products users, renewals and alerts.

Alert List List of health alerts.
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The overall score for all accounts is represented by the number in the middle of the donut. Hover over the colored 
sections to find the number of accounts in that category. Click on a donut to be taken to the Account page. The 
arrows indicate trends, whether the scores are going up or down. In addition, you can display all accounts or only 
those selected to be on a watchlist.

Accounts
The Customer Growth Dashboard page also displays the overall health score and 30 day trend for all accounts. 
The list can be filtered to show only those accounts on the watchlist by selecting the Watchlist button.

Alerts
The Customer Growth Dashboard page also displays a list of alerts, the accounts, and type of alerts. Alerts are 
only displayed if the watched accounts are selected by clicking the Watchlist button. An alert is generated when 
either a renewal or consumption score crosses a threshold: Healthy, Warning, or At Risk—in either direction.

The alert shows:

• How long ago the alert was triggered 

• The score when the alert was triggered

• The type of change, i.e. from Warning to At Risk

Clicking on an alert notice takes you to the Alerts tab for that account and filters the results based the type of 
alert selected (i.e. Renewal Health or Consumption). See Configuring System Settings for more information on 
setting Renewal and Consumption Health thresholds.

Alert List
Use the topics in this section to learn more about viewing Account Alerts:    

Listing Account Alerts

Task To see a list of alerts for all accounts

• Click Accounts & Users > Alerts. The Accounts Health page opens. 

Table 7-56 • 

Topic Description

Listing Account Alerts Shows how to list alerts for all accounts.

Filtering Accounts Alerts Explains how to filter the alert list by account type, alert type, or the 
direction the alert score changed.
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On the Accounts Alerts page, you can filter the account list by account type and alert type. See To filter the 
Accounts Alerts list for more information. The list contains the following information:  

Filtering Accounts Alerts
By default, the alerts list defaults to display all account types (watched and unwatched) by alert date and all alert 
types and directions of alert changes. To quickly reduce the size of the accounts list displayed on the accounts 
alerts page, filter it by account type, alert type and/or the direction the alert score changed.

Task To filter the Accounts Alerts list

1. On the Accounts Alerts page, hover the cursor over the  filter icon to display the filter selection list. By 
default, the Accounts Alerts page is set to display the Renewal Health and Consumption scores for all 
accounts (whether they are on the watchlist or not) as well as the direction the score changed for the alert.

2. To change the default filter setting, do one of the following:

• Select the Watched box to only view accounts on the Watchlist.

• Unselect one of the Alert types, Renewal Health or Consumption. If both the Alert type boxes are 
unselected, a warning appears to remind you that at least one alert type must be selected. 

• Select either the Increased or Decreased direction of the alert score. Both directions unselected is the 
same as both directions selected.

3. Click Apply to filter the accounts according to your selections. 

The number in the red bubble indicates how many filters are active.

You can also search a filtered account list. Use the drop-down list to narrow your search to Account name or 
Account ID.

Column Description

Alert The type of alert that was triggered.

Account name The name of account the alert was triggered for. Click on the name to be 
taken to the account’s Alerts tab. See Account Alerts for more information.

Account ID The unique identifier of the account.

Score The score at the time of the alert along with an arrow indicating whether the 
alert score increased or decreased.

Date The date the alert was triggered.

Alert age The age of the alert in whole days (i.e. 24 hour periods).
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Accounts
Use the topics in this section to learn more about viewing and managing account health metrics.   

Listing Accounts 
Use the following instructions to list health metrics for existing accounts on the Producer Portal. 

Task To list accounts

• Click Accounts & Users > Accounts. The Accounts Health page opens. 

On the Accounts Health page, you can filter the account list by account type, scores, and health status. See 
Filtering the Account List for more information. The list contains the following information: 

Table 7-57 • 

Topic Description

Listing Accounts Shows how to list existing accounts.

Filtering the Account 
List

Explains how to filter the account list by account type and health status.

Account Health 
Overview

Shows the current overall health, renewal health, and consumption scores.

Account Product Health Shows the health score for products consumed, as well as the number of items 
consumed and the total quantity of consumable items.

Account Renewal 
Health

Shows the list of account renewals so producers can take action on accounts that 
are near expiration.

Account Alerts Shows the account alerts so producers can be aware of accounts that have passed 
a threshold, either up or down.

Table 7-58 • 

Column Description

Account Name The account name.

Account ID Unique identifier of the account.

Products The score of all consumed products to the total number of consumable 
items.
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To view a particular account, click its Account name. On the Account <account name> page, you can view details 
of the health metrics and alerts. 

Note • You can sort the list by Account name, Account ID, Consumption, Renewal Health, or Account Health.

Filtering the Account List
By default, the account list defaults to display all account types (watched and unwatched) by Account health 
score and all health statuses. To quickly reduce the size of the accounts list displayed on the accounts Health 
page, filter it by type, score, and health status.

Task To filter the accounts list

1. On the Accounts Health page, hover the cursor over the  filter icon to display the filter selection list. By 
default, the Accounts Health page is set to display the Account Health score with all statuses.

2. To change the default filter setting, do one of the following:

• Select the Watched box to only view accounts on the Watchlist.

Consumption Total of all consumed products for an account vs the actual quantity. 
Consumed products include:

• Licensing technologies

• Fulfillments generated

• Licenses activated

• Features acquired

See Account Product Health for more information about how consumption 
is counted.

Renewal Health The Renewal Health score is a weighted calculation of days until expiration 
and the consumption value. See Account Renewal Health for more details 
on how the renewal score is calculated.

Account Health The Account Health score is a combination of Consumption and Renewal 
Health scores: (Renewal Score+Consumption Score)/2.

Watchlist Select the icon to add or remove an account from the watchlist.

 - Unwatched

 - Watched

Table 7-58 • 

Column Description
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• Unselect the Account Health and select either the Renewal Health or Consumption scores. 

Note • At least one of the scores must be selected: Account Health, Renewal Health, or Consumption. 
Only one score can be selected at a time; the other scores are inactive. To change scores, unselect the 
active one to make them all active before selecting the score to be filtered on.

• Unselect one or more of the statuses. All statuses unselected is the same as all statuses selected.

3. Click Apply to filter the accounts according to your selections. 

The number in the red bubble indicates how many filters are active.

You can also search a filtered account list. Use the drop-down list to narrow your search to Account name or 
Account ID.

Account Health Overview
On the Account <account name> page, the Overview tab is displayed by default.

The Overview tab displays the account, renewal, and consumption scores related to that account. 

There is also a health meter line graph showing the trends for that health metric. Hover over a point on the graph 
to see the date and its related health score for that metric. 

To add or remove the account from the watchlist, click the Watch or Unwatch button in the upper right hand 
corner.

Account Product Health
On the Account <account name> page, click on the Products tab to see the list of products.

The list contains the following information: 

Table 7-59 • 

Column Description

Score The calculated health score. This number is based on the number of consumed 
versus total available consumable features and/or licenses for that product. The 
number is then assigned a status of healthy, warning, or at risk, depending on the 
threshold set in the system configuration. See the Customer Growth settings under 
Configuring System Settings.
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Note • The list can be sorted by Score, Consumed quantity, Total quantity, and Product name.

Task To filter the products list 

1. On the Products tab, hover the cursor over the  filter icon to display the filter selection list. By default, the 
Products tab is set to display the product health score with all statuses, At risk, Warning, or Healthy.

2. To change the default filter setting, unselect one or more of the conditions. If all the condition boxes are 
unselected, a warning appears to remind you that at least one of the score filters must be selected.

3. Click Apply to filter the products according to your selections.

The number in the red bubble indicates how many filters are active.

You can also search a filtered product list. Use the drop-down list to target your search to a product’s Product 
Name or Description.

Task To view Feature Consumption

• Click on the Consumed quantity value to open the Feature Consumption window.

The Feature Consumption window displays the consumption of features attached to any given product, if there 
are any. Any feature with an embedded license model, and mapped to a license server, is included in the 
consumption numbers.

Note • The list can be sorted by Score, Consumed quantity, Total quantity, or Feature name.

Consumed quantity The total number of licenses and/or features that have been consumed. If feature 
consumption exists, this number is displayed as a link. Consumed products include

• FlexNet Publisher—fulfillments generated from entitlements

• FlexNet Embedded (Standalone device)—licenses mapped from entitlements

• FlexNet Embedded (Local or Cloud license server)—features checked out by 
served devices

• Third part license technology—fulfillments generated from entitlements

Total quantity The sum of all possible features or licenses plus all possible quantities not mapped 
to a server.

Product name The name of the product.

Description A description of the product.

Table 7-59 • 

Column Description
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Task To filter the feature consumption list 

1. On the Feature Consumption window, hover the cursor over the  filter icon to display the filter selection 
list. By default, the Feature Consumption window is set to display the feature health score with all 
conditions, At risk, Warning, or Healthy.

2. To change the default filter setting, unselect one or more of the conditions. If all the status boxes are 
unselected, a warning appears to remind you that at least one of the score filters must be selected.

3. Click Apply to filter the features according to your selections.

The number in the red bubble indicates how many filters are active.

You can also search a filtered feature list. Use the drop-down list to target your search to for a feature by Name or 
Description.

Account Renewal Health
On the Account <account name> page, click on the Renewals tab to see the renewal health of each product the 
account has licenses for.

The list contains the following information: 

Note • The list can be sorted by Score, Days remaining, Expiration, or Product name

Table 7-60 • 

Column Description

Score A calculated value based the number of days until the product expires and the 
consumption value.

Days remaining The number of days before the license expires.

Expiration The date the license expires.

Product name The name of the product.

Type The type of product. Options include:

• Subscription

• Maintenance

Activation ID The activation ID of the product. Click on the Activation ID to see the Entitlement 
Details.
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Calculating the Renewal Score
The formula for calculating the Renewal Score is based on two factors:

1. How far the products are from their expiration dates (for subscription or maintenance lines).

2. The Consumption value. The Consumption score is derived from the ratio of consumed quantities to 
purchased quantities for the account, on a 100-point scale. For example, if an account purchased a quantity 
of 42 but consumed a quantity of 21, the Consumption value is 0.5 and the Consumption score is 50.

For the first factor, there are three weighted renewal periods, based on how close the entitlements are to their 
expiration dates: Renewal Look Ahead, Expiring Window, and Renewal Critical. These renewal periods are labels 
for how close an entitlement is to its expiration date. 

The renewal period weights are fixed and not configurable; however, producers can configure the renewal period 
threshold values in their system configuration settings. In the Producer Portal, click System > Configure > 
FlexNet Operations > Renewals.

The complete formula for the renewal score is

(1–((Renewal Look Ahead*.25)+(Expiring Window*.50)+(Renewal Critical*.90)+Consumption Value))/2

where the value for each renewal period is either 0 or 1. 

Using the renewal period values, only one renewal period (Renewal Look Ahead, Expiring Window, or Renewal 
Critical) is factored into the score at a time. After a product enters a specific renewal period, that renewal period 
has a value of 1 and all other renewal periods have a value of 0.

Task To filter the renewals list 

1. On the Renewals tab, hover the cursor over the  filter icon to display the filter selection list. By default, the 
Accounts page is set to display the product health score with all conditions, At risk, Warning, or Healthy, with 
types, Subscription and Maintenance, and with a status of Expiring.

2. To change the default filter setting, unselect one or more of the statuses, types and/or conditions. If all the 
status boxes are unselected, a warning appears to remind you that at least one status must be selected. All 
types unselected is the same as all types selected. 

3. Click Apply to filter the renewals according to your selections.

The number in the red bubble indicates how many filters are active.

You can also search a filtered renewal list. Use the drop-down list to target your search to a Product Name or 
Activation ID.

Table 7-61 • Weights and Thresholds for Each Renewal Period

Renewal Period Weight Default Threshold

Renewal Look Ahead .25 200 days

Expiring Window .50 90 days

Renewal Critical .90 30 days
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Task To view Entitlement Details

• Click on the Activation ID value to open the Entitlement Details window.

The Entitlement Details window displays the information for a particular entitlement including ID information 
(Entitlement ID, state, sold-to, description and activation ID), the name and description of the products the 
entitlement is associated with, and the activation information.

Account Alerts
On the Account <account name> page, click on the Alerts tab to see the alerts for an account. 

The list contains the following information: 

Note • You can sort the list by either Alert or Alert age.

Task To filter the alerts list 

1. On the Alerts tab, hover the cursor over the  filter icon to display the filter selection list. By default, the 
Alerts page is set to display both the Renewal Health and Consumption score. If the page was loaded by 
clicking on an account from the Customer Growth Dashboard, it automatically filters the list based on the 
selected alert.

2. To change the default filter setting, unselect one of the Alert types and/or select either the Raised or 
Lowered direction. If all Alert type boxes are unselected, a warning appears to remind you that at least one 
alert type must be selected. Both directions unselected is the same as both directions selected.

3. Click Apply to filter the alert types according to your selections.

The number in the red bubble indicates how many filters are active.

Table 7-62 • 

Column Description

Alert The type of alert generated. One of the following:

• Renewal Health

• Consumption

Score The score at the time of the alert. The score also includes an arrow to show if the 
alert level was raised or lowered.

Date The date the alert was generated.

Alert age The age of the alert in days. Maximum days: 30. By default, the list is sorted by the 
alert age.
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Branding the End-User Portal

Producers can alter the appearance of their End-User Portal to fit their company’s branding guidelines. This 
section discusses different End-User Portal customization approaches and explains how to use them to control 
how the End-User Portal appears to your company’s customers.

Branding Overview
This section discusses the different approaches to branding the End-User Portal, provides an overview of 
branding configuration options, and basic instructions for applying branding settings in the Producer Portal 
system configuration pages. 

Table 8-1 • End-User Portal Branding

Section Description

Branding Overview Discusses the different approaches to branding the End-User Portal, 
provides an overview of branding configuration options, and provides basic 
instructions for applying branding settings in the Producer Portal system 
configuration pages.

End-User Portal Settings Provides a complete list of the system configuration settings available in 
the Producer Portal’s End-User Portal Setup page.

End-User Portal Page Structure Includes graphics to illustrate the structure of End-User Portal pages. 

Section Description

About the Standard Branding 
Approach

Introduces the standard branding options producers can use to customize 
the appearance of their End-User Portal.

About the Advanced Branding 
Approach

Discusses the additional branding options available for producers who want 
greater control of End-User Portal branding.
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About the Standard Branding Approach
The standard approach allows a producer to apply their account’s branding to the End-User Portal without the 
need for HTML or CSS knowledge. Some of the changes a Producer Portal administrator can apply include

• Inserting your account’s logo

• Choosing the page-position of the End-User Portal’s primary navigation (top, left, or right)

• Setting the color for body text

• Setting the color for heading text

• Setting the color for anchor text (links)

• Setting primary color for buttons

For many producers, these configuration settings suffice to ensure your End-User Portal shows continuity with 
your account’s branding guidelines. For greater control over the End-User Portal appearance, Producer Portal 
administrators can take advantage of more advanced branding capabilities. 

About the Advanced Branding Approach
The advanced approach allows for a high degree of customization. With enough effort, most producers can mirror 
the appearance of their account’s other online properties. Taking advantage of these advanced branding 
capabilities requires HTML and CSS skills to achieve the desired result, whether those skills come from your 
account’s personnel or a Revenera services engagement.

The advanced branding approach leverages all the standard branding options, plus the ability to 

• Replace header/footer with branded HTML content

• Inject custom CSS

For more details about available system configuration settings related to End-User Portal appearance and 
behavior as well as page structure guidelines, see the next section, End-User Portal Page Structure.

Overview of Producer-Configurable Branding Options
Producer Portal administrators can access these End-User Portal configuration features via the System menu. (In 
the Producer Portal, click System > Configure > End-User Portal Setup.) From a branding perspective, there are a 
few key options to work with. They are broken down by section below.

• Branding-Specific Settings

Overview of Producer-
Configurable Branding Options

Describes the End-User Portal configuration settings that are most 
commonly used for branding.

Changing End-User Portal 
Settings

Provides basic instructions for specifying configuration settings in the 
Producer Portal to control the appearance of the End-User Portal. 

Section Description
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• General Settings

Branding-Specific Settings
The configuration settings for the End-User Portal that exclusively support branding of the portal are collected 
into a group called Custom Branding.

Table 8-2 • Custom Branding settings on the End-User Portal Setup page

Option Description

Upload Company 
Logo

Upload your company logo to replace the Revenera logo in End-User Portal. 

When a file is uploaded, it will appear in the upper-left of the portal and above the login 
form. 

Make sure the logo image is no more that 30px in height, with a file size no greater than 
40KB, and set either on a white or transparent background. 

The Producer Portal shows the path to the uploaded logo file just below the file upload 
control. For administrators pursuing an advanced branding approach, this path can be 
used in your custom CSS to link the image (for example, in a custom page header). 

At this time, only logo uploads are supported. No additional image assets can be 
uploaded via the system configuration options. Speak with your Revenera representative 
to learn about additional options. 

Upload CSS Upload custom CSS to change look of your End-User Portal. 

Part of the advanced branding approach, this field allows you to upload custom CSS 
selectors as a text file. These style settings override other style settings (including the 
default styles or styles defined via standard system configuration settings). 

In addition, CSS selectors can be added here to support custom HTML added for the 
page header and footer. When configured, a custom.css file is loaded as the last linked 
CSS file in the HTML document head. This location takes advantage of inheritance to 
override base style selectors. Normal cascade rules of specificity and inheritance apply 
here. 

Intermediate to advanced CSS and HTML knowledge is recommended to take advantage 
of this option for all but minor CSS changes. Customizing the CSS comes with the 
potential for disruptive effects on the End-User Portal user interface. 

Upload Header Upload custom HTML, as a text file, to replace the existing header. 

This is the area that contains the logo and current user information. When configured, 
the End-User Portal’s User menu and system help are moved into the main content area. 

The custom HTML header must be a self-contained HTML fragment with all elements 
closed. 
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Upload Footer Upload custom HTML, as a text file, to replace the existing footer. This is the grey, 
shaded area at the bottom of each view. 

The custom HTML footer must be a self-contained HTML fragment with all elements 
closed. If the height of your footer differs from the default, you must to add custom CSS 
to ensure it is positioned properly at the bottom of the page. For example

#page-footer-nudge {
height: [ yourFooterOuterHeight + 40 ]px 
}

#page-footer { 
height: [ yourFooterOuterHeight + 20 ]px;
margin-top: -[ yourFooterHeight + 40 ]px;
}

Primary Navigation 
Position

Select an orientation for End-User Portal’s main navigation. 

If, for example, your custom header includes your own site’s primary navigation, the 
End-User Portal navigation can be positioned to the left or right of the main content 
area. It then acts as a sub-navigation for the Entitlement & Delivery section of your site. 

Default Button 
Label Color

Change the color of default button label in the End-User Portal. This option is set within 
the Color Configurator.

Use a color that ensures enough contrast with default button color. White (#FFFFFF) or 
black (#000000) are usually safe alternatives. (Hex values accepted.)

Default Button 
Color

Change the color of default action buttons in the End-User Portal. This option is set 
within the Color Configurator. 

Buttons generally represent page-level commands—Save, Submit, Activate, for example. 
(Hex values accepted.)

Background Color Change the background color of pages in the End-User Portal. This option is set within 
the Color Configurator.

This setting is applied to the <body/> element of every page. (Hex values accepted.)

Title Color Change the color of page headings and sub-headings in the End-User Portal. This option 
is set within the Color Configurator.

(Hex values accepted.)

Link Color Change the color of text links (anchors) in the End-User Portal. This option is set within 
the Color Configurator.

(Hex values accepted.)

Table 8-2 • Custom Branding settings on the End-User Portal Setup page

Option Description
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General Settings
Many End-User Portal configuration settings control the appearance or behavior of the portal without being 
branding-specific. Often these settings correspond to the functionality your account wants to provide in its End-
User Portal. 

Changing End-User Portal Settings
Whether producers use a standard or advanced branding approach, their choices are stored in the Producer 
Portal’s End-User Portal-related system configuration settings. These settings apply resources, like your 
account’s graphics and style sheets, combined with your design choices to govern the appearance of your 
account’s End-User Portal. 

Follow the instructions, below, to configure the End-User Portal. 

Primary Navigation Change the background color the primary navigation menus in the End-User Portal. This 
option is set within the Color Configurator.

(Hex values accepted.)

Primary Navigation 
Open

Change the background color open (active) primary navigation menus in the End-User 
Portal. This option is set within the Color Configurator.

(Hex values accepted.)

Primary Navigation 
Text

Change the color of all text in the End-User Portal’s primary navigation menus. This 
option is set within the Color Configurator.

(Hex values accepted.)

Table 8-3 • Non-branding-specific configuration settings

Option Description

Hide Top-level 
Navigation

Select to hide the top-level navigation portal-wide. Use this option with caution; hiding 
the primary navigation restricts access to all but the initial landing page. 

This may be appropriate for some embedded implementations—for example, included 
via an iframe in another application page.

Hide Header Select to hide header on each page. The header is the area above the primary 
navigation. This setting is useful when the End-User Portal is to be embedded in your 
own online property. When configured this way, the End-User Portal shows the user 
menu and system help in the main content area.

Table 8-2 • Custom Branding settings on the End-User Portal Setup page

Option Description
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Important • A user must be assigned a role with the View and Manage Configurations permission to modify 
configuration settings for the End-User Portal through the Producer Portal. 

Tip • Before changing any configuration settings in a working FlexNet Operations instance, it is advisable to 
export the working configuration settings. If there is a problem with the new settings, you have a backup of 
working settings to restore.

Task To configure the End-User Portal

1. In the Producer Portal, click System > Configure. 

2. Click End-User Portal Setup to open the configuration page for the End-User Portal. 

Initially, the General Options group is expanded. Click on the name of a group to expand the settings list for 
that group. For example, click Custom Branding to show all branding-specific system configuration settings 
for the End-User Portal.

3. Make any setting changes that suit your configuration needs. 

Refer to the following sections for additional information: 

• For administrators performing standard branding, consult the system configuration setting tables in for 
additional information about the settings in each section in End-User Portal Settings.

• For administrators performing advanced branding, also review the End-User Portal Page Structure 
section.

4. Click Save Configs to save changes. 

The Producer Portal saves your configuration changes.

End-User Portal Settings
The following tables include all system configuration settings for End-User Portal appearance and behavior in the 
Producer Portal. All of these settings are found on the End-User Portal Setup tab of the System Configuration 
page.

The settings that apply expressly to branding appear in the Custom Branding group, below. However, other 
settings also have an impact on the appearance of portal to your end users. (Many of these non-branding-specific 
settings pertain more to the behavior and included functionality rather than branding.) 

Important • A user must be assigned a role with the View and Manage Configurations permission to modify 
configuration settings for the End-User Portal through the Producer Portal. 
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Tip • Before changing any configuration settings in a working FlexNet Operations instance, it is advisable to 
export the working configuration settings. If there is a problem with the new settings, you have a backup of 
working settings to restore.

This section includes the following sub-sections with instructions for changing End-User Portal settings and 
descriptions of different End-User Portal setting groups: 

• General Options Configurations

• Login Page Configurations

• Portal Navigation Configurations

• End-User Portal Home Page Configurations

• Entitlements Page Configurations

• Bulk Entitlements Page Configurations

• License Support Page Configurations

• Devices Page Configurations

• Downloads Page Configurations

• Recent Releases Configurations

• Recent Files Page Configurations

• Download Order Page Configurations

• Download Packages Page Configurations

• Manage Accounts & Users Configurations

• Custom Branding Configurations

• Custom Tags Configurations

General Options Configurations
These settings correspond to the General Options section of the End-User Portal Setup page in System > 
Configure.  

Table 8-4 • End-User Portal: General Options Configurations

Name
Possible 
Values Description Rqd

Transferred Items 
Set to On Hold

Selected or 
unselected

Set the state of items transferred in the End-User Portal to On 
Hold and send an email to the FlexNet Operations administrator 
to approve the transfer by releasing the hold.

 

Enable Auto Login Selected or 
unselected

Select to enable an end user to log in to the portal by passing an 
activation ID or entitlement ID in the login URL.
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Hide Header Selected or 
unselected

Hides the header in all pages of portal. Select to enable when 
End-User Portal is embedded into an external portal.

 

Skip Home Page Selected or 
unselected

Skips the Home page after a user logs in and proceeds directly 
to the List Entitlements page.

Resource Bundle 
Time-to-Live

30 or specify Reload the resource bundle cache at this time interval 
(minutes). Specify the number of minutes between resource 
bundle cache reloads.

* 

Enable Self-
Registration for an 
existing Account

Selected or 
unselected

Select to enable an end user to be associated with an existing 
Self-Registered account when they self-register in the End-User 
Portal  with an entitlement ID or activation ID.

Enable terms and 
conditions panel

Selected or 
unselected

Show or hide the Privacy Terms and Conditions link on the 
Register for Account page for self-registering users. If enabled, 
users are reminded to read the privacy terms and conditions 
when they click Complete on the Register for Account page. 
When a user clicks the link, the Privacy Terms and Conditions 
are opened in a new tab. Customers are not required to 
acknowledge that they have read the Privacy Terms and 
Conditions.

Terms and 
conditions URL

Specify If you selected Enable terms and conditions panel, enter the 
URL to the Privacy Terms and Conditions that a self-registering 
user should read before registering.

Show Download 
Button

Selected or 
unselected

Show or hide the Download button on the Downloads tab on the 
device’s default view. If selected, the Download button enables 
a user to download entire download packages or individual files 
contained in a download package. 

Requires that the configuration setting Hide Download 
Manager (in the Downloads Page section) be unselected and 
Show Downloads Tab (in the Devices Page section) be selected.

Default: Unselected.

Version • This setting is only available for producers who use 
the Software Delivery module.

Table 8-4 • End-User Portal: General Options Configurations

Name
Possible 
Values Description Rqd
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Login Page Configurations
These settings correspond to the Login Page section of the End-User Portal Setup page in System > Configure.   

Portal Navigation Configurations
These settings correspond to the Portal Navigation section of the End-User Portal Setup page in System > 
Configure.    

Table 8-5 • End-User: Portal Login Page Configurations

Name
Possible 
Values Description Rqd

Hide Register Link Selected or 
unselected

Hides the Register link for self-service registration near Log In.  

Hide Log in With 
Entitlement ID 
Option 

Selected or 
unselected

Hides With Entitlement ID link in the login page.

Important • Hiding any two login methods will remove the 
option box from the login form.

 

Hide Log in With 
Activation ID 
Option 

Selected or 
unselected

Hides With Activation ID link in the login page.

Important • Hiding any two login methods will remove the 
option box from the login form.

 

Hide Log in With 
User Name Option

Selected or 
unselected

Hides With User Name link in the login page.

Important • Hiding any two login methods will remove the 
option box from the login form.

Table 8-6 • End-User Portal: Navigation Configurations

Name
Possible 
Values Description Rqd

Hide Top-level 
Navigation 

Selected or 
unselected

Hides the top-level navigation/menu in all pages of portal. 
Select to hide navigation/menu when End-User Portal is 
embedded into an external portal.

Hide System Help Selected or 
unselected

Hides the system help links in the top-level navigation.
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Hide Home Button Selected or 
unselected

Hides Home in the top-level navigation.

Hide Activation & 
Entitlements Menu

Selected or 
unselected

Hides the Activation & Entitlements menu in the top-level 
navigation.

Hide Claim 
Activation IDs Link

Selected or 
unselected

Hides the Claim Activation IDs link in the Activation & 
Entitlements menu.

Hide Devices Menu Selected or 
unselected

Hides the Devices menu in the top-level navigation.

Hide Users & 
Accounts Menu

Selected or 
unselected

Hides the Users & Accounts menu in the top-level navigation.

Hide Host Transfer 
Jobs Link

Selected or 
unselected

For customer users, hides the Host/Device Transfer Jobs links 
in the License Support menu.

Hide Downloads 
Menu

Selected or 
unselected

Hides the Downloads menu in the top-level navigation.

Hide List 
Downloads Link

Selected or 
unselected

Hides the List Downloads link in the Downloads menu.

Hide Recent Files 
Added Link

Selected or 
unselected

Hides the Recent Files Added link in the Downloads menu.

Hide Recent 
Releases Link

Selected or 
unselected

Hides the Recent Releases link in the Downloads menu.

Hide Usage Menu Selected or 
unselected

Hides the Usage menu in the top-level navigation.

Hide License 
Support Menu

Selected or 
unselected

Hides the License Support menu in the top-level navigation.

Table 8-6 • End-User Portal: Navigation Configurations

Name
Possible 
Values Description Rqd
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End-User Portal Home Page Configurations
These settings correspond to the Portal Home Page section of the End-User Portal Setup page in System > 
Configure.   

Entitlements Page Configurations
These settings correspond to the Entitlements Page section of the End-User Portal Setup page in System > 
Configure.     

Table 8-7 • End-User Portal: Home Page Configurations

Name
Possible 
Values Description Rqd

Hide Recent 
Entitlements 
Widget

Selected or 
unselected

Hides the Recent Entitlements panel on the Home page.

Hide Recent 
Releases Widget

Selected or 
unselected

Hides the Recent Releases panel on the Home page. 

Hide Recent Files 
Widget

Selected or 
unselected

Hides the Recent Files panel on the Home page.

Hide Downloads 
Widget

Selected or 
unselected

Hides the Downloads panel on the Home page.

Hide 
Announcements 
Widget

Selected or 
unselected

Hides the Announcements panel on the Home page. See 
Managing Custom Content for information about publishing 
announcements to the home page.

Hide Quick Links 
Widget

Selected or 
unselected

Hides the Quick Links panel on the Home page.

Table 8-8 • End-User Portal: Entitlements Page Configurations

Name
Possible 
Values Description Rqd

Hide Activate Selected or 
unselected

Hides the Actions > Activate link on the Entitlements page.

Hide Trusted 
activate

Selected or 
unselected

Hides the Actions > Trusted activate link on the Entitlements 
page. 

For producers that support only trusted storage activation, 
hiding the Trusted Activate link prevents users from activating 
anything from the End-User Portal. However, the short code 
activation link is still shown and is usable. 
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Bulk Entitlements Page Configurations
These settings correspond to the Bulk Entitlements Page section of the End-User Portal Setup page in System > 
Configure.     

Hide Transfer Selected or 
unselected

Hides the Action > Transfer link on the Entitlements page. 

Hide Split Selected or 
unselected

Hides the Action > Split link on the Entitlements page. 

Hide Short Code 
Activation

Selected or 
unselected

Hides the Action > Short Code Activation link on the 
Entitlements page. 

Hide Print Selected or 
unselected

Hides the View > Print link on the Entitlements page. 

Hide View 
Certificate

Selected or 
unselected

Hides the View > View certificate link on the Entitlements page. 

Hide Email Selected or 
unselected

Hides the View > Email link on the Entitlements page. 

Hide Claim 
Activation IDs

Selected or 
unselected

Hides the Action > Claim Activation IDs link on the Entitlements 
page.

Hide Export Selected or 
unselected

Hides the Export button on the Entitlements page.

Table 8-9 • End-User Portal: Bulk Entitlements Page Configurations

Name
Possible 
Values Description Rqd

Hide View Web 
Register Keys 
Button

Selected or 
unselected

Hides the View > View Web Register Keys link on the Bulk 
Entitlements page. Default: Unchecked.

Table 8-8 • End-User Portal: Entitlements Page Configurations

Name
Possible 
Values Description Rqd
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License Support Page Configurations
These settings correspond to the License Support Page section of the End-User Portal Setup page in System > 
Configure.   

Table 8-10 • End-User Portal: License Support Page Configurations

Name
Possible 
Values Description Rqd

Hide Return Selected or 
unselected

Hides the Action > Return link on the License Support page.

Hide Rehost Selected or 
unselected

Hides the Action > Rehost link on the License Support page.

Hide Repair Selected or 
unselected

Hides the Action > Repair link on the License Support page. 

Hide Upgrade Selected or 
unselected

Hides the Action > Upgrade link on the License Support page.

Hide Upsell Selected or 
unselected

Hides the Action > Upsell link on the License Support page.

Hide Renew Selected or 
unselected

Hides the Action > Renew link on the License Support page.

Hide Manual 
Return

Selected or 
unselected

Hides the Action > Manual Return link on the License Support 
page.

Hide Manual 
Repair

Selected or 
unselected

Hides the Action > Manual Repair link on the License Support 
page.

Hide Save to File Selected or 
unselected

Hides the View > Save to File on the License Support page.

Hide Email License Selected or 
unselected

Hides the View > Email License link on the License Support 
page.

Hide Shipment 
Records

Selected or 
unselected

Hides the View > Shipment Records link on the License Support 
page.

Hide View 
Fulfillments 
Button

Selected or 
unselected

Hides the View > View Fulfillments button on the License 
Support/Consolidate Licenses page.

Hide Print Selected or 
unselected

Hides the View > Print link.
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Devices Page Configurations
These settings correspond to the Devices Page section of the End-User Portal Setup page in System > Configure.     

Hide Export Menu Selected or 
unselected

Hides the Export menu above lists of licenses.

Hide Consolidate 
Link

Selected or 
unselected

Hides the Action > Consolidate link on the License Support 
page.

Hide Verify Selected or 
unselected

Hides the Action > Verify link (shown when user generates a 
license).

Hide Transfer 
Licenses

Selected or 
unselected

Hides the Action > Transfer Licenses link on the License 
Support and Manage Hosts pages. 

Hide Product 
Version Details

Selected or 
unselected

Hides the Product Version details for activatable line items on 
all pages. Select the box to prevent the product version from 
being rendered in the Product column after the product name. 

Hide Batch Rehost Selected or 
unselected

For customer users, hides the Action > Batch Rehost link.

Hide Short Code 
Return 

Selected or 
unselected

Hides the Action > Short Code Return link on the License 
Support page. 

Hide Short Code 
Repair 

Selected or 
unselected

Hides the Action > Short Code Repair link on the License 
Support page. 

Hide List Hosts 
Link

Selected or 
unselected

Hides the List Hosts link in the License Support menu. 

Table 8-11 • End-User Portal: Devices Page Configurations

Name
Possible 
Values Description Rqd

Hide View History 
Button

Selected or 
unselected

Hides View History option on the device’s default view.

Hide Download 
Capability 
Response Link

Selected or 
unselected

Hides the Download Capability Response link in the Action 
menu for the device’s default view and View Server pages.

Table 8-10 • End-User Portal: License Support Page Configurations

Name
Possible 
Values Description Rqd
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Allow Standalone 
Device Creation 

Selected or 
unselected

Allows creation of standalone devices in the End-User Portal. If 
Allow Standalone Device Creation and Allow Server Device 
Creation are unselected, the Create Device menu item and 
button are hidden. 

Allow Server 
Device Creation

Selected or 
unselected

Allows creation of server devices in the End-User Portal. If Allow 
Standalone Device Creation and Allow Server Device Creation 
are unselected, the Create Device menu item and button are 
hidden.

Hide Move Button Selected or 
unselected

Hides the Move Device button in the Action menu on the 
device’s default view. 

Allow Device Name 
Editing

Selected or 
unselected

Allows editing of device name in the End-User Portal.

Display Site Name 
in Devices Page

Selected or 
unselected

Displays the Site Name attribute on the Devices page. *

Enable Return 
Device/Server

Selected or 
unselected

Allows devices and servers to be returned via the End-User 
Portal. 

Allow Backup 
Server ID Editing

Selected or 
unselected

Allows End-User Portal users to add backup servers. 

Display vendor 
dictionary 
information in 
Devices page

Selected or 
unselected

Controls whether vendor dictionary information is visible on the 
device’s default view in the End-User Portal.

Default: selected (vendor dictionary information is visible on the 
device’s default view).

Show Downloads 
Tab

Selected or 
unselected

Controls whether the Downloads tab is visible on the device’s 
default view. If selected, the Downloads tab shows all 
downloads that are available for a standalone device.

Default: unselected.

Version • This setting is only available for producers who use 
the Software Delivery module.

Table 8-11 • End-User Portal: Devices Page Configurations

Name
Possible 
Values Description Rqd
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Downloads Page Configurations
These settings correspond to the Downloads Page section of the End-User Portal Setup page in System > 
Configure.    

Table 8-12 • End-User Portal: Downloads Page Configurations

Name
Possible 
Values Description Rqd

Show File Count Selected or 
unselected

Show or hide the download file count on the Download page. 
Select the box to have the End-User Portal show how many 
times each file has been downloaded.

Hide Download Log 
Tab

Selected or 
unselected

Show or hide the Download Log tab on the Downloads page. 
Select the box to hide the Download Log tab. 

Hide Notification 
Log Tab

Selected or 
unselected

Show or hide the Notification Log tab on the Downloads page. 
Select the box to hide the Notification Log tab. 

Hide Date Added Selected or 
unselected

Show or hide the Date Added column in the Files list. Select the 
box to hide the Date Added column.

Hide Extended File 
Description

Selected or 
unselected

Show or hide the extended file description in the expanded file 
details. Select the box to hide the extended file description.

Hide Custom 
Attributes

Selected or 
unselected

Show or hide custom file attributes in the expanded file details. 
Select the box to hide custom attributes.

Hide File 
Checksums

Selected or 
unselected

Show or hide the checksum values in the expanded file details. 
Select the box to hide the checksums attribute.

Show Download 
Package Version

Selected or 
unselected

Show or hide the version number for each download package 
next to the download package name above the file list on the 
Download List page. 

Note that download packages are not required to have a 
version. If no download package version is available, no 
download package version will appear in the End-User Portal.

Select the box to show the download package version numbers. 

Hide File Details Selected or 
unselected

Show or hide all additional file details in the expanded file 
details. Select the box to hide all such details. 

Show Order Media Selected or 
unselected

Show or hide Order Media on the Downloads page. Order Media 
enables End-User Portal users to request copies of the files to 
which they are entitled on physical media. 

Order Media 
Request Recipient

Specify The email destination for the Order Media request messages. 
Set the email address the End-User Portal uses when an end 
user wants to order physical media. 

*
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Recent Releases Configurations
These settings correspond to the Recent Releases section of the End-User Portal Setup page in System > 
Configure.    

Recent Files Page Configurations
These settings correspond to the Recent Files Page section of the End-User Portal Setup page in System > 
Configure.     

Hide Download 
Manager

Selected or 
unselected

Show or hide the Download Selected Files button on the 
Download List page. 

Table 8-13 • End-User Portal: Recent Releases Configurations

Name
Possible 
Values Description Rqd

Default Days to 
Show

30 or specify Set the default recency of the release for the recent files list. 
This setting determines the recency, in days, for download 
packages to be included in the recent releases list. Common 
settings are 30, 60, 90, and 120.

Table 8-14 • End-User Portal: Recent Files Page Configurations

Name
Possible 
Values Description Rqd

Default Days to 
Show

30 or specify Set the default recency for the recent files list. This setting 
determines the recency, in days, for files to be included in the 
recent files list. Common settings are 30, 60, 90, and 120.

Table 8-12 • End-User Portal: Downloads Page Configurations

Name
Possible 
Values Description Rqd
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Download Order Page Configurations
These settings correspond to the Download Order Page section of the End-User Portal Setup page in System > 
Configure.      

Download Packages Page Configurations
These settings correspond to the Download Packages Page section of the End-User Portal Setup page in System 
> Configure.      

Manage Accounts & Users Configurations
These settings correspond to the Manage Accounts & Users section of the End-User Portal Setup page in System 
> Configure.

Table 8-15 • End-User Portal: Download Order Page Configurations

Name
Possible 
Values Description Rqd

Show Version Selected or 
unselected

Show or hide the Version column in the Download Package list 
of the Available Downloads page. 

The Available Downloads page lists the download packages 
associated with an entitlement. In the End-User Portal, the 
Available Downloads page appears when you click an 
entitlement’s Download Now link on the List Entitlements page. 

Table 8-16 • End-User Portal: Download Packages Page Configurations

Name
Possible 
Values Description Rqd

Show Version Selected or 
unselected

Show or hide the Version column in the Download Package list 
on the Download Packages page. 

The Download Packages page lists the download packages for 
a product. In the End-User Portal, the Download Packages page 
appears when you click on a product name. For example, an 
end user might click on a product name that appears in Your 
Downloads on the Home page or in the list that appears after 
clicking Downloads > List Downloads.
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Note • You can also configure the display of the Created By column on the Accounts page in the End-User Portal 
using the OPS_PORTAL_CONFIG table. See the FlexNet Operations On-Premises Installation & Implementation 
Guide for more information.  

Table 8-17 • End-User Portal: Manage Accounts & Users Configurations

Name
Possible 
Values Description Rqd

Hide Create a 
Sub Account

Selected or 
unselected

Hides the Create a Sub Account link in the Actions menu on the 
Accounts page.

Hide Delete 
Account

Selected or 
unselected

Hides the Delete Account link in the Actions menu on the 
Accounts page.

Hide Delete Subtree Selected or 
unselected

Hides the Delete Subtree link in the Actions menu on the 
Accounts page.

Hide Create a User Selected or 
unselected

Hides the Create a User link in the Actions menu on the 
Accounts and Users pages.

Hide Delete a User Selected or 
unselected

Hides the Delete User link in the Actions menu on the Accounts 
and Users pages.

Prevent editing 
Account ID and 
Account Name

Selected or 
unselected

Prevents customer users and partner users from editing their 
account ID and account name.

Hide Create an 
Account

Selected or 
unselected

Hides the Create partner account and Create customer account 
links in the Actions menu on the Accounts page.
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Custom Branding Configurations
These settings correspond to the Branding section of the End-User Portal Setup page in System > Configure.   

Table 8-18 • End-User Portal: Custom Branding Configurations

Name
Possible 
Values Description Rqd

Upload Company 
Logo 

Specify Choose an image file (PNG or JPG format) to serve as your 
account’s logo in the End-User Portal and upload it. Use the 
controls to choose a file from your local machine to upload. 

After an image file is uploaded, a reset button is available to 
enable you to clear the uploaded image. 

Maximum file size: 40KB

Recommended image height: 30 pixels

Upload CSS Specify Choose a CSS file to replace the style settings used by default 
for the End-User Portal. Uploading a customized CSS file allows 
for a broader range of style changes consolidated into a single 
place. For smaller changes, it may be simpler to use one of the 
override settings instead. 

Use the controls to choose a CSS file from your local machine to 
upload. (When no custom CSS file is present, the End-User 
Portal uses its default CSS.)

Upload Header Specify Choose an HTML file to replace the default header content for 
the End-User Portal. Use the controls to choose a file from your 
local machine to upload. (When no custom header HTML is 
present, the End-User Portal uses its default header content.)

Upload Footer Specify Choose an HTML file to replace the default footer content for 
the End-User Portal. Use the controls to choose a file from your 
local machine to upload. (When no custom footer HTML is 
present, the End-User Portal uses its default footer content.)

Primary Navigation 
Position

Top, Left, or 
Right

Specify where to show the high-level navigation menu for the 
End-User Portal. Default: Top. 
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Configure Portal 
Colors

Click Open Configurator to show the Color Configurator panel. 
The Color Configurator allows you to set the colors to use in 
your End-User Portal pages for the following content:

• Default button label color – sets the color of the label on 
default buttons in the End-User Portal. 

• Default button color – sets the color of the default buttons 
in the End-User Portal. 

• Background color – sets the background page color for all 
End-User Portal pages. 

• Title color – sets the text color of the page titles in the End-
User Portal. 

• Link color – sets the color of the link text and lightweight 
button text on End-User Portal pages. 

• Primary navigation – sets the background color for the 
primary navigation menu. 

• Primary navigation open – sets the background color for 
open (active) primary navigation menu items. 

• Primary navigation text – sets the color for all text in the 
primary navigation menu. 

Specify all colors using hexadecimal format. For example, 
#000000 for black, #ffffff for white, or #228B22 for forest green.

Click Preview to show a sample of your color settings within the 
Color Configurator.

Click Undo to revert any changes that have not yet been saved.

Click Use Defaults to restore color settings to the FlexNet 
Operations default colors.

Click Save to store your changes to these color settings.

Table 8-18 • End-User Portal: Custom Branding Configurations

Name
Possible 
Values Description Rqd
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Custom Tags Configurations
These settings correspond to the Custom Tags section of the End-User Portal Setup page in System > Configure.       

End-User Portal Page Structure
The following graphics illustrate the general page structure as well as specific page structure for scenarios where 
a custom header and footer have been applied and also where a custom header and footer have been applied 
with navigation left-aligned. 

• General Page Structure

• Page Structure with Custom Header and Footer

• Page Structure with Custom Header and Footer, and Navigation Aligned Left

General Page Structure
The following is a graphic illustrating the general page structure of an End-User Portal page.

Table 8-19 • End-User Portal: Custom Tag Configurations

Name
Possible 
Values Description Rqd

Last in Head Custom script tags added here will be inserted last in the 
document <head/> of the End-User Portal. 

Last in Body Custom script tags added here will be inserted last in the 
document <body/> of the End-User Portal.
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Page Structure with Custom Header and Footer
The following graphics illustrate a specific page structure for a scenario where a custom header and footer have 
been applied. 
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Page Structure with Custom Header and Footer, and Navigation Aligned Left
The following graphics illustrate a specific page structure for a scenario where a custom header and footer have 
been applied with navigation left-aligned. 
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Part 2
Getting Started

This part of the FlexNet Operations User Guide includes the following sections:

• Getting Started with FlexNet Embedded Licensing

• Getting Started with FlexNet Publisher Trusted Storage-Based Licensing

• Getting Started with FlexNet Publisher License File-Based Licensing

• Getting Started with Non-FlexNet Licensing Technologies

• Getting Started with Cloud Licensing Service

• Getting Started with Entitlement Management

• Getting Started with Electronic Software Delivery

• Getting Started with Usage Management

• Getting Started with FlexNet Customer Growth

• Getting Started with Advanced Organization Management
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Getting Started with 
FlexNet Embedded Licensing

This section Getting Started with FlexNet Embedded Licensing presents fundamental FlexNet Operations 
concepts and uses exercises to guide you through basic FlexNet Embedded licensing setup, and creation of 
FlexNet Embedded devices. The intended audience for this getting started section is the first-time Producer 
Portal user, or one without FlexNet Operations training or experience. This getting started section is organized 
into the following topics. 

Topic Content

 Introduction Overview of this getting started section, exercise prerequisites, summary of 
the FlexNet Operations license lifecycle, and FlexNet Operations embedded 
licensing concepts. 

Setup FlexNet Operations publisher and product concepts and exercises that 
demonstrate how to set up a publisher account and products, then entitle a 
customer to those products. Brief descriptions of advanced topics with 
references for more information. 

Devices FlexNet Operations embedded device concepts and exercises that 
demonstrate how to create FlexNet Embedded standalone devices and 
generate pre-installed product licenses for them. End-User Portal exercises 
that demonstrate how to map an entitlement to a device; claim a device and 
map an entitlement to it; then automatically create a device, claim it for a 
customer account, and activate its licenses. Brief descriptions of advanced 
topics with references for more information. 

License Servers FlexNet Operations embedded license server concepts, and exercises that 
demonstrate how to create a FlexNet Embedded license server and map an 
entitlement to it. Brief descriptions of advanced topics with references for 
more information. 
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To view a brief, informative video that walks you through the exercises in the Getting Started with 
FlexNet Embedded Licensing, click here. We recommend that you read this getting started section in full, to gain 
an understanding of the concepts it covers, before you view the video. 

Introduction
This section lists the exercise prerequisites, a summary of the FlexNet Operations license lifecycle, and FlexNet 
Operations embedded licensing concepts. 

• Exercise Prerequisites

• The License Lifecycle: FlexNet Embedded

• FlexNet Embedded Licensing Key Concepts

• Advanced Topics

Exercise Prerequisites
Before you begin the exercises in this getting started section:

• FlexNet Operations must be properly installed and configured 

• FlexNet Operations seed data and demonstration database must be loaded 

Important • These exercises require a FlexNet Operations database populated with demonstration data. For 
more information, refer to the step-by-step instructions in the FlexNet Operations On-Premises Installation & 
Implementation Guide to create seed data using the flexnet loaddb command and to populate the sample 
data using the flexnet demodata command. 

• You must have access to the FlexNet Operations Advanced Lifecycle Management module. 

• The FlexNet Embedded SDK must be properly installed and configured.

• The FlexNet Operations email templates must be set up (verify that the Entitlement Certificate email template 
is set to active). 

• You must have a FlexNet Operations Producer Portal login and a System Administrator role. 

• You must complete the exercises in the section Getting Started with Entitlement Management. 

The License Lifecycle: FlexNet Embedded
The FlexNet Operations license lifecycle is a repeating process of producer and customer activities, as depicted in 
the figure and described below.

https://www.youtube.com/watch?v=UIPThmlDtGg&feature=youtu.be
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Figure 9-1:  FlexNet Operations License Lifecycle

The delivery/installation and activation stages of the FlexNet Embedded license lifecycle are covered in this 
getting started section.

• Create Products – Create product definitions that are used to generate licenses. 

• Order/Entitle – Define an customer’s rights to obtain licenses for your products. 

• Deliver⁄Install – Deliver the application software to the customer and install that software. 

• Activate – Deliver licenses to the customer. 

• Return/Rehost – Manage license transfers from one user or system to another. 

• Maintain/Update – Deliver software and license updates to the customer. 

• Upsell/Renew – Renew customer licenses, or sell the customer additional product functionality. 

FlexNet Embedded Licensing Key Concepts
FlexNet Embedded Licensing
Software on a device controls the product feature set expressed on that particular device. If the device has 
Internet connectivity, it can connect directly to FlexNet Operations and receive the license for its particular 
product feature set. A device can also be activated offline or using a FlexNet Embedded license server. 
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FlexNet Embedded license technology can also be integrated with a producer’s software to make it capable of 
enforcing perpetual, subscription, or demo software license models. 

FlexNet Embedded licenses are of two types: 

• An uncounted license allows a customer to deploy an unlimited number of licenses. 

• A counted license restricts deployment to a limited number of licenses. The count is specified during the 
entitlement process. 

Linking multiple license models to a single product is permitted. If multiple license models are linked to a 
product, it must be specified, when an entitlement line is created, which license model applies to the entitlement 
line. If only a single license model is linked to a product, then it is used by default. 

FlexNet Embedded SDK
To use FlexNet Embedded, FlexNet Operations works in conjunction with the FlexNet Embedded SDK, a licensing 
library. Before you continue, ensure that you have access to the following: 

• FlexNet Operations Producer Portal 

• FlexNet Embedded SDK 

Installing and Configuring the FlexNet Embedded SDK 

Install and configure the FlexNet Embedded SDK as explained in your FlexNet Embedded documentation. Consult 
the user guide and getting started guide for your FlexNet Embedded SDK. For example, if you are using the 
FlexNet Embedded C SDK, consult the FlexNet Embedded C SDK Getting Started Guide and the FlexNet Embedded 
C SDK User Guide. 

Building Product Binaries 

Using the FlexNet Embedded SDK, your development team must create Flex-enabled product binaries that are 
able to take advantage of the FlexNet licensing technology. Some sample license-enabled code is included in 
your FlexNet Embedded SDK. Consult the user guide for your FlexNet Embedded SDK for details. 

Configuring the Device Servlet 

The device request servlet handles incoming binary HTTP requests (capability requests) from FlexNet Embedded 
devices. The servlet URL is http://<fnoServer>:<httpPort>/flexnet/deviceservices/. This URL must be 
accessible to networked devices to obtain their licenses from FlexNet Operations. Your development team must 
configure the connection method using the device servlet. 

Using the Capability Request Command Line Utility 

The caprequestutil capability request utility, located in <FlexNet_Embedded_install_dir>\bin\tools, enables you 
to manually generate a capability request and save it as a file or send it to a back office server. This utility is 
intended for quick testing involving capability requests. It is implemented using Java, and uses a text file as a 
substitute for trusted storage. This command line utility works for all platforms. 

Embedded Activation 
A FlexNet Embedded entitlement can be activated online or offline. 
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• Online activation – The Flex-enabled application generates a capability request for entitled features, then 
sends the request to FlexNet Operations via the Internet. FlexNet Operations sends a capability response to 
the device, which processes the response and places the license into trusted storage. 

• Offline activation – The Flex-enabled application generates a capability request file, which is manually 
transferred to a connected system from which it can be uploaded to FlexNet Operations. The capability 
response is downloaded from FlexNet Operations and transferred to the Flex-enabled application for 
processing. 

Embedded License Support 
The license lifecycle extends beyond activation; support is also an important part of the lifecycle. Embedded 
licenses can easily be added, deleted, or re-allocated in response to customer demands, maintenance, or market 
conditions.

Next Steps
This topic introduced fundamental FlexNet Operations Embedded licensing concepts. In the next topic, you are 
introduced to FlexNet Embedded licensing setup.  

Advanced Topics
For more information about this topic, refer to Administering License Models. 

License Formats
FlexNet Embedded supports different ways of representing license rights on a system. A producer can create 
customized license models by combining the two different ways to store licenses: 

• Trusted Storage: License rights can be fulfilled or upgraded by a back office server, either online or offline. 
This type of license is kept in trusted storage, a secure location bound to a particular device, and which 
supports verifiable returns to the back office server and subsequent transfer to a different device. 

• Binary License: License can be stored as an array of bytes, either imported by license-enabled code during 
execution or compiled into the executable code. This type of license is typically locked to a particular device, 
and may contain an expiration date. 

When a device model is created in FlexNet Operations, one of three license formats must be selected: 

• Pre-installed license in file, additional licenses in trusted storage: The pre-installed license is stored in a 
binary file, and additional licenses are stored in trusted storage. 
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• Pre-installed license and additional licenses in file: The pre-installed license and additional licenses are 
stored in a binary file. 

• Pre-installed license and additional licenses in trusted storage: The pre-installed license and additional 
licenses are stored in trusted storage. 

Setup
This topic introduces FlexNet Embedded licensing and its setup. Setup tasks include adding a publisher and 
publisher identity; deploying the Embedded Counted license model; adding product features, a product, and 
deploying the product; and entitling the customer account to the product. For more information, refer to 
Administering License Models. 

The exercises in this topic guide you through the basic FlexNet Embedded licensing setup work flow. 

• Setup: Key Concepts

• Setup: Exercises

• Setup: Next Steps

• Setup: Advanced Topics

Setup: Key Concepts
Publishers and Publisher Identities 
Before FlexNet Embedded can be used, a publisher and identity must be set up on the FlexNet Operations 
Producer Portal. A publisher identity is binary data that contains a publisher or producer name and encryption 
data. The publisher owns the license and validates it; the identity secures communication between the back 
office and the device. 

Revenera supplies each publisher with a unique name and a series of five publisher keys. The keys cannot be 
regenerated or duplicated. 

The publisher can create any number of identities, each providing a different level of security for different classes 
of devices or licenses. For example, a line of high-end devices may require higher security than a line of low-end 
devices. When an identity is created, a digital signature algorithm is selected to prevent forgery and tampering on 
the device. 

Products and Features 
Products—hardware or software—are packages of features that can be sold by a producer. A feature is a 
software functionality or set of functionalities. Feature definitions are created in the FlexNet Operations Producer 
Portal that correspond to product features defined in the code. For more information about products and 
features, refer to Getting Started with Entitlement Management. 

Entitling a Customer Account 
You entitle a customer account to a product linked to one or more FlexNet Embedded license models, then you 
license the product. For more information about entitlements, refer to Getting Started with 
Entitlement Management. 
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Setup: Exercises
These exercises use examples to guide you through the following FlexNet Embedded setup tasks: 

Adding a Publisher and a Publisher Identity
In this exercise, you add publisher demo and publisher identity ABCNetworks. 

Task To add the demo publisher 

1. Log in to the FlexNet Operations Producer Portal. The Producer Portal Home page appears. 

2. Click Administer > Publishers. The List Publishers page appears. 

3. Click Create Publisher. The Create A Publisher page appears. 

4. In the Publisher Name field, type demo 

5. In the Notes field, type FlexNet Embedded Demo Publisher. 

6. In the Publisher Keys fields, type 0x9ddcd080 0x99aa8309 0x33995896 0x271213a5 0x0b165dcb and click Save. 
The Create Identity page appears with this message: The publisher was created successfully.

Task To add the ABCNetworks identity to the demo publisher 

1. On the Create Identity page, enter the publisher identity’s attributes: 

• Identity Name: Type ABCNetworks 

• Signature Algorithm: Select any algorithm 

Exercise Description

Adding a Publisher and 
a Publisher Identity

Add publisher demo and publisher identity ABCNetworks. 

Deploy the Embedded 
Counted License Model

Deploy the FlexNet Licensing technology’s Embedded Counted license model. 

Adding Product 
Features

Add product features SimultaneousUsers, Encryption_Throughput, and Redundancy. 

Adding a Product Add the VPN5050 and 10MbpsVPN5000 additional encryption throughput products and 
link them to the Embedded Counted license model. 

Deploying a Product Deploy the VPN5050 and 10MbpsVPN5000 products. 

Entitling a Customer 
Account to a Product

Entitle the Barry Photography Studio customer account to the VPN5050 and 
10MbpsVPN5000 products. 
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Note • The Custom IdentityBackOffice.bin field is not mandatory. For this exercise, leave it blank. 

2. Click Save. The List Identities page appears with publisher identity name ABCNetworks and the message The 
identity was created successfully. 

Deploy the Embedded Counted License Model
In this exercise, you deploy the FlexNet Licensing technology’s Embedded Counted license model. You deployed 
FlexNet Licensing and the Nodelocked Uncounted license model in section Getting Started with 
Entitlement Management. The Embedded Counted license model deployment procedure is similar to the one you 
performed for Nodelocked Uncounted. 

Note • If the Embedded Counted license model is already deployed in your FlexNet Operations instance, you can 
skip this task and continue with To add the Encryption_Throughput, SimultaneousUsers, and Redundancy 
features. 

Task To deploy the Embedded Counted license model 

1. In the Producer Portal, click Administer > License Models. The Package Products – License Models page 
appears. 

2. Search for and select the Embedded Counted license model, click Change State ?, then select Deploy from 
the menu. 

3. Click OK in the verification message. This message appears: Deployed the following License Model(s) 
successfully: Embedded Counted. In the License Models table, Embedded Counted has a state of deployed. 

Adding Product Features
In this exercise, you add product features SimultaneousUsers, Encryption_Throughput, and Redundancy. Features 
SimultaneousUsers and Encryption_Throughput are counted, and feature Redundancy is uncounted (enabled or 
disabled). 

Task To add the Encryption_Throughput, SimultaneousUsers, and Redundancy features 

1. In the Producer Portal, click Products > Features. The Package Products page appears. 

2. Click Add New Feature. 

3. Under Create A Feature, enter the first feature’s attributes: 

• Feature Name: Type Encryption_Throughput 

• Version: Type 1.0 

• Description: Type Encryption throughput in Mbps 
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4. Click Add New Feature. The first feature is saved and this message appears: Feature Encryption_Throughput 
successfully added. 

5. Under Create a Feature, enter the second feature’s attributes: 

• Feature Name: Type SimultaneousUsers 

• Version: Type 1.0 

• Description: Type Number of simultaneous users 

6. Click Add New Feature. The second feature is saved and this message appears: Feature SimultaneousUsers 
successfully added.

7. Under Create a Feature, enter the third feature’s attributes: 

• Feature Name: Type Redundancy 

• Version: Type 1.0 

• Description: Type Redundancy 

• Under Feature Overrides, from the Counted list, select No (Redundancy is enabled or disabled) 

8. Click Save. The third feature is saved and this message appears: Feature Redundancy successfully added. 
Note that the three new features are listed in the table on the right side of the Package Products page. 

Adding a Product
In this exercise, you add the VPN5050 and 10MbpsVPN5000 additional encryption throughput products and link them 
to the Embedded Counted license model. The procedure is similar to the one you used to create PhotoPrint in the 
section Getting Started with Entitlement Management. 

Task To add product ABC VPN 5050 

1. In the Producer Portal, click Products > Products. The Package Products page appears. 

2. Click Add New Product. 

3. Under Create A Product, enter the product attributes: 

• Product Name: Type VPN5050 

• Description: Type ABC VPN 5050 Basic Features 

• Version: Type 1.0 

• License Technology: Select FlexNet Licensing 

• Can be used on a device: Select Yes 

• License Generator: Select demo 

4. Click Add Features. The Add Features To Product window opens. 

5. In the Add Features To Product window, under Available Features, search for and select 
Encryption_Throughput,1.0, SimultaneousUsers,1.0, and Redundancy,1.0. 
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6. Click Add ? to move Encryption_Throughput,1.0, SimultaneousUsers,1.0, and Redundancy,1.0 to Selected 
Features, then click Add. The features are added to product VPN5050 and the window closes. 

7. In the feature table, enter a number in the Quantity field for each feature: 

8. Click Next. Under Link License Models To Product, click Link License Models. The Select License Models 
window opens. 

9. Under Available License Models, select Embedded Counted then click Add ? to move it to Selected License 
Models. 

10. Click Add to add the license model and close the window. On the Package Products page, the Embedded 
Counted license model is shown. 

11. Click Save to save the product. This message appears: License models linked successfully. Note that the 
new VPN5050 product is listed in the table on the right side of the Package Products page. 

Task To add product ABC VPN 5000 Encryption Throughput (10 Mbps) 

1. On the Package Products page, click Add New Product. 

2. Under Create A Product, enter the product attributes: 

• Product Name: Type 10MbpsVPN5000 

• Description: Type ABC VPN 5000 Encryption Throughput (10 Mbps) 

• Version: Type 1.0 

• License Technology: Select FlexNet Licensing 

• Can be used on a device: Select Yes 

• License Generator: Select demo 

3. Click Add Features. The Add Features To Product window opens. 

4. In the Add Features To Product window, under Available Features, search for and select 
Encryption_Throughput,1.0. 

5. Click Add ? to move Encryption_Throughput,1.0 to Selected Features, then click Add. The feature is added to 
product 10MbpsVPN5000 and the window closes. 

6. In the feature table, on the Encryption_Throughput line, type 10 in the Quantity field. 

7. Click Next. Under Link License Models To Product, click Link License Models. The Select License Models 
window opens. 

Feature Quantity

Encryption_Throughput 5

SimultaneousUsers 5

Redundancy 1
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8. Under Available License Models, select Embedded Counted then click Add ? to move it to Selected License 
Models. 

9. Click Add to add the license model and close the window. On the Package Products page, the Embedded 
Counted license model is shown. 

10. Click Save to save the product. This message appears: License models linked successfully. Note that the 
new 10MbpsVPN5000 product is listed in the table on the right side of the Package Products page. 

Deploying a Product
In this exercise, you deploy the VPN5050 and 10MbpsVPN5000 products. The procedure is similar to the one you used 
to deploy PhotoPrint in Getting Started with Entitlement Management.

Task To deploy products VPN5050 and 10MbpsVPN5000 

1. In the Producer Portal, click Products > Products. The Package Products appears. 

2. Under Recently Accessed Products, search for and select products VPN5050 and 10MbpsVPN5000. 

3. Click Change State ? and select Deploy from the menu. Click OK in the verification message. Deployment 
information for the VPN5050 and 10MbpsVPN5000 products is shown under Deploy Products and Following 
Features Will Also Be Deployed. 

4. Click Deploy. This message appears: Products deployed successfully.

Entitling a Customer Account to a Product
In this exercise, you entitle the BarryPhoto customer account and customer end user Lisa Barry to the VPN5050 
and 10MbpsVPN5000 products. The procedure is similar to the one you used to entitle BarryPhoto to product 
PhotoPrint in Getting Started with Entitlement Management. 

Task To entitle customer account BarryPhoto to product VPN5050 

1. In the Producer Portal, click Entitlements > Create. The Entitle Customers to Licenses page appears. 

2. Under Create An Entitlement, on the Entitlement ID list, select Specify and type ENT-VPN5050 in the field that 
appears next to it. 

3. Under End Customer And Channel Partners, click Add. The End Customer And Channel Partners | Accounts 
window opens. 

4. On the Customers tab under Accounts, select Account from the Search For menu, search for and select 
BarryPhoto, then click Next. The End Customer And Channel Partners | Contacts window opens. 

5. Under Contacts, search for and select Lisa Barry, then click Save. The window closes. On the Entitle 
Customers to Licenses page, under End Customer And Channel Partners, the end customer’s account name, 
contact, and email address are populated. 

6. On the Line Items tab, click New Line Item. The Configure Line Item wizard opens. Search for and select the 
VPN5050 product. 
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7. At the bottom of the wizard, click Next twice to advance to the Configure Product step. Enter the VPN5050 line 
item attributes: 

• Qty: Type 5 

• Start Date: Select Use First Activation Date 

• Expiration: Select Specify Duration, type 1, then select Years 

• Keep the default values for all other attributes. 

Click Save. 

8. On the Line Items tab, review the draft VPN5050 line item, then click Save & Deploy. The line item is deployed 
and this message appears: Entitlement deployed successfully. 

9. Click the VPN5050 line item’s Activation ID, review the Line Item Details window, then click Cancel to close it. 

10. At the bottom of the Entitle Customers to Licenses page, click View and select View History from the menu. 
The Change History window opens for the ENT-VPN5050 entitlement. 

11. Review the change history of the ENT-VPN5050 entitlement, then click OK to close the window. 

12. On the Entitle Customers to Licenses page, click Email to send entitlement notification email to Lisa Barry at 
Barry Photography Studio. The Entitle Customers to Licenses page appears with the customer’s address in 
the Ship To Email field. 

Note • To include additional recipients, type their email addresses into the Ship To Email field separated by 
commas. 

13. Add your email address to the recipients list so you receive a copy of the entitlement email. 

14. Click Send. The Entitle Customers to Licenses page appears with the message Email sent to the recipients 
<address list>. 

15. Review the entitlement notification email you receive. 

Task To entitle customer account BarryPhoto to product 10MbpsVPN5000 

Repeat Step 1 through Step 15 of task To entitle customer account BarryPhoto to product VPN5050 to entitle the 
customer to a product with these attributes: 

• Entitlement ID: Type ENT-10MbpsVPN5000 

• Product: Type 10MbpsVPN5000 

Line item attributes: 

• Qty: Type 10 

• Start Date: Select Use first activation date 

• Expiration: Select Specify duration, type 1, and select Years 

• Customer: Select Barry Photo 

• Contact: Select Lisa Barry 
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Log out of the Producer Portal or continue with Devices. 

Setup: Next Steps
This topic introduced FlexNet Embedded licensing setup. In the next topic, you are introduced to FlexNet 
Embedded devices and device management tasks. 

Setup: Advanced Topics
Adding a FlexNet Embedded License Model 
A FlexNet Embedded license model assigns default parameters for either a pre-installed license that is used for a 
device model, or licenses for additional products to which a customer account can be entitled. The license model 
specifies sources for the values of feature record properties in generated licenses. For more information, see 
Creating a License Model.

Digital Signature Algorithms 
The publisher can define any number of identities, each providing a different level of security for different classes 
of devices or licenses. For example, a line of high-end devices may require higher security than a line of low-end 
devices. 

When an identity is created, a digital signature algorithm is selected to prevent forgery and tampering on the 
device. FlexNet Operations supports several digital signature algorithms. For more information, see Creating a 
Publisher Identity.

Devices
This topic introduces FlexNet Embedded standalone devices and typical tasks performed for them. These tasks 
include creating a device, assigning a device to a customer account, mapping a product entitlement to a device, 
claiming a device, and activating a device’s product licenses. 

The exercises in this topic guide you through the basic FlexNet Embedded standalone device work flows. 

• Devices: Key Concepts

• Devices: Exercises

• Devices: Next Steps

• Devices: Advanced Topics

Devices: Key Concepts
Devices
A device is a hardware or software component that uses FlexNet Embedded to license its products. FlexNet 
Embedded devices connect to FlexNet Operations to manage their ownership, state, features, and more. 
Examples of devices include high-end medical equipment, routers, and microchip ID scanners. 
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A device is identified by a device ID and its type. Device types are 

• Standalone Device—FlexNet Embedded device that connects to FlexNet Operations, which manages the 
device.

• Server—FlexNet Embedded server that communicates with FlexNet Operations to manage device ownership, 
state, and features for a collection of served devices. (When a FlexNet Embedded server is used, its served 
devices connect with the FlexNet Embedded server rather than connecting directly to FlexNet Operations.)

• Served Device—FlexNet Embedded device that is managed via a FlexNet Embedded server. In FlexNet 
Operations, served devices are essentially read-only entities.

Creating a Device
There are many ways to create a device. In the typical scenario, the device is claimed via the activation process in 
the End-User Portal. In another scenario, the producer creates a device and assigns an owner through the 
Producer Portal, then the customer accesses the device through their End-User Portal. 

Adding Device Features
Applications running on devices use licensed product features to turn access to functionality on or off in the 
application or device. When a feature is created, it is configured as one of two types: counted or uncounted. This 
configuration indicates whether the feature is limited to a certain quantity or turns access to the functionality on 
or off. 

An example of a counted feature is number of cell phone minutes you have, and an example of an uncounted 
feature is whether you have access to text messaging or not.

Pre-Installed Licenses
A device must be created before a pre-installed license can be generated for it. A pre-installed license defines the 
basic or default features of a device. Pre-installed license generation is a producer activity; a pre-installed license 
is typically loaded on the device by the producer before shipping. 

On the Producer Portal, producer users can download a license response file for a pre-installed license after the 
pre-installed license is generated. 

Additional Products 
Additional products are capabilities that can be mapped to a device in addition to the basic, pre-installed product 
included with the device. Additional products can also be removed from a device. 

Product Licenses 
A product license grants additional capabilities or capacity for a device or an application. For example, a producer 
can create a camera with a pre-installed license for the basic product. Later, licenses for more advanced 
products can be added to the camera to reflect additional capabilities purchased by the customer. An application 
example is personal computer software with a pre-installed license for system security features. The software 
can also include product licenses for a system repair tool kit and junk file removal tool that the customer can 
purchase later. 
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Product licenses can be generated online (programmatically), or manually on the Producer Portal or End-User 
Portal. (Additional features on devices that cannot connect directly to FlexNet Operations can be activated via the 
manual process of offline activation.) A feature license can be generated manually with a request file (offline 
activation) or without one. A license response file for a feature license can be downloaded after the license is 
generated. 

Devices: Exercises
These exercises use examples to guide you through the following FlexNet Embedded standalone devices tasks: 

Creating a Device
In this exercise, you use the Producer Portal to create standalone devices ABCVPN5050-1 and ABCVPN5050-2 and 
generate VPN5050 pre-installed product license files for them. 

Task To create standalone device ABCVPN5050-1 

1. Log in to the FlexNet Operations Producer Portal if you have not already done so. 

2. Click Devices > Create Device. The Device | New Device page appears. 

3. Enter the device’s attributes: 

• Device name: Type ABCVPN5050-1 

• Model: Select FLX_CLIENT 

• ID: Select STRING and type ABCVPN5050-1 for Primary ID. 

• Identity: Select ABCNetworks 

• Account: Select BarryPhoto: 

Exercise Description

Creating a Device Create standalone devices ABCVPN5050-1 and ABCVPN5050-2 for account 
BarryPhoto and generate VPN5050 pre-installed product license files for them. 

Mapping an Additional 
Product Entitlement to a 
Device

Log in to the End-User Portal and map the 10MbpsVPN5000 product entitlement to 
device ABCVPN5050-1. 

Claiming a Device and 
Mapping an Additional 
Product Entitlement

In the End-User Portal, claim device ABCVPN5050-2 and map the 10MbpsVPN5000 
product entitlement to it. 

Activating a Device’s Pre-
Installed and Additional 
Product Licenses

In the End-User Portal, automatically create standalone device ABCVPN5050-3 for 
customer account BarryPhoto, map the VPN5050 and 10MbpsVPN5000 products to 
it, and activate the licenses. 
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a. Click the search icon next to Account. The Assign Device Owner pop-up window opens. 

b. On the Customers tab, search for and select BarryPhoto, then click Select. The Account window 
closes. On the Device page, Account is populated with device owner details. 

c. Click Save. The device’s default view appears. Note that Device Details lists BarryPhoto as the 
Account, Status is ACTIVE, and Pre-installed License Generated? is No. Model Details is The device 
model does not include any pre-installed licenses. Licenses is No licenses have been mapped. 

Task To add a VPN5050 pre-installed product to device ABCVPN5050-1 

1. On the device’s default view, click Edit > Edit this Device. The Edit Device page appears. 

2. Under Pre-installed Product, click Add Pre-installed Product. The Add Pre-installed Product pop-up window 
opens. 

3. Under Product Details, click By Product. In the Select Product window that opens, select product VPN5050 
and click OK to close the Select Product window and populate the product name and version in the Add Pre-
installed Product window. 

4. In the Add Pre-installed Product window, enter the product details: 

• License Model: Select Embedded Counted 

• Start Date: Click the calendar icon, then click Today at the bottom of the calendar page that opens 

• Expiration: Select Specify Duration, type 1, then select Years 

5. Click Add. The Edit Device page appears with VPN5050 listed under Pre-installed Product. 

6. Click Save. The device’s default view page appears. Note that this device’s Status is ACTIVE but Pre-Installed 
License Generated? is No. 

Task To generate a VPN5050 pre-installed product license file for device ABCVPN5050-1 

1. Click Generate license file. This message appears: License file successfully generated. Under Device 
Details, Pre-installed License Generated? is Yes. 

2. On the device’s default view, click View and select View License File from the menu. On the View License File 
page that appears, review the license file, which looks similar to: 

MessageType="Buffer license" 
MessageTime=( 

Timestamp=1440445832891 
TimestampUnits=Milliseconds 

) 
License=( 

Name=SimultaneousUsers 
Vendor=demo 
Version=1.0 
Expires=24-aug-2016 
Count=5 
HostID=( 

Type=String 
ID=ABCVPN5050-1 
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) 
Issued=24-aug-2015 
Start=23-aug-2015 
Issuer="My Corporation" 
) 
License=( 

Name=Redundancy 
Vendor=demo 
Version=1.0 
Expires=24-aug-2016 
Uncounted 
HostID=( 

Type=String 
ID=ABCVPN5050-1 ) 

Issued=24-aug-2015 
Start=23-aug-2015 
Issuer="My Corporation" 
) 
License=( 

Name=Encryption_Throughput 
Vendor=demo 
Version=1.0 
Expires=24-aug-2016 
Count=5 
HostID=( 

Type=String 
ID=ABCVPN5050-1 

) 
Issued=24-aug-2015 
Start=23-aug-2015 
Issuer="My Corporation" 
) 

Task To create standalone device ABCVPN5050-2 

Repeat Step 2 through Step 3 of task To create standalone device ABCVPN5050-1 to create a device with these 
attributes: 

• ID: Type ABCVPN5050-2 

• Device Model: Select FLX_CLIENT 

• ID: Select STRING and type ABCVPN5050-2 for Primary ID. 

• Identity: Select ABCNetworks 

Task To add a VPN5050 pre-installed product to device ABCVPN5050-2 

Repeat Step 1 through Step 6 of task To add a VPN5050 pre-installed product to device ABCVPN5050-1 to add a 
VPN5050 product license file to device ABCVPN5050-2. 



Chapter 9 Getting Started with FlexNet Embedded Licensing
Devices

386 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Task To generate a VPN5050 pre-installed product license for device ABCVPN5050-2 

Repeat Step 1 through Step 2 of task To generate a VPN5050 pre-installed product license file for device 
ABCVPN5050-1 to generate a VPN5050 product license file for device ABCVPN5050-2. The license file looks similar to 
the device ABCVPN5050-1 license file. 

Mapping an Additional Product Entitlement to a Device
In this exercise, you log in to the End-User Portal to map an additional 10 Mbps of encryption throughput to 
standalone device ABCVPN5050-1. 

Task To map the ABC VPN 5000 Encryption Throughput (10 Mbps) product entitlement to device ABCVPN5050-1 

1. Log in to the End-User Portal as Lisa Barry, the Barry Photography Studio end user you created in the 
exercise in the section Getting Started with Entitlement Management. 

2. In the End-User Portal, click Devices > Devices. The Devices page for Barry Photography Studio appears. 

3. In the Devices page list, click the ABCVPN5050-1 link. The device’s default view for ABCVPN5050-1 appears. 
Review the information under Device Details. Under Model Details, note that Product Name is VPN5050 and 
that no additional licenses are currently mapped to this device. 

4. Click Action and select Map Entitlements from the menu. The Map Entitlements page appears. 

5. In the 10MbpsVPN5000, Version 1.0 Qty to Add field, type 1 to represent 10 Mbps of additional encryption 
throughput. 

6. Click Save. This message appears on the device’s default view: Entitlements successfully mapped. Note that 
the Status of 10MbpsVPN5000, Version 1.0 is License not generated. 

7. Click Action > Download Capability Response to generate the license. When asked if you want to open or 
save the binary license file, save it as <FlexNet_Embedded_install_dir>\bin\tools\ABCVPN5050-1.bin, where 
<FlexNet_Embedded_install_dir> is the directory in which your FlexNet Embedded licensing toolkit is 
installed. The exact behavior varies slightly, depending on your browser and operating system. 

8. On the device’s default view, click View and select View History from the menu. On the Device History page 
that appears, review the Time, Event, and Additional Details of each line in the list. 

9. Click Devices > Devices and click the ABCVPN5050-1 link. On the device’s default view, note that the Status of 
10MbpsVPN5000, Version 1.0 is now License generated. 

10. To use the FlexNet Embedded printbin tool to view the contents of the binary license file: 

a. Open a command prompt window. 

b. In the command prompt window, navigate to <FlexNet_Embedded_install_dir>\bin\tools, the directory 
in which you saved the binary license file in Step 7. 

c. At the prompt, type and enter the command 
printbin ABCVPN5050-1.bin 
where ABCVPN5050-1.bin is the name of the binary license file. 

11. Review the license file, which looks similar to: 
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MessageType="Capability response"
ServerIDType=String
ServerID=BACK_OFFICE
SourceIds=BACK_OFFICE
Lifetime=86400
ResponseTime="Sep 18, 2015 10:57:19 AM"
RequestHostID=ABCVPN5050-1
RequestHostIDType=String
MachineType=Unknown
EnterpriseID=61135
License=(Name=Encryption_Throughput Vendor=demo Version=1.0
    Expires=18-sep-2016 Count=10 HostID=ABCVPN5050-1 Issued=18-sep-2015
    Start=17-sep-2015 Issuer="My Corporation")

Claiming a Device and Mapping an Additional Product Entitlement
In this exercise, you claim standalone device ABCVPN5050-2 on the End-User Portal and map an additional 10 Mbps 
of encryption throughput to it. 

Task To claim standalone device ABCVPN5050-2 and map the ABC VPN 5000 Encryption Throughput (10 Mbps) 
product entitlement to it 

1. In the End-User Portal, click Activation & Entitlements > List Entitlements. The List Entitlements page for 
Barry Photography Studio appears. 

2. Copy the activation ID for the 10MbpsVPN5000 product. 

3. Click Devices > Claim and Activate. The Claim and Activate page for Barry Photography Studio appears. 

4. In the Device ID field, type ABCVPN5050-2. 

5. In the Activation IDs field, paste the activation ID you copied in Step 2 and click Validate. The entitlement for 
10MbpsVPN5000 is listed with Available qty, Product, and Expiration details. 

6. In the Qty to add field, type 1 to represent 10 Mbps of additional encryption throughput. 

7. Click Save. The device’s default view appears with this message: Entitlements successfully mapped. Under 
Licenses, note that the Status of 10MbpsVPN5000, Version 1.0 is License not generated. 

8. Click Action > Download Capability Response to generate the license. When asked if you want to open or 
save the binary license file, save it as <FlexNet_Embedded_install_dir>\bin\tools\ABCVPN5050-2.bin. The 
exact behavior varies slightly, depending on your browser and operating system. 

9. On the device’s default view, click View and select View History from the menu. On the Device History page 
that appears, review the Time, Event, and Additional Details of each line in the list. 

10. Click Devices > Devices and click the ABCVPN5050-2 link. On the device’s default view, note that the Status of 
the 10MbpsVPN5000 product is now License generated. 

11. In the command prompt window, type and enter the command 
printbin ABCVPN5050-2.bin 
where ABCVPN5050-2.bin is the name of the binary license file you saved in Step 8. 

12. Review the license file, which looks similar to: 
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MessageType="Capability response"
ServerIDType=String
ServerID=BACK_OFFICE
SourceIds=BACK_OFFICE
Lifetime=86400
ResponseTime="Sep 18, 2015 1:11:29 PM"
RequestHostID=ABCVPN5050-2
RequestHostIDType=String
MachineType=Unknown
EnterpriseID=61135
License=(Name=Encryption_Throughput Vendor=demo Version=1.0
    Expires=18-sep-2016 Count=10 HostID=ABCVPN5050-2 Issued=18-sep-2015
    Start=17-sep-2015 Issuer="My Corporation")

Activating a Device’s Pre-Installed and Additional Product Licenses
In this exercise, you use a capability request to automatically create standalone device ABCVPN5050-3, claim it for 
customer account BarryPhoto, map the VPN5050 and 10MbpsVPN5000 product entitlements to it, and activate 
the licenses. 

Task To activate the pre-installed product and additional product licenses of standalone device ABCVPN5050-3 

1. In the End-User Portal, click Activation & Entitlements > List Entitlements. The List Entitlements page 
appears. 

2. In the table, note that Available quantity and Total quantity for pre-installed product VPN5050 are both 5. 
Also note the VPN5050 Activation ID; you will use it in Step 4. 

3. In the table, note that Available quantity is 8 and Total quantity is 10 for product 10MbpsVPN5000. Also note 
the 10MbpsVPN5000 Activation ID; you will use it in Step 4. 

4. In the command prompt window, type and enter the following command to create the activation request for 
pre-installed product VPN5050 and additional product 10MbpsVPN5000: 

caprequestutil -id IdentityClient.bin -host ABCVPN5050-3 -type FLX_CLIENT 
-activate activation_ID_A 1 -activate activation_ID_B 1 mycapabilityrequest.bin 

where IdentityClient.bin contains publisher demo and publisher identity ABCNetworks you added in the Setup 
topic, activation_ID_A is the pre-installed product VPN5050 activation ID, activation_ID_B is the product 
10MbpsVPN5000 activation ID, and mycapabilityrequest.bin is the activation request in binary format. 

5. When the command prompt returns, type and enter the following command to print the activation request for 
pre-installed product VPN5050 and product 10MbpsVPN5000:

printbin mycapabilityrequest.bin

6. Review the activation capability request, which looks similar to: 

MessageType="Capability request"
Vendor=demo
MessageTime="May 7, 2016 1:43:48 PM"
ResponseTime="Dec 31, 1969 6:00:00 PM"
SourceIds=ABCVPN5050-3
RequestHostIDType=String
RequestHostID=ABCVPN5050-3
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MachineType=Unknown
HostType=FLX_CLIENT
IsServer=false
IdentityName=ABCNetworks
DesiredRights=(ActivationID=b890-f02f-b5f2-45e8-808a-86fd-3341-7d42:1
    ActivationID=a931-4c60-1080-4a92-8e8b-1e62-eebe-8a53:1)
RequestOperation="Normal request"

7. In the End-User Portal, click Devices > Offline Device Management. The Offline Device Management page 
appears. 

8. For Upload type, select Generate license. Click Browse and select the mycapabilityrequest.bin activation 
request file in the <FlexNet_Embedded_install_dir>\bin\tools directory, then click Upload. 

9. Download the capability response file using the link offered by the application and save the file as 
<FlexNet_Embedded_install_dir>\bin\tools\ABCVPN5050-3.bin. The exact behavior varies slightly, 
depending on your browser and operating system. 

10. In the command prompt window, type the command 

printbin ABCVPN5050-3.bin

where ABCVPN5050-3.bin is the name of the capability response file you saved in Step 9. 

11. Review the capability response, which looks similar to: 

MessageType="Capability response"
ServerIDType=String
ServerID=BACK_OFFICE
SourceIds=BACK_OFFICE
Lifetime=86400
ResponseTime="May 8, 2016 9:13:43 AM"
RequestHostID=ABCVPN5050-3
RequestHostIDType=String
MachineType=Unknown
EnterpriseID=61135
License=(Name=Encryption_Throughput Vendor=demo Version=1.0
    Expires=8-may-2017 Count=10 HostID=ABCVPN5050-3 Issued=8-may-2016
    Start=7-may-2016 Issuer="My Corporation")
License=(Name=SimultaneousUsers Vendor=demo Version=1.0 Expires=8-may-2017
    Count=5 HostID=ABCVPN5050-3 Issued=8-may-2016 Start=7-may-2016
    Issuer="My Corporation")
License=(Name=Redundancy Vendor=demo Version=1.0 Expires=8-may-2017
    Uncounted HostID=ABCVPN5050-3 Issued=8-may-2016 Start=7-may-2016
    Issuer="My Corporation")
License=(Name=Encryption_Throughput Vendor=demo Version=1.0
    Expires=8-may-2017 Count=5 HostID=ABCVPN5050-3 Issued=8-may-2016
    Start=7-may-2016 Issuer="My Corporation")

12. In the End-User Portal, click Activation & Entitlements > List Entitlements. The List Entitlements page 
appears. 

13. On the List Entitlements page, note that VPN5050 Available quantity is 4 and Total quantity is 5, and that 
10MbpsVPN5000 Available quantity is 7 and Total quantity is 10. 

14. Log out of the End-User Portal or continue with License Servers. 
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Devices: Next Steps
This topic introduced FlexNet Embedded standalone devices, device management, and activation of a device’s 
licenses. In the next topic, you are introduced to FlexNet Embedded license servers and license server 
management. 

Devices: Advanced Topics
For more information about these topics, refer to Administering Device and License Server Setup. 

Activations of Entitlements Across Multiple Accounts on a Single Device 
Producers with the FlexNet Advanced Organization module that use FlexNet Embedded licensing technology can 
take greater advantage of their account hierarchies and channel partner sets during entitlement mapping 
operations. This capability also supports producers who want end users to be able to activate entitlements on any 
device. 

FlexNet Operations enables accounts, other than the device owner, to map entitlements to a device. Producers 
can map entitlements from the device owner's sub-accounts to any device, and End-User Portal users can map 
entitlements from their account, or its sub-accounts, to any device visible to them. 

Activate Remaining Available Copies of an Entitlement 
The FlexNet Embedded client API has a “partial” option when specifying activation IDs for a capability request 
intended for the back office. It is now possible to request, if there are insufficient copies of the entitlement to 
satisfy the request, that the back office instead activate the remaining available copies. Without this option, such 
a request would fail with a message indicating that the number of copies requested exceeds the available copies. 
With the option, the request succeeds with a status message indicating that the request was only partially 
fulfilled. 

This partial option can be added for each activation code requested. For example,

-activate activation-id [copies] [partial] 

Note • The partial option does not take into consideration optional limits imposed by the device series. 

Refer to your FlexNet Embedded API documentation for details. 

Device Series and Device Models 
A device series is a collection of device models that are physically identical but can be upgraded in the field 
through license changes and products that are added on. The device series sets the maximum limits for device 
capabilities. 

A device model is a basic configuration for which a producer creates a pre-installed license defining a set of 
capabilities within the maximum limits for the device series. The device model with that particular pre-installed 
license represents a purchasable configuration for the device. The capability of the model can be increased to the 
maximum for the series. 

In the following example, producer ABC Networks, Inc. has a VPN 5000 device series that includes three device 
models: VPN 5005, VPN 5020, and VPN 5050. Each model represents a different basic configuration. 
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In the VPN 5000 device series, all device models can have up to 10,000 simultaneous users, up to 100 Mbps of 
throughput, and redundancy enabled or disabled. 

The VPN 5050, the device model in the series with the highest basic capabilities, has a basic configuration of 
5,000 simultaneous users, 50 Mbps of throughput, and redundancy enabled. 

Two VPN 5000 series products that can be added on are an additional 1,000 simultaneous users and an 
additional 10 Mbps of throughput. All device models in the series can be upgraded by a customer to the 
maximum limits for devices in the VPN 5000 series. 

Claiming an Unknown Device 
If unknown device support is enabled for their site, a customer can claim an unknown device—a device that was 
not created using the Producer Portal—in one of the following ways: 

• The device makes a capability request to FlexNet Operations. 

• The customer uses the device ID to claim the device through the End-User Portal. The device is no longer 
unknown because it is associated with an account. 

Mapping an Entitlement to a Device Using an Activation ID 
Devices often include pre-installed products, but also permit the optional addition of new products. When the 
current owner of a device is entitled to additional products, the additional products can be mapped 
programmatically to the device using an activation ID. 

Viewing Device Details and History 
Use the FlexNet Operations Producer Portal to view details about a device such as device ID, status, host type, as 
well as details about any pre-installed or additional products. You can also view the history specific to a single 
device. The device history page lists all the device events including device creation, changes, and activation 
requests. 
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Associating a Device with an End User 
A FlexNet Operations device can be associated with an end user or contact called the Device User. Associating a 
device with a Device User allows an End-User Portal administrator to communicate with someone regarding the 
licenses on that device. For example, if the End-User Portal administrator needs a license for a new device but 
there are no licenses available, the administrator can search for all existing devices using that license and 
request that one of those Device Users return their license so it can be used on the new device. 

With the proper combination of system configuration and user permission settings, a Device User can be added, 
edited, or deleted via capability request, sync request, the End-User Portal, the Producer Portal, or Web Services. 
The same Device User can be associated with multiple devices, but a device can only be associated with one 
Device User. 

Removing Licenses from a Device 
A license for a device’s added-on product can be manually removed in the Producer Portal via the device’s default 
view. 

Moving a Device 
A device that has not yet been assigned to a customer account can be moved to a related account in the Producer 
Portal via the device’s default view. For example, a parent account can move a device from one of its child 
accounts (a regional division, for instance) to another child account. 

When a device is moved, entitlements that belong to that device are moved as well. The result of such a move is 
to either create new entitlements for the receiving account or to increment the count of that account’s existing 
(and matching) entitlements by the count on the device that was moved. 

Returning a Device 
A device can be returned in the Producer Portal via the device’s default view. Returns are irreversible actions 
intended for devices that will no longer receive a capability response or license file. 

When customer returns a malfunctioning device to a manufacturer or reseller, the customer has the option of 
moving all of that device’s licenses to a replacement device. Licenses that are not moved are returned to the pool 
of unused licenses and can be allocated to another device later. 

Upgrading a Device 
An upgrade is defined as moving a customer from a specified version of a product to an improved version with 
new or expanded capabilities. First, in the Producer Portal, create a product with additional features, configure 
FlexNet licensing for that product, and create an entitlement to the product for the customer account. 

Note • The customer must remove the device’s previous licenses before mapping an entitlement for the new 
version of the product. 

Managing Hardware Returns 
When FlexNet Embedded is used to license hardware, the Return Material Authorization (RMA) process is used to 
return a malfunctioning device to a producer or reseller and replace it with a new one. Some or all of the licenses 
can be moved to the replacement device. If a license is not moved, it is returned to the pool of unused licenses 
and can be allocated to another device. 
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Making a Device Obsolete 
An active device can be made obsolete from its default view on the Producer Portal. When a device is made 
obsolete, its licenses are removed and returned to the pool, and it becomes unable to acquire new license rights. 
Obsolete devices cannot be re-activated. Obsolete status is permanent.

Offline Activation 
Some devices use an offline activation model in which the device generates a binary license request file for an 
additional product license. The request file can be manually uploaded on the FlexNet Operations End-User Portal. 

FlexNet Operations processes the request file to generate a license. If the license request is for an existing 
device, FlexNet Operations generates a regenerative license. This means that each response contains the 
complete state of capabilities for the device and that calling the FlexNet Embedded library to process the 
response overwrites the existing state. Each capability response completely replaces the previous response. 

If the request is made for a new device, FlexNet Operations enters the device into the system, adds the 
corresponding additional product, and generates a license for it. 

Vendor Dictionary 
The FlexNet Embedded capability request allows a device to send producer-specific information called a vendor 
dictionary. A vendor dictionary is a collection of name value parameters that are defined by the producer, such as 
GPS coordinates, time zone, and region. The vendor dictionary provides an interface for an implementer to send 
custom data in addition to the FlexNet Embedded-specific data from the device to server or vice versa. This data 
can be used in license-enabled code and the back office server to send information back and forth for any 
producer-defined purposes, as needed. 

Rehosting a License 
Rehosting licenses is defined as the process of transferring licenses from one device to another. 

Note • The customer must remove a device’s licenses before they can be transferred to another device. 

Generating a Trial License 
A trial license enables a customer to demonstrate a product for trial purposes. The license expires after a short 
period of time. 

License Servers
This topic introduces FlexNet Embedded license servers and typical tasks performed for a license server. These 
tasks include creating a FlexNet Embedded license server and mapping an entitlement for an additional product 
to a license server. 

The exercises in this topic guide you through the basic FlexNet Embedded license server work flows. 

• License Servers: Key Concepts

• License Server: Exercises

• License Server: Advanced Topics
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License Servers: Key Concepts
FlexNet Embedded License Servers 
The FlexNet Embedded license server communicates with FlexNet Operations to manage devices and product 
features for a collection of served devices. If a FlexNet Embedded license server is used, served devices connect 
to this server rather than connecting directly to FlexNet Operations. 

The FlexNet Embedded license server provides functionality for serving and monitoring a counted pool of licenses 
for intelligent device or software clients. The license server application administers licenses, enforces usage 
count, and provides served license status information in conjunction with client code that incorporates FlexNet 
Embedded licensing. 

FlexNet Embedded license servers can be hosted in the Revenera cloud (Revenera’s Cloud License Service must 
be purchased separately) or locally deployed in a customer’s enterprise; the hosting approach depends on the 
account’s deployment needs. The following figure shows the FlexNet Embedded license server’s role in the 
FlexNet Embedded architecture.  

Mapping Additional Product Entitlements to a License Server 
Additional product entitlements are mapped to a FlexNet Embedded license server the same way they are 
mapped to a FlexNet Embedded standalone device. When the server activates with FlexNet Operations, its 
additional product entitlements can be served to local devices. Licenses for additional products can also be 
removed from a license server. 

Viewing Served Devices 
Served devices refers to FlexNet Embedded devices that are managed by a FlexNet Embedded license server. In 
FlexNet Operations, served devices are read-only entities. 
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For a FlexNet Embedded license server deployed in the customer’s enterprise, served device data is only 
available when the server is syncing with the FlexNet Operations back office. License servers hosted in the 
Revenera cloud automatically sync with the back office. 

License Server: Exercises
These exercises use examples to guide you through the following FlexNet Embedded license server tasks: 

Creating a FlexNet Embedded License Server
In this exercise, you use the End-User Portal to create the ABCVPN_Server local license server for FlexNet 
Embedded devices. The ABCVPN_Server local license server can also be created in the Producer Portal. 

Task To create FlexNet Embedded license server ABCVPN_Server 

1. If you have not already done so, log in to the End-User Portal as Lisa Barry, the Barry Photography Studio 
end user you created in the exercise in the section Getting Started with Entitlement Management. 

2. Click Devices > Create Device. The Device | New Device page appears. 

3. In the Name field, type ABCVPN_Server. 

4. Select the Runs license server? check box. 

5. For Server deployment, select Local. 

6. On the ID drop-down menu, select ETHERNET. In the Primary ID field, type ABCVPN_Server. 

7. Click Save. On the View Server page that appears, review the server details. Under Model Details, note that 
this server does not include any pre-installed product and that no additional product entitlements are 
currently mapped. 

Mapping Additional Product Entitlements to a License Server
In this exercise, you use the End-User Portal to map 3 copies of product 10MbpsVPN5000 to the ABCVPN_Server 
server. 

Exercise Description

Creating a FlexNet 
Embedded License 
Server

In the End-User Portal, create the ABCVPN_Server license server for FlexNet 
Embedded devices. 

Mapping Additional 
Product Entitlements to 
a License Server

In the End-User Portal, map 3 copies of product 10MbpsVPN5000 to the ABCVPN_Server 
license server. 
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Note • If you just completed the Creating a FlexNet Embedded License Server exercise, you can start with Step 3 
of this exercise. 

Task To map 3 copies of product 10MbpsVPN5000 to license server ABCVPN_Server 

1. In the End-User Portal, click Devices > Devices. The Devices page appears. 

2. In the devices list, click the ABCVPN_Server link. The View Server page appears with the server details. 

3. Click Action and select Map Entitlements from the menu. The Map Entitlements page appears with server 
details and additional products available. 

4. On the 10MbpsVPN5000, Version 1.0 line of the table, type 3 in the Qty to add field. 

5. Click Save. The View Server page appears with this message: Entitlements successfully mapped. Note that 
the Status of the 10MbpsVPN5000, Version 1.0 product is License not generated. 

6. Click Action > Download Capability Response to generate the license. When asked if you want to open or 
save the binary license file, save it as <FlexNet_Embedded_install_dir>\bin\tools\ABCVPN_Server.bin, where 
<FlexNet_Embedded_install_dir> is the directory in which your FlexNet Embedded licensing toolkit is 
installed. The exact behavior varies slightly, depending on your browser and operating system.

7. Under View Server, click View and select View History from the menu. On the Server History page that 
appears, review the Time, Event, and Additional Details of each line in the list. 

8. Click Devices > Devices and click the ABCVPN_Server link. On the View Server page, note that the server does 
not include any pre-installed product and the Status of the 10MbpsVPN5000 product is now License generated. 

9. To use the FlexNet Embedded printbin tool to view the contents of the binary license file: 

a. Open a command prompt window. 

b. In the command prompt window, navigate to navigate to <FlexNet_Embedded_install_dir>\bin\tools, 
the directory in which you saved the license file in Step 6. 

c. At the prompt, type the command 
printbin ABCVPN_Server.bin 
where ABCVPN_Server.bin is the name of the binary license file. 

10. Review the license file, which looks similar to: 

MessageType="Capability response"
ServerIDType=String
ServerID=BACK_OFFICE
SourceIds=BACK_OFFICE
Lifetime=86400
ResponseTime="Sep 18, 2015 5:22:51 PM"
RequestHostID=ABCVPN_Server
RequestHostIDType=Ethernet
MachineType=Unknown
EnterpriseID=61135
License=(Name=Encryption_Throughput Vendor=demo Version=1.0

Expires=18-sep-2016 Count=30 ServerHostID=ABCVPN_Server/Ethernet HostID=ANY
BorrowInterval=”1 week(s)” RenewInterval=20 Issued=18-sep-2015
Start=17-sep-2015 Issuer="My Corporation")
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11. In the End-User Portal, click Activation & Entitlements > List Entitlements. The List Entitlements page 
appears. 

12. On the List Entitlements page, note that VPN5050 Available quantity is 4 and Total quantity is 5, and that 
10MbpsVPN5000 Available quantity is 4 and Total quantity is 10. 

13. Log out of the End-User and Producer Portals. 

License Server: Advanced Topics
Activations of Entitlements Across Multiple Accounts on a Single Device 
Producers with the FlexNet Advanced Organization module that use FlexNet Embedded licensing technology can 
take greater advantage of their account hierarchies and channel partner sets during entitlement mapping 
operations. This capability also supports producers who want end users to be able to activate entitlements on any 
device. 

FlexNet Operations enables accounts, other than the device owner, to map entitlements to a device. Producers 
can map entitlements from the device owner's sub-accounts to any device, and End-User Portal users can map 
entitlements from their account, or its sub-accounts, to any device visible to them. 

Activate Remaining Available Copies of an Entitlement 
The FlexNet Embedded client API has a “partial” option when specifying activation IDs for a capability request 
intended for the back office. It is now possible to request, if there are insufficient copies of the entitlement to 
satisfy the request, that the back office instead activate the remaining available copies. Without this option, such 
a request would fail with a message indicating that the number of copies requested exceeds the available copies. 
With the option, the request succeeds with a status message indicating that the request was only partially 
fulfilled. 

This partial option can be added for each activation code requested. For example,

-activate activation-id [copies] [partial] 

Note • The partial option does not take into consideration optional limits imposed by the device series. 

Refer to your FlexNet Embedded API documentation for details. 

Associating a Server with an End User
A FlexNet Operations server can be associated with an end user or contact called the Device User. Associating a 
server with a Device User allows an End-User Portal administrator to communicate with someone regarding the 
licenses on that server. For example, if the End-User Portal administrator needs a license for a new device but 
there are no licenses available, the administrator can search for all existing devices using that license and 
request that one of those Device Users return their license so it can be used on the new device. 

With the proper combination of system configuration and user permission settings, a Device User can be added, 
edited, or deleted via capability request, sync request, the End-User Portal, the Producer Portal, or Web Services. 
The same Device User can be associated with multiple devices, but a device can only be associated with one 
Device User. 
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Mapping a Product to a License Server Using an Activation ID 
License servers often include pre-installed products but also permit the optional addition of new products. When 
the current owner of a license server is entitled to additional products, those products can be mapped 
programmatically to the license server using an activation ID. 

Removing Product Licenses from a License Server
Licenses for additional products that are mapped to a license server can be manually removed via the Producer 
Portal’s View Server page. 

Note • The following limitations exist for auto-provisioned license servers that have entitlements mapped for 
metered features: 

• License servers cannot be moved to another account.

• You cannot remove licenses using Licenses > Remove Licenses.

• License servers can be made obsolete, which will remove all licenses mapped to the server. However, this is 
not recommended, because future line items will not be mapped automatically to the auto-provisioned 
license server. 

Moving a License Server 
A license server can be moved from an account to a related account via the Producer Portal’s View Server page. 

Note • Auto-provisioned license servers that have entitlements mapped for metered features cannot be moved to 
another account. Refer to Auto-Provisioning for more information.

Returning a License Server 
A license server can be returned via the Producer Portal’s View Server page. Returns are irreversible actions 
intended for server hosts that will no longer receive a capability response or license file. 

Making a License Server Obsolete 
An active license server can be made obsolete from its View Server page on the Producer Portal. When a license 
server is made obsolete, its licenses are removed and returned to the pool of unused licenses, and it becomes 
unable to acquire new license rights. Obsolete license servers cannot be re-activated. Obsolete status is 
permanent. 

Note • Making an auto-provisioned license server obsolete that has entitlements mapped for metered features 
will remove all licenses mapped to the server. However, this is not recommended, because future line items will 
not be mapped automatically to the auto-provisioned license server. Refer to Auto-Provisioning for more 
information.
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Activating an Unclaimed FlexNet Embedded License Server 
A FlexNet Embedded license server can be created in the Producer Portal, but an unclaimed license server can be 
created by submitting an activation request to the FlexNet Operations back office. The request must include an 
activation code and host information. When it receives such a request, FlexNet Operations creates the license 
server and maps the activation code to that license server with the requested quantity. 

Note • A site can be configured so that an activation code is not required to create an unclaimed license server. 

FlexNet Operations processes activation requests from an unclaimed license server using the default server host 
type FLX_SERVER, then assigns the FLX_SERVER server host type to each license server created through this 
process—thereby defining the server’s identity. 

Note • The pre-defined server host type, FLX_SERVER, is associated, by default, with the first identity a producer 
creates. 

Viewing License Server Request History 
You can view the history of all license server requests and filter the history by ID and date range. 

Using Server Sync to Send License Transaction Data to FlexNet Operations 
As transactions occur between a FlexNet Embedded server and its FlexNet Embedded devices, the license server 
incrementally updates the device status and activation data it stores. When syncing is enabled, the license server 
syncs with FlexNet Operations, providing the back office with information about how customers use served 
devices and what features they use. Sync data transmission to FlexNet Operations is configured by the device 
producer when the FlexNet Embedded license server is configured. 

Note • Sync messages can be viewed by viewing the device’s history. The history of a FlexNet Embedded license 
server shows sync messages related to all its served devices, while the history of a served device shows only the 
messages specific to that served device. 

Usage 
Refer to Getting Started with Usage Management for information about FlexNet usage management concepts, 
exercises, and advanced activities. 
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Getting Started with 
FlexNet Publisher Trusted 
Storage-Based Licensing

This section Getting Started with FlexNet Publisher Trusted Storage-Based Licensing introduces fundamental 
FlexNet Operations concepts and uses exercises to guide a Producer Portal user through basic trusted storage 
license activation and support. The intended audience for this getting started section is the first-time Producer 
Portal user, or one without FlexNet Operations training or experience. 

Introduction
This section lists exercise prerequisites, provides a summary of the FlexNet Operations license lifecycle, 
describes the FlexNet Publisher Licensing Toolkit, and explains how to configure your machine for trusted 
storage. 

• Exercise Prerequisites

• The License Lifecycle: FlexNet Publisher Trusted Storage-Based Licensing

Topic Description

Introduction Overview of this getting started section, exercise prerequisites, 
summary of the FlexNet Operations license lifecycle, description of the 
FlexNet Publisher Licensing Toolkit, and how to configure your 
machine for trusted storage. 

Trusted Storage License Activation FlexNet Operations trusted storage licensing concepts and exercises 
that demonstrate how to generate a trusted storage license. Brief 
descriptions of advanced trusted storage license activation topics and 
cross references to documents that contain more information. 

Trusted Storage License Support FlexNet Operations trusted storage licensing concepts and exercises 
that demonstrate how to return a trusted storage license. Brief 
descriptions of advanced trusted storage license activation topics and 
cross references to documents that contain more information. 
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• FlexNet Publisher Licensing Toolkit

• Configuring Your Machine for Trusted Storage

• Next Steps

Exercise Prerequisites
Before you begin the exercises in this getting started section:

• FlexNet Operations must be properly installed and configured

• FlexNet Operations seed data and demonstration database must be loaded 

Important • These exercises require a FlexNet Operations database populated with demonstration data. 
Refer to the step-by-step instructions in the FlexNet Operations On-Premises Installation & Implementation 
Guide to create seed data using the flexnet loaddb command and to populate the sample data using the 
flexnet demodata command.

• You must have a FlexNet Operations Producer Portal login and a role with permission to view and manage 
accounts and users, such as System Administrator 

• You must complete the exercises in the section Getting Started with Entitlement Management 

• The FlexNet Publisher Licensing Toolkit must be properly installed and configured 

Important • Refer to the instructions in the FlexNet Publisher Installation Guide to download and install the 
licensing toolkit, and to the FlexNet Publisher document “Getting Started with Trusted Storage-Based 
Licensing” for using the example files provided in the licensing toolkit. 

The License Lifecycle: FlexNet Publisher Trusted Storage-
Based Licensing

The FlexNet Operations license lifecycle is a repeating process of producer and customer activities, as depicted in 
the figure and described below. 
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Figure 10-1:  FlexNet Operations License Lifecycle

• Create Products – Create product definitions that are used to generate licenses. 

• Order/Entitle – Define a customer account’s rights to obtain licenses for your products. 

• Deliver⁄Install – Deliver the application software to the customer and install that software. 

• Activate – Deliver licenses to the customer. 

• Return/Rehost – Manage license transfers from one user or system to another. 

• Maintain/Update – Deliver software and license updates to the customer. 

• Upsell/Renew – Renew customer licenses, or sell the customer additional product functionality. 

FlexNet Publisher Licensing Toolkit
Windows Platform 
The exercises in this getting started section require a FlexNet Publisher Licensing Toolkit installed on a Windows 
platform (either the i86_n3 or x64_n6 toolkit). Each exercise uses sample utilities and executables included in the 
Windows toolkit. The same components are included in UNIX toolkits. However, to perform the exercises on a 
UNIX machine, you must adjust the path and file name syntax for the UNIX environment. 
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Activation Utilities 
FlexNet Publisher Licensing activation utilities are designed so that the end user can enter required input via 
explicit command line arguments. The exercises in this getting started section use command line arguments to 
issue activation commands. These arguments represent one way of supplying input to the utilities; this method 
can differ from your specific requirements as a publisher. 

Commands are issued in relation to the platform directory under the FlexNet Publisher Licensing Toolkit 
installation directory. For example, if the Windows 64-bit toolkit is installed, commands are issued from a 
command prompt in the x64_n6 directory. 

License Server Manager 
The license server manager forwards connections from a FlexEnabled application to the correct vendor daemon, 
which is the part of the license server that authenticates requests and serves licenses. When an exercise requires 
a license server manager, lmadmin is used. 

Note • If necessary, you can use the alternative license server manager, lmgrd, in place of lmadmin. 

The exercises use the sample vendor daemon, called demo, included in the licensing toolkit. 

Toolkit Directories 
It is assumed, for exercises in this getting started section, that FlexNet Operations is installed on a Windows 
machine. The table below lists the toolkit directories, with their shortcut names, referenced in the exercises. 

Become familiar with the FlexNet Publisher Licensing Toolkit directory structure for your installation before 
proceeding; these shortcuts are used throughout the getting started section. 

Configuring Your Machine for Trusted Storage
Before starting the license activation and support exercises, configure your machine to use trusted storage. The 
configuration type depends on your machine’s platform: 

• Installing the Licensing Service (on Windows)

• Initializing the Trusted Storage Directory (on UNIX) 

Normally, for a licensed product, configuration occurs as part of product installation and is performed only once 
on a given machine. 

Shortcut Name Location 

<install_dir> No default. Path is defined at toolkit installation time. 

<platform_dir> <install_dir>\i86_n3 (or <install_dir>\x_64_n6) 

<publisher> <install_dir>\i86_n3\publisher (or <install_dir>\x64_n6\publisher) 



Chapter 10 Getting Started with FlexNet Publisher Trusted Storage-Based Licensing
Introduction

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 405

Installing the Licensing Service (on Windows)
On a Windows machine, configuration for trusted storage requires installing the FlexNet Publisher Licensing 
Service and registering the product that is using the service. This procedure uses the example executable 
installanchorservice.exe. 

Task To install FlexNet Publisher Licensing Service 

1. On the Start Menu of your machine, right-click the Windows Command Prompt and select Run as 
administrator. 

2. To install the FlexNet Publisher Licensing Service and register product PhotoPrint-client that is supplied by 
publisher demo, at a command prompt in the <platform_dir>, enter 

installanchorservice demo PhotoPrint-client 

The output is 

Successfully installed anchor service for publisher demo, product PhotoPrint-client 

For product PhotoPrint-server that is supplied by publisher demo, at a command prompt in the 
<platform_dir>, enter 

installanchorservice demo PhotoPrint-server 

The output is 

Successfully installed anchor service for publisher demo, product PhotoPrint-server 

Initializing the Trusted Storage Directory (on UNIX)
On a UNIX machine, configuration for trusted storage requires initializing the trusted storage directory. 
Additionally, for OS X and Linux machines, configuration also requires installing the FlexNet Publisher Licensing 
Service. This procedure uses the example script installfnp.sh. 

Note • On OS X platforms, your user account must have sudo privileges to perform this procedure. On all other 
UNIX platforms, you must have root permission to perform this procedure. 

Task To initialize the trusted storage directory (and install the FlexNet Publisher Licensing Service, if required) 

Perform the appropriate step at a command prompt in the <publisher> directory: 

• On a UNIX machine, enter the command: 

sh install_fnp.sh 

• On an OS X machine, enter the command: 

sudo sh install_fnp.sh 

The output is 

Configuration completed successfully. 
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Resetting Trusted Storage
If this is your first time through the trusted storage exercises, proceed to Starting the FlexNet License Server. 
Otherwise, use this procedure to remove any client-side and server-side trusted storage files from previous 
exercises. 

Important • The utilities tsreset_app and tsreset_svr are provided for use with exercises and are not intended to 
be shipped to an end-user site. 

Task To reset trusted storage 

1. To shut down all license servers that might be running, in the <platform_dir>, enter 

lmdown -all 

2. To delete any client-side trusted-storage files, at a command prompt in the <platform_dir>, enter 

tsreset_app -delete all 

The output is 

Performing reset operation, please wait...
Trusted Storage Contents have been reset...

3. To delete any server-side trusted-storage files, at a command prompt in the <platform_dir>, enter 

tsreset_svr -delete all 

The output is 

Performing reset operation, please wait...
Trusted Storage Contents have been reset...

Starting the FlexNet License Server
Use this procedure to import the vendor daemon demo and start the license server that uses it. 

Task To start the license server and import the vendor daemon demo 

1. Copy files <platform_dir>\demo.exe and <platform_dir>\demo_libFNP.dll to the 
<platform_dir>\lmadmin\demo directory. 

Note • On UNIX platforms, copy files <platform_dir>/demo and <platform_dir>/demo_libFNP.so to the 
<platform_dir>/lmadmin/demo directory. On AIX, copy demo and demo_server_libFNP_notr.so. 

2. To import the vendor daemon demo and use the demo.lic license file, at a command prompt in the 
<platform_dir>\lmadmin directory, enter 

lmadmin -import demo\demo.lic -force 

The output is 

Configured new vendor daemon, demo. 
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3. To start the license server in the background, from a command prompt in the <platform_dir>\lmadmin 
directory, enter 

lmadmin -allowRemoteStopServer yes 

Next Steps
The next topic introduces trusted storage licenses and their activation, the stage of the FlexNet Operations 
license lifecycle that follows delivery of the product’s activation IDs to the customer. 

Trusted Storage License Activation
This topic introduces trusted storage licenses and their activation, the stage of the FlexNet Operations license 
lifecycle that follows delivery of the product’s activation IDs to the customer. Activation is the process of 
requesting, generating, delivering, and installing license rights. 

The exercises in this topic getting started section you through basic FlexNet Operations trusted storage license 
activation. 

Note • To use the exercises in this topic, you must be familiar with the FlexNet Publisher Licensing Toolkit. For 
more information, refer to the FlexNet Publisher document  “Getting Started with Trusted Storage-Based 
Licensing”. 

Trusted Storage License Activation Key Concepts
After a product purchase has been registered with FlexNet Operations as an entitlement, a customer can obtain a 
license for the product. The license enables use of some or all of the product’s features, and contains information 
about the computers on which the software is to run, the expiration date, and the count of the entitlement’s 
available quantity that have been activated. Before the license can be generated, the entitlement must be 
validated (marked as deployed) in FlexNet Operations. 

Trusted Storage License Models
Trusted storage models enable programmatic activation, that is, activation of license rights on a machine using a 
process that is completely hands-free and transparent to the user. 

Trusted storage license models include these types: 

• A retail activation license model is used in a retail scenario for activation of license rights in trusted storage 
on a standalone end-user machine. Unlimited instances of the licensed application can be run on that 
machine. You create a product that uses a retail activation model as one of the Client-Side Online Activation 
exercise prerequisites. 

• A floating transferable license model allows license rights to be written to the trusted storage of a license 
server. The license server can then transfer these rights to another server, or allow them to float over a 
network from which end users check them out. These license rights cannot be activated directly on end-user 
machines. 



Chapter 10 Getting Started with FlexNet Publisher Trusted Storage-Based Licensing
Trusted Storage License Activation

408 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

• A floating borrowable license is first activated on a license server. It can be transferred to another license 
server, served as a floating license, or activated on an end-user machine for use when it is no longer 
connected to a license server. 

• An enterprise activation license model is used to activate license rights on an enterprise server, from which 
the license rights can be transferred to another server or activated on an end-user machine. These licenses 
cannot float over a network. You create a product that uses an enterprise activation model as one of the 
Server-Side Online Activation exercise prerequisites. 

License rights data in trusted storage is encrypted and authenticated to prevent tampering. 

Transaction Keys 
Products that use a trusted storage license model require at least one transaction key. A transaction key consists 
of a publisher ID, a set of transaction key seeds, binding, and anchors. Binding ensures that license rights held in 
trusted storage are not copied to another system, while anchors detect whether trusted storage has been 
tampered with, deleted, or restored. 

A transaction key is linked with a product only if the product uses a trusted storage license model. The 
transaction key is linked with the product when the first trusted storage license model is linked with the product, 
and can be changed later or overridden. You must create at least one transaction key before linking a trusted 
storage license model with a product. Unlike license models, it is not necessary to deploy transaction keys. 

You create a transaction key as one of the Client-Side Online Activation exercise prerequisites. 

Generating Trusted Storage Licenses 
Trusted storage is a technology, used by FlexEnabled applications to store license rights, that allows hands-free 
activation. Users can obtain trusted storage licenses without downloading them from a web portal; instead, 
license rights are stored in an encrypted file on the local host’s drive. 

The process of placing license rights in client trusted storage, also called activating an application, requires a 
utility on the customer’s system that communicates with FlexNet Operations. The utility sends a request for a 
particular product with particular terms. FlexNet Operations processes the request to determine if the system is 
entitled to the software, and if so, sends a response containing the corresponding license rights. The utility 
processes the response, which results in the license rights being stored in trusted storage. 

The two types of trusted storage are: 

• client-side – license rights stored on an end-user system that are checked out by a licensed application 

• server-side – counted license rights stored on a license server system that are served in a corporate network 

Activation Utilities
The FlexNet Publisher Licensing Toolkit component that communicates with FlexNet Operations to activate 
software is called an activation utility. An activation utility that activates software on a client system is called an 
application activation utility. An activation utility that activates software to be served by a license server is called 
a server activation utility. 
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Composite Transaction and Single Transaction Activation Utilities 
FlexNet Operations provides sample client-side and server-side activation utilities that operate from the 
command line, as listed in the following table. Later releases include composite transaction activation utilities, 
which facilitate more efficient activation operations by bundling multiple transactions into a single 
communication exchange between the client or server utility and FlexNet Operations. The older, single 
transaction activation utilities are still supported for legacy purposes. 

Important • The sample utilities shown in the table are provided for use with the exercises in this getting started 
section. They are not suitable for use in a production environment. 

Using Sample Activation Utilities
The sample client-side application activation utilities, appcomptranutil and appactutil, are command-line tools 
for adding license rights to client-side trusted storage. These executables are located in the <platform_dir> of 
the FlexNet Publisher Licensing Toolkit, where platform_dir is the name of the platform on which the toolkit is 
installed. 

To use a sample application activation utility, open a command prompt or console window and set the 
<platform_dir> to be the current directory. For example, to verify that no license rights are currently available on 
the client system, enter the command 

appcomptranutil -view

or

appactutil -view

This command displays the current contents of client trusted storage, which should initially report that there are 
no fulfillment records in trusted storage. 

Similar sample utilities, servercomptranutil and serveractutil, are supplied for server-side activation, and are 
located in the same directory as the application activation utilities. 

FlexNet Operations supports three types of trusted storage license activation: 

• Online Activation 

• Short Code Activation (also called phone-based activation)

• Manual Activation (also called email-based activation)

Activation Utility Type Composite Transaction Legacy, Single Transaction 

Application (client side) appcomptranutil appactutil 

Server (server side) servercomptranutil serveractutil 
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Online Activation
Trusted activations are normally done programmatically as transactions between a client or server activation 
utility and the FlexNet Operations server. The activation utility generates a request that is submitted 
programmatically and the FlexNet Operations server generates a response that is used to complete the 
activation. 

The following sections describe the client and server utilities used to perform online trusted storage license 
activation. For syntax and options, type the utility name in the FlexNet Publisher Licensing Toolkit <platform_dir> 
command window. 

Note • The exercises in this getting started section are based on a Windows platform installation of the FlexNet 
Publisher Licensing Toolkit. To do the exercises on a UNIX machine, adjust the path and file name syntax for the 
UNIX environment. 

Client-Side Online Activation 
The client-side online activation utilities are appcomptranutil (composite transaction) and appactutil (single 
transaction). These utilities are run, in a command window on the client, with command-line parameters that 
indicate the FlexNet Operations server host and port, and the activation ID. 

Client-side activation requires a product linked to a retail activation license model. 

Composite Transaction 

For the composite transaction activation utility, appcomptranutil, the command to perform a retail activation 
looks similar to 

appcomptranutil -t http://<hostname:port>/flexnet/services/ActivationService -a <act_ID> 

where 

• <hostname> is localhost, the name of the system on which the license server is running 

• <port> is 8888 

• <act_ID> is the activation ID displayed by FlexNet Operations 

Note • For sample commands shown in this getting started section, it is assumed that FlexNet Operations and the 
activation utilities are running on the same system. If not, replace localhost:8888 with the appropriate host and 
port values. 

Progress messages are displayed at the command line. 

Multiple transactions can be invoked in a single command with appcomptranutil. To perform multiple activations 
in a single command, append additional activations to the command with -a <act_ID>. For example, 

appcomptranutil -t http://<hostname:port>/flexnet/services/ActivationService 
-a <act_ID1> -a <act_ID2> -a <act_ID3> 
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Note • To successfully perform multiple activations in a single command, all entitlements must belong to the 
same account, use the same license type (client or server), and be performed on the same machine. 

Legacy, Single Transaction 

For the single transaction activation utility, appactutil, the command to perform a retail activation looks like 

appactutil -served -comm soap -commServer http://<hostname:port>/flexnet/services/ActivationService
-entitlementID <ent_ID>

where <ent_ID> is the entitlement ID. 

Progress messages are displayed at the command line. 

New license rights for the products and features you defined in FlexNet Operations are visible in client-side 
trusted storage when you run the command 

appcomptranutil -view

or 

appactutil -view

Output is similar to 

Trust Flags: FULLY TRUSTED
Fulfillment Type: PUBLISHER ACTIVATION
Status: ENABLED
Fulfillment ID: FID__111ff222_333445555__666e
Entitlement ID: ent_ID
Product ID: NAME=Sample App;VERSION=1.0
Expiration date: 31-dec-2015
Feature line(s):
INCREMENT F1 demo 1.0 31-dec-2015 1 ISSUER="Sample Co." \
        ISSUED=1-jan-2015 START=1-jan-2015 SIGN="..."
INCREMENT F2 demo 1.0 31-dec-2015 1 ISSUER="Sample Co." \
        ISSUED=1-jan-2015 START=1-jan-2015 SIGN="..."

Server-Side Online Activation 
Server-side activation is performed in a manner similar to client-side activation, and can be performed using a 
server activation utility such as servercomptranutil or serveractutil. 

Server-side activation requires a product linked to one of the following license model types: 

• Enterprise activation 

• Floating borrowable 

• Floating transferable 

Composite Transaction 

Server-side commands using servercomptranutil are similar to client-side commands using appcomptranutil. For 
a composite transaction server activation utility, a sample command is 

servercomptranutil -t http://<hostname:port>/flexnet/services/ActivationService -a <act_ID> count=1 
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Multiple transactions can be invoked in a single command with servercomptranutil. To perform multiple 
activations in the same command, append additional activations to the command with -a <act_ID> count=n, 
where n is the number of products being activated. For example, 

servercomptranutil -t http://<hostname:port>/flexnet/services/ActivationService 
-a <act_ID1> count=x -a <act_ID2> count=y -a <act_ID3> count=z 

Note • To successfully perform multiple activations in a single command, all entitlements must belong to the 
same account, use the same license type (client or server), and be performed on the same machine. 

Legacy, Single Transaction 

Legacy, server-side commands using serveractutil are similar to client-side commands using appactutil. For a 
single transaction server activation utility, a sample command is 

serveractutil –served –comm soap –commServer http://<hostname:port>/flexnet/services/ActivationService -
entitlementID <ent_ID> -expiration 1-jan-2018 -licensemodeltype <count> 

where 

• <ent_ID> is the entitlement ID 

• licensemodeltype is one of the following: 

• activatable for an enterprise activation model 

• hybrid for a floating borrowable model 

• concurrent for a floating transferable model 

• <count> is the number of products, using licensemodeltype, that are being activated 

Trusted Storage License Activation Exercises
These exercises use examples to guide you through the following trusted storage license activation tasks: 

Important • This getting started section describes operations that are performed on the server side (referring to 
the FlexNet license server) and on the client side (referring to the machine on which the FlexEnabled application 

Exercise Description

Client-Side Online Activation Perform a client-side online activation of a PhotoPrint-client product 
license. 

Server-Side Online Activation Perform a server-side online activation of a PhotoPrint-server product 
license. 

Local Online Activation Perform a local online activation of a PhotoPrint-server product license on 
the client. 
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is installed). The exercises use the same machine for both types of operations. However, a real enterprise 
environment typically has one or more dedicated license servers that are distinct from the client machines. 

Client-Side Online Activation
In this exercise, you perform a client-side online activation of the PhotoPrint-client product license. 

Prerequisites 
Log in to the FlexNet Operations Producer Portal to: 

• Create a transaction key called TS-DemoTransKey: 

a. Click Administer > Transaction Keys 

b. Click Add a Transaction Key 

c. Under Create a Transaction Key, enter these attributes: 

• Name: Type TS-DemoTransKey 

• Description: Type Demo trans key for trusted storage licensing exercises 

• Publisher ID: Select 256-demo 

• Transaction Key Seeds: Type eight sets of eight hexadecimal digits each: 

00000000 aaaaaaaa 11111111 bbbbbbbb 

22222222 cccccccc 33333333 dddddddd 

• Binding Type: Select Default Fingerprint 

• Do you want to use Anchoring? Select Yes 

d. Click Save 

If necessary, refer to the section Getting Started with Entitlement Management to: 

• Deploy the Retail Activation license model (Deploying a License Technology and Model) 

• Copy product PhotoPrint and save it as PhotoPrint-client (Creating a Product) 

a. Click Products > Products 

b. Search for and select the PhotoPrint check box, then click Copy 

c. Under Create a Product, in the Product Name field, type PhotoPrint-client and click Save 

• Link PhotoPrint-client to the Retail Activation license model and select Transaction Key TS-DemoTransKey 
from the Default menu (Linking a License Model to a Product). Remove (unlink) the Nodelocked Uncounted 
license model and save PhotoPrint-client. 

• Deploy the PhotoPrint-client product (Deploying a Product) 

• Create and configure an entitlement called ENT-PhotoPrint-client (Creating and Configuring an 
Entitlement): 

• for end customer Lisa Barry of BarryPhoto 
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• with a product PhotoPrint-client line item for a quantity of 1 copy and a license that starts at the first 
activation date and has a duration of 1 year 

• Save and deploy the ENT-PhotoPrint-client entitlement (Deploying an Entitlement)

• If this is not your first time through the trusted storage license exercises, perform the steps in Resetting 
Trusted Storage to remove any client-side and server-side trusted storage files that might exist from previous 
exercises. 

Task To activate a license using appcomptranutil 

1. In the FlexNet Operations Producer Portal, click Entitlements > List Entitlements. The List Entitlements page 
appears. 

2. On the Activatable Line Items list, search for entitlement ID ENT-PhotoPrint-client and review the line item 
details. Note that available quantity and total quantity are 1 for product PhotoPrint-client. Expiration is in 1 
year. 

3. At a command prompt in the <platform_dir>, enter the following, where <hostname:port> is localhost:8888 
and <act_ID> is the FlexNet Operations PhotoPrint-client activation ID:  

Important • Exercises are based on the assumption that FlexNet Operations and the activation utilities are 
running on the same system. If not, replace localhost:8888 in the appcomptranutil command with the 
appropriate host and port values. 

appcomptranutil -t http://<hostname:port>/flexnet/services/ActivationService -a <act_ID> 

Output is similar to 

Server http://localhost:8888/flexnet/services/ActivationService, comms type SOAP
Status: 4, Creating request
Status: 5, Request created
Status: 6, Context created
Status: 7, Connected to remote server
Status: 8, Request Sent
Status: 9, Polling for response
Status: 10, Waiting for response
Status: 9, Polling for response
Status: 11, Done
Response processed successfully. Actions were:

Configuration TrustedId “13”
Create fulfillment “FID_d7a83787_46d6_43b1_a65b_ad85e135aa60”

4. At a command prompt in the <platform_dir>, to view the new license rights in client-side trusted storage, 
enter 

appactutil -view 

Output is similar to 

--------------------------------------------------------------------
Trust Flags: FULLY TRUSTED
Fulfillment Type: PUBLISHER ACTIVATION
Status: ENABLED
Fulfillment ID: FID_d7a83787_46d6_43b1_a65b_ad85e135aa60
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Entitlement ID: ff6a-cf25-7c72-4b15-9d49-945e-4b2f-519f
Product ID: NAME=PhotoPrint-client;VERSION=12.0
Suite ID: NONE
Expiration date: 29-Nov-2016
Feature line(s):

INCREMENT PrintToPDF demo 12.3 29-nov-2016 1 ISSUER="My Corporation" \
        ISSUED=29-nov-2015 START=28-nov-2015 SIGN="003F 469C FAA0 F579 \
        2035 9632 BDAB B500 67F2 72CE 68BA FF86 4FC8 4123 FF47"
INCREMENT Print demo 12.3 29-nov-2016 1 ISSUER="My Corporation" \
        ISSUED=29-nov-2015 START=28-nov-2015 SIGN="0072 6DC3 2310 9577 \
        9B9D 781E 36BC 0900 0E73 A2B7 C4A3 99FF BCA0 F23F 1D94"
INCREMENT PrintHighQualityColor demo 12.3 29-nov-2016 1 ISSUER="My \
        Corporation" ISSUED=29-nov-2015 START=28-nov-2015 SIGN="0080 \
        7DCA A76B 32CD 539C D4D2 F8C5 E900 8A05 0830 DEC5 8686 FB52 \
        2E64 B961"
--------------------------------------------------------------------

Review the license rights output, noting the information on these lines: Trust Flags, Fulfillment Type, 
Status, Product ID, Expiration date, and Feature line(s). 

5. In FlexNet Operations, click Licenses > Licenses. The Support Licenses And Maintenance page appears. 

6. On the list, search for product PhotoPrint-client and review the license details. Note that count is 1 because 
1 PhotoPrint-client license is activated. Note the fulfillment date and expiration. 

Server-Side Online Activation
In this exercise, you perform a server-side online activation of the PhotoPrint-server product license. 

Prerequisites 
If necessary, refer to the section Getting Started with Entitlement Management to: 

• Deploy the Enterprise Activation license model (Deploying a License Technology and Model) 

• Copy product PhotoPrint-client and save it as PhotoPrint-server (Creating a Product) 

a. Click Products > Products 

b. Search for and select the PhotoPrint-client check box, then click Copy 

c. Under Create a Product, in the Product Name field, type PhotoPrint-server and click Save 

• Link PhotoPrint-server to the Enterprise Activation license model (Linking a License Model to a Product). 
Remove (unlink) the Retail Activation license model and save PhotoPrint-server. 

• Deploy the PhotoPrint-server product (Deploying a Product) 

• Create and configure an entitlement called ENT-PhotoPrint-server (Creating and Configuring an 
Entitlement): 

• for end customer Lisa Barry of BarryPhoto 

• with a product PhotoPrint-server line item for a quantity of 3 copies and a license that starts at the first 
activation date and has a duration of 1 year 

• Save and deploy the ENT-PhotoPrint-server entitlement (Deploying an Entitlement) 



Chapter 10 Getting Started with FlexNet Publisher Trusted Storage-Based Licensing
Trusted Storage License Activation

416 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Task To activate a license using servercomptranutil 

1. In FlexNet Operations, click Entitlements > List Entitlements. The List Entitlements page appears. 

2. On the Activatable Line Items list, search for entitlement ID ENT-PhotoPrint-server and review the line item 
details. Note that available quantity and total quantity are 3 for product PhotoPrint-server. Expiration is in 1 
year. 

3. At a command prompt in the <platform_dir>, enter the following for a count of 2, where <act_ID> is the 
FlexNet Operations PhotoPrint-server activation ID: 

servercomptranutil -t http://<hostname:port>/flexnet/services/ActivationService -a <act_ID> count=2 

Output is similar to 

Server http://localhost:8888/flexnet/services/ActivationService, comms type SOAP
Status: 4, Creating request
Status: 5, Request created
Status: 6, Context created
Status: 7, Connected to remote server
Status: 8, Request Sent
Status: 9, Polling for response
Status: 10, Waiting for response
Status: 9, Polling for response
Status: 11, Done
Response processed successfully. Actions were:
    Configuration  TrustedId "13"
    Create         fulfillment "FID_c40614fd_1489_4e28_9bb6_c5872fadb51b"

4. At a command prompt in the <platform_dir>, to view the new license rights in server-side trusted storage, 
enter 

serveractutil -view 

Output is similar to 

--------------------------------------------------------------------
Trust Flags: FULLY TRUSTED
Fulfillment Type: PUBLISHER ACTIVATION
Status: ENABLED
Fulfillment ID: FID_c40614fd_1489_4e28_9bb6_c5872fadb51b
Entitlement ID: 4dff-ff10-c75a-432e-8dbf-8bc3-066b-ff1c
Product ID: NAME=PhotoPrint-server;VERSION=12.0
Suite ID: NONE
Expiration date: 29-Nov-2016
Concurrent: 0
Concurrent overdraft:0
Hybrid: 0
Hybrid overdraft: 0
Activatable: 2
Activatable overdraft: 0
Repairs: 0
Feature line(s):

INCREMENT PrintToPDF demo 12.3 29-nov-2016 1 ISSUER="My Corporation" \
        ISSUED=29-nov-2015 START=28-nov-2015 SIGN="003F 469C FAA0 F579 \
        2035 9632 BDAB B500 67F2 72CE 68BA FF86 4FC8 4123 FF47"



Chapter 10 Getting Started with FlexNet Publisher Trusted Storage-Based Licensing
Trusted Storage License Activation

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 417

INCREMENT Print demo 12.3 29-nov-2016 1 ISSUER="My Corporation" \
        ISSUED=29-nov-2015 START=28-nov-2015 SIGN="0072 6DC3 2310 9577 \
        9B9D 781E 36BC 0900 0E73 A2B7 C4A3 99FF BCA0 F23F 1D94"
INCREMENT PrintHighQualityColor demo 12.3 29-nov-2016 1 ISSUER="My \
        Corporation" ISSUED=29-nov-2015 START=28-nov-2015 SIGN="0080 \
        7DCA A76B 32CD 539C D4D2 F8C5 E900 8A05 0830 DEC5 8686 FB52 \
        2E64 B961"
--------------------------------------------------------------------

Review the license rights output, noting the information on these lines: Trust Flags, Fulfillment Type, 
Status, Product ID, Expiration date, Activatable, and Feature line(s). 

5. Record the Entitlement ID for later use in Step 1 of the To activate a local license using appactutil task in the 
Local Online Activation exercise. 

6. In FlexNet Operations, click Licenses > Licenses. The Support Licenses and Maintenance page appears. 

7. On the licenses list, search for product PhotoPrint-server and review the license details. Note that the count 
is 2 because 1 PhotoPrint-server license is activated. Note the fulfillment date and expiration. 

8. Click Entitlements > List Entitlements. The List Entitlements page appears. On the Activatable Line Items 
list, search for entitlement ID ENT-PhotoPrint-server and review the line item details. Note that available 
quantity is reduced to 1 and total quantity is 3 for product PhotoPrint-server. Note the expiration. 

Local Online Activation
In this exercise, you activate a PhotoPrint-server license from the FlexNet license server’s trusted storage on the 
client. 

Task To activate a local license using appactutil 

1. At a command prompt in the <platform_dir>, to activate a server-side license in client-side trusted storage, 
enter 

appactutil -served -commServer <port@hostname> -entitlementID <ent_ID> 

where 

• <port@hostname> is 27000@localhost, the license server 

Note • For purposes of this exercise, the default port number 27000 is used. If 27000 is not the port 
assigned to the license server, specify the correct one in the command. 

• <ent_ID> is the Entitlement ID you recorded in Step 5 of the Server-Side Online Activation exercise 

This command does the following: 

• Creates an activation request that contains the entitlement ID 

• Sends the activation request to the license server 
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Note • In your production environment, best practice is not to assign a default port for the license server. 
Instead, for security purposes, assign a port number outside of the range 27000 through 27009. 

• Places one fulfillment record from the license server’s trusted storage into the client machine’s trusted 
storage 

Output is similar to 

Generating activation request using:
        Entitlement ID = 4dff-ff10-c75a-432e-8dbf-8bc3-066b-ff1c
        Expiration = 29-Nov-2016
ACTIVATION REQUEST SUCCESSFULLY PROCESSED
ProductID NAME=PPrint-server;VERSION=12.0, FulfillmentID FID-1448810769

2. At a command prompt in the <platform_dir>, to view the new license rights in client-side trusted storage, 
enter 

appactutil -view 

Output is similar to 

--------------------------------------------------------------------
Trust Flags: FULLY TRUSTED
Fulfillment Type: PUBLISHER ACTIVATION
Status: ENABLED
Fulfillment ID: FID_d7a83787_46d6_43b1_a65b_ad85e135aa60
Entitlement ID: ff6a-cf25-7c72-4b15-9d49-945e-4b2f-519f
Product ID: NAME=PhotoPrint-client;VERSION=12.0
Suite ID: NONE
Expiration date: 29-Nov-2016
Feature line(s):

INCREMENT PrintToPDF demo 12.3 29-nov-2016 1 ISSUER="My Corporation" \
        ISSUED=29-nov-2015 START=28-nov-2015 SIGN="003F 469C FAA0 F579 \
        2035 9632 BDAB B500 67F2 72CE 68BA FF86 4FC8 4123 FF47"
INCREMENT Print demo 12.3 29-nov-2016 1 ISSUER="My Corporation" \
        ISSUED=29-nov-2015 START=28-nov-2015 SIGN="0072 6DC3 2310 9577 \
        9B9D 781E 36BC 0900 0E73 A2B7 C4A3 99FF BCA0 F23F 1D94"
INCREMENT PrintHighQualityColor demo 12.3 29-nov-2016 1 ISSUER="My \
        Corporation" ISSUED=29-nov-2015 START=28-nov-2015 SIGN="0080 \
        7DCA A76B 32CD 539C D4D2 F8C5 E900 8A05 0830 DEC5 8686 FB52 \
        2E64 B961"

--------------------------------------------------------------------
Trust Flags: FULLY TRUSTED
Fulfillment Type: SERVED ACTIVATION
Status: ENABLED
Fulfillment ID: FID-1448810769
Entitlement ID: 4dff-ff10-c75a-432e-8dbf-8bc3-066b-ff1c
Product ID: NAME=PhotoPrint-server;VERSION=12.0
Suite ID: NONE
Expiration date: 29-Nov-2016
Feature line(s):

INCREMENT PrintToPDF demo 12.3 29-nov-2016 1 ISSUER="My Corporation" \
        ISSUED=29-nov-2015 START=28-nov-2015 SIGN="003F 469C FAA0 F579 \
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        2035 9632 BDAB B500 67F2 72CE 68BA FF86 4FC8 4123 FF47"
INCREMENT Print demo 12.3 29-nov-2016 1 ISSUER="My Corporation" \
        ISSUED=29-nov-2015 START=28-nov-2015 SIGN="0072 6DC3 2310 9577 \
        9B9D 781E 36BC 0900 0E73 A2B7 C4A3 99FF BCA0 F23F 1D94"
INCREMENT PrintHighQualityColor demo 12.3 29-nov-2016 1 ISSUER="My \
        Corporation" ISSUED=29-nov-2015 START=28-nov-2015 SIGN="0080 \
        7DCA A76B 32CD 539C D4D2 F8C5 E900 8A05 0830 DEC5 8686 FB52 \
        2E64 B961"

--------------------------------------------------------------------

Review the two sets of license rights output, noting the information on these lines: Trust Flags, Fulfillment 
Type, Status, Product ID, Expiration date, and Feature line(s). Compare the fulfillment types of the two 
sets—for PhotoPrint-client the type is PUBLISHER ACTIVATION and for PhotoPrint-server the type is SERVED 
ACTIVATION. 

Trusted Storage License Activation Next Steps
License support is the stage of the FlexNet Operations license lifecycle that follows license activation. Support 
includes return of licenses. The exercises in the next topic use products PhotoPrint-client and 
PhotoPrint-server to guide you through basic FlexNet Operations trusted storage license support tasks. 

Trusted Storage License Activation Advanced Topics
Short Code Activation
Short code (keyboard) activation is intended for customers who do not have the network connection resources 
needed for typical activation transactions, and must activate a product manually, such as over the telephone. This 
is typically done for machines not connected to a network. Short code activation of a local license server is also 
supported. 

License rights are loaded from an Activation Specification Record (ASR) file using an activation transaction that 
requires a specific code, called a short code because it is not the prohibitively long code used in typical 
activations. Using a short code ASR, a customer provides a short request code and receives a short response 
code, over the telephone, that can be typed into the application interface. For more information, see Short Code 
Activations. 

Manual Activation
Manual activation is useful when there is no Internet connectivity directly on the host. The activation request is 
generated and written to a file by a FlexNet Publisher activation utility running on the machine where the license 
is to be activated, then the request is emailed to the publisher. The publisher uses FlexNet Operations to generate 
the response XML file. Alternatively, the customer can use the End-User Portal to submit and receive the 
response XML file. For more information, see Manual Activations.

Trusted Storage License Support
This topic introduces trusted storage license support, the stage of the FlexNet Operations license lifecycle that 
follows license activation. Trusted storage license support includes returning licenses. 
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The exercise in this topic guides you through basic FlexNet Operations trusted storage license support. 

Note • To use the exercise in this topic, you must be familiar with the FlexNet Publisher Licensing Toolkit. For 
more information, refer to the FlexNet Publisher document “Getting Started with Trusted Storage-Based 
Licensing”. 

Trusted Storage Key Concepts
After a license is activated, support becomes an important part of the license lifecycle. Changes resulting from 
business decisions such as the repackaging of products or introduction of maintenance, and end user events 
such as purchase of a new machine affect the license lifecycle. 

Many types of license change management for trusted storage-based licenses—including returns, repairs, 
rehosts, upgrades, upsells, and renewals—are supported by FlexNet Operations. 

Returning a Trusted Storage License 
FlexNet Operations supports three types of trusted storage license return: 

• Online Return

• Short Code Return (also called phone-based return) 

• Manual Return (also called email-based return) 

Note • The commands and exercises in this getting started section are based on a Windows platform installation 
of the FlexNet Publisher Licensing toolkit. To do the exercises on a UNIX machine, you must adjust the path and 
file name syntax for the UNIX environment. 

Note • For sample commands shown in this getting started section, it is assumed that FlexNet Operations and the 
activation utilities are running on the same system. If not, replace localhost:8888 with the appropriate host and 
port values. 

Online Return 

If an end user’s machine has Internet access, the end user can return a license using an activation utility. Unlike 
license file-based licenses, return of a trusted storage license is a secure operation; the user can no longer use 
the license after it is returned. 

Composite Transaction 

Online returns can be performed using the composite transaction activation utilities appcomptranutil and 
servercomptranutil. To perform multiple returns in the same command, append each additional return to the 
command with -r <fulfill_ID> and reason=<reason_code>. For example, 

appcomptranutil -t http://localhost:8888/flexnet/services/ActivationService 
-r <fulfill_ID1> reason=0 -r <fulfill_ID2> reason=0 -r <fulfill_ID3> reason=0 
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Note • To successfully perform multiple returns in a single command, all fulfillments must belong to the same 
account, use the same license type (client or server), and be performed on the same machine. 

Legacy, Single Transaction 

For legacy versions of FlexNet Operations, appactutil and serveractutil are still supported to perform license 
lifecycle operations. 

Trusted Storage Exercises
This exercise uses examples to guide you through the following trusted storage license support task: 

Client-Side Online Return
In this exercise, you perform a client-side online return of the PhotoPrint-client product license. 

Task To return a license using appcomptranutil 

1. To view the PhotoPrint-client and PhotoPrint-server license rights in client-side trusted storage, at a 
command prompt in the <platform_dir>, enter 

appcomptranutil -view 

Output is similar to 

Viewing application trusted storage.

U if untrusted
. D if disabled
. . fulfillmentType
. . . Expiry   Count FulfillmentId                   ProductId

. . 6 29-Nov-2016  1 FID_d7a83787_46d6_43b1_a65b_ad85e135aa60 NAME=PhotoPrint-client
;VERSION=12.0
. . 4 29-Nov-2016  1 FID-1448810769                  NAME=PhotoPrint-server;VERSION=
12.0

Viewed 2 of 2 fulfillment records.

2. From its fulfillment record, record the fulfillment ID of the PhotoPrint-client license to be returned. 

3. In the <platform_dir> on the client, enter this command, where <Fulfill_ID> is the PhotoPrint-client 
fulfillment ID: 

appcomptranutil -t http://localhost:8888/flexnet/services/ActivationService 
-r <Fulfill_ID> reason=0 

Exercise Description

Client-Side Online Return Perform a client-side online return of a PhotoPrint-client product license. 
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Output is similar to 

Server http://localhost:8888/flexnet/services/ActivationService, comms type SOAP
Status: 4, Creating request
Status: 5, Request created
Status: 6, Context created
Status: 7, Connected to remote server
Status: 8, Request Sent
Status: 9, Polling for response
Status: 10, Waiting for response
Status: 9, Polling for response
Status: 11, Done
Response processed successfully. Actions were:
    Delete         fulfillment "FID_d7a83787_46d6_43b1_a65b_ad85e135aa60"

4. Enter one of the following commands in the <platform_dir> and note that the PhotoPrint-client fulfillment 
was deleted from trusted storage: 

appcomptranutil -view 

or 

appactutil -view 

In FlexNet Operations, click Entitlements > List Entitlements and note that the PhotoPrint-client copy was 
returned to the FlexNet Operations List Entitlements list (Available Quantity is 1, Total Quantity is 1). Click 
Licenses > Licenses and note that the PhotoPrint-client fulfillment was deleted from the list on the Support 
Licenses And Maintenance page. 

Trusted Storage Advanced Topics
Online Repair 
A trusted storage license repair is necessary when the license becomes invalid because the machine hardware 
configuration changed enough to exceed the tolerance for the machine bindings, or the anchor is broken. 

Most trusted repairs are done programmatically but they can also be done through the FlexNet Operations 
Producer Portal or the End-User Portal. The number of allowed license repairs per unit time per line item is 
governed by a policy on the license model or the line item. 

Reason Codes
Certain FlexNet Operations activation and return requests include reason codes to identify the nature of the 
request. Reason codes are supported only for activation and change management requests coming from server 
activation utilities; reason codes are not supported for retail activation models. 

The meanings of these reason codes depend, in part, on whether the request is an activation or a return. 

Note that while reason codes accompany certain activation and return requests, not all requests require or 
include reason codes. For example, normal activation requests do not include reason codes, nor do repair 
requests. 
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Short Code Return
As with short code (keyboard) activation, if an end user’s machine has no Internet access, the end user can still 
return a license using a short code. Fulfillment records generated using online, manual, or short code activation 
can all be returned using short codes. Short code returns are not supported by composite transaction utilities. 

Short Code Repair
As with short code (keyboard) activation, if an end user’s machine has no Internet access, the end user can still 
repair a license using a short code. Fulfillment records generated using online, manual, or short code activation 
can all be repaired using short codes. Short code repairs are not supported by composite transaction utilities. 

Manual Return
As with manual activation, if an end user’s machine has no Internet access, the end user can still return a license 
using an XML file. Fulfillment records generated using online or manual activation can all be returned manually 
using XML files. Fulfillments generated using short code (keyboard) activation cannot be returned using this 
method. 

Manual Repair
As with manual activation, if the end user machine has no Internet access, the end user can still repair a license 
using an XML file. Fulfillment records generated using online or manual activation can all be repaired manually 
using XML files. Fulfillments generated using short code (keyboard) activation cannot be repaired using this 
method. 

Manual repairs can be performed using composite transaction utilities or single transaction utilities. Manual 
repairs executed with composite transaction utilities can perform multiple repairs in a single command. Append 
each additional repair to the command with -e <fulfillment_ID>. 

Rehosting a License 
Moving a license from one machine to another is called rehosting a license. 

Upgrading a License 
Changing from one version of a product to an improved version is called upgrading a license. For example, a 
customer can upgrade a license for Paint 4.0 software to one for Paint 5.1. 

Upselling a License 
Changing from one product to another with more capabilities is called upselling a license. For example, a 
customer who has a license for a four-function Basic Calculator can be upsold to the Scientific Calculator, 
which is designed for engineers and scientists. 

Renewing a License 
Extending an expiring license is called renewing a license. For example, a customer whose software license 
expires after one year can renew it for another year. 
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Reinstalling a License 
Over time, an end customer may reinstall an operating system on the client machine or reinstall a FlexEnabled 
application. In this case, the customer usually wants to get the original license back without consuming an 
additional count from the entitlement. FlexNet Operations uses the Unique Machine Number (UMN) of the client 
machine to determine that the user is indeed reinstalling the application. 

A reinstall works differently for a server activation request. Because it is common for a server to send an 
activation request for the same activation ID multiple times to activate a few copies each time, an additional 
parameter is added to the activation request to indicate that it is a reinstall. FlexNet Operations obsoletes all the 
existing fulfillment records for the given activation ID and UMN, and generates a new fulfillment record based on 
the parameters in the reinstall activation request. 

For both client and server activations, when a fulfillment record is identified as a reinstall, fulfillment history on 
the line item is updated. 
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Getting Started with 
FlexNet Publisher License File-
Based Licensing

This section Getting Started with FlexNet Publisher License File-Based Licensing presents fundamental FlexNet 
Operations concepts and uses exercises to lead a Producer Portal user through basic certificate license activation 
and support. The intended audience for this getting started section is the first-time Producer Portal user, or one 
without FlexNet Operations training or experience. 

Introduction
To view a brief, informative video that walks you through the exercises in Getting Started with FlexNet Publisher 
License File-Based Licensing, click here. We recommend that you read this getting started section in full, to gain 
an understanding of the concepts it covers, before you view the video. 

Prerequisites 
Before you begin the exercises in this getting started section: 

•  FlexNet Operations must be properly installed and configured 

Topic Description

Introduction Overview of this getting started section, exercise prerequisites, and a 
summary of the FlexNet Operations license lifecycle. 

Certificate License Activation FlexNet Operations certificate licensing concepts and exercises that 
demonstrate how to generate a certificate license and review fulfillment 
history after activation. Brief descriptions of advanced certificate license 
activation topics with references for more information. 

Certificate License Support FlexNet Operations certificate licensing support concepts and exercises 
that demonstrate how to return a certificate license and review fulfillment 
history after the license is returned. Brief descriptions of advanced 
certificate license support topics with references for more information. 

https://www.youtube.com/watch?v=HJ-h2ZZZVcc&feature=youtu.be
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• FlexNet Operations seed data and demonstration database must be loaded 

Important • These exercises require a FlexNet Operations database populated with demonstration data. For 
more information, refer to the step-by-step instructions in the FlexNet Operations On-Premises Installation & 
Implementation Guide to create seed data using the flexnet loaddb command and to populate the sample 
data using the flexnet demodata command. 

• You must have a FlexNet Operations Producer Portal login and a System Administrator role

• You must complete the exercises in the section Getting Started with Entitlement Management. 

The License Lifecycle: FlexNet Publisher License File-
Based Licensing

The FlexNet Operations license lifecycle is a repeating process of producer and customer activities, as depicted in 
the figure and described below. 

Figure 11-1:  FlexNet Operations License Lifecycle 

• Create Products – Create product definitions that are used to generate licenses. 

• Order/Entitle – Define an customer account’s rights to obtain licenses for your products. 

• Deliver⁄Install – Deliver the application software to the customer and install that software. 

• Activate – Deliver licenses to the customer. 
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• Return/Rehost – Manage license transfers from one user or system to another. 

• Maintain/Update – Deliver software and license updates to the customer. 

• Upsell/Renew – Renew customer licenses, or sell the customer additional product functionality. 

Certificate License Activation
This topic introduces certificate licenses and their activation, the stage of the FlexNet Operations license lifecycle 
that follows delivery of the product’s activation IDs to the customer. Activation is the process of requesting, 
generating, delivering, and installing license rights. 

The exercises in this topic guide you through basic FlexNet Operations certificate license activation. 

• Certificate License Activation Key Concepts

• Certificate License Activation Exercises

• Certificate License Activation Next Steps

• Certificate License Activation Advanced Topics

Certificate License Activation Key Concepts
Certificate License Models 
Certificate-based license model types include combinations of nodelocked or floating and counted or uncounted: 

• A nodelocked uncounted license model enables a product to be used on a specific computer system, with or 
without terminal server privileges. The end user can open unlimited instances of the product, but only on the 
nodelocked machine. This license model requires a host ID that uniquely identifies the nodelocked machine. 

• A nodelocked counted license model allows a fixed number of licenses to be accessed over a network by a 
specified list of computer systems. The specific host IDs are provided by the customer and put in the license 
certificate. This model requires a license server system. 

• A floating counted license model requires a license server system and allows a maximum number of licenses 
to be used at any one time on a network. This model is also called networked or concurrent licensing. 

• With a floating uncounted license model, any number of product licenses are available for checkout from a 
license server system over a network. 

After a product purchase has been registered with FlexNet Operations as an entitlement, a customer can obtain a 
license for the product. The license enables use of some or all of the product’s capabilities, and contains 
information about the computers on which the software is to run, the expiration date, and the count of the 
entitlement’s total quantity that has been activated. Before the license can be generated, the entitlement must be 
deployed in FlexNet Operations. 

Generating Certificate Licenses 
After a customer receives an activation ID, it can be presented to a software publisher’s order entry department, 
which uses FlexNet Operations to generate the certificate-based license. The license is then emailed or delivered 
to the customer by other means. 
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A customer could also use the activation ID to log in to the End-User Portal, enabled by FlexNet Operations, and 
generate a license. Similarly, an end user who has purchased software from a reseller could either call in to the 
software publisher with a Web register key, or use the key to log in to the End-User Portal to generate a license. 

Licenses are generated for one entitlement line item at a time. FlexNet Operations generates a fulfillment ID for 
each activation. 

Certificate License Activation Exercises
These exercises use examples to guide you through the following certificate license activation tasks: 

Generating a Certificate License
In this exercise, you generate a certificate license for 3 of the 10 copies of the PhotoPrint-cert product to which 
the customer is entitled. 

Prerequisites 
Log in to the FlexNet Operations Producer Portal and use the referenced procedures in the section Getting 
Started with Entitlement Management to: 

• Deploy the Floating Counted certificate license model (Deploying a License Technology and Model) 

• Copy product PhotoPrint and save it as PhotoPrint-cert (Creating a Product): 

a. Click Products > Products 

b. Search for and select the PhotoPrint check box, then click Copy 

c. In the Product Name field, type PhotoPrint-cert and click Save 

• Link PhotoPrint-cert to the Floating Counted license model (Linking a License Model to a Product) 

• Deploy PhotoPrint-cert (Deploying a Product) 

• Create and configure an entitlement called ENT-PhotoPrint-cert (Creating and Configuring an Entitlement): 

• for end customer Lisa Barry of BarryPhoto 

• for 10 copies of product PhotoPrint-cert with a license that starts at the first activation date and has a 
duration of 1 year 

• Deploy the ENT-PhotoPrint-cert entitlement (Deploying an Entitlement) 

Exercise Description

Generating a Certificate 
License

Generate a certificate license for 3 of the 10 copies of the PhotoPrint-cert 
product to which the customer is entitled. 

Reviewing Fulfillment 
History after Activation

Review the fulfillment history of the PhotoPrint-cert entitlement. 
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Task To generate a certificate license from an entitlement 

1. Log in to the FlexNet Operations Producer Portal, if you have not already done so. 

2. Click Entitlements > List Entitlements. The List Entitlements page appears. 

3. In the Activatable Line Items table, search for and click the Activation ID link for the PhotoPrint-cert 
product. The Line Item Details window opens. 

4. Review the details of the line item, noting that Qty and Qty Remaining are both 10, Start Date Option is Use 
First Activation Date, and License Model is Floating Counted. Click Cancel at the bottom to close the window. 

5. In the Activatable Line Items table, select the PhotoPrint-cert line item check box and click Activate. The 
List Entitlements page for the line item appears. 

6. To configure the host, click Next. Under Generate Licenses, click Add New Host. The Create License Host 
window opens. 

7. On the Server Hosts drop-down list, select ANY. Click OK to add ANY to the host list and close the window. 

8. Under Generate Licenses, select the ANY host check box, then click Next. The List Entitlements | Configure 
Counts page appears, listing the PhotoPrint-cert Activation ID and showing that Qty and Unallocated Qty 
are both 10. 

9. Type 3 in the Fulfill Count field, then click Next. The List Entitlements | Generate Licenses - Review page 
appears. 

10. Click Verify to verify the validity of the license, then click Generate. The Generated Licenses page appears, 
listing PhotoPrint-cert with License Hosts ANY and a Count of 3. Note the Fulfill Date and Expiration. 

11. On the Generated Licenses page, click Complete. The List Entitlements page appears, listing PhotoPrint-
cert with an Available Quantity of 7, Total Quantity of 10, and Expiration one year from the first activation 
date. 

12. Click Licenses > Licenses. The Support Licenses And Maintenance page appears, listing PhotoPrint-cert 
with License Hosts ANY, and a Count of 3. Note the Fulfill Date and Expiration. 

13. Click the PhotoPrint-cert Fulfillment ID link to review the information in the Fulfillment Details window, then 
click Cancel at the bottom to close the window. 

14. On the Support Licenses And Maintenance page, select the check box next to the PhotoPrint-cert license, 
then click Save to File. When you are asked whether you want to open or save the license file, select Open. 

15. Review the contents of the license file, which look similar to: 

#Please Do not delete this comment line.
SERVER this_host ANY
VENDOR demo
USE_SERVER
INCREMENT PrintToPDF demo 12.3 7-jul-2016 3 ISSUER="My \

Corporation" ISSUED=7-jul-2015 START=6-jul-2015 SIGN="0044 \
55B7 BB28 9979 433E B0A6 66FB E600 2D54 F9A8 18CC F949 56FA \
1E93 ADAE"

INCREMENT Print demo 12.3 7-jul-2016 3 ISSUER="My \
Corporation" ISSUED=7-jul-2015 START=6-jul-2015 SIGN="0003 \
5E3B 1F67 5DDE AB6C 69AA DA34 6600 4879 A4C9 C9CE ABE9 0F33 \
2FC2 715B"
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INCREMENT PrintHighQualityColor demo 12.3 7-jul-2016 3 \
ISSUER="My Corporation" ISSUED=7-jul-2015 START=6-jul-2015 \
SIGN="006D D640 5E71 98AD 21FB 32F4 7391 CD00 520F 044C 9578 \
938A 1DCE FB14 5CCA"

Note that any host can be used, a license server is required, and note that the count is 3 in the licensing 
information of each of the three features in the product. Close the license file when you are done. 

Reviewing Fulfillment History after Activation
In this exercise, you review the fulfillment history of the PhotoPrint-cert entitlement. 

Task To review the fulfillment history of the entitlement 

1. Click Entitlements > List Entitlements by Order. The List Entitlements by Order page appears. 

2. In the Entitlements list, search for the PhotoPrint-cert product line item (the Entitlement ID is ENT-
PhotoPrint-cert) and click the ENT-PhotoPrint-cert entitlement ID link. The Entitle Customers to Licenses 
page appears.

3. Under Line Items, in the list on the Line Items tab, search for the PhotoPrint-cert line item whose history you 
want to review. 

4. Click the Fulfill History link under the PhotoPrint-cert line item’s Activation ID. The Fulfillment History 
window opens for the line item. 

5. Review the PhotoPrint-cert line item’s fulfillment history, noting that a count of 3 of the entitlement’s Total 
Quantity of 10 are activated, then click OK to close the window. 

6. Log out of the FlexNet Operations Producer Portal or continue with Certificate License Support. 

Certificate License Activation Next Steps
License support is the stage of the FlexNet Operations license lifecycle that follows license activation. Support 
includes return of licenses. The exercises in the next topic use product PhotoPrint-cert to guide you through 
basic FlexNet Operations certificate license support tasks. 

Certificate License Activation Advanced Topics
Batch Activation 
Batch activation is the simultaneous activation of multiple entitlement line items under these conditions: 

• All line items are sold to the same account. 

• If the line items use FlexNet Licensing, they must all use the same license model type. 

• If the line items use a custom license technology, they must all use the same license technology. 

For more information, see What is Batch Activation?.
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License Consolidation 
License consolidation is combining multiple license certificates into a single license file for convenience. License 
consolidation can be done during batch activation or post-activation. 

For more information, see What is License Consolidation?.

Certificate License Support
This topic introduces certificate license support, the stage of the FlexNet Operations license lifecycle that follows 
license activation. Certificate license support includes returning licenses. 

The exercises in this topic guide you through basic FlexNet Operations certificate license support. 

Certificate License Support Key Concepts
After license activation, support becomes an important part of the license lifecycle. Changes resulting from 
business decisions such as the repackaging of products or introduction of maintenance, and end user events 
such as purchase of a new machine affect the license lifecycle. 

Many types of license change management for certificate licenses—including returns, repairs, rehosts, upgrades, 
upsells and renewals—are supported by FlexNet Operations. 

Returning a Certificate License 
Returning a license means moving license rights back to an entitlement. After receiving certificate license rights 
for a certain count, a customer can return some of that count to the software publisher for re-licensing at a later 
time. The product entitlement’s available quantity is increased by the count returned. 

Certificate License Support Exercises
These exercises use examples to guide you through the following certificate license support tasks: 

Returning a Certificate License
In this exercise, you return 1 of the 3 copies of the PhotoPrint-cert product you activated in Certificate License 
Activation. 

Exercise Description

Returning a Certificate 
License

Return 1 of the 3 copies of the PhotoPrint-cert product you activated. 

Reviewing Fulfillment 
History after a Return

Review the fulfillment history of the PhotoPrint-cert product after you return 1 
copy. 



Chapter 11 Getting Started with FlexNet Publisher License File-Based Licensing
Certificate License Support

432 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Prerequisite
• Complete the exercises in Certificate License Activation 

Task To return a certificate license 

1. Log in to the FlexNet Operations Producer Portal, if you have not already done so. 

2. Click Licenses > Licenses. The Support Licenses And Maintenance page appears with a fulfillments list. 

3. Search for the PhotoPrint-cert fulfillment and select its check box. 

4. Click Support Actions > Return. The Support Licenses And Maintenance | Return Licenses For Fulfillment 
page appears for the PhotoPrint-cert fulfillment. 

5. Under Fulfillment Details, type 1 in the Return Count field, click Verify to verify the validity of the license, then 
click Return. The Generated Licenses page appears, showing an activated Count of 2 for the PhotoPrint-cert 
fulfillment. 

6. Select the PhotoPrint-cert fulfillment’s check box, then click Save to File. When you are asked whether you 
want to open or save the license file, select Open. 

7. Review the contents of the license file, which look similar to: 

#Please Do not delete this comment line.
SERVER this_host ANY
VENDOR demo
USE_SERVER
INCREMENT PrintToPDF demo 12.3 7-jul-2016 2 ISSUER="My \

Corporation" ISSUED=7-jul-2015 START=6-jul-2015 SIGN="0017 \
1E37 A59A 3E07 D0B5 996F 97A2 A700 1EC6 01C8 5B6D 16A7 7A6E \
E916 B726"

INCREMENT Print demo 12.3 7-jul-2016 2 ISSUER="My \
Corporation" ISSUED=7-jul-2015 START=6-jul-2015 SIGN="00B4 \
CA1F 332D 4BA9 6732 9BD7 E5F4 D900 5DF2 47B8 EC89 EB50 1134 \
0338 411B"

INCREMENT PrintHighQualityColor demo 12.3 7-jul-2016 2 \
ISSUER="My Corporation" ISSUED=7-jul-2015 START=6-jul-2015 \
SIGN="003D 832D 8000 3D58 B750 9401 03BA 3A00 244C 0351 A6C0 \
489B C36E 2DB2 DB7C"

Note that the count in the licensing info for each of the three PhotoPrint-cert features is now 2. Close the 
license file when you are done. 

8. On the Generated Licenses page, click Complete. The Support Licenses and Maintenance page appears, 
showing that Count is 2. 

Reviewing Fulfillment History after a Return
In this exercise, you review the fulfillment history of PhotoPrint-cert after you return 1 of the 3 copies. 
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Task To review the fulfillment history after a certificate license is returned 

1. Click Entitlements > List Entitlements by Order. The List Entitlements by Order page appears.

2. In the Entitlements list, search for the PhotoPrint-cert product line item with the Entitlement ID of ENT-
PhotoPrint-cert. 

3. Click the ENT-PhotoPrint-cert Entitlement ID link. The Entitle Customers to Licenses page appears. 

4. Scroll down to the Line Items tab. In the Line Items list, search for the PhotoPrint-cert line item whose 
fulfillment history you want to review. 

5. Click the Fulfill History link under the PhotoPrint-cert line item’s Activation ID. The Fulfillment History 
window opens for the PhotoPrint-cert line item. 

6. Review the PhotoPrint-cert line item’s fulfillment history, noting that 3 of 10 copies were activated, then 1 
copy was returned, leaving a count of 2. Click OK to close the window. 

Certificate License Support Advanced Topics
Repairing a License 
A customer may require support for a license key. A support request for a certificate license is processed as a 
repair, and involves the change of a license parameter other than a host ID. For more information, see Repairing a 
License.

Rehosting a License 
Moving a license from one machine to another is called rehosting. Batch rehosting is moving groups of licenses 
from one server to others by: 

• Redistributing – re-allocating licenses for a group of products among various license servers to change the 
license count of products on different servers 

• Transferring – moving all of an account’s licenses from one host to another, usually when a host machine 
crashes and the licenses on it must be moved to a new machine 

For more information, see Rehosting a License.

Upgrading a License 
Changing a license for one version of a product to a license for an improved version of the product is called 
upgrading. For example, a customer can upgrade a license for Paint 4.0 to one for Paint 5.1. For more 
information, see Upgrade, Upsell, or Renew a Fulfillment.

Upselling a License 
Changing a license for one product to a license for another product with more capabilities is called upselling. For 
example, a customer who has a license for AntiMalware can be upsold to the Total PC Protection package, which 
includes AntiSpam and ParentalControl in addition to AntiMalware. For more information, see Upgrade, Upsell, or 
Renew a Fulfillment.
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Renewing a License 
Extending an expiring license is called renewing a license. For example, a customer whose software license 
expires after one year can renew it for another year. For more information, see Upgrade, Upsell, or Renew a 
Fulfillment.

Correcting a Producer Error 
Regeneration of a license may be required because of a producer error, such as incorrect data entry. For more 
information, see Correcting a Publisher Error in a License. For more information, see Upgrade, Upsell, or Renew a 
Fulfillment.

Generating an Emergency License 
An emergency license is a short term license generated for a customer who cannot use the unexpired license. For 
example, while a customer’s main computer is being upgraded or repaired, the product must be used temporarily 
on another computer. For more information, see Generating an Emergency License.

Generating a Stop-Gap License 
A stop-gap license is a short term license generated for a customer whose expired license renewal is being 
processed. For more information, see Generating a Stop Gap License.
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Getting Started with 
Non-FlexNet Licensing 
Technologies

This section Getting Started with Non-FlexNet Licensing Technologies presents fundamental FlexNet Operations 
concepts and uses exercises to guide a Producer Portal user through basic setup, activation, and support for 
non-FlexNet licensing. The intended audience for this getting started section is the first-time Producer Portal 
user, or one without FlexNet Operations training or experience. 

Topic Description

Introduction Overview of this getting started section, an overview of the FlexNet Operations 
license lifecycle, non-FlexNet licensing concepts, and exercise prerequisites. 

External SOAP Service 
Technology 

Introduction to external SOAP service licensing. Exercises that demonstrate 
how to set up an external SOAP service license technology and license model, 
and activate and support external SOAP service licenses. 

Custom Generator Interface 
Technology

Introduction to custom generator interface licensing. Exercises that 
demonstrate how to set up a custom generator interface license technology 
and license model, and activate and support custom generator interface 
licenses.

Manual Technology Introduction to manual licensing. Exercises that demonstrate how to set up a 
manual license technology and license model, and activate and support manual 
licenses. 

Hands-Free Technology Introduction to hands-free licensing. 

Advanced Topics Brief descriptions of advanced non-FlexNet licensing activation and support 
topics with references for more information. 
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Introduction
This section provides an overview of the FlexNet Operations license lifecycle, non-FlexNet licensing concepts, 
and exercise prerequisites. 

• Non-FlexNet License Technologies

• The License Lifecycle: Non-FlexNet Licensing Technologies

• Exercise Prerequisites

Non-FlexNet License Technologies
In addition to Revenera’s FlexNet license technology, FlexNet Operations can be integrated with other license 
technologies to unify disparate licensing systems and manage fulfillments. A non-FlexNet licensing technology 
generally fits into one of the following categories: 

• External SOAP Service Technology 

• Custom Generator Interface Technology

• Manual Technology 

• Hands-Free Technology 

• Replacement/Regenerative Technology, covered below 

Replacement/Regenerative Technology
When a replacement licensing technology is used, the most recent license file on a host overrides all earlier 
licenses. Each time a license is generated, the licensing system calculates the total fulfillment count for each 
product on the host and generates a license; the license is not generated based on the fulfillment count in a 
single transaction or on the fulfillment record. 

FlexNet Operations stores a master copy of the host license. Whenever a new license is generated for the host, or 
is returned, the master copy is modified. When a user downloads a license for a fulfillment record belonging to 
this host, the user receives the entire host license, not the individual fulfillment count of the fulfillment record. 
FlexNet Operations supplies only the master copy of the host license. 

License Activation
After a product purchase is registered with FlexNet Operations as an entitlement and the entitlement is deployed, 
a customer can obtain a license for the product. The license enables use of some or all of the product’s 
capabilities, and contains information about the computers on which the software is to run, the expiration date, 
and the count of the entitlement’s total quantity that has been activated. 

License Support
After license activation, support becomes an important part of the license lifecycle. Changes resulting from 
business decisions such as the repackaging of products or introduction of maintenance, and end user events 
such as purchase of a new machine affect the license lifecycle. Support operations include: 

• Repairing a License – Customers may require support for license keys. Requests for license support are 
processed as repairs. 
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• Returning a License – Returning a license means moving license rights back to an entitlement. After 
receiving licenses for copies of a product, a customer can return some of them to the software producer for 
re-licensing at a later time. The customer’s entitlement for the product is increased by the number of copies 
returned. 

The License Lifecycle: Non-FlexNet Licensing 
Technologies

The FlexNet Operations license lifecycle is a repeating process of producer and customer activities, as depicted in 
the figure and described below. 

Figure 12-1:  FlexNet Operations License Lifecycle

• Create Products – Create product definitions that are used to generate licenses. 

• Order/Entitle – Define a customer account’s rights to obtain licenses for your products. 

• Deliver⁄Install – Deliver the application software to the customer and install that software. 

• Activate – Deliver licenses to the customer. 

• Return/Rehost – Manage license transfers from one user or system to another. 

• Maintain/Update – Deliver software and license updates to the customer. 

• Upsell/Renew – Renew customer licenses, or sell the customer additional product functionality. 
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Exercise Prerequisites
Before you begin the exercises in this getting started section: 

• FlexNet Operations must be properly installed and configured

• FlexNet Operations seed data and demonstration database must be loaded 

Important • These exercises require a FlexNet Operations database populated with demonstration data. For 
more information, refer to the step-by-step instructions in the FlexNet Operations On-Premises Installation & 
Implementation Guide to create seed data using the flexnet loaddb command and to populate the sample 
data using the flexnet demodata command. 

• You must have a FlexNet Operations Producer Portal login and a System Administrator role 

• You must complete the exercises in the section Getting Started with Entitlement Management. 

License Technology-Specific Prerequisites 
• The external SOAP service must be deployed  

• If there is no manual technology license generator configured for FlexNet Operations, create a text file on 
your Desktop called NonFlexManualLicenseFile.lic that contains the line 
This is a sample non-FlexNet, manual technology license file. 

• For the Custom Generator Interface technology, a Java callout must be compiled and deployed, as described 
in the FlexNet Operations On-Premises Installation & Implementation Guide. A sample callout class is 
provided in the site/samples/customgenerator directory. 

External SOAP Service Technology
This topic introduces FlexNet Operations external SOAP service licensing and includes exercises that guide you 
through basic licensing setup, activation, and support. 

External SOAP Service Technology Key Concepts
Licenses that use an external SOAP service license technology are generated by a service that implements the 
FlexNet Operations LicenseGeneratorService Web Services Description Language (WSDL), an XML-based 
interface definition language that is used for describing the functionality offered by a web service. The external 
service is deployed in an application server independent of FlexNet Operations, as shown in the figure below, and 
is accessed by FlexNet Operations at run time for operations such as product and license model validation and 
license generation. The URL to the external service is linked to the custom generator when the license technology 
is created in FlexNet Operations.



Chapter 12 Getting Started with Non-FlexNet Licensing Technologies
External SOAP Service Technology

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 439

License Technology Set-Up
The exercises in this section use examples to guide you through these external SOAP service license set-up tasks:

Setting Up and Deploying the License Technology
In this exercise, you set up and deploy the SOAPTech license technology, an uncounted license technology. 

Task To set up the external SOAP service license technology 

1. Log in to the FlexNet Operations Producer Portal if you have not already done so. The Producer Portal Home 
page appears. 

2. Click Administer > License Technologies. The License Technologies page appears. 

3. Click Add a License Technology. The Create A License Technology page appears. 

4. Under Create A License Technology, enter the license technology information. 

• Name: Type SOAPTech 

Exercise Description

Setting Up and Deploying 
the License Technology

Set up and deploy the SOAPTech license technology. 

Setting Up and Deploying 
the License Model

Set up and deploy the SOAPModel license model of the SOAPTech license 
technology. 

Creating and Deploying the 
Product

Create and deploy product PhotoPrint-soap, which uses the SOAPTech license 
technology and SOAPModel license model. 
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• Description: Type External SOAP Service technology 

• State: Note that this license technology is created in a Draft state. 

• Type?: Select External SOAP Service

• Generator Service End Point: Type this path: 
{CUSTOM_TECH_HOST}/flexnet-licgen/services/LicenseGeneratorService 

• Authentication type for service: Select None

5. Click  to test the connection. Click OK in the message that says you have successfully connected to the 
service. 

6. Scroll down the page and click Add File Definition. The Create File Definition window opens. 

7. In the Create File Definition window, enter the file definition information. 

• Name: Type SOAP_FILE_Definition 

• File Type: Select TEXT. 

• Description: Type Custom generator interface technology file definition 

8. Click OK. The window closes and the file definition is added to the Create A License Technology page. Click 
Save to save the new license technology.

Task To deploy the external SOAP service license technology 

1. Click Administer > License Technologies. The License Technologies page appears and lists SOAPTech in the 
Draft state. 

2. Select the SOAPTech check box, then click Change State ? and select Deploy from the drop-down menu. Click 
OK in the verification message that appears. In the License Technologies table, SOAPTech is shown with a 
State of Deployed. This message appears: Deployed the following License Technologies successfully 
SOAPTech 

Setting Up and Deploying the License Model
In this exercise, you set up and deploy the SOAPModel license model. 

Task To set up the external SOAP service license model 

1. On the Administer menu, click License Models. The Package Products – License Models page appears. 

2. Click Create New License Model. The Package Products – License Models page refreshes. 

3. Under Select A License Technology, select SOAPTech from the License Technology menu, then click Next. The 
Package Products – License Models page refreshes. 

4. Under Create A License Model, enter the license model information. 

• Name: Type SOAPModel 
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• Description: Type SOAP license model 

• State: Note that the license model is created in a Draft state. 

• License Technology: Note that this is set to SOAPTech. 

• Expiration: Use the default value of None. 

5. Click Save to create the SOAPModel license model. This message appears: License Model successfully 
created. 

Task To deploy the external SOAP service license model 

1. On the Administer menu, click License Models. The Package Products – License Models page appears. 
Search for and select the SOAPModel check box. 

2. Click Change State ? and select Deploy from the drop-down menu. Click OK in the verification message that 
appears. This message appears: Deployed the following License Model(s) successfully SOAPModel. In the 
License Models table, SOAPModel is shown with a State of Deployed. 

Creating and Deploying the Product
In this exercise, you create a product called PhotoPrint-soap that uses the SOAPTech license technology and 
SOAPModel license model, then you deploy the product. 

Task To create product PhotoPrint-soap 

1. Click Products > Products. The Package Products page appears. 

2. Click Add New Product. The Package Products | Create A Product page appears.

3. Under Create A Product, enter the product information: 

• Product Name: Type PhotoPrint-soap 

• Version: Type 12.3 

• State: Note that the product is created in a Draft state. 

• License Technology: Select SOAPTech 

4. Click Add Features. The Add Features To Product window opens. 

5. In the Add Features To Product window, search for feature name equals Print. Feature Print is listed under 
Available Features. 

6. In the Add Features To Product window, under Available Features, select  Print,12.3. 

7. Click Add ? to move feature Print,12.3 to Selected Features, then click Add. The window closes and the 
feature is added to product PhotoPrint-soap. 

8. Click Save. Note that product PhotoPrint-soap and its version appear in the list on the right side of the 
Package Products page. This message appears: Product PhotoPrint-soap successfully added. 

9. Click Next. The Package Products | Link License Models To Product page appears. 
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10. Click Link License Models. The Select License Models window opens. Search for and select SOAPModel from 
Available License Models, then click Add ? to move it to Selected License Models. 

11. Click Add. Product PhotoPrint-soap is linked to the SOAPmodel license model and the window closes. 

12. On the Package Products page, click Save. Note that product PhotoPrint-soap is now listed under Products 
Linked To License Models. This message appears: License models linked successfully. 

Task To deploy product PhotoPrint-soap 

1. Click Products > Products. The Package Products page appears. Search for product PhotoPrint-soap and 
select its check box. 

2. Click Change State ? and select Deploy from the drop-down menu. Click OK in the verification message. The 
Package Products | Deploy Products page appears for product PhotoPrint-soap. 

3. Click Deploy. The Package Products page shows that PhotoPrint-soap is deployed. This message appears: 
Products deployed successfully.

License Activation
The exercises in this section use examples to guide you through these external SOAP service license activation 
tasks:

Entitling the Customer to the Product
In this exercise, you create, configure, and deploy an entitlement for 3 copies of product PhotoPrint-soap. 

Task To create the product PhotoPrint-soap entitlement 

1. Click Entitlements > Create. The Entitle Customers to Licenses page appears. 

2. Under Create An Entitlement, from the Entitlement ID list, select Specify and type ENTL-soap in the box that 
appears next to it. Note that the entitlement is created in a Draft state. 

3. Under End Customer And Channel Partners, click Add. The End Customer And Channel Partners window 
opens. 

4. On the Customers tab, search for and select BarryPhoto as the account to receive the entitlement, then click 
Save. The End Customer And Channel Partners window closes, and the Entitle Customers to Licenses page 
shows Barry Photography Studio as the end customer. 

Exercise Description

Entitling the Customer to 
the Product

Create, configure, and deploy the product PhotoPrint-soap entitlement. 

Activating the License Activate a product PhotoPrint-soap license. 
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Task To configure the product PhotoPrint-soap entitlement 

1. On the Line Items tab near the bottom of the page, click New Line Item. The Configure Line Item wizard 
opens. 

2. In wizard step 1, Select Product, search for and select product PhotoPrint-soap, then click Next. 

3. In wizard step 2, Select Part Number & License Model, leave the default values as they are. Click Next. 

4. In wizard step 3, Configure Product, enter these line item attributes: 

• Qty: Type 3 for the quantity of PhotoPrint-soap copies in this line item 

• Start Date: Select Use First Activation Date from the drop-down list 

• Expiration: Select Permanent 

• Keep the default values for all other attributes. 

Click Next. 

5. In wizard step 4, Custom Attributes, click Next. 

6. In wizard step 5, Order Type, keep the default value as it is. Click Save to save the line item and close the 
Configure Line Item wizard. 

7. On the Line Items tab, note that the line item for product PhotoPrint-soap is PERMANENT, has a total quantity 
of 3, and is in the Draft state. 

Task To deploy the product PhotoPrint-soap entitlement 

1. At the bottom of the Entitle Customers to Licenses page, click Save & Deploy. The page is refreshed, the Line 
Item State of PhotoPrint-soap is now Deployed, and this message appears: Entitlement deployed 
successfully. 

2. On the Entitle Customers to Licenses page, click Email to send entitlement notification email to Barry 
Photography Studio. Type your email address in the Ship To Email box so you receive the certificate. 

Note • To include additional recipients, type their email addresses into the Ship To Email box separated by 
commas. 

3. Click Send. The email is sent and this message appears: Email sent to the recipients <address list>. 

Activating the License
In this exercise, you activate a license for 1 copy of product PhotoPrint-soap. An external SOAP service license 
technology is integrated with FlexNet Operations using your technology’s API. After collecting fulfillment data 
from the user, FlexNet Operations invokes your custom generator Java class to generate the license. 
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Task To activate the external SOAP service license 

1. On the Entitle Customers to Licenses page, select the PhotoPrint-soap line item’s check box and click 
Activate. The List Entitlements page appears. 

2. In the Activatable Line Items table, click the Activation ID link for the PhotoPrint-soap line item. The Line 
Item Details window opens.

3. Review the details of the line item, noting that Qty and Qty Remaining are both 3, Start Date Option is Use 
First Activation Date, Permanent is true, and License Model is SOAPModel, then click Cancel at the bottom to 
close the window. 

4. In the Activatable Line Items table, select the PhotoPrint-soap line item check box and click Activate. The 
List Entitlements | Generate Licenses page for the line item appears. 

5. Click Verify to verify the validity of the license. This message appears: License is Valid.

6. Click Generate. The Generated Licenses page appears, listing PhotoPrint-soap with a Count of 1. 

7. On the Generated Licenses page, click Complete. The List Entitlements page appears, listing the 
PhotoPrint-soap line item with an Available Quantity of 2, Total Quantity of 3, and Expiration of PERMANENT. 

8. Click Licenses > Licenses. The Support Licenses And Maintenance page appears, listing product 
PhotoPrint-soap with a Count of 1. 

9. Click the product PhotoPrint-soap Fulfillment ID link. The Fulfillment Details window opens. 

10. Review the fulfillment information, then click Cancel at the bottom to close the window.

11. On the Support Licenses And Maintenance page, put a check mark in the product PhotoPrint-soap license’s 
check box, then click Save to File. When you are asked whether you want to open or save the license file, 
select Open. 

12. Review the contents of the license file, which look similar to: 

Fulfillment
 fulfilment Id: FID_a9a12791_78e1_4eba_98e3_513f5fe335ad
 Count: 1
 OverDraft : 0
 StartDate : 08-03-2015
 ShipToEmail: 
 CustomHost
 RequestType : ACTIVATION
 isVerifyRequest : false
 FULFILMENT Custom License Attribute 

ActivationRecord
 Activation ID: 1233-37c1-99af-465c-976f-2909-4407-bcfe
 LineItem Attribute
 ENTITLEMENT Custom License Attribute 

Entitlement
 EntitlementId : ENTL-soap 
 OrderId : null
 OrderLineNumber: 
 OrganizationUnit

 DisplayName : Barry Photography Studio
 OrganizationUnit Attribute
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 SoldToUser
 DisplayName : Lisa Barry
 FirstName   : Lisa
 LastName    : Barry

 User Attribute
 DisplayName : John Barry
 FirstName   : John
 LastName    : Barry

 User Attribute
 Entitlement Attribute

Product
 Name    : PhotoPrint-soap 
 Version : 12.3
 Quantity Per Copy : 1
 Product Attribute

 TestCustomAttribute: SOAP_TCA,
 Features

 Print : 1, version : 12.3, isDateBased : false

 Featur Overrides
 NOTICE : null
 VENDOR_STRING : null
 ISSUER : null
 SERIAL_NUMBER : null
 DUP_GROUP : null
 REUSABLE : null

License
 Model Name: SOAPModel
 MODEL Custom License Attribute 

License Technolgy 
 Name: SOAPTech
 License file defnition Name : SOAP_File_Def
 License file defnition Type : TEXT
 LicenseFileType : TEXT

Logged In User : YourFirstName YourLastName
 LoggedIn User Attribute

13. Close the license file window when you are done. 

License Support
The exercises in this section use examples to guide you through these external SOAP service license support 
tasks:

Exercise Description

Repairing the License Repair the product PhotoPrint-soap license that you activated. 

Returning the License Return the product PhotoPrint-soap license. 
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Repairing the License
In this exercise, you repair the PhotoPrint-soap license. 

Task To repair the external SOAP service license 

1. Click Licenses > Licenses. The Support Licenses And Maintenance page appears. 

2. On the Support Licenses And Maintenance page, search for and select the check box next to the product 
PhotoPrint-soap fulfillment. 

3. Click Support Actions and select Repair from the drop-down menu. The Support Licenses And Maintenance 
page refreshes with the PhotoPrint-soap fulfillment information. 

4. Click Verify to verify the validity of the license. This message appears: License is valid. 

5. Click Repair. The Generated Licenses page appears with updated PhotoPrint-soap fulfillment information. 

6. On the Generated Licenses page, click Complete. The Support Licenses And Maintenance page appears. 

7. Click Entitlements > List Entitlements by Order, search for the ENTL-soap entitlement, then click on the 
ENTL-soap Entitlement ID link. The Entitle Customers to Licenses page for the entitlement appears. 

8. Under Line Items, on the Line Items tab, click the Fulfill History link of the PhotoPrint-soap line item. The 
Fulfillment History window opens. 

9. Review the fulfillment history for the PhotoPrint-soap line item. Note when it was initially activated and when 
it was repaired and reactivated. Click OK when you are done to close the Fulfillment History window. 

Returning the License
In this exercise, you return the PhotoPrint-soap license. 

Task To return the external SOAP service license 

1. Click Licenses > Licenses. The Support Licenses And Maintenance page appears. 

2. On the Support Licenses And Maintenance page, search for and select the check box next to the product 
PhotoPrint-soap fulfillment. 

3. Click Support Actions and select Return from the drop-down menu. The Support Licenses And Maintenance 
page refreshes with the PhotoPrint-soap fulfillment information. 

4. Click Verify to verify the validity of the license. This message appears: License is valid. 

5. Click Return. The Support Licenses And Maintenance page is refreshed, and a message similar to this 
appears: Successfully returned licenses for fulfillment FID_2d0cea6e_e9b8_441b_949b_caa858c30843

6. Click Entitlements > List Entitlements by Order, search for the ENTL-soap entitlement, then click on the 
ENTL-soap Entitlement ID link. The Entitle Customers to Licenses page appears. 

7. Under Line Items, on the Line Items tab, click the Fulfill History link of the PhotoPrint-soap line item. The 
Fulfillment History window opens. 
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8. Review the fulfillment history for the PhotoPrint-soap line item. Note when it was returned. Click OK when 
you are done to close the Fulfillment History window. 

Custom Generator Interface Technology
This topic introduces FlexNet Operations custom generator interface licensing and includes exercises that guide 
you through basic licensing setup, activation, and support.

Key Concepts
License technologies that use a custom generator interface require the implementation of a callout that runs in 
the FlexNet Operations application environment. FlexNet Operations provides a Java interface and methods for 
this callout in its public API. 

License Technology Set-Up
The exercises in this section use examples to guide you through these custom generator interface license set-up 
tasks:

Setting Up and Deploying the License Technology
In this exercise, you set up and deploy the CustomGen license technology, an uncounted license technology. 

Task To set up the custom generator interface license technology 

1. Log in to the FlexNet Operations Producer Portal if you have not already done so. The Producer Portal Home 
page appears. 

2. Click Administer > License Technologies. The License Technologies page appears. 

3. Click Add a License Technology. The Create A License Technology page appears. 

4. Under Create A License Technology, enter the required license technology information. 

• Name: Type CustomGen 

Exercise Description

Setting Up and Deploying 
the License Technology

Set up and deploy the CustomGen license technology. 

Setting Up and Deploying 
the License Model

Set up and deploy the CustomGenModel license model of the CustomGen license 
technology. 

Creating and Deploying the 
Product

Create and deploy product PhotoPrint-custom, which uses the CustomGen 
license technology and CustomGenModel license model. 
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• Description: Type Custom Generator Interface technology 

• State: Note that this license technology is created in a Draft state. 

• Type?: Select Use Generator Interface 

• Generator Service: Type the path (in other words, the path, including any package structure, inside the 
WEB-INF/classes directory) to the Java class that generates licenses for this license technology. This 
class must implement the com.flexnet.operations.publicapi.LicenseGeneratorService interface. 

Note • The class must already be deployed in FlexNet Operations (see the Implementation Guide for 
compiling and deploying Java callouts).

5. Scroll down the page and click Add File Definition. The Create File Definition window opens. 

6. In the Create File Definition window, enter the file definition information. 

• Name: Type CustomGen_FILE_Definition 

• File Type: Select TEXT. 

• Description: Type Custom Generator Interface technology file definition 

7. Click OK. The window closes and the file definition is added to the Create A License Technology page. Click 
Save to save the new license technology. 

8. Click Add Host Type. The Create Host Type window opens. 

9. In the Create Host Type window, enter the host type information. 

• Name: Type CustomGen_HOST_Type 

• Description: Type Custom Generator Interface technology host type 

The default Host ID Generator Class generates a hostid based on a host type and host attribute values. Or a 
custom host ID generator can be specified.

10. Click OK. The window closes and the host type is added. 

11. Near the bottom of the Create A License Technology page, click Next. The Create Custom Attribute page 
appears. 

12. Under Create A License Generator Attribute, enter the license generator attribute information. 

• Name: Type CustomGen_LGA 

• License Technology: Verify that this is set to CustomGen. 

• Make this a required attribute: Leave check box unselected. 

• Type: Select Number. 

13. Click Next. The Create License Generator Configuration page appears. 

14. Under Create License Generator Configuration, enter the license generator configuration information. 

• Name: Type CustomGen_GEN 

• Description: Type Custom generator configuration 
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• License Technology: Verify that this is set to CustomGen. 

Under Custom Attributes, enter the license model attribute information. 

• CustomGen_LGA: Type 4444 

15. Click Next. The Create Custom Attribute page appears. 

16. Under Create A License Model Attribute, enter the license model attribute information. 

• Name: Type CustomGen_LMA 

• License Technology: Verify that this is set to CustomGen. 

• When to request this attribute value: Verify that all boxes are checked. 

• Make this a required attribute: Leave check box unselected. 

• Type: Select Number. 

• Copy to data warehouse: Leave check box unselected. 

17. Click Complete. The License Technologies page appears and lists CustomGen in the draft state. 

Task To deploy the custom generator interface license technology 

1. On the License Technologies page, select the CustomGen check box. 

2. Click Change State ? and select Deploy from the drop-down menu. Click OK in the verification message that 
appears. In the License Technologies table, CustomGenerator is shown with a State of Deployed. This 
message appears: Deployed the following License Technologies successfully CustomGen 

3. On the Administer menu, click Custom Host Attributes. The Custom Host Attributes page appears. 

4. Click Create. The Create Custom Host Attribute page appears. 

5. To create a custom host for the host type added during license technology creation, under Create Custom 
Host Attribute, enter the custom host attribute information. 

• Name: Type UUID_CustomGen 

• License Technology: Verify that this is set to Custom Licensing. 

• Host Type: Select CustomGen_HOST_Type 

• Required: Use the default value of No. 

• Type: Select Number. 

6. Click Save. The Create Custom Host Attribute page refreshes and this message appears: License Host 
Attribute UUID_CustomGen successfully added. UUID_CustomGen is saved as a custom host attribute. 

Setting Up and Deploying the License Model
In this exercise, you set up and deploy the CustomGenModel license model. 
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Task To set up the custom generator interface license model 

1. Click Administer > License Models. The Package Products – License Models page appears. 

2. Click Create New License Model. The Package Products – License Models page refreshes. 

3. Under Select A License Technology, select CustomGen from the License Technology menu, then click Next. 
The Package Products – License Models page refreshes. 

4. Under Create A License Model, enter the license model information. 

• Name: Type CustomGenModel 

• Description: Type Custom generator interface license model 

• State: Note that the license model is created in a Draft state. 

• License Technology: Note that this is set to CustomGen. 

• Expiration: Use the default value of None. 

5. Under Custom Attributes, select Specify Value Now from the drop-down menu next to CustomGen_LMA, 
then type 5678 in the field that appears to the right. 

6. Click Save to create the CustomGenModel license model. This message appears: License Model successfully 
created. 

Task To deploy the custom generator interface license model 

1. Click Administer > License Models. The Package Products – License Models page appears. Search for and 
select the CustomGenModel check box. 

2. Click Change State ? and select Deploy from the drop-down menu. Click OK in the verification message that 
appears. In the License Models table, CustomGenModel is shown with a State of Deployed. This message 
appears: Deployed the following License Model(s) successfully CustomGenModel.

Creating and Deploying the Product
In this exercise, you create a product called PhotoPrint-custom that uses the CustomGen license technology and 
CustomGenModel license model, then you deploy the product. 

Task To create product PhotoPrint-custom

1. Click Products > Products. The Package Products page appears. 

2. Click Add New Product. The Package Products | Create A Product page appears.

3. Under Create A Product, enter the product information: 

• Product Name: Type PhotoPrint-custom 

• Version: Type 12.4 
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• State: Note that the product is created in a Draft state. 

• License Technology: Select CustomGen 

• Host Type: Select CustomGen_HOST_Type 

• License Generator: Select CustomGen_GEN 

4. Click Add Features. The Add Features To Product window opens. 

5. In the Add Features To Product window, search for feature name equals Print. Feature Print is listed under 
Available Features. 

6. In the Add Features To Product window, under Available Features, select  Print,12.3. 

7. Click Add ? to move feature Print,12.3 to Selected Features, then click Add. The window closes and the 
feature is added to product PhotoPrint-custom. 

8. Click Save. Note that product PhotoPrint-custom and its version appear in the list on the right side of the 
Package Products page. This message appears: Product PhotoPrint-custom successfully added. 

9. Click Next. The Package Products | Link License Models To Product page appears. 

10. Click Link License Models. The Select License Models window opens. Search for and select CustomGenModel 
from Available License Models, then click Add ? to move it to Selected License Models. 

11. Click Add. Product PhotoPrint-custom is linked to the CustomGenModel license model and the window closes. 

12. On the Package Products page, click Save. Note that product PhotoPrint-custom is now listed under 
Products Linked To License Models. This message appears: License models linked successfully. 

Task To deploy product PhotoPrint-custom 

1. Click Products > Products. The Package Products page appears. Search for product PhotoPrint-custom and 
select its check box. 

2. Click Change State ? and select Deploy from the drop-down menu. Click OK in the verification message. The 
Package Products | Deploy Products page appears for product PhotoPrint-custom. 

3. Click Deploy. The Package Products page shows that PhotoPrint-custom is deployed. This message appears: 
Products deployed successfully.

License Activation
The exercises in this section use examples to guide you through these custom generator interface license 
activation tasks: 

Exercise Description

Entitling the Customer to 
the Product

Create, configure, and deploy the product PhotoPrint-custom entitlement. 

Activating the License Activate a product PhotoPrint-custom license. 
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Entitling the Customer to the Product
In this exercise, you create, configure, and deploy an entitlement for 3 copies of product PhotoPrint-custom. 

Task To create the PhotoPrint-custom entitlement 

1. Click Entitlements > Create. The Entitle Customers To Licenses page appears. 

2. Under Create An Entitlement, from the Entitlement ID list, select Specify and type ENTL-custom in the box that 
appears next to it. Note that the entitlement is created in a Draft state. 

3. Under End Customer And Channel Partners, click Add. The End Customer And Channel Partners window 
opens. 

4. On the Customers tab, search for and select BarryPhoto as the account to receive the entitlement, then click 
Save. The End Customer And Channel Partners window closes, and the Entitle Customers To Licenses page 
shows Barry Photography Studio as the end customer. 

Task To configure the PhotoPrint-custom entitlement 

1. On the Line Items tab near the bottom of the page, click New Line Item. The Configure Line Item wizard 
opens. 

2. In wizard step 1, Select Product, search for and select product PhotoPrint-custom, then click Next. 

3. In wizard step 2, Select Part Number & License Model, leave the default values as they are. Click Next. 

4. In wizard step 3, Configure Product, enter these line item attributes: 

• Qty: Type 3 for the quantity of PhotoPrint-custom copies in this line item 

• Start Date: Select Use First Activation Date from the drop-down list 

• Expiration: Select Permanent 

• Keep the default values for all other attributes. 

Click Next. 

5. In wizard step 4, Order Type, keep the default value as it is. Click Save to save the line item and close the 
Configure Line Item wizard. 

6. On the Line Items tab, note that the line item for product PhotoPrint-custom is PERMANENT, has a total 
quantity of 3, and is in the Draft state. 
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Task To deploy the product PhotoPrint-custom entitlement 

Important • The Entitlement and Entitlement Certificate Email templates must be active for you to receive the 
entitlement notification email and certificate when the product entitlement is deployed. 

1. At the bottom of the Entitle Customers To Licenses page, click Save & Deploy. The page is refreshed, the Line 
Item State of PhotoPrint-custom is now Deployed, and this message appears: Entitlement deployed 
successfully.

2. On the Entitle Customers To Licenses page, click Email to send entitlement notification email to Lisa Barry 
at Barry Photography Studio. The Entitle Customers To Licenses page appears with the customer’s address 
in the Ship To Email box. Type your email address in the Ship To Email box so you receive the certificate. 

Note • To include additional recipients, type their email addresses into the Ship To Email box separated by 
commas. 

Tip • Add your email address to the recipients list and review the PhotoPrint-custom entitlement certificate 
you receive. 

3. Click Send. The email is sent and this message appears: Email sent to the recipients <address list>. 

Activating the License
In this exercise, you activate a license for 1 copy of product PhotoPrint-custom. 

Task To activate the custom generator license 

1. Click Entitlements > List Entitlements. The List Entitlements page appears. 

2. In the Entitlements table, click the Activation ID link for the PhotoPrint-custom product. The Line Item Details 
window opens. 

3. Review the details of the line item, noting that Qty and Qty Remaining are both 3, Start Date Option is Use 
First Activation Date, Permanent is true, and License Model is CustomGenModel, then click Cancel at the 
bottom to close the window. 

4. In the Entitlements table, select the PhotoPrint-custom line item and click Activate. The List Entitlements | 
Generate Licenses page for the PhotoPrint-custom line item appears. 

5. Click Next. The List Entitlements | Generate Licenses page now allows you to add host information. 

6. Click Add New Host. The Create License Host window opens. 

7. In the Create License Host window, for UUID_CustomGen, type 7777. Click OK to add the new host and close 
the window. A host ID is generated based on the Host ID Generator Class configured for the product’s host 
type.
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8. Click Verify to verify the validity of the license. This message appears: License is Valid.

9. Click Generate. The Generated Licenses page appears, listing PhotoPrint-custom with a Count of 1. 

10. On the Generated Licenses page, click Complete. The List Entitlements page appears, showing the 
PhotoPrint-custom line item with an Available Quantity of 2, Total Quantity of 3, and Expiration of 
PERMANENT. 

11. Click Licenses > Licenses. The Support Licenses And Maintenance page appears, showing product 
PhotoPrint-custom with a Count of 1. The Type is Non-FlexNet (denoted by the NF  icon). 

12. Click the product PhotoPrint-custom Fulfillment ID link. The Fulfillment Details window opens. 

13. Review the fulfillment information, then click Cancel at the bottom to close the window. 

14. On the Support Licenses And Maintenance page, put a check mark in the product PhotoPrint-custom 
license’s check box, then click Save to File. If your browser asks whether you want to open or save the 
license file, select Open. 

15. Review the contents of the license file and close the window when you are done. 

License Support
The exercises in this section use examples to guide you through these custom generator interface license 
support tasks:

Repairing the License
In this exercise, you repair the PhotoPrint-custom license. 

Task To repair the custom generator interface license 

1. Click Licenses > Licenses. The Support Licenses and Maintenance page appears. 

2. On the Support Licenses and Maintenance page, search for and select the check box next to the product 
PhotoPrint-custom fulfillment. 

3. Click Support Actions and select Repair from the drop-down menu. The Support Licenses And Maintenance 
page refreshes with the PhotoPrint-custom fulfillment information. 

4. Click Repair. The Generated Licenses page appears with updated product PhotoPrint-custom fulfillment 
information. 

5. On the Generated Licenses page, click Complete. The Support Licenses And Maintenance page appears. 

Exercise Description

Repairing the License Repair the product PhotoPrint-custom license that you activated. 

Returning the License Return the product PhotoPrint-custom license. 
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6. Click Entitlements > List Entitlements, select the product ENTL-custom entitlement, then click Fulfill History. 
The Fulfillment History window opens. 

7. Review the fulfillment history for the PhotoPrint-custom line item. Note that it was activated, repaired, and 
reactivated. Click OK when you are done to close the Fulfillment History window. 

Returning the License
In this exercise, you return the PhotoPrint-custom license. 

Task To return the custom license 

1. Click Licenses > Licenses. The Support Licenses and Maintenance page appears. 

2. On the Support Licenses and Maintenance page, search for and select the check box next to the product 
PhotoPrint-custom fulfillment. 

3. Click Support Actions and select Return from the drop-down menu. The Support Licenses And Maintenance 
page refreshes with the PhotoPrint-custom fulfillment information. 

4. Click Verify to verify the validity of the license. This message appears: License is valid. 

5. Click Return. The Support Licenses And Maintenance page is refreshed. A message similar to this appears: 
Successfully returned licenses for fulfillment FID_8fbd3105_8d5e_41b2_99a9_c867bca9ff8d 

6. Click Entitlements > List Entitlements, select the ENTL-custom entitlement, then click Fulfill History. The 
Fulfillment History window opens. 

7. Review the fulfillment history for the PhotoPrint-custom line item. Note when it was returned. Click OK when 
you are done to close the Fulfillment History window. 

Manual Technology
This topic introduces FlexNet Operations manual licensing and includes exercises that guide you through basic 
licensing setup, activation, and support. 

Manual Technology Key Concepts
Licenses that use manual technology are manually generated by a customer support representative using a third-
party system. Because this license generator is not integrated into FlexNet Operations, when a user generates a 
license, the generated fulfillment is placed on hold and an email is sent to the administrator. The administrator 
logs in to the third-party system and generates the license, then returns to FlexNet Operations to set the license 
on the on-hold fulfillment record. The user can then download the license. FlexNet Operations tracks fulfillment 
and other data. 
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License Technology Set-Up
The exercises in this section use examples to guide you through these manual license set-up tasks:

Setting Up and Deploying the License Technology
In this exercise, you set up and deploy the ManualTech license technology, an uncounted license technology. 

Task To set up a manual license technology 

1. Click Administer > License Technologies. The License Technologies page appears. 

2. Click Add a License Technology. The Create A License Technology page appears. 

3. Under Create A License Technology, enter the license technology information. 

• Name: Type ManualTech 

Exercise Description

Setting Up and Deploying 
the License Technology

Set up and deploy the ManualTech license technology. 

Setting Up and Deploying 
the License Model

Set up and deploy the ManualModel license model of the ManualTech license 
technology. 

Creating and Deploying the 
Product

Create and deploy product PhotoPrint-manual, which uses the ManualTech 
license technology and ManualModel license model. 
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• Description: Type Manual technology 

• State: Note that this license technology is created in a Draft state. 

• Type?: Select Manual 

4. Scroll down the page and click Add File Definition. The Create File Definition window opens. 

5. In the Create File Definition window, enter the file definition information. 

• Name: Type Manual_FILE_Definition 

• File Type: Select TEXT. 

• Description: Type Manual technology file definition 

6. Click OK. The window closes and the file definition is added to the Create A License Technology page. Click 
Save to save the new license technology. 

Task To deploy the manual license technology 

1. Click Administer > License Technologies. The License Technologies page appears and lists ManualTech in 
the Draft state. 

2. Select the ManualTech check box, then click Change State ? and select Deploy from the drop-down menu. 
Click OK in the verification message that appears. In the License Technologies table, ManualTech is shown 
with a State of Deployed. This message appears: Deployed the following License Technologies 
successfully ManualTech 

Setting Up and Deploying the License Model
In this exercise, you set up and deploy the ManualModel license model. 

Task To set up the manual license model 

1. Click Administer > License Models. The Package Products – License Models page appears. 

2. Click Create New License Model. The Package Products – License Models page refreshes. 

3. Under Select A License Technology, select ManualTech from the License Technology menu, then click Next. 
The Package Products – License Models page refreshes. 

4. Under Create A License Model, enter the license model information. 

• Name: Type ManualModel 

• Description: Type Manual license model 

• State: Note that the license model is created in a Draft state. 

• License Technology: Note that this is set to ManualTech. 

• Expiration: Use the default value of None. 
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5. Click Save to create the ManualModel license model. This message appears: License Model successfully 
created. 

Task To deploy the manual license model 

1. Click Administer > License Models. The Package Products – License Models page appears. Search for and 
select the ManualModel check box. 

2. Click Change State ? and select Deploy from the drop-down menu. Click OK in the verification message that 
appears. In the License Models table, ManualModel is shown with a State of Deployed. 

Creating and Deploying the Product
In this exercise, you create a product called PhotoPrint-manual that uses the ManualTech license technology and 
ManualModel license model, then you deploy the product. 

Task To create product PhotoPrint-manual 

1. Click Products > Products. The Package Products page appears. 

2. Click Add New Product. The Package Products | Create A Product page appears.

3. Under Create A Product, enter the product information: 

• Product Name: Type PhotoPrint-manual 

• Version: Type 12.3 

• State: Note that the product is created in a Draft state. 

• License Technology: Select ManualTech 

4. Click Add Features. The Add Features To Product window opens. 

5. In the Add Features To Product window, search for feature name equals Print. Feature Print is listed under 
Available Features. 

6. In the Add Features To Product window, under Available Features, select  Print,12.3. 

7. Click Add ? to move feature Print,12.3 to Selected Features, then click Add. The window closes and the 
feature is added to product PhotoPrint-manual. 

8. Click Save. Note that product PhotoPrint-manual and its version appear in the list on the right side of the 
Package Products page. This message appears: Product PhotoPrint-manual successfully added. 

9. Click Next. The Package Products | Link License Models To Product page appears. 

10. Click Link License Models. The Select License Models window opens. Search for and select ManualModel from 
Available License Models, then click Add ? to move it to Selected License Models. 

11. Click Add. Product PhotoPrint-manual is linked to the ManualModel license model and the window closes. 

12. On the Package Products page, click Save. Note that product PhotoPrint-manual is now listed under 
Products Linked To License Models. This message appears: License models linked successfully. 
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Task To deploy product PhotoPrint-manual 

1. Click Products > Products. The Package Products page appears. Search for product PhotoPrint-manual and 
select its check box. 

2. Click Change State ? and select Deploy from the drop-down menu. Click OK in the verification message. The 
Package Products | Deploy Products page appears for product PhotoPrint-manual. 

3. Click Deploy. The Package Products page shows that PhotoPrint-manual is deployed. This message appears: 
Products deployed successfully.

License Activation
The exercises in this section use examples to guide you through these manual license activation tasks:

Entitling the Customer to the Product
In this exercise, you create, configure, and deploy an entitlement for 3 copies of product PhotoPrint-manual. 

Task To entitle the customer to product PhotoPrint-manual 

1. Click Entitlements > Create. The Entitle Customers to Licenses page appears. 

2. Under Create An Entitlement, from the Entitlement ID list, select Specify and type ENTL-manual in the box that 
appears next to it. Note that the entitlement is created in a Draft state. 

3. Under End Customer And Channel Partners, click Add. The End Customer And Channel Partners window 
opens. 

4. On the Customers tab, search for and select BarryPhoto as the account to receive the entitlement, then click 
Save. The End Customer And Channel Partners window closes, and the Entitle Customers to Licenses page 
shows Barry Photography Studio as the end customer. 

Task To configure the product PhotoPrint-manual entitlement 

1. On the Line Items tab near the bottom of the page, click New Line Item. The Configure Line Item wizard 
opens. 

2. In wizard step 1, Select Product, search for and select product PhotoPrint-manual, then click Next. 

Exercise Description

Entitling the Customer to the Product Create, configure, and deploy the product PhotoPrint-manual 
entitlement. 

Activating the License Activate a product PhotoPrint-manual license. 
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3. In wizard step 2, Select Part Number & License Model, leave the default values as they are. Click Next. 

4. In wizard step 3, Configure Product, enter these line item attributes: 

• Qty: Type 3 for the quantity of PhotoPrint-manual copies in this line item 

• Start Date: Select Use First Activation Date from the drop-down list 

• Expiration: Select Permanent 

• Keep the default values for all other attributes. 

Click Next. 

5. In wizard step 4, Custom Attributes, click Next. 

6. In wizard step 5, Order Type, keep the default value as it is. Click Save to save the line item and close the 
Configure Line Item wizard. 

7. On the Line Items tab, note that the line item for product PhotoPrint-manual is PERMANENT, has a total 
quantity of 3, and is in the Draft state. 

Task To deploy the product PhotoPrint-manual entitlement 

1. At the bottom of the Entitle Customers to Licenses page, click Save & Deploy. The page is refreshed, the Line 
Item State of PhotoPrint-manual is now Deployed, and this message appears: Entitlement deployed 
successfully. 

2. On the Entitle Customers to Licenses page, click Email to send entitlement notification email to Barry 
Photography Studio. Type your email address in the Ship To Email box so you receive the certificate. 

Note • To include additional recipients, type their email addresses into the Ship To Email box separated by 
commas. 

3. Click Send. The email is sent and this message appears: Email sent to the recipients <address list>. 

Activating the License
In this exercise, you activate a license for 1 copy of product PhotoPrint-manual. Your manual technology 
generates the license, while FlexNet Operations tracks fulfillment and other data. Because there is no 
programmatic link between them, your customer service staff must transfer license data from the manual 
technology to FlexNet Operations. 

The manual technology licensing work flow is: 

• On-hold Fulfillment – The end user initiates the fulfillment. FlexNet Operations collects the relevant 
information, then creates an on-hold fulfillment record. 

• Email Notification – FlexNet Operations sends email to notify customer service to begin the licensing process 
using your manual technology, with information collected in FlexNet Operations. 

• License Generation – Your customer service staff generates the license using your manual technology. 
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• Manual Update – Your customer service staff manually updates the fulfillment record in FlexNet Operations 
and sets the license, which activates the fulfillment record and allows the user to download the license. 

Task To activate the manual license 

1. On the Entitle Customers to Licenses page, click Activate. The List Entitlements page appears. 

2. In the Activatable Line Items table, click the Activation ID link for the PhotoPrint-manual product. The Line 
Item Details window opens. 

3. Review the details of the line item, noting that Qty and Qty Remaining are both 3, Start Date Option is Use 
First Activation Date, Permanent is true, and License Model is ManualModel, then click Cancel at the bottom 
to close the window. 

4. In the Activatable Line Items table, select the PhotoPrint-manual line item check box and click Activate. The 
List Entitlements | Generate Licenses page for the PhotoPrint-manual line item appears. 

5. Click Verify to verify the validity of the license. This message appears: License is Valid.

6. Click Generate. The Generated Licenses page appears, listing PhotoPrint-manual with a Count of 1. This 
message appears: 

License text has not been set for some of the fulfillments generated. The administrator has been 
notified. You will receive an email when the license is ready to download.

7. On the Generated Licenses page, click Complete. The List Entitlements page appears, listing the 
PhotoPrint-manual line item with an Available Quantity of 2, Total Quantity of 3, and Expiration of PERMANENT. 

8. Click Licenses > Licenses. The Support Licenses And Maintenance page appears, listing product 
PhotoPrint-manual with a Count of 1. The Type is ON HOLD (denoted by the N icon). 

9. Click the product PhotoPrint-manual Fulfillment ID link. The Fulfillment Details window opens. 

10. Review the fulfillment information, then click Cancel at the bottom to close the window. 

11. On the Support Licenses And Maintenance page, put a check mark in the product PhotoPrint-manual 
license’s check box, then click Set License. The Set License For Fulfillment window opens. 

12. In the Set License For Fulfillment window, browse to and select the appropriate License File for your 
scenario: 

• The actual license file generated by your manual license generator, or 

• the NonFlexManualLicenseFile.lic sample if no manual technology license generator is configured. 

Click OK. The Set License For Fulfillment window closes. On the Support Licenses And Maintenance page, 
Type changes from ON HOLD to Non-Flexnet (denoted by the NF  icon). 

13. On the Support Licenses And Maintenance page, put a check mark in the product PhotoPrint-manual 
license’s check box, then click Save to File. When you are asked whether you want to open or save the 
license file, select Open. 

14. Review the contents of the license file and close the window when you are done. 
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License Support
The exercises in this section use examples to guide you through these manual license support tasks:

Repairing the License
In this exercise, you repair the PhotoPrint-manual license. 

Task To repair the manual license 

1. Click Licenses > Licenses. The Support Licenses and Maintenance page appears. 

2. On the Support Licenses and Maintenance page, search for and select the check box next to the product 
PhotoPrint-manual fulfillment. 

3. Click Support Actions and select Repair from the drop-down menu. The Support Licenses And Maintenance 
page refreshes with the PhotoPrint-manual fulfillment information. 

4. Click Verify to verify the validity of the license. This message appears: License is valid. 

5. Click Repair. The Generated Licenses page appears with updated PhotoPrint-manual fulfillment information. 
Type is ON-HOLD (denoted by the N icon). This message appears: License text has not been set for some 
of the fulfillments generated. The administrator has been notified. You will receive an email when 
the license is ready to download. 

6. On the Generated Licenses page, click Complete. The Support Licenses And Maintenance page appears. 

7. Search for and select the check box next to the on-hold product PhotoPrint-manual fulfillment, then click Set 
License. The Set License For Fulfillment window opens. 

8. Browse to the PhotoPrint-manual license file, then click OK. The Set License For Fulfillment window closes. 
The Support Licenses And Maintenance page is refreshed and the PhotoPrint-manual fulfillment is no longer 
on hold. 

9. Click Entitlements > List Entitlements by Order, search for the product ENTL-manual entitlement, then click on 
the ENTL-manual link. The Entitle Customers to Licenses page appears. 

10. Under Line Items, on the Line Items tab, click the Fulfill History link of the PhotoPrint-manual line item. The 
Fulfillment History window opens. 

11. Review the fulfillment history for the PhotoPrint-manual line item. Note that it was repaired, generated and 
put on hold, and reactivated. Click OK when you are done to close the Fulfillment History window. 

Exercise Description

Repairing the License Repair the product PhotoPrint-manual license that you activated. 

Returning the License Return the product PhotoPrint-manual license. 
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Returning the License
In this exercise, you return the PhotoPrint-manual license. 

Task To return the manual license 

1. Click Licenses > Licenses. The Support Licenses and Maintenance page appears. 

2. On the Support Licenses and Maintenance page, search for and select the check box next to the product 
PhotoPrint-manual fulfillment. 

3. Click Support Actions and select Return from the drop-down menu. The Support Licenses And Maintenance 
page refreshes with the PhotoPrint-manual fulfillment information. 

4. Click Verify to verify the validity of the license. This message appears: License is valid. 

5. Click Return. The Support Licenses And Maintenance page is refreshed. A message similar to this appears: 
Successfully returned licenses for fulfillment FID_8fbd3105_8d5e_41b2_99a9_c867bca9ff8d 

6. Click Entitlements > List Entitlements by Order, search for the ENTL-handsfree entitlement, then click on the 
ENTL-handsfree link. The Entitle Customers to Licenses page appears. 

7. Under Line Items, on the Line Items tab, click the Fulfill History link of the PhotoPrint-manual line item. The 
Fulfillment History window opens. 

8. Review the fulfillment history for the PhotoPrint-manual line item. Note when it was returned. Click OK when 
you are done to close the Fulfillment History window. 

Hands-Free Technology
Licenses that use hands-free technology are generated programmatically between a client and the FlexNet 
Operations server using a third-party system. A license request, usually in XML format, is submitted to the license 
server, which processes the request and sends a response to the client. The server generates the license and 
stores the license information in FlexNet Operations, where it is tracked. 
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Advanced Topics
Brief descriptions of more advanced activation and support topics for producers who use FlexNet Operations with 
a non-FlexNet license technology are provided below. For more information about these advanced topics, refer to 
the FlexNet Operations On-Premises Installation & Implementation Guide, the FlexNet Operations Web Services 
Integration Guide or the FlexNet Operations SOAP Web Services Guide. 

License Activation
File Definitions
If the license technology uses multiple license files, multiple license file types can be defined for a fulfillment 
record. A license file type can be text or binary. 

Generator Validator
Implement the license model validator and product validator using a Java callout.

License Consolidator
Implement the custom license consolidator using a Java callout..

File Name Generator
Implement the custom file name generator using a Java callout.
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Custom HostID String
Implement the custom HostID string using a Java callout.

License Support
Rehosting a License
Moving a license from one machine to another is called rehosting. Batch rehosting is moving groups of licenses 
from one server to others by: 

• Redistributing – re-allocating licenses for a group of products among various license servers to change the 
license count of products on different servers 

• Transferring – moving all of an account’s licenses from one host to another, usually when a host machine 
crashes and the licenses on it must be moved to a new machine 

Upgrading a License
Changing a license for one version of a product to a license for an improved version of the product is called 
upgrading. For example, a customer can upgrade a license for Paint 4.0 to one for Paint 5.1. 

Upselling a License
Changing a license for one product to a license for another product with more capabilities is called upselling. For 
example, a customer who has a license for AntiMalware can be upsold to the Total PC Protection package, which 
includes AntiSpam and ParentalControl in addition to AntiMalware. 

Renewing a License
Extending an expiring license is called renewing a license. For example, a customer whose software license 
expires after one year can renew it for another year. 

Correcting a Producer Error
Regeneration of a license may be required because of a producer error, such as incorrect data entry. 

Generating an Emergency License
An emergency license is a short term license generated for a customer who cannot use the unexpired license. For 
example, while a customer’s main computer is being upgraded or repaired, the product must be used temporarily 
on another computer. 

Generating a Stop-Gap License
A stop-gap license is a short term license generated for a customer whose expired license renewal is being 
processed. 
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Getting Started with 
Cloud Licensing Service

The purpose of this section Getting Started with Cloud Licensing Service is to provide an overview on the use of 
FlexNet Operations and FlexNet Cloud Licensing Service (a feature of FlexNet Operations). For FlexNet Operations 
users who use FlexNet Embedded licensing, the FlexNet Cloud Licensing Service allows the rapid deployment of 
cloud-hosted license servers. 

This getting started section primarily describes concepts and tasks related to FlexNet Operations with FlexNet 
Cloud Licensing Service. For information about implementing a FlexNet Embedded client that communicates with 
license servers, see the appropriate FlexNet Embedded documentation. For example, the FlexNet Embedded 
Client C SDK User Guide or the FlexNet Embedded Client C XT SDK User Guide.

This getting started section is organized into the following sections.

To view a brief, informative video that walks you through the exercises in Getting Started with Cloud Licensing 
Service, click here. We recommend that you read this getting started section in full, to gain an understanding of 
the concepts it covers, before you view the video.

FlexNet Cloud Licensing Service Concepts
This section describes general concepts involved in working with FlexNet Operations, FlexNet Embedded, and 
FlexNet Cloud Licensing Service. The following are some of the concepts and terminology used throughout this 
documentation.

Topic Content

FlexNet Cloud Licensing Service 
Concepts

Provides general information about FlexNet Embedded license server 
terminology and tasks.

FlexNet Cloud Licensing Service 
Exercises

Provides a walkthrough of creating a cloud-hosted license server in 
FlexNet Operations.

https://www.youtube.com/watch?v=pdKsRCWL3EA
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FlexNet Embedded Licensing
FlexNet Embedded license technology is intended for use by software publishers and intelligent device 
manufacturers. 

Licensing software on each client (such as a device or a workstation) controls the feature set expressed. If the 
device has network connectivity, it can connect directly to FlexNet Operations and receive the license for its 
feature set. A device can also be activated off line or using a FlexNet Embedded license server. This getting 
started section focuses on a licensing model in which one or more clients interact with a cloud-hosted FlexNet 
Embedded license server.

FlexNet Embedded license technology also enables the use of perpetual, subscription, and demonstration license 
models in traditional software applications. 

Embedded licenses are of two types: 

• An uncounted license model allows a customer to deploy an unlimited number of licenses. 

• A counted license model restricts deployment to a limited number of licenses. The count is specified during 
the entitlement process. 

License Servers
Your served clients send capability requests to a FlexNet Embedded license server. In this getting started section, 
the license server is a license server instance hosted in the FlexNet Cloud Licensing Service that holds license 
rights for use by its served clients. 

Auto-Provisioning
License servers can be created manually or, when the license model permits auto-provisioning, automatically 
generated by FlexNet Operations. 

When auto-provisioning is permitted, FlexNet Operations generates a new license server when an entitlement 
using such a license model and owned by an end customer account, is deployed. Also, line items included in the 
entitlement are automatically mapped to the license server. 

When auto-provisioning is not permitted, producers can create the license server manually. In this scenario, the 
producer uses the Create License Server page to create a license server for the end customer and then manually 
maps the entitlement line items to that server. 

The exercises in this getting started section make use of auto-provisioning in the license model to streamline 
license server creation and entitlement mapping.

Limitations
The following limitations exist for auto-provisioned license servers that have entitlements mapped for metered 
features:

• License servers cannot be moved to another account.

• You cannot remove licenses using Licenses > Remove Licenses.
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• License servers can be made obsolete, which will remove all licenses mapped to the server. However, this is 
not recommended, because future line items will not be mapped automatically to the auto-provisioned 
license server.

Features
A feature represents a licensable capability defined in a software application, and is the basic building block for a 
product. A feature could represent any of the following:

• a product consisting of one or more components

• a specific version of a product

• a part of a product

• one or more pieces of data (restricted through the access routines)

An example of a feature would be the Add function in a calculator, or the Print function in a word processing 
program.

You define the feature or features that make up your products in FlexNet Operations. Licensing code checks for 
the availability of certain features to determine a product’s functionality.

During execution, your licensing code uses FlexNet Embedded functions that attempt to acquire a license. The 
FlexNet Embedded libraries validate such conditions as the feature not having expired. If the license acquisition 
succeeds, your code would then enable the corresponding capability.

Capability Requests and Responses
When your licensing code communicates with FlexNet Operations, the communications involve capability 
requests and capability responses. A capability request is generated by the client (requesting features that it will 
acquire). The request data contains some combination of a host identifier, one or more desired features, and 
other optional data to pass to FlexNet Operations.

The license server instance then processes the request, reading the various identifiers, desired features, and 
custom data. If FlexNet Operations determines that the client requires a response, it generates a capability 
response. The response data contains current license rights available for the client. The capability response is 
then conveyed back to the client, which processes the response, after which the features in the response can be 
queried for the sake of detecting if a quota has been exceeded or for feature clipping.

Your licensing code specifies one or more desired features, which represent features desired in the capability 
request. 

Your code also specifies an operation in the capability request, which indicates whether a response is expected. 
The “request” operation is used in feature-clipping scenarios, where a response is needed. 

Publishers and Publisher Identities
Before you use a FlexNet Embedded license technology, you must set up a publisher and identity on the FlexNet 
Operations Producer Portal. A publisher identity is binary data that contains a publisher or producer name and 
encryption data. A publisher is necessary to identify who the license belongs to and who can validate the license. 
An identity is used to secure communication between the back office and device. 
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Revenera supplies you with a unique publisher name and a series of five publisher keys. You use this name and 
these keys to set up a publisher. The keys cannot be regenerated or duplicated. 

The publisher can define any number of identities, each providing a different level of security for different classes 
of devices or licenses. For example, a line of high-end devices may require higher security than a line of low-end 
devices. When an identity is created, a digital signature algorithm is selected to prevent forgery and tampering on 
the device. 

FlexNet Cloud Licensing Service Exercises
This section describes how to get started with FlexNet Operations and FlexNet Cloud Licensing Service. You will 
learn about setting up a license server in FlexNet Operations and connecting your clients to their license server 
instance in FlexNet Cloud Licensing Service. 

The section is divided into the following subsections. 

Prerequisites
The following items are prerequisites for developing and deploying licensing code with the FlexNet Operations 
Producer Portal and your FlexNet Embedded toolkit. 

FlexNet Embedded Client Implementation
It is assumed that you have downloaded your FlexNet Embedded platform for implementing an application to 
obtain license rights from a license server. You should already have implemented FlexNet Embedded C SDK or 
FlexNet Embedded XT code for a connected application running in a customer environment. See the 
corresponding FlexNet Embedded documentation for information about building the example code and 
implementing a served client.

To complete the exercises in this getting started section, users also must have received publisher keys from 
Revenera. 

Note • The creation of a publisher and an identity are covered in the section Getting Started with 
FlexNet Embedded Licensing. 

Section Description

Prerequisites Prerequisites for included exercises.

Preparing FlexNet Operations Exercises to create a license server in FlexNet Operations. This section 
includes creating your license models, features, products, and so forth.

Obtaining the License Server URL Instructions for determining the URL for the license server instance with 
which your served clients communicate for license rights. 

Running a Served Client Example Brief discussion of how to confirm that counts can be successfully 
mapped from the license server to its FlexNet Embedded clients. 
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FlexNet Operations Instance
It is also assumed that you have access to FlexNet Operations via the Producer Portal and the End-User Portal. 
Producers must have already activated their producer account and user account activated on the Producer Portal 
in which FlexNet Embedded and FlexNet Cloud Licensing Service features are enabled. 

Preparing FlexNet Operations
To prepare FlexNet Operations to create a license server, you must create and associate several entities using the 
Producer Portal. Many of these steps are common to any use of FlexNet Operations with FlexNet Embedded.

This preparation includes the following exercises. 

After you verify that the new license server was created, the FlexNet Operations preparations are complete. 
Continue with Obtaining the License Server URL and Running a Served Client Example.

If you have not previously used FlexNet Operations, see the section Getting Started with 
FlexNet Embedded Licensing for more information. 

Creating License Models
In this exercise, you create license models to use with the products to be created in later exercises. Two license 
models will be created: one for use with the counted product to be mapped to the license server and the other to 
serve as a baseline product to manage client registration. You then deploy both these license models before 
proceeding to create features. 

Exercise Description

Creating License Models Shows how to create and deploy license models to use with the 
example products we plan to deliver through the license server.

Creating Features Explains how to create the example feature, scientific-operations, as 
well as a baseline feature with which served clients can be 
registered.

Creating Products Explains how to create the products necessary to create the 
entitlement line items to be delivered through the license server. 

Creating an Account and a User Shows how to create a customer account and user to which the new 
product will be entitled.

Entitling the Account Describes how to create an entitlement, configure its line items with 
the new products, and entitle the customer account to those line 
items.

Viewing the Auto-Provisioned License 
Server

Explains how to find the license server that was created when the 
entitlement was deployed. 
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Creating a Counted License Model
For the product that will contain the counted feature, create a license model called Example Embedded Counted. 
Example Embedded Counted will be a copy of the Embedded Counted license model with auto-provisioning, but 
with additional license model policies set to Not Used. 

Specify the following settings for the copied Embedded Counted license model:

For any attributes not listed, above, keep the settings copied from the Embedded Counted license model

Task To create the Example Embedded Counted license model

1. In the Producer Portal, click Administer > License Models. The Producer Portal opens the License Models 
page. 

2. On the License Models page, locate the built-in Embedded Counted license model, select its checkbox, and 
then click Copy. This button opens the Create a License Model page with attribute settings that match 
Embedded Counted. 

3. Specify license model name and expiration setting. For this exercise, use the values specified in the table 
above: Example Embedded Counted and None.

4. Set the license model attribute values described in the table above, and click Save. 

The Producer Portal creates the license model with the settings you specified. 

Creating an Uncounted License Model for Client Registration
For connected software client security, the client registration process requires an additional uncounted license 
model. For this purpose, create a second license model, called Example Baseline LM. Example Baseline LM will be 
a copy of the Embedded Uncounted license model with additional license model policies set to Not Used. 

Attribute Value

Name Example Embedded Counted

Auto Provision Yes

Issuer Not Used

Serial Number Not Used

Vendor String Not Used

Notice Not Used
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For the second part of this exercise, repeat the license model creation process but specify the following settings 
to the copied Embedded Uncounted license model:

For any attributes not listed, above, keep the settings copied from the Embedded Uncounted license model

Task To create the Example Baseline LM license model

1. In the Producer Portal, click Administer > License Models. The Producer Portal opens the License Models 
page. 

2. On the License Models page, locate the built-in Embedded Uncounted license model, select its checkbox, 
and then click Copy. This button opens the Create a License Model page with attribute settings that match 
Embedded Uncounted. 

3. Specify license model name and expiration setting. For this exercise, use the values specified in the table 
above: Example Baseline LM and None.

4. Set the license model policy values described in the table above, and click Save.

The Producer Portal creates the license model with the settings you specified. 

Deploying the License Models
The new license models must be deployed before they can be linked to products or used in entitlement line items.

Task To deploy the Example Embedded Counted and Example Baseline LM license models

1. In the Producer Portal, click Administer > License Models. The Producer Portal opens the License Models 
page. 

2. On the License Models page, locate the license models: Example Embedded Counted and Example Baseline 
LM. If it do not immediately appear in the License Models list, try searching License Models for Example.

3. Select the checkboxes for both license models, and then click Change State > Deploy.

4. Click OK to confirm the state-change operation. 

The Producer Portal deploys the license model and refreshes the License Models page to show the new Deployed 
state.

Attribute Value

Name Example Baseline LM

Issuer Not Used

Serial Number Not Used

Vendor String Not Used

Notice Not Used
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Figure 13-1: Example Embedded Counted and Example Baseline LM license models deployed

Creating Features
In the Producer Portal, use the commands under the Products menu to add a feature called scientific-
operations, version 1.0. and a feature called baseline-client-reg, version 1.0. When defining the features, use 
the following settings:

Leave all other attribute settings on their default values.

Creating an Counted Feature to Map to the License Server
Use the instructions, below, to create the scientific-operations feature.

Task To create the scientific-operations feature

1. In the Producer Portal, click Products > Features. The Producer Portal opens the Feature page. 

2. On the Feature page, click Add New Feature. This button opens the Create a Feature page. 

3. On the Create a Feature page, set the feature attributes using the values in the table above. 

4. Click Save. 

The Producer Portal creates the scientific-operations feature and remains on the Create a Feature page. 

Attribute Value

Feature Name scientific-operations

Feature Version 1.0

Description Example feature for cloud-hosted license server 
exercises.
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Figure 13-2: The Create a Feature page for the scientific-operations feature.

Creating an Uncounted Feature for Client Registration
For security, the client registration process requires an additional uncounted feature. For this purpose, create a 
second feature called baseline-client-reg. 

Repeat the feature creation process for the baseline feature. Use the settings shown in the table below. 

Leave all other attribute settings on their default values.

Creating Products
Use commands under the Products menu to create two products: Example Calculator for the counted features 
and Example Baseline for the baseline-client-reg feature

Attribute Value

Feature Name baseline-client-reg

Feature Version 1.0

Description Example feature to do client-registration for 
products to be run on served clients.
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Creating the Example Calculator Product
The Example Calculator product includes the counted feature you defined in the previous exercise: scientific-
operations. Use the following settings when creating Example Calculator:

Task To create Example Calculator

1. In the Producer Portal, click Products > Products. The Producer Portal opens the Products page. 

2. On the Products page, click Add New Product. This button opens the Create a Product page. 

3. On the Create a Product page, set Product Name, Version, License Technology, and Can Be Used on a Device 
as shown in the table above.

4. Click Add Features. The Producer Portal opens the Add Features to Product page in a pop-up window. 

a. Locate the feature, scientific-operations, 1.0., and click Add. This selects the feature and moves it to the 
Selected Features list.

b. Click Add. The Producer Portal closes the Add Features to Product window. 

5. On the Create a Product page, set the Quantity for the scientific-operations feature to 1, and click Next. (For 
a counted feature, this is the feature count per copy of the product ordered.) The Producer Portal opens the 
Link License Models to Product page. 

6. Click Link License Models to open the Select License Models page in a pop-up window. 

a. Locate the license model, Example Embedded Counted, and click Add. This selects the license model 
and moves it to the Selected License Models list.

b. Click Add. The Producer Portal closes the Select License Models window.

7. Click Save.

The Producer Portal saves Example Calculator and remains on the Map Product to Product Line page. 

Attribute Value

Product Name Example Calculator

Description An example counted product used with the exercises in the section 
Getting Started with Cloud Licensing Service

Version 1.0

Licensing Technology FlexNet Licensing

Can Be Used on a Device Yes

Feature scientific-operations

Feature Quantity 1

License Model Example Embedded Counted
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Creating the Example Baseline Product
Next, repeat the steps, creating a product for the uncounted baseline-client-reg feature and uncounted license 
model used in client registration. Use the following settings for the Example Baseline product.

Important • Before these new products can be used in an entitlement, you must deploy them. (Deploying a 
product changes its state, and the state of its features, from draft to deployed.) Select the checkboxes for the 
Example Calculator and Example Baseline products, click Change State > Deploy, and follow the on screen 
instructions to confirm the change.

Figure 13-3: Example Baseline and Example Calculator products deployed

Attribute Value

Product Name Example Baseline

Description A product to contain the uncounted, baseline feature to be used for client 
registration on served clients.

Version 1.0

Licensing Technology FlexNet Licensing

Can Be Used on a Device Yes

Feature baseline-client-reg,1.0

Feature Quantity 1

License Model Example Baseline LM



Chapter 13 Getting Started with Cloud Licensing Service
FlexNet Cloud Licensing Service Exercises

478 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Creating an Account and a User
In the FlexNet Operations Producer Portal, use the commands under the Users & Accounts menu to create an 
account that represents a customer enterprise. For this example, create an account called Demo Customer Org.

Note • The creation of this customer account and end user is also part of other FlexNet Operations getting started 
sections. If the account and user already exist in the Producer Portal, you can skip this exercise.

If you already have a test end user in a customer account you can entitle to these products, you can opt use that 
user instead of creating the user described here. Otherwise, follow the instructions, below, to create the 
customer account (Demo Customer Org), the end user account (Demo Customer) and entitle it to the Example 
Calculator and Example Baseline products.

Task To create the customer account and end user

1. In the Producer Portal, click Users & Accounts > Create Account. The Producer Portal opens the Create an 
Account page. 

2. On the Create an Account page, type the following values for the Account Name and Display Name attributes. 

Keep the default values for all other attributes.

3. Click Create a User. The Producer Portal saves the Demo Customer Org account and opens the Create a User 
page to add a new user to it.

4. On the Create a User page, type the following values for the new user’s Contact Details: 

Keep the default values for all other User Details and Contact Details attributes.

5. In Accounts, select the check box for Portal User Role. This gives Demo Customer the standard permissions 
for portal users. 

6. Click Save. 

Attribute Value

Account Name DemoCustOrg

Display Name Demo Customer Org

Attribute Value

First Name Demo

Last Name Customer

Email Address An email address you control. This email account is where FlexNet Operations 
will send the initial login credentials and entitlements.
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The Producer Portal creates Demo Customer as a new user and sends a welcome message to the email address 
you provided. Use the credentials in that email to log in to the End User Portal and verify the Demo Customer 
account is functional.

Entitling the Account
Use the commands in the Entitlements menu to create an entitlement to the Example Calculator and Example 
Baseline products for Demo Customer Org. 

In this exercise, you will create a new entitlement, add Demo Customer Org as the end customer, configure a line 
item for the uncounted product for client-registration, Example Baseline, and configure another line item for the 
counted product, Example Calculator. 

Task To create the entitlement ENTL-SCI-OPS

1. In the Producer Portal, click Entitlements > Create. The Producer Portal opens the Create an Entitlement 
page. 

2. For Entitlement ID, select Specify and type ENTL-SCI-OPS. 

3. For End Customer and Channel Partners, click Add. The Producer Portal opens the End Customer and 
Channel Partners page in a pop-up window. 

a. Click the DemoCustOrg option to select the Demo Customer Org as the customer account to receive the 
entitlement. 

b. Click Next. The Producer Portal shows the End Customer and Channel Partners: Contacts page in the 
pop-up window.

c. Click the Demo Customer option to select Demo Customer as the end user who will receive the 
entitlement message.

d. Click Save.

The Producer Portal closes the pop-up window and shows Demo Customer Org and Demo Customer as the 
end customer. 

4. Click New Line Item to begin configuring a line item for the Example Baseline product. The Producer Portal 
opens the Configure Line Item page in a pop-up window.
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Figure 13-4: Starting the line item configuration process for the Example Baseline product.

a. Locate and select the Example Baseline product, and then click Next. 

b. Select the license model, Example Baseline LM, and click Next. 

c. Specify the following settings for product configuration: 

• Qty: 1

• Start Date: Use First Activation Date

• Expiration: 01/01/2020

d. Click Next.

e. Click Save.

5. Click New Line Item to begin configuring a line item for the Example Calculator product. The Producer Portal 
opens the Configure Line Item page in a pop-up window.

a. Locate and select the Example Calculator product, and then click Next. 

b. Select the license model, Example Embedded Counted, and click Next. 

c. Specify the following settings for product configuration: 

• Qty: 30

• Start Date: Use First Activation Date

• Expiration: 01/01/2020

d. Click Next.

e. Click Save.

6. Click Save & Deploy.

The Producer Portal saves ENTL-SCI-OPS with line items for Example Baseline and Example Calculator. 
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Figure 13-5: The entitlement line items for Example Calculator and Example Baseline in ENTL-SCI-OPS

FlexNet Operations also generates the license server and maps the Example Calculator line item to the new 
server. 

Tip • Make a note of the resulting activation ID for Example Baseline. (Yours will be different than the activation ID 
depicted in the figure above.) When you run a connected client, you will use the activation ID as the rights ID 
during the client registration process.

Viewing the Auto-Provisioned License Server
Once you deploy the entitlement, ENTL-SCI-OPS, FlexNet Operations automatically generates the license server 
from which served clients in the end customer account acquire their license rights. In this exercise, you will 
locate the auto-provisioned license server in the Producer Portal. 

Task To view the auto-provisioned license server

1. In the Producer Portal, click Devices > Devices. The Producer Portal opens the Devices page. 

2. On the Devices page, locate the new license server by its account name. 

a. In the search controls, select Account name from the drop-down list. 

b. Type DemoCustOrg in the search field and then click Search. 

3. On the Devices search results page, click the Name of DemoCustOrg’s license server. The Producer Portal 
opens the View Server page. 

Notice that the View Server page shows a number of important attributes of the license server. In particular, make 
a note of the license server ID. The license server ID, in this case 3VH8MNZESMSP, is also the instance ID value 
for the server URL. This instance ID value is used in the endpoint URL where the served clients connect to make 
capability requests. (See Obtaining the License Server URL.)
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Notice also, that the license Server’s View Server page also shows the product licenses that are served by it. In 
this case, the license server includes the Example Calculator line item from the ENTL-SCI-OPS entitlement. (The 
Example Baseline line item is not served by the license server. Instead, it is present in the entitlement to support 
the registration of its served clients.)

Tip • When auto-provisioning is used, you can also find a customer account’s default license server instance on 
customer account’s Create an Account page. There, click the license server ID link, labeled Cloud Licensing 
Service instance (Auto Provisioned), to open the View Server page.

Obtaining the License Server URL
The URL for the license server identifies the location where your FlexNet Embedded client communicates with its 
cloud-hosted license server. For a connected software client using the FlexNet Embedded C SDK or FlexNet 
Embedded XT, the URL is:  

http://<serverhost>:<serverport>/gls/instances/<CLS instance ID>/request 

In the URL, above, <serverhost> is the hostname for your FlexNet Operations instance and <serverport> is the 
HTTP port. <CLS instance ID> is the license server ID of the license server with the license rights to the Example 
Calculator product. The <CLS instance ID> value based on the license server created in the exercises in this 
section would be 3VH8MNZESMSP.

Running a Served Client Example
At this point, you can put the pieces together and run a served client from your FlexNet Embedded client toolkit.

Use FlexNet Embedded C SDK or FlexNet Embedded XT to implement a served client that is configured with the 
correct endpoint URL for the license server. 

In these implementations, you first send a capability request that specifies the Example Baseline activation ID as 
a rights ID, to claim the client, and then send a capability request containing the desired feature, scientific-
operations, to request counts from the license server. 

See your FlexNet Embedded user guide for other served client and license server implementation details and 
examples.
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Getting Started with 
Entitlement Management

This section Getting Started with Entitlement Management presents fundamental FlexNet Operations concepts 
and uses exercises to guide you through creation of a product entitlement, including the supporting tasks. Topics 
and exercises are presented in the order that a Producer Portal user would perform them when setting up a new 
customer account, customer user, and product, and then creating an entitlement. 

The intended audience for Getting Started with Entitlement Management is the first-time Producer Portal user, or 
one without FlexNet Operations training or experience. This getting started section is organized into the following 
topics. 

To view a brief, informative video that walks you through the exercises in Getting Started with 
Entitlement Management, click here. We recommend that you read this getting started section in full, to gain an 
understanding of the concepts it covers, before you view the video. 

Topic Content

 Introduction Overview of this getting started section, exercise prerequisites, and a 
summary of the FlexNet Operations license lifecycle. 

 Account and User Creation Customer account, customer user, and producer account concepts with 
exercises that demonstrate how to create each of them. Brief descriptions 
of advanced account topics with references for more information. 

 Product Creation Product packaging concepts with exercises that demonstrate how to 
create, link a license model to, and deploy a product. Brief descriptions of 
advanced product packaging topics with references for more information. 

 Entitlement Creation Entitlement concepts with exercises that demonstrate how to create, 
configure, and deploy an entitlement, and how to review it on the End-User 
Portal. Brief descriptions of advanced entitlement topics with references for 
more information. 

https://www.youtube.com/watch?v=3cEJQ_HhHow&feature=youtu.be
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Introduction
This section lists exercise prerequisites, and provides a summary of the FlexNet Operations license lifecycle. 

• Exercise Prerequisites

• The License Lifecycle: Entitlement Management

Exercise Prerequisites
Before you begin the exercises in this getting started section:

• FlexNet Operations must be properly installed and configured

• FlexNet Operations seed data and demonstration database must be loaded 

Important • These exercises require a FlexNet Operations database populated with demonstration data. 
Refer to the step-by-step instructions in the FlexNet Operations On-Premises Installation & Implementation 
Guide to create seed data using the flexnet loaddb command and to populate the sample data using the 
flexnet demodata command. 

• FlexNet Operations email templates must be set up 

• You must have a FlexNet Operations Producer Portal login and a role with permission to view and manage 
accounts and users, such as System Administrator 

The License Lifecycle: Entitlement Management
The FlexNet Operations license lifecycle is a repeating process of producer and customer activities, as depicted in 
the figure and described below. 
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Figure 14-1:  FlexNet Operations License Lifecycle

Product creation and entitlement, the first two stages of the license lifecycle, are covered in this getting started 
section. 

• Create Products – Create product definitions that are used to generate licenses. 

• Order/Entitle – Define a customer’s rights to obtain licenses for your products. 

• Deliver⁄Install – Deliver the application software to the customer and install that software. 

• Activate – Deliver licenses to the customer. 

• Return/Rehost – Manage license transfers from one user or system to another. 

• Maintain/Update – Deliver software and license updates to the customer. 

• Upsell/Renew – Renew customer licenses, or sell the customer additional product functionality. 

Account and User Creation
This topic introduces fundamental FlexNet Operations account and user concepts, and guides you through 
customer account and customer user setup tasks in preparation for entitlement creation. 

• Account and User Creation Key Concepts

• Account and User Creation Exercise Scenario

• Account and User Creation Exercises
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• Account and User Creation Next Steps

• Account and User Creation Advanced Topics

Account and User Creation Key Concepts
Accounts 
To be associated with an entitlement, a company must be entered as one of the FlexNet Operations account 
types. Account and User Creation Key Concepts touches only on the account types relevant to this section’s 
entitlement creation exercises: 

• Producer – software producer or intelligent device manufacturer 

• Customer – end user of the software or device 

User Roles 
A FlexNet Operations user must belong to one of the FlexNet Operations account types, and a user name and 
password are required to log in. Revenera creates the initial user account for a producer’s FlexNet Operations 
System Administrator, then the System Administrator creates any additional users required for the producer’s 
account and for the producer’s customers (end users). 

The activities a user can perform are based on the permissions that user has. However, permissions are not 
assigned to users directly. Instead, permissions are grouped into roles and FlexNet Operations users are 
assigned one or more roles. Account and User Creation Key Concepts touches only on the user roles relevant to 
this section’s entitlement creation exercises; these roles, and others, are provided as seed data: 

• System Administrator – a producer FlexNet Operations administrator who has the ability to create new roles 
for producer personnel and end users by assigning specific permissions 

• Portal Administrative User – a customer user who has End-User Portal administrative privileges 

• Portal User – an End-User Portal customer user 

Account and User Creation Exercise Scenario
GraphicsPrint is a producer offering specialized printing services for its customers, who can pre-purchase these 
services. GraphicsPrint’s LargeFormat product line includes the PhotoPrint, SignPrint, and CADPrint products. 

In Account and User Creation Exercises, you set up GraphicsPrint’s customer account Barry Photography Studio 
and customer end-user Lisa Barry. 

In Product Creation Exercises, you set up GraphicsPrint’s LargeFormat product line and the PhotoPrint product, 
which includes FlexNet Operations demonstration data features PrintToPDF, Print, and PrintHighQualityColor. 

In Product Creation Exercises, you entitle customer account Barry Photography Studio to use the PhotoPrint 
product. 
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Account and User Creation Exercises
The following exercises use examples to guide you through the customer account and end user setup tasks: 

Creating a Producer User
One of the first tasks you perform as a Producer Portal administrator is creating producer users and assigning 
them roles. The procedure for creating a producer user is similar to the one below for creating a customer user. 
For more information on creating different types of users, refer to Creating a User. 

Note • In these exercises, FlexNet Operations default producer My Organization (MYORG) represents 
GraphicsPrint.

Creating a Customer Account
In this exercise, you create customer account Barry Photography Studio. 

Task To create a customer account 

1. Log in to the FlexNet Operations Producer Portal. 

2. Click Accounts & Users > Create Account. The Create An Account page appears. Note that Account Type is 
CUSTOMER. 

3. On the Create An Account page, enter the customer account attributes: 

• Account Name: Type BarryPhoto 

• Display Name: Type Barry Photography Studio 

• Keep the default values for all other attributes. 

4. Click Save. The Barry Photography Studio account is saved and this message appears: Account BarryPhoto 
has been successfully added. 

Creating a Customer End User
In this exercise, you create end user Lisa Barry. 

Exercise Description

Creating a Customer Account Create customer account Barry Photography Studio.

Creating a Customer End User Create customer end user Lisa Barry.
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Task To create a customer end user 

1. On the same Create An Account page, click Create a User. The Create A User page appears. 

2. Under Contact Details, enter the new customer user’s attributes: 

• First Name: Type Lisa 

• Last Name: Type Barry 

• Email Address: Type an email address you control. This is the customer’s End-User Portal login user 
name. 

Note • This is also the email account to which FlexNet Operations sends the customer’s initial 
credentials and entitlements. 

• Keep the default values for all other user and contact attributes. 

3. Under Accounts, select the check box for Portal Admin User Role. This gives Lisa Barry administrative Portal 
User permissions. 

4. Click Save. New user Lisa Barry is created and this message appears: User Lisa Barry successfully 
added.A welcome email is sent to the email address you provided. 

5. Record the credentials you receive in the welcome email, then use them to log in to the FlexNet Operations 
End-User Portal and verify that the Lisa Barry account is functional. 

Note • The first time the customer logs in to the FlexNet Operations End-User Portal, he/she is asked to 
change the temporary password and select security questions. 

6. Log out of the FlexNet Operations End-User Portal. 

7. Log out of the FlexNet Operations Producer Portal or continue with Product Creation. 

Account and User Creation Next Steps
Product creation, the first stage of the FlexNet Operations license lifecycle, includes packaging features, linking a 
license model or models, and deploying the product. The exercises in Product Creation guide you through FlexNet 
Operations product creation. 

Account and User Creation Advanced Topics
For more information about these advanced account topics and others, refer to the sections Managing Accounts, 
Managing Users, and Getting Started with Advanced Organization Management.

Account Types 
FlexNet Operations categorizes accounts into four types: Producer, Customer, Partner, and Self Registered. 
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Partners and Distribution Tiers 
Accounts can represent the relationship between a producer and its distribution chain. 

Sub-Accounts 
Accounts can have sub-accounts, which can be used to reflect the hierarchical nature of corporate structures. 
Accounts and sub-accounts are defined in a parent-child relationship. 

Product Lines 
When the product lines feature is enabled, FlexNet Operations filters what customer users see based on the 
product lines linked to the users’ accounts. Only entitlements that include products in product lines to which the 
user account is linked are visible. 

Working with User Roles and Permissions 
You can administer user access roles and permissions. 

Product Creation
This topic introduces fundamental FlexNet Operations product concepts, and guides you through product setup 
tasks in preparation for entitlement creation. Product creation, the first stage of the FlexNet Operations license 
lifecycle, includes packaging features, linking a license model or models, and deploying a product. 

• Product Creation Key Concepts

• Product Creation Exercises

• Product Creation Next Steps

• Product Creation Advanced Topics

Product Creation Key Concepts
Products, Product Suites, and Product Lines 
Products are packages of entities, called features and feature bundles, that can be sold by a producer. A feature 
is a software functionality or set of functionalities. Feature definitions created in the FlexNet Operations Producer 
Portal correspond to product features defined in the product’s code. Features can be grouped into feature 
bundles for modular control over how the features are packaged in different products. Typically, a feature bundle 
consists of features grouped by similarity, complexity level, or other defined criteria (grouping features into a 
feature bundle is optional). 

A product suite is a set of products grouped together for promotional purposes or because the products are 
functionally complementary (grouping products into a product suite is optional). 

Products can be assigned to product lines, which define user access rights to product information. Product lines 
can also be used to group products for searching and reporting purposes. 
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Important • Product lines are required for FlexNet Embedded licensing and electronic software delivery; 
otherwise, they are optional. For more information, refer to the sections Getting Started with 
FlexNet Embedded Licensing and Getting Started with Electronic Software Delivery. 

Entity States 
The state of an entity, such as a product or its component features or feature bundles, determines how that entity 
can be referenced in different stages of its configuration. Allowed state transitions are shown in the figure, and 
the states are described below it. 

• Draft – The default state when an entity is created. In this state, the entity can be edited, but it is not 
available for production use. 

• Deployed – The entity is available for production use. If an entity is deployed accidentally and no other 
entities refer to it, it can be moved back to draft state. 

• Inactive – The entity has been withdrawn from use. No new references can be made to it, but existing 
references remain unchanged. 

• Obsolete – The entity exists only for reporting purposes. While there is existing data that refers to it, no new 
references can be made. An obsolete entity can be deleted if there are no references to it. 

Changing an entity from one state to another affects the states of related entities. For example, when a product is 
deployed, its component features and feature bundles are also deployed. However, when a product is made 
inactive or obsolete, its features and feature bundles are unaffected because a feature or feature bundle can be 
associated with several different products. A deployed entity may be modifiable, depending on configuration. 

Product Creation Exercises
These exercises use examples to guide you through the following product creation tasks: 

Exercise Description

Deploying a License Technology and 
Model

Deploy the FlexNet Licensing technology and Nodelocked 
Uncounted license model. 
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Deploying a License Technology and Model
A license model defines characteristics that determine how, when, where, and by whom a Flex-enabled 
application can be used. In this exercise, you deploy the FlexNet Licensing technology and its Nodelocked 
Uncounted license model. 

Important • Licensing is not covered in this getting started section. These tasks are included because product 
PhotoPrint must be linked to a license model to be deployed. For more information, see Administering License 
Technologies, or these getting started sections: 

• Getting Started with FlexNet Embedded Licensing

• Getting Started with FlexNet Publisher License File-Based Licensing

• Getting Started with FlexNet Publisher Trusted Storage-Based Licensing 

• Getting Started with Non-FlexNet Licensing Technologies 

Task To deploy the license technology 

1. Log in to the FlexNet Operations Producer Portal if you logged out after completing the Account and User 
Creation exercises. 

2. Click Administer > License Technologies. The License Technologies page appears, listing FlexNet Licensing 
with a state of draft. 

3. Select the FlexNet Licensing check box, then click Change State ▼ and select Deploy from the drop-down 
menu. Click OK in the verification message. In the License Technologies table, FlexNet Licensing is shown 
with a State of Deployed. This message appears: Deployed the following License Technologies 
successfully: FlexNet Licensing. 

Task To deploy the license model 

1. Click Administer > License Models. The Package Products - License Models page appears. 

2. Select Nodelocked Uncounted. 

Creating a Product Line Create product line LargeFormat. 

Creating a Product Create product PhotoPrint. 

Linking a License Model to a Product Link the Nodelocked Uncounted license model to product 
PhotoPrint. 

Mapping a Product to a Product Line Map product PhotoPrint to product line LargeFormat. 

Deploying a Product Review the attributes of product PhotoPrint and deploy it. 

Exercise Description
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3. Click Change State ▼ and select Deploy from the menu. 

4. Click OK in the verification message. In the License Models table, Nodelocked Uncounted is shown with a 
State of Deployed. This message appears: Deployed the following License Model(s) successfully: 
Nodelocked Uncounted. 

Creating a Product Line
In this exercise, you create product line LargeFormat, which includes the product PhotoPrint that you create in the 
next exercise. 

Important • Product lines are required for FlexNet Embedded licensing and electronic software delivery; 
otherwise, they are optional. For more information, refer to the sections Getting Started with 
FlexNet Embedded Licensing and Getting Started with Electronic Software Delivery. 

Task To create product line LargeFormat 

1. Click Products > Product Lines. The Package Products | Product Lines page appears. 

2. Click Add Product Line. Under Create Product Line, enter the product line attributes: 

• Name: Type LargeFormat 

• Description: Type Includes products PhotoPrint, SignPrint, and CADPrint.

3. Click Save. This message appears: Product Line added successfully. 

4. Click Products > Product Lines. The Package Products | Product Lines page appears. Note that LargeFormat 
is listed in the Product Lines table with its description. 

Creating a Product
In this exercise, you create product PhotoPrint from FlexNet Operations demonstration data features PrintToPDF, 
Print, and PrintHighQualityColor. 

Task To create product PhotoPrint 

1. Click Products > Products. The Package Products page appears. 

2. Click Add New Product. Under Create A Product, enter the product attributes: 

• Product Name: Type PhotoPrint 

• Description: Type Sends to PDF file, prints normal quality, or prints high quality. 

• Version: Type 12.0 

• Keep the default values for all other attributes. 

3. Click Add Features. The Add Features To Product window opens. 
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4. In the Add Features To Product window, search for feature names that contain the string Print. Features 
Print, PrintHighQualityColor, PrintToFiery, PrintToPDF, and PrintToPlotter are listed under Available 
Features. 

5. In the Add Features To Product window, under Available Features, select  Print, PrintHighQualityColor, 
and PrintToPDF. 

Note • Press CTRL+click to select non-contiguous items. Press SHIFT+click to select a range of items. 

6. Click Add ► to move features Print, PrintHighQualityColor, and PrintToPDF to Selected Features, then 
click Add. The window closes and the features are added to product PhotoPrint. 

7. The features are listed in the Feature or Feature Bundle Name table with their Name, Version, State, and 
Quantity. In the Quantity column, keep the default values of 1 to specify that there is one copy each of 
features Print, PrintHighQualityColor, and PrintToPDF in product PhotoPrint. 

8. Click Save. Note that product PhotoPrint and its version appear in the list on the right side of the page. This 
message appears: Product PhotoPrint successfully added. 

Linking a License Model to a Product
In this exercise, you link the Nodelocked Uncounted license model to product PhotoPrint. 

Task To link the license model to product PhotoPrint 

1. Click Products > Products. The Package Products page appears. 

2. Search for product PhotoPrint, then click its link in the product table. The Package Products | Create A 
Product page appears with product PhotoPrint information.

3. Click Next. The Package Products | Link License Models To Product page for PhotoPrint appears. 

4. Click Link License Models. The Select License Models window opens. 

5. Search for and select Nodelocked Uncounted from Available License Models, then click Add ► to move it to 
Selected License Models. 

6. Click Add. The Select License Models window closes. 

7. On the Package Products page, click Save. Product PhotoPrint is linked to the Nodelocked Uncounted 
license model. This message appears: License models linked successfully.Note that product PhotoPrint 
appears with its description in the list on the right side of the page. 

Mapping a Product to a Product Line 
In this exercise, you map product PhotoPrint to product line LargeFormat that you created in the previous 
exercise. 
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Task To map product PhotoPrint to product line LargeFormat 

1. Click Products > Products. The Package Products page appears. 

2. Search for product PhotoPrint, which is listed as an uncategorized product because it is not mapped to a 
product line. Click the PhotoPrint link in the product table. The Package Products | Create A Product page 
appears with product PhotoPrint information.

3. Click Next four times to advance to the Package Products | Map Product To Product Line page for 
PhotoPrint. 

4. Under Map Product To Product Line, do either of the following to specify the product line LargeFormat:

• In the Product Line field, type LargeFormat.

• Click the search icon next to the Product Line box. The Select Product Line For Product window opens. 
Search for and select product line LargeFormat, then click OK. The Select Product Line For Product 
window closes.

5. On the Package Products page, click Save to map product PhotoPrint to product line LargeFormat. This 
message appears: PhotoPrint is successfully mapped to product line LargeFormat. 

Deploying a Product
In this exercise, you review the attributes of product PhotoPrint, then you deploy it. 

Task To review the attributes of product PhotoPrint 

1. Click Products > Products. The Package Products page appears. 

2. Search for product PhotoPrint and note that it is in the Draft state. 

3. Click the PhotoPrint link. The Package Products | Create A Product page appears. Under Create A Product, 
review these attributes: 

• Product Name: PhotoPrint 

• Description: Sends to PDF file, prints normal quality, or prints high quality. 

• Version: 12.0 

• State: Draft 

4. Scroll down to the Feature or Feature Bundle Name table and note that PhotoPrint contains one copy each of 
features PrintToPDF, Print, and PrintHighQualityColor in the Draft state and no feature bundles. 

5. Click Back to return to the Package Products page. 
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Task To deploy product PhotoPrint 

1. On the Package Products page, select the product PhotoPrint check box. 

2. Click Change State ▼ and select Deploy from the drop-down menu. Click OK in the verification message. The 
Package Products page appears, with the feature and feature bundle deployment information, for product 
PhotoPrint. 

3. Click Deploy. The Package Products page shows that PhotoPrint and its features are successfully deployed. 
This message appears: Products deployed successfully.

4. Log out of the FlexNet Operations Producer Portal or continue with Entitlement Creation. 

Product Creation Next Steps
Entitlement is the stage of the FlexNet Operations license lifecycle that follows product creation. The entitlement 
process includes creation, configuration, and deployment of the entitlement. The exercises in Entitlement 
Creation use product PhotoPrint to guide you through FlexNet Operations entitlement creation and deployment. 

Product Creation Advanced Topics
Free Product Trials 
Product trials enable self-service user registration for, and provisioning of a product for customer evaluation. 

The producer creates the trial registration page, the custom content of which can include survey questions. When 
a prospective customer signs up for a free product trial, FlexNet Operations creates an account for that customer, 
creates an entitlement for a trial product, and sends a welcome email to the customer. The customer logs in to 
end-user portal using the credentials sent in the email, downloads and activates the product, and runs the trial 
for the time period specified by the product’s license model. 

The producer can easily access information about product trial customers, product evaluations, and responses to 
survey questions. 

Maintenance Products 
A maintenance product represents a customer’s right to obtain technical support, upgrades, updates, or new 
platforms for a particular licensed product or product suite for a specified duration. 

Product Part Numbers 
After a product is linked to a license model or models, it can be mapped to one or more part numbers that link it 
to an accounting application. Part numbers are referenced by customers in their orders and can be tracked by an 
enterprise resource planning (ERP) or customer relationship management (CRM) system. 

Product Relationships 
In addition to being grouped into suites, software products can also be related in these ways: 

• Demo – A demonstration, or limited functionality version of a product. 
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• Upgrade – A newer version of a product. 

• Upsell – A product with a wider range, capability, or more advanced features than another product. 

• Maintenance – An unlicensed product that represents additional rights that a customer can purchase. For 
example, maintenance may give the customer the right to technical support, upgrades, updates, or new 
platforms for the duration of the maintenance period. 

Product relationships enable follow-up sales operations such as upgrades, upsells, and renewals. 

Entitlement Creation
This topic introduces entitlements, the stage of the FlexNet Operations license lifecycle that follows product 
creation. The entitlement process includes creation, configuration, and deployment of an entitlement. 

The exercises in this topic use Lisa Barry of Barry Photography Studio, the customer you created in the Account 
and User Creation exercises, and PhotoPrint, the product you deployed in the Product Creation exercises, to 
guide you through FlexNet Operations entitlement creation. 

• Entitlement Creation Key Concepts

• Entitlement Creation Exercises

• Entitlement Creation Next Steps

• Entitlement Creation Advanced Topics

Entitlement Creation Key Concepts
Entitlements 
An entitlement represents a product, with its associated license model(s), that a customer has purchased. The 
following figure depicts the relationships that you set up in the exercises of this getting started section. 
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Figure 14-2: Entitlement Creation Relationships

The entitlement indicates how many copies of the product the customer has the right to use or access, along with 
any maintenance, and the duration for which the customer can use or access the product. The customer must 
activate the entitlement to generate licenses in formats like license files, trusted storage, or others.

An entitlement is created for many reasons, including after order shipment. Each entitlement is associated with 
an entitlement ID. Entitlement IDs are generated when an order is entered in FlexNet Operations; an entitlement 
ID is associated with every entitlement for that order. Each line item of an entitlement is an activatable unit and is 
uniquely identified by an activation ID. The details of a line item specify the product and its options, the quantity, 
and the duration of the license rights. An entitlement can have one or more line items. 

Entitlements can be created in a number of ways, but the two most common are manually, by an authorized user 
using the FlexNet Operations Producer Portal, and by importing them from an external enterprise resource 
planning (ERP) or customer relationship management (CRM) system that is integrated with FlexNet Operations 
(importing entitlements, an advanced topic, is not covered in this getting started section). 

Entitlement and Line Item Attributes
The List Entitlements by Order page of the Producer Portal (click Entitlements > List Entitlements by Order) lists 
entitlements and their line items with the following attributes: 

• Entitlement ID – Unique identifier of the entitlement 

• Account – End customer and/or channel partner account(s) that the entitlement was sold to 

• State – Entitlement’s state: Draft, Deployed, Inactive, Test, or Obsolete (refer to Entitlement States) 

• Bulk – Is this a bulk entitlement? No = Regular and Yes = Bulk (refer to Entitlement Styles) 

• # Line Items – Number of activatable items in the entitlement  
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• Activation ID – Unique identifier of the activatable item 

• Product – Product(s) defined for the line item, including version number(s) 

• Maintenance – Maintenance line item that is related to a product 

Clicking an Entitlement ID link displays the Entitle Customers to Licenses | Create An Entitlement page, which 
provides more information about the entitlement and its line items. The table on the Line Items tab lists the 
entitlement’s line items with the following attributes: 

• Type – License model type of an activatable line item: 

• FlexNet Embedded E  

• FlexNet Publisher license file-based (also called certificate) C  

• FlexNet Publisher trusted storage-based T  

• Custom, non-FlexNet  NF  

• Activation ID – Unique identifier of the activatable item 

• Product – Product(s) defined for the line item, including version number(s) 

• Part Number – Unique number assigned by the producer to identify a specific product. Part numbers can be 
added in FlexNet Operations or imported from a file. Part numbers are optional. 

• Expiration – Specifies when the line item expires. 

• Total Quantity – Count of a product in the line item

• Line Item State – Line item’s state: Draft, Deployed, Inactive, Test, or Obsolete (refer to Line Item States) 

• Maintenance – Maintenance line item that is related to a product 

Entitlement States
Entitlements have states that determine their ability to be edited and to be used in various license lifecycle 
activities. Changes to these states are tracked by FlexNet Operations. These states are: 

• Draft – Draft entitlements can be created only from deployed products and suites. An entitlement is created 
in a draft state so it can be modified or deleted. 

• Deployed – Deployed entitlements can be activated, upsold, and so on, but not edited or deleted (this can be 
changed with configuration). However, some fields in a deployed entitlement can be modified. 

• Inactive – When an entitlement is made inactive, all of its line items are made inactive and cannot be 
activated, upgraded, upsold, or renewed. Existing activations against an inactive line item cannot be 
returned, repaired, or rehosted. 

• Test – Test entitlements can be created from draft products, and enable testing of draft products and license 
models before they are deployed. All entitlement actions can be performed on test entitlements, but test 
entitlements cannot be moved to any other state. When a test entitlement is deleted, existing activations 
against it are also deleted. 

• Obsolete – An entitlement can be made obsolete if it is no longer required or if it was created and deployed in 
error. While there is existing data that refers to an obsolete entitlement, no new references to it can be made. 
An obsolete line item cannot be activated. Existing activations of an obsolete line item cannot be rehosted. 
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Note • An entitlement that has been activated on a device can have its state changed to Inactive or Obsolete only 
if the configuration option Allow used entitlement/line item state change to Inactive or Obsolete is selected. 

When this configuration option is selected, an entitlement or line item that has been activated on a device can 
still be used until the license expires, even if the entitlement or line item has been deactivated or made obsolete. 

For more information, see General Options in Configuring System Settings.

Entitlement Styles 
The two styles of FlexNet Operations entitlement are regular and bulk. A regular entitlement is used when the 
licensee is known, and is created for a direct or drop ship order. It represents a customer's right to use or access 
a product. A bulk entitlement is used when the licensee is not immediately known and the entitlement must flow 
through channels. It represents a large number of individual entitlements, for one or more products, that will 
move through a channel flow or will be claimed by a licensee/end customer (bulk entitlements, an advanced 
topic, is not covered in this getting started section). 

Line Item States 
Like entitlements, line items also have states: 

• Draft – A line item is created and can be edited in the draft state. 

• Deployed – A line item must be deployed to be activated. Deploying a draft line item allows it to be activated, 
upgraded, upsold, or renewed. 

• Inactive – Existing activations against an inactive line item cannot be returned, repaired, or rehosted. Inactive 
line items can be changed back to a deployed state as necessary.

• Test – Test line items can be defined for draft products and license models, and enable testing to ensure that 
products and license models are defined correctly. 

• Obsolete – A line item can be made obsolete if it is no longer required or if it was created and deployed in 
error. An obsolete line item cannot be activated. Activations of an obsolete line item cannot be rehosted. The 
obsolete state is permanent; when a line item is made obsolete, it cannot be changed back to a deployed 
state. 

Note • An entitlement that has been activated on a device can have its state changed to Inactive or Obsolete only 
if the configuration option Allow used entitlement/line item state change to Inactive or Obsolete is selected. 

When this configuration option is selected, an entitlement or line item that has been activated on a device can 
still be used until the license expires, even if the entitlement or line item has been deactivated or made obsolete. 

For more information, see General Options in Configuring System Settings.
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Entitlement Creation Exercises
These exercises use examples to guide you through the following entitlement tasks: 

Creating and Configuring an Entitlement
In this exercise, you create and configure an entitlement for the product PhotoPrint that you deployed in the 
Product Creation topic. 

Prerequisite
• Complete the Account and User Creation and Product Creation exercises 

Task To create an entitlement for PhotoPrint 

1. Log in to the FlexNet Operations Producer Portal if you logged out after completing the Product Creation 
exercises. 

2. Click Entitlements > Create. The Entitle Customers to Licenses page appears. 

3. Under Create An Entitlement, enter the entitlement attributes: 

• Entitlement ID: Select Specify from the drop-down list and type ENT-PhotoPrint in the box to the right. 

• Keep the default values for all other attributes. 

Note that the entitlement is created in the Draft state. 

Task To entitle the customer user to product PhotoPrint 

1. Under End Customer And Channel Partners for entitlement ENT-PhotoPrint, click Add. The End Customer And 
Channel Partners window opens. 

2. On the Customers tab, search for and select BarryPhoto as the account to receive the entitlement, then click 
Next.

3. Under Contacts, select Lisa Barry as the end user to receive the entitlement email message. 

4. Click Save. The End Customer And Channel Partners window closes, and the Entitle Customers to Licenses 
page shows Barry Photography Studio as the end customer and Lisa Barry as the contact. 

Exercise Description

Creating and Configuring an 
Entitlement

Create and configure an entitlement for product PhotoPrint.

Deploying an Entitlement Deploy the product PhotoPrint entitlement. 

Reviewing an Entitlement on the 
End-User Portal

Log in to the FlexNet Operations End-User Portal, as customer Lisa Barry, 
to review the PhotoPrint entitlement. 
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Task To configure the PhotoPrint line item 

1. On the Line Items tab near the bottom of the page, click New Line Item. The Configure Line Item wizard 
opens. 

2. In wizard step 1, Select Product, search for and select product PhotoPrint, then click Next. 

3. In wizard step 2, Select Part Number & License Model, leave the default values as they are. Click Next. 

4. In wizard step 3, Configure Product, enter these line item attributes: 

• Qty: Type 1 for the quantity of PhotoPrint copies in this line item 

• Start Date: Select Use First Activation Date from the drop-down list 

• Expiration: Select Specify Duration from the drop-down list, enter 1, then select Years from the drop-
down list 

• Keep the default values for all other attributes. 

Click Next. 

5. For the remaining wizard steps, keep the default value. Click Next. 

6. In the last wizard step, click Save to save the line item and close the Configure Line Item wizard.

7. On the Line Items tab, click on the Activation ID and change it to ACT01-PhotoPrint. Note that the PhotoPrint 
line item expires after 1 year, has a total quantity of 1 copy, and is in the Draft state. 

Deploying an Entitlement
In this exercise, you deploy the product PhotoPrint entitlement that you created and configured for customer 
Barry Photography Studio in the previous exercise. 

Task To deploy the product PhotoPrint entitlement 

1. On the Line Items tab, select the PhotoPrint line item. 

2. At the bottom of the Entitle Customers to Licenses page, click Save & Deploy. The Line Item State of 
PhotoPrint is changed to Deployed and this message appears: Entitlement deployed successfully. 

3. On the Entitle Customers to Licenses page, click Email to send entitlement notification email to Lisa Barry at 
Barry Photography Studio. The Entitle Customers to Licenses page appears with the customer’s address in 
the Ship To Email box. 

Note • To include additional recipients, type their email addresses into the Ship To Email box separated by 
commas. 

Tip • Add your email address to the recipients list and review the PhotoPrint entitlement certificate you 
receive. 



Chapter 14 Getting Started with Entitlement Management
Entitlement Creation

502 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Click Send. This message appears: Email sent to the recipients <address list>. 

4. Log out of the FlexNet Operations Producer Portal. 

Reviewing an Entitlement on the End-User Portal
In this exercise, you log in to the FlexNet Operations End-User Portal as customer Lisa Barry and review the 
PhotoPrint entitlement. 

Task To review the product PhotoPrint entitlement on the End-User Portal 

1. Use the Lisa Barry credentials you recorded in the Creating a Customer End User procedure to log in to the 
FlexNet Operations End-User Portal. Note the PhotoPrint entitlement listed under Recent Entitlements on 
the home page. 

2. Click the PhotoPrint activation ID. In the Entitlement Details window that opens, scroll down and review the 
ID Info, Product Info, and Activation Info. When you are done, click Cancel to close the window. 

3. Log out of the FlexNet Operations End-User Portal. 

Entitlement Creation Next Steps
Refer to these getting started sections for concepts and exercises that guide you through electronic software 
delivery, usage management, and cloud licensing service tasks:

• Getting Started with Electronic Software Delivery (requires the Software Delivery module)

• Getting Started with Usage Management

• Getting Started with Cloud Licensing Service

Refer to this getting started section for concepts and exercises that guide you through advanced account 
management tasks: 

• Getting Started with Advanced Organization Management 

Refer to these getting started sections for concepts and exercises that guide you through licensing activation and 
support tasks: 

• Getting Started with FlexNet Embedded Licensing

• Getting Started with FlexNet Publisher License File-Based Licensing

• Getting Started with FlexNet Publisher Trusted Storage-Based Licensing 

• Getting Started with Non-FlexNet Licensing Technologies 
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Entitlement Creation Advanced Topics
Bulk Entitlements 
Bulk entitlements are used for channel sales or redistributors who order large quantities of a product, each copy 
of which is expected to be resold to a different retail end user. 

Importing Entitlements 
Entities, including entitlements, can be imported to and exported from a FlexNet Operations database into other 
Operations databases. This enables data migration between different FlexNet Operations installations. 

Test Entitlements 
Test entitlements allow testing of draft products and license models before they are deployed. All entitlement 
actions can be performed on test entitlements, but test entitlements cannot be moved to any other state. 

Maintenance Entitlements 
Maintenance is an unlicensed product that represents additional rights that a customer can purchase with a 
product. For example, maintenance can give the customer the right to technical support, upgrades, updates, or 
new platforms for the product for the duration of the maintenance period. A maintenance product cannot exist in 
an entitlement by itself; it must be associated with a product line item. 

Merging Entitlements 
Entitlements can be reassigned to another account when two accounts merge into one. When an entitlement is 
merged, everything in the entitlement remains the same except the Account value, which is changed to reflect 
the new account. 

Transferring Entitlements 
License rights in a single entitlement can be transferred from one account to another. All of the entitlement’s line 
items are transferred. Line items can also be transferred individually. 

Splitting Entitlements 
Producer and partner users can split entitlements on the End-User Portal, if this functionality is enabled. 

Bulk Operations 
All of the following operations can be performed as non-bulk operations also. 

Product Upgrades 

An upgrade allows a customer to replace an older version of a product with a newer version, such as moving from 
Calculator version 4.5 to Calculator version 5.0. 

Product Upsells 

An upsell allows a customer to replace a product with another that has more features, such as moving from Paint 
Standard Edition to Paint Professional Edition. 
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Product Renewals 

A renewal allows a customer to extend a licensed product’s existing entitlement to a date farther in the future.
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Getting Started with 
Electronic Software Delivery

The section Getting Started with Electronic Software Delivery presents fundamental electronic software delivery 
concepts and uses exercises to lead a Producer Portal user through basic download management tasks. The 
intended audience for this getting started section is the first-time Producer Portal user, or one without FlexNet 
Operations training or experience.

Version • Electronic software delivery features are only available for producers who purchase the Software 
Delivery module.

To view a brief, informative video that walks you through the exercises in Getting Started with 
Electronic Software Delivery, click here. We recommend that you read this getting started section in full, to gain 
an understanding of the concepts it covers, before you view the video.

Table 15-1 • Electronic Software Delivery Topics

Section Description

 Introduction Overview of this getting started section and a summary of FlexNet 
Operations electronic software delivery features. 

 About Electronic Software Delivery A discussion of basic FlexNet Operations electronic software delivery 
concepts. This section introduces download packages, download files, 
license agreements, and producers. 

Electronic Software Delivery Setup 
for Distributing Files

A series of electronic software delivery setup exercises that 
demonstrate how to deliver your software electronically via the End-
User Portal. The end of this section also provides brief descriptions of 
more advanced topics and explains where to find more information 
about them.

https://www.youtube.com/watch?v=qR2kOl6Cojg
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Introduction
This section includes a summary of prerequisites and FlexNet Operations electronic software delivery features. 

• Prerequisites

• The License Lifecycle: Electronic Software Delivery

• The Electronic Software Delivery Module

Prerequisites
Before you begin the exercises in this getting started section: 

• The FlexNet Operations demonstration database and seed data must be loaded. 

• You must have a FlexNet Operations Producer Portal login.

• The Producer Portal must be configured to Show Product Lines functionality.

Additionally, the exercises in this getting started section make use of the product, features, and entitlements 
created in the early exercises of the section Getting Started with Entitlement Management. Any product will 
suffice, as a sample to which download packages can be linked, but the exercises here use the product created 
in Getting Started with Entitlement Management.

The License Lifecycle: Electronic Software Delivery
The FlexNet Operations license lifecycle is a repeating process of producer and customer activities, as depicted in 
the figure and described below. 
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Figure 15-1:  FlexNet Operations License Lifecycle 

• Create Products—Create product definitions that are used to generate licenses. 

• Order/Entitle—Define an account’s rights to obtain licenses for your products. 

• Deliver⁄Install—Deliver the application software to the customer and install that software. 

• Activate—Deliver licenses to the customer. 

• Return/Rehost—Manage license transfers from one user or system to another.

• Maintain/Update—Deliver software updates to the customer. 

• Upsell/Renew—Renew customer licenses, or sell the customer additional product functionality. 

The Electronic Software Delivery Module
The Electronic Software Delivery module adds electronic software delivery support to FlexNet Operations. 
Producers who use FlexNet Operations with the Electronic Software Delivery module define their downloads as 
part of the product packaging process. The downloads they define are available to entitled end users in the End-
User Portal.

Downloads are specified as download packages. A download package describes a group of files and relates that 
group with a product, a producer, and, optionally, a license agreement (sometimes called an end-user license 
agreement or EULA, for short). 
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Figure 15-2: Download Packages Associations

A product can have many download packages, and download packages can be associated with one or more 
products. Download packages collect files into groups that might comprise a software release, a component, or 
any other grouping that fits your account’s needs. 

For producers who use FlexNet Operations with the Electronic Software Delivery module, the Producer Portal 
includes features for managing download packages, files, agreements, and producers. The Products menu 
includes links for creating and managing these items. Also, product lines, which are otherwise optional, are 
required for producers who use the Electronic Software Delivery module.
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About Electronic Software Delivery
This section introduces electronic software delivery concepts. Electronic software delivery setup is part of 
product packaging, the first stage of the FlexNet Operations license lifecycle.

Download Packages
Download packages are groups of files that can be related to one or more products and tied to a producer and a 
product line. Optionally, a download package can be associated with a license agreement as well.

It is through a download package’s relationship to products that FlexNet Operations determines which download 
packages an end user is entitled to. End-User Portal users see downloads for the products to which they have 
entitlements.

On the End-User Portal, download packages are grouped by producer and product line so that entitled users can 
navigate hierarchically through the producer, product line, product, and version to find the downloads they 
require. And when optional license agreements are associated with a download package, the End-User Portal 
shows the agreement before allowing end users to download files.

Download Files
On the Producer Portal, you can add and manage the files you want to make available for your customers to 
download from the End-User Portal. You can add a file by creating a file definition for it and then uploading its file 
image. 

When you create a file definition in the Producer Portal, you specify a file description and file ID. Then, you upload 
the file image from your local system into FlexNet Operations. Without the file image upload, the file definition in 
FlexNet Operations has no payload when a customer tries to download it from the End-User Portal. 

The creation of a download file follows the sequence below: 

1. Create the file definition—Create a placeholder for the file image in FlexNet Operations and give the file, at 
minimum, a file ID. Other file details are optional at this point.

2. Upload the file image—Copy the actual file into FlexNet Operations. This file is what gets delivered to End-
User Portal users when they download the file.

Table 15-2 • Electronic Software Delivery Concepts

Topic Description

Download Packages Discusses what download packages are and how they are used in FlexNet 
Operations.

Download Files Covers the basics of download files and file images.

License Agreements Describes how license agreements are connected with electronic software 
delivery. 

Producers and Product Lines Discusses the use of producers as a mechanism for grouping product lines and 
download packages in the End-User Portal.
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3. Associate the file with one or more download packages—Download packages collect one or more files and 
tie them to a product. Without any association to a download package, the file will never appear for 
download on the End-User Portal. 

Once a file has been added and associated with a download package, it is available for End-User Portal users to 
download from any product to which the download package is associated and to which the End-User Portal user 
is entitled. 

 License Agreements
In FlexNet Operations, producers can add agreements that can be tied to one or more download packages.

A click-through or end-user license agreement (EULA) commonly contains content supplied by your legal 
department. The license agreement is an optional attribute of a download package.

In the Producer Portal, producers add agreements by providing an agreement name and the content for the 
agreement text. (The agreement content can be plain text or HTML.) Then, the agreement can be linked to a 
download package on the Edit Download Package page.

When an agreement is connected to a download package, the End-User Portal prompts users to agree to the 
terms of that agreement before proceeding with the download. 

Producers and Product Lines
When an end user is entitled to downloads from more than one producer, the End-User Portal groups download 
packages by producer and then product line. For this reason, both Producer and Product Line are required 
attributes for download packages. Each download package can have only one producer and only one product 
line.

Producers
Although FlexNet Operations documentation frequently refers to Producer Portal users—typically software 
publishers or intelligent device manufacturers—as “producers,” this term also refers to the logical entities that 
Producer Portal users must define as part of their electronic software delivery setup.

Many software publishers and intelligent device manufacturers only use a single producer. In this case, the 
Producer attribute typically reflects the name of the user’s account. Others define multiple producers and use the 
Producer attribute to distinguish between different product groups or families or simply as an additional layer of 
navigation before end users choose a product line. When you click List Producers in the Products menu, the 
Producer Portal displays a list of all the producers your account has created.

Product Lines
Product lines allow you to group, classify, and describe products and to control how download packages are 
presented in the End-User Portal. Product lines can also be used to define end-user access rights to product 
information. In the End-User Portal, users can only see the product lines to which their user accounts are linked.
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Display of Downloads in the End-User Portal
In the End-User Portal, the producer is the highest level of grouping for products lines, download packages, and 
files. Users who are entitled to products of more than one producer see a list of producers when they look for 
downloads. For example, users who click List Downloads from the Downloads menu in the End-User Portal must 
first choose from a list of producers and then from a list of product lines to show a list of download packages for 
that product line. If an end user is entitled to downloads from only one producer, the End-User Portal skips the 
producer list and shows product lines directly.

Tip • For more information about other tasks and topics related to the Electronic Software Delivery module, see 
Advanced Topics at the end of this document.

Electronic Software Delivery Setup for 
Distributing Files

This section walks through the process of creating download packages and files for the product created in the 
early exercises of the section Getting Started with Entitlement Management.

Topic Description

Before You Begin This section prepares a customer user to acquire downloads in the End-
User Portal and reviews the customer account, customer user, product, 
product line, and entitlements created in the exercises in the section 
Getting Started with Entitlement Management. 

Creating a Producer Adds a producer to use when creating a download package. 

Creating Download Packages Adds download packages for the products in the LargeFormat product 
line. 

Associating Download Packages 
with a Product

Links the new download packages to their respective products.

Creating Download Files Creates files and uploads file images for the files that will be the 
deliverables in the download packages.

Associating Download Files with 
Download Packages

Links the new files with the download packages to tie products to their 
deliverables.

Viewing and Downloading Files 
from the End-User Portal

Uses an end user account entitled to the PhotoPrint product to view and 
download the files for PhotoPrint Installer Package and PhotoPrint 
Documentation Package.

Advanced Topics Briefly introduces advanced electronic software delivery topics and 
explains where to get additional information on them.
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Before You Begin
The exercises in this section make use of the entities created as part of the exercises in Getting Started with 
Entitlement Management. This section lists the customer account, customer user, product, product line, and 
entitlements created in Getting Started with Entitlement Management. For Producer Portal users who have not 
yet created their own products and customer users, these items are necessary for the rest of the exercises in this 
section. 

If these entities, such as the entitlement, ENT-PhotoPrint, do not yet exist in your FlexNet Operations instance, 
follow the exercises in the section Getting Started with Entitlement Management to create the necessary entities. 

Important • If the customer user, Lisa Barry, already exists but is not associated with an email address you 
control, you must create another customer user in the Barry Photography Studio account with the Portal User 
role. Choose an email address you control for this new customer user so that you can use it to log in to the End-
User Portal and see the downloads. 

Later in this section, we create download packages and files to be the deliverables for the PhotoPrint product.

Creating a Producer
In this exercise, you add the producer, ABC Networks, Inc. Producer is a required attribute for the download 
packages that are created later in this section.

Prerequisites
• Review of the key concepts in the previous section, About Electronic Software Delivery

• FlexNet Operations login

Entity Type Entities

Customer Account Barry Photography Studio

Customer User Lisa Barry

Product PhotoPrint

This product includes the following features: 

• Print

• PrintHighQualityColor

• PrintToPDF

As indicated in the section Getting Started with Entitlement Management, the 
features, above, are among those pre-defined in your environment’s demo data.

Product Line LargeFormat

Entitlement ENT-PhotoPrint
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Note • If the producer, ABC Networks, Inc. already exists in your FlexNet Operations instance, you can skip this 
exercise.

Task To add the ABC Networks, Inc. producer 

1. Log in to the Producer Portal. 

2. Click Products > Create Producer. The Producer Portal opens the Create Producer page.

3. In the Producer ID box, type ABCNetworks. 

4. In the Producer Name box, type ABC Networks, Inc. This value is what the End-User Portal shows to your end 
users when they choose among multiple producers. 

Figure 15-3: The Create Producer page for ABC Networks, Inc. 

5. Click Save. 

The Producer Portal saves the new producer and shows the List Producers page. 

Creating Download Packages
In this exercise, you add two download packages for the PhotoPrint product: 

• PhotoPrintInstaller

• PhotoPrintDocumentation
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Task To create the PhotoPrintInstaller download package

1. In the Producer Portal, click Products > Create Download Package. The Producer Portal opens the Create 
Download Package page. 

2. On the Create Download Package page, set values for the following attributes in Download Package Details. 

Keep the default values for all other attributes.

3. For End-User Download Instructions, type the following: 

Review system requirements in the release notes (included) prior to running the installer.

Attribute Value

Download Package ID PhotoPrintInstaller

Download Package 
Name

PhotoPrint Installer Package

Extended Description Includes the installer and release notes for PhotoPrint.

Effective Date Keep the current date default value.

Expiration Date Set for one year from current date. 

Download Package 
Producer

ABC Networks, Inc.

Product Line LargeFormat

Restrict to US/CANADA 
(NLR)

Yes
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Figure 15-4: The Create Download Package page for PhotoPrint Installer Package. 

4. Click Save.

The Producer Portal adds the PhotoPrintInstaller download package and shows its View Download Package page. 

Repeat these steps to create the PhotoPrintDocumentation download package using the values in shown below. 

• Download Package Details: 

Attribute Value

Download Package ID PhotoPrintDocumentation

Download Package 
Name

PhotoPrint Documentation Package

Extended Description Includes release notes and user guide for PhotoPrint.

Effective Date Keep the current date default value.

Expiration Date Set for one year from current date. 



Chapter 15 Getting Started with Electronic Software Delivery
Electronic Software Delivery Setup for Distributing Files

516 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

• End-User Download Instructions: 

PhotoPrint documentation includes PDF files for release notes and the PhotoPrint User Guide.

The Producer Portal adds the PhotoPrintDocumentation download package and shows its View Download 
Package page. 

Associating Download Packages with a Product
In this exercise, you associate the PhotoPrintInstaller and PhotoPrintDocumentation download packages with the 
PhotoPrint product. 

Task To associate the PhotoPrintInstaller download package to the PhotoPrint product

1. In the Producer Portal, click Products > Search Download Packages. The Producer Portal opens the Search 
Download Packages page. 

2. On the Search Download Packages page, type a value for Download Package ID: PhotoPrintInstaller.

3. Click Search. The Producer Portal opens the Search Results: Download Packages page and shows the 
PhotoPrintInstaller download package in the search results. 

4. Click PhotoPrintInstaller. The Producer Portal opens the View Download Package page for 
PhotoPrintInstaller.

5. On the View Download Package page, click Associate > Associate to Product. The Producer Portal opens the 
Associate this Download Package to Products page. 

6. In Search Products, for Product ID type Photo* and click Search. The Producer Portal shows a list of products 
with matching product IDs. 

Download Package 
Producer

ABC Networks, Inc.

Product Line LargeFormat

Restrict to US/CANADA 
(NLR)

Yes

Attribute Value



Chapter 15 Getting Started with Electronic Software Delivery
Electronic Software Delivery Setup for Distributing Files

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 517

Figure 15-5: In Search Products, use Photo* to find the PhotoPrint product. 

7. Click the checkbox for PhotoPrint::12.0 and then click Associate Download Package to Selected Products. 

Important • Notice that the product ID for PhotoPrint is a combination of the product name and product 
version: PhotoPrint::12.0. This is how FlexNet Operations identifies the product, internally. One ramification 
of the product ID syntax is that a search for the product by its product name, PhotoPrint, does not match the 
product ID. For best results, use an asterisk as a wildcard character to be sure your product search captures 
the product you are looking for. For example, Photo* or PhotoPrint* successfully finds PhotoPrint.

The Producer Portal saves the product-download package association and shows the Where Download Package 
Used page for PhotoPrintInstaller. 

Repeat the steps above to associate the PhotoPrintDocumentation download package with the PhotoPrint 
product as well. 

Creating Download Files
In this exercise, you create five download files as the deliverables for the PhotoPrint product. 

• PhotoPrintInstaller

• PhotoPrintUserGuide

• PhotoPrintReleaseNotes

For each file, the exercises add a file definition and upload its file image. For these exercises it does not matter 
what files images you upload for the files. The file images used in these exercises are simple text files with 
different file names.
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Task To create the PhotoPrintInstaller file

1. In the Producer Portal, click Products > Create File. The Producer Portal opens the Create File page. 

2. On the Create File page, type values for the following attributes. 

Keep the default values for all other attributes.

Figure 15-6: The Create File page for PhotoPrintInstaller. 

3. Click Save & Upload File. The Producer Portal opens the Upload File page. 

Attribute Value

File ID PhotoPrintInstaller

File Description PhotoPrint Installer

Extended Description Installs PhotoPrint. 

Content Detail Review the release notes prior to running the installer. See the 
PhotoPrint User Guide for more information.
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Figure 15-7: The Upload File page for PhotoPrintInstaller. 

4. Click Choose File and select a file to upload. (Button names may vary for different web browsers and 
operating systems.) 

5. Click Upload. 

The Producer Portal uploads the file image, saves the file, and shows its View File page. 

Repeat these steps, above, to create file definitions and upload file images for PhotoPrintUserGuide and 
PhotoPrintReleaseNotes. Use the values below for the file definitions. Use any small file as the file image. (For 
these exercises we used text files renamed to reflect their prospective file contents.)

• PhotoPrintUserGuide: 

• PhotoPrintReleaseNotes: 

Attribute Value

File ID PhotoPrintUserGuide

File Description PhotoPrint User Guide

Extended Description Includes a PDF of the PhotoPrint user Guide

Attribute Value

File ID PhotoPrintReleaseNotes

File Description PhotoPrint Release Notes

Extended Description Includes a PDF of the PhotoPrint Release Notes
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Next, you will associate these files to their download packages and review the customer experience in the End-
User Portal.

Associating Download Files with Download Packages
In this exercise, you associate the download files with their download packages, as shown in the table below.

These associations complete the connection between the download files and the product to which the customer 
user, Lisa Barry, is entitled. 

Task To associate the PhotoPrintInstaller download package with its download files

1. In the Producer Portal, click Products > Search Download Packages. The Producer Portal opens the Search 
Download Packages page. 

2. On the Search Download Packages page, type a value for Download Package ID: PhotoPrintInstaller.

3. Click Search. The Producer Portal opens the Search Results: Download Packages page and shows the 
PhotoPrintInstaller download package in the search results. 

4. Click PhotoPrintInstaller. The Producer Portal opens the View Download Package page for 
PhotoPrintInstaller.

5. On the View Download Package page, click Associate > Associate Files. The Producer Portal opens the 
Associate Files to this Download Package page. 

6. Enter the following in File IDs: PhotoPrintInstaller, PhotoPrintReleaseNotes.

Download Package Download Files

PhotoPrintInstaller PhotoPrintInstaller

PhotoPrintReleaseNotes

PhotoPrintDocumentation PhotoPrintUserGuide

PhotoPrintReleaseNotes
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Figure 15-8: The Associate Files to this Download Package page with file IDs for the PhotoPrint Installer 
Package. 

7. Click Associate Files.

The Producer Portal makes the file associations with the PhotoPrintInstaller download package and shows its 
View Download Package page. Notice that the View Download Package page now shows the two associated files: 
PhotoPrintInstaller and PhotoPrintReleaseNotes.

Repeat the steps, above, to make similar associations between the PhotoPrintDocumentation download package 
and the PhotoPrintUserGuide and PhotoPrintReleaseNotes files.

When both download packages are associated with their download files, you are ready to review the End-User 
Portal experience. 

Viewing and Downloading Files from the End-User Portal
In this exercise, you log in to the End-User Portal and navigate through to view your downloads. Use the customer 
account, Barry Photography Studio (created as part of the exercise sets in the section Getting Started with 
Entitlement Management). That account is now entitled to the PhotoPrint product and its downloads. 

Task Logging in to the End-User Portal

1. In a web browser, navigate to the End-User Portal. 

https://<hostname>/flexnet/operationsportal/

2. On the End-User Portal Login page, type values for the Username and Password fields. 

• Username—The email address you used when you created the user Lisa Barry.
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• Password—The password you setup for the Lisa Barry user account. If you have not logged in to the End-
User Portal, previously, you must use the temporary password included in the welcome message to Lisa 
Barry and first create a new password and security question/response before you can log in. 

3. Click Log In. 

The End-User Portal opens to the Home page. Notice that Barry Photography Studio has an entitlement to 
PhotoPrint and downloads available for LargeFormat—the product line to which PhotoPrint belongs. 

Note • These instructions assume you control the Lisa Barry user account as described in Before You Begin and 
that PhotoPrint is the only product to which that account is entitled. When an end user is entitled to product lines 
from multiple producers, the Downloads panel first lists producers, like ABC Networks, Inc., instead of product 
lines.

Task Navigating the End-User Portal and downloading files

1. In the End-User Portal, use the Downloads menu to list the downloads available to you. Click Downloads > 
List Downloads. The End-User Portal opens the Downloads page. This page shows a link for the product line, 
LargeFormat. 

Note • If the demonstration account, Lisa Barry, has been entitled to products from other producers, the End-
User Portal first shows a list of producers on the Product List page. Click a producer name to show entitled 
product lines. In this case, click ABC Networks, Inc.

2. Click LargeFormat. The End-User Portal shows the Download Packages page for the LargeFormat product 
line: PhotoPrint Installer Package and PhotoPrint Documentation Package.

3. Click PhotoPrint Installer Package. The End-User Portal shows the Downloads page for the PhotoPrint 
Installer Package download package. To view file details, click + by the file name. 

Notice that the Download Instructions value you specified on the Producer Portal appears right under the 
download package name: “Review system requirements in the release notes (included) prior to running the 
installer.” Also, notice that the Extended Description value appears in the expanded file details: “Includes a 
PDF of the PhotoPrint Release Notes.”
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Figure 15-9: The Downloads page for PhotoPrint Installer Package showing file details for PhotoPrint 
Release Notes. 

4. Click your browser’s Back button to return to the Download Packages page for LargeFormat.

5. Click PhotoPrint Documentation Package. The End-User Portal shows the download files for PhotoPrint 
Documentation Package.

Figure 15-10: The Downloads page for PhotoPrint Documentation Package. 

6. To download files, select the files you want to download and click Download Selected Files. The End-User 
Portal opens the Download Manager in a pop-up window. 

Important • To complete your download, the Download Manager must be installed on your system. If it is not 
installed, follow the instructions in the Download Manager window to download and run the installer, then 
accept the license agreement.  

Tip • You can also download individual files by clicking on the file name link for the file you want to download.

7. Click Browse to select a target directory for the download files. 
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Figure 15-11: The Download Manager page for selecting a target directory. 

8. Click OK. The Download Manager starts the file download process.

Figure 15-12: The Download Manager page showing download progress. 

The End-User Portal downloads the selected files to the target directory you selected. 

This concludes the getting-started exercises for FlexNet Operations users with the Electronic Software Delivery 
module. For information about more advanced download management options and activities—such as those 
listed in Advanced Topics (below)—see the appropriate sections in this user guide.

Advanced Topics
Restricting Access to Files and Download Packages
Access to individual download packages or files can be controlled by customer account. Using the Producer 
Portal, producers can create allowed lists or non-allowed lists of the accounts permitted to see a download 
package or a file in the End-User Portal. For more information, see Restricting a Download Package and 
Restricting a File in the Packaging Products section.
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Visibility of Download Packages for Maintenance Customers
Visibility of download packages is dependent on the Maintenance Line Item expiration date. If there is no 
maintenance plan, the visibility is based on the expiration date of the line item. If there is a maintenance plan, the 
visibility is based on the expiration of the maintenance line item. The following table illustrates what is visible 
based on the maintenance plan in effect. The assumed current date is 1 July 2016.

Sending Email Notifications for Files and Download Packages
In the Producer Portal, producers can send email messages to end-users entitled to a file or a download package. 
Instructions for sending email notifications are in the sections Managing Download Packages and Managing 
Download Files.

Order Media Requests and Physical Distribution
For producers who want their end users to be able to request download files on physical media, the End-User 
Portal includes an Order Media control. Configuring the End-User Portal to handle these request requires some 
configuration in the Producer Portal. For more information, see About Physical Distribution and Order Media 
Requests in the section Packaging Products.

Making File Aliases
Aliasing a file creates a duplicate of an existing file that points to the same file image but can be managed 
separately. File aliases allow you to avoid uploading multiple copies of the same file image. See About Aliases in 
the section Packaging Products for more information about file aliases.

Export Compliance
Producers must specify export compliance settings that define how download delivery is controlled 
internationally. Export compliance settings are part of a download package. To learn more about export 
compliance settings, see About Export Compliance in the section Packaging Products.

Customer
Name

Line Item
Expiration

Maintenance
Line Item
Expiration

Visibility of Base
Download Package

Visibility of
Maintenance
Download Package

Acme Perpetual NA Yes Yes

Blandit January 2018 January 2018 Yes until January 2018 Yes until January 2018

Convallis Perpetual Expired Yes, if the effective date of 
the base download 
package was before the 
maintenance expiration 
date

Yes, if the effective date of 
the maintenance download 
package was before the 
maintenance expiration 
date

Dapibus November 2017 April 2016
February 2017
January 2018

Yes until January 2018 Yes until January 2018

Euismod May 2019 January 2018 Yes until May 2019 Yes until May 2019
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Enabling Channel Partners to Download Files 
A producer can enable a channel partner to download files, on behalf of end users, for product demonstration 
and support purposes.  

After the product is deployed and associated with a download package, the producer creates the channel partner 
user, creates an entitlement line item for the product for the channel partner user’s account, and assigns an end 
customer user account to the entitlement. 

Important • This option is limited to entitlements with end customer and channel partner user accounts. It does 
not work for entitlements with only channel partner users.

The channel partner user logs in to the FlexNet Operations End-User Portal with the line item’s activation ID, 
navigates to the List Entitlements page, and locates the entitlement in the table. From there, the file can be 
downloaded using the standard download procedure. 
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Getting Started with Usage 
Management

The purpose of this getting started section is to provide an overview on the use of the FlexNet Operations and 
FlexNet Usage Management (a feature of FlexNet Operations). These components, when used with FlexNet 
licensing products, help application producers maximize software revenues and eliminate revenue leakage 
through new support of increasingly popular usage-based trust but verify, pay-for-use, and pay-for-overage 
models. Revenera’s market-leading compliance management solution provides application producers the 
flexibility to implement any software licensing model across the entire spectrum—from strict enforcement to 
usage-based, trust but verify.

This getting started section primarily describes concepts and tasks related to FlexNet Operations with FlexNet 
Usage Management. For information about implementing an application that performs usage capture, see the 
appropriate FlexNet licensing documentation. For example, if you are implementing a connected software client 
that will run in a customer environment, see your FlexNet client documentation: The FlexNet Embedded Client C 
SDK User Guide or the FlexNet Embedded Client C XT SDK User Guide. 

It is expected that you will use this section Getting Started with Usage Management in conjunction with the 
usage-capture instructions in your FlexNet licensing user guide.

This getting started section is organized into the following subsections.

Table 16-1 • Getting Started With Usage Management

Topic Content

FlexNet Usage Management 
Concepts

Provides general information about usage-capture and usage-
management terminology and tasks.

FlexNet Usage Management 
Exercises

Provides an introductory walkthrough of preparing FlexNet Operations 
to work with the FlexNet licensing usage-capture in order to perform 
usage management.

Advanced FlexNet Usage 
Management Activities

Provides additional information about usage-capture and usage-
management terminology and tasks.



Chapter 16 Getting Started with Usage Management
FlexNet Usage Management Concepts

528 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

To view a brief, informative video that walks you through the exercises in the section Getting Started with Usage 
Management, click the link, below: 

https://www.youtube.com/watch?v=YduQeOevrJM

We recommend that you read this getting started section in full, to gain an understanding of the concepts it 
covers, before you view the video. 

FlexNet Usage Management Concepts
This section describes general concepts involved in working with FlexNet Usage Management. The following are 
some of the concepts and terminology used throughout this documentation.

• Usage Management

• Metered Licensing

• Products

• Features

• Capability Requests and Responses

• License Servers

• Usage Dashboard

Usage Management
FlexNet Usage Management allows producers to flexibly track, view, and report on feature usage in the usage-
capture clients. FlexNet Operations’ usage management features support compliance management licensing 
models. 

In the FlexNet Operations Producer Portal, you define the metered license model, features, products, and 
entitlements to model the usage events your clients are capturing. The exercises in this getting started section 
walk through the setup in the Producer Portal necessary to connect with the “survey” feature included in the 
FlexNet Embedded licensing code samples.

As usage capture data is collected in your license servers and uploaded to FlexNet Operations, you can also use 
the Producer Portal to view graphs and gauges of your customers’ usage.

Connecting to the back office, producers can also pull usage data in CSV format via reconcilation summary 
requests.

Metered Licensing
Metered licensing refers to usage-based licensing. In FlexNet Operations, metered licensing starts with the 
creation of a metered license model and related choices about the reusability, undo interval, and overdraft 
settings for products that use it. For more information about these settings, see the exercise, Creating License 
Models. 

https://www.youtube.com/watch?v=YduQeOevrJM
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With a metered license model created, you can define features to match the usage data your usage capture 
clients are sending and create a product that delivers those features under the rules defined by your metered 
license model. 

Products
Products are packages of features that can be sold by a producer. Products that will support usage management 
must use a metered license model. Also, producers specify a usage model for the product. The usage model 
defines the length of the reporting period and frequency at which usage data is reset. See Creating Products.

Important • Products using the same feature must be configured with the same usage model per account. For an 
account, the usage model that is specified for a product containing a specific feature will be the usage model 
that is used for subsequent entitlements or products containing that specific feature. For example:

• Product A (feature f1) and product B (features f1 and f2)

• Account C is first entitled to product A (feature f1) with usage model Monthly Statements (No Reset)

• Account C is then entitled to product B (features f1 and f2) with usage model Monthly Statements (Reset 
Monthly)

• Account C will use usage model Monthly Statements (No Reset) for both products A and B because they both 
contain feature f1 which was included in the first entitlement.

If Account C was first entitled to product B (features f1 and f2) with usage model Monthly Statements (Reset 
Monthly), this usage model would be used for both products/entitlements for the account. 

Features
The smallest unit for which usage can be captured is a feature. You define the feature or features that make up 
your products in FlexNet Operations, and your usage-capture code sends information about these features. In 
addition, feature-clipping code checks for the availability of certain features to determine a product’s 
functionality.

During execution, your capped-usage or feature-clipping code uses FlexNet licensing functions that attempt to 
acquire a license. The FlexNet licensing libraries validate such conditions as the feature not having expired. If the 
license acquisition succeeds, your code would then enable the corresponding capability.

For features intended to support usage management, you will also specify units and scale settings. Together, 
these settings allow you capture usage data in fine detail but report on usage counts with more manageable or 
meaningful numbers. Units define the label to be shown when usage data is reported. Scale is the factor by which 
the raw usage counts are divided. For example, if your usage-capture client tracks the time for which a feature is 
used in seconds but you want usage reports to show usage in minutes, you might set Units to “Minutes” and 
Scale to “60.” For more about features, see the exercise, Creating Features. 
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Capability Requests and Responses
When your usage-capture code communicates with FlexNet Operations, the communications involve capability 
requests and capability responses. A capability request is generated by the client (either a client reporting usage 
or requesting features that it will acquire). The request data contains some combination of a host identifier, one 
or more desired features, and other optional data to pass to FlexNet Operations.

The license server instance then processes the request, reading the various identifiers, desired features, and 
custom data. If FlexNet Operations determines that the client requires a response, it generates a capability 
response. The response data contains current license rights available for the client. The capability response is 
then conveyed back to the client, which processes the response, after which the features in the response can be 
queried for the sake of detecting if a quota has been exceeded or for feature clipping (programmatically 
restricting access to features based on the capability response).

Your usage-capture code specifies one or more desired features, which represent features whose usage is being 
reported or features desired for the sake of feature clipping, in the capability request. 

Your code also specifies an operation in the capability request, which indicates whether it is simply reporting 
feature usage, or whether a response is expected. The “report” operation is used in uncapped-usage scenarios, 
when no response is needed; and the “request” operation is used in capped-usage and feature-clipping 
scenarios, where a response is needed. The request operation can also be used in untrusted environments to 
report uncapped usage to force a confirmation response from the server, ensuring that the usage has been 
reported. (There is also an “undo” operation, which enables recent information to be undone, in case of error or 
canceled usage.)

License Servers
Your usage-capture clients send usage data to a license server. The license server can be a local license server 
or, as in the case in this getting started section, a license server instance in the FlexNet Cloud Licensing Service. 
In both cases, the license server captures the metered usage data that your usage-capture clients send.

• Local License Servers

• Cloud Licensing Service Instances

• Auto-Provisioning

Local License Servers
Usage-capture clients can send usage data to license servers that you deploy into your customers’ enterprises. 
(The deployment of local license servers is not covered in this getting started section.) Consult your FlexNet 
licensing documentation for more information about deploying local license servers. 

Cloud Licensing Service Instances
For producers who use FlexNet Cloud Licensing Service in addition to FlexNet Operations, license servers can be 
created in the FlexNet Cloud Licensing Service. These license server instances can be manually created or 
dynamically generated (using the Auto Provision feature of FlexNet Operations). The chief benefits of using cloud 
licensing service instances rather than deploying local license servers is the speed with which license servers can 
be deployed and the ease with which licenses can be mapped to the license server instance. 
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Auto-Provisioning
When the license model permits auto-provisioning, cloud licensing service instances can be automatically 
generated by FlexNet Operations. 

When auto-provisioning is permitted, FlexNet Operations generates a new license server when an entitlement 
using such a license model and owned by an end customer account, is deployed. Also, line items included in the 
entitlement are automatically mapped to the license server instance. 

When auto-provisioning is not permitted, producers can create the license server instance manually. In this 
scenario, the producer uses the Create License Server page to create a license server for the end customer and 
then manually maps the entitlement line items to that server. 

The exercises in this getting started section make use of auto-provisioning in the license model to streamline 
license server creation and entitlement mapping. 

Limitations
The following limitations exist for auto-provisioned license servers that have entitlements mapped for metered 
features:

• License servers cannot be moved to another account.

• You cannot remove licenses using Licenses > Remove Licenses.

• License servers can be made obsolete, which will remove all licenses mapped to the server. However, this is 
not recommended, because future line items will not be mapped automatically to the auto-provisioned 
license server.

Usage Dashboard
FlexNet Operations enables you to view enterprise customers’ current usage data in the Producer Portal. 
Similarly, your enterprise customers can view their current usage data in Usage Management in the enterprise 
portal you set up.

The following types of graphs are supported with respect to usage capture. Usage data can also be downloaded 
as a text file in CSV format. After selecting what usage data to display—as described in Viewing Usage 
Information—and selecting the desired usage period, you can select the type of graph in which to display the 
usage data.

Figure 16-1: Buttons for selecting the graph type

These buttons in FlexNet Operations correspond to usage gauges, tables, timelines, and comparisons, as 
described in the following sections.

• Usage Gauges

• Usage Tables

• Usage Timelines
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Usage Gauges
This type of graph shows usage data as a graphical gauge representing the percentage of usage compared to the 
overall entitled amount. The green region of the gauge indicates usage of none to 75 percent of the available 
count; the yellow region indicates 75 percent to 100 percent of the available count; and the red region indicates 
over 100 percent (overage) of the entitled amount.

Figure 16-2: Usage gauge

Details of the usage information are displayed beneath the gauge.

Usage Tables
Usage information can also be displayed in a textual table.

Figure 16-3: Usage table

Usage Timelines
Usage information can also be displayed in an interactive Flash-based timeline. Commands in the upper left 
corner enable zooming in to different time periods, and you can click and drag the graph left and right to control 
the dates for which data are being displayed.
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Figure 16-4: Interactive usage timeline

A similar interactive option is the Compare Meters graph, which simultaneously displays multiple features’ usage 
information over the same period of time.

The following section describes setting up FlexNet Operations with FlexNet Usage Management to handle usage 
capture.

FlexNet Usage Management Exercises
This section describes how to get started with FlexNet Usage Management. You will learn about setting up 
FlexNet Operations to support usage-based licensing and connecting your usage clients to a license server 
instance hosted in the FlexNet Cloud Licensing Service. 

The section is divided into the following subsections. 

Section Description

Prerequisites Prerequisites for included exercises.

Preparing FlexNet Operations Exercises to set up FlexNet Operations with FlexNet Usage Management 
for usage capture. This section includes creating license models, 
features, products, and entitlements.

Obtaining the License Server URL Instructions for determining the license server URL to which your usage-
capture clients send their usage data. 
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Prerequisites
The following items are prerequisites for developing and deploying usage-capture code with FlexNet Usage 
Management. 

FlexNet Licensing Usage-Capture Client Implementation
It is assumed that you have downloaded your FlexNet licensing platform for implementing an application to 
perform usage capture. Refer to the corresponding licensing client documentation for information about building 
the example code and implementing a usage-capture client.

To complete the exercises in this getting started section, users also must have received publisher keys from 
Revenera. 

Note • The creation of a publisher and an identity are covered in the section Getting Started with 
FlexNet Embedded Licensing. 

FlexNet Operations Instance
It is also assumed that you have access to FlexNet Operations via the Producer Portal and the End-User Portal. 
Producers must have already have their producer account activated and a user account on the Producer Portal in 
which FlexNet Embedded, FlexNet Usage Management, and FlexNet Cloud Licensing Service features are 
enabled. 

Preparing FlexNet Operations
To prepare FlexNet Operations to receive usage data, you must create and associate several entities using the 
Producer Portal. Some of these steps are common to any use of FlexNet Operations with FlexNet Licensing, and 
some steps are specific to FlexNet Usage Management.

This preparation includes the following exercises. 

Running a Usage-Capture Client 
Example

Brief discussion of running a usage-capture client. 

Viewing Usage Information Instructions for viewing usage graphs and gauges on the Producer 
Portal.

Usage Management Next Steps Identifies other, more advanced usage capture activities covered, briefly, 
in the following section.

Exercise Description

Creating License Models Shows how to create two license models: one for metered products 
and one for unmetered products.

Section Description
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After you verify that the new license server was created, the FlexNet Operations preparations are complete. 
Continue with Obtaining the License Server URL, Running a Usage-Capture Client Example, and Viewing Usage 
Information.

If you have not previously used FlexNet Operations, see Getting Started with FlexNet Embedded Licensing for 
more information. 

Creating License Models
In this exercise, you create two license models: one is a usage-based (metered) license model to be used with 
metered products and the other is an unmetered license model to use with the unmetered product and facilitate 
client registration. 

Note • The unmetered product is used to register usage-capture clients operating in untrusted environments. 

Creating a Metered License Model to Track Usage
Usage-based license models are FlexNet Embedded license models that use metered licensing—typically 
following a metered-capped (limits to usage counts) and metered-uncapped (tracking and reporting but no 
limits).

To indicate that usage data should be tracked for a feature (capability), you must create a metered license model 
with appropriate settings. For the example basic uncapped usage client, you will define a metered-uncapped 
license model.

When working with usage capture, the important settings are Metered, Reusable, Undo Interval, and Overdraft, 
and Auto Provision. 

Creating Features Explains how to create the metered feature, survey, for which 
metered usage is tracked and an unmetered feature, baseline-client-
reg, that is necessary to register usage-capture clients running 
outside of trusted environments.

Creating a Product Line Covers the creation of a product line necessary for usage reporting.

Creating Products Explains how to create two separate products: one for the metered 
feature and one for the unmetered feature. 

Creating an Account and User Shows how to create a customer account and user to which the new 
products will be entitled.

Entitling the Account Describes how to create an entitlement, configure its line items with 
the new products, and entitle the customer account to those line 
items.

Viewing the Auto-Provisioned License 
Server

Explains how to find the Cloud Licensing Service license server that 
was created when the entitlement was deployed. 

Exercise Description
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• Defining a license model as Metered indicates that it is intended for use with usage capture and usage 
management.

• Reusable and Undo Interval attributes work together to determine whether usage counts can only increase or 
are permitted to decrease as well. Reusable allows the decrease of feature checkouts, generally. Undo 
Interval optionally expresses a window in which checkouts can be canceled even if Reusable is set to No. 

• The Overdraft setting defines the policy for usage over the entitled license count: overdraft can be Not Used 
(no overdraft allowed), Unlimited (uncapped usage, as with this example), or defined as a fixed value or 
percentage of the total entitlement. 

• Set Auto Provision to Yes to support license server auto-provisioning. Auto-provisioning allows FlexNet 
Operations to automatically create new license servers when new entitlements require it and, when a default 
license server is present, automatically maps new rights to the default license server. 

For the first part of this exercise, you specify the following settings for the metered license model attributes:

Attribute Value

Name Example Metered License Model

Expiration None

Is this an Embedded License Model? Yes

Is this a Counted Model? Yes

Is this a Metered Model? Yes

Reusable Yes

Undo Interval Not Used

Overdraft Unlimited

Auto Provision Yes

Issuer Not Used

Serial Number Not Used

Vendor String Not Used

Notice Not Used
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Task To create a usage-based license model

1. In the Producer Portal, click Administer > License Models. The Producer Portal opens the License Models 
page. 

2. On the License Models page, click Create New License Model. This button opens the Select a License 
Technology page. 

3. Select FlexNet Licensing and click Next. The Producer Portal opens the Create a License Model page. 

4. Specify license model name and expiration setting. For this exercise, use the values specified in the table 
above: Example Metered License Model and None.

5. Click Next. The Producer Portal begins rendering interactive settings for license model policies. 

6. Set the license model policy values described in the table above, and click Save.

The Producer Portal creates the license model with the settings you specified. 

Creating an Unmetered License Model for Client Registration
If you are implementing a connected software client, the client registration process requires an additional 
unmetered license model. For this purpose, create a second license model, called Example Baseline LM, with 
Metered set to No and Counted set to No.

For the second part of this exercise, repeat the license model creation process but specify the following settings 
for the unmetered license model attributes:

Retain the defaults for all other attributes.

Attribute Value

Name Example Baseline LM

Expiration None

Is this an Embedded License Model? Yes

Is this a Counted Model? No

Is this a Metered Model? No

Issuer Not Used

Serial Number Not Used

Vendor String Not Used

Notice Not Used
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Deploying the License Models
Before these new license models can be used in an entitlement, you must deploy them. (Deploying a license 
model changes its state from draft to deployed.)

Task To deploy Example Metered License Model and Example Baseline LM

1. In the Producer Portal, click Administer > License Models. The Producer Portal opens the License Models 
page. 

2. On the License Models page, locate the Example Metered License Model and Example Baseline LM license 
models. If they do not immediately appear in the License Models list, try searching License Models for 
Example.

3. Click the checkboxes for Example Metered License Model and Example Baseline LM, and then click Change 
State > Deploy.

4. Click OK to confirm the state-change operation. 

The Producer Portal deploys the license models and refreshes the License Models page to show the new 
Deployed state.

Creating Features
In FlexNet Operations, usage data is tracked by feature. In this exercise you will create two features. 

The FlexNet Embedded C SDK and FlexNet Embedded XT usage-capture examples track usage for a feature called 
survey. You will create that feature as our metered feature in this exercise. In addition, you will create another 
feature, called baseline-client-reg, to facilitate client registration. 

• For instruction on creating the survey feature, see Creating a Metered Feature.

• For instruction on creating the baseline-client-reg feature, see Creating an Uncounted, Unmetered Feature 
for Client Registration.

For each feature, we will create a separate product and then combine those products in an entitlement to deliver 
to a user in a customer account.

Creating a Metered Feature
In the Producer Portal, use the commands under the Products menu to add a feature called survey, version 1.0. 
When defining the feature, use the following settings:

Attribute Value

Feature Name survey

Feature Version 1.0

Description Example feature for usage capture.

Units Measurements

Scale 1
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Leave all other attribute settings on their default values.

Task To create the survey feature

1. In the Producer Portal, click Products > Features. The Producer Portal opens the Feature page. 

2. On the Feature page, click Add New Feature. This button opens the Create a Feature page. 

3. On the Create a Feature page, set the feature attributes using the values in the table above. 

4. Click Save. 

The Producer Portal creates the survey feature and remains on the Create a Feature page. 

In practice, a feature count of 1 should represent the smallest possible difference in values you intend to capture. 
If this choice would cause large numbers in usage reports, you can use the Scale setting to define a factor by 
which the values in the reports will be divided before they are displayed. For example, a realistic choice for file 
sizes is to have feature usage counted in bytes, set the scale to one billion, and set Units to GB.

Creating an Uncounted, Unmetered Feature for Client Registration
The client registration process requires an additional unmetered, uncounted feature. For this purpose, create a 
second feature called baseline-client-reg. 

Repeat the feature creation process for the baseline feature. Use the settings shown in the table below. 

Leave all other attribute settings on their default values.

Creating a Product Line
In the Producer Portal, use the commands under the Products menu to create a product line. No particular 
settings are required for usage capture. The following instructions create a product line called Example Product 
Line. 

Counted Do Not Override

Reusable Do Not Override

Attribute Value

Feature Name baseline-client-reg

Feature Version 1.0

Description Example unmetered feature to do client-
registration for entitlements that deliver metered 
products.

Attribute Value



Chapter 16 Getting Started with Usage Management
FlexNet Usage Management Exercises

540 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Task To create the Example Product Line

1. In the Producer Portal, click Products > Product Lines. The Producer Portal opens the Product Lines page. 

2. On the Product Lines page, click Add Product Line. This button opens the Create Product Line page. 

3. On the Create Product Line page, type the name of the product line: Example Product Line.

4. Click Save.

The Producer Portal saves Example Product Line. The product line is used as an attribute in the search criteria on 
the Usage Search page, when you want to view usage graphs or gauges for a particular product line. 

Creating Products
Use commands under the Products menu to create two products: 

• Example Survey for the metered feature for which you intend to capture usage (survey)

• Example Baseline for the client registration feature (baseline-client-reg)

Creating the Example Survey Product
Follow the steps, below, to create the Example Survey product. 

Task To create Example Survey

1. In the Producer Portal, click Products > Products. The Producer Portal opens the Products page. 

2. On the Products page, click Add New Product. This button opens the Create a Product page. 

Attribute Value

Product Name Example Survey

Version 1.0

Licensing Technology FlexNet Licensing

Can Be Used on a Device Yes

Usage Models Monthly Statements (Reset Monthly)

Feature Survey,1.0

Feature Quantity 1

License Model Example Metered License Model

Product Line Example Product Line
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3. On the Create a Product page, set the Product Name, Version, License Technology, Can Be Used on a Device, 
and Usage Model as shown in the table above.

Note • A usage model must be set for reconciliation to take place and to be able to view usage gauges and 
graphs. Also, be aware that usage models labeled as monthly statements refer to a rolling 30-day window 
and not a calendar month.

Important • Products using the same feature must be configured with the same usage model per account. 
For an account, the usage model that is specified for a product containing a specific feature will be the 
usage model that is used for subsequent entitlements or products containing that specific feature.

Example:

• Product A (feature f1) and product B (features f1 and f2)

• Account C is first entitled to product A (feature f1) with usage model Monthly Statements (No Reset)

• Account C is then entitled to product B (features f1 and f2) with usage model Monthly Statements (Reset 
Monthly)

• Account C will use usage model Monthly Statements (No Reset) for both products A and B because they 
both contain feature f1 which was included in the first entitlement.

If Account C was first entitled to product B (features f1 and f2) with usage model Monthly Statements (Reset 
Monthly), this usage model would be used for both products/entitlements for the account.

4. Click Add Features. The Producer Portal opens the Add Features to Product page in a pop-up window. 

a. Locate the feature, survey, 1.0., and click Add. This selects the feature and moves it to the Selected 
Features list.

b. Click Add. The Producer Portal closes the Add Features to Product window. 

5. On the Create a Product page, set the Quantity for the survey feature to 1, and click Next. (For a counted 
feature, this is the feature count per copy of the product ordered.) The Producer Portal opens the Link 
License Models to Product page. 

6. Click Link License Models to open the Select License Models page in a pop-up window. 

a. Locate the license model, Example Metered License Model, and click Add. This selects the license 
model and moves it to the Selected License Models list.

b. Click Add. The Producer Portal closes the Select License Models window.

7. Click Next until you see the Map Product to Product Line page. (Depending on your Producer Portal 
configuration, you will pass a few pages—such as Map Part Numbers to Products and Relate to Different 
Products—without making any changes.)

8. On the Map Product to Product Line page, do either of the following to specify the product line Example 
Product Line: 

• In the Product Line field, type Example Product Line.

• Click the search icon next to the Product Line box. The Producer Portal opens the Select Product Line for 
Product page in a pop-up window. Search for and select product line Example Product Line, then click 
OK. The Producer Portal closes the Select Product Line for Product window. 
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9. Click Save.

The Producer Portal saves Example Survey and remains on the Map Product to Product Line page. 

Creating the Example Baseline Product
Next, repeat the steps, creating a product for the uncounted baseline-client-reg feature and unmetered license 
model used in client registration. Use the following settings for the Example Baseline product.

Important • Before these new products can be used in an entitlement, you must deploy them. (Deploying a 
product changes its state, and the state of its features, from draft to deployed.) Click the checkboxes for the 
Example Survey and Example Baseline products, click Change State > Deploy, and follow the on screen 
instructions to confirm the change.

Creating an Account and User
In the FlexNet Operations Producer Portal, use the commands under the Users & Accounts menu to create an 
account that represents a customer enterprise. For this example, create an account called Demo Customer Org.

Note • The customer account and end user created in these exercises are the same as those created in the 
exercises in the section Getting Started with Electronic Software Delivery. If the account and user already exist, 
you can skip the steps that create them, below.

If you already have a test end user in a customer account you can entitle to these products, you can opt use that 
user instead of creating the user described here. 

Attribute Value

Product Name Example Baseline

Version 1.0

Licensing Technology FlexNet Licensing

Can Be Used on a Device Yes

Usage Models None

Feature baseline-client-reg,1.0

Feature Quantity 1

License Model Example Baseline LM

Product Line Example Product Line
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Follow the instructions, below, to create the customer account (Demo Customer Org), the end user account 
(Demo Customer) and entitle it to the survey product.

Task To create the customer account and end user

1. In the Producer Portal, click Users & Accounts > Create Account. The Producer Portal opens the Create an 
Account page. 

2. On the Create an Account page, type the following values for the Account Name and Display Name attributes. 

Keep the default values for all other attributes.

3. Click Create a User. The Producer Portal saves the Demo Customer Org account and opens the Create a User 
page to add a new user to it.

4. On the Create a User page, type the following values for the new user’s Contact Details: 

Keep the default values for all other User Details and Contact Details attributes.

5. In Accounts, select the check box for Portal User Role. This gives Demo Customer the standard permissions 
for portal users.

6. Click Save. 

The Producer Portal creates Demo Customer as a new user and sends a welcome message to the email address 
you provided. Use the credentials in that email to log in to the End User Portal and verify the Demo Customer 
account is functional.

Entitling the Account
Use the commands in the Entitlements menu to create an entitlement to the survey and baseline products for 
Demo Customer Org. 

In this exercise, you will create a new entitlement, add Demo Customer Org as the end customer, configure a line 
item for the uncounted, unmetered product for client registration, Example Baseline, and configure another line 
item for the metered product, Example Survey. 

Attribute Value

Account Name DemoCustOrg

Display Name Demo Customer Org

Attribute Value

First Name Demo

Last Name Customer

Email Address An email address you control. This email account is where FlexNet Operations 
will send the initial login credentials and entitlements.
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Task To create the entitlement ENTL-SURVEY001

1. In the Producer Portal, click Entitlements > Create. The Producer Portal opens the Create an Entitlement 
page. 

2. For Entitlement ID, select Specify and type ENTL-SURVEY001. 

3. For End Customer and Channel Partners, click Add. The Producer Portal opens the End Customer and 
Channel Partners page in a pop-up window. 

a. Click the radio button for DemoCustOrg to select the Demo Customer Org as the customer account to 
receive the entitlement. 

b. Click Next. The Producer Portal shows the End Customer and Channel Partners: Contacts page in the 
pop-up window.

c. Click the radio button for Demo Customer to select Demo Customer as the end user who will receive the 
entitlement message.

d. Click Save.

The Producer Portal closes the pop-up window and shows Demo Customer Org and Demo Customer as the 
end customer. 

4. Click New Line Item to begin configuring a line item for the Example Baseline product. The Producer Portal 
opens the Configure Line Item page in a pop-up window.

Figure 16-5: Starting the line item configuration process for the Example Baseline product.

a. Locate and select the Example Baseline product, and then click Next. 

b. Select the license model, Example Baseline LM, and click Next. 

c. Specify the following settings for product configuration: 

• Qty: 1
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• Start Date: 01/01/2016

• Expiration: 01/01/2020

d. Click Next.

e. Click Save.

5. Click New Line Item to begin configuring a line item for the Example Survey product. The Producer Portal 
opens the Configure Line Item page in a pop-up window.

a. Locate and select the Example Survey product, and then click Next. 

b. Select the license model, Example Metered License Model, and click Next. 

c. Specify the following settings for product configuration: 

• Qty: 2000

• Start Date: 01/01/2016

• Expiration: 01/01/2020

d. Click Next.

e. Click Save.

6. Click Save & Deploy.

The Producer Portal saves ENTL-SURVEY001 with line items for Example Baseline and Example Survey. 

Important • Notice, in the instructions above, that the entitlement line item for the Example Survey product 
stipulates dates for Start Date and Expiration settings. To track usage for a product, you must specify a date for 
the Start Date value when you create the entitlement. Start Date cannot be Specify at First Activation, Specify at 
Each Activation, Use First Activation Date, or Use Each Activation Date. Similarly, Expiration cannot be set to 
Specify Duration. Its value must be either Permanent or a specified date. 

At this point, if you log in to the End-User Portal, as Demo Customer, you can see the survey entitlement listed on 
the End-User Portal’s home page. 

FlexNet Operations also generates the license server instance in the FlexNet Cloud Licensing Service and maps 
the Example Survey line item to the new server. 

Tip • Make a note of the activation ID for Example Baseline. When you run a usage capture client, you will use the 
activation ID as the rights ID during the client registration process.

Viewing the Auto-Provisioned License Server
Once you deploy the entitlement, ENTL-SURVEY001, FlexNet Operations automatically generates the license 
server instance from which served clients in the end customer account acquire their license rights. In this 
exercise, you will locate the auto-provisioned license server in the Producer Portal. 
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Task To view the auto-provisioned license server

1. In the Producer Portal, click Devices > Search License Servers. The Producer Portal opens the Search License 
Servers page. 

2. On the Search License Servers page, locate the new license server by its account name. For Account Name, 
type DemoCustOrg and then click Search. The Producer Portal opens the Search Server Results page. 

3. On the Search Server Results page, click the license server ID for DemoCustOrg’s license server. The 
Producer Portal opens the View Server page. 

Notice that the View Server page shows a number of important attributes of the license server. In particular, make 
a note of the license server ID. The license server ID, in this case 3VH8MNZESMSP, is used in the endpoint URL for 
that license server, where the served clients connect to make capability requests. (See Obtaining the License 
Server URL.)

Notice also, that the license server’s View Server page also shows the product licenses that are served by it. In 
this case, the license server includes the Example Survey line item from the ENTL-SURVEY001 entitlement. (The 
Example Baseline line item is not served by the license server. Instead, it is present in the entitlement to support 
the registration of the license server’s served clients.)

Tip • When auto-provisioning is used, you can also find a customer account’s default license server instance on 
customer account’s Create an Account page. There, click the license server ID link, labeled Cloud Licensing 
Service instance (Auto Provisioned), to open the View Server page.

Obtaining the License Server URL
The URL for the license server instance hosted in the FlexNet Cloud Licensing Service is the location where your 
FlexNet licensing client sends its usage capture data. 

Tip • This getting started section uses the FlexNet Operations User Acceptance Testing (UAT) site for 
demonstration purposes. Any URLs mentioned will need to be adjusted when used in Production. 

For a connected software client using FlexNet licensing, such as the FlexNet Embedded C SDK or FlexNet 
Embedded XT, the URL is:

http://<serverhost>:<serverport>/gls/instances/<CLS instance ID>/request 

In the URL, above, <serverhost> is the hostname for your FlexNet Operations instance and <serverport> is the 
HTTP port. <CLS instance ID> is the license server ID of the license server to which capture data is sent. For 
example, the <CLS instance ID> value based on the auto-provisioned license server instance created in the 
exercises in this section would be 3VH8MNZESMSP. For more information about the site ID, see FlexNet Operations 
Environments.
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Running a Usage-Capture Client Example
At this point, you can put the pieces together and run the usage-capture client example from the appropriate 
client toolkit.

If you are using FlexNet Embedded C SDK or FlexNet Embedded XT to implement a connected software 
application or device, the example is called usage capture client. In these implementations, you will use the 
example to first send a capability request that specifies the activation ID as a rights ID, to register the client, and 
then send capability requests containing desired features that describe the usage being captured.

See your licensing user guide for implementation and usage details for the examples.

Viewing Usage Information
You can view usage information in the Producer Portal. Recall that your product must have a usage model set for 
usage information to be shown in the usage graphs and gauges, as described in Creating Products. 

Under the Usage menu, select Usage Search. In the Usage Search screen, enter the name of your metered 
feature—survey—in the Meter Name field and then click Search. Click the desired account from the list of results 
to see usage reports for that account. For these exercises, choose the customer account you created earlier: 
DemoCustOrg.

The captured usage information is then rendered on the Usage Search page. By default, the usage information is 
displayed as a gauge showing the percentage of the usage count compared to the entitled count. The label for 
the gauge shows the text you entered for the feature description, if any. The value you entered for Units on the 
Create a Feature page—in this case, Measurements—appears as the label for the usage count. In practice, this 
might be Downloads or Gigabytes or whatever usage you are tracking.
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Figure 16-6: Example usage gauge for the survey feature

In the View Usage page, you can view the captured usage information as different types of graphs, or download 
the usage information for analysis. With the graph buttons, you can display usage information as a gauge, a 
textual table of usage information, a graphical timeline, or a graphical timeline comparing multiple metrics.

Note • Unless you have a client that is already reporting usage data, expect the usage reports to show 0 usage. 

Similarly, a user in the enterprise customer account can view current usage information by logging in to the End-
User Portal and viewing usage reports.

Usage Management Next Steps
This section demonstrates a simple scenario for verifying that your toolkit is working properly. See the following 
section for further information about more advanced FlexNet Usage Management tasks, like manually created 
license servers, uploading usage history data, and downloading reconciliation summaries.
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Advanced FlexNet Usage Management 
Activities

The following are some more advanced activities for producers who use FlexNet Operations with FlexNet Usage 
Management.

Manually Creating a License Server
An enterprise customer’s usage data is sent to a license server. In some cases, such as for a large enterprise 
customer, it may be desirable to provide multiple license servers hosted in the Cloud Licensing Service. This 
exercise shows how to use the Producer Portal to manually create a single license server deployed via FlexNet 
Cloud Licensing Service, to receive usage data for the Example Survey product. 

Note • The exercises in the previous section, FlexNet Usage Management Exercises, show the license server 
created automatically with auto-provisioning. With auto-provisioning off, a producer must manually create the 
license server instance and then map any entitlements to it. 

From the Devices menu, click Create License Server. Use the following settings to create a server.

Topic Description

Manually Creating a License Server Shows how to manually create a new license server instance in the 
FlexNet Cloud Licensing Service and then map the entitlement line item 
for the metered product to it.

Uploading Historical Usage Very briefly discusses the option to directly upload usage data for 
testing or demonstrations. 

Reconciliation Summaries Explains how to programmatically pull usage and overage data from 
the FlexNet Operations back office. 

Obtaining Raw Usage Data Provides an overview on how to use the Usage Data Extract job on the 
Producer Portal and the data extract RESTful services to retrieve raw 
usage data from FlexNet Operations.

Usage Data via SOAP Introduces the getUsage web service as a method of retrieving real-
time, reconciled usage data for an account.

Attribute Value

Deployment Cloud Licensing Service

Identity fne-demo

Site Name Demo Customer Org’s Hosted Server 1
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Retain the default settings for all other attributes. 

Figure 16-7: Creating a license server instance to be hosted in the FlexNet Cloud Licensing Service

The View Server page displays the server’s license server ID. The license server ID, in this case RD1KPTL6NJ21, is 
also the instance ID value for the server. This instance ID value is used in the URL where usage information is sent 
for this enterprise customer.

While still in the View Server page, click Action and then click Map Entitlements. Use the Map Entitlements page 
to associate a quantity of line items to the server. From the list of entitlements, type quantities in the Qty to Add 
column. Type 1000 for Example Survey and click Save. 

Note • The metered Example Survey product is the one that is used on this license server. The unmetered 
Example Baseline is for registering devices that report usage data.

Figure 16-8: Mapping a product to a license server

Owner ID Demo Customer Org

Attribute Value
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After the product is mapped, usage-capture code can send capability requests to this license server instance.

Uploading Historical Usage
When testing or demonstrating FlexNet Operations usage reporting functionality, it may be useful to quickly 
upload some test usage data rather than waiting for your usage-capture clients to report actual usage data. This 
operation is supported via the Upload Historical Usage command in the FlexNet Operations Producer Portal. For 
more information, consult the section Managing Usage.

Reconciliation Summaries
In addition to viewing gauges in the Producer Portal, FlexNet Usage Management provides a way to download 
simple usage reports that can be uploaded to a billing system. A reconciliation summary is a file containing 
records of usage and overage data for a given account ID, product name, and feature name, for the desired billing 
period.

While logged in to the Producer Portal, you can download a reconciliation summary file by opening this URL, 
where <siteID> is your account’s site ID and yyyy-mm-dd is the billing period end date (for information about the 
site ID, see FlexNet Operations Environments):

https://<siteID>-fno.flexnetoperations.com/flexnet/service/ReconSummary?StmtCloseDate=yyyy-mm-dd

For a UAT environment, include -uat in the URL: 

https://<siteID>-fno-uat.flexnetoperations.com/flexnet/service/ReconSummary?StmtCloseDate=yyyy-mm-
dd

If you are not logged in, the URL must include username and password values in the query string. 

Instead of using a browser, you can automate download of the reconciliation summary data with a utility such as 
cURL, using a command similar to the following:

curl --url 'https://<siteID>-fno.flexnetoperations.com/flexnet/service/ReconSummary?
    username=user@domain.com&password=pwd&StmtCloseDate=yyyy-mm-dd'

The reconciliation summary file is a comma-separated text file (CSV file) containing the summary usage data for 
the specified billing period. The file contains a header row followed by records of usage data.

enterpriseName, accountID, productName, productID, featureName, friendlyName, startDate,
  endDate, usageUnitName, usageFromStatement,  entitled, overageFromReset, overageFromStatement
"DEMO1","DEMO1","Storage","55555","Connections","Number of Connections",2014-07-01,
  2014-08-01,,0,5000,0,0
"DEMO1","DEMO1","Storage","55555","Storage","Storage (GB)",2014-07-01,2014-08-01,,0,2000,0,0

You can then transform the data into the required format before uploading it to your billing system for processing.

Obtaining Raw Usage Data
Producers who schedule the Usage Data Extract job can download raw usage data from the results of that job via 
a RESTful service. The Usage Data Extract job generates an extract of all usage events from the end time of the 
last successful run to the current time.

See the Administering Alerts section for instructions on how to schedule the Usage Data Extract job.
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See the Data Extract RESTful Services section of the FlexNet Operations Web Services Integration Guide for 
instructions on how to query the results of the Usage Data Extract job.

Usage Data via SOAP
FlexNet Operations includes a getUsage web service. getUsage is a SOAP-based web service that retrieves real-
time, reconciled usage data for an account. It allows producers to programmatically gather the same data used in 
the Producer Portal to render usage in the usage gauges, tables, and timelines.

getUsage returns the end-user’s product line, meter, unit of measure, actual usage, entitled quantity, overage 
since statement, overage since reset, percentage, interval/reset, and time period.

For more information, see the FlexNet Operations SOAP Web Services Guide.
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Getting Started with 
FlexNet Customer Growth

The section Getting Started with FlexNet Customer Growth presents customer health visualization and 
entitlement renewal concepts and includes instructions for viewing customer health information as well as 
exercises for performing basic renewal tasks.

The intended audience for this getting started section is the first-time Producer Portal user, or one without 
FlexNet Operations training or experience, but one who has previously completed the exercises in the section 
Getting Started with Entitlement Management.

Section Description

Introduction Overview of this getting started section as well as a brief discussion of 
the licensing lifecycle, a summary of the features available with the 
FlexNet Customer Growth module, and a list of prerequisites for the 
exercises in this getting started section. 

• The License Lifecycle: FlexNet Customer Growth

• The FlexNet Customer Growth Module

• Exercise Prerequisites

FlexNet Customer Growth Concepts A discussion of basic FlexNet Operations customer health and renewal 
management concepts. This section describes the customer health 
and renewal features and their components and controls.

Visualizing Customer Health Instructions for navigating to and working with the Customer Growth 
dashboard and related account health pages in the Producer Portal to 
see the account health, renewal health, and consumption scores for 
your customers. 
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Introduction
This section provides a brief discussion of the licensing lifecycle, a summary of the features available with the 
FlexNet Customer Growth module, and a list of prerequisites for the exercises in this getting started section. 

• The License Lifecycle: FlexNet Customer Growth

• The FlexNet Customer Growth Module

• Exercise Prerequisites

The License Lifecycle: FlexNet Customer Growth
The FlexNet Operations license lifecycle is a repeating process of producer and customer activities, as depicted in 
the figure and described below. 

Notifying End Users about Expiring 
Entitlements

A series of exercises that demonstrate how to create renewals for 
expiring entitlements, how to activate email templates used to send 
renewal-related messages, how to set up the Expiring Entitlements job 
in the Producer Portal, and how to see Renewal Reminder email 
messages and view expiring entitlements in the End-User Portal, and 
how to send an intent-to-renew message from the End-User Portal. 

Notifying End Users About 
Expired Entitlements

A series of exercises that demonstrate how to set up the Expired 
Entitlements job and how to see the results of that job in the Producer 
Portal, End-User Portal, and Renewal Reminder messages. 

Section Description
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Figure 17-1:  FlexNet Operations License Lifecycle

• Create Products—Create product definitions that are used to generate licenses. 

• Order/Entitle—Define an account’s rights to obtain licenses for your products. 

• Deliver⁄Install—Deliver the application software to the customer and install that software. 

• Activate—Deliver licenses to the customer. 

• Return/Rehost—Manage license transfers from one user or system to another.

• Maintain/Update—Deliver software updates to the customer. 

• Upsell/Renew—Renew customer licenses, or sell the customer additional product functionality. 

This getting started section focuses on FlexNet Customer Growth features in the Upsell/Renew phase.

The FlexNet Customer Growth Module
The intent of the FlexNet Customer Growth module is to improve the end-customer nurturing process and reduce 
churn through visual account health indicators and automated renewal alerts.

The FlexNet Customer Growth module provides a dashboard, donut charts, and pages to highlight the health of 
your accounts and adds more robust support for the renewals process to FlexNet Operations. Producers who use 
FlexNet Operations with the FlexNet Customer Growth module can configure FlexNet Operations to automatically 
identify expiring entitlements and send renewal reminder messages to those accounts with licenses that are 
nearing their expiration date. In addition, the End-User Portal gains a new Expiring Entitlements page. This page 
lists an end user’s entitlements by their expiration date and gives special emphasis to those entitlements that 
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have expired or that are nearing their expiration date. On the Expiring Entitlements page, end users can select 
entitlements they want to renew and click a Request button to send a message to the producer about their intent 
to renew. 

The Exercise Prerequisites section, below, identifies what producers need in order to complete the exercises in 
this getting started section. 

To read more about FlexNet Customer Growth features and concepts, see FlexNet Customer Growth Concepts. 
(See Visualizing Customer Health for instructions on the use of these pages and features.)

To walk through exercises that illustrate the process of setting up FlexNet Operations to automatically alert end 
users about expiring or expired entitlements, see Notifying End Users about Expiring Entitlements or Notifying 
End Users about Expiring Entitlements. 

Exercise Prerequisites
Two areas of this getting started section provide exercises basic renewal tasks. The exercises show how to create 
renewal entitlements, set up the Expiring Entitlements and Expired Entitlements jobs, customize the Renewal 
Reminder email template, view Expiring Entitlements in the End-User Portal, view a Renewal Reminder message, 
and send an intent-to-renew message from the End-User Portal. 

Before you begin the exercises in this getting started section, verify that you meet the following prerequisites: 

• The FlexNet Operations demonstration database and seed data must be loaded. 

• You must have a FlexNet Operations Producer Portal login.

• End-User Portal users must have the View Expiring Entitlements permission to see the Expiring Entitlements 
page or to elect to receive renewal reminders.

Additionally, the exercises in this getting started section make use of the account, user, product, features, and 
entitlement created in the early exercises of the section Getting Started with Entitlement Management. Any 
product will suffice, as a sample to which expiring entitlements and renewals can be linked, but the exercises 
here use the product created in that getting started section.

FlexNet Customer Growth Concepts
This section introduces FlexNet Customer Growth concepts.

Section Description

The Customer Growth 
Dashboard

Explains how to read the Account Health, Renewal Health, and Consumption 
charts and also covers the Account KPIs list on the dashboard page and the 
Watchlist functionality. 

Account Health Pages Describes the main Accounts Health page as well as the Account Health detail 
pages for a particular account. 
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The Customer Growth Dashboard
The Customer Growth Dashboard shows charts for the three customer health scores above a list of accounts that 
shows the Key Performance Indicators (KPIs) for each account. By default, the charts and the account list include 
all of your accounts. If you select one or more accounts for more regular observation and add them to your 
watchlist, you can use the Watchlist toggle switch to include only the watched accounts in the charts and the list. 

The following sections have more detail about the charts, the KPI scores, and account list, and the watchlist. 

Renewals Briefly discusses how renewals fit in the license lifecycle, describes renewal 
jobs, renewal reminder email messages, and the End-User Portal’s Expiring 
Entitlements page. This section also provides more detailed examples of how 
FlexNet Operations handles the display of and messaging for expiring 
entitlements.

Next Steps Briefly discusses how to proceed in this getting started section according to 
your own needs and interests.

Section Description

About the Dashboard Charts Describes how the dashboard charts are composed, what they show, 
and how the interactive elements of the chart function. This section 
also explains how account health-related system configuration 
settings affect how the charts are rendered.

Key Performance Indicator (KPI) 
Scores

Discusses the KPI scores in more detail. For each chart—Account 
Health, Renewal Health, and Consumption—this section describes 
how the scores are calculated and how they are rendered on the 
Account Health pages.

About the Dashboard Account List Describes how the accounts are listed on the Customer Growth 
Dashboard page and what the trend lines represent.

Watched and Unwatched Accounts Explains what the watchlist is, how you can add or remove accounts 
from the watchlist, and how the Watchlist toggle alters the content of 
the account health charts and lists. 

Alerts Explains what triggers an alert and what type of alerts are generated.

Section Description
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About the Dashboard Charts
Visible from both the FlexNet Operations Home page and the Customer Growth Dashboard page, the Customer 
Growth Dashboard provides an at-a-glance view of overall health scores. This information is an aggregation of all 
the producer’s accounts, by default. It shows the number of healthy, warning and at risk items for account health, 
renewal health, and consumption, each in its own donut chart. 

For each chart, the overall score for all your accounts is represented by the number in the center. The arrows 
indicate trends, whether the scores are ascending or descending. Hover over the colored chart segments to find 
the number of accounts in that category. Click on a segment to be taken to the Accounts Health page with filters 
set for the score type and condition to match the segment you clicked.

Customer Growth Charts
The donut charts on the Customer Growth Dashboard page primarily show the Account Health, Renewal Health, 
and Consumption scores for your accounts—either all your accounts or all your watched accounts, depending on 
your Watchlist setting. (See Watched and Unwatched Accounts for information about using the Watchlist.)

• Account Health—The Account Health score is a weighted combination of the other account metrics (Renewal 
Health and Consumption). 

• Renewal Health—The Renewal Health score provides an overall rating for your accounts based mainly on 
how close the accounts’ entitlements are to their expiration dates. The chart also indicates the number of 
entitlements in each category (healthy, warning, and at risk) with the overall score of those accounts in the 
center. 

• Consumption—The Consumption score represents the ratio of products, features, or licenses used to the 
total number products, features, or licenses to which the accounts are entitled. Higher scores are better and 
indicate healthy consumption rates. Lower scores indicate that your accounts are further away from 
consuming the quantities to which they are entitled.

When the Producer Portal renders the chart segments, it applies the health threshold values in the system 
configuration settings. 
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System Configuration Settings for Customer Health Scores
The following system configuration settings play a role in determining whether an account’s condition is 
considered healthy, warning, or at risk. 

Tip • Producers can set the threshold values in their system configuration settings. In the Producer Portal, click 
System > Configure > FlexNet Operations > Health. 

Key Performance Indicator (KPI) Scores
The scores shown on the customer health pages indicate the fitness of your customer accounts by helping you 
visualize the accounts that are healthy, at risk, or in between. The Customer Growth Dashboard shows three 
scores: 

• The Consumption score shows the ratio of products, features, or licenses used to the total number of 
products, features, or licenses entitled expressed on a 100-point scale.

• The Renewal Health score provides a weighted score to highlight accounts with entitlements that are 
approaching their expiration date. 

• The Account Health score is simply a combination of Consumption and Renewal Health scores: 
(Renewal Score+Consumption Score)/2.

These scores appear in the dashboard charts, the dashboard’s account list, the Accounts Health page, and the 
account details pages. 

Consumables Counted Towards the Consumption Score
The items that count towards consumption depend on the type of licensing used. When FlexNet Operations 
calculates the Consumption score, it counts the following items: 

• FlexNet Publisher—fulfillments generated from entitlements

• FlexNet Embedded (Standalone device)—licenses mapped from entitlements

Table 17-1 • Customer Health-related System Configuration Settings

Name Possible Values Description

Consumption Thresholds  
(Low,High)

0-100,0-100

Default: 30,70

The low and high markers for service consumption levels. 
Consumption is considered unhealthy if below the low 
threshold and very healthy if at or above the high threshold. 

Renewal Health Thresholds 
(Low,High)

0-100,0-100

Default: 30,70

The low and high markers for a customer's renewal health. A 
low renewal health score is indicative of a risky renewal. A 
renewal health at or above the high mark translates to a high 
probability of the renewal. 

Account Health Thresholds 
(Low,High)

0-100,0-100

Default: 30,70

The low and high markers for an account's overall health. 
The account is considered unhealthy if below the low 
threshold and very healthy if at or above the high threshold. 
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• FlexNet Embedded (Local or Cloud license server)—features checked out by served devices

• Third part license technology—fulfillments generated from entitlements

This number is based on the number of consumed versus total available consumable features or licenses for that 
product to which the account is entitled. The number is then assigned a status of healthy, warning or at risk 
depending on the system configuration setting for the consumption threshold. 

In the Producer Portal, click System > Configure > FlexNet Operations > Health to set Consumption Threshold 
values.

Renewal Health Calculation
The formula for calculating the Renewal Score is based on two factors:

1. How far the products are from their expiration dates (for subscription or maintenance lines).

2. The Consumption value which is a score of consumed quantities of what an account has purchased.

For the first factor, there are three weighted renewal periods, based on how close the entitlements are to their 
expiration dates: Renewal Look Ahead, Expiring Window, and Renewal Critical. These renewal periods are labels 
for how close an entitlement is to its expiration date. 

The renewal period weights are fixed and not configurable; however, producers can configure the renewal period 
threshold values in their system configuration settings. In the Producer Portal, click System > Configure > 
FlexNet Operations > Renewals.

The complete formula for the renewal score is

(1–((Renewal Look Ahead*.25)+(Expiring Window*.50)+(Renewal Critical*.90)+Consumption Score))/2

where the value for each renewal period is either 0 or 1. 

Using the renewal period values, only one renewal period (Renewal Look Ahead, Expiring Window, and Renewal 
Critical) is factored in to the score at a time. Once a product enters a specific renewal period, that renewal period 
gets a value of 1 and all other renewal periods get a value of zero.

Table 17-2 • Weights and Thresholds for Each Renewal Period

Renewal Period Weight Default Threshold

Renewal Look Ahead .25 200 days

Expiring Window .50 90 days

Renewal Critical .90 30 days
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About the Dashboard Account List
The Customer Growth Dashboard page also lists your accounts below the charts. The account list displays the 
overall health score, the account name, and a 30-day trend for each account shown. 

The Accounts list shows up to 20 accounts. Clicking Show More adds 20 more accounts to the list for each click 
until you reach the end of the list. 

Tip • The Accounts list on the Customer Growth Dashboard page shows either all accounts or watched accounts. 
When showing all accounts, the Accounts list shows any watched accounts at the top of the list. 

Watched and Unwatched Accounts
The Producer Portal includes a Watchlist to which you can add or remove the accounts you want to follow most 
closely on the Customer Growth pages. Initially, the Watchlist is empty, but you can manage your Watchlist on the 
Accounts Health page by clicking the Watch/Unwatch icon. Then, on the Customer Growth Dashboard, you can 
switch between All Accounts and Watchlist, depending on whether you want to see metrics for all accounts or 
focus in on only the watched accounts.
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The accounts in your Watchlist and the setting of the Watchlist toggle on the Customer Growth Dashboard 
determine which accounts are included in the Customer Growth charts and related pages. The Watchlist toggle 
affects which account are included in the Customer Growth charts, scores, and account lists. This setting has an 
impact on the following Producer Portal pages: 

• Customer Growth Dashboard—Charts, scores, and accounts include just the watched accounts or all 
accounts. Also, if you have one or more watched accounts, these accounts appear at the top of the list when 
the Watchlist toggle is set to All Accounts.

• Accounts Health—Lists only watched accounts or all accounts.

• Producer Portal Home—Charts and scores include just the watched accounts or all accounts.

See Watching and Unwatching Accounts to see how to add or remove accounts from your Watchlist. 

Alerts
The Customer Growth Dashboard page also displays a list of alerts, the accounts, and type of alerts. Alerts are 
only displayed if the watched accounts are selected by clicking the Watchlist button. An alert is generated when 
either a renewal or consumption score crosses a threshold: Healthy, Warning, or At Risk—in either direction.

The alert shows:

• How long ago the alert was triggered 

• The score when the alert was triggered

• The type of change, i.e. from Warning to At Risk

Clicking on an alert notice takes you to the Alerts tab for that account and filters the results based the type of 
alert selected (i.e. Renewal Health or Consumption). 

Account Health Pages
In the Producer Portal, you can get lists of your accounts that show the scores for each account. These pages can 
be searched and filtered in various ways so that you can better track the health of your accounts. You can also 
see details about a particular account including its specific KPIs, its product consumption, and its renewal health. 

Accounts Health Page
The Accounts Health page lists your accounts, and you can filter, sort, and search that list in many different ways. 
The Accounts Health page is also the best place to watch or unwatch multiple accounts.

Section Description

Accounts Health Page Discusses the Accounts Health page and its functionality. 

Account Detail Pages Describes the account detail pages and what information is included 
on each tab.
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• You can sort the list by the account name, the account ID, or by their Consumption, Renewal Health, or 
Account Health scores. 

• You can filter the list by watched/unwatched setting, the score type, and the status condition. 

• You can search the list for a particular account by its account name or its account ID. 

• On the Accounts Health page, you can also click an account name to see the account details page for that 
account.

The Accounts Health page shows the following information for each account listed: 

See the section Visualizing Customer Health for information about filtering and searching account list or viewing 
details about a particular account.

Account Detail Pages
The account detail pages in the Producer Portal show more detailed information about the health of a particular 
account. These pages are titled, Account <AccountName>. You get to them by clicking on an account name on 
the dashboard or on the Accounts Health page. 

Tip • You can click Watch on an account’s detail page to add it to your Watchlist.

The in-depth information on the account detail page is divided into three tabs: 

• Overview—shows a summary of health scores for the current account. This tab is the default tab for the 
account details page.

Column Description

Account Name The account name.

Account ID Unique identifier of the account.

Products The number of products to which the account is entitled.

Consumption Total of all consumed products or licenses or features versus the quantity to 
which the account is entitled.

Renewal Health The Renewal Health score is a weighted calculation of days until expiration 
and the consumption value.

Account Health The Account Health score is a weighted combination of the other account 
metrics.

Watchlist Select the icon to add or remove an account from the Watchlist.

 - Unwatched

 - Watched
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• Products—shows product, feature, and license consumption for the current account.

• Renewals—shows the renewal health of each product for which the account is licensed.

Overview Tab
The Overview tab is displayed by default. It displays the Account KPIs (Key Performance Indicators)—the account 
health, renewal health, and consumption scores—related to that account. Other tabs include Products and 
Renewals.

There is also a health meter line graph showing the trends for that health metric. Hover over the points on the 
graph to see the date and its related health score for that metric. 

Products Tab
The Products tab to see the list of products for the current account. Products are listed by their consumption 
scores, and show the current consumed quantity and total available quantity along with the product name and 
description. Producers can click on the consumed quantity number of any product to see feature consumption 
details for that product in the current account. 

The list contains the following information: 

On the Products tab, you can filter the list and view feature-usage details for a particular product. See Working 
with the Products Tab on the Account Details Page for instructions.

Renewals Tab
The Renewals tab to see the renewal health of each product for which the account has licenses.

Column Description

Score The calculated health score. See Key Performance Indicator (KPI) Scores for 
details on how this score is derived.

Consumed quantity The total number of licenses or features that have been consumed. If 
feature consumption exists, the Producer Portal renders this number as a 
link.

Total quantity The sum of all possible features or licenses plus all possible quantities not 
mapped to a server.

Product name The name of the product.

Description A description of the product.
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The list contains the following information: 

On the Renewals tab, you can filter the list and view details for a particular entitlement. See Working with the 
Renewals Tab on the Account Details Page for instructions.

Renewals
Producers that issue subscription licenses or perpetual licenses with expiring maintenance typically create 
additional line items for their existing customers to extend the duration of the customer’s license. When these 
renewal line items are created, a producer specifies the relationship between the initial subscription or 
maintenance. Customers can then activate the renewal line item when their existing line item is due to expire.

The FlexNet Customer Growth module brings greater visibility to expiring entitlements and renewals. With this 
module, the End-User Portal includes a new Expiring Entitlements page on which the customer’s entitlements are 
listed by their expiration date with special emphasis on those that are expired or soon to expire. In addition, the 
FlexNet Customer Growth module helps producers automate messaging about expiring entitlements to their 
customers who subscribe to receive renewal reminders. 

Separate jobs automate messaging for expiring entitlements and expired entitlements, and producers can 
customize the content and frequency of the automated messaging. 

The following sections cover renewal concepts in greater detail.

Column Description

Score A calculated value based the number of days until the product expires and 
the consumption value. See Key Performance Indicator (KPI) Scores for 
details on how this score is derived.

Days remaining The number of days before the license expires.

Expiration The date the license expires.

Product name The name of the product.

Type The type of product. Options include

• Subscription

• Maintenance

Activation ID The activation ID of the product. Click the Activation ID to see the 
entitlement details.

Section Description

Renewal Jobs Describes the Expiring Entitlements job and the Expired Entitlements 
job, how they operate, and how they are configured.
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Renewal Jobs
The automation of renewal messaging hinges on two jobs you administer through the Producer Portal’s Configure 
Alerts/Jobs page: the Expiring Entitlements job and the Expired Entitlements job. 

Producers can schedule these jobs and subscribe to their alerts in the Producer Portal. 

Expiring Entitlements Job
The Expiring Entitlements job finds entitlements that are nearing their expiration date and generates email 
messages to end user accounts with expiring entitlements. 

When the Expiring Entitlements job finds entitlements that are soon to expire for an account, FlexNet Operations 
generates an email message about that account’s expiring entitlements and attempts to send the message to the 
account’s users. End users who elect to receive renewal notifications will get an email message when their 
account’s entitlements are nearing their expiration date. 

For producers, a number of system configuration settings determine when email messages are triggered, which 
entitlements are included in the Renewal Reminder message, whether or not an email is to be sent, and how 
frequently an account may receive such email messages. Producers can also customize the email template 
FlexNet Operations uses when it sends these renewal notifications. 

Expired Entitlements Job
This job controls how often FlexNet Operations checks for entitlements that have recently expired. When it finds 
entitlements that have expired since the last time the job was run, it generates email messages to end user 
accounts with expired entitlements. 

When the Expired Entitlements job finds entitlements that are expired for an account, FlexNet Operations 
generates an email message about that account’s expired entitlements and attempts to send the message to the 
account’s users. End users who elect to receive renewal notifications will get an email message when their 
account’s entitlements have expired. 

Renewal Reminder Email Messages Describes the renewal notifications FlexNet Operations sends for 
expiring and expired entitlements and how end users can subscribe to 
these notifications.

Expiring Entitlements Page Describes the End-User Portal’s Expiring Entitlements page and what 
features end users can employ there. 

More About the Expiring Lines 
Shown on the Expiring Entitlements 
Page

Provides a more detailed example to explain how the End-User Portal 
displays expiring entitlements on the Expiring Entitlements page. 

More About How Expiring Lines Are 
Selected for the Renewal Reminder 
Email Message

Provides an example to illustrate how FlexNet Operations selects 
entitlements to include in its renewal reminder email messages.

Section Description
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For producers, system configuration settings help determine how frequently an account may receive such email 
messages as well as which expired entitlements appear in the End-User Portal’s Expiring Entitlements page. 
Producers can also customize the email template FlexNet Operations uses when it sends these renewal 
notifications. 

Job Configuration
The operation of these jobs is configurable with both the standard job scheduling controls and with the renewal-
specific configuration settings. 

Job scheduling controls are the same as those shared by other FlexNet Operations jobs, like the User Deactivated 
job, the Product/Version Upgrade job, and the numerous data-extract jobs. These controls allow you to set the 
status of the job (active or inactive), specify the frequency with which the job runs, and limit the subscription to 
the alerts spawned by the job to specific Producer Portal user roles. 

System configuration settings for FlexNet Customer Growth behavior appear on the FlexNet Operations system 
configuration page (System > Configure > FlexNet Operations). These include settings that govern the time 
ranges the Expiring Entitlements and Expired Entitlements jobs use to determine which entitlements qualify for 
renewal reminders or expired entitlement messages. System configuration settings also specify email addresses 
to receive renewal request messages from end users and to receive notifications when there are no end users 
who have opted to receive expiring entitlements messages.

• In determining when to send an Renewal Reminder email message, FlexNet Operations uses the system 
configuration settings Renewal Look Ahead (default: 200 days), Expiring Window (default: 90 days), and 
Expiring Email Frequency (default: 30 days).

• In determining when to send an Expired Entitlements email message, FlexNet Operations uses the system 
configuration setting, Expired Email Frequency (default: 30 days).

For details about these system configuration settings, see the Renewals settings in Configuring System Settings.

Renewal Reminder Email Messages
FlexNet Customer Growth introduces three new email templates. 

• Renewal Reminder—Used to send Renewal Reminder email messages generated as a result of the Expiring 
Entitlement job.

• Renewal Reminder for Expired Entitlements—Used to send expired entitlement email messages generated 
as a result of the Expired Entitlements job.

• Renewal Intent for End Customer—Used to send intent-to-renew email messages generated when a 
customer clicks the Request button on the Expiring Entitlements page in the End-User Portal. FlexNet 
Operations sends copies of the intent-to-renew message to the end user who clicked the Request button and 
also to the producer at the address specified for the system configuration setting, Request Renewal 
Notification Email.

Tip • For both the renewal reminder messages, end users must meet the following conditions to receive 
messages:

• An end user must have the View Expiring Entitlements permission. 

• An end user’s account must have Expiring Entitlements Email marked in his or her user profile.
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Expiring Entitlements Page
The End User Portal includes an Expiring Entitlements page (Activations & Entitlements > Expiring Entitlements). 
This page shows the expiring and expired entitlements for the accounts to which the current user belongs and 
gives special emphasis to those that are soon to expire. (Expired entitlements are not shown by default. End 
users can use on-page filters in the End-User Portal to include expired entitlements in the list.) 

Tip • Lines that expire more than 200 days from the current date are not shown on the Expiring Entitlements 
page. Similarly, when expired entitlements are included, those lines that expired more than 200 days ago are not 
shown. This limit is configurable on the Producer Portal by changing the value for Renewal Look Ahead (System > 
Configure > FlexNet Operations > Renewals).

Highlight Colors on the Expiring Entitlements Page
The entitlement lines and maintenance lines closest to their expiration date are highlighted on the Expiring 
Entitlements page. 

Producers determine which lines get special emphasis by specifying values for the system configuration settings, 
Renewal Critical (default: 30 days) and Expiring Window (default: 90 days). By default, expired lines and lines 
that expire in the next 30 days are highlighted in red, those that expire between 31 and 90 days are highlighted in 
yellow, and those that expire further out than 90 days are not highlighted. 

End Users Can Send a Renew Request to Producers from the Expiring Entitlements 
Page
On the End-User Portal’s Expiring Entitlements page, end users can click a Request button to send an email 
message to the producer about their intent to renew selected entitlements. The intent-to-renew message is 
generated by the End-User Portal using the default variation of the email template, Renewal Intent for End 
Customer. The End-User Portal sends a copy of this message to the end user who clicked the Request button and 
to the producer at the address specified in the system configuration setting, Request Renewal Notification Email 
(System > Configure > FlexNet Operations > Renewals). 

Important • The intent-to-renew email message is for communication purposes only; FlexNet Operations does not 
automatically renew the selected entitlements. 

More About the Expiring Lines Shown on the Expiring Entitlements Page
FlexNet Operations determines what to show in this page according to the lines’ expiration dates, the current 
date, and the system configuration settings, Renewal Critical, Expiring Window, and Renewal Look Ahead. The 
graphic below illustrates how three entitlement lines with different expiration dates are shown on the Expiring 
Entitlements page. 

Note • The start date and expiration dates shown below are the same as those for the lines used in the exercises 
in the next section, Notifying End Users about Expiring Entitlements. See Preparing Entitlement Line Items for 
Renewal Exercises for more information on these entitlement lines.
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Figure 17-2: Entitlement lines shown on the Expiring Entitlements page include ACT-01 and ACT-02. ACT-03 
expires outside the Renewal Look Ahead range (default: 200 days). 

The Expiring Entitlements page lists all the entitlement and maintenance lines to which the end user is entitled 
and that are due to expire within the Renewal Look Ahead range (default: 200 days from the current date). This 
page also highlights lines with different background colors if their expiration dates fall within the Renewal Critical 
(default: 30 days) or the Expiring Window (default: 90 days). 

• ACT-01 expires on 7 May 2017, which occurs within the Renewal Critical range (default: 30 days). Therefore, 
it appears on the Expiring Entitlements page and is highlighted in red to indicate it is 30 days or fewer until 
its expiration date. 

• ACT-02 expires on 7 August 2017, which occurs outside the Renewal Critical range and outside of the 
Expiration Window range (default: 90 days). Therefore, it appears on the Expiring Entitlements page but is 
not highlighted. (If its expiration date fell within 30-90 days from the current date, it would have a yellow 
highlight to indicate its expiration date fell within the Expiring Window.) 

• ACT-03 expires on 7 November 2017. Because its expiration date happens outside the Renewal Look Ahead 
range (default: 200 days), it is not shown on the Expiring Entitlements page. (There are 204 days between 
17 April 2017 and 7 November 2017. If its expiration date fell within the Renewal Look Ahead range, this line 
would be included on the Expiring Entitlements page.)
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More About How Expiring Lines Are Selected for the Renewal Reminder 
Email Message

FlexNet Operations determines what to include in the renewal reminder about expiring entitlements based on the 
lines’ expiration dates, the date the Expiring Entitlements job runs, and the system configuration settings, 
Expiring Window, and Renewal Look Ahead. The graphic below illustrates how three entitlement lines with 
different expiration dates are shown on the Expiring Entitlements page. 

Note • The start date and expiration dates shown below are the same as those for the lines used in the exercises 
in the next section, Notifying End Users about Expiring Entitlements. See Preparing Entitlement Line Items for 
Renewal Exercises for more information on these entitlement lines.

Figure 17-3: When a renewal reminder is generated for expiring entitlements, that email message includes 
entitlement lines and maintenance lines that expire within the Expiring Window (default: 90 days) as well as any 
that are due to expire within the Renewal Look Ahead range (default: 200 days). 

The renewal reminder message lists all the entitlement and maintenance lines to which the end user is entitled 
and that are due to expire within the Renewal Look Ahead range (default: 200 days from the current date). Given 
the expiring entitlement lines ACT-01, ACT-02, and ACT-03, a renewal reminder generated on 17 April 2017 
would include ACT-01 and ACT-02: 

• ACT-01 expires on 7 May 2017, which occurs within the Expiring Window (default: 90 days), and causes the 
Expiring Entitlements job to begin the generation of the renewal reminder message. It is included in the 
renewal reminder email message. 
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• ACT-02 expires on 7 August 2017, which occurs outside the Expiring Window but within the Renewal Look 
Ahead range (default: 200 days). Therefore, it does not expire soon enough to cause the FlexNet Operations 
to generate a renewal reminder email message but it is included in the list of expiring entitlement lines. 

• ACT-03 expires on 7 November 2017. Because its expiration date happens outside the Renewal Look Ahead 
range, it is excluded from the renewal reminder email message. (There are 204 days between 17 April 2017 
and 7 November 2017. If its expiration date fell within the Renewal Look Ahead range, this line would be 
included in the renewal reminder.)

Additional information about the processing of the Expiring Entitlements job appears in the section More About 
the Expiring Entitlements Job. Likewise, you can find information about the Expired Entitlements job in More 
About the Expired Entitlements Job.

Next Steps
The next section, Visualizing Customer Health, provides instructions for navigating to the Customer Growth 
Dashboard and Accounts Health pages, filtering and otherwise manipulating page content, and viewing the 
account details for a particular account. 

The renewal exercises in this getting started section walk through the processes of setting up renewals and 
seeing the results of the renewal jobs in the End-User Portal and in email messaging.

• Notifying End Users about Expiring Entitlements

• Notifying End Users about Expiring Entitlements

To learn more about handling the dashboard and account health pages, continue reading the next section. To get 
started with the renewal exercises, skip ahead to Notifying End Users about Expiring Entitlements. 

Visualizing Customer Health
This section provides brief instructions for viewing the Customer Growth pages on the Producer Portal and 
managing the content there.

Section Description

Viewing the Customer Growth Dashboard Describes how to see the Customer Growth Dashboard.

Toggling Between All Accounts and the 
Watchlist

Explains how to set the Watchlist Toggle to show all accounts or 
only watched accounts.

Viewing the Accounts Health Page Describes how to see the Accounts Health page.

Filtering the Accounts Health List Explains how to filter the account list on the Accounts Health 
page.

Searching the Accounts Health List Explains how to search the account list on the Accounts Health 
page.

Watching and Unwatching Accounts Explains how to add or remove accounts from the Watchlist.
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Viewing the Customer Growth Dashboard
You can view the dashboard using the Producer Portal menus.

Task To view the Customer Growth Dashboard

• In the Producer Portal, click Accounts & Users > Dashboard. 

The Producer Portal shows the Customer Growth Dashboard for all accounts or for watched accounts, depending 
your current Watchlist Toggle setting.

For more information about the dashboard page features, see The Customer Growth Dashboard.

Toggling Between All Accounts and the Watchlist
You can use the Watchlist Toggle to configure the Producer Portal to show either all accounts or only watched 
accounts. This control affects the content of the dashboard page, the Accounts Health page, and the health 
charts on the Producer Portal home page. 

Task To show all accounts

• On the Customer Growth Dashboard, click All Accounts.

The Customer Growth components include data for all accounts. 

Task To show Watchlist accounts

• On the Customer Growth Dashboard, click Watchlist.

The Customer Growth components include data only for watched accounts.

To learn more about the Watchilst feature, see Watched and Unwatched Accounts.

Viewing Account Details Shows how to view the account details page for an account 
listed on the Accounts Health page. 

Working with the Products Tab on the 
Account Details Page

Discusses how to filter the products list and see feature-
consumption details for a particular product on the Products 
tab.

Working with the Renewals Tab on the 
Account Details Page

Discusses how to filter the entitlements list and view details for 
a particular entitlement on the Renewals tab.

Next Steps Briefly discusses how to proceed in this getting started section 
according to your own needs and interests.

Section Description
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Viewing the Accounts Health Page
You can view the Accounts Health page using the Producer Portal menus. 

Task To view Accounts Health page

• In the Producer Portal, click Accounts & Users > Accounts.

See Accounts Health Page for more information about the content of this page. 

See Filtering the Accounts Health List and Searching the Accounts Health List for instructions on how to work 
with the lists on these tabs. 

See Watching and Unwatching Accounts for instructions on how to add or remove accounts from your Watchlist.

Filtering the Accounts Health List
By default, the account list defaults to display all account types (watched and unwatched) by their account health 
score and shows accounts with any health condition (At Risk, Warning, or Healthy). To quickly reduce the number 
of accounts listed on the Accounts Health page, filter it by type, score and health condition.

Task To filter the accounts list

1. On the Accounts Health page, hover the cursor over the  filter icon to display the filter selection list. 

2. To change the default filter setting, do one of the following:

• Type: Check Watched Accounts to only view accounts on the Watchlist.

• Score: Uncheck the Account Health and check either Renewal Health or Consumption. 

Note • At least one of the scores must be selected: Account Health, Renewal Health or Consumption. 
Only one score can be checked at a time.

• Condition: Uncheck one or more of the conditions. 

Note • If all the conditions are unchecked, the Producer Portal behaves as if all conditions are checked. 
(Accounts with all health conditions are shown.)

3. Click Apply. 

The Producer Portal shows the account list with the new filter settings applied. Notice that he number in the red 
bubble indicates how many filters are active.

Searching the Accounts Health List
You can search the account list on the Accounts Health page. 
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Task To search the accounts list

1. On the Accounts Health page, choose what to search for. Use the menu to search by Account name or 
Account ID.

2. Enter your search criteria.

3. Click Search.

The Accounts Health list shows accounts that match your search criteria.

Watching and Unwatching Accounts
You can add or remove accounts from the Watchlist using the controls on the Accounts Health page. 

Task To add an account to your Watchlist

• On the Accounts Health page, click the Watch icon for that account. 

The Producer Portal adds the account to your Watchlist. 

Task To remove an account from your Watchlist

• On the Accounts Health page, click the Unwatch icon for that account. 

The Producer Portal removes the account from your Watchlist.

To learn more about the Watchlist feature, see Watched and Unwatched Accounts.

Viewing Account Details
You can view details about a particular account from the Accounts Health page. 

Task To view account details

• On the Accounts Health page, click the account name of the account for which you want to view.

See Account Detail Pages for more information about the content of this page and its Overview, Products, and 
Renewals tabs. 

See Working with the Products Tab on the Account Details Page and Working with the Renewals Tab on the 
Account Details Page for instructions on how to work with the lists on these tabs and get more information about 
the renewal conditions of entitlements or feature consumption for the current account’s products.

Tip • You can add or remove an account from the Watchlist by clicking the Watch or Unwatch button on the 
account details page.
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Tip • Click the Back to List link to go to the Accounts Health page.

Working with the Products Tab on the Account Details 
Page

On the account details page’s Products tab, you can filter and search the product list. You can also view feature 
consumption for a product listed on the Products tab and filter the results in that feature list.

See instructions for these activities in the sections below: 

• Filtering the Product List

• Searching the Products List

• Viewing Feature Consumption

• Filtering the Feature Consumption List

Filtering the Product List
Follow the steps, below, to change the filter settings for the product list. 

By default the Products tab filter values are set to display the product health score with all conditions: At risk, 
Warning, or Healthy.

Task To filter the products list 

1. On the Products tab, hover the cursor over the  filter icon to display the filter selection list. 

2. To change the default filter setting, uncheck one or more of the conditions. 

3. Click Apply. 

Notice that the number in the red bubble indicates how many filters are active. If all the condition boxes are 
cleared, the Producer Portal warns that at least one condition must be checked.

You can also sort the products list by score (default), consumed quantity, or total quantity.

Searching the Products List
You can search the list of products on the Products tab of account details pages. 

Task To search the products list

1. On the account details page, choose what to search for. Use the menu to search by Product Name or 
Description.

2. Enter your search criteria.

3. Click Search.
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The shows products that match your search criteria.

Viewing Feature Consumption
Follow the steps, below, to see feature consumption details for a product. 

Task To view Feature Consumption

• Click the Consumed quantity value for a product in the product list to see its Feature Consumption details.

The Feature Consumption window displays the consumption of features attached to the current product, if there 
are any. Any feature with an embedded license model, and mapped to a license server, is included in the 
consumption numbers.

Filtering the Feature Consumption List
Follow the steps, below, to filter settings for the feature list. By default the Feature Consumption window filter is 
set to display the feature health score for products with all condition values: At risk, Warning, and Healthy.

Task To filter the feature list 

1. In the Feature Consumption window, hover the cursor over the  filter icon to display the filter selection 
list. 

2. Check the checkboxes for the status, types, and conditions you want to show.

3. Click Apply. 

Notice that, for the filter, the number in the red bubble indicates how many filters are active. If all the condition 
boxes are unchecked, the Producer Portal warns that at least one condition must be checked.

You can also search a filtered feature list. Use the menu to target your search to for a feature by Name or 
Description.

Working with the Renewals Tab on the Account Details 
Page

You can filter and search the entitlements list on the Renewals tab. You can also view details about the 
entitlements listed on this tab.

See instructions for these activities in the sections below: 

• Filtering the Renewal Health List

• Searching the Renewal Health List

• Viewing Entitlement Details
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Filtering the Renewal Health List
Follow the instructions below to filter the renewals list. By default the filter for this page includes all types, status 
values, and conditions except Expired. Therefore, the renewals list includes products in all conditions, At risk, 
Warning, and Healthy; with types, Subscription and Maintenance; and with a status of Expiring.

Task To filter the renewals list 

1. On the Renewals tab, hover the cursor over the  filter icon to display the filter selection list.

2. Check the checkboxes for the status values, types, and conditions you want to show.

3. Click Apply. 

Notice that, for the filter, the number in the red bubble indicates how many filters are active. If all the status 
boxes are unchecked, the Producer Portal warns that at least one status must be checked. If all the types are 
unchecked, the filter behaves as if all types are checked.

You can also sort the entitlements list by score (default), days remaining, expiration date, or product name.

Searching the Renewal Health List
You can search the list of entitlements on the Renewals tab of account details pages. 

Task To search the entitlements list

1. On the account details page, choose what to search for. Use the menu to search by Product name or 
Activation ID.

2. Enter your search criteria.

3. Click Search.

The shows entitlements that match your search criteria.

Viewing Entitlement Details
Follow the instructions below to view entitlement details for an entitlement on the Renewals tab.

Task To view Entitlement details

• Click on the Activation ID to open the Entitlement Details window.

The Entitlement Details window displays the information for a particular entitlement including ID information 
(Entitlement ID, state, sold-to, description and activation ID), the name and description of the products with 
which the entitlement is associated, and the activation information.
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Next Steps
The next two sections provide exercises for working with expiring entitlements and expired entitlements—from 
setting up the necessary entitlements and configuring FlexNet Operations to viewing entitlements in the End-
User Portal and receiving notifications. 

For expiring entitlements notifications, see Notifying End Users about Expiring Entitlements. 

For expired entitlements notifications, see Notifying End Users about Expiring Entitlements. 

Notifying End Users about Expiring Entitlements
This section walks through the process of configuring FlexNet Operations to send renewal reminders to end users 
who have expiring entitlements. In these exercises, you use the account, user, product, and entitlement created 
in the early exercises of the section Getting Started with Entitlement Management, and add expiring and renewal 
line items to see how the job operates.

Remember to check the prerequisites in the Introduction before starting these exercises. See Exercise 
Prerequisites. 

Preparing Entitlement Line Items for Renewal Exercises
As you start the exercises in this section, take a moment to review the product, entitlement, and other entities 
you created in the section Getting Started with Entitlement Management. Then, for the exercises in this section, 
create three line items on ENT-PhototPrint. 

Topic Description

Preparing Entitlement Line Items 
for Renewal Exercises

Creates three line items on ENT-PhototPrint to illustrate how the FlexNet 
Customer Growth module enhances the handling of and communication 
about expiring entitlements.

Activating the Renewal Email 
Templates

For notifications about expiring entitlements, producers must have the 
following email templates in active status: Renewal Reminder and 
Renewal Intent for End Customer. This exercise walks you through that 
process.

Setting Up the Job This exercise activates and schedules the Expiring Entitlements job. 

Viewing the Expiring Entitlements 
Page and Receiving Renewal 
Notifications

To understand what is sent to the end user, this exercise uses an end-
user account to see the entitlements approaching their expiration dates 
on the Expiring Entitlements page, see the emailed renewal notification 
for those entitlements, and send a request to renew selected 
entitlements to the producer. 

Next Steps Discusses the possibilities of moving on to the exercises for notifying 
users about expired entitlements or reading more about viewing sent 
emails in the Producer Portal, customizing email templates, and 
configuring jobs schedules and subscriptions.
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Starting Account, User, Product, Product Line, and Entitlement
Remember that these exercises start with the expectation that you have already completed the exercises in the 
section Getting Started with Entitlement Management, and have continuing access to the system on which those 
entities were defined. In those exercises, you create the following entities: 

If these entities, such as the entitlement, ENT-PhotoPrint, do not yet exist in your FlexNet Operations instance, be 
sure you have loaded the demo data; then follow the exercises in the section Getting Started with 
Entitlement Management to create the necessary entities. 

Tip • Take a moment to verify that the user profile for Lisa Barry has the checkbox for Expiring Entitlements Email 
checked. To verify this in the End-User Portal, log in and click the user name, Lisa Barry, at the top right of the 
page, and then click Profile. (If the user profile page does not show the Expiring Entitlements Email checkbox, 
then Lisa Barry may still need to be granted the View Expiring Entitlements permission.)

Important • If the customer user, Lisa Barry, already exists but is not associated with an email address you 
control, you must create another customer user in the Barry Photography Studio account with the Portal User 
role. Use an email address you control for this new user so that you will be able to use that user account to log in 
to the End-User Portal and see the downloads. 

Create the New Line Items
To illustrate FlexNet Customer Growth module feature, you must create three line items: one that is nearly 
expired, one that expires within the Renewal Look Ahead window, and one that expires on a date that falls 
outside the Renewal Look Ahead time frame. (See Renewal Jobs for more information about the system 
configuration settings and how they affect the Expiring Entitlements job.) 

Entity Type Entities

Customer Account Barry Photography Studio

Customer User Lisa Barry

Product PhotoPrint

This product includes the following features: 

• Print

• PrintHighQualityColor

• PrintToPDF

As indicated in the section Getting Started with 
Entitlement Management, the features, above, are among those pre-
defined in your environment’s demo data.

Product Line LargeFormat

Entitlement ENT-PhotoPrint
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Task To create the new line items

1. In the Producer Portal, find ENT-PhotoPrint.

a. Click Entitlements > List Entitlements by Order. 

b. On the List Entitlements by Order page, search for ENT-PhotoPrint.

2. On the Entitle Customers to Licenses page for ENT-PhotoPrint, create three new line items: 

• ACT-PhotoPrint-01

• ACT-PhotoPrint-02

• ACT-PhotoPrint-03

Use the following settings for these line items: 

ACT-PhotoPrint-01

ACT-PhotoPrint-02

Attribute Value

Product PhotoPrint

License Model Nodelocked Uncounted

Qty 1

Start Date Expiration date minus three months

Expiration Date Current date plus twenty days

Activation ID ACT-PhotoPrint-01

Attribute Value

Product PhotoPrint

License Model Nodelocked Uncounted

Qty 1

Start Date Current date plus twenty days

Expiration Date Start date plus three months

Activation ID ACT-PhotoPrint-02
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ACT-PhotoPrint-03

For example, if the current date is 17 April 2017, you have the following line items in ENT-PhotoPrint: 

• ACT-PhotoPrint-01—starts on 7 February 2017; ends on 7 May 2017. 

• ACT-PhotoPrint-02—starts on 7 May 2017; ends on 7 August 2017. 

• ACT-PhotoPrint-03—starts on 7 August 2017; ends on 7 November 2017. 

3. Click Save & Deploy to update ENT-PhotoPrint with the new line items.

With these entitlement lines in place, we can activate the renewal-related email templates and setup the Expiring 
Entitlements job to see how the FlexNet Customer Growth module operates to highlight expiring entitlements and 
automate the communication about renewal opportunities to your end users. 

Activating the Renewal Email Templates
In this exercise, you activate the Renewal Reminder and Renewal Intent for End Customer email templates. 

• The Renewal Reminder template is used by FlexNet Operations to send email messages to end users about 
their expiring entitlements. (A separate email template is used for expired entitlements as identified by the 
Expired Entitlements job.) The default version of this template lists all the account’s entitlements that are 
due to expire within the Renewal Look Ahead window. 

• The Renewal Intent for End Customers template is used by FlexNet Operations to send intent-to-renew email 
messages when an end user selects an expiring entitlement and clicks the Request button on the End-User 
Portal’s Expiring Entitlements page. 

If these templates are not already in an active status, follow the instructions below to activate them. 

Task To activate the Renewal Reminder email template

1. In the Producer Portal, click Administer > Templates. 

2. On the Templates page, find the Renewal Reminder template and click its Template ID. 

3. On the View Email Template page, click Edit > Edit Active Content.

Attribute Value

Product PhotoPrint

License Model Nodelocked Uncounted

Qty 1

Start Date Current date plus three months and twenty days

Expiration Date Start date plus three months 

Activation ID ACT-PhotoPrint-03
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4. Click Validate Template.

5. Click Save Active.

This activates the Renewal Reminder template. Repeat these steps for the Renewal Intent for End Customer 
template. 

When both email templates are active, you are ready to setup the Expiring Entitlements job. 

Setting Up the Job
The Expiring Entitlements job drives the notification process for the renewal reminders about expiring 
entitlements. In this exercise, you activate and schedule the Expiring Entitlements job. 

Task To set up the Expiring Entitlements job

1. In the Producer Portal, click Administer > Configure Alerts/Jobs. This link opens the Configure Alerts/Jobs 
page. 

2. On the Configure Alerts/Jobs page, click the Configure button for the Expiring Entitlements job. This button 
opens the Configure Alert/Job Schedule for the Expiring Entitlements job. 

3. Set Status to Active and keep the default schedule (30 days).

4. Click Save. 

The Producer Portal saves your job configurations and returns to the Configure Alerts/Jobs page. 

The Expiring Entitlements job is now active and set to run once every 30 days. 

Using the default job schedule and the default system configuration settings for renewal settings, FlexNet 
Operations checks for expiring entitlements once every 30 days and sends renewal reminders to subscribed 
users in accounts with one or more entitlements that expire in the next 90 days (Expiring Window). And, when 
assembling the renewal reminder email, FlexNet Operations includes a list of all entitlements for that account 
that are due to expire within the next 200 days (Renewal Look Ahead). 

With the renewal email templates active, the Expiring Entitlements job can send renewal reminders to end users 
and to send intent-to-renew email messages from the End-User Portal’s Expiring Entitlements page. 

Viewing the Expiring Entitlements Page and Receiving 
Renewal Notifications

With the Expiring Entitlements job activated, you can log in to the End-User Portal as Lisa Barry and review the 
contents of the Expiring Entitlements page. In addition, FlexNet Operations has sent Lisa Barry a renewal 
reminder about those entitlements due to expire in the next 200 days. After logging in to the End-User Portal as 
Lisa Barry, you can also send a renewal request message from her right from the Expiring Entitlements page.

• Viewing the Expiring Entitlements Page

• Viewing the Renewal Notification

• Sending a Renewal Request from the End-User Portal
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Tip • Remember that Lisa Barry is the end user account for these exercises. If you are using a different end user 
for these exercises, log in as that user. 

Viewing the Expiring Entitlements Page
The End-User Portal’s Expiring Entitlements page shows two of the three line items you created at the start of 
these exercises. 

In order to see the Expiring Entitlements page, the end user account must have the View Expiring Entitlements 
permission. Otherwise, there is no link to the Expiring Entitlements page in the End-User Portal. 

Task To view the Expiring Entitlements page

1. Log in to the End-User Portal using the credentials for Lisa Barry. 

2. In the End-User Portal, click Activation & Entitlements > Expiring Entitlements. 

Notice that the Expiring Entitlements page shows the line items ACT-PhotoPrint-01 and ACT-PhotoPrint-02. 
ACT-PhotoPrint-03 does not appear because its expiration date is outside the Renewal Look Ahead window—
greater than 200 days in this case.

Figure 17-4: The Expiring Entitlements page shows the line items that meet requirements expressed in the 
Renewal settings in the FlexNet Operations system configurations. 

Viewing the Renewal Notification
When the Expiring Entitlements job runs, it finds ACT-PhotoPrint-01 within the Expiring Window. It then looks for 
any line items in Barry Photography Studio that are expiring within the Renewal Look Ahead window (200 days 
from the current date) and finds ACT-PhotoPrint-02. It includes both line items in the renewal reminder message 
and sends it to the end user, Lisa Barry, because she has opted in to receive expiring entitlements email 
messages. 

Task To view the renewal notification email message

Log in to the email account you set up for Lisa Barry, and open the Renewal Reminder message.
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Figure 17-5: A sample renewal reminder email message showing the two line items that are included by the 
Expiring Entitlement job (ACT-PhotoPrint-01 and ACT-PhotoPrint-02). ACT-PhotoPrint-03 is not included because 
its expiration date is further away than 200 days. 

In order to receive renewal reminder email messages, the end user must have the Expiring Entitlements Email 
checkbox checked on his or her user profile. And to see that checkbox, the end user must have the View Expiring 
Entitlements permission.

Tip • Another way to verify that FlexNet Operations has sent an renewal reminder is to check the Sent Messages 
page in the Producer Portal. To do so, click Administer > Sent Emails. 

Sending a Renewal Request from the End-User Portal
When you have a valid email address specified in the Producer Portal system configuration setting, Request 
Renewal Notification Email, the Expiring Entitlements page in the End-User Portal includes a Request button. End 
users can click the Request button to send an email message to that address when they see entitlements on the 
Expiring Entitlements page they want to renew. 

Task To set a Request Renewal Notification Email address

1. In the Producer Portal, open the system configuration page for FlexNet Operations and show the Renewals 
group. 

a. Click System > Configure > FlexNet Operations. 

b. Expand the Renewals settings on the FlexNet Operations system configuration page. 

2. In the Renewals settings find Request Renewal Notification Email and enter an email address for an email 
account at which you can receive messages.

3. Click Save Configs.
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If you log in, again, to the End-User Portal as Lisa Barry and refresh the End-User Portal’s Expiring Entitlements 
page, the Request button appears above the list of entitlements. 

Task To send a renewal request from the Expiring Entitlements page

1. In the End-User Portal, click Activation & Entitlements > Expired Entitlements. This link opens or re-opens 
the Expiring Entitlements page that now shows the Request button. 

2. Click the checkbox to select ACT-PhotoPrint-01. 

3. Click Request.

The End-User Portal sends an email message to the address you specified for Request Renewal Notification Email 
using the Renewal Request for End Customer email template. 

For end users, it reports the result of this process in a message on the Expiring Entitlements page. For producers, 
a message is sent to the Request Renewal Notification Email address. (Check your email account to see the 
resulting email message or check the Sent Messages page in the Producer Portal.) 

Next Steps
While the Expiring Entitlements job sends email messages about line items and maintenance lines that are 
approaching their expiration date, the Expired Entitlements job sends email messages about line items and 
maintenance lines that have already expired. To walk through the process of setting up the Expired Entitlements 
job to send messages about those entitlements, see Notifying End Users about Expiring Entitlements.

Consider also reading Managing Email Templates to learn about how to customize email templates. For instance, 
you may want to apply your account’s branding to the Renewal Reminder email template or alter the message 
content in the Renewal Intent for End Customer email template. 

Producer administrators may also be interested in customizing the job schedule for FlexNet Operations 
background jobs and subscribing to the alerts that are generated when such jobs run. For more information, see 
Administering Alerts .

Notifying End Users About Expired Entitlements
This section walks through the process of configuring FlexNet Operations to send renewal reminders to end users 
who have expired entitlements. In these exercises, you use the account, user, product, and entitlement created in 
the early exercises of the section Getting Started with Entitlement Management, and add expired line items to 
see how the job operates.
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Remember to check the prerequisites in the Introduction before starting these exercises. See Exercise 
Prerequisites. 

Preparing Entitlement Line Items for Renewal Exercises
If you have not already done so in the previous section, take a moment to review the product, entitlement, and 
other entities you created in the section Getting Started with Entitlement Management. Then, create three line 
items used in these exercises on the entitlement, ENT-PhototPrint. 

Starting Account, User, Product, Product Line, and Entitlement
Remember that these exercises start with the expectation that you have already completed the exercises in the 
section Getting Started with Entitlement Management, and have continuing access to the system on which those 
entities were defined. In those exercises, you create the following entities: 

Topic Description

Preparing Entitlement Line Items 
for Renewal Exercises

Creates three line items on ENT-PhototPrint, including one that has 
recently expired. These line items are essential to illustrate how the 
FlexNet Customer Growth module enhances the handling of and 
communication about expired entitlements.

Activating the Renewal Email 
Templates

For notifications about expired entitlements, producers must have the 
following email templates in active status: Renewal Reminder for Expired 
Entitlements and Renewal Intent for End Customer. This exercise walks 
you through that process.

Setting Up the Job This exercise activates and schedules the Expired Entitlements job. 

Viewing the Expiring Entitlements 
Page and Receiving Renewal 
Notifications

To understand what is sent to the end user, this exercise uses an end-
user account to see entitlements that have passed their expiration dates 
on the Expiring Entitlements page, see the emailed renewal reminder 
about those entitlements, and send a request to renew selected 
entitlements to the producer. 

Next Steps Discusses additional concepts related to sending expired entitlement 
messages—such as viewing sent emails in the Producer Portal, 
customizing email templates, and configuring jobs schedules and 
subscriptions—and where to find more information about them.

Entity Type Entities

Customer Account Barry Photography Studio

Customer User Lisa Barry
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If these entities, such as the entitlement, ENT-PhotoPrint, do not yet exist in your FlexNet Operations instance, be 
sure you have loaded the demo data; then follow the exercises in the section Getting Started with 
Entitlement Management to create the necessary entities. 

Tip • Take a moment to verify that the user profile for Lisa Barry has the checkbox for Expiring Entitlements Email 
checked. To verify this in the End-User Portal, log in and click the user name, Lisa Barry, at the top right of the 
page, and then click Profile. (If the user profile page does not show the Expiring Entitlements Email checkbox, 
then Lisa Barry may still need to be granted the View Expiring Entitlements permission.)

Important • If the customer user, Lisa Barry, already exists but is not associated with an email address you 
control, you must create another customer user in the Barry Photography Studio account with the Portal User 
role. Use an email address you control for this new user so that you will be able to use that user account to log in 
to the End-User Portal and see the downloads. 

Create the New Line Items
To illustrate FlexNet Customer Growth module feature, you must create a line item that is just past its expiration 
date plus a second line item that expired sometime within the Expiring Window. A third line item expires well 
outside the default Expiring Window and, as a result, is not included in the renewal reminder. (See Renewal Jobs 
for more information about the system configuration settings and how they affect the Expired Entitlements job.) 

Task To create the new line items

1. In the Producer Portal, find ENT-PhotoPrint.

a. Click Entitlements > List Entitlements by Order. 

b. On the List Entitlements by Order page, search for ENT-PhotoPrint.

2. On the Entitle Customers to Licenses page for ENT-PhotoPrint, create three new line items: 

Product PhotoPrint

This product includes the following features: 

• Print

• PrintHighQualityColor

• PrintToPDF

As indicated in the section Getting Started with 
Entitlement Management, the features, above, are among those pre-
defined in your environment’s demo data.

Product Line LargeFormat

Entitlement ENT-PhotoPrint

Entity Type Entities
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• ACT-PhotoPrint-11

• ACT-PhotoPrint-12

• ACT-PhotoPrint-13

Use the following settings for these line items: 

ACT-PhotoPrint-11

ACT-PhotoPrint-12

ACT-PhotoPrint-13

Attribute Value

Product PhotoPrint

License Model Nodelocked Uncounted

Qty 1

Start Date Current date minus three months

Expiration Date Yesterday’s date

Activation ID ACT-PhotoPrint-11

Attribute Value

Product PhotoPrint

License Model Nodelocked Uncounted

Qty 1

Start Date Current date minus six months

Expiration Date Current date minus three months

Activation ID ACT-PhotoPrint-12

Attribute Value

Product PhotoPrint

License Model Nodelocked Uncounted

Qty 1

Start Date Current date minus nine months
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For example, if the current date is 20 April 2017, you have the following line items in ENT-PhotoPrint: 

• ACT-PhotoPrint-11—started on 20 January 2017; ended on 19 April 2017. 

• ACT-PhotoPrint-12—started on 20 October 2016; ended on 20 January 2017. 

• ACT-PhotoPrint-13—started on 20 July 2016; ended on 20 October 2016. 

3. Click Save & Deploy to update ENT-PhotoPrint with the new line items.

With these entitlement lines in place, we can activate the renewal-related email templates and setup the Expired 
Entitlements job to see how the FlexNet Customer Growth module operates to highlight expired entitlements and 
automate the communication about renewal opportunities to your end users. 

Activating the Renewal Email Templates
In this exercise, you activate the Renewal Reminder for Expired Entitlements email template and Renewal Intent 
for End Customer email template. 

• The Renewal Reminder for Expired Entitlements template is used by FlexNet Operations to send email 
messages to end users about their expired entitlements. (This is a separate email template from the one 
used for expiring entitlements identified by the Expiring Entitlements job.) The default version of this 
template lists all the account’s entitlements that have expired within the days specified for the system 
configuration setting, Expiring Window. 

• The Renewal Intent for End Customer template is used by FlexNet Operations to send intent-to-renew email 
messages when an end user selects an entitlement and clicks the Request button on the End-User Portal’s 
Expiring Entitlements page. 

If these templates are not already in an active status, follow the instructions below to activate them. 

Task To activate the Renewal Reminder for Expired Entitlements email template

1. In the Producer Portal, click Administer > Templates. 

2. On the Templates page, find the Renewal Reminder for Expired Entitlements template and click its Template 
ID. 

3. On the View Email Template page, click Edit > Edit Active Content.

4. Click Validate Template.

5. Click Save Active.

This activates the template. Repeat these steps for the Renewal Intent for End Customer template, if necessary. 

When both email templates are active, you are ready to setup the Expired Entitlements job. 

Expiration Date Current date minus six months 

Activation ID ACT-PhotoPrint-13

Attribute Value
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Setting Up the Job
The Expired Entitlements job drives the notification process for renewal reminders for expired entitlements. In 
this exercise, you activate and schedule the Expired Entitlements job. 

Task To set up the Expired Entitlements job

1. In the Producer Portal, click Administer > Configure Alerts/Jobs. This link opens the Configure Alerts/Jobs 
page. 

2. On the Configure Alerts/Jobs page, click the Configure button for the Expired Entitlements job. This button 
opens the Configure Alert/Job Schedule for the Expired Entitlements job. 

3. Set Status to Active and keep the default schedule (30 days).

4. Click Save. 

The Producer Portal saves your job configurations and returns to the Configure Alerts/Jobs page. 

The Expired Entitlements job is now active and set to run once every 30 days. 

Using the default job schedule and the default system configuration settings for renewal settings, FlexNet 
Operations checks for expired entitlements once every 30 days and sends renewal reminders to subscribed users 
in accounts with one or more entitlements that have expired since the last time an email message was sent for 
expired entitlements. And, when assembling the expired entitlements email, FlexNet Operations includes a list of 
all entitlements for that account that have expired.

With the renewal email templates active, the Expired Entitlements job can send renewal reminders to end users 
and end users can send intent-to-renew email messages from the End-User Portal’s Expiring Entitlements page. 

Viewing the Expiring Entitlements Page and Receiving 
Renewal Notifications

With the Expired Entitlements job activated, you can log in to the End-User Portal as Lisa Barry and review the 
contents of the Expiring Entitlements page. In addition, FlexNet Operations has sent Lisa Barry a renewal 
reminder about those entitlements that expired in the last 90 days. After logging in to the End-User Portal as Lisa 
Barry, you can also send a renewal request message from her right from the Expiring Entitlements page.

• Viewing the Expiring Entitlements Page

• Viewing the Renewal Notification

• Sending a Renewal Request from the End-User Portal

Tip • Remember that Lisa Barry is the end user account for these exercises. If you are using a different end user 
for these exercises, log in as that user. 

Viewing the Expiring Entitlements Page
The End-User Portal’s Expiring Entitlements page shows two of the three line items you created at the start of this 
section’s exercises. 
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In order to see the Expiring Entitlements page, the end user account must have the View Expiring Entitlements 
permission. Otherwise, there is no link to the Expiring Entitlements page in the End-User Portal. 

Task To view the Expiring Entitlements page

1. Log in to the End-User Portal using the credentials for Lisa Barry. 

2. In the End-User Portal, click Activation & Entitlements > Expiring Entitlements. 

Notice that the Expiring Entitlements page shows the expired line items ACT-PhotoPrint-11, ACT-PhotoPrint-12, 
and ACT-PhotoPrint-13. (Line items that expired more than 200 days ago do not appear because that span 
exceeds the default Renewal Look Ahead setting of 200 days.)

Tip • The default filter settings on the Expiring Entitlements page prevents the page from showing expired 
entitlements. If you do not see expired entitlements on the page, use the on-page filter controls to include 
expired entitlements. (Mark the Expired checkbox in the filter to include expired entitlements.) 

Viewing the Renewal Notification
When the Expired Entitlements job runs, it finds ACT-PhotoPrint-11, ACT-PhotoPrint-12, and ACT-PhotoPrint-13 
have expired. It includes all three line items in the renewal reminder message and sends it to the end user, Lisa 
Barry, because she has opted in to receive expired entitlements email messages. 

Task To view the renewal notification email message

• Log in to the email account you set up for Lisa Barry, and open the Renewal Reminder message.

In order to receive renewal reminder email messages, the end user must have the Expiring Entitlements Email 
checkbox checked on his or her user profile. And to see that checkbox, the end user must have the View Expiring 
Entitlements permission.

Tip • Another way to verify that FlexNet Operations has sent an renewal reminder is to check the Sent Messages 
page in the Producer Portal. To do so, click Administer > Sent Emails. 

Sending a Renewal Request from the End-User Portal
When you have a valid email address specified in the Producer Portal system configuration setting, Request 
Renewal Notification Email, the Expiring Entitlements page in the End-User Portal includes a Request button. End 
users can click the Request button to send an email message to that address when they see entitlements on the 
Expiring Entitlements page they want to renew. (If you have already completed the exercises in the previous 
section, then the Request Renewal Notification Email address is likely already set.) 
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Task To set a Request Renewal Notification Email address

1. In the Producer Portal, open the system configuration page for FlexNet Operations and show the Renewals 
group. 

a. Click System > Configure > FlexNet Operations. 

b. Expand the Renewals settings on the FlexNet Operations system configuration page. 

2. In the Renewals settings find Request Renewal Notification Email and enter an email address for an email 
account at which you can receive messages.

3. Click Save Configs.

If you log in, again, to the End-User Portal as Lisa Barry and refresh the End-User Portal’s Expiring Entitlements 
page, the Request button appears above the list of entitlements. 

Task To send a renewal request from the Expiring Entitlements page

1. In the End-User Portal, click Activation & Entitlements > Expired Entitlements. This link opens or re-opens 
the Expiring Entitlements page that now shows the Request button. 

2. Click the checkbox to select ACT-PhotoPrint-11. 

3. Click Request.

The End-User Portal sends an email message to the address you specified for Request Renewal Notification Email 
using the Renewal Request for End Customer email template. 

For end users, it reports the result of this process in a message on the Expiring Entitlements page. For producers, 
a message is sent to the Request Renewal Notification Email address. (Check your email account to see the 
resulting email message or check the Sent Messages page in the Producer Portal.) 

Next Steps
Assuming you have already completed the exercises for sending messages about expiring entitlements, the 
exercises in this section for sending messages about expired entitlements complete the available activities in this 
getting started section. 

Consider reading Managing Email Templates to learn about how to customize email templates. For instance, you 
may want to apply your account’s branding to the Renewal Reminder for Expired Entitlements email template or 
alter the message content in the Renewal Intent for End Customer email template. 

Producer administrators may also be interested in customizing the job schedule for FlexNet Operations 
background jobs and subscribing to the alerts that are generated when such jobs run. For more information, see 
Administering Alerts.
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Getting Started with Advanced 
Organization Management

This section Getting Started with Advanced Organization Management presents fundamental FlexNet Operations 
concepts and uses exercises to lead a Producer Portal user through basic account, user and partner creation and 
management. The intended audience for this getting started section is the first-time Producer Portal user, or one 
without FlexNet Operations training or experience. 

Introduction
This section includes a list of prerequisites, an introduction to the FlexNet Operations license lifecycle, and a 
description of how to perform searches in the FlexNet Operations Producer Portal user interface.

Topic Description

Introduction List of prerequisites, introduction to FlexNet Operations license lifecycle, and 
description of how to perform searches in the FlexNet Operations Producer 
Portal user interface.

Managing Accounts FlexNet Operations account and account management concepts and exercises 
that demonstrate how to browse, create, edit, and delete accounts. Brief 
descriptions of advanced account management topics with references for more 
information. 

Managing Users FlexNet Operations user and user management concepts and exercises that 
demonstrate how to browse, create, edit, deactivate/reactivate, and delete 
users. Brief descriptions of advanced user management topics with references 
for more information. 

Managing Channel Partners FlexNet Operations partner tier management concepts and exercises that 
demonstrate how to create tiers and channel partners. Brief descriptions of 
advanced partner management topics with references for more information.
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Prerequisites
Before you begin the exercises in this getting started section: 

• FlexNet Operations must be properly installed and configured 

• The FlexNet Operations demonstration database and seed data must be loaded 

• You must have a FlexNet Operations Producer Portal login and System Administrator role 

The License Lifecycle: Advanced Organization 
Management

The FlexNet Operations license lifecycle is a repeating process of producer and customer activities, as depicted in 
the figure and described below. 

Figure 18-1: Software License Lifecycle Stages 

• Create Products – Create product definitions that are used to generate licenses. 

• Order/Entitle – Define an account’s rights to obtain licenses for your products. 

• Deliver⁄Install – Deliver the application software to the customer and install that software. 

• Activate – Deliver licenses to the customer. 

• Return/Rehost – Manage license transfers from one user or system to another. 
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• Maintain/Update – Deliver software and license updates to the customer. 

• Upsell/Renew – Renew customer licenses, or sell the customer additional product functionality. 

Performing Searches in the FlexNet Operations Producer 
Portal User Interface

Performing Searches
The Producer Portal includes powerful search functionality on most pages. You can use the search functionality 
to filter lists of entitlements, fulfillments, devices, machines, accounts, and so forth by a wide variety of criteria. 
Refer to the following subsections for instructions:

• Performing Simple Searches

• Performing Advanced Searches

Tip • The search results from most pages can be exported as comma-separated value (CSV) files. You can export 
all the entities in the search results or only selected entities. For more information about exporting to CSV, see 
Importing and Exporting Entities.

Performing Simple Searches
You can perform simple searches on any page that has search controls. The search controls appear near the top 
of the page. 

Figure 18-2: The search controls for the Manage Entitlements page

Table 18-1 • Simple Search Controls

Control Description

Search For A drop-down menu that contains short list of the most common elements to search 
for on the current page. For example, on the Support Licenses page, the Search For 
menu includes Activation ID, Product, Part Number, Sold To Account Name, Sold To 
Account ID, Host ID, Fulfillment ID, and Trusted Client Platform Type. 

If the element you want to search on does not appear in the Search For menu, it may 
be available as part of an advanced search.
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Task To perform a simple search

1. In the Search For menu, choose an element to search. The elements available depend on the Producer Portal 
page you are currently using. 

2. In the Search Operator menu, choose a search operator. Default: Contains.

3. In the Search Value field, type the characters you want to search for. 

4. Click Search. 

The Producer Portal searches the entities that correspond to the current page for instances where the search 
value occurs in the search element according to the method specified by the search operator. It then reloads the 
current page showing only those entities that matched the search criteria. 

Search Operator A drop-down menu that contains a short list of possible search operators. These 
operators specify how the Producer Portal conducts the search. Operators include 
Contains (default), Equals, Starts With, and Ends With. 

• Contains matches any entity for which the search value appears in the Search 
For element. The search value can occur anywhere in the element that is 
searched. 

• Equals matches only entities for which the search value exactly matches the 
entirety of the Search For element. Partial matches are not included. 

• Starts With matches any entity for which the search value occurs at the start of 
the Search For element. 

• Ends With matches any entity for which the search value occurs at the end of 
the Search For element.

Search Value A text field where you can enter the value you want to find in the Search For 
element. (Wild card characters are not necessary nor permitted. Spaces can be 
used.) 

Search Button The first button in the search controls, the Search button has a magnifying glass 
icon. Click the Search button to search the entities on the current page for elements 
that match the contents of the Search Value field. 

Clear Search Button The Clear Search button is the second button in the search controls. It has an icon 
that shows an pencil eraser being used on a document. The Clear Search button 
immediately clears the search criteria—both for simple searches and advanced 
searches. When you click Clear Search, the current page reloads with no search 
criteria applied. 

Advanced Search 
Button

The Advanced Search button is the third button in the search controls. It has an icon 
that shows a magnifying glass with a plus sign on it. When you click the Advanced 
Search button, the portal opens the Advanced Search page in a new window. 

Table 18-1 • Simple Search Controls

Control Description



Chapter 18 Getting Started with Advanced Organization Management
Introduction

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 597

Task To clear a search

• Click the Clear Search button. 

The Producer Portal clears the search criteria and reloads the current page showing all entities (no search criteria 
applied) for that page. 

Performing Advanced Searches
While the simple search controls provide quick access to the most commonly searched elements on a given 
Producer Portal page, the advanced search controls offer a wider selection of elements to search on and the 
ability to search multiple elements for multiple values. When you click the Advanced Search button, the Producer 
Portal opens the Advanced Search page in a new window. 

The Advanced Search page lists every element that can be searched for in the context of the main entity of the 
page on which you clicked the Advanced Search button. An advanced search from the Manage Accounts page 
allows you to search on Name, Display Name, Description, City, State/Province, Zip, Country, and Region. All 
elements meaningful to searches of accounts. An advanced search from the Support Licenses page, in contrast, 
shows a wide array of elements—from common elements like Entitlement ID and Activation ID, to date elements 
like Start Date and Expiration date, to detailed elements like individual Custom Attributes and Custom Host 
Attributes. You can search for multiple elements using various search operators. Search results reflect all the 
entities that match all the search criteria. 

Task To perform an advanced search

1. Click Advanced Search. This button opens the Advanced Search page in a new window. 
Searchable elements depend on the context of the page on which you initiated the advanced search. An 
advanced search from the Package Products page shows different searchable elements than an advanced 
search from the Entitle Customers page.

2. For the elements you want to search, set the search operator and type a search value. 
Operators vary by the element type. For textual elements, the typical search operators are the same as the 
simple search operators: Contains, Equals, Starts With, and Ends With. For date elements, the common 
search operators are Before, After, and On.

Tip • You can also search on producer-defined custom attributes. To use multiple attributes, select an 
attribute, a search operator and search value, then click Add Custom Attribute. Continue adding attributes as 
needed. Click the X after a custom attribute or custom host attribute to remove only that attribute from the 
search criteria. 

3. Click Search. 

The Producer Portal closes the Advanced Search page and reloads the current Producer Portal page to show only 
entities that match all the search criteria in the advanced search. When looking at the search results, you can 
clear the search criteria in the same way you clear a simple search: Click the Clear Search button. 

You can also clear the search criteria in the Advanced Search page. Clearing the search criteria in the Advanced 
Search page only clears the fields on that page. It does not clear the current query, if one has been applied.
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Task To clear advanced search criteria

• On the Advanced Search page, click Clear. 

Searchable Entities and Elements
The following entities and elements are searchable in the Producer Portal:

Managing Accounts
This topic introduces accounts and account management. Account management includes creating, editing, and 
deleting an account. 

The exercises in this topic guide you through basic FlexNet Operations account management tasks. 

Accounts Key Concepts
FlexNet Operations provides a set of flexible tools that enable you to define account relationships that reflect your 
customer and distribution partner relationships.

• Provide producers and their customers the ability to define and manage their account hierarchies.

• Provide a true representation of “who owns what” within a large corporation.

• Be able to share/redistribute entitlements throughout the customer account.

• Even if a large enterprise account buys via different sources and via multiple accounts, the total number of 
entitlements they own can be easily tracked.

Note • Not all users have access to the account pages. 

Features Feature bundles 

Products Suites 

Maintenances License models 

Transaction keys Entitlements 

Activatable items Fulfillments 

Accounts Custom attributes

Part numbers Product lines

ASRs Devices

Custom host attributes Machines
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About Accounts
An account is an entity in FlexNet Operations. Accounts can represent the structure of a customer enterprise, the 
internal structure of a software producer or device manufacturer and, optionally, the relationships between the 
producer and its distribution chain. To be associated with an entitlement, a company must be entered as an 
account in FlexNet Operations. 

Accounts can have sub-accounts, which can be used to reflect the hierarchical nature of corporate structures. 
Accounts and sub-accounts are defined in a parent-child relationship. For example, you could create account 
Eclipse SunShades and set up Eclipse NA and Eclipse EMEA as sub-accounts. 

An account hierarchy can have multiple levels to flexibly accommodate different account models. For example, a 
single account can have multiple sub-accounts that would share a sibling relationship. Sub-accounts can 
themselves have sub-accounts. In addition, accounts can have multiple parents. It is recommended that the total 
number of associated sub-accounts for any given account does not exceed 1000.

Account Types
A FlexNet Operations account is one of four types: Producer, Customer, Partner, or Self Registered. On the 
Manage Accounts page, each of these types has a tab as described below. 

• Producers – Software producers or intelligent device manufacturers. Producers can create multiple sub-
accounts for their producer account. 

•  Customers – End users of your software or device. This category includes PORTAL_ORG_UNIT—the default 
account that maps to users who choose to self-register through the End-User Portal. A customer account can 
have sub-accounts. 

• Partners – Distribution partners like wholesalers, distributors, resellers, and retailers. Producers can map 
their distribution tiers by defining their distribution partners as partner accounts. A partner account can have 
sub-accounts. Refer to Managing Channel Partners for more information about channel partners and tiers.

• Self Registered – Users who self-register by logging in to the FlexNet Operations End-User Portal with an 
entitlement ID or activation ID and set up their own user account. Optionally, users can select to be 
associated with an existing Self-Registered account by providing the account ID upon self-registration, 
instead of creating a new account.

Default Accounts
The following accounts are available in FlexNet Operations by default: 

• My Organization (MYORG) – The producer account. Only the account display name (My Organization) is 
editable on the Edit Account page. This account cannot be deleted.

• Information Not Available (UNKNOWN_ORG_UNIT) – The account set as Sold To for any web register keys 
when account information is not provided and as the end customer or channel partner for entitlements and 
devices that have not been assigned an owner account. 

UNKNOWN_ORG_UNIT is a temporary holding account used by FlexNet Operations, internally, when no owner 
account is assigned. When UNKNOWN_ORG_UNIT is the owner of an entitlement or a device, the Producer 
Portal shows Information Not Available for End Customer or Channel Partner. 

This account cannot be updated or deleted.

• Organization for Portal Accounts (PORTAL_ORG_UNIT) – The account that maps to users who choose to self-
register through the End-User Portal. Users who log in to the portal with an entitlement ID or activation ID can 
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subsequently choose to self-register, set up a user account, or be associated with an existing Self-
Registered account.

This account cannot be updated or deleted.  

Account Hierarchies
The Advanced Organization Management module enables users to create multi-level account hierarchies for 
producers, customers and partners within FlexNet Operations to manage entitlements. 

The following is an example of an account hierarchy created using the Advanced Organization Management 
module. It includes several branches and levels of a customer account.

Figure 18-3: Example Account Hierarchy

Management Tasks
Management tasks include the following activities:

• Browsing Accounts and Sub-Accounts

• Creating, Editing, or Deleting an Account
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Browsing Accounts and Sub-Accounts
Accounts and sub-accounts are displayed, one type at a time, on tabs labeled Producers, Customers, Partners, 
and Self Registered on the Manage Accounts page. If you are assigned a role with the View Accounts or View and 
Manage Accounts permission, you can browse accounts in the Producer Portal. You can also view an account’s 
hierarchy—the parent account and any sub-accounts associated with it. To view any sub-accounts of an account, 
click the + icon to expand the tree view in the Manage Accounts list.

The Manage Accounts page provides the following information: 

• Account: Unique identifier of the account 

• Display Name: User-friendly name of the account 

• Created By, Created On: User name of the creator and date of creation 

• Description, City, State, Country: If included in the account settings, these columns are also populated in the 
accounts list. 

Creating, Editing, or Deleting an Account
To be associated with an entitlement, a company must be entered as an account in FlexNet Operations. 

If you are assigned a role with the View and Manage Accounts permission, you can add, edit, or delete accounts 
and sub-accounts. 

After you have created an account, you can create sub-accounts for it. It is recommended that the total number of 
associated sub-accounts for any given account does not exceed 1000.

You can edit an account or sub-account to change its name; to add, edit, or delete users; or to delete its sub-
accounts. 

To delete an account or sub-account from FlexNet Operations, use the Delete Account or the Delete Subtree 
button on the Manage Accounts page: 

• Delete Account—removes the selected accounts. If the account has sub-accounts, those sub-accounts no 
longer have a parent account. The sub-accounts are retained but become top-level accounts. (For example, 
any sub-accounts of a deleted customer account become customer accounts.) Any sub-accounts that were 
also parents of sub-accounts retain the hierarchy of sub-accounts beneath them. 

• Delete Subtree—removes the selected account and all of the sub-accounts in its hierarchy. 

Account Management Exercises
These exercises use examples to guide you through the following account management tasks: 

Exercise Description

Browsing Accounts Browse the Producers, Customers, Partners, and Self Registered account types. 

Creating a Customer 
Account and User

Create customer account Eclipse SunShades and customer user Laurie Larson, and 
add existing user Lisa Barry. 



Chapter 18 Getting Started with Advanced Organization Management
Managing Accounts

602 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Browsing Accounts
In this exercise, you browse accounts to become familiar with the Producers, Customers, Partners, and Self 
Registered tabs on the Manage Accounts page of the FlexNet Operations Producer Portal. 

Task To browse existing accounts 

1. Log in to the FlexNet Operations Producer Portal if you have not already done so. The Producer Portal Home 
page appears. 

2. Click Users & Accounts > All Accounts. The Manage Accounts page appears with the Customers tab 
selected. 

3. Click the Account link for any of the customers listed on the tab. The Create An Account page appears with 
details such as the customer’s account type, name, description, and address. Click Cancel to return to the 
Manage Accounts page. 

Note • When there are several pages of accounts to browse, you can use the search feature to locate a 
specific account. However, Search and Advanced Search are applied only on the currently selected account 
tab.

4. Repeat Step 3 for the Producers, Partners, and Self Registered account tabs. 

Creating a Customer Account and User
In this exercise, you create customer account Eclipse SunShades and customer user Laurie Larson, and you add 
existing user Lisa Barry. 

Task To create customer account Eclipse SunShades and add customer users 

1. Click Users & Accounts > Create Account. The Create An Account page appears. Note that the Account Type 
is set to CUSTOMER. 

2. Enter the account information:

Creating a Customer 
Sub-Account

Create sub-accounts Eclipse NA and Eclipse EMEA for customer account Eclipse 
SunShades. 

Creating a Producer 
Sub-Account

Create producer sub-account Beta Software.

Editing an Account Edit the display name for account Eclipse SunShades and remove user Lisa Barry. 

Deleting an Account Delete the sub-account Eclipse NA of customer account Eclipse SunShades.

Exercise Description
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• Account Name: Type Eclipse_SunShades 

• Display Name: Type Eclipse SunShades 

• Add additional description and address information as desired. 

3. To create a user for this customer account, click Create a User. The Create A User page appears.

4. Under User Details, enter the FlexNet Operations user information: 

a. End-User Portal Access?: Select Yes 

• Yes allows the user to log in to FlexNet Operations. Time Zone, Status, and Shared Login attributes 
are shown when this is selected. 

• No maintains the user as a contact only. Time Zone, Status, and Shared Login are hidden when this 
is selected. 

b. User Name: Specify a login name for the user. 

c. Time Zone: Select a time zone from the drop-down list 

d. Status: Leave the status set to Active. The records of an inactive user remain on file, but the user no 
longer has access to FlexNet Operations. 

Note • Multiple unsuccessful login attempts automatically set the user’s status to Inactive. The user can 
be reactivated by an administrator after confirming the user’s legitimacy. 

e. Shared Login: Select No 

• Yes means this account is shared by a group of users. 

• No means this account has only one user. 

5. Under Contact Details, enter the contact information: 

• First Name: Type Laurie 

• Last Name: Type Larson 

• Email Address: Type llarson@eclipsesunshades.com 

6. Under Accounts, select Portal User Role, then click Save. This message appears:  User Laurie Larson 
successfully added. Click Cancel to return to the Create An Account page. 

7. To link an existing user to this customer account, click Link Existing Users. The Select User window opens. 

8. In the Select User window, select Display Name Lisa Barry and Portal User Role, then click OK to close the 
window. This message appears:  Users have been linked to the account Eclipse_SunShades successfully. 

9. Click Users & Accounts > All Accounts to verify that Eclipse_SunShades appears on the Customers list of the 
Manage Accounts page. 

Creating a Customer Sub-Account
In this exercise, you create sub-accounts Eclipse NA and Eclipse EMEA for customer account Eclipse SunShades. 
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Task To create customer sub-accounts Eclipse NA and Eclipse EMEA 

1. Click Users & Accounts > All Accounts. The Manage Accounts page appears with the Customers tab open. 

2. Select the Eclipse_SunShades check box and click Create a Sub Account. The Create An Account page 
appears with Parent Account set to Eclipse_SunShades and Account Type set to CUSTOMER. 

3. Enter the account information: 

• Account Name: Type Eclipse_NA 

• Display Name: Type Eclipse NA 

• Country: Select United States 

Click Save. This message appears: Account Eclipse_NA has been successfully added. 

4. Repeat Step 1 through Step 3 to create another sub-account: 

• Account Name: Type Eclipse_EMEA 

• Display Name: Type Eclipse EMEA 

• Country: Select Netherlands 

Click Save. This message appears: Account Eclipse_EMEA has been successfully added. 

5. Click Users & Accounts > All Accounts and search for  Eclipse_SunShades. 

6. Click the Eclipse_SunShades account’s + icon to expand the tree and verify that sub-accounts Eclipse_NA and 
Eclipse_EMEA appear on the Customers list. Note the information that appears in the Created By, Created On, 
and Country columns for Eclipse_SunShades and its sub-accounts. 

Creating a Producer Sub-Account
In this exercise, you create producer sub-account Beta Software. 

Task To create a producer sub-account 

1. Click Users & Accounts > All Accounts. The Manage Accounts page appears.

2. Select the Producers tab and select the check box next to MYORG then click Create a Sub Account. The 
Create An Account page appears.

3. Enter the account information:

• Account ID: Type Beta_Software 

• Display Name: Type Beta Software 

4. Click Save. This message appears: Account Beta_Software has been successfully added.
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Editing an Account
In this exercise, you edit the display name for account Eclipse SunShades and remove user Lisa Barry. 

Task To edit the Eclipse SunShades account 

1. Click Users & Accounts > All Accounts. The Manage Accounts page appears with the Customers tab 
selected. 

2. In the Manage Accounts list, click Eclipse_SunShades, the account you want to edit. The Create An Account 
page appears. 

3. Change the Display Name from Eclipse SunShades to Eclipse SunShades, Inc. then click Save. This message 
appears:  Account Eclipse_SunShades has been successfully edited. 

4. On the user list, select the Lisa Barry check box. Click Remove Users then click OK in the confirmation 
message. User Lisa Barry is removed from the Eclipse SunShades, Inc. account and this message appears: 
Removed Users Lisa Barry for the account successfully. 

Deleting an Account
In this exercise, you delete the Eclipse NA sub-account of customer account Eclipse SunShades, Inc. 

Task To delete the Eclipse NA sub-account 

1. Click Users & Accounts > All Accounts. The Manage Accounts page appears with the Customers tab 
selected. 

2. In the Manage Accounts list, click the Eclipse_SunShades account’s + icon to expand the tree then select the 
Eclipse_NA account’s check box. 

3. Click Delete Account and click OK in the confirmation message. The Eclipse_NA account is deleted and this 
message appears:  Account(s) Eclipse_NA have been deleted successfully. 

Task To delete an account and all its sub-accounts

1. Click Users & Accounts > All Accounts. The Producer Portal opens the Manage Accounts page. 

2. Click the tab for the Account Type (Producers, Customers, Partners, or Self Registered) of the accounts you 
want to delete.

3. In the Manage Accounts list, select the parent account to delete. 

4. Click Delete Subtree. 

Note • If the Delete Subtree option is not selected, only the parent account is deleted. The sub-accounts are 
promoted to root accounts.

5. Click OK to confirm deletion. 
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The Producer Portal deletes the selected account along with its account hierarchy and refreshes the Manage 
Accounts page.

Note • Not all accounts are eligible for deletion. If an account owns entitlements it cannot be deleted.

Account Management Next Steps
In this topic, you performed basic FlexNet Operations account management tasks such as browsing accounts, 
creating a customer account and sub-accounts, and editing and deleting an account. In the next topic, you 
perform basic user management tasks. 

Account Management Advanced Topics
For more information about this advanced account management topic, refer to Managing Accounts. 

Activations of Entitlements Across Multiple Accounts on a Single Device 
Producers with the FlexNet Advanced Organization Management module who use FlexNet Embedded licensing 
technology can take greater advantage of their account hierarchies and channel partner sets during entitlement 
mapping operations. This capability also supports producers who want end users to be able to activate 
entitlements on any device. 

FlexNet Operations enables accounts, other than the device owner, to map entitlements to a device. Producers 
can map entitlements from the device owner's sub-accounts to any device, and End-User Portal users can map 
entitlements from their account, or its sub-accounts, to any device visible to them. 

Managing Users
This topic introduces users and user management. User management includes creating, editing, deactivating/
reactivating, and deleting users, and assigning/removing user roles. 

The exercises in this topic guide you through basic FlexNet Operations user management tasks. 

Users Key Concepts
FlexNet Operations provides a set of flexible tools that enable you to define and manage users and their roles. 

Note • Not all users have access to the user and role pages. 

About Users
A FlexNet Operations user is an individual or group account that appears on the Manage Users page and has all or 
some of its user information stored in the FlexNet Operations database. 
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To log in to FlexNet Operations, a user must provide a user name and password. Revenera creates the initial user 
account for a producer’s FlexNet Operations system administrator, then the system administrator (or other users) 
creates any additional users required for the producer’s account and for the producer’s customers (end users). 

Beyond the ability to simply log in, the activities a user can perform are based on the permissions that user has 
been granted. However, permissions are not assigned to users directly. Instead, permissions are grouped into 
roles and FlexNet Operations users are assigned one or more roles. FlexNet Operations users belong to either a 
producer account or a customer account. Users who self-register through the End-User Portal belong to the 
account for Portal Accounts. If a self-registered user supplies a company name while registering, a new account 
will be created corresponding to the new company name and the user assigned to it. Optionally, users can select 
to be associated with an existing Self-Registered account by providing the account ID upon self-registration, 
instead of creating a new account.

To log in to FlexNet Operations, a user must provide a user name and password. Users can get access to FlexNet 
Operations by being either: 

1. A FlexNet Operations user, meaning that all or some information for that user, whatever its source, is stored 
in the FlexNet Operations database. FlexNet Operations users appear under one of the tabs in the Manage 
Users page of FlexNet Operations and are members of the Home account or one of the Customer accounts. A 
FlexNet Operations user can be in the FlexNet domain or a directory service domain and can be added 
through the Producer Portal or Web services. Users who can log into FlexNet Operations by virtue of being a 
member of a domain or directory service that has been assigned a role will not appear in the Manage Users 
page. To be visible they must also be added individually as a user.

2. A user in a configured directory service who is not a FlexNet Operations user. Any user in a configured 
directory service domain can log in to FlexNet Operations. However, to perform a task in FlexNet Operations, 
a non-FlexNet domain user must belong to a group that has been granted a role that can perform the task. 
These users appear in the Users page of FlexNet Operations and are indicated by the non-FlexNet domain 
name in the domain column. 

FlexNet Operations users entered manually into the application are users in the FlexNet domain. Authentication 
information for a user in the FlexNet domain is stored in the FlexNet Operations database. FlexNet Operations 
users imported from a directory service are users in that directory service domain. Authentication information for 
a user in a directory service domain is maintained in the directory service.

Users can be members of FlexNet groups. Groups cannot be entered manually through FlexNet Operations, but 
can only be imported from a directory service. Membership in a group is managed entirely in the directory service.

Some user names are designed to be used as shared logins, such as proxy users rather than users who log in 
directly. For example, when a customer logs in to the End-User Portal with an activation ID, a shared login called 
portaluser logs in on behalf of the customer. A shared login is also useful for setting up group user accounts. For 
example, Revenera recommends creating a user who submits web service requests as a shared login. 

Shared logins are indicated on the Manage Users page with an icon showing several people. Shared logins do not 
appear in the Logged-In Users page, their last login date is not recorded, nor are they deactivated automatically 
after a number of unsuccessful logins. The profile of a shared login cannot be edited. Both shared and non-
shared users can log in to FlexNet Operations from multiple browsers simultaneously. 
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Users and Accounts
Each FlexNet Operations user must be linked to at least one account—either a Producer account to log in to the 
Producer Portal, or a Customer or Partner account to log in to the End-User Portal. A user can belong to multiple 
accounts, but all of the accounts must be of the same type and must not be in the same vertical hierarchy as 
shown in the following diagram:

Figure 18-4: Example User Assignments in a Multi Layered Account

User B can not be assigned to Acme Massachusetts, Acme East or Acme North America because they are all in 
the same vertical hierarchy. However, User B can be assigned to Special Operations because it is not a sub-
account of Acme North America.

What a user can see and do in the End-User portal is dependent on the permissions granted them and their 
location in the hierarchy. 

In the above scenario, User A can see all the entitlements associated with the Acme Massachusetts account and 
its sub-accounts as well as Acme New York because User A has been assigned the Portal Administrative User role 
which, by default, comes with all the permissions to see and manage entitlements in sub-accounts. User B can 
only see the entitlements in the Acme Boston and Special Operations accounts because, by default, the Portal 
User role does not have permission to see any entitlements beyond their own account(s).

A user who self-registers through the End-User Portal provides a company name, a new account is created to 
correspond to the new company name, and the user is assigned to it. Optionally, users can select to be 
associated with an existing Self-Registered account by providing the account ID upon self-registration, instead of 
creating a new account. 

A user belongs to one of four types. On the Manage Users page, each of these types has a tab as described 
below. 
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• Customer Users – End users of a producer’s software or device 

• Producer Users – Software producer or intelligent device manufacturer users 

• Partner Users – Distribution partner users like wholesalers, distributors, resellers, and retailers 

• Self-Registered Users – Users who self-register by logging in to the End-User Portal with an entitlement ID or 
activation ID and set up their own user account 

Default Users
By default, the following users are provided with FlexNet Operations: 

Your User Profile and Password
Each FlexNet Operations account has a user profile that includes details about the user’s name, email address, 
password, phone number, and postal address.

You can view your own user profile from the User menu—the name of the current user next to the System menu at 
the top right corner of the Producer Portal page—by selecting My Profile. If you are not a shared user, you can 
edit your user profile. A shared user can only view the profile. 

Whenever you enter your user name and a system-generated FlexNet password to log in to FlexNet Operations, 
you are directed to the Change Password page to change your system-assigned password to one that you 
choose. You can also change your password or select a secret question and answer at a later time by editing your 
user profile. 

Note • To change your password from the My Profile page, enter the old password then enter and confirm the 
new password. No email message is sent to remind you of your new password. The next time you log in, enter 
your new password. 

Table 18-2 • FlexNet Operations Users

User Name Description

admin Non-shared login with the System Administrator role. This user cannot be 
deactivated. 

portaluser Shared login for End-User Portal users who log in with an entitlement ID or 
activation ID. This user is assigned the Portal User role. 

trustedstorageuser Shared login that does not appear in any of the user management pages. It is 
displayed in the fulfillment history as the user who performs trusted transactions.  

legacyuser Shared login that does not appear in any of the user management pages. It is 
displayed in the fulfillment history as the user who imported legacy fulfillments 
from another system.  
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If you forget your password and have selected a secret question and answer, you can have a system-generated 
password emailed to you. If you did not select a secret question and answer, you must contact the FlexNet 
Operations administrator to request a new system-generated password. 

Browsing Users
If you are assigned a role with View Users permission, you can browse users in the Producer Portal. Click on a 
user to view details of the user’s account. 

Note • To locate a difficult to find user, use the search feature on the Manage Users page. 

Creating, Editing, or Deleting a User
Information for a FlexNet Operations user can be typed manually into FlexNet Operations. Or, if access to a 
directory service is configured, user data can also be imported from an LDAP directory service.

FlexNet Operations users entered manually into the application are users in the FlexNet domain. If no domain is 
shown, the user is in the FlexNet domain. Authentication information for a user in the FlexNet domain is stored in 
the FlexNet Operations database. FlexNet Operations users imported from a directory service are users in that 
directory service domain. Authentication information for a user in a directory service domain is stored in the 
directory service.

If you are assigned a role with the View and Manage Users permission, you can view, add, and edit all types of 
users. If you are assigned a role with the View and Manage Customer Users permission or View and Manage 
Partner Users permission, you can view all types of users but you can add and edit only customer users or partner 
users, respectively. The Create a User page displays the creation and last login dates for non-shared users. 

When you create a new user account, an email containing a system-generated password and login instructions is 
sent to the user’s email address. The user logs in for the first time with the system-generated password and is 
immediately prompted to change the password. 

You can edit a user to change the user’s details, contact information, or account. 

You can delete a user from FlexNet Operations if the user has no dependencies (such as, for example, line items, 
entitlements, or alert subscriptions). This permanently removes that user from the database. If you want to keep 
the user in the database but want to restrict access, consider deactivating the user instead. 

You cannot permanently delete a user from the database who has dependencies. However, you can perform a 
force delete. The force delete ensures that the user record and its dependencies are retained but placed in an 
inactive state. In this state, all fields on the user record are rendered obsolete, login-credential resets for the user 
are prohibited, and no further access to the user record is allowed.

Note that his option applies only to the forced deletion of non-producer users with dependencies.

Import a User or Group from a Directory Service
If a directory service domain is configured in FlexNet Operations, groups can be imported from the directory 
service and assigned roles. Users in an imported group can perform tasks allowed by the group’s roles and do not 
have to be added individually as FlexNet Operations users. However, users added as part of a group are not 
visible in the UI.
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If you want to give a domain user additional roles in addition to those granted by group membership, import the 
user and add additional roles as shown below. Users who are explicitly imported are visible in the UI. 

Domain (LDAP) users can be assigned to an account of a different type than the account to which they were 
originally assigned. However, these users credentials (username and password) are managed separately in the 
external domain. 

Resetting a User Password
When you reset a non-shared user’s password, an email is sent to the user with a new system-generated 
password. The user logs in with the new password and is immediately prompted to change the password. 

If the user is shared, the email containing a system-generated password is sent to a FlexNet Operations 
administrator (if you specified the administrator’s email address when the user was created). The administrator 
logs in to FlexNet Operations with the system-generated password, changes the password and keeps a record of 
it, then sends the new password to all users of the shared login. 

Deactivating and Reactivating a User
If you are assigned a role with View and Manage Users permission, you can deactivate and reactivate all types of 
users manually. If you are assigned a role with the View and Manage Customer Users permission or View and 
Manage Partner Users permission, you can deactivate and reactivate only customer users or partner users, 
respectively. User activation status is shown on the Create A User page. 

Users can be deactivated manually or automatically. Deactivated users remain in the FlexNet Operations 
database, but they cannot log in. 

Non-shared users are deactivated automatically after too many consecutive failed login attempts. 

Note • The default number of consecutive failed authentications is 3; this number can be configured in the 
FlexNet Platform Server configuration. When a user is deactivated automatically, the User Deactivated alert is 
triggered if it has been configured. 

Deactivated users must be reactivated manually. A reactivated user is informed by email, and if the reactivated 
user is shared, an administrator receives the email stating that the user has been reactivated. Reactivation does 
not affect a user’s password. 

About Roles and Permissions
The activities a FlexNet Operations user can perform are based on the permissions that user has. However, 
permissions are not assigned to users directly. Instead, sets of permissions are grouped into roles and users are 
assigned one or more roles. 
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Permissions 
FlexNet Operations permissions are organized into the following categories. For more information about the 
permissions in these categories, refer to FlexNet Operations Permissions. 

Roles
By default, the following producer and end-user roles are available in FlexNet Operations. For more information 
about these roles, refer to FlexNet Operations Roles. 

Browsing Roles 
Roles for FlexNet Operations are displayed in the Roles page. If you are assigned a role with the View Roles or 
View and Manage Roles permission, you can view a summary of roles. 

Assigning a Role to a User
You can assign a role to a user, if the user is able to log in to FlexNet Operations, on the user’s Create A User 
page. Role assignments are made per account in the Accounts table near the end of the page. 

Note • Not all users have sufficient permissions to assign or remove a user’s role(s). 

• Alert Management

• System Administration

• Operations Feature Bundles

• Operations License Models

• Operations Entitlements - Producer Portal

• End-User Portal

• End-User Portal Trusted Storage Licensing

• Web Services

• Operations Export Import

• User Management

• Account Management

• Operations Features

• Operations Products, Suites, and Maintenance

• Operations Part Numbers

• Operations License Management

• Operations Policies

• Operations Trusted Storage Licensing

• Operations Sub-Accounts

• License Technologies

• FlexNet Embedded

• Customer Support Representative

• Executive

• IT Back Office Manager

• Order Entry

• Portal Administrative User (end-user role)

• Portal User (end-user role)

• Product Manager

• Sales Operations Manager

• System Administrator 
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Browsing Users with a Role 
If you are assigned a role with View Users and View Roles permissions, you can view users who have been 
assigned a particular role. In addition, you can determine whether a user is shared; shared users are marked with 
an icon showing several people. The following summary information is displayed on the Users for Role page: 

• User Name: Login name of the user 

• Display Name: Full name of user 

• Date Created: Date the user was created 

• Date of Last Login: Date of last login by the user (not recorded for shared users) 

• Status: Whether the user is active or inactive 

User Management Exercises
These exercises use examples to guide you through the following user management tasks: 

Exercise Description

Browsing Users Browse the Customer Users, Producer Users, Partner Users, and Self Registered 
Users types. 

Creating a User Create a customer user named William Barry and link him to account BarryPhoto. 

Importing a User or 
Group from a Directory 
Service

Adding a user from an LDAP service.

Editing a User Change the name of customer user William Barry to Warren Barry. 

Resetting a User’s 
Password

Reset the password of customer user Warren Barry. 

Changing a User’s 
Account

Change the account a user is linked to.

Deactivating or 
Reactivating a User

Deactivate and reactivate customer user Warren Barry. 

Deleting a User Delete customer user Warren Barry.

Browsing Roles Browse the existing user roles on your system. 

Browsing Users with a 
Role

Browse users who are assigned a particular role. 

Assigning or Removing 
a User’s Role

Assign the Portal Admin User Role to Lisa Barry and remove the Portal User Role. 
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Browsing Users
In this exercise, you browse FlexNet Operations users to become familiar with the Customer Users, Producer 
Users, Partner Users, and Self Registered Users tabs on the Manage Users page of the Producer Portal. 

Task To browse existing users 

1. Click Users & Accounts > All Users. The Manage Users page appears with the Customer Users tab selected. 
On a Manage Users page tab, you can view the following information: 

• Whether a user is a shared user (a shared user has an icon depicting several people) 

• Display Name: User’s full name 

• User Name: User’s login name 

• Email Address: User’s email address 

• Type: User or Contact. A contact is a user account that cannot log in, and is maintained for account 
contact purposes. 

• Accounts: All accounts to which the user belongs 

2. Click on the Producer Users tab to view the producer users. Note that Portal User is a shared user. 

3. Click on the Partner Users tab to view the partner users. 

4. Click on the Self Registered Users tab to view the self registered users. 

5. Click on the Customer Users tab, then click the Lisa Barry Display Name link to view the details on the 
Create A User page that appears. When you are done, click Cancel to close the Create A User page. 

Creating a User
In this exercise, you create a customer user named William Barry and link him to account BarryPhoto. 

Task To create user William Barry and link him to account BarryPhoto 

1. Click Users & Accounts > Create User. The Create A User page appears. 

2. On the Create A User page, select FlexNet User, and click Next. 

3. Under User Details, enter the FlexNet Operations user information: 

a. End-User Portal Access?: Select Yes 

• Yes allows the user to log in to FlexNet Operations. Time Zone, Status, and Shared Login attributes 
are shown when this is selected. 

• No maintains the user as a contact only. Time Zone, Status, and Shared Login are hidden when this 
is selected. 

b. User Name: Specify a login name for the user. 

c. Time Zone: Select a time zone from the drop-down list 
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d. Status: Leave the status set to Active. The records of an inactive user remain on file, but the user no 
longer has access to FlexNet Operations. 

Note • Multiple unsuccessful login attempts automatically set the user’s status to Inactive. The user can 
be reactivated by an administrator after confirming the user’s legitimacy. 

e. Shared Login: Select No 

• Yes means this account is shared by a group of users. 

• No means this account has only one user. 

4. Under Contact Details, enter the user’s contact information: 

a. First Name: Type William 

b. Last Name: Type Barry 

c. Email Address: Type WBarry@barryphoto.com 

5. Under Accounts, click Link Accounts. The Select Account window opens with the Customers tab selected. 
Search for and select the BarryPhoto and Portal User Role check boxes, then click OK to close the window. 
An email containing a system-generated password and login instructions is sent to the user’s email address, 
and this message appears: User William Barry successfully added.

Note • Users can be assigned to more than one account, provided those accounts are parallel to one another 
or are in a different vertical hierarchy. For example, user can not be assigned to both a parent and child 
account because they are vertical to one another in the hierarchy. 

Importing a User or Group from a Directory Service
If a directory service domain is configured in FlexNet Operations, groups can be imported from the directory 
service and assigned roles. Users in an imported group can perform tasks allowed by the group’s roles and do not 
have to be added individually as FlexNet Operations users. However, if you want to give a domain user additional 
roles in addition to those granted by group membership, import the user and add additional roles as shown 
below.

Task To import a user from a directory service

1. Click Users & Accounts > Create User. This link opens the Create A User page. 

2. On the Create a User page, select User From a Directory Service.

a. Select one of the directory service domains that contains the information to authenticate this user, and 
then click Next.

b. Search for and select one or more users to import from the directory service. Select multiple users at one 
time only if you plan to assign them all the same roles. Only a small amount of user information will be 
imported from the directory service to the FlexNet Operations database. User authentication is done by 
contacting the directory service. Click Next.

c. The user to be imported is displayed. (Leave the Status of the new user Active.) 
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d. Assign at least one role to the user.

e. Click Finish.

When the new user account is saved, the external domain user can log in to FlexNet Operations using his or 
her credentials from the external domain directory service.

Editing a User
In this exercise, you change the name of customer user William Barry to Warren Barry. 

Task To edit existing user William Barry 

1. Click Users & Accounts > All Users. The Manage Users page appears with the Customer Users tab selected. 

2. In the Users list, click the William Barry link to view the user and contact details on the Create A User page 
that appears. 

3. Change the user’s First Name from William to Warren, then click Save. This message appears: User Warren 
Barry successfully edited. 

Resetting a User’s Password
In this exercise, you reset the password of customer user Warren Barry. 

Task To reset Warren Barry’s password

1. Click Users & Accounts > All Users. The Manage Users page appears with the Customer Users tab selected. 

2. In the Users list, click the Warren Barry link to open the Create A User page. 

3. On the Create A User page, click Reset Password to send an email to the user with a new system-generated 
password. This message appears: Password has been reset and emailed to the user. 

Changing a User’s Account
Use the following to change the account to which a user is linked.

Task To move a user from one account to another.

1. Click on Users & Accounts > All Users. This opens up the Manage Users page.

2. On the Manage Users page, click the name of a user.

3. On the Create a User page, scroll down to the Accounts heading and click Link Accounts. This opens the 
Select Account page.
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4. On the Select Account page, select the user’s new account and select a role, for example: Portal Admin User 
or Portal User, then click OK to close the window. A message like the following appears: User John Doe 
successfully edited.

Note • A user can only be moved to an account of the same type (i.e. end customer or channel partner)

5. On the Create a User page, scroll down to the Account heading and select the account to remove, then click 
the Remove button.

Note • A user must have at least one account associated with it. You can only assign accounts that are 
parallel to one another or in a different vertical hierarchy. You cannot move a user from a child account to a 
parent account or vice versa through the UI. It can only be done through Web Services. For more information, 
refer to the Web Services Guide.

Deactivating or Reactivating a User
In this exercise, you deactivate and reactivate customer user Warren Barry. 

Task To deactivate user Warren Barry 

1. Click Users & Accounts > All Users. The Manage Users page appears with the Customer Users tab selected. 

2. In the Users list, click the Warren Barry link to open the Create A User page. 

3. On the Create A User page, in the Status drop-down list, select Inactive, then click Save. User Warren Barry is 
deactivated and this message appears: User Warren Barry successfully edited.

Task To reactivate user Warren Barry 

1. Click Users & Accounts > All Users. The Manage Users page appears with the Customer Users tab selected. 

2. In the Users list, click the Warren Barry link to open the Create A User page. 

3. On the Create A User page, in the Status drop-down list, select Active, then click Save. User Warren Barry is 
reactivated and this message appears: User Warren Barry successfully edited.

Deleting a User
In this exercise, you delete customer user Warren Barry. 

Task To delete a user

1. Click Users & Accounts > All Users. The Manage Users page appears with the Customer Users tab selected. 

2. In the Users list, search for and select the Warren Barry check box. 
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3. Click Delete and click OK in the confirmation message. Warren Barry is deleted from the Customer Users list 
and this message appears: User(s) Warren Barry have been deleted successfully. 

Note • If the user Warren Barry has dependencies (such as, for example, line items, entitlements, or alert 
subscriptions), you are prompted to confirm the deletion in an additional dialog. When you confirm the 
deletion, all fields in the user record are changed to Obsolete. This means that this user record is no longer 
accessible.

Browsing Roles
In this exercise, you browse the existing user roles on your FlexNet Operations system. 

Task To view a list of existing roles 

1. Click Users & Accounts > All Roles. The Roles page appears with the following information: 

• Role Name: Name of the role, which links to its Edit Role page 

• Status: Whether the role is active or inactive and whether it is a system-defined role 

• Mapped Users: Links to users who are assigned the role 

2. Click one of the roles in the list. When the Edit Role page appears, review the different categories and 
permissions included in each. When you are done, click Cancel to return to the Roles page. 

Browsing Users with a Role
In this exercise, you browse users who are assigned a particular role. 

Task To browse users with a particular role 

1. Click Users & Accounts > All Roles. 

2. To see the users with a Portal User Role, click the users link for that role under Mapped Users. The Users For 
Role page appears with the following information about the users who are assigned this role: 

• User Name: Login name of the user and whether the account is shared (portaluser is shared) 

• Display Name: Full name of the user 

• Date Created: Date the user was created 

• Date of Last Login: Date of user’s last login (not recorded for shared users) 

• Status: Whether the user is active or inactive 

3. Review the information and note that portaluser is a shared user. 

4. Use your browser’s Back button to return to the Roles page, then repeat Step 2 and Step 3 for the System 
Administrator role. Note that legacyuser and trustedstorageuser are also shared users. 
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Assigning or Removing a User’s Role
In this exercise, you assign the Portal Admin User Role to Lisa Barry and you remove the Portal User Role. 

Task To assign a role to a user

1. Click Users & Accounts > All Users. The Manage Users page appears with the Customer Users tab selected. 

2. On the Manage Users page, search the user list for the Lisa Barry Display Name. 

Note • Users can appear on different tabs. Be sure you are looking for the user on the correct tab. 

3. Click the Lisa Barry link to view her Create A User page. 

4. On the Create A User page, under Accounts, select the Portal Admin User Role box to assign it to Lisa Barry. 
(Possible roles appear in the Role column of the Accounts table—one set per account.) 

Note • A user must have at least one role assigned for each account to which he or she belongs.

5. Click Save. The role assignment is saved and this message appears: User Lisa Barry successfully edited.

Task To remove a role from a user

1. Click Users & Accounts > All Users. The Manage Users page appears with the Customer Users tab selected. 

2. On the Manage Users page, search the user list for the Lisa Barry Display Name. 

Note • Users can appear on different tabs. Be sure you are looking for the user on the correct tab. 

3. Click the Lisa Barry link to view her Create A User page. 

4. On the Create A User page, under Accounts, uncheck the Portal User Role box to remove it from Lisa Barry. 
(Possible roles appear in the Role column of the Accounts table—one set per account.) 

Note • A user must have at least one role assigned for each account to which he or she belongs.

5. Click Save. The role removal is saved and this message appears: User Lisa Barry successfully edited.

User Management Next Steps
In this topic, you performed basic FlexNet Operations user management tasks such as browsing users, creating 
and editing a user, resetting a user’s password, deactivating and reactivating a user, deleting a user, browsing 
roles, browsing users assigned a particular role, and assigning or removing a user’s role. 

In the next topic you will perform channel partner management, including creating tiers and adding channel 
partners.
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User Management Advanced Topics
For more information about this advanced account management topic, refer to Managing Users. 

Activations of Entitlements Across Multiple Accounts on a Single Device 
Producers with the FlexNet Advanced Organization Management module who use FlexNet Embedded licensing 
technology can take greater advantage of their account hierarchies and channel partner sets during entitlement 
mapping operations. This capability also supports producers who want end users to be able to activate 
entitlements on any device. 

FlexNet Operations enables accounts, other than the device owner, to map entitlements to a device. Producers 
can map entitlements from the device owner's sub-accounts to any device, and End-User Portal users can map 
entitlements from their account, or its sub-accounts, to any device visible to them. 

Managing Channel Partners
This topic discusses the management of channel partner tiers. Channel Partner management includes adding 
tiers and channel parter accounts.

Channel Partner Key Concepts
• Create distribution tiers for classification of distributors and resellers.

• Represent non-flat channel distribution structures in FlexNet Operations as they exist in an enterprise 
resource planning system.

• Allow multiple accounts from different distribution tiers to be associated with an entitlement.

• Build a complete distribution list through the entire entitlement sale.

• Split entitlements, bulk entitlements and maintenance between partners and customers.

• Pool entitlements to existing line items to minimize proliferation of line items.

• Self-service for channel partners to split entitlements

• Partner, such as a system integrator, can manage licensing on behalf of the end customer.

• Visibility, roles, and permissions allow/prevent information about the partner tier account to be seen by 
others, as appropriate.

Partners and Distribution Tiers
Partner accounts identify accounts in your distribution chain—those accounts that act as distributors of your 
products and entitlements. Partner accounts exist in distribution tiers between your producer account and your 
end customers. You can add multiple partner accounts on the Manage Accounts page. Unless additional tiers are 
added, these partner accounts all occupy the default distribution tier.
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By default, FlexNet Operations provides a Distributor tier and an End Customer tier for entitlements. The 
distribution chain allows entitlements and devices to move from the producer account to a distributor (partner 
account) to an end user (customer account). However, you can customize the distribution chain and add multiple 
tiers. Changes to the tiers in the distribution chain require customizations to the FlexNet Operations database and 
related properties files. For details, see the FlexNet Operations On-Premises Installation & Implementation Guide.

Unique to partner accounts is their relationship to the producer account. Information about the transactions in 
the partner accounts flows up through the distribution chain so that these transactions are visible on the 
Producer Portal. 

Some FlexNet Operations features are only available to the producer account and partner accounts. For example, 
only partner and producer accounts (if the current owner is set to a partner account) can split entitlements.

Architecture Overview
By default, FlexNet Operations supports a single distribution tier:

Figure 18-5: Default Tier Structure

The Advanced Organization Management module supports multiple distribution tiers:
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Figure 18-6: Sample Custom Tier Structure

Built-In Tiers
The built-in tiers are End Customer and Distributor.

End Customer Tier
• All simple entitlements must have the End Customer tier populated (analogous to SoldTo).

• If the end customer account is not known, the End Customer tier can be populated with Info Not Available 
(UNKNOWN_ORG_UNIT) until a known account claims the entitlement.

• Additional tiers can be populated for simple entitlements, but the End Customer tier is always required.

• End Customer tier is not supported for bulk entitlements.

• Partner accounts cannot be specified in the End Customer tier of an entitlement.

Distribution Tier
• All bulk entitlements must have the Distributor (tier1) tier populated (analogous to SoldTo).

• Additional tiers can be populated for bulk entitlements but the Distributor tier is always required.



Chapter 18 Getting Started with Advanced Organization Management
Managing Channel Partners

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 623

Custom Tiers
Custom tiers have no enforced hierarchy and their presence does not change the functional requirements of the 
built-in tiers. Creation of the custom tiers requires direct access to the database (there is no UI for creating 
custom tiers) so for cloud users, custom tiers are added as part of onboarding the tenant. A channel partner set 
contains one or more partner tiers, each tier populated by exactly one account.

Designing Channel Partner Tiers
The first step in setting up tiers for channel partners is to sketch out what the distribution channel looks like and 
plan for the partner tiers to accommodate that. You need to decide how rights pass from a producer to a first 
level distributor, to their distributors and finally to end customers. Add enough partner tiers in the database to 
address the demand chain.

For information about adding channel partner tiers, see the FlexNet Operations On-Premises Installation & 
Implementation Guide.

Tracking Entitlements Through a Demand Chain
Unlike account hierarchies, there is no one direct chain between the producer and the end customer. 
Entitlements may be split multiple times between partner accounts before an entitlement is assumed by an End 
Customer. The following diagram demonstrates how a bulk entitlement can be split through several tiers of 
distributors and resellers to the final end customers. 

Figure 18-7: Example Demand Chain

In this example, Distributor tiers are in blue and the End Customer tier is in green.



Chapter 18 Getting Started with Advanced Organization Management
Managing Channel Partners

624 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

When setting up the channel partner tiers for this example, a user would need to add one reseller tier and four 
channel partner accounts. The remaining tiers are already populated by default (distributor and end customer).

Accounts are not assigned to Channel Partner Tiers until you have an entitlement since the appropriate partner 
tier may change depending on the entitlement and the deal. See Getting Started with Entitlement Management. 

Partner Relationships
Partner relationships between accounts can be defined to allow a Partner to split or sell entitlements along a 
distribution chain. Relationships can be set up between two Partner accounts or between a Partner account and 
a Customer account and can be set either by a Producer or by a Partner user.

A Partner user with the equivalent of a Portal Administrative User role can create other Partner accounts and 
users as well as other Customer accounts and users. Accounts created by a Partner user are automatically 
related to the user’s account.

In Figure 18-7, accounts in blue represent Channel Partner tiers while the Customer tier is in green. Partner 
relationships exist between Distributor 1 and Reseller 1 as well as between Distributor 1 and Reseller 2. Likewise, 
Reseller 2 has partner relationships with both End Customer 1 and End Customer 2. Entitlements passing 
between partner accounts are split whereas entitlements from End Customer 2 to Business Unit 1 and Business 
Unit 2 are transferred since they are part of the same account hierarchy within the Customer tier.

Splitting Entitlements
One of the partner tiers (either the partner account or one of its sub-accounts) of an entitlement must be set as 
Current Owner before an entitlement can be split. A Producer user can also split an entitlement on behalf of a 
Partner account, however, the Current Owner must still be set. Only unactivated entitlements or web register keys 
can be split. 

If a bulk entitlement has several layers of Channel Partners, one layer can split off some of the web register keys 
to another bulk entitlement to another related Channel Partner account.

Once a known End Customer is identified on the entitlement, it will be set as the current owner and the current 
owner cannot be changed to another tier.

If the Current Owner setting is set to a tier other than End Customer, it indicates only that a user in the account in 
that tier, or a producer user, can split that entitlement. It has no additional significance.

Transferring vs Splitting Entitlements
Entitlement transfers happen primarily within a customer account hierarchy because entitlements can only be 
transferred to a customer account. An End Customer account can transfer entitlements to a parent or child 
account of itself whereas a Channel Partner can only transfer an entitlement to a related customer account. To 
move an entitlement to a related Channel Partner account, the entitlement must be split. Producer users can 
transfer or split entitlements on behalf of the customer or partner users.

Information Visibility
To control visibility there is a flag on the Create An Account page called Visible to other Partners. If the flag is set 
to false, it will prevent distributors or resellers higher up the chain from seeing the name of the Current Owner of 
an entitlement. The account name will be displayed as Name Withheld. If the flag is set to true, all partner 
accounts directly related to the account can view the account name on visible entitlements.
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Creating a Partner Account
Partners are special accounts in FlexNet Operations. (See Partners and Distribution Tiers for more information.)

Users assigned a role with the View and Manage Accounts permission can view, add, and edit accounts.

Task To create a partner account

1. Click Accounts & Users > Create Partner Account.

2. On the Create An Account page:

a. Enter the Account ID (required). 

b. Enter the Account Name of the account (required).

c. Add a description and address information as desired.

d. Set the Visible to other Partners check box (it is selected by default).

• To prevent partners in different distribution tiers from seeing information about this account, un-
check Visible to other Partners. 

• To allow partners to see information about this account, check Visible to other Partners.

3. If you want to link users to the account, do one of the following:

• Click Create a User to link a new user to the account. Then follow the steps outlined in Creating, Editing, 
or Deleting a User to create the new user account.

• Click Link Existing Users to link existing users to the account. Select the users (and roles, if applicable) 
you want to link and click OK.

4. Click Next. On the Linked Sub-Accounts page, select any sub-accounts you want to link to this account. 
(Optional)

Note • Only parent accounts can set up links to sub-accounts.

5. Click Next. On the Relate Accounts page, select any partners you want to relate to this account. (Optional)

Note • Relationships between Channel Partners and End Customers must be set up from the Channel Partner 
or Producer end. Producers can set up relationships between Channel Partners and End Customers but they 
don’t participate in the relationships.

6. Click Complete.

Channel Partner Next Steps
In this topic, you performed the basic FlexNet Operations partner management task creating Channel Partner 
Accounts. 

Product ordering and entitlement is the stage of the FlexNet Operations license lifecycle that follows.
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Refer to these getting started sections for concepts and exercises that guide you through electronic software 
delivery, usage management, and cloud licensing service tasks:

• Getting Started with Electronic Software Delivery (requires the Software Delivery module)

• Getting Started with Usage Management 

• Getting Started with Cloud Licensing Service  

Refer to this getting started section for concepts and exercises that guide you through entitlement management 
tasks: 

• Getting Started with Entitlement Management 

Refer to this section for detailed information on transferring and splitting entitlements:

• Entitling Customers and Activating Licenses

Refer to these getting started guides for concepts and exercises that guide you through licensing activation and 
support tasks: 

• Getting Started with FlexNet Embedded Licensing 

• Getting Started with FlexNet Publisher License File-Based Licensing 

• Getting Started with FlexNet Publisher Trusted Storage-Based Licensing 

• Getting Started with Non-FlexNet Licensing Technologies 

Channel Partner Advanced Topics
Activations of Entitlements Across Multiple Accounts on a Single Device 
Producers with the FlexNet Advanced Organization Management module who use FlexNet Embedded licensing 
technology can take greater advantage of their account hierarchies and channel partner sets during entitlement 
mapping operations. This capability also supports producers who want end users to be able to activate 
entitlements on any device. 

FlexNet Operations enables accounts, other than the device owner, to map entitlements to a device. Producers 
can map entitlements from the device owner's sub-accounts to any device, and End-User Portal users can map 
entitlements from their account, or its sub-accounts, to any device visible to them. 
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Part 3
Administrator Reference

This part of the FlexNet Operations User Guide includes the following sections:

• Configuring FlexNet Operations

• Performing Administrative Tasks
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Configuring FlexNet Operations

This chapter discusses how to configure FlexNet Operations using the links in the System menu. 

Using the System Menu  
Users assigned a role with the View System Information permission can view system information. 

The System menu includes a number of links for viewing system information as well as a number of links for 
managing system configuration settings and custom content and the like. The system information links are 
covered here. The other activities, such as system configuration, are covered in their own sections. 

Table 19-1 • 

Topic Description

Using the System Menu View system configuration settings, custom content, recent news, and link to your 
end-user portal, your reports, system uptime statistics, and FlexNet Operations’ 
customer community via the System menu.

Performing System 
Configuration

Administer system configuration settings for FlexNet Operations Producer Portal, 
End-User Portal, FlexNet Platform server, embedded devices, and more via the 
options in System > Configure.

Configuring Secure 
Token Single Sign-On

Configure the FlexNet Operations end-user portal to interface with a separate 
application, such as a corporate portal or intranet. 

Viewing Transaction 
Histories

Describes how to search for and view transaction histories and transaction details. 

Managing Custom 
Content

Create and manage custom HTML and text snippets to be rendered in your End-User 
Portal pages. 
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System information links in the System menu include the following: 

Table 19-2 • 

Link Description

Configure Opens the System Configuration page. For details about changing system 
configuration settings, see Performing System Configuration.

Custom Content Opens the Custom Content page. For more information about administering custom 
content, see Managing Custom Content.

End-User Portal A shortcut for opening your End-User Portal in a separate tab or window. Click 
System > End-User Portal to open your End-User Portal to the login page. 

Transaction History Opens the Search Transaction History page. For more information about searching 
and viewing transaction histories, see Viewing Transaction Histories.

Updates Manually checks for updates to FlexNet Operations. To configure update check 
settings, see System > Configure > Updates.

Application Log Opens the View FlexNet Application Log page. The FlexNet Operations application 
log contains useful information for debugging problems with the application, and 
technical support may ask you to send all or part of the log to help solve any 
problems you report.

Click System > Application Log to view the log entries. 

You can also download the application log entries by clicking the Download button 
on the View FlexNet Application Log page. 

About Advanced 
Lifecycle Management 
Module 

Opens a page to give version information—versions, build numbers, patch levels, 
and license status—about the FlexNet Operations base module. Click System > 
About Advanced Lifecycle Management Module to show module-specific 
information.

About Electronic 
Software Delivery 
Module

Opens a page to give version information—versions, build numbers, patch levels, 
and license status—about the FlexNet Operations electronic software delivery 
module. Click System > About Electronic Software Delivery Module to show 
module-specific information.

Uptime Shows basic uptime information for cloud-hosted FlexNet Operations components 
and environments. Click System > Uptime to show uptime information.

Latest News Shows information about the current year’s release schedule and the timing for the 
environment update. Click System > Latest News to show the Latest News page.

Customer Community Opens the Revenera Customer Community home page in a new window. Click 
System > Customer Community to show customer community portal. 
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Performing System Configuration 
A user must be assigned a role with the View and Manage Configurations permission to view system 
configuration and to modify any configuration settings through the Producer Portal. 

To change configuration settings through the FlexNet Operations Producer Portal, click System > Configure to 
open the System Configuration page. 

Note • Configuration changes made in the FlexNet Operations System Configuration page could take a few 
minutes to take effect on the system, typically 1-2 minutes. 

Table 19-3 • System Configuration Page

Topic Description

Configuring the FlexNet 
Platform Server

Customize outbound email settings, logging, timeouts, and other FlexNet Platform 
Server settings.

Configuring the 
Producer Portal User 
Interface

Alter user interface settings for the Producer Portal. The System Configuration > 
User Interface page allows you to specify settings such as the number of records 
per page and log lines per page.

Configuring Validators Customize the validation of user name and password fields. 

Configuring System 
Settings

Customize a wide range of FlexNet Operations settings. These include URLs for 
support and user communities, classnames for ID and fulfillment ID generators, 
host ID validators, as well as many other default settings and settings for optional 
features. 

Configuring Trusted 
Activation Settings

Configure settings to activate or deactivate trusted storage features and specify 
generators for custom attributes in online responses and short code responses.

Configuring Public 
Services Settings

Configure settings to activate or deactivate public services and specify a generator 
for public services responses. 

Configuring Export and 
Import Settings

Set limits that govern the number of features, feature bundles, license technologies, 
license models, and so on per exported XML file. Likewise, this page includes 
settings for the number of errors per file and the I/O buffer size for imports. 

Configuring End-User 
Portal Settings

Customize settings for the FlexNet Operations End-User Portal. This page enables 
you to customize logos, colors, and page footer content; hide various page 
elements, links, fields, buttons, and views; and otherwise control the appearance 
and behavior of the portal.

Activating and 
Licensing FlexNet 
Operations

Activate your account’s FlexNet Operations license. You must activate your FlexNet 
Operations license to enable the FlexNet Operations features your account 
purchased.
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Configuring the FlexNet Platform Server 
A user must be assigned a role with the View and Manage Configurations permission to modify configuration 
settings for the FlexNet Platform Server through the Producer Portal. 

Note • Before changing any configuration settings in a working FlexNet Operations instance, it is advisable to 
export the working configuration settings. If there is a problem with the new settings, you have a backup of 
working settings to restore. 

Task To change FlexNet Platform Server configuration settings through the FlexNet Operations Producer Portal

1. Click System > Configure. 

2. Click FlexNet Platform Server to open the configuration page for the FlexNet Platform Server. 

3. View or change the values of the settings below. 

4. Click Save Configs to save changes. 

The Producer Portal saves your configuration changes. 

The platform server settings include the following. Note that default values are listed as the first choice. Also, 
required fields are indicated with an asterisk.   

Importing a 
Configuration

Import a previously exported configuration file. 

Exporting a 
Configuration

Export the current system configuration settings as a zip file. This exported zip file 
can be used to restore FlexNet Operations system configuration settings. 

Configuring Embedded 
Devices Settings

Fine tune features related to devices and specify classnames for request handlers 
and device handlers.

Table 19-4 • FlexNet Platform Server Configurations

Name Possible Values Description Rqd

Outbound Mail 
Server Host 

mail or specify The name of the machine that hosts the mail server 
for mail sent from FlexNet Operations.

Default: fnosmtp

*

Outbound Mail 
Security 

None or SSL Type of security set for mail sent from FlexNet 
Operations. 

Table 19-3 • System Configuration Page

Topic Description
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Outbound Mail 
Server Port 

0 or specify The port on which the outbound mail server runs: 
Set to 0 to use the default port determined by 
security: 

SMTP/None: 25

SMTP/SSL: 587

*

Outbound Mail 
Logging Detail 

Brief or Verbose Level of detail of outbound mail written to the 
FlexNet Operations application log.

Default: Brief

Outbound Mail 
Account 

Mail account to use for mail sent from FlexNet 
Operations: Typically left blank. Value needed only if 
outbound mail server requires account 
authentication.

Outbound Mail 
Password 
(Confirm)

Password to use for Outbound Mail Account: 
Provide confirmation for the password.

From-Address for 
Outbound Mail 

flexnet-server or specify Email sent from FlexNet Operations is sent from this 
email address. (Should be an actual account in the 
email system.)

Default: flexnet-server@myorg.com

*

FlexNet 
Application 
Logging 
Threshold 

Debug Messages
Informational Messages
Warnings
Errors

The maximum level of detail for the messages 
written to the FlexNet Operations application log file 
after FlexNet Operations starts: Only messages at or 
below the selected level of detail are displayed in 
the log. 

FlexNet 
Application 
Performance 
Logging 

Selected or unselected Select to enable performance logging in the 
application. 

Default: unselected

Session Timeout 30 or specify If a user has been inactive for the specified amount 
of time (minutes), the user must log in to FlexNet 
Operations again.

*

Table 19-4 • FlexNet Platform Server Configurations
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Consecutive 
Failed 
Authentications 

3 or specify Number of consecutive failed attempts to log in 
before a user is deactivated. These attempts are 
counted over the Time Period for Failed 
Authorizations.

For a non-shared user, the specified value applies.

For a shared user, the specified value is multiplied 
by 2. (Example: 3 x 2 = 6; a shared user is 
deactivated after 6 consecutive failed login 
attempts within the Time Period for Failed 
Authorizations.)

*

Minutes for re-
enabling a shared 
login after 
deactivation

3 or specify The number of minutes after which a shared user 
account will be reactivated after it has been 
deactivated due to the number of Consecutive 
Failed Authentications having been reached.

Recaptcha Site 
key

The site key used to invoke the Google reCAPTCHA 
service on the End-User Portal. The site key is 
programmatically validated by the Google API.

The Google reCAPTCHA mechanism enables a 
shared user whose account is locked (due to too 
many consecutive failed login attempts) to have 
their account reactivated before the Minutes for re-
enabling a shared login after deactivation timeout 
has elapsed. In this case, the login screen of the 
End-User Portal shows the “I’m not a robot” check 
box which enables the user to validate their 
account.

Recaptcha Secret 
key

The secret key that authorizes communication 
between FlexNet Operations and the Google 
reCAPTCHA server to verify the shared user's 
response. It is essential that the secret key be kept 
secure.

Time Period for 
Failed 
Authorizations 

1440 or specify Amount of time (minutes) during which Consecutive 
Failed Authentications are allowed before the user 
is deactivated.

*

Table 19-4 • FlexNet Platform Server Configurations
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Default Account 
for External 
Domain

MYORG
or specify 

Name of the default account to be used when the 
account of the external domain user does not map 
to any account in the FlexNet Operations 
application. The default account for a user 
belonging to an external domain is MYORG. This can 
be changed.

*

HTTP Response 
Header X-FRAME-
OPTIONS

SAMEORIGIN

DENY

A value for X-Frame-Options in the HTTP response 
header. Check browser support for specified value. 

Default: SAMEORIGIN 

HTTP Response 
Header P3P

A value for P3P in the HTTP response header. 
Specify an appropriate P3P value if a browser 
privacy policy is required.

Number of Days 
Email Copies 
retained

1 or specify The total number of days the email history is 
retained. The Purge Email History job reads this 
configuration and based on the number of days set, 
deletes all the email copies.

*

Log emails in 
history, do not 
send them

Selected or unselected When selected, emails are logged to the email 
history but only reset password emails are sent. 

Default: unselected

Note • For emails generated by Order Media 
requests, there are two emails that are triggered. 
One uses the template and is sent to the end user. 
The other does not use the template and is sent to 
the producer. Because this configuration setting 
only applies to emails generated from templates, 
the email sent to the producer is still sent.

Maximum Batch 
sizes for create / 
update 
Webservices 
requests

25 or specify The batch-size maximum for requests issued from 
SOAP and REST web services.

The value indicates the maximum number of records 
allowed in a single web services batch request that 
results in a write. Specifying a request with a batch 
size greater than the limit results in an error.

Note • Editing this setting requires the Super 
Administrator role.

Table 19-4 • FlexNet Platform Server Configurations

Name Possible Values Description Rqd



Chapter 19 Configuring FlexNet Operations
Performing System Configuration

636 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

Configuring the Producer Portal User Interface 
A user must be assigned a role with the View and Manage Configurations permission to modify configuration 
settings for the Producer Portal. 

Note • Before changing any configuration settings in a working FlexNet Operations instance, it is advisable to 
export the working configuration settings. If there a problem with the new settings, you have a backup of working 
settings to restore.

Task To change user interface configuration settings for the Producer Portal

1. Click System > Configure. 

2. Click User Interface. 

3. View or change the values of the settings below.

4. Click Save Configs to save changes. 

The Producer Portal saves your configuration changes. 

The user interface settings include the following. Note that default values are listed as the first choice. Also, 
required fields are indicated with an asterisk.  

Maximum Batch 
sizes for read 
Webservices 
requests

2000 or specify The batch-size maximum for requests issued from 
SOAP and REST web services.

The value indicates the maximum number of records 
allowed in a single web services batch request for a 
read. Specifying a request with a batch size greater 
than the limit results in an error.

Note • Editing this setting requires the Super 
Administrator role.

Table 19-5 • User Interface Configurations

Name
Possible 
Values Description Rqd

Records Per Page 20 or 
specify 

Number of records displayed on a page that implements 
pagination (For example, Users page implements pagination; 
Roles and Alert Types pages do not.) 

* 

Table 19-4 • FlexNet Platform Server Configurations
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Configuring Validators
A user must be assigned a role with the View and Manage Configurations permission to modify configuration 
settings for configuring validators through the Producer Portal. 

Note • Before changing any configuration settings in a working FlexNet Operations instance, it is advisable to 
export the working configuration settings. If there is a problem with the new settings, you have a backup of 
working settings to restore.

Task To change validators configuration settings through the FlexNet Operations Producer Portal

1. Click System > Configure. 

2. Click Validators to open the configuration page for validators. 

3. View or change the values of the settings below.

4. Click Save Configs to save changes. 

The Producer Portal saves your configuration changes. 

The validator settings include the following. Note that default values are listed as the first choice. Also, required 
fields are indicated with an asterisk.    

Log Lines Per Page 200 or 
specify

Number of log lines displayed on a page when View Application 
Log is clicked.

*

Alert Dismissal URL Specify The URL for creating an alert dismissal link generated as part of 
an alert’s email notification. The URL syntax must be 
<protocol>://<hostname>:<port> where <protocol>, <hostname>, 
and <port> represent the FlexNet Operations server or gateway 
(proxy). 

Table 19-6 • Validator Configurations

Name Possible Values Description Rqd

FlexNet User Name 
Validator 

Either:

com.flexnet.platform.services.
userManagement.FLEXnetUserIdVa
lidator

or specify another

Default Implementation class for user ID 
validation. 

* 

Table 19-5 • User Interface Configurations

Name
Possible 
Values Description Rqd
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User Name Length 4 or specify Minimum length of characters allowed for 
a user ID by default implementation. 

* 

FlexNet User 
Authenticator 

Either:

com.flexnet.platform.services.
userManagement.FLEXnetUserIdVa
lidator

or specify another

Class for additional FlexNet user 
authentication checks. 

FlexNet User 
Password Validator 

Either:

com.flexnet.platform.services.
userManagement.FLEXnetUserIdVa
lidator

or specify another

Default Implementation class for user 
password validation. 

* 

User Password 
Length 

4 or specify Minimum number of characters allowed 
for a user password by default 
implementation.

* 

User Password 
Requires Uppercase 
Character

Selected or unselected Select to enable uppercase character 
requirement for a user password by 
default implementation.

Default: unselected

 

User Password 
Requires Numeric 
Character 

Selected or unselected Select to enable the requirement that a 
user password requires a number.

Default: unselected

 

Temporary Password 
Timeout

240 or specify The amount of time, in minutes, for which 
a system-generated, temporary password 
is valid. (FlexNet Operations generates 
temporary passwords for new users and 
for users who forget their password.) The 
timeout period starts when the password 
is generated. 

For permanent (non-expiring) temporary 
passwords, set Temporary Password 
Timeout to 0. 

Default: 240 minutes (4 hours).

* 

Table 19-6 • Validator Configurations
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Configuring System Settings
A user must be assigned a role with the View and Manage Configurations permission to modify configuration 
settings for FlexNet Operations settings through the Producer Portal. 

Note • Before changing any configuration settings in a working FlexNet Operations instance, it is advisable to 
export the working configuration settings. If there is a problem with the new settings, you have a backup of 
working settings to restore.

Task To change FlexNet Operations-specific configuration settings through the FlexNet Operations Producer Portal

1. Click System > Configure. 

2. Click FlexNet Operations to open the configuration page for FlexNet Operations-specific settings. 

3. View or change the values of the settings below.

4. Click Save Configs to save changes. 

The Producer Portal saves your configuration changes. Keep in mind that before certain settings are active in the 
Producer Portal, FlexNet Operations must be restarted. 

Configuration options for FlexNet Operations appear in the following groups: 

• General Options

• External Services Configuration

• Embedded Device Settings

• Custom Tags

• Renewals

• Customer Growth

• Updates

Note that default values are listed as the first choice. Also, required fields are indicated with an asterisk. Fields 

marked with the  icon require that the FlexNet Platform Server be restarted for their changes to take effect.

General Options
These settings correspond to the General Options section of the FlexNet Operations configuration page in System 
> Configure.    

Table 19-7 • FlexNet Operations: General Option Configurations

Name Possible Values Description Rqd Restart

Max Recently Used 
Records 

4 or specify The number of recently used items 
to display in the product packaging 
pages.

*
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Description Max 
Length 

15 or specify Maximum number of characters in 
the description field displayed in 
tables.

*

Support Center Link http://www.revenera.com/
support.htm
or specify 

URL for your support center that is 
displayed on the Home page. 

*

Communities Link http://community.
revenera.com 
or specify 

URL for a community link. *

ID Generator 
Classname 

com.flexnet.
operations.generator.
OpsEsnGenerator
or specify

Set this parameter to the class that 
implements the 
com.flexnet.operations.publicapi.
IDGenerator interface: It is used to 
generate entitlement IDs, activation 
IDs, and web register keys.

* 

Fulfillment ID 
Generator 
Classname 

com.flexnet.
operations.generator.
OpsFIDGenerator 
or specify

Set this parameter to the Java class 
that implements 
com.flexnet.operations.publicapi.
FulfillmentIDGenerator interface: It 
is used to generate fulfillment IDs 
and consolidated license IDs.

* 

Host ID Validator com.flexnet.operations.
publicapi.HostIDValidator
or specify

Set this parameter to the Java class 
that implements custom validations 
of host IDs.

 

Table 19-7 • FlexNet Operations: General Option Configurations
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Basic IP Address 
Host ID Validation

Selected or unselected Permits or prohibits basic validation 
of IP address values by FlexNet 
Operations. 

Default: Selected. 

When selected, FlexNet Operations 
and the VCG validate the octet 
values of IP addresses according to 
the special host id types validation 
rules.

To disable IP address validation, 
unselect this setting and use a 
version 12.8.0.1 or later VCG 
configured to disable validation for 
internet host IDs. (Some minimal 
validation—requiring numeric values 
or asterisks—still occurs based on 
FlexNet Publisher requirements.)

License File Name license or specify This is the base name used to 
generated names for license files 
based on a custom license 
technology that is saved to disk or 
sent as an email attachment. These 
types of license files do not 
incorporate FlexNet capabilities. The 
default setting is license. If this field 
is left blank, the file name for a non-
FlexNet license file or email 
attachment is license.lic.

If the file name is set by the 
CustomGenerator class in the 
GeneratorResponse object, the 
system uses that file name.

 

Interval to Poll the 
VCG

Value in ms (default 50) After license generation process is 
submitted to VCG, FlexNet 
Operations polls VCG at this interval 
(in milliseconds) to check if license 
generation is complete.

 *

Maximum Time to 
Wait for a Response 
from the VCG

 Value in ms (default 4000) Maximum time (in milliseconds) that 
the server waits for a response from 
a VCG when generating a license.

 *  

Table 19-7 • FlexNet Operations: General Option Configurations
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Maximum Lifetime 
for a VCG Process 

 Number of licenses (default 
50)

Maximum number of licenses that a 
single VCG process generates, after 
which the VCG instance is shut down 
and another one generated.

 *  

Allow License 
Headers and 
Trailers 

Selected or unselected Selecting this allows header and 
trailer text to be entered for 
products.

 

Always Display 
Page Count of 
Search Results

Selected or unselected Determining the number of pages of 
search results is often time 
consuming. Deselect this box to 
prevent automatic display of the 
number of pages returned. This 
reduces the time needed to load the 
landing pages for Entitle Customers, 
Activate Licenses, and Support 
Licenses.

 

Entitlement 
Records per Page 

Number of records (default 
10)

Number of records displayed on the 
Entitle Customers landing page. 
This setting overrides the Default 
Records Per Page setting in the user 
interface configuration.

* 

Use SUPERSEDE or 
SUPERSEDE_SIGN 
Keyword

None (default)

Use SUPERSEDE for 
Upgrade

Use SUPERSEDE for 
Renewal

Use SUPERSEDE for 
upgrade and renewal

Use SUPERSEDE_SIGN for 
Upgrade

Use SUPERSEDE_SIGN for 
Renewal 

Use SUPERSEDE_SIGN for 
upgrade and renewal

Select to use either SUPERSEDE or 
SUPERSEDE SIGN for upgrade or 
renewal of licenses. GCS must 
carefully evaluate the risks before 
setting this flag. Refer to the product 
documentation to understand the 
risks.

Table 19-7 • FlexNet Operations: General Option Configurations
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Show Consolidate 
Licenses 
Functionality 

Selected or unselected Selecting this allows users to see 
functionality related to Consolidate 
Licenses. If you change the flag, you 
must log out and re-login for the 
changes to be effective. 

Override Older 
Fulfillments on Host 
Using 
SUPERSEDE_SIGN 
Keyword

Selected or unselected When fulfillment A is upgraded or 
renewed to create fulfillment B, if 
SUPERSEDE_SIGN keyword is 
enabled, licenses in fulfillment B 
supersede signatures in fulfillment 
A. If fulfillment B is upgraded or 
renewed to fulfillment C and this is 
selected, fulfillment C supersedes 
signatures from fulfillments A and B. 
Ensures that counts provided by 
fulfillment A are disabled even if 
user removes fulfillment B license 
from their server. However, this 
increases length of license line 
(limited to 4096 bytes).

Enable Host ID 
Policies 

Selected or unselected Selecting this allows host ID policies 
to be configured and enforced.

Number of Allowed 
Retries

Number of retries For the createLicense web service 
only: enter an integer value greater 
than zero to retry the createLicense 
transaction if there is a failure due to 
concurrent modification exception.

Allow Multiple 
Owners

Selected or unselected If selected, multiple users are able 
to map a line item, web register key, 
or entitlement to themselves.

Do Not Sort Results 
by Default

Selected or unselected If selected, search results are not 
sorted by Last Modified Date on 
Operations landing pages. 

Show Line Items 
with Zero Copies by 
Default

Selected or unselected Configures the End-User Portal to 
show line items with zero copies 
remaining on the Activatable Items 
and the Manage Entitlements 
pages. 

Default: Unselected.

Table 19-7 • FlexNet Operations: General Option Configurations
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Entitlement 
Certificate File 
Name

EntitlementCertificate.
html or specify

Default file name used for the HTML 
entitlement certificate. The file 
extension should be either .html or 
.htm for browser display.

Email for On-Hold 
Fulfillments or On-
Hold Entitlements

Valid email address Enter an email address to notify 
when On-Hold fulfillment or On-Hold 
Entitlement is generated.

Send Email on Set 
License for On-Hold 
Fulfillments

Selected or unselected Determines whether to send email 
to an end user while a license is set 
for on-hold fulfillments. 

Drop Existing 
Supersede Sign 
Signatures

Selected or unselected When selected, drops old 
SUPERSEDE_SIGN signatures and 
ensures that license length cannot 
exceed 4096 bytes. This feature is 
available in VCG 12.0 or later.

Mapped Users or 
Account Records in 
Create Account and 
User Page

Number of records Number of Mapped User or Account 
records displayed on the Create 
Account and User Page. This setting 
overrides the default Records Per 
Page setting in the User Interface 
configuration.

* 

Filter UMN1 Keys One or more UMN1 values In some rare scenarios (For 
example, client machines using 
RAID disks), the UMN1 value is not 
unique. In these cases, UMN1 value 
is being set as the model type of the 
client machine, rather than its disk 
serial number. As UMN1 is treated 
as a primary identifier for re-
installation requests, non-unique 
UMN1 values can lead to problems 
during reinstalls, returns and 
rehosts. In these cases, the machine 
identifier (MID) is a better host 
identifier. This parameter can be set 
to a comma separated list of UMN1 
values. If the trusted storage 
activation request contains any of 
these values, FlexNet Operations 
ignores the UMN1 value and uses 
the MID instead.

Table 19-7 • FlexNet Operations: General Option Configurations
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Add Default 
Comment Line in 
License File

Selected or unselected For FlexNet license files containing 
non-ASCII characters, the first line in 
the license file must be a comment 
line. This comment line is added by 
default by FlexNet Operations. If this 
comment line is causing issues with 
downstream applications, deselect 
this setting.

Enable Product 
Lines for Products, 
Users, and 
Accounts

Selected or unselected If selected, the Product Line feature 
is enabled for products, users, and 
accounts, including visibility 
restrictions for users and accounts. 

Producers can define product lines, 
assign products to product lines, 
and link producer accounts and 
customer user accounts with those 
product lines.

When this setting is enabled, End-
User Portal views are filtered to 
show only entitlement line items for 
products in product lines to which 
the user’s account is linked.

To enable product lines functionality 
without enforcing visibility 
restrictions, deselect this setting 
and check Enable Product Lines for 
Products, instead.

Default: Unselected.

Bulk Operation 
Batch Size

Number of records The number of SQL statements to 
group as a batch during a bulk 
operation. 

* 

Line Items Page 
Size per 
Entitlement

10 or specify Maximum number of line items 
loaded for each entitlement in page. 
If number of line items exceeds 
maximum, a more... link enables the 
others to be displayed. Setting value 
to -1 loads all line items associated 
with entitlement.

* 
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Bulk Operation 
‘Select All Line 
Items’ Batch Size

Number of records The number of entitlement line items 
to group as a batch.

* 

Bulk Operation 
Retry

Number of attempts Number of times to retry a bulk 
operation.

* 

Bulk Operation 
Retry Sleep Interval

Number of seconds The time, in seconds, to sleep before 
retrying a bulk operation.

* 

Default Country for 
Users and Account 
Addresses

Unspecified or a two-letter 
country code (as specified 
by ISO 3166 guidelines)

A two-character country code that 
FlexNet Operations uses as the 
default country for users and 
accounts. Use Unspecified if you do 
not want FlexNet Operations to 
supply a default value.

* 

Allow Editing of 
Deployed Entities

Selected or unselected Permits some modification of 
product, suite, feature bundle, 
entitlement, and line item attributes 
post-deployment. 

Default: Unselected. 

When enabled, editing of the 
following elements is possible: 

• Products: name, version, 
package name, package 
version, feature/feature bundle 
list (can add to, or remove from 
list), and Can be used on a 
device? setting.

• Suites: name, version, package 
name, package version, product 
list (can add to, or remove from 
list), and Can be used on a 
device? setting.

• Feature bundles: name, version, 
and feature list (can add to, or 
remove from list).

• Entitlements

• Line items

Note that inactive or obsolete 
entities cannot be changed. 
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Send Email When 
New Entitlement Is 
Created After Split

Selected or unselected Configures FlexNet Operations to 
send a notification email when a 
new entitlement is created as the 
result of a split. (Entitlements can be 
split, by publisher and partner users, 
on the End-User Portal.)

Default: Selected.

By Default Show 
Product 
Information in the 
Select Host Page

Selected or unselected Shows product information on the 
Select License Host page (part of 
the Generate License wizard), both 
in the Producer Portal and in the 
End-User Portal. When you hide the 
product information FlexNet 
Operations still provides a link that, 
when clicked, shows the product 
information for a specific host.

Default: Selected.

Default Operator 
Used for Simple 
Search

Contains (default) 
Equals 
Starts With 
Ends With

Sets the default operator for simple 
searches in the Producer Portal. 

Always Attach 
Entitlement 
Certificate in Email

Selected or unselected Select to attach entitlement 
certificate in email.

Enable Product 
Lines for Products

Selected or unselected. Show or hide product lines 
functionality for products only. No 
visibility restrictions for users and 
accounts are applied. 

When this setting is selected, 
producers can define product lines, 
assign products to product lines

Requires that the configuration 
setting for Enable Product Lines for 
Products, Users, and Accounts be 
unselected. 

Default: Selected.
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Cloud License 
Service URL

test or specify The URL used when auto-
provisioning a Cloud Licensing 
Service instance during entitlement 
creation. Intended to be used in 
entitlement creation emails.

Data Extract File 
Location

flexnet-data\site or 
specify

The relative path to the location 
where the output (artifact files) of 
optional data extract jobs are stored. 

For Data Extract File Location, 
specify a valid path on the local file 
system.

For more information about 
scheduling data extract jobs, see 
Administering Alerts.

Auto upgrade batch 
size

10 or specify Number of line items to be 
processed in a single transaction 
during automatic product upgrade. 
Defaults to 10.

Highlight Latest 
Upgrade Line Items

Selected or unselected By default, show only line items for 
the most recent version in the 
End-User Portal’s List Entitlements 
page and Map Entitlements page. 
Related, older version are grouped 
under the most recent version when 
related, older versions are available. 

When Highlight Latest Upgrade Line 
Items is unselected, the List 
Entitlements page and Map 
Entitlements page show a mixed, 
flat list of line items—including 
parent line items and older versions 
along with the most recent version. 

Default: Selected. 
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Enable User 
Expiration

Selected or unselected Enables an expiration date when a 
user no longer has access to an 
account. This is applicable to all 
users except:

• Contacts

• Shared login users

• Super admin

• LDAP users

To disable the expiration date for all 
users, unselect the box. This 
prevents all users’ account access 
from expiring.

Show environment 
with email subject

Selected or unselected Enables the addition of the 
environment in the subject of the 
email. If selected the name of the 
environment (UAT, CI, QA, etc., 
except PROD or DR) that triggered 
the email will be included in the 
subject line.

Default: Unselected.

Show maintenance 
line items custom 
attributes in 
Entitlements Page

Selected or unselected Controls whether custom attributes 
for maintenance lines are visible in 
the Producer Portal and End-User 
Portal in the following locations:

• on the List Entitlements and List 
Entitlements By Order pages

• on the Maintenance Line Item 
Details panel

Default: Unselected (custom 
attributes for maintenance lines are 
not visible).
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Apply Manage 
Users permission to 
users in shared 
accounts

Selected or unselected Manages the behavior when a 
customer user belongs to more than 
one account.

If selected, a customer user logged 
in at the End-User Portal has 
Manage Users permissions (view, 
edit, reset password, link or remove 
an account) for other customer 
users that belong to the same 
account.

Default: Unselected

Verify user ID 
validity during 
password reset

Selected or unselected If selected, the validity of the user ID 
is verified, and the user is only 
prompted to reply to a security 
question if they entered a valid user 
ID. If the entered user ID is invalid, 
an error is displayed.

If unselected, the behavior is the 
same for valid and invalid user IDs: 
the user is prompted to select the 
answer to a security question. (If the 
entered user ID is invalid, a random 
question is displayed.)

Default: Unselected

Table 19-7 • FlexNet Operations: General Option Configurations

Name Possible Values Description Rqd Restart



Chapter 19 Configuring FlexNet Operations
Performing System Configuration

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 651

Allow used 
entitlement/line 
item state change 
to Inactive or 
Obsolete

Selected or unselected Controls whether entitlements or 
line items that have been activated 
on a device can have their state 
changed to Inactive or Obsolete.

When not selected, attempting to 
change such an entitlement’s or line 
item’s state to Inactive or Obsolete 
triggers an error message. The state 
can only be changed after the 
entitlement or line item has been 
unmapped from the device.

When this configuration option is 
selected, an entitlement or line item 
that has been activated on a device 
can still be used until the license 
expires, even if the entitlement or 
line item has been deactivated or 
made obsolete.

Default: Selected.

Preserve Product 
Custom Attributes 
when changing a 
Product Line

Selected or unselected Manages the behavior when a 
product line for a given product is 
changed. 

If selected, all custom attributes for 
a given product are preserved if the 
product line for the product is 
changed.

Default: Selected.

Process all line 
items in an 
Entitlement during 
Batch Rehost

Selected or unselected If selected, all line items in the 
entitlement are included for 
processing during batch rehost. In 
scenarios where a large number of 
line items are associated with a 
single entitlement, selecting this 
option might significantly increase 
the time required for processing the 
batch rehost.

If unselected, only the default 
number of 10 line items are included 
for processing during batch rehost.

Default: Unselected.

Table 19-7 • FlexNet Operations: General Option Configurations

Name Possible Values Description Rqd Restart
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External Services Configuration
These settings correspond to the External Services Configuration section of the FlexNet Operations configuration 
page in System > Configure.  

Table 19-8 • FlexNet Operations: External Service Configurations

Name Possible Values Description Rqd Restart

Notification 
Classname

Set to class implementing the 
com.flexnet.operations.notificati
on.EntityNotifier interface. Used to 
process notifications when certain 
entities are created, updated, or 
deleted.

RabbitMQ URL Specify valid URL URL used by notification framework 
(including login credentials and 
virtual host) in <protocol>://
<hostname>:<port> format. 

RabbitMQ 
Exchange Name 

fno.public.transactions or 
specify

Exchange name used by notification 
framework.

License Fulfillment 
Service URL

Specify valid URL URL used by license fulfillment 
framework in <protocol>://
<hostname>:<port> format.

FlexNet Operations 
Cloud URL

Specify valid URL URL for the FlexNet Operations Cloud 
replication service endpoint in 
<protocol>://<hostname>:<port> 
format.

Windows VCG 
Service URL

Specify valid URL URL for the Windows VCG service 
endpoint in <protocol>://
<hostname>:<port> format.

Linux VCG Service 
URL

Specify valid URL URL for the Linux VCG service 
endpoint in <protocol>://
<hostname>:<port> format.

Usage Analytics 
Service URL

Specify valid URL URL for the usage analytics service 
endpoint in <protocol>://
<hostname>:<port> format.

*

Electronic Software 
Delivery Host Name

Specify valid hostname Electronic Software Delivery 
hostname in <protocol>://
<hostname>:<port> format.
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End-User Portal 
Host Name

Specify valid hostname End-User Portal hostname in 
<protocol>://<hostname>:<port> 
format.

*

Electronic Software 
Delivery Service 
URL

Specify valid URL URL of Electronic Software Delivery 
Service endpoint.

Custom License 
Generator Host

Specify valid host Custom License Generator Host as 
protocol://host:port. This value 
can be referenced as 
{CUSTOM_TECH_HOST} in Custom 
License Technology URL.

CMS Consumer 
Queue Name

ops.cms.consumer or specify Name of the CMS consumer queue in 
RabbitMQ.

* 

Base FNOC 
Consumer Queue 
Name

ops.fnoc.consumer or 
specify

Base name of the tenant specific 
queue in RabbitMQ, which is 
concatenated with the tenantid to 
form the full queue name.

* 

Audit Trail Queue 
Name

ops.audit.consumer or 
specify

Name of the audit trail queue in 
RabbitMQ.

* 

Use Soap Service 
for VCG

Selected or unselected Select to use the SOAP service for 
secure license generation, instead of 
the Windows VCG Service or the 
Linux VCG Service.

Default: Unselected.

VCG Service soap 
URL

Valid URL The URL of the SOAP service hosted 
by the producer. FlexNet Operations 
must be able to access this over the 
internet.

VCG Service User 
Name

Valid user name in the 
format domain/username

The user name used to authenticate 
the SOAP service for generating the 
secure license.

VCG Service User 
Password (Confirm)

The password for the user name 
used to authenticate the SOAP 
service for generating the secure 
license.

Table 19-8 • FlexNet Operations: External Service Configurations

Name Possible Values Description Rqd Restart
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Embedded Device Settings
These settings correspond to the Embedded Device Settings section of the FlexNet Operations configuration 
page in System > Configure.   

VCG service 
credential in SOAP 
request header

If selected, users are authenticated 
using SOAP header-based 
authentication instead of basic http 
authentication.

Only available if Use Soap Service for 
VCG is selected.

Default: Unselected.

Table 19-9 • FlexNet Operations: Embedded Device Settings

Name Possible Values Description Rqd Restart

Allow Adding 
Backup Server for 
Producer

Selected or unselected Allow or prevent adding backup servers 
via web services and Producer Portal. 

 

Server Deployment 
Choice

Local
Cloud
Both

Select whether FlexNet Embedded server 
deployments can be local, cloud, or both.

 

Skip Account Check 
– for hosts (see 
next row for 
devices) 

Selected or unselected Hosts: If selected, allows a host to have 
line items belonging to other accounts 
also. 

 

Table 19-8 • FlexNet Operations: External Service Configurations
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Skip Account Check 
– for devices (see 
previous row for 
hosts) 

Selected or unselected Devices: Controls sharing of devices 
across accounts. By default, FlexNet 
Operations applies rules to limit the 
mapping of entitlements to devices 
based on the device owner account. 

Generally, enabling Skip Account Check 
permits entitlements that belong to 
accounts other than the device owner 
and its sub-accounts to be mapped to a 
device. (See About Device Management 
for more information.)

Unselected (Default)

The FlexNet Embedded license generator 
executes the activation request when 

• the device is owned by the same 
account as activation ID 

• the device is owned by the parent 
account and the activation ID is 
owned by one of its child accounts

The FlexNet Embedded license generator 
produces an error when the activation ID 
is owned by the parent account and the 
device is owned by one of its child 
accounts.

Selected 

The FlexNet Embedded license generator 
executes the activation request without 
regard to the account that owns the 
device.

Auto-provision 
error email 
recipient(s)

Valid email address Comma-separated email IDs that receive 
any error emails related to auto-
provisioning.

Device user option Off (default)
On with no validation
On with validation 

Select to offer the option to assign a user 
to a device, as well as whether the 
system checks the validity of the user. 

 

Override license 
expiration date

Selected or unselected If selected, allows user to shorten license 
expiration term.

 

Table 19-9 • FlexNet Operations: Embedded Device Settings
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Custom Tags
These settings correspond to the Custom Tags section of the FlexNet Operations configuration page in System > 
Configure.    

Renewals
These settings correspond to the Renewals section of the FlexNet Operations configuration page in System > 
Configure. For producers who use FlexNet Operations with the FlexNet Customer Growth module, these settings 
determine how FlexNet Operations behaves when the Expiring Entitlements job or Expired Entitlements job runs. 
These settings are required for producers who use FlexNet Operations with the FlexNet Customer Growth module; 
otherwise, they are not used.

Enable Producer 
User for CLS

Selected or unselected If selected, allows a user to reset the 
Cloud Licensing Service producer user 
password for both existing and future 
Cloud License Server (CLS) instances. 
This producer password can be used to 
obtain Authorization tokens for all 
instances.

Producer User’s 
Password for CLS 
(Confirm)

Password fulfilling the 
requirements

The Cloud Licensing Service password 
must fulfill the following requirements:

• 8-30 characters

• 1 uppercase character

• 1 lowercase character

• 1 digit

• 1 of the following special characters: 
( ^*$-+?_&=!%{}/# )

• No spaces

Table 19-10 • FlexNet Operations: Custom Tag Configurations

Name Possible Values Description Rqd Restart

Last in Head Custom script tags added here are inserted 
last in the document <head/> of the Producer 
Portal.

Last in Body Custom script tags added here are inserted 
last in the document <body/> of the Producer 
Portal.

 

Table 19-9 • FlexNet Operations: Embedded Device Settings
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Note • For more information about using the Expiring Entitlements and Expired Entitlements jobs, see 
Administering Alerts.  

Table 19-11 • FlexNet Operations: Renewal Configurations

Name Possible Values Description Rqd
Restar
t

Renewal 
Look Ahead

200 or specify.

Default: 200 days.

The number of days in the future, including the 
day the Expiring Entitlements job runs, to search 
for entitlements to include in the Renewal 
Reminder email message. 

This value is also used as the upper limit for line 
items that appear on the Expiring Entitlements 
page in the End-User Portal. Those entitlements 
with expiration dates further out than the 
Renewal Look Ahead are excluded from the list.

Note • This setting is also used to limit the 
number of expired entitlements shown on pages 
that list expired entitlements. Entitlements that 
are more than 200 days (using the default 
setting) past their expiration date are not shown. 

Tip • The Renewal Look Ahead value must be 
greater than the Expiring Window value.

* 
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Expiring Window 90 or specify.

Default: 90 days. 

The number of days in the future, including the 
day the Expiring Entitlements job runs, to search 
for entitlements that are soon to expire. 

Together with the Expiring Email Frequency, 
Expiring Window determines whether or not 
FlexNet Operations sends a Renewal Reminder 
email message. See More About the Expiring 
Entitlements Job for details.

This value and the Renewal Critical value 
determine the way line items are highlighted on 
the Expiring Entitlements page in the End-User 
Portal. Line items that expire in the span 
between the Renewal Critical setting and the 
Expiring Window setting are highlighted in 
yellow.

Tip • The Expiring Window value must be smaller 
than the Renewal Look Ahead value.

*  

Expiring Email 
Frequency

30 or specify.

Default: 30 days.

The minimum number of days to wait before 
sending out the next Renewal Reminder email 
message to a particular account. 

For example, using the default system 
configuration settings, FlexNet Operations limits 
the number of renewal reminders sent to an 
account to one every 30 days. 

Together with the Expiring Window, Expiring 
Email Frequency determines whether or not 
FlexNet Operations sends a Renewal Reminder 
email message. (Renewal Reminder email 
messages are based on the Renewal Reminder 
email template.) 

See More About the Expiring Entitlements Job for 
details.

*

Table 19-11 • FlexNet Operations: Renewal Configurations

Name Possible Values Description Rqd
Restar
t
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Expired Email 
Frequency

30 or specify.

Default: 30 days.

The minimum number of days to wait before 
sending out the next expired entitlements 
message to a particular account. 

If FlexNet Operations has sent an expired 
entitlements message to an account within the 
number of days specified, no new email 
messages are sent, even if newly expired 
entitlements are discovered when the Expired 
Entitlements job runs. (Expired entitlements 
messages are based on the Renewal Reminder 
for Expired Entitlements email template.) 

See More About the Expired Entitlements Job for 
details.

*

Renewal Critical 30 or specify.

Default: 30 days.

Number of days from an entitlement’s expiration 
date to mark the entitlement as critical. 

This value and the Expiring Window value 
determine the way line items are highlighted on 
the Expiring Entitlements page in the End-User 
Portal. Line items that expire within the number 
of days specified in the Renewal Critical setting 
are highlighted in red.

*

Request Renewal 
Notification Email

Valid email address An email address, managed by the producer, to 
which an end user’s intent-to-renew messages 
are sent.

In the End-User Portal, the Expiring Entitlements 
page includes a Request button. When an end 
user selects expiring entitlements and clicks 
Request, the End-User Portal sends an intent-to-
renew message (based on the Renewal Intent for 
End Customer email template) to the email 
address you specify here.

Request Renewal Notification Email is optional. 

The Renewal Callout and the Request Renewal 
Notification Email are not mutually exclusive. If 
both are present, FlexNet Operations runs the 
callout code and sends an email to the address 
indicated by Request Renewal Notification Email. 
If neither setting has a value, the Request button 
is suppressed in the End-User Portal.

Table 19-11 • FlexNet Operations: Renewal Configurations

Name Possible Values Description Rqd
Restar
t
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Customer Growth
These settings correspond to the Customer Growth section of the FlexNet Operations configuration page in 
System > Configure.

Renewal Failed 
Notification Email

Valid email address An email address to which FlexNet Operations 
sends renewal notifications when an account 
with expiring or expired entitlements has no end 
users who have subscribed to receive renewal 
reminders. Producers can use this address to 
receive the renewal reminders on behalf of their 
customer accounts. 

Renewal Callout Classname or URL Optionally identify a callout to use when an end 
user clicks the Request button on the End-User 
Portal’s Expiring Entitlements page. Specify a 
callout as an external SOAP endpoint that 
implements the RenewalService interface. (Click 
the Test Connection button to verify connectivity 
between FlexNet Operations and your endpoint.).

The Renewal Callout and the Request Renewal 
Notification Email are not mutually exclusive. If 
both are present, FlexNet Operations runs the 
callout code and sends an email to the address 
indicated by Request Renewal Notification Email. 
If neither setting has a value, the Request button 
is suppressed in the End-User Portal. 

Version • Sample implementations are available 
in the site/samples/renewal folder.

Table 19-12 • FlexNet Operations: Customer Growth Configurations

Name Possible Values Description Rqd Restart

Consumption 
Thresholds  
(Low,High)

0-100,0-100

Default: 30,70

The low and high markers for service 
consumption levels. Consumption is 
considered unhealthy if below the 
low threshold and very healthy if at 
or above the high threshold. 

Table 19-11 • FlexNet Operations: Renewal Configurations

Name Possible Values Description Rqd
Restar
t



Chapter 19 Configuring FlexNet Operations
Performing System Configuration

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 661

Updates
These settings correspond to the Updates section of the FlexNet Operations configuration page in System > 
Configure. 

Configuring Trusted Activation Settings 
A user must be assigned a role with the View and Manage Configurations permission to modify configuration 
settings for Trusted Activation settings through the Producer Portal. 

Note • Before changing any configuration settings in a working FlexNet Operations instance, it is advisable to 
export the working configuration settings. If there is a problem with the new settings, you have a backup of 
working settings to restore.

Renewal Health 
Thresholds 
(Low,High)

0-100,0-100

Default: 30,70

The low and high markers for a 
customer's renewal health. A low 
renewal health score is indicative of 
a risky renewal. A renewal health at 
or above the high mark translates to 
a high probability of the renewal. 

 

Account Health 
Thresholds 
(Low,High)

0-100,0-100

Default: 30,70

The low and high markers for an 
account's overall health. The 
account is considered unhealthy if 
below the low threshold and very 
healthy if at or above the high 
threshold. 

Alert Period 0-30

Default: 5

The period in days to wait before 
generating another alert for the 
same account and score type.

Enable running 
health aggregation 
job on demand

Selected or unselected Enables the health aggregation job 
to be run for this specific tenant on 
demand.

Table 19-13 • FlexNet Operations: Updates Configurations

Name Possible Values Description Rqd Restart

Platforms Comma separated list of custom 
platforms which are available for an 
Update when defining the Release 
To packages. 

Table 19-12 • FlexNet Operations: Customer Growth Configurations

Name Possible Values Description Rqd Restart
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Task To configure trusted activation settings

1. Click System > Configure. 

2. Click Trusted Storage to open the configuration page for trusted activation.

3. View or change the values of the settings below.

4. Click Save Configs.

The Producer Portal saves your configuration settings. Required fields are indicated with an asterisk.  

Table 19-14 • Trusted Storage Configurations

Name Possible Values Description Rqd Restart

Do not delete Generated 
Trusted Configurations, 
ASRs, and Key Files

Selected or 
unselected

Select to prevent the deletion of 
generated files stored in <User Data 
Directory as configured in the 
configurator> store. These files are 
generated when the first activation is 
requested using a new transaction key. 

Load Web Register Keys as 
Part of Trusted Type Bulk 
Entitlements Activation

Selected or 
unselected

Select to prevent pre-loading of web 
register keys for bulk entitlements using 
a trusted license model. Web register 
keys are loaded dynamically at the time 
of activation. This setting does not 
affect bulk entitlements using a 
certificate-based license models. Those 
web register keys are always pre-
loaded.

Enable Bulk Entitlement 
Linking while Creating Short 
Code

Selected or 
unselected

Select to link a bulk entitlement when 
creating a short code ASR. This only 
allows keyboard (short code) activation 
with bulk entitlement.

Unwrap License Lines for 
Trusted Activations

Selected or 
unselected

In some network transport scenarios, 
new line between INCREMENT lines in 
trusted storage response XML file is 
stripped during transport, causing 
license to be invalid. In these cases, 
license is not applied to trusted storage. 
Select to remove new lines from license 
and sign response to prevent this 
problem. 
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Enable Internet Address 
Binding

Selected or 
unselected

Determines whether or not to use 
internet address as one of the binding 
elements for every transaction key 
created. 

Caution • Use caution when changing 
this configuration option. Changing the 
binding elements may change trusted 
configurations and fulfillment records 
on your end users’ machines. Such 
changes can result in otherwise 
unnecessary repair requests.

Default: Unselected.

Send Host Address and Port 
Number in the Activation 
Response

Selected or 
unselected

Determines whether or not activation 
responses include a host address and 
port number. 

Default: Selected.

Generator for Custom 
Attributes in Online 
Response

Class name This class can be used to implement the 
vendor dictionary response, to enable 
sending data back to the activation 
application after fulfillment generation.

Generator for Custom 
Attributes in Short Code 
Response

Class name This class can be used to implement the 
Short Code Response Overrides 
Generator to populate values for the 
short code response override keys that 
are configured in ASR.

Force Default Transaction 
Key for all FNP versions

Selected or 
unselected

Default: unselected

Server Chain Host Name URI or blank Enter a URI in the format protocol://
hostname:port/... which is sent in 
activation responses. If blank, the URI 
sent in the activation responses is the 
actual server name.

Default: blank.

Table 19-14 • Trusted Storage Configurations

Name Possible Values Description Rqd Restart
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Configuring Public Services Settings
A user must be assigned a role with the View and Manage Configurations permission to modify configuration 
settings for Public Services settings through the Producer Portal. 

Public Services are described in detail in the FlexNet Operations On-Premises Installation & Implementation 
Guide. 

Note • Before changing any configuration settings in a working FlexNet Operations instance, it is advisable to 
export the working configuration settings. If there is a problem with the new settings, you have a backup of 
working settings to restore.

Task To configure public services settings

1. Click System > Configure. 

2. Click Public Services to open the configuration page for public services settings.

3. View or change the values of the settings below.

4. Click Save Configs.

The Producer Portal saves your configuration changes.  

Add Version in Product ID Selected or 
unselected

Select to add version information as 
part of product ID in 
NAME=PRODUCT;VERSION=PROD_VERSION 
format.

Default: Selected

Enable short code for license 
server

Selected or 
unselected

Select to create short code for a license 
server.

Default: unselected

Table 19-15 • Public Service Configurations

Name Possible Values Description Rqd

Publish LineItemDetails 
Public Service

Selected or 
unselected

Select to enable an activation application to query 
for line item information based on activation ID.

Publish EntitlementDetails 
Public Service

Selected or 
unselected

Select to enable activation application to query for 
entitlement information based on entitlement ID.

Table 19-14 • Trusted Storage Configurations

Name Possible Values Description Rqd Restart
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 Configuring Export and Import Settings
A user must be assigned a role with the View and Manage Configurations permission to modify configuration 
settings for Export and Import settings through the Producer Portal. 

Note • Before changing any configuration settings in a working FlexNet Operations installation, it is advisable to 
export the working configuration settings. If there is a problem with the new settings, you have a backup of 
working settings to restore.

Task To configure export and import settings

1. Click System > Configure. 

2. Click Import/Export Settings to open the configuration page for export and import settings.

3. View or change the values of the settings below.

4. Click Save Configs.

The Producer Portal saves your configuration changes.   

Publish registerUser Public 
Service

Selected or 
unselected

Select to enable the activation application to 
create a user object in the FlexNet Operations 
database and map that user to an activatable item. 

Publish mapEntitlement 
Public Service

Selected or 
unselected

Select to enable the activation application to map 
activatable items to users.

Public Services Response 
Generator Classname

Class name Producers can choose information sent in 
response to EntitlementDetails and 
LineItemDetails public services. Set this parameter 
to the class that implements the interface 
com.flexnet.operations.public.api.PublicServic
esResponseGenerator.

*

Table 19-16 • Import/Export Setting Configurations

Name
Possible 
Values Description Rqd

Features per File 100 or 
specify

Maximum number of features per file during export. * 

Feature Bundles per File 100 or 
specify

Maximum number of feature bundles per file during 
export.

* 

Table 19-15 • Public Service Configurations

Name Possible Values Description Rqd
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License Technologies per File 100 or 
specify

Maximum number of publishers listed in one export 
file before a new XML file is created.

* 

Publishers per File 100 or 
specify

Maximum number of feature bundles per file during 
export.

* 

Custom Attributes per File 100 or 
specify

Maximum number of custom attributes allowed per 
file during export.

* 

License Generator 
Configurations per File

100 or 
specify

Maximum number of license generator 
configurations allowed per file during export.

* 

License Models per File 100 or 
specify

Maximum number of license models allowed per file 
during export.

* 

Products per File 100 or 
specify

Maximum number of products allowed per file 
during export.

* 

Part Numbers per File 200 or 
specify

Total number of part numbers allowed per file during 
export.

* 

Transaction Keys per File 200 or 
specify

Maximum number of transaction keys allowed per 
file during export.

* 

Product Relationships per File 200 or 
specify

Maximum number of product relationships allowed 
per file during export.

* 

Uniform Suites per File 100 or 
specify

Maximum number of uniform suites allowed per file 
during export.

* 

Maintenances per File 100 or 
specify

Maximum number of maintenances allowed per file 
during export.

* 

Web Register Keys per File 100 or 
specify

Maximum number of web register keys allowed per 
file during export.

* 

Bulk Entitlements per File 100 or 
specify

Maximum number of bulk entitlements allowed per 
file during export.

* 

Simple Entitlements per File 100 or 
specify

Maximum number of simple entitlements listed in 
one export file before a new XML file is created.

* 

Fulfillments per File 100 or 
specify

Maximum number of fulfillments allowed per file 
during export.

* 

Table 19-16 • Import/Export Setting Configurations

Name
Possible 
Values Description Rqd
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See Also
Performing System Configuration
Exporting a Configuration
Importing a Configuration

Configuring End-User Portal Settings 
A user must be assigned a role with the View and Manage Configurations permission to modify configuration 
settings for the End-User Portal through the Producer Portal. 

Note • Before changing any configuration settings in a working FlexNet Operations instance, it is advisable to 
export the working configuration settings. If there is a problem with the new settings, you have a backup of 
working settings to restore.

This section includes the following sub-sections with instructions for changing End-User Portal settings and 
descriptions of different End-User Portal setting groups: 

• Changing End-User Portal Settings

• General Options

• Login Page

• Portal Navigation

• End-User Portal Home Page

• Entitlements Page

• Bulk Entitlements Page

• License Support Page

Line Items per File 100 or 
specify

Maximum number of line items allowed per file 
during export.

* 

Consolidated Licenses per File 100 or 
specify

Maximum number of consolidated licenses allowed 
per file during export.

* 

Account Units per File 200 or 
specify

Maximum number of account units allowed per file 
during export.

* 

Number of Errors per File 200 or 
specify

Maximum number of error messages listed in one 
file during import.

* 

I/O Buffer Size Size in KB Size, in kilobytes, of the input/output buffer size to 
read XML files during import. 

* 

Table 19-16 • Import/Export Setting Configurations

Name
Possible 
Values Description Rqd
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• Devices Page

• Downloads Page

• Recent Releases

• Recent Files Page

• Download Order Page

• Download Packages Page

• Manage Accounts & Users

• Custom Branding

• Custom Tags

Changing End-User Portal Settings
Follow the instructions, below, to change the settings that govern the appearance and behavior of your End-User 
Portal. 

Task To configure the End-User Portal

1. Click System > Configure. 

2. Click End-User Portal Setup to open the configuration page for the End-User Portal. 

3. Make any setting changes that suit your configuration needs. Consult the tables, below, for additional 
information about the settings in each section.

4. Click Save Configs to save changes. 

The Producer Portal saves your configuration changes.

General Options
These settings correspond to the General Options section of the End-User Portal Setup page in System > 
Configure.    

Table 19-17 • End-User Portal: General Options Configurations

Name
Possible 
Values Description Rqd

Transferred Items 
Set to On Hold

Selected or 
unselected

Set the state of items transferred in the End-User Portal to On 
Hold and send an email to the FlexNet Operations administrator 
to approve the transfer by releasing the hold.

 

Enable Auto Login Selected or 
unselected

Select to enable an end user to log in to the portal by passing an 
activation ID or entitlement ID in the login URL.

 

Hide Header Selected or 
unselected

Hides the header in all pages of portal. Select to enable when 
End-User Portal is embedded into an external portal.
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Skip Home Page Selected or 
unselected

Skips the Home page after a user logs in and proceeds directly 
to the List Entitlements page.

Resource Bundle 
Time-to-Live

30 or specify Reload the resource bundle cache at this time interval 
(minutes). Specify the number of minutes between resource 
bundle cache reloads.

* 

Enable Self-
Registration for an 
existing Account

Selected or 
unselected

Select to enable an end user to be associated with an existing 
Self-Registered account when they self-register in the End-User 
Portal  with an entitlement ID or activation ID.

Enable terms and 
conditions panel

Selected or 
unselected

Show or hide the Privacy Terms and Conditions link on the 
Register for Account page for self-registering users. If enabled, 
users are reminded to read the privacy terms and conditions 
when they click Complete on the Register for Account page. 
When a user clicks the link, the Privacy Terms and Conditions 
are opened in a new tab. Customers are not required to 
acknowledge that they have read the Privacy Terms and 
Conditions.

Terms and 
conditions URL

Specify If you selected Enable terms and conditions panel, enter the 
URL to the Privacy Terms and Conditions that a self-registering 
user should read before registering.

Show Download 
Button

Selected or 
unselected

Show or hide the Download button on the Downloads tab on the 
device’s default view. If selected, the Download button enables 
a user to download entire download packages or individual files 
contained in a download package. 

Requires that the configuration setting Hide Download 
Manager (in the Downloads Page section) be unselected and 
Show Downloads Tab (in the Devices Page section) be selected.

Default: Unselected.

Version • This setting is only available for producers who use 
the Software Delivery module.

Table 19-17 • End-User Portal: General Options Configurations

Name
Possible 
Values Description Rqd
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Login Page
These settings correspond to the Login Page section of the End-User Portal Setup page in System > Configure.   

Portal Navigation
The settings correspond to the Portal Navigation section of the End-User Portal Setup page in System > 
Configure.   

Table 19-18 • End-User: Portal Login Page Configurations

Name
Possible 
Values Description Rqd

Hide Register Link Selected or 
unselected

Hides the Register link for self-service registration near Log In.  

Hide Log in With 
Entitlement ID 
Option 

Selected or 
unselected

Hides With Entitlement ID link in the login page.

Important • Hiding any two login methods removes the option 
box from the login form.

 

Hide Log in With 
Activation ID 
Option 

Selected or 
unselected

Hides With Activation ID link in the login page.

Important • Hiding any two login methods removes the option 
box from the login form.

 

Hide Log in With 
User Name Option

Selected or 
unselected

Hides With User Name link in the login page.

Important • Hiding any two login methods removes the option 
box from the login form.

Table 19-19 • End-User Portal: Navigation Configurations

Name
Possible 
Values Description Rqd

Hide Top-level 
Navigation 

Selected or 
unselected

Hides the top-level navigation/menu in all pages of portal. 
Select to hide navigation/menu when End-User Portal is 
embedded into an external portal.

Hide System Help Selected or 
unselected

Hides the system help links in the top-level navigation.

Hide Home Button Selected or 
unselected

Hides Home in the top-level navigation.
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End-User Portal Home Page
These settings correspond to the Portal Home Page section of the End-User Portal Setup page in System > 
Configure.  

Hide Activation & 
Entitlements Menu

Selected or 
unselected

Hides the Activation & Entitlements menu in the top-level 
navigation.

Hide Claim 
Activation IDs Link

Selected or 
unselected

Hides the Claim Activation IDs link in the Activation & 
Entitlements menu.

Hide Devices Menu Selected or 
unselected

Hides the Devices menu in the top-level navigation.

Hide Accounts & 
Users Menu

Selected or 
unselected

Hides the Accounts & Users menu in the top-level navigation.

Hide Host Transfer 
Jobs Link

Selected or 
unselected

For customer users, hides the Host/Device Transfer Jobs links 
in the License Support menu.

Hide Downloads 
Menu

Selected or 
unselected

Hides the Downloads menu in the top-level navigation.

Hide List 
Downloads Link

Selected or 
unselected

Hides the List Downloads link in the Downloads menu.

Hide Recent Files 
Added Link

Selected or 
unselected

Hides the Recent Files Added link in the Downloads menu.

Hide Recent 
Releases Link

Selected or 
unselected

Hides the Recent Releases link in the Downloads menu.

Hide Usage Menu Selected or 
unselected

Hides the Usage menu in the top-level navigation.

Hide License 
Support Menu

Selected or 
unselected

Hides the License Support menu in the top-level navigation.

Table 19-20 • End-User Portal: Home Page Configurations

Name
Possible 
Values Description Rqd

Hide Recent 
Entitlements 
Widget

Selected or 
unselected

Hides the Recent Entitlements panel on the Home page.

Table 19-19 • End-User Portal: Navigation Configurations

Name
Possible 
Values Description Rqd
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Entitlements Page 
These settings correspond to the Entitlements Page section of the End-User Portal Setup page in System > 
Configure.   

Hide Recent 
Releases Widget

Selected or 
unselected

Hides the Recent Releases panel on the Home page. 

Hide Recent Files 
Widget

Selected or 
unselected

Hides the Recent Files panel on the Home page.

Hide Downloads 
Widget

Selected or 
unselected

Hides the Downloads panel on the Home page.

Hide 
Announcements 
Widget

Selected or 
unselected

Hides the Announcements panel on the Home page. See 
Managing Custom Content for information about publishing 
announcements to the home page.

Hide Quick Links 
Widget

Selected or 
unselected

Hides the Quick Links panel on the Home page.

Table 19-21 • End-User Portal: Entitlements Page Configurations

Name
Possible 
Values Description Rqd

Hide Activate Selected or 
unselected

Hides the Actions > Activate link on the Entitlements page.

Hide Trusted 
activate

Selected or 
unselected

Hides the Actions > Trusted activate link on the Entitlements 
page. 

For producers that support only trusted storage activation, 
hiding the Trusted Activate link prevents users from activating 
anything from the End-User Portal. However, the short code 
activation link is still shown and is usable. 

Hide Transfer Selected or 
unselected

Hides the Action > Transfer link on the Entitlements page. 

Hide Split Selected or 
unselected

Hides the Action > Split link on the Entitlements page. 

Hide Short Code 
Activation

Selected or 
unselected

Hides the Action > Short Code Activation link on the 
Entitlements page. 

Table 19-20 • End-User Portal: Home Page Configurations

Name
Possible 
Values Description Rqd
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Bulk Entitlements Page 
These settings correspond to the Bulk Entitlements Page section of the End-User Portal Setup page in System > 
Configure.   

License Support Page
These settings correspond to the License Support Page section of the End-User Portal Setup page in System > 
Configure.   

Hide Print Selected or 
unselected

Hides the View > Print link on the Entitlements page. 

Hide View 
Certificate

Selected or 
unselected

Hides the View > View certificate link on the Entitlements page. 

Hide Email Selected or 
unselected

Hides the View > Email link on the Entitlements page. 

Hide Claim 
Activation IDs

Selected or 
unselected

Hides the Action > Claim Activation IDs link on the Entitlements 
page.

Hide Export Button Selected or 
unselected

Hides the Export button on the Entitlements page.

Show View 
Download 
Packages

Selected or 
unselected

If selected, shows the View > View Download Packages link on 
the Entitlements page.

Default: unselected.

Table 19-22 • End-User Portal: Bulk Entitlements Page Configurations

Name
Possible 
Values Description Rqd

Hide View Web 
Register Keys 
Button

Selected or 
unselected

Hides the View > View Web Register Keys link on the Bulk 
Entitlements page. Default: Unselected.

Table 19-23 • End-User Portal: License Support Page Configurations

Name
Possible 
Values Description Rqd

Hide Return Selected or 
unselected

Hides the Action > Return link on the License Support page.

Table 19-21 • End-User Portal: Entitlements Page Configurations

Name
Possible 
Values Description Rqd
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Hide Rehost Selected or 
unselected

Hides the Action > Rehost link on the License Support page.

Hide Repair Selected or 
unselected

Hides the Action > Repair link on the License Support page. 

Hide Upgrade Selected or 
unselected

Hides the Action > Upgrade link on the License Support page.

Hide Upsell Selected or 
unselected

Hides the Action > Upsell link on the License Support page.

Hide Renew Selected or 
unselected

Hides the Action > Renew link on the License Support page.

Hide Manual 
Return

Selected or 
unselected

Hides the Action > Manual Return link on the License Support 
page.

Hide Manual 
Repair

Selected or 
unselected

Hides the Action > Manual Repair link on the License Support 
page.

Hide Save to File Selected or 
unselected

Hides the View > Save to File on the License Support page.

Hide Email License Selected or 
unselected

Hides the View > Email License link on the License Support 
page.

Hide Shipment 
Records

Selected or 
unselected

Hides the View > Shipment Records link on the License Support 
page.

Hide View 
Fulfillments 
Button

Selected or 
unselected

Hides the View > View Fulfillments button on the License 
Support/Consolidate Licenses page.

Hide Print Selected or 
unselected

Hides the View > Print link.

Hide Export Menu Selected or 
unselected

Hides the Export menu above lists of licenses.

Hide Consolidate 
Link

Selected or 
unselected

Hides the Action > Consolidate link on the License Support 
page.

Hide Verify Selected or 
unselected

Hides the Action > Verify link (shown when user generates a 
license).

Table 19-23 • End-User Portal: License Support Page Configurations

Name
Possible 
Values Description Rqd
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Devices Page
These settings correspond to the Devices Page section of the End-User Portal Setup page in System > Configure.   

Hide Transfer 
Licenses

Selected or 
unselected

Hides the Action > Transfer Licenses link on the License 
Support and Manage Hosts pages. 

Hide Product 
Version Details

Selected or 
unselected

Hides the Product Version details for activatable line items on 
all pages. Select the box to prevent the product version from 
being rendered in the Product column after the product name. 

Hide Batch Rehost Selected or 
unselected

For customer users, hides the Action > Batch Rehost link.

Hide Short Code 
Return 

Selected or 
unselected

Hides the Action > Short Code Return link on the License 
Support page. 

Hide Short Code 
Repair 

Selected or 
unselected

Hides the Action > Short Code Repair link on the License 
Support page. 

Hide List Hosts 
Link

Selected or 
unselected

Hides the List Hosts link in the License Support menu. 

Table 19-24 • End-User Portal: Devices Page Configurations

Name
Possible 
Values Description Rqd

Hide View History 
Button

Selected or 
unselected

Hides View History option on the device’s default view.

Hide Download 
Capability 
Response Link

Selected or 
unselected

Hides the Download Capability Response link in the Action 
menu for the device’s default view and View Server pages.

Allow Standalone 
Device Creation 

Selected or 
unselected

Allows creation of standalone devices in the End-User Portal. If 
Allow Standalone Device Creation and Allow Server Device 
Creation are unselected, the Create Device menu item and 
button are hidden. 

Allow Server 
Device Creation

Selected or 
unselected

Allows creation of server devices in the End-User Portal. If Allow 
Standalone Device Creation and Allow Server Device Creation 
are unselected, the Create Device menu item and button are 
hidden.

Table 19-23 • End-User Portal: License Support Page Configurations

Name
Possible 
Values Description Rqd
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Hide Move Button Selected or 
unselected

Hides the Move Device button in the Action menu on the 
device’s default view.

Allow Device Name 
Editing

Selected or 
unselected

Allows editing of device name in the End-User Portal.

Display Site Name 
in Devices Page

Selected or 
unselected

Displays the Site Name attribute on the Devices page. *

Enable Return 
Device/Server

Selected or 
unselected

Allows devices and servers to be returned via the End-User 
Portal. 

Allow Backup 
Server ID Editing

Selected or 
unselected

Allows End-User Portal users to add backup servers. 

Display vendor 
dictionary 
information in 
Devices page

Selected or 
unselected

Controls whether vendor dictionary information is visible on the 
device’s default view in the End-User Portal.

Default: selected (vendor dictionary information is visible on the 
device’s default view).

Show Downloads 
Tab

Selected or 
unselected

Controls whether the Downloads tab is visible on the device’s 
default view. If selected, the Downloads tab shows all 
downloads that are available for a standalone device.

Default: unselected.

Version • This setting is only available for producers who use 
the Software Delivery module.

Enforce device 
management 
permissions 
across accounts

Selected or 
unselected

Controls the capabilities available on the Device Details page. 
When selected, a user belonging to more than one account will 
have their permissions to view or manage devices enforced 
according to the account that owns the device.

Default: unselected.

Table 19-24 • End-User Portal: Devices Page Configurations

Name
Possible 
Values Description Rqd
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Downloads Page
These settings correspond to the Downloads Page section of the End-User Portal Setup page in System > 
Configure.   

Table 19-25 • End-User Portal: Downloads Page Configurations

Name
Possible 
Values Description Rqd

Show File Count Selected or 
unselected

Show or hide the download file count on the Download page. 
Select the box to have the End-User Portal show how many 
times each file has been downloaded.

Hide Download Log 
Tab

Selected or 
unselected

Show or hide the Download Log tab on the Downloads page. 
Select the box to hide the Download Log tab. 

Hide Notification 
Log Tab

Selected or 
unselected

Show or hide the Notification Log tab on the Downloads page. 
Select the box to hide the Notification Log tab. 

Hide Date Added Selected or 
unselected

Show or hide the Date Added column in the Files list. Select the 
box to hide the Date Added column.

Hide Extended File 
Description

Selected or 
unselected

Show or hide the extended file description in the expanded file 
details. Select the box to hide the extended file description.

Hide Custom 
Attributes

Selected or 
unselected

Show or hide custom file attributes in the expanded file details. 
Select the box to hide custom attributes.

Hide File 
Checksums

Selected or 
unselected

Show or hide the checksum values in the expanded file details. 
Select the box to hide the checksums attribute.

Show Download 
Package Version

Selected or 
unselected

Show or hide the version number for each download package 
next to the download package name above the file list on the 
Download List page. 

Note that download packages are not required to have a 
version. If no download package version is available, no 
download package version appears in the End-User Portal.

Select the box to show the download package version numbers. 

Hide File Details Selected or 
unselected

Show or hide all additional file details in the expanded file 
details. Select the box to hide all such details. 

Show Order Media Selected or 
unselected

Show or hide Order Media on the Downloads page. Order Media 
enables End-User Portal users to request copies of the files to 
which they are entitled on physical media. 

Order Media 
Request Recipient

Specify The email destination for the Order Media request messages. 
Set the email address the End-User Portal uses when an end 
user wants to order physical media. 

*
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Recent Releases
These settings correspond to the Recent Releases section of the End-User Portal Setup page in System > 
Configure.    

Recent Files Page
These settings correspond to the Recent Files Page section of the End-User Portal Setup page in System > 
Configure.   

Hide Download 
Manager

Selected or 
unselected

Show or hide the Download Selected Files button on the 
Download List page. 

Table 19-26 • End-User Portal: Recent Releases Configurations

Name
Possible 
Values Description Rqd

Default Days to 
Show

30 or specify Set the default recency of the release for the recent files list. 
This setting determines the recency, in days, for download 
packages to be included in the recent releases list. Common 
settings are 30, 60, 90, and 120.

Table 19-27 • End-User Portal: Recent Files Page Configurations

Name
Possible 
Values Description Rqd

Default Days to 
Show

30 or specify Set the default recency for the recent files list. This setting 
determines the recency, in days, for files to be included in the 
recent files list. Common settings are 30, 60, 90, and 120.

Table 19-25 • End-User Portal: Downloads Page Configurations

Name
Possible 
Values Description Rqd
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Download Order Page
These settings correspond to the Download Order Page section of the End-User Portal Setup page in System > 
Configure.   

Download Packages Page
These settings correspond to the Download Packages Page section of the End-User Portal Setup page in System 
> Configure.  

Manage Accounts & Users
These settings correspond to the Manage Accounts & Users section of the End-User Portal Setup page in System 
> Configure.

Table 19-28 • End-User Portal: Download Order Page Configurations

Name Possible Values Description Rqd

Show Version Selected or 
unselected

Show or hide the Version column in the Download Package list 
of the Available Downloads page. 

The Available Downloads page lists the download packages 
associated with an entitlement. In the End-User Portal, the 
Available Downloads page appears when you click an 
entitlement’s Download Now link on the List Entitlements page. 

Table 19-29 • End-User Portal: Download Packages Page Configurations

Name
Possible 
Values Description Rqd

Show Version Selected or 
unselected

Show or hide the Version column in the Download Package list 
on the Download Packages page. 

The Download Packages page lists the download packages for 
a product. In the End-User Portal, the Download Packages page 
appears when you click on a product name. For example, an 
end user might click on a product name that appears in Your 
Downloads on the Home page or in the list that appears after 
clicking Downloads > List Downloads.
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Note • You can also configure the display of the Created By column on the Accounts page in the End-User Portal 
using the OPS_PORTAL_CONFIG table. See the FlexNet Operations On-Premises Installation & Implementation 
Guide for more information.    

Custom Branding
These settings correspond to the Branding section of the End-User Portal Setup page in System > Configure.   

Table 19-30 • End-User Portal: Manage Accounts & Users Configurations

Name
Possible 
Values Description Rqd

Hide Create a 
Sub Account

Selected or 
unselected

Hides the Create a Sub Account link in the Actions menu on the 
Accounts page.

Hide Delete 
Account

Selected or 
unselected

Hides the Delete Account link in the Actions menu on the 
Accounts page.

Hide Delete Subtree Selected or 
unselected

Hides the Delete Subtree link in the Actions menu on the 
Accounts page.

Hide Create a User Selected or 
unselected

Hides the Create a User link in the Actions menu on the 
Accounts and Users pages.

Hide Delete a User Selected or 
unselected

Hides the Delete User link in the Actions menu on the Accounts 
and Users pages.

Prevent editing 
Account ID and 
Account Name

Selected or 
unselected

Prevents customer users and partner users from editing their 
account ID and account name.

Hide Create an 
Account

Selected or 
unselected

Hides the Create partner account and Create customer account 
links in the Actions menu on the Accounts page.

Table 19-31 • End-User Portal: Custom Branding Configurations

Name
Possible 
Values Description Rqd

Upload Company 
Logo 

Specify Choose an image file (PNG or JPG format) to serve as your 
account’s logo in the End-User Portal and upload it. Use the 
controls to choose a file from your local machine to upload. 

After an image file is uploaded, a reset button is available to 
enable you to clear the uploaded image. 

Maximum file size: 40KB

Recommended image height: 30 pixels



Chapter 19 Configuring FlexNet Operations
Performing System Configuration

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 681

Upload CSS Specify Choose a CSS file to replace the style settings used by default 
for the End-User Portal. Uploading a customized CSS file allows 
for a broader range of style changes consolidated into a single 
place. For smaller changes, it may be simpler to use one of the 
override settings instead. 

Use the controls to choose a CSS file from your local machine to 
upload. (When no custom CSS file is present, the End-User 
Portal uses its default CSS.)

Upload Header Specify Choose an HTML file to replace the default header content for 
the End-User Portal. Use the controls to choose a file from your 
local machine to upload. (When no custom header HTML is 
present, the End-User Portal uses its default header content.)

Upload Footer Specify Choose an HTML file to replace the default footer content for 
the End-User Portal. Use the controls to choose a file from your 
local machine to upload. (When no custom footer HTML is 
present, the End-User Portal uses its default footer content.)

Primary Navigation 
Position

Top, Left, or 
Right

Specify where to show the high-level navigation menu for the 
End-User Portal. Default: Top. 

Table 19-31 • End-User Portal: Custom Branding Configurations

Name
Possible 
Values Description Rqd
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Custom Tags
These settings correspond to the Custom Tags section of the End-User Portal Setup page in System > Configure.   

Configure Portal 
Colors

Click Open Configurator to show the Color Configurator panel. 
The Color Configurator allows you to set the colors to use in 
your End-User Portal pages for the following content:

• Default button label color – sets the color of the label on 
default buttons in the End-User Portal. 

• Default button color – sets the color of the default buttons 
in the End-User Portal. 

• Background color – sets the background page color for all 
End-User Portal pages. 

• Title color – sets the text color of the page titles in the End-
User Portal. 

• Link color – sets the color of the link text and lightweight 
button text on End-User Portal pages. 

• Primary navigation – sets the background color for the 
primary navigation menu. 

• Primary navigation open – sets the background color for 
open (active) primary navigation menu items. 

• Primary navigation text – sets the color for all text in the 
primary navigation menu. 

Specify all colors using hexadecimal format. For example, 
#000000 for black, #ffffff for white, or #228B22 for forest green.

Click Preview to show a sample of your color settings within the 
Color Configurator.

Click Undo to revert any changes that have not yet been saved.

Click Use Defaults to restore color settings to the FlexNet 
Operations default colors.

Click Save to store your changes to these color settings.

Table 19-32 • End-User Portal: Custom Tag Configurations

Name
Possible 
Values Description Rqd

Last in Head Custom script tags added here are inserted last in the 
document <head/> of the End-User Portal.

Table 19-31 • End-User Portal: Custom Branding Configurations

Name
Possible 
Values Description Rqd
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Activating and Licensing FlexNet Operations
You can configure your FlexNet Operations license on the Licensing configuration page (System > Configure > 
Licensing). This page is where producers activate their license to use FlexNet Operations by providing the URL for 
the FlexNet Embedded endpoint they receive in their welcome message from Revenera. 

The Producer Portal shows the Licensing page when the first user from a producer’s account logs in. Until a valid 
FlexNet Embedded endpoint URL is in place, the Producer Portal remains in its unactivated state, and no other 
pages are accessible to the producer’s accounts’ users. 

Task To activate FlexNet Operations

1. Click System > Configure. 

2. Click Licensing. The Producer Portal opens the Licensing configuration page. 

3. On the Licensing configuration page, enter your FlexNet Embedded endpoint URL. 

4. Click Save Configs.

The Producer Portal activates for the features contained in your FlexNet Operations license. 

Version • You must restart the FlexNet Operations server for these changes to take effect. 

Importing a Configuration 
The configuration import utility uses the JAR file created by the configuration export utility to restore all FlexNet 
configuration settings. A user must be assigned a role with the View and Manage Configurations permission to 
import configuration settings. 

Note • Before importing configuration settings into a working FlexNet Operations instance, export the working 
configuration settings (without writing over the JAR file you plan to import). If there is a problem with the 
imported settings, you have a backup of working settings to restore.

Last in Body Custom script tags added here are inserted last in the 
document <body/> of the End-User Portal.

Table 19-32 • End-User Portal: Custom Tag Configurations

Name
Possible 
Values Description Rqd
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Task To import configuration settings through the FlexNet Operations Producer Portal

1. Click System > Configure. 

2. Click Import to open the Import page. 

3. Specify the JAR file that contains the configuration settings to restore. 

4. Click Import. 

The Producer Portal imports the settings contained in the imported file. 

Version • You must restart the FlexNet Operations server for these changes to take effect. 

Exporting a Configuration 
The configuration export utility exports all of the FlexNet configuration settings at once. Configurations are 
exported to a JAR file that contains database, FlexNet Platform Server, Producer Portal, and application-specific 
settings in separate XML files. The configuration import utility uses the JAR file to restore all configuration 
settings. A user must be assigned a role with the View and Manage Configurations permission to export 
configurations to a file. 

Task To export configuration settings through the FlexNet Operations Producer Portal

1. Click System > Configure. 

2. Click Export to open the Export page. 

3. Click Export. 

4. In the File to download dialog, click Open, Save, or Cancel.

Specify the location and file name for the JAR file. By default, the configuration settings are saved to a file 
called flexnet_configurations.jar. It is recommended to save the file to a safe location. 

Configuring Embedded Devices Settings
A user must be assigned a role with the View and Manage Configurations permission to modify configuration 
settings for Embedded Devices through the Producer Portal. 

Note • Before changing any configuration settings in a working FlexNet Operations instance, it is advisable to 
export the working configuration settings. If there is a problem with the new settings, you have a backup of 
working settings to restore.
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Task To configure embedded devices settings

1. Click System > Configure. 

2. Click Embedded Devices to open the configuration page.

3. View or change the values of the settings below.

4. Click Save Configs. 

The Producer Portal saves your configuration changes. 

Settings appear in the following groups: 

• Host Options

• Capability Request Handling

• License Generation

• History Logging

Host Options
These settings correspond to the Host Options section of the License Fulfillment Service Configuration Settings 
page in System > Configure. 

Table 19-33 • Embedded Devices: Host Option Configurations

Name
Possible 
Values Description

Default Client Host Type FLX_CLIENT 
or specify

The default host type FlexNet Operations uses when creating an 
unknown client device from a request, if the request does not 
specify a host type. This value is also used when claiming a client 
device from the End-User Portal, if not supplied by the request, 
the portal UI, or a call-out. Default: FLX_CLIENT.

Default Server Host Type FLX_SERVER 
or specify

The default host type FlexNet Operations uses when creating an 
unknown server device from a request, if the request does not 
specify a host type. This value is also used when claiming a 
server device from the End-User Portal, if not supplied by the 
request, the portal UI, or a call-out. Default: FLX_SERVER.

Excluded Client Host ID 
Types

specify Use this option to select which of the normally supported host ID 
types should be excluded from the choices presented when 
editing the allowed ID types for a host type that supports clients. 

Excluded Server Host ID 
Types

specify Use this option to select which of the normally supported host ID 
types should be excluded from the choices presented when 
editing the allowed ID types for a host type that supports servers. 
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Capability Request Handling
These settings correspond to the Capability Request Handling section of the License Fulfillment Service 
Configuration page in System > Configure.    

Entitlement Map Overlap Value in days Maximum elapsed time, in days, that an entitlement mapping can 
exceed the limits specified by any applicable host series 
definitions.

Allow Duration License 
Decrease

Selected or 
unselected

Select to allow licenses with duration based features to have 
their copies reduced. Normally, licenses using durations only 
allow increasing the number of copies. 

Allow Duration License 
Decrease for Producer

Selected or 
unselected

Select to allow licenses with duration based features to have 
their copies reduced by a producer. Normally, licenses using 
durations only allow increasing the number of copies. 

Consume Copies When 
Mapping

Selected or 
unselected

Immediately deduct the number of copies from the appropriate 
line item when a request to increase a host’s license copies is 
processed. If this option is not selected, the additional copies are 
not deducted until the license is generated.

Clone Detection Selected or 
unselected

Select to record the clone suspect events in the back office. 

Table 19-34 • Embedded Devices: Capability Request Handling Configurations

Name
Possible 
Values Description

Device Response Lifetime Time value in 
seconds, 
minutes, 
hours, days, 
or weeks 

Lifetime for device responses generated when a device request 
is received. You can specify the value to explicitly identify the 
time unit as seconds, minutes, hours, days, or weeks with a 
suffix of s, m, h, d, or w. If no suffix is used, the value is assumed 
to be in seconds. If the value is zero (0), the responses never 
expire.

Allow Adding Unknown 
Hosts

Selected or 
unselected

Select to allow an unknown host to be added as a result of 
processing a capability request. An unknown server is added only 
if the capability request contains a valid activation ID. (To add a 
server when the request contains no activation ID, select Allow 
Server Without Activation IDs.) 

Allow Server Without 
Activation IDs

Selected or 
unselected

Select to allow unknown servers to be added as a result of 
processing a capability request, even if the request does not 
contain any activation IDs.

Table 19-33 • Embedded Devices: Host Option Configurations

Name
Possible 
Values Description
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License Generation
These settings correspond to the License Generation section of the License Fulfillment Service Configuration 
page in System > Configure.    

Prohibit Virtual Hosts Selected or 
unselected

Select to prohibit capability requests for hosts running on virtual 
machines. If this option is not selected (default), capability 
requests are served regardless of the machine type. 

Capability Request Call-
out

URL or 
classname

The base URL of a REST server or name of a class that 
implements the 
com.flexnet.lm.bot.service.CapabilityRequestCallOut interface. 
If specified, it is called to customize handling of capability 
requests and generated responses. 

Capability Request 
Finalize Host Call-out

Selected or 
unselected

Select to invoke call-out just before creating an unknown host. 
Additional attributes can be defined before it is persisted. It can 
also be used to cancel creation of the new host instance.

Capability Request 
Access Check Call-out

Selected or 
unselected

Select to invoke call-out after (optionally) creating an unknown 
host, before proceeding with processing an off-line request. The 
return value can be used to deny access to the targeted host.

Capability Request 
Finalize Response
Call-out

Selected or 
unselected

Select to invoke call-out after an incoming host request has been 
validated, but before the capability response has been 
generated.

Call-out Includes Host 
Details

Selected or 
unselected

Select to send details about the target host in the request body. 
Otherwise, just send the host id and id type, host class, host type, 
and alias.

Call-out Includes Add-on 
Details

Selected or 
unselected

Select to send add-on details in the request body. Otherwise, just 
send list of activation IDs.

Table 19-35 • Embedded Devices: License Generation Configurations

Name
Possible 
Values Description

Default Borrow Interval Time value in 
seconds, 
minutes, 
hours, days, 
or weeks

The default borrow interval for features that do not specify an 
override. You can specify the value to explicitly identify the time 
unit as seconds, minutes, hours, days, or weeks with a suffix of s, 
m, h, d, or w. If no suffix is used, the value is assumed to be in 
seconds. If the value is zero (0), the interval is unlimited. 

Table 19-34 • Embedded Devices: Capability Request Handling Configurations

Name
Possible 
Values Description
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History Logging
These settings correspond to the History Logging section of the License Fulfillment Service Configuration page 
in System > Configure.   

Default Renew Interval Percentage of 
borrow 
interval

The default renew interval expressed as a percentage of the 
borrow interval, for features that do not specify an override. If set 
to zero (0), the renew interval is at the client discretion.

Include Issued Date Selected or 
unselected

If selected, include the Issued Date attribute in generated 
licenses for devices. Default: Selected.

Include Start Date Selected or 
unselected

If selected, include the Start Date attribute in generated licenses 
for devices. Default: Selected.

Default Metered Undo 
Interval

Time value in 
seconds, 
minutes, 
hours, days, 
or weeks

The default value of the undo interval for metered features that 
do not explicitly define an undo interval and are not reusable. You 
can specify the value to explicitly identify the time unit as 
seconds, minutes, hours, days, or weeks with a suffix of s, m, h, 
d, or w. If no suffix is used, the value is assumed to be in 
seconds. 

Skip Confirmation Selected or 
unselected

When selected, no confirmation capability request is required 
when reducing the number of copies of a license.

Skip Confirmation for 
Producer

Selected or 
unselected

When selected, no confirmation capability request is required for 
a producer when reducing the number of copies of a license.

Date-based Version 
Format

yyyy.MM or 
yyyy.MMdd 

When a feature that uses a date-based version format is created, 
this format is used when converting the version date to a version 
representation. For a date of May 15, 2018, yyyy.MM is 2018.05 
and yyyy.MMdd is 2018.0515. 

Table 19-36 • Embedded Devices: History Logging Configurations

Name
Possible 
Values Description

Successful Capability in 
Request History

Selected or 
unselected

When selected, successful capability requests and matching 
responses are recorded in the request history. By default, 
successes are recorded only in the host history. 

Record Sync in Request 
History

Selected or 
unselected

When selected, sync messages and acknowledgments are 
recorded in the request history. By default, messages are 
recorded only in the host history, at debug log level. 

Table 19-35 • Embedded Devices: License Generation Configurations

Name
Possible 
Values Description
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Configuring Secure Token Single Sign-On
The FlexNet Operations End-User Portal can be configured to interface with a separate application, such as a 
corporate portal or intranet. The single sign-on (SSO) application passes user credentials to the FlexNet 
Operations End-User Portal, enabling a user to have a single set of credentials for both. The user signs on to the 
SSO application, and gains access to both the SSO application and FlexNet Operations End-User Portal for the 
duration of the browser session. This section describes how to configure single sign-on applications.

The secure token single sign-on process includes the following steps:

Configuring Secure Token Single Sign-On
Secure token single sign-on uses FlexNet Operations Web services. 

• Synchronizing SSO Application User Data

• Generating a Token

Write License History 
Events

Selected or 
unselected

When selected, individual license host history events are 
included in the request history for backward compatibility. 
Recording such events has been deprecated and replaced by 
adding fulfillment details in other events. 

Host History Log Level Debug, 
Information, 
Error 

Include events in host history that are at or above the specified 
log level. The lowest log level is Debug; the highest is Error.  

Table 19-37 • Secure Token Single Sign-On Process Steps

# Step Description

1 SSO application requests 
secure token

The SSO application requests a secure token from the FlexNet Operations 
server. The FlexNet Operations server sends the secure token back to the 
SSO application.

2 SSO application receives 
secure token and constructs 
URL

The SSO application receives the secure token and constructs a URL, 
which includes parameters that control the display and behavior of the 
End-User Portal.

3 SSO application sends URL 
to FlexNet Operations server

The SSO application sends the URL and the secure token to the FlexNet 
Operations server.

4 Upon login, credentials are 
passed to server and user is 
authenticated

When the user logs into the SSO application, credentials are passed to the 
FlexNet Operations server, and the user is authenticated. The FlexNet 
Operations server displays the End-User Portal landing page. 

Table 19-36 • Embedded Devices: History Logging Configurations

Name
Possible 
Values Description
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• Constructing a URL

Note • For more information about Web services, including the SSO Web service, consult the FlexNet Operations 
Web Services Integration Guide and FlexNet Operations SOAP Web Services Guide. 

Synchronizing SSO Application User Data
Before configuring secure token single sign-on, you must synchronize SSO application user data from the SSO 
application with your FlexNet Operations database, as shown here. 

Native Authentication
If the secure token SSO application performs authentication natively, then you must pre-load all user data from 
the SSO application into FlexNet Operations using the UserAcctHierarchyService Web service. In addition, the 
SSO application must synchronize all subsequent changes to user information with the FlexNet Operations 
database. 

• For example, if the application allows online user registration, the UserAcctHierarchyService Web service 
must be used to create the same user in FlexNet Operations.

• Because FlexNet Operations does not allow deletion of user information, if a user is deleted from the SSO 
application, the user’s status must be set to Inactive in FlexNet Operations.

Note • For complete reference information on the individual FlexNet Operations SOAP-based APIs, see the 
FlexNet Operations SOAP Web Services Guide.

Table 19-38 • Data Synchronization for Secure Token SSO Applications

Data Required or Optional?

User first name Required

User last name Required

User email ID Required

User role Required

User locale Optional, defaults to system locale

User time zone Optional, defaults to system time zone

User Account ID Optional, ID of the account to which the user belongs

Account ID Required for all accounts

Account display name Required

https://docs.revenera.com/fno2021r1_onprem/soapapi/Default_frame.htm
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External Authentication
If the secure token SSO application is authenticating users with a directory service (such as LDAP), you must 
configure the directory service in FlexNet Operations as follows:

Task To configure the directory service for external authentication:

1. Add the directory service as a new domain in FlexNet Operations. 

2. Import groups from the directory service into the FlexNet Operations database.

3. Map roles to the imported directory groups. (Typically, the groups are assigned the Portal User role.)

Subsequent changes to the directory service user database must be synchronized with FlexNet Operations using 
the UserAcctHierarchyService Web service.

Note • For more information on roles, users, and domains, see Managing Accounts and Users. 

Generating a Token
 FlexNet Operations Web services are used in making, processing, and generating token requests.

Task To generate a token:

1. The SSO application must request a secure token from the FlexNet Operations server. This request is 
performed with a SOAP message using a FlexnetAuthentication Web service call. Create a FlexNet user for a 
Web service client, and pass the credentials in the request for authentication so that the 
FlexnetAuthentication service processes the request and serves the response with a valid, secure token. The 
request message has the form: 

<secureTokenRequest>
<userId>sjoe</userId>

</secureTokenRequest>

2. After the request is processed by the FlexNet Operations server, the response message is returned with the 
secure token. The response message has the form: 

<secureTokenResponse>
<token>vZ1VakmEUiNmTsj5-dYE38qQvUW_OcxoLeDhtNmS53v04xPF__2GmfKwUE7D6hPoZcV9W0KlqhjET
_NjY1QvK0_j_dmNUEVhkxibIQz1A2g__wg</token>

</secureTokenResponse>

The token is valid for 300 seconds after creation. 

Constructing a URL
After the SSO application receives the secure token, it must launch a URL to display the End-User Portal. The URL 
has the form: 

http://<host>:<port>/flexnet/operationsportal/sso.do?username=<username>&token=<token>
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&language=<language>&externallogoffurl=<URL>&goToPage=<page>&hideheader=<value>

Important • Query string parameters must be URL encoded. 

Parameters are described in the following table: 

Table 19-39 •  SSO URL Parameters

Parameter Description

username User’s name. Must be in the FlexNet Operations database or the login fails. 

token Secure token value. 

language Optional. The user’s preferred language, such as en_US. 

externallogoffurl URL to display if the session times out. 

Important • The externallogoffurl must be URL encoded. 

goToPage Optional. Indicates which page of the FlexNet Operations End-User Portal to display 
initially. Possible values are: 

• homePage displays the End-User Portal landing page 

• showEntitlements displays the entitlements landing page 

• showFulfillments displays the fulfillments landing page 

• activate displays the item corresponding to the activation ID 

activationID Optional. If specified, the user can access only the specified activation ID. Used in 
conjunction with the goToPage value "activate" to directly navigate to activation 
page. 

entitlementID Optional. If specified, the user can access only the specified entitlement ID. Used in 
conjunction with the goToPage value "activate" to directly navigate to activation 
page. Note that if the goToPage is set to activate, only non-child items can be 
activated from this page. Child line items are those which are derived by upgrading 
or renewing another line item. 

An example of a URL that would load the activation page for a given entitlement ID: 
http://opshost:8888/flexnet/operationsportal/
sso.do?username=admin&goToPage 
=activate&hideheader=true&token%3Dv9vF941Xv18xvhAY&entitlementId=SSOEnt
&externallogoffurl=http%3A%2F%2Flocalhost%3A9090externalportalstartpage.jsp
26language%3Den_US 

hideheader Optional. Controls the display of the End-User Portal header. Value is true or false. 
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Sample Application

A sample secure token single sign-on application is included with the FlexNet Operations installation. You can 
use this sample application to test configuration of your own single sign-on solution. The sample also includes a 
readme file that contains installation and configuration instructions. 

The sample is located in the Samples folder and is named portalSSODemoApp.zip. 

Viewing Transaction Histories 
Producers can use the transaction history feature to view system state changes of entity transactions to 
troubleshoot issues by observing the transactions and/or comparing changes in the entity fields. There are 
several types of entities that can be viewed. These entities include:

• Account

• Product

• User

• Update

• Entitlement

You can view when the entities were created, updated, deleted, and who submitted the change.

Task To search for a transaction

1. Click System > Transaction History.

2. Select or enter your search criteria. Options include:

a. Select the Entity Type you want to search for from the drop-down menu.

b. If you select a specific entity, you can enter a value for that type of entity.

c. Enter the ID of the user who performed the transaction.

d. Enter or select a start date.

e. Enter or select an end date.

3. Click Search.

The Producer Portal searches for transactions that match your search criteria and shows a list of matching 
transactions in the search results. The results page lists the following:

• The timestamp of the transaction

• The event type (create, update or delete)

• The entity type

• The entity ID 

• The user who performed the transaction.
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Click on the View details of an entity to view the details of the transaction. On the Transaction Details page, you 
can view all the fields associated with an entity, including any changes from the Show all fields tab, or select the 
Show only differences tab to view just the fields that changed.

Note • Only transactions with an event type of UPDATE have the Show all fields and Show only differences tabs. 
There are no differences to display for CREATE events.

Click on the Entity ID of a transaction to be taken to the create/update page for that entity.

Managing Custom Content
Producers can create custom text or HTML to be shown to their end-users in the End-User Portal. Custom content 
is used in the End-User Portal to customize page instructions on supported pages, add announcements to the 
home page, or create standalone pages. 

Note • To create or edit custom content, a Producer Portal user must have the View and Manage Custom Content 
permission. See Working with Roles and Permissions for more information about users, roles, and permissions.

The topics below explain more about custom content and how to manage it. 

About Custom Content 
Producers can modify the on-page instructions of End-User Portal pages—typically the content at the top of a 
page just below the page title—by creating custom content in the Producer Portal. One common use for custom 
content is to add announcements to the End-User Portal’s home page. Producers can also create custom, 
standalone HTML pages to be included in the End-User Portal using the Custom Content feature. 

Table 19-40 • 

Topic Description

About Custom Content Discusses custom content concepts, attributes, and supported End-User 
Portal pages. 

About Product Trial 
Registration Support

Describes how to use the TrialRegistration custom content template to 
support the registration for trial products by end users, including the optional 
use of a custom email message and a custom registration-success page.

Listing Custom Content Shows how to use the System menu to list all custom content.

Creating Custom Content Explains how to create custom content. 

Editing Custom Content Describes how to edit an existing custom content item. 

Localizing Custom Content Explains how to update page instructions for localized sites.



Chapter 19 Configuring FlexNet Operations
Managing Custom Content

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 695

To use custom content to modify on-page instructions of regular End-User Portal pages, first identify the End-
User Portal page you want to customize. Next, on that page, determine the custom content ID of the portion you 
plan to customize. Then use the controls on the Custom Content page, along with your custom text or HTML, to 
create the new content. The custom content you create replaces the standard content (corresponding to the 
custom content ID) on the End-User Portal page. 

Use the pages listed in Pages That Support Custom Content to determine which custom content ID to use when 
you create content. For example, use NotificationLogContent to alter the instructions on the Downloads page that 
appears when a user clicks on a download package on the Download Packages page. 

Tip • To add announcements to the End-User Portal’s home page, edit the HTML for custom content ID: 
epAnnouncements. Announcements are rendered on the home page in the Announcements panel.

To use custom content to create custom, standalone pages, add content from the Custom Content page but be 
sure to use a unique, unused custom content ID. 

Additional information about custom content attributes, status, supported pages, and so forth appears in the 
following sections: 

• Custom Content Attributes

• Custom Content Status

• Pages That Support Custom Content

• Localization and Custom Content

• Additional Notes and Tips for Content Customization

For information about using custom content to support trial registrations, see About Product Trial Registration 
Support.

Custom Content Attributes
The following attributes are relevant to Producer Portal users who are creating or editing custom content to be 
shown in their End-User Portals.

Table 19-41 • Custom Content Attributes

Attribute Description

Custom Content ID A unique ID that can be used to identify custom content in FlexNet Operations. 

When custom content is to replace existing, standard content on an End-User Portal 
page, this ID must match the ID of the content it replaces. 

When custom content is intended to introduce a new page to the End-User Portal, 
this ID must be unique and otherwise unused in the End-User Portal. 

Description A longer, descriptive name for custom content. 
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Hide from Portal? A switch that determines whether live custom content appears on the End-User 
Portal. 

• Selected—Hide the custom content from End-User Portal users even if the 
custom content is the live version.

• Unselected—Show the custom content to End-User Portal users if it is the live 
version.

Default: Unselected.

Hide from Portal is a control that appears on the Create Content and Edit Content 
pages.

Template The template to use for the custom content. 

Currently, only one template is available: TrialRegistration. This template is purpose 
built to support free trial registrations in the End-User Portal. In all other cases, 
leave the Template setting blank. 

Status The status of the custom content version. For custom content, status can be Live, 
Draft, or Archived. (See Custom Content Status, below.) 

Status is a value that appears in the list of custom content items on the Custom 
Content page. 

Last Modified The date the custom content was last changed. 

Last Modified is a value that appears in the list of custom content items on the 
Custom Content page. 

Modified By The Producer Portal user who last changed the custom content.

Modified By is a value that appears in the list of custom content items on the 
Custom Content page. 

Permalink The relative URL for custom content in the End-User Portal. For standalone pages 
built from custom content, this URL can be used for links that target the custom 
content page.

Permalink is an attribute that appears on the Edit Content page.

Content Version The version of the custom content for the current custom content ID. Content 
Version values show the status and version of custom content. For example: Draft /
1 or Live / 2. 

Content Version is a control that appears on the Edit Content page. 

Content The text or HTML to be used in the End-User Portal. 

Table 19-41 • Custom Content Attributes

Attribute Description
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Custom Content Status
Similar to email template status values, custom content items can have one of three status values: 

• Live—The current version of the content that appears in your End-User Portal. Only one version of a custom 
content item can be live at any given time.

• Draft—A work-in-progress version of new custom content or an existing custom content item that is being 
revised. Custom content items in draft state are not shown in the End-User Portal. Only one version of a 
custom content item can be in draft status at any given time. 

• Archived—Formerly live versions of a custom content item. Archived versions are preserved in the system 
and can be made live, again, if your account is required to roll back changes made to the live version.

A custom content item’s status is shown on the Custom Content page. 

Pages That Support Custom Content
The following table lists End-User Portal pages that support custom content, the custom content IDs for the 
customizable items, and a description of how the content is used for each custom content ID. 

Note • It is also possible to create custom, standalone pages for the End-User Portal using your own custom 
content ID. The Trial Registration page is a special standalone page that producers can implement using the 
TrialRegistration template.   

Table 19-42 • Pages That Support Custom Content

End-User
Portal Page Content ID Description

Home 
(End-User Portal 
Announcements)

epAnnouncements The Announcements panel on the home page can 
display messages from your account to its end 
users. This content is rendered on the home page 
unless the End-User Portal system configuration 
setting: Hide Announcements Widget is selected. (It 
is unselected by default.) 

Downloads ManufacturersContent Displayed when the user is presented with a list of 
producers. If only one producer is available, the end 
user sees only the list of available product lines (no 
producer choice when files from only one producer 
are available).

This is the page that appears when an end user 
chooses Downloads > List Downloads in the End-
User Portal, for example.

This content is rendered under the page title 
(Downloads) and above the list of producers and 
product lines. 
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Download 
Packages 
(Download 
Package Versions)

NewDownloadPackagesInfo The Download Packages page is the page that 
appears when an end user chooses a product line 
on the Producers page (the page the End-User 
Portal shows when end users click Downloads > List 
Downloads).

This content is displayed when the New Versions 
tab is rendered and there are previous (archived) 
versions available for the product line selected.

Download 
Packages 
(Download 
Package Versions)

ArchivedDownloadPackagesInfo The Download Packages page is the page that 
appears when an end user chooses a product line 
on the Producers page (the page the End-User 
Portal shows when end users click Downloads > List 
Downloads).

This content is displayed when the Previous 
Versions tab is rendered and there are new (current) 
versions available for the product line selected.

Download 
Packages (View 
Download Order)

NewDownloadOrderContent The Download Order page is the page that appears 
when an end user clicks Download Now on the 
Entitlements page (the page the End-User Portal 
shows when end users click Activation & 
Entitlements > List Entitlements). 

This content is displayed when the New Versions 
tab is selected. 

Download 
Packages (View 
Download Order)

ArchivedDownloadOrderContent The Download Order page is the page that appears 
when an end user clicks Download Now on the 
Entitlements page (the page the End-User Portal 
shows when end users click Activation & 
Entitlements > List Entitlements). 

This content is displayed when the Archived 
Versions tab is selected. 

Download Search SearchContent This content is displayed on the Download Search 
page and rendered under the page title and above 
the search controls.

Table 19-42 • Pages That Support Custom Content

End-User
Portal Page Content ID Description
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Download Files DownloadContent Displayed on the Downloads page. This is the page 
that appears when an end user clicks on a 
download package on the Downloads page. This 
content is present when the Files tab is active. It is 
rendered below the page title (Downloads) and 
above the download package name.

Note that download package-specific content is still 
maintained via the download package Download 
Instructions attribute. (Download instructions 
appear below the download package name and just 
above the Files, Download Log, and Notification Log 
tabs.)

Download Log DownloadLogContent Displayed on the Downloads page when the 
Download Log tab is active and the Download Log 
tab is showing its default Files Downloaded view. It 
is rendered below the page title (Downloads) and 
above the download package name.

Note that the Download Log tab can show three 
different views: Files Downloaded, Download 
Transactions, and Download Details. Each view 
corresponds to a separate HTML content entry. 

Download Log 
Detail

DownloadDetailContent This content is displayed on the Downloads page for 
a download package when a user clicks a file name 
on the Download Log tab. (Clicking a file name 
shows the Download Log’s Download Transactions 
view for that file.) The custom content for 
DownloadDetailContent is rendered below the page 
title (Downloads) and above the download package 
name.

Note that the Download Log tab can show three 
different views: Files Downloaded, Download 
Transactions, and Download Details. Each view 
corresponds to a separate custom content entry. 

Table 19-42 • Pages That Support Custom Content

End-User
Portal Page Content ID Description
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Download Log 
Detail File

DownloadDetailFileContent This content is displayed on the Downloads page for 
a download package when a user clicks a date-time 
value on the transaction list on the tab’s Download 
Transactions view. (Clicking a time-date value 
shows the Download Log’s Download Details view.) 
The custom content for DownloadDetailFileContent 
is rendered below the page title (Downloads) and 
above the download package name.

Note that the Download Log tab can show three 
different views: Files Downloaded, Download 
Transactions, and Download Details. Each view 
corresponds to a separate custom content entry. 

Notification Log NotificationLogContent Displayed on the Notification Log accessible from 
the Download page. Custom content for 
NotificationLogContent is rendered below the page 
title (Downloads) and above the download package 
name.

DownloadOrder DownloadOrderContent Displayed on the Available Downloads page. The 
Available Downloads page is shown when a user 
clicks the Download Now link for an entitlement on 
the List Entitlements page. 

The Available Downloads page shows download 
packages for the products in the entitlement that 
include downloads. Custom content for 
DownloadOrderContent is rendered below the page 
title (Available Downloads) and above the Activation 
ID.

View Recent Files ViewRecentFilesContent Displayed on the View Recent Files page on the 
Home page for specific implementation.

View Recent 
Products

RecentProductReleasesContent Displayed on the View Recent Products page.

LandingPage NoDownloadContent Displayed on the landing page when no downloads 
are available for the current user.

Files Not 
Downloaded

NoDownloadContent Displayed on the Files Not Downloaded page when 
no downloads are available for the current user.

Table 19-42 • Pages That Support Custom Content

End-User
Portal Page Content ID Description
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Localization and Custom Content
Producers can localize the following custom content IDs, used to display custom instructions and information on 
specific End-User Portal pages:

• Download Files (Content ID: DownloadContent)

• Home (End-User Portal Announcements) (Content ID: epAnnouncements)

• Password Reset (Content ID: ForgotOrResetPassword)

Custom content IDs are defined using the System > Custom Content page (see Listing Custom Content). 

To localize the content associated with the IDs listed above, you must add the locale code as a suffix to the ID. For 
example, to localize the epAnouncements content for France, add the “-fr_FR” suffix to the ID: epAnnouncements-
fr_FR. 

For step-by-step instructions, see Localizing Custom Content.

Additional Notes and Tips for Content Customization
A short list of tips to keep in mind as you customize End-User Portal pages. 

• Remember that custom content items replace the content in question rather than appending to it.

Claim and Activate ClaimAndActivateContent Displayed on the Claim and Activate page. Custom 
content for ClaimAndActivateContent is rendered 
below the page title (Claim and Activate) and above 
the form inputs on that page.

Map by 
Activation IDs

AddOnUserEntryContent Displayed on the Map by Activation IDs page. 
Custom content for AddOnUserEntryContent is 
rendered below the page title (Map by Activation 
IDs) and above the Device ID and Activation IDs 
field. 

Password Reset ForgotOrResetPassword Displayed when a user clicks the Forgot Password 
link on the sign-in page. On the Password Reset 
page, the user is asked for their user ID and then 
asked to correctly answer their security question. 

Expiring 
Entitlements

ExpiringEntitlementsContent Displayed when, in the End-User Portal, a user clicks 
Activations & Entitlements > Expiring Entitlements. 
On the Expiring Entitlements page, the End-User 
Portal shows a list of entitlements in which the 
entitlements due to expire soonest are listed first. 
ExpiringEntitlementsContent is rendered below the 
page title and above the list of entitlements. 
(Default: blank.)

Table 19-42 • Pages That Support Custom Content

End-User
Portal Page Content ID Description
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• To revert the content of an End-User Portal page back to the standard content, edit the page’s customized 
HTML content (Edit Custom Content Data) so that its Hide from Portal attribute is selected.

• A completely empty custom content file does not remove a page’s standard content. To remove standard 
page instructions, use an empty HTML comment in the page’s custom content. For example, <!-- -->. 

• Troubleshooting: In the End-User Portal pages, customizable content has HTML comments before and after it 
to indicate its custom content ID. Therefore, when you view the page source, you can see where the custom 
content is placed and what its ID is. Custom content appears like the following in the page source: 

<!--BEGIN HTML Content ID <Custom Content ID value> -->
<Custom Content> 
<!--END HTML Content ID <Custom Content ID value> -->

About Product Trial Registration Support 
Producers who want to offer trial registrations in the End-User Portal can use the TrialRegistration template to 
create a landing page for the free trial software users. 

The TrialRegistration template uses the AngularJS framework along with standard custom content functionality 
to render a list of trial products from which end users can select and form fields for them to enter an email 
address (required) as well as additional contact information. 

Tip • See About Trial Products to learn how to configure the products you want to make available for free trials.

Trial Registration Process
Upon successful submission of the trial registration form, FlexNet Operations generates a new account and a new 
user account for the trial user (based on the email address provided). FlexNet Operations also creates an 
entitlement for that user to the trial product the end-user selected. The End-User Portal sends an email based on 
the Welcome Email for End Users template to the new trial user, giving that user access to their trial entitlement 
on the End-User Portal. 

Tip • Producers can create a variation of the Welcome Email for End Users template to use specifically for trial 
registrations. This variation name is then used in the trial registration custom content. In the custom content for 
your Trial Registration page, locate the hidden input, emailTemplate, and replace default value 
{{formData.emailTemplate}} with the Welcome Email for End Users email template’s variation name. 

Sending End Users to a Trial Registration Page
With a custom content Trial Registration page, and all trial registration elements in place, producers can send 
trial users to their trial registration page using a URL based on their End-User Portal location domain plus the 
Permalink path for the trial registration custom content page. For example, if your End-User Portal is hosted at 
mycompany.flexnetoperations.com/flexnet/operationsportal and the content ID for your trial registration page is 
TrialReg, the URL for your trial registration page would be
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https://mycompany.flexnetoperations.com/flexnet/operationsportal/
showTrialRegisterUserPage.do?contentId=TrialReg

Showing a Custom Registration-Success Page (Optional)
When an end user successfully registers, the End-User Portal shows a simple registration-success page. 
However, a producer can create a custom registration-success page to show to end users who complete the trial 
registration form. To do so, a producer first creates a standalone custom content page to serve as the custom 
registration-success page. The content ID of this new standalone page can then be used as the value for the 
hidden landingContentId input on the Trial Registration page. 

Customizing Trial Registration Content
You can customize the trial registration template that is available on the Custom Content page. To access the trial 
registration template, in section Creating Custom Content, follow Step 1 through Step 4. By default, the trial 
registration template contains predefined code that you can customize as required. 

The Preview option  enables you to see how your code is rendered.

The following subsections explain the sections and individual fields that are included in the code, as well as how 
to customize the trial registration template code if custom attributes are used in FlexNet Operations.

“Trial Registration” Section
The only mandatory information that FlexNet Operations requires from a user to create an entitlement is a valid 
email address. Any other information is optional. 

Table 19-43 • Trial Registration Fields

Field(s) Description

userEmail Required. Prompts the user to enter their email address. The email address is 
the only user information required by FlexNet Operations to create an 
entitlement. 

By default, FlexNet Operations automatically generates the code snippet for 
the userEmail field with the label Email, and the field is displayed in the End-
User Portal. This is the address that the trial details will be sent to.

userFirstName

userLastName

companyphoneNumber

streetAddress

city

state

postalCode

Optional fields that can be used to collect additional customer information.

By default, FlexNet Operations automatically generates the code snippet for 
these additional fields. You can edit the code according to your requirements.



Chapter 19 Configuring FlexNet Operations
Managing Custom Content

704 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

“Product Selection” Section
There are several ways to let your users select one or more part numbers, or you can specify a predefined part 
number in a hidden field:

• Hidden input—Does not let the user select a part number. You can include a predefined part number that 
cannot be seen or modified by users when the form is submitted.

• Check boxes—Enables the user to select one or more predefined part numbers. If you present the user with 
this option, the user should be required to select at least one check box.

• Other selection/input mechanisms—Listing all available selection or input mechanisms here would exceed 
the scope of this documentation. Offer the mechanism that suits your environment.

“Additional Information” Section
This section contains code snippets that illustrate how to customize the trial registration template code if custom 
attributes are used in FlexNet Operations. These custom attributes can be user attributes, account attributes, or 
license attributes. For information about custom attributes, see Defining Custom Attributes.

Defining Custom Attributes
It is important that you use the same structure for your code as demonstrated in the code snippets, otherwise 
errors may occur. You can include CSS styles, if required. 

The following notes are applicable to all code snippets in this section and its subsections:

• Any class attribute must reference the style "liExtProperty". This style can only be used on list item (<li>) 
tags.

• class="required" marks the custom attribute as mandatory (the output includes the red * symbol). Leave this 
out if the custom attribute is optional.

• The code snippets use the ng-model directive to bind the value of a user input field to a variable created in 
AngularJS. Permitted binding values are formData.licenseCustomAttributes, 
formData.orgUnitCustomAttributes, and formData.userCustomAttributes.

Defining Custom User Attributes
When you define custom user attributes in FlexNet Operations, the trial registration template will automatically 
contain relevant code for these attributes. You can customize this code to suit your needs.

Example 
<li class="liExtProperty"><label >User_Identity:</label>

<input type='text' ng-model="formData.userCustomAttributes['User_Identity'][0]" />

Table 19-44 • Product Selection Fields

Field(s) Description

selectedPartNumbers Use this field to specify the part number or selection of part numbers.
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</li>
<li class="liExtProperty"><label class="required">User_Identity_required:</label>

<input type='text' ng-model="formData.userCustomAttributes['User_Identity_required'][0]" />
</li>

Defining Custom Account Attributes
When you define customer account attributes in FlexNet Operations, the trial registration template will 
automatically contain relevant code for these attributes. You can customize this code to suit your needs.

Example
<li class="liExtProperty"><label >Account_Custom_Attribute:</label>

<input type='text' ng-model="formData.orgUnitCustomAttributes['Account_Custom_Attribute'][0]" />
</li>
<li class="liExtProperty"><label class="required">Account_Custom_Attribute_Required:</label>

<input type='text' ng-model="formData.orgUnitCustomAttributes['Account_Custom_Attribute_
Required'][0]" />

</li>

Defining Custom License Attributes
When you define custom license attributes using FlexNet Operations for FlexNet Licensing, the trial registration 
template will automatically generate code for these attributes. However, the auto-generated code is not visible to 
the user until you remove the code style="display: none", which is included by default. For more information on 
the effect of style="display: none", see Customization with Toggle Switch for Custom License Attributes.

Producer Portal users need to ensure these custom license attributes match existing part numbers. For custom 
license technology (other than FlexNet Licensing), the producer user has to define custom license attributes 
manually. The code snippets in this section help you with this task.

Customizing Custom Content Code for a Single Part Number
The following code snippet demonstrates how to create a trial activation for only one part number. The snippet 
shows custom content code for data type “number”. For snippets using different data types, see Custom License 
Attribute Code Samples for Different Data Types.

<fieldset>
<ol>

<div id="Flexnet_Part1" class="WideColumnBlock left" >
<li class="liExtProperty"><label class="required">CustLMA1:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CustLMA1'][0]" />

</li>
</div>

</ol>
</fieldset>

Notes

• Flexnet_Part1 is the part number that was created and mapped to the product for trial activation.

• CustLMA1 is the name of the custom license model attribute.
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• In the trial registration template, this code snippet can be placed after the "Please answer the following 
questions" paragraph tag which is already included in the sample code.

Customizing Custom Content Code for Multiple Part Numbers with Different Custom 
License Attributes
If the trial registration allows the user to select between multiple part numbers, you can customize the content 
code so that either:

• only custom license attributes are displayed that apply to the part number that the user has selected. See 
Customization with Toggle Switch for Custom License Attributes.

• all configured custom license attributes are displayed in the End-User Portal, irrespective of the part number 
selection. See Customization Without Toggle Switch for Custom License Attributes.

The following subsections explain how to customize the code and possible use cases for both scenarios.

Customization with Toggle Switch for Custom License Attributes

When you customize the code to include a toggle switch, the End-User Portal initially does not display any custom 
license attributes. When the user selects a part number, only those custom license attributes are displayed that 
apply to the selected part number. When the user clears the part number selection, the custom license attributes 
are hidden.

Use the code style="display: none" to hide custom license attributes, as shown in the following snippet. 

<fieldset>
<ol> 

<div id="Flexnet_Part1" class="WideColumnBlock left" style="display: none" > 
<li class="liExtProperty"><label class="required">CUSTLMA_4_Flexnet_Part1:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CUSTLMA_4_Flexnet_Part1']
[0]" />

</li>
</div>
<div id="Flexnet_Part2" class="WideColumnBlock left" style="display: none" >

<li class="liExtProperty"><label class="required">CustLMA1:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CustLMA1'][0]" />

</li>
<li class="liExtProperty"><label >CustLMA2:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CustLMA2'][0]" />

</li>
</div>

</ol>
</fieldset>

Notes

• The code style="display: none" hides the license attributes for all unselected part numbers. If you want the 
preview to show the license attributes for all part numbers (regardless of whether they are selected), remove 
the code style="display: none" and then generate a preview. Make sure that after the preview you add this 
code back to the custom content to enable the toggle functionality in the End-User Portal.

• Flexnet_Part1 and Flexnet_Part2 are the part numbers created and mapped to products for trial activation.

• CUSTLMA_4_Flexnet_Part1, CustLMA1 and CustLMA2 are the names of the custom license model attributes.
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• License attributes CUSTLMA_4_Flexnet_Part1 and CustLMA1 are required attributes, as indicated by <label 
class="required">, whereas license attribute CustLMA2 is optional.

Customization Without Toggle Switch for Custom License Attributes

When you do not include a toggle switch, all configured custom license attributes related to available trial part 
numbers are displayed in the End-User Portal, irrespective of the part number selection.

Note • If you have multiple products defined that use different license models, it is possible that each license 
model has different custom license attributes defined. For trial activation, all custom license attributes that are 
associated with the product are displayed, irrespective of the selected part number. In this case, it might be 
advisable to include a toggle switch, as described in Customization with Toggle Switch for Custom License 
Attributes.

Sample code

<fieldset>
<ol>

<div id="Flexnet_Part1" class="WideColumnBlock left" > 
<li class="liExtProperty"><label class="required">CUSTLMA_4_Flexnet_Part1:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CUSTLMA_4_Flexnet_Part1']
[0]"/>

</li>
</div>
<div id="Flexnet_Part2" class="WideColumnBlock left"  >

<li class="liExtProperty"><label class="required">CustLMA1:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CustLMA1'][0]" />

</li>
<li class="liExtProperty"><label >CustLMA2:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CustLMA2'][0]" />

</li>
</div>

</ol>
</fieldset>

Notes

• Flexnet_Part1 and Flexnet_Part2 are the part numbers created and mapped to products for trial activation.

• CUSTLMA_4_Flexnet_Part1, CustLMA1 and CustLMA2 are the names of the custom license model attributes.

• License attributes CUSTLMA_4_Flexnet_Part1 and CustLMA1 are required attributes, as indicated by <label 
class="required">, whereas license attribute CustLMA2 is optional.

Custom License Attribute Code Samples for Different Data Types
The code snippets in this section demonstrate how to customize the custom license attributes for different data 
types.

Type "Number"
<li class="liExtProperty"><label >CUSTLMA_4_Flexnet_Part1:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CUSTLMA_4_Flexnet_Part1'][0]" />
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</li>

Type "Boolean"
<li class="liExtProperty"><label >CLM_BOOLEAN:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CLM_BOOLEAN'][0]" />

</li>

Note that currently the Boolean data type accepts only true or false as whole words, not T or F as on the Trial 
Registration page. 

Type "Date"
<li class="liExtProperty"><label >CLM_DATE:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CLM_DATE'][0]" />

</li>

Note that currently the Date data type accepts only the date format "MM/DD/YYYY" (for example, 10/24/2018) on the 
Trial Registration page. 

Type "Long Text" and Subtype "Text Area"
<li class="liExtProperty"><label >CLM_LONG_TXT_TXT_AREA:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CLM_LONG_TXT_TXT_AREA'][0]" />

</li>

Type "Long Text" and Subtype "Text Field"
<li class="liExtProperty"><label >CLM_LONG_TXT_TXT_FLD:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CLM_LONG_TXT_TXT_FLD'][0]" />

</li>

Type "Text" and Text Type "Single Select"

You can choose between a dropdown menu or radio buttons.

<li class="liExtProperty"><label >CLM_TEXT_FREFORM_SINGLE_SELECT:</label>

• Code snippet for dropdown menu:

<select ng-model="formData.licenseCustomAttributes['CLM_TEXT_FREFORM_SINGLE_SELECT'][0]"
ng-options="v as v for v in selectedLicenseCustomAttributes['CLM_TEXT_FREFORM_SINGLE_SELECT'].
values"/>

• Code snippet for radio buttons:

<table cellspacing="0" cellpadding="0" border="0">
<tbody><tr  ng-repeat="value in selectedLicenseCustomAttributes['CLM_TEXT_FREFORM_SINGLE_SELECT'].
values">
<td  valign="top" nowrap="true">
<input class="form"  type='radio' ng-
model="formData.licenseCustomAttributes['CLM_TEXT_FREFORM_SINGLE_SELECT']
[0]"
name="formData.licenseCustomAttributes['CLM_TEXT_FREFORM_SINGLE_SELECT'][0]" ng-
value="value" /><label style="text-align:left" >{{value}}</label>

</td>
</tr>
</tbody>
</table>
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Type "Text", Text Type "Free Form" and Display Type "Text Area"
<li class="liExtProperty"><label >CLM_TEXT_FREFORM_TXTAREA:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CLM_TEXT_FREFORM_TXTAREA'][0]" />

</li>

Type "Text", Text Type "Free Form" and Display Type "Text Field"
<li class="liExtProperty"><label >CLM_TEXT_FREFORM_TXTFIELD:</label>
<input type='text' ng-model="formData.licenseCustomAttributes['CLM_TEXT_FREFORM_TXTFIELD'][0]" />

</li>

Type "Text" and Text Type "Multi-Valued Text"
<li class="liExtProperty"><label >CLM_TEXT_MULTI_VALUED_TXT:</label>
<table cellspacing="0" cellpadding="0" border="0">
<tbody><tr ng-repeat="value in selectedLicenseCustomAttributes['CLM_TEXT_MULTI_VALUED_TXT'].values">
<td  valign="top" nowrap="true">

<input class="form"  type='checkbox' ng-model="value.checked"   />
<label style="text-align:left" >{{value.val}}</label>

</td>
</tr>

</tbody>
</table>

</li>

Listing Custom Content 
Use the System menu to show a list of all existing custom content items. 

Task To list custom content

Click System > Custom Content. 

The Producer Portal shows the Custom Content page. This page shows the ID, description, and status of each 
custom content item, plus its last modified date and the Producer Portal user who made the modification. Click 
the ID of a custom content item to see its Edit Content page. 

Creating Custom Content 
You can create custom content items from the Custom Content page. A new custom content item can replace the 
default content (if any) on a supported End-User Portal page or create a new standalone page. 

Task To create custom content

1. On the Custom Content page, click Create Content. The Producer Portal opens the Create Content page. 

2. On the Create Content page, set content details and enter the custom content in the field provided. See 
Custom Content Attributes in About Custom Content for more information. 
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Important • To change the content for a supported End-User Portal page, you must use the custom content 
ID for that page. To instead create a custom, standalone page, you must use a unique, unused custom 
content ID value. See Pages that Support Custom Content in About Custom Content for details. 

3. Choose whether the custom content is available to viewers in the End-User Portal: 

• Select the Hide from Portal? check box to prevent this content from appearing in the End-User Portal.

• Leave the Hide from Portal? check box unchecked to allow this content to appear in the End-User Portal 
(when its status is Live). 

4. Choose a template. 

• For producers who want to create a landing page for free product trial registrations, click Template > 
TrialRegistration. See About Product Trial Registration Support for more information, in particular 
Sending End Users to a Trial Registration Page, which includes the URL for your trial registration page.

• For all other custom content pages, leave Template blank. 

5. Click the Preview icon. The Producer Portal shows the Preview Content in a pop-up window where you can 
see the custom content rendered.

6. Choose whether to save the custom content as a draft or to save and publish it: 

• Click Save Draft to save the content in its current state in Draft status. The Producer Portal saves the 
custom content with a status of Draft. 

• Click Publish to save the content in its current state in Live status. The Producer Portal saves the custom 
content with a status of Live. Custom content with Live status is available to End-User Portal users 
unless its Hide from Portal? check box is selected.

You can edit the custom content later by clicking its ID on the Custom Content page.

Editing Custom Content 
When you edit custom content, you can alter its ID, description, the custom content, whether or not to show the 
content in the End-User Portal, and its version. 

Tip • Notice that the custom content details on Edit Content page include a Permalink attribute. If the custom 
content is to be used as a stand-alone page, use the Permalink URI to link to your custom page.

Note • For more information about the use of content customizations, see About Custom Content.

Task To edit custom content

1. On the Custom Content page, click the ID of the item to edit. The Producer Portal opens the Edit Content page 
for the custom content. 

2. If necessary, change the content ID or description for this custom content.
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3. Choose whether the custom content is available to viewers in the End-User Portal: 

• Select the Hide from Portal? check box to prevent this content from appearing in the End-User Portal.

• Leave the Hide from Portal? check box unselected to allow this content to appear in the End-User Portal 
(when its status is Live). 

4. If necessary, change the version of the custom content with the Content Version control.

5. In Content, revise the text or HTML as needed. 

6. Click the Preview icon. The Producer Portal shows the Preview Content in a pop-up window where you can 
see the custom content rendered.

7. Choose whether to save the custom content as a draft or to save and publish it: 

• Click Save Draft to save the content in its current state in Draft status. The Producer Portal saves the 
custom content with a status of Draft. 

• Click Publish to save the content in its current state in Live status. The Producer Portal saves the custom 
content with a status of Live. Custom content with Live status is available to End-User Portal users 
unless its Hide from Portal? check box is selected. 

Tip • Note that the Permalink attribute on the Edit Content page identifies the path to the custom content page 
where your End-User Portal is hosted. You can link directly to the custom content page by creating a URL that 
uses your End-User Portal domain plus the Permalink value. 

Localizing Custom Content
You can update page instructions for localized sites. When you localize custom content, you create new content 
by suffixing a custom content ID with a locale code. You can also decide whether or not to show the content in the 
End-User Portal.

Note • For information about the content that is localizable, see Localization and Custom Content.

Task To localize custom content

1. On the Custom Content page, click Create Content. The Producer Portal opens the Create Content page.

2. On the Create Content page, provide the following information:

a. Content ID: Enter the content ID of a supported End-User Portal page, followed by the locale code as a 
suffix to the ID. For example, to localize the epAnouncements content for France, add the “-fr_FR” suffix to 
the ID: epAnnouncements-fr_FR.

b. Description: Enter a descriptive name for custom content. (This content will not be visible on the End-
User Portal page.)

c. Choose whether the custom content is available to viewers in the End-User Portal: 
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• Select the Hide from Portal? check box to prevent this content from appearing in the End-User 
Portal.

• Leave the Hide from Portal? check box unselected to allow this content to appear in the End-User 
Portal (when its status is Live). 

3. Leave Template blank.

4. In Content, enter the localized text or HTML to be displayed in the End-User Portal.

5. Click the Preview icon. The Producer Portal shows the Preview Content in a pop-up window where you can 
see the custom content rendered.

6. Choose whether to save the custom content as a draft or to save and publish it: 

• Click Save Draft to save the content in its current state in Draft status. The Producer Portal saves the 
custom content with a status of Draft. 

• Click Publish to save the content in its current state in Live status. The Producer Portal saves the custom 
content with a status of Live. Custom content with Live status is available to End-User Portal users 
unless its Hide from Portal? check box is selected. 
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Performing Administrative Tasks

Depending on the permissions you have been granted through FlexNet Operations roles, you can perform 
administration activities using the links in the Administer menu. 

Table 20-1 • 

Topic Description

Administering Alerts View and configure alerts using the Alerts links in the Administer menu.

Administering Custom 
Attributes

View and manage custom attributes, custom host attributes, and custom license 
attributes.

Administering Domains View, add, and edit domains.

Importing and Exporting 
Entities

Migrate data between different FlexNet Operations instances by importing or 
exporting entities. 

Administering License 
Technologies

Use the License Setup and Custom Attributes links in the Administer menu to 
manage license technologies and license generator configurations, and custom 
license generator and license model attributes.

Administering License 
Models

View, add, and edit license models.

Working with Time 
Zones

Describes how to use the time zone functionality to bind license usage to a 
specified geographic location by identifying the time zone of that region. Only for 
producers who use certificate-based licenses.

Administering Device 
and License Server 
Setup

Covers the setup and administration of device series, device models, server host 
types, publishers, and publisher identities. 
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Administering Alerts 
Alerts, which by default are displayed in the Start Page, notify FlexNet Operations users of events that may 
require attention, such as expired or expiring entitlements, updated product definitions, or notifications for 
importing product part numbers or bulk entitlement Web register keys. 

Alerts pages allow you to view a summary of alerts, view the types of alerts, and define alerts. Depending on the 
permissions you have been granted through roles, you can browse alert messages that have been triggered (and 
not dismissed) or configure how alerts behave and who is notified when they are triggered. 

Working with 
Transaction Keys

Only for producers who use FlexNet licensing with trusted storage, this section 
explains how to use transaction keys and anchoring. 

Working with 
Application 
Specification Records 
(ASRs)

Explains the use of Application Specification Records (ASRs) for local trials and 
short code activation. 

View and Manage 
Trusted Activation 
Requests

Describes how to administer trusted activation requests.

Managing Email and 
Email Templates

Covers the administration of email messaging as well as email template 
management.

Table 20-2 • 

Topic Description

Browsing Alerts Explains how to view alerts. 

Dismissing (Removing) 
an Alert

Describes how to remove alerts from the Alerts page.

Configuring Alert 
Behavior

Shows how to configure alert behavior, including setting detection and notification 
interval, setting email notification properties, and limiting who can see an alert by 
their user role.

Setting Alert 
Subscriptions

Explains how to subscribe to an alert. Producers who subscribe to an alert receive 
an email when the job associated with that alert runs (depending on which alerts 
have been configured, the outcome of the job, and the subscription properties you 
set). 

FlexNet Operations 
Alert Types

Provides more information about alert types. 

Table 20-1 • 

Topic Description
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Browsing Alerts 
Recent alerts appear on the Producer Portal home page, but you can also browse alerts via the Administer menu. 

Users assigned roles with the View Alerts or View and Manage Alerts permission can view a summary of alerts.

Task To view a summary of alerts

• Click Administer > Alerts. 

The Producer Portal shows the Alerts page. 

In the Alerts page, you can view the

• Date: Date the alert message was sent 

• Message: Text of the alert message 

Dismissing (Removing) an Alert 
When an alert message is dismissed, its message is removed from the Alerts page. After an alert message is 
dismissed, the alert is displayed again if the alert condition is not corrected before the next time the alert 
condition is checked (based on the alert’s detection and notification interval). 

Users assigned a role with the View and Manage Alerts permission can dismiss an alert. 

Task To remove an alert

On the Alerts page, select the alert and then click Dismiss to remove it from the list. 

Configuring Alert Behavior
There are alerts available in FlexNet Operations that can be used to notify specified users about different types of 
conditions or events. Alerts can be configured to display to the Alerts page or to send one or more email 
messages. 

Users assigned a role with the View and Manage Alert Configurations permission can configure alert behavior.

Task To configure the behavior of an alert

1. Click Administer > Configure Alerts/Jobs. 

2. For the alert type you want to configure, click Configure. The Producer Portal shows the Configure Alert/Job 
Schedule page.

3. On the Configure Alert/Job Schedule page, select a Status of Active or Inactive. When you select Active, the 
Schedule option appears. For all alerts, except Purge Email History, the default status is Inactive.

4. For the Schedule option you can: 
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• Select the Standard option to set the number and time interval (default is 30 days). 

Note • For Purge Email History, the default setting is to run once a day. It purges all sent emails older 
than 183 days or whatever is configured in System > Configuration.

• Select the Advanced option to set a cron expression for the time and frequency of the schedule. See 
Creating a Customized Schedule for more information.

An alert condition is first checked within a couple of minutes of the configuration being saved. 
Thereafter, the alert condition is checked according to the Schedule. For example, if an alert was 
configured with an interval of 15 minutes, the first check occurs a couple of minutes after the 
configuration is saved. The second check occurs 15 minutes after the first checking process finishes, 
the third check occurs 15 minutes after the second checking process finishes, etc. Therefore, the clock 
time that an alert condition is checked varies according to when the original alert configuration was 
saved and how long each checking process lasts. 

5. Specify a Subscription Restriction. You can choose to allow only certain roles to subscribe to the alert.

• Click Add. 

• Check the role(s) that you wish to allow to subscribe to that alert.

• Click Select, to save.

6. Click Save. 

The Producer Portal saves your alert behavior changes. 

Creating a Customized Schedule
For more advanced scheduling options, you can use a CronTrigger using a standard cron expression. A cron 
expression is a string consisting 6-7 fields (sub-expressions) that describe the details of the schedule. These 
fields are separated by a white space and are described in table Allowed Fields and Values of Cron Expressions in 
their expected order. 

Table 20-3 • Allowed Fields and Values of Cron Expressions

Field Required Allowed Values Allowed Special Characters

Seconds Yes 0-59 , - * /

Minutes Yes 0-59 , - * /

Hours Yes 0-23 , - * /

Day of Month Yes 1-3 , - * / ? L W

Month Yes 0-11 or JAN-DEC , - * /

Day of Week Yes 1-7 or SUN-SAT , - * / ? L #

Year No empty or 1970-2099 , - * /
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The purpose of the special characters is explained in the following table:

Table 20-4 • Explanation of Special Characters

Character Description

, Used to specify a list of values not in a range. For example: “2,4,6” or 
“MON,WED,FRI” in the day-of-the-week field means “the days Monday, Wednesday 
and Friday”.

- Used to indicate a range of values or an offset. For example “10-12” in the hour field 
means “the hours 10-12”.

* Wildcard meaning every possible value of this field.

/ Used to specify increments to values. For example “0/15” in the minutes field 
means “every 15th minute of the hour, starting at minute zero”, i.e. 0, 15, 30, and 
45. A “3/20” in the minutes field means “every 20 minutes starting at minute 3”, i.e. 
3, 23 and 43. A “1/3” in the day-of-the-month field means “every three days 
starting on the first day of the month.” Omitting the initial number is equivalent to 
using 0, i.e. “/35” is the same as “0/35”.

? Used for day-of-the-month and day-of-the-week fields to mean “no specific value”. 
This is useful when you must specify something in one of the two fields but not the 
other. For example if you want to schedule a job for the 10th day of the month, 
regardless of the day of the week, you would put a “10” in the day-of-the-month 
field and a “?” in the day-of-the-week field.

L Used for day-of-the-month and day-of-the-week fields and is used to specify “Last”, 
but it has different interpretations in each of those fields. An “L” in the day-of-the-
month field means the “last day of the month, i.e. 31 for January or 28 for February 
on non-leap years and 29 on leap years.

If used in the day-of-the-week field by itself, it means “7” or “SAT”, but if used in the 
day-of-the-week field after another value, it means the last X day of the month. For 
example, “6L” or “FRIL” both mean “the last Friday of the month.” You can also 
specify offsets such as “L-3” which means the third to the last day of the calendar 
month.

Note • When using the “L” option, it is important not to specify lists or ranges of 
values as you will get unexpected results.

The “L” and “W” characters can be combined in the day-of-the-month field to yield 
“LW” which means “last weekday of the month”.
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Cron Expression Examples
The following table gives a list of example cron expressions.

W Used to specify the “Weekday” (Monday-Friday) nearest the given day. For example 
15W as a day-of-the-month value means, “the nearest weekday to the 15th of the 
month.” However, if you specify “1W” as the value for the day-of-the-month and the 
1st is on a Saturday, the job is scheduled for Monday, the 3rd because the previous 
Friday (which is closer to the 1st) is in a different month.

Note • When using the “W” option, it is important not to specify lists or ranges of 
values as you will get unexpected results.

# Used for day-of-the-week fields to specify nth X day of the month. For example, the 
value “6#3” or “FRI#3” means “the third Friday of the month.”

Note • If you specify #5 and there are not 5 of the given day-of-the-week in the 
month, then no firing occurs that month.

Table 20-5 • Sample Cron Expressions

Expression Meaning

0 0 12 * * ? Fire at 12:00pm (noon) every day

0 15 10 ? * * Fire at 10:15am every day

0 15 10 * * ? Fire at 10:15am every day

0 15 10 * * ? * Fire at 10:15am every day

0 15 10 * * ? 2017 Fire at 10:15am every day during the year 2017

0 10,44 14 ? 3 WED Fire at 2:10pm and at 2:44pm every Wednesday in the month of March

0 15 10 ? * MON-FRI Fire at 10:15am every Monday, Tuesday, Wednesday, Thursday, and Friday

0 15 10 15 * ? Fire at 10:15am on the 15th day of every month

0 15 10 L * ? Fire at 10:15am on the last day of every month

0 15 10 L-2 * ? Fire at 10:15am on the 2nd-to-last day of every month

0 15 10 ? * 6L Fire at 10:15am on the last Friday of every month

Table 20-4 •  (cont.)Explanation of Special Characters

Character Description
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Note • Be mindful of setting times between the hours of the morning when the change to or from “daylight saving 
time” begins (for U.S. locales, this is between 1 am and 3 am) because the time shift can cause a skip or a repeat 
depending on whether the time moves back or jumps forward.

Setting Alert Subscriptions
After you have set the behavior of an alert type, you can set up to three email subscriptions for that alert type. 
Users assigned a role with the View and Manage Alert Configurations permission can set an alert subscription.

Task To set an email subscription for an alert type

1. In the user menu, click your name and then click Alert Subscriptions.

2. Click Subscribe/Edit for one of the alert types.

3. In the Create/Edit Alert Subscription page, set the following properties:

• Inbox Notification: Choose whether or not to display the alert in the Alerts page. Once the alert has been 
displayed in the page, it is not displayed again unless the alert is dismissed and the alert condition 
remains uncorrected.

• Show Additional Email Notifications: Select the box to configure more than one email subscription. One 
email notification per detected alert is sent for each email subscription that is specified for an alert. 
Consider setting up multiple email subscriptions with different trigger times to escalate alerts to 
different email recipients if an alert condition is not corrected. 

Task To configure email subscription properties

1. Select the Enabled check box for the subscription.

2. Supply the following information for the alert subscription:

0 15 10 ? * 6L Fire at 10:15am on the last Friday of every month

0 15 10 ? * 6L 2017-
2020

Fire at 10:15am on every last Friday of every month during the years 2017, 2018, 
2019, and 2020

0 15 10 ? * 6#3 Fire at 10:15am on the third Friday of every month

0 0 12 1/5 * ? Fire at 12pm (noon) every 5 days every month, starting on the first day of the month

0 11 11 11 11 ? Fire every November 11th at 11:11am

Table 20-5 •  (cont.)Sample Cron Expressions

Expression Meaning
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• Trigger time: Minutes, hours, days after the alert date or days before the alert date. The alert date is the 
time the alert condition began, and the trigger time is the time offset from the alert date when the alert 
email is triggered, but not necessarily sent. Email with a trigger delay is sent when the alert condition is 
next checked after the trigger time has passed, if the triggering alert has not been dismissed.

Note that if an email subscription is set with a trigger time delay (for example, 1 hour) less than the 
detection interval (for example, 1 day), an email could be triggered by an alert condition on Monday, but 
not actually be sent until the alert is checked again on Tuesday (if the alert was not dismissed). 
Therefore, for clarity, set a trigger time to be a multiple of the Detection and Notification Interval.

We strongly recommend setting one subscription to trigger immediately upon detection of the event and 
setting trigger time delays only on additional subscriptions.

• Send Email to: Address for alert email. Multiple email address can be specified in a comma-separated 
list.

3. Click Save.

FlexNet Operations Alert Types
Alerts can be used to notify specified users about different types of conditions or events. 

In new installations of FlexNet Operations, all alerts are set to Inactive. If you want an alert to run, you must set its 
status to active and define an interval at which it is to run. (Upgrades of FlexNet Operations from previous 
versions retain the previous alert status.) 

Table 20-6 • FlexNet Operations Alerts

Alert Type Possible Values Description

User Deactivated Detection and 
notification interval: n 
minutes, hours, days. 
The default is 30 
seconds. 

Generated when a user has been deactivated because 
the user has incorrectly logged in to FlexNet Operations 
too many times. The number of times that a user login 
can fail within a specified time period before being 
deactivated can be configured in the FlexNet Platform 
Server configuration. A FlexNet Operations administrator 
must reactivate a deactivated user before the user can 
log in to FlexNet Operations again. 

Expired/Expiring 
Entitlements

Detection and 
notification interval: n 
minutes, hours, days. 
The default is 1 day. 

Generated when any entitlement line items are expiring in 
the next 30 days. Lists all of the line items that are 
expiring in the next 30 days and all the line items that 
have already expired. 

Updated Products Detection and 
notification interval: n 
minutes, hours, days. 
The default is 1 day.

Generated when a Licensed Product is updated. 
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Importing Bulk 
Entitlement Web 
Register Keys 

Detection and 
notification interval: n 
minutes, hours, days. 
The default is 1 day.

Generated when bulk entitlement Web register keys are 
imported. 

This job is required for producers who want to load Web 
register keys via a user-supplied file, via auto-generation, 
or via Web service requests that are processed 
asynchronously. 

Tip • If this job is not active, FlexNet Operations does not 
import Web register keys. See Loading Web Register Keys 
for more information.

Importing Part Numbers Detection and 
notification interval: n 
minutes, hours, days. 
The default is 30 days. 

Generated when part numbers are imported.

Export and Import 
Background Jobs

Detection and 
notification interval: n 
minutes, hours, days. 
The default is 1 day.

Controls how frequently FlexNet Operations checks for 
new export or import background jobs. 

When scheduled and active, this job runs background 
import jobs based on both JAR file imports and data 
import template imports. Likewise, this alert runs any 
background export jobs (regardless of format) that are 
pending. 

Fulfillment Data Extract Detection and 
notification interval: n 
minutes, hours, days. 
The default is 30 days.

Controls how often FlexNet Operations runs a job to 
generate a snapshot of fulfillment events. 

This job takes a snapshot of fulfillments that have been 
created or updated. Designed to be run on a daily basis, 
this job’s first run gathers data on events from the 
previous day—from 00:00:00 until 23:59:59. 
Subsequently, the job attempts to gather data on events 
starting from the end of the last successful run of the job 
until the current time.  

Note • For more information on this extract, see the 
FlexNet Operations Web Services Integration Guide.

Table 20-6 • FlexNet Operations Alerts

Alert Type Possible Values Description
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Device Data Extract Detection and 
notification interval: n 
minutes, hours, days. 
The default is 30 days.

Controls how often FlexNet Operations runs a job to 
generate a snapshot of device and license server events. 

This job takes a snapshot of devices and license servers 
that have been created or updated (including the licenses 
mapped to them). Designed to be run on a daily basis, 
this job’s first run gathers data on events from the 
previous day—from 00:00:00 until 23:59:59. 
Subsequently, the job attempts to gather data on events 
starting from the end of the last successful run of the job 
until the current time.

Note • For more information on this extract, see the 
FlexNet Operations Web Services Integration Guide.

Version • Only producers who use FlexNet Embedded 
licensing gather device and license server events.

Served Device 
Data Extract

Detection and 
notification interval: n 
minutes, hours, days. 
The default is 30 days.

Controls how often FlexNet Operations runs a job to 
generate a snapshot of served device events. 

This job takes a snapshot of served devices that have 
been created or updated. Designed to be run on a daily 
basis, this job’s first run gathers data on events from the 
previous day—from 00:00:00 until 23:59:59. 
Subsequently, the job attempts to gather data on events 
starting from the end of the last successful run of the job 
until the current time.

Note • For more information on this extract, see the 
FlexNet Operations Web Services Integration Guide.

Version • Only producers who use FlexNet Embedded 
licensing gather served device events.

Table 20-6 • FlexNet Operations Alerts

Alert Type Possible Values Description
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User Data Extract Detection and 
notification interval: n 
minutes, hours, days. 
The default is 30 days.

Controls how often FlexNet Operations runs a job to 
generate a snapshot of user events. 

This job takes a snapshot of user accounts that have 
been created or updated. Designed to be run on a daily 
basis, this job’s first run gathers data on events from the 
previous day—from 00:00:00 until 23:59:59. 
Subsequently, the job attempts to gather data on events 
starting from the end of the last successful run of the job 
until the current time.

Note • For more information on this extract, see the 
FlexNet Operations Web Services Integration Guide.

Account Data Extract Detection and 
notification interval: n 
minutes, hours, days. 
The default is 30 days.

Controls how often FlexNet Operations runs a job to 
generate a snapshot of account events. 

This job takes a snapshot of accounts that have been 
created or updated. Designed to be run on a daily basis, 
this job’s first run gathers data on events from the 
previous day—from 00:00:00 until 23:59:59. 
Subsequently, the job attempts to gather data on events 
starting from the end of the last successful run of the job 
until the current time.

Note • For more information on this extract, see the 
FlexNet Operations Web Services Integration Guide.

Usage Data Extract Detection and 
notification interval: n 
minutes, hours, days. 
The default is 30 days.

Controls how often FlexNet Operations runs a job to 
generate a snapshot of all usage events from the 
previous day. 

Designed to be run on a daily basis, this job’s first run 
gathers data on events from the previous day—from 
00:00:00 until 23:59:59. Subsequently, the job attempts 
to gather data on events starting from the end of the last 
successful run of the job until the current time.

Note • For more information on this extract, see the 
FlexNet Operations Web Services Integration Guide.

Table 20-6 • FlexNet Operations Alerts

Alert Type Possible Values Description
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Product Version 
Upgrade

Detection and 
notification interval: n 
minutes, hours, days. 
The default is 30 days.

Controls how often FlexNet Operations runs a job to 
automatically add product upgrade line items to eligible 
entitlements. This job creates upgrade line items for 
qualifying products and line items.

Note that logic the Product Version Upgrade job may 
create unwanted upgrade lines and related email 
messages for producers who are not properly prepared 
for its use.

See More About the Product Version Upgrade Job for 
guidelines about using this job as well as product and 
line-item eligibility requirements. 

Expiring Entitlements Detection and 
notification interval: n 
minutes, hours, days. 
The default is 30 days.

Controls how often FlexNet Operations runs a job to 
identify entitlements scheduled to expire in the near 
future. 

When this job finds entitlements that are nearing their 
expiration date, FlexNet Operations generates a Renewal 
Reminder email message and sends it to end users in the 
account that owns the entitlement and have subscribed 
to receive renewal notifications (users that have the 
Expiring Entitlements Email check box selected).

See More About the Expiring Entitlements Job for 
guidelines about using this job.

Expired Entitlements Detection and 
notification interval: n 
minutes, hours, days. 
The default is 30 days.

Controls how often FlexNet Operations runs a job to 
identify entitlements that have expired. 

When this job finds entitlements that have expired, 
FlexNet Operations generates an Expired Entitlements 
email message and sends it to end users in the account 
that owns the entitlement and have subscribed to receive 
renewal notifications (users that have the Expiring 
Entitlements Email check box selected). 

See More About the Expired Entitlements Job for 
guidelines about using this job. 

Table 20-6 • FlexNet Operations Alerts

Alert Type Possible Values Description
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More About the Product Version Upgrade Job
The Product Version Upgrade job automates the creation of upgrade line items. For eligible products and line 
items, it causes FlexNet Operations to create upgrade line items, to add them to existing entitlements, and to 
send an email message to end users to notify them about the upgrade. 

Important • To avoid the creation of unexpected upgrade line items and unwanted email messages, be sure to 
review the guidance in Product Version Upgrade Use Guidelines and Product and Line Item Eligibility Rules before 
scheduling the Product Version Upgrade job. 

Product Version Upgrade Use Guidelines
Due to the qualifications FlexNet Operations uses to determine which entitlements receive the automatic upgrade 
line items, the use of this feature is best suited for producers who structure their product upgrades in the 
following ways: 

• Product upgrade relationships are relatively simple. Products upgrade in a direct line from one version to the 
next without branching into multiple upgrade paths. 

• Permanent entitlements, if offered, are sold with maintenance items. 

• All accounts are entitled to product upgrades. (No need to filter out specific accounts.) 

Producers who follow different product upgrade models may not benefit from using the Product Version Upgrade 
Job.

Note • To support the Product Version Upgrade job, products include product-upgrade-specific attributes: Start 
Date, End Date, and Email Template to Use for Product Upgrade. The dates play a role in determining which 
products are eligible to upgrade. The email template attribute specifies which variation to use for the email 
messages sent to end users as a result of this new job. See Creating a Product for more information.

Entitlement Data 
Extract

Detection and 
notification interval: n 
minutes, hours, days. 
The default is 1 day. 

Controls how often FlexNet Operations runs a job to 
generate a snapshot of all entitlement data from the 
previous day. 

Designed to be run on a daily basis, this job’s first run 
gathers data on events from the previous day—from 
00:00:00 until 23:59:59. Subsequently, the job attempts 
to gather data on events starting from the end of the last 
successful run of the job until the current time.

Note • For more information on this extract, see the 
FlexNet Operations Web Services Integration Guide. 

Table 20-6 • FlexNet Operations Alerts

Alert Type Possible Values Description
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Product and Line Item Eligibility Rules
The Product Version Upgrade job determines which entitlements receive upgrade line items based on associated 
product and line item attributes.

• Upgrade relationships must exist between the products (with only one possible upgrade-to path). 

• The license model to use for upgrade entitlements must be clearly determined due to some combination of 
the following conditions: 

• An upgrade product is linked to the same license model as the license model on the line item to be 
upgraded.

• An upgrade product is linked to only one license model.

• A default license model has been defined on an upgrade relationship. (See Relating Products to Other 
Products for instructions on setting the default license model in Upgrade Default Model for an upgrade 
relationship.)

• Product start and end dates are either valid or unspecified.

• Line items must be deployed.

• Line items cannot include multiple products.

• Permanent line items must be linked to a maintenance item that has not expired.

• Non-permanent line items must not be expired (past a known end date). They are not required to be linked to 
a maintenance item. However, when a non-permanent line item is linked to a maintenance item, the 
maintenance item must not be expired. 

• If a line item is linked to a maintenance line item, the following conditions must be met: 

• Maintenance products must have Allow Upgrades set to Yes. 

• The upgrade-to product must be related to all the maintenance products to which the upgrade-from 
product is related. The Product Version Upgrade job does not create upgrade lines for a product if the 
upgrade-from product has relationships that the upgrade-to product does not have.

• Line items must not already have been otherwise upgraded, upsold, or renewed.

Entitlements that do not meet these qualifications are ignored by the upgrade job. 

Avoiding the Creation of Upgrade Line Items with Incompatible License Models
Some license technology and license model conflicts can prevent the successful activation of upgrade line items. 
(FlexNet Operations does not prevent the creation of these upgrade line items, but the resulting line items cannot 
be successfully activated.) The following upgrade paths result in upgrade line items that cannot be activated: 

Table 20-7 • 

Upgrading From Upgrading To Notes

Custom licensing FlexNet Publisher 
Trusted Licensing

Sharing counts between a license model from a custom 
license technology and retail activation license model is 
not supported.
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Information Copied During the Upgrade
During the upgrade job, the following information is copied from the line item to be upgraded to the upgrade line: 

• License model (if possible)

• Start date and license term settings

• Number of copies

• Custom line item attribute values

• Entitlement-time license model attribute values. (This copying happens even if the license technologies are 
different as long as the license model attributes have the same name and data type.)

Tip • To learn about how predefined and custom attribute values can be substituted into license strings, see 
Employing a Predefined Substitution Variable. 

Running the Job
Producers can schedule the Product Version Upgrade job to run activating the Product Version Upgrade alert on 
its Configure Alert Definition page. By default, this alert is inactive and the Product Version Upgrade job does not 
run. (See Configuring Alert Behavior for instructions.) 

When the Product Version Upgrade job is completed, customers can use the End-User Portal to view the new 
upgrade line items in their entitlements, then download and activate them. 

More About the Expiring Entitlements Job
The Expiring Entitlements job finds entitlements that are nearing their expiration date and generates email 
messages to end user accounts with expiring entitlements. 

FlexNet Publisher 
Certificate Licensing

FlexNet Publisher 
Trusted Licensing

Sharing counts between a floating, counted license 
model and a retail activation license model is not 
supported.

FlexNet Embedded 
Licensing

FlexNet Publisher 
Certificate Licensing

Sharing counts between an embedded counted license 
model and a node-locked, uncounted license model is 
not supported.

FlexNet Embedded 
Licensing

FlexNet Publisher 
Trusted Licensing

Sharing counts between an embedded, counted license 
model and a retail activation license model is not 
supported.

Table 20-7 • 

Upgrading From Upgrading To Notes
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Like other jobs, producers can schedule the Expiring Entitlements job and subscribe to its alerts in the Producer 
Portal. However, when the Expiring Entitlements job finds entitlements that are soon to expire for an account, 
FlexNet Operations generates an email message about that account’s expiring entitlements and attempts to send 
the message to the account’s users. End users who elect to receive renewal notifications will receive an email 
message when their account’s entitlements are nearing their expiration date. 

The FlexNet Customer Growth module also adds an End-User Portal page to list expiring entitlements and to 
highlight those entitlements that are closest to their expiration date. From this Expiring Entitlements page, end 
users can click the Request button to send the producer an email message that indicates their intent to renew. 

For producers, a number of system configuration settings determine when email messages are triggered, which 
entitlements are included in the Renewal Reminder message, whether or not an email is to be sent, and how 
frequently an account can receive such email messages. Producers can also customize the email template 
FlexNet Operations uses when it sends these renewal notifications. 

Tip • In determining when to send an Renewal Reminder email message, FlexNet Operations uses the system 
configuration settings Renewal Look Ahead (default: 200 days), Expiring Window (default: 90 days), and Expiring 
Email Frequency (default: 30 days). These values are set in the Renewals settings on the FlexNet Operations 
system configuration page at System > Configure > FlexNet Operations. For details about these system 
configuration settings, see Configuring System Settings.

Understanding When FlexNet Operations Generates a Renewal Reminder Email 
Message
When the Expiring Entitlements job runs, it scans all of your end user accounts’ entitlements to see if any are 
approaching their expiration date. For a given account, FlexNet Operations first looks to see if any of the 
entitlements have line items or maintenance lines expiration dates that fall within the Expiring Window. If so, 
FlexNet Operations then checks when that account last received an Renewal Reminder email message. 

• If FlexNet Operations has recently sent an Renewal Reminder email message to the account, no new email 
messages are sent, even if newly expiring entitlements (per the Expiring Window setting) are discovered 
when the Expiring Entitlements job runs. 

• If FlexNet Operations has not sent an email to the account within the number of days specified in the system 
configuration setting, Expiring Email Frequency, it generates a new Renewal Reminder email message for 
that account. 

Using the default system configuration settings, when an account has expiring entitlements, FlexNet Operations 
limits the frequency of its renewal reminders to once every 30 days per account. Producers can customize this 
frequency (Expiring Email Frequency) to best suit the needs of their end users.

Note • The decision of whether or not to generate an email is made at the account level. The choice to receive 
renewal notifications happens at the user level. End users who belong to multiple accounts may receive multiple 
Renewal Reminder messages (one for each account that qualifies for an Renewal Reminder email message). 

Anticipating the Content of the Renewal Reminder Email Message
The content of the Renewal Reminder email message that FlexNet Operations generates depends mainly on two 
factors: 
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• The Renewal Reminder email template content. Producers can customize the content of the email template 
FlexNet Operations uses to send Renewal Reminder email messages. (See Managing Email Templates for 
instructions on editing an email template.) 

• The account’s entitlement line items and maintenance lines that expire within the number of days specified 
in the system configuration setting, Renewal Look Ahead. 

For the Renewal Reminder email message, FlexNet Operations compiles a list of all the account’s entitlements 
with line items or maintenance lines that expire within the Renewal Look Ahead range. All the account’s line items 
and maintenance lines that expire within that range are all included in the Renewal Reminder email message that 
FlexNet Operations generates. 

Tip • The Renewal Look Ahead is a separate system configuration from the Expiring Window setting. The Expiring 
Window determines whether or not to generate an Renewal Reminder message. The Renewal Look Ahead 
determines which line items or maintenance lines are included in the message itself. 

Understanding Who Receives Renewal Reminders
After generating a Renewal Reminder message for an account, FlexNet Operations sends the message to that 
account’s End-User Portal users who have opted to receive expiring entitlement email. If none of the account’s 
end users is subscribed to receive renewal reminders, FlexNet Operations instead sends the Renewal Reminder 
message to the address you specify for the system configuration setting, Renewal Failed Notification Email 
(optional). If there are no end users who have subscribed to receive renewal reminders and no valid email 
address specified for Renewal Failed Notification Email, then FlexNet Operations does not send any renewal 
reminders for that account, even if the Expiring Entitlements job finds qualifying, expiring entitlements.

Tip • To receive renewal reminders, end users must select the Expiring Entitlements Email check box in their user 
profiles. 

Important • End users must have the View Expiring Entitlements permission to subscribe to see the Expiring 
Entitlements Email check box, receive renewal reminders, or see the Expiring Entitlements page in the End-User 
Portal. (End users with the Portal Administrator User role have the View Expiring Entitlements permission by 
default.) 

More About the Expired Entitlements Job
The Expired Entitlements job finds entitlements that have expired since the last time the job was run and 
generates email messages to end-user accounts with expired entitlements. 

Like other jobs, producers can schedule the Expired Entitlements job and subscribe to its alerts in the Producer 
Portal. However, when the Expired Entitlements job finds entitlements that are expired for an account, FlexNet 
Operations generates an email message about that account’s expired entitlements and attempts to send the 
message to the account’s users. End users who elect to receive renewal notifications will receive an email 
message when their account’s entitlements have expired. 
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The FlexNet Customer Growth module also adds an End-User Portal page to list expiring entitlements and to 
highlight those entitlements that are closest to their expiration date. (Expired entitlements are not shown by 
default. End users can use on-page filters in the End-User Portal to include expired entitlements in the list.) From 
the Expiring Entitlements page, end users can click the Request button to send the producer an email message 
that indicates their intent to renew. 

For producers, system configuration settings help determine how frequently an account can receive such email 
messages, as well as which expired entitlements appear in the End-User Portal’s Expiring Entitlements page. 
Producers can also customize the email template FlexNet Operations uses when it sends these renewal 
reminders. 

Tip • In determining when to send an Expired Entitlements email message, FlexNet Operations uses the system 
configuration setting, Expired Email Frequency (default: 30 days). This value is set in the Renewals settings on 
the FlexNet Operations system configuration page at System > Configure > FlexNet Operations. For details about 
these system configuration settings, see Configuring System Settings.

Understanding When FlexNet Operations Generates an Expired Entitlements Email 
Message
When the Expired Entitlements job runs, it scans all of your end user accounts’ entitlements to see if any have 
expired line items or maintenance lines. If so, FlexNet Operations then checks when that account last received an 
email message about expired entitlements (based on the Renewal Reminder for Expired Entitlements email 
template). 

• If FlexNet Operations has recently sent an email message about expired entitlements to the account, no new 
email messages are sent, even if newly expired entitlements are discovered when the Expired Entitlements 
job runs. 

• If FlexNet Operations has not sent an expired entitlements message to the account within the number of 
days specified in the system configuration setting, Expired Email Frequency, it generates a new renewal 
reminder email message for that account. 

Using the default system configuration settings, when an account has expired entitlements, FlexNet Operations 
limits the frequency of its expired entitlements message to once every 30 days per account. Producers can 
customize this frequency (Expired Email Frequency) to best suit the needs of their end users.

Note • The decision of whether or not to generate an email is made at the account level. The choice to receive 
renewal notifications happens at the user level. End users who belong to multiple accounts may receive multiple 
Renewal Reminder for Expired Entitlements messages (one for each account that qualifies for an expired 
entitlements message). 

Anticipating the Content of the Expired Entitlements Email Message
The content of the Expired Entitlements email message that FlexNet Operations generates depends mainly on 
two factors: 

• The Renewal Reminder for Expired Entitlements email template content. Producers can customize the 
content of the email template FlexNet Operations uses to send Expired Entitlements email messages. (See 
Managing Email Templates for instructions on editing an email template.) 
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• The account’s entitlement line items and maintenance lines that have expired since the last time the expired 
entitlements message was sent to subscribed users in that account. 

FlexNet Operations uses the Renewal Reminder for Expired Entitlements email template to create expired 
entitlements messages. For this email message, FlexNet Operations compiles a list of all the account’s line items 
and maintenance lines that expired since the Expired Entitlements job was last run and includes that list in the 
message. 

Tip • The frequency with which the Expired Entitlements job runs is set on its Configure Alert/Job Schedule page, 
but the frequency with which FlexNet Operations sends expired entitlements messages is also restricted by the 
system configuration setting, Expired Entitlements Frequency. Even if the job runs and finds new expired 
entitlements, no email messages about expired entitlements are sent for a particular account until the specified 
number of days has passed since the account was last messaged about expired entitlements.

Understanding Who Receives Renewal Reminders
After generating a Renewal Reminder message for an account, FlexNet Operations sends the message to that 
account’s End-User Portal users who have opted to receive expiring entitlement email. If none of the account’s 
end users is subscribed to receive renewal reminders, FlexNet Operations instead sends the expired entitlements 
message to the address you specify for the system configuration setting, Renewal Failed Notification Email 
(optional). If there are no end users who have subscribed to receive renewal reminders and no valid email 
address specified for Renewal Failed Notification Email, then FlexNet Operations does not send any renewal 
reminders for that account, even if the Expired Entitlements job finds qualifying, expired entitlements.

Tip • To receive renewal reminders, end users must select the Expiring Entitlements Email check box in their user 
profiles. 

Important • End users must have the View Expiring Entitlements permission to subscribe to see the Expiring 
Entitlements Email check box in their user profiles, receive expired entitlements messages, or see the Expiring 
Entitlements page in the End-User Portal. (End users with the Portal Administrator User role have the View 
Expiring Entitlements permission by default.) 

Administering Custom Attributes
Producers can use the commands in the Administer menu to view and manage custom attributes, custom host 
attributes, and custom license attributes.
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The FlexNet Operations On-Premises Installation & Implementation Guide is also a useful resource for information 
about customizing custom attributes. 

Table 20-8 • 

Topic Description

About Custom 
Attributes

Discusses the custom attributes FlexNet Operations supports, how they operate in 
FlexNet Operations, and some rules particular to their use, including custom 
attribute data types, required versus optional attributes, and attribute status, and 
the use of the Copy to Data Warehouse setting.

Managing Custom 
Attributes

Covers the management of the standard set of custom attributes for entities such 
as users, accounts, products, entitlements, entitlement lines, download packages, 
and download files. Topics include

• Custom Attribute Settings

• Adding Custom Attributes

• Listing Custom Attributes

• Editing Custom Attributes

• Deleting Custom Attributes

Managing Custom Host 
Attributes

Covers the management of custom host attributes on custom license technologies. 
Topics include

• Custom Host Attribute Settings

• Adding Custom Host Attributes

• Listing Custom Host Attributes

• Deleting Custom Host Attributes

Managing Custom 
License Attributes

Covers the management of custom license attributes defined on a particular 
technology. Topics describe how to list, create, edit, and delete custom license 
generator attributes and custom license model attributes. Topics include

• Custom License Generator Attribute Settings

• Custom License Model Attribute Settings

• Adding Custom License Attributes

• Listing Custom License Attributes

• Editing Custom License Attributes

• Deleting Custom License Attributes
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About Custom Attributes
In the Producer Portal, custom attributes occur in three different groups, and each group is managed from a 
different page: 

Table 20-9 • Custom Attribute Types

Type Description

Custom attributes or 
entity-specific custom 
attributes

Custom attributes that apply to entities like users, accounts, products, and so 
forth are referred to simply as custom attributes, or entity-specific custom 
attributes when necessary to distinguish them from the other two groups. 

Entity-specific custom attributes allow producers to capture extra information 
and associate it with a user, account, product, entitlement, entitlement line, 
download package, or file. 

Producers manage these attributes from the Custom Attributes page. 

Note • See Managing Custom Attributes for details.

Custom host attributes Custom attributes that apply only to host types of custom license technologies 
are called custom host attributes. 

Custom host attributes provide a way for producers to capture information that 
can be used to generate host IDs for custom license technology fulfillments. 

Producers manage these attributes from the Custom Host Attributes page. 

Note • See Managing Custom Host Attributes for details.

Custom license attributes Custom attributes that apply to license generators or license models of a 
particular license technology are called custom license attributes. These include 
custom license generator attributes and custom license model attributes. 

• License generator attributes provide a way to capture information that can 
be sent to a custom license generator. 

• License model attributes provide a way to capture licensing-related 
information that might be useful in the entitlement lifecycle or even 
expressed in license text. 

Producers manage these attributes from the Custom License Attributes page. 

Note • See Managing Custom License Attributes for details.
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Required Attributes and Optional Attributes
When you create a custom attribute, you can define it as required or optional. Generally, you must supply a value 
for each required custom attribute when creating or editing the entity to which it is associated; the value for 
optional custom attributes can be left blank. 

When considering whether to make a product-specific custom attribute required, for example, be aware that the 
custom attribute is also required on any existing product the next time that product is edited. 

The Required setting can be toggled on and off for entity-specific custom attributes; however, the Required 
setting is permanent for custom host attributes and custom license attributes after they are created.

For custom license model attributes, when a custom attribute is required, it means that the value of the custom 
attribute must be set at the specified time in the entitlement lifecycle (license model creation time, entitlement 
time, or activation time). However, the value of an inactive custom attribute is not asked for at the specified time.

Tip • License model attributes can be defined as optional when they are created, but later can be defined as 
required when they are enabled on individual license models. 

Custom Attribute Status
Entity-specific custom attributes can have a status of either active or inactive. All active custom attributes 
defined for a particular entity are automatically displayed on Producer Portal and End-User Portal pages on which 
those entities are created or edited. 

Note • Entity-specific custom attributes have a Status setting. Custom host attributes and custom license 
attributes do not. 

Only entity-specific custom attributes can be made inactive. Custom host attributes and license generator 
attributes can only be active. 

Likewise, custom license model attributes can only be active but, unlike other groups of custom attributes, active 
custom license model attributes are not automatically displayed. When you create a custom license model 
attribute, you can specify the possible times the attribute’s value can be set (license model creation time, 
entitlement time, or fulfillment time). A custom license model attribute is not displayed on a license model unless 
at least one setting is enabled for When to Request this Attribute Value. 

Inactive custom attributes are hidden in the End-User Portal and Producer Portal pages; however, they remain 
visible in the Producer Portal under Administer > Custom Attributes so that they can be managed. (Click the Show 
All link to view both inactive and active custom attributes.) 

A custom attribute is not required to be inactive to be deleted. However, after a custom attribute is in use, with 
values recorded on related entitlements, users, or other entities, it cannot be deleted from the system.
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Custom Attribute Data Types
When you create a custom attribute, you choose the data type for that attribute. (A custom attribute’s data type 
cannot be changed after it is set.) 

Copying to the Data Warehouse
Most but not all custom attributes can be copied to the data warehouse. The Copy to Data Warehouse setting 
flags attributes to be included in the reporting transformation process. Those attributes that are copied to the 
data warehouse are subsequently available for reporting. 

Entity-specific custom attributes for Download Packages and Download Files are not transformed to the reporting 
data warehouse. Also, custom host attributes and custom license generator attributes cannot be copied to the 
data warehouse. In addition, some custom attributes are also unavailable for reporting due to the data type used 
for the attribute. For example, custom license model attributes that use a Long Text data type are not allowed to 
be copied to the data warehouse. 

Specifically, the following conditions apply:

• Download Package and File-specific custom attributes cannot be transformed. 

Table 20-10 • Custom Attribute Data Types

Data Type Description

Number A numeral, for example, 33452. (The value must be an integer.)

Text An alphanumeric string. If you choose this option, the Producer Portal reveals additional controls 
for Max. Length and Text Type.

• Max Length: Maximum number of characters the text field accepts.

• Text Type: (Required) Choose from Free Form, Single Select, or Multi Valued Text. (This 
choice cannot be changed once set.)

Free Form: If you select this option, your custom attribute takes a typed-in alphanumeric 
string. When the Text Type is Free Form, also choose a Display Type to determine how the 
text attribute is displayed: Text Field or Text Area. 

Single Select: If you select this option, your custom attribute takes the value of an item from 
a drop-down list. When the Text Type is Single Select, also specify Valid Values with the Add 
Value button. Valid Values determine the list of values a user can choose for this attribute.

Multi Valued Text: If you select this option, your custom attribute takes the value of several 
selected boxes next to items in a specified list. When the Text Type is Multi Valued Text, also 
specify Valid Values with the Add Value button. Valid Values determine the list of values a 
user can choose for this attribute.

Long Text An alphanumeric string that can be up to 16384 characters. The value can be typed or pasted 
into the text box. When the attribute’s Type is Long Text, also choose a Display Type to determine 
how the text attribute is displayed: Text Field or Text Area. 

Boolean A pair of options for mutually exclusive choices, such as Yes or No.

Date A calendar date.
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• Attributes of all data types except Long Text are available for reporting.

• There is a limit of 30 attributes for a single entity and single tenant.

• If there are more than 30 attributes, or if the attribute type is set to Long Text, the Copy to Data Warehouse 
check box is not visible.

• After it is selected and saved, the option cannot be reverted (the Copy to Data Warehouse check box is 
disabled) nor can the attribute modified. (However, the attribute can be deleted if it has not yet been used, 
and then re-created as a new attribute.)

• Multi Valued Text type is supported, but only allows 255 characters, with all the values separated by a 
vertical bar (a | pipe character) as a delimiter. For example, if the values are Address,Email,Phone, then the 
value in the data warehouse is transformed into Address | Email | Phone format.

Managing Custom Attributes
Entity-specific custom attributes allow producers to capture extra information and associate it with a user, 
account, product, entitlement, entitlement line, download package, or file. Producers can define these custom 
attributes for the following entity types: 

• Users

• Accounts

• Products

• Entitlements

• Entitlement Lines

• Download Packages

• Download Files

Note • For information about managing custom host attributes or custom license attributes, see Managing 
Custom Host Attributes or Managing Custom License Attributes, respectively.

Table 20-11 • 

Topic Description

Custom Attribute Settings Provides details about the settings associated with custom attributes.

Adding Custom Attributes Explains how to add entity-specific custom attributes for users, accounts, 
products, entitlements, entitlement lines, download packages, and download 
files.

Listing Custom Attributes Describes how to show a list of custom attributes.

Editing Custom Attributes Explains how to edit an existing custom attribute.

Deleting Custom Attributes Shows how to remove custom attributes.
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Custom Attribute Settings

Note • Custom host attributes and custom license attributes are managed separately. For details, see Managing 
Custom Host Attributes or Managing Custom License Attributes.

Custom attributes have the following settings:

Table 20-12 • 

Setting Description

Name Type a name to uniquely identify this custom attribute. This name must be 
unique for the entity type you select next. Custom attribute names can contain 
upper and lower case alphabet characters, numbers, and underscores. 

Entity Type For Entity Type, choose entity to which you want this attribute added. Choose 
from

• Account

• User

• Product

• Entitlement

• Entitlement Line

• Download Package

• File

After the attribute is saved, you cannot change its Entity Type. 

Note that custom attributes for Download Packages and Files cannot be copied 
to the data warehouse and, as a result, cannot be made available for reporting. 
For details, see Copying to the Data Warehouse in About Custom Attributes.

Required? Choose Yes or No to specify whether this custom attribute is required or 
optional. If required, a value for this attribute must be set when the entity is 
created.

For more information about required and optional custom attributes, see 
Required Attributes and Optional Attributes in About Custom Attributes.

Status Sets the custom attribute to active or inactive status. 
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Adding Custom Attributes
Producers can add custom attributes for users, accounts, products, entitlements, entitlement lines, download 
packages, and download files from the Custom Attributes page. 

Note • To add custom host attributes or custom license attributes (license model attributes or license generator 
configuration attributes), see Adding Custom Host Attributes or Adding Custom License Attributes. 

Task To add a custom attribute

1. In the Producer Portal, click Administer > Custom Attributes. This link shows the Custom Attributes page. 

2. On the Custom Attributes page, click Add Attribute.

3. On the Create Custom Attribute page, specify custom attribute settings. 

See Custom Attribute Settings for more information about attribute properties. 

4. Click Save. 

The Producer Portal adds the custom attribute using the settings you provided, and returns to the Custom 
Attributes page.

Type The data type of the values the custom attribute accepts. Type cannot be 
changed once set. 

Choose from the following:

• Number

• Text (requires Max. Length and Text Type settings)

• Long Text (requires Display Type setting)

• Boolean

• Date

For details about these data types, see Custom Attribute Data Types in About 
Custom Attributes.

Copy to Data 
Warehouse

If selected, this attribute is included in the data transformation for reporting. 
Otherwise, the custom attribute is not available for reporting. 

Note that some data types cannot be copied to the data warehouse and, as a 
result, cannot be made available for reporting. For details, see Copying to the 
Data Warehouse in About Custom Attributes.

Table 20-12 • 

Setting Description
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Listing Custom Attributes
The Producer Portal shows previously defined custom attributes on the Custom Attributes page. 

Note • Custom host attributes and custom license attributes are managed separately. For details, see Managing 
Custom Host Attributes or Managing Custom License Attributes.

Task To list existing custom attributes

• Click Administer > Custom Attributes. 

The Producer Portal shows the Custom Attributes page. This page lists attributes with the following information:

Tip • By default, only active custom attributes are shown. To display both active and inactive attributes, click 
Show All. 

Click an attribute name to view its details.

Click Add Attribute to add a custom attribute.

Editing Custom Attributes
You can edit existing custom attributes from the Custom Attributes page. 

Note • Custom host attributes and custom license attributes are managed separately. For details, see Managing 
Custom Host Attributes or Managing Custom License Attributes.

Table 20-13 • Custom Attributes Information

Field Description

Name Name of the custom attribute

Data Type Type of value the custom attribute accepts: Boolean, Date, Text (free form or 
single select), Multi-valued text, Long Text, or Date. 

Required Shows whether or not the attribute is required. 

• true for required attributes

• false for optional attributes

See Custom Attribute Settings for more information about required versus 
optional attributes.

Status Shows whether the attribute is active or inactive.
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Task To edit a custom attribute

1. In the Producer Portal, click Administer > Custom Attributes. This link shows the Custom Attributes page. 

2. On the Custom Attributes page, click the name of the attribute you want to change.

3. On the Create Custom Attribute page, specify custom attribute settings. 

Some attribute settings cannot be edited. The ability to edit a setting depends, in part, on its status, whether 
or not it has been in use, and whether it is required or optional. See Custom Attribute Settings for more 
information about attribute properties. 

4. Click Save. 

The Producer Portal saves your changes to the attribute settings.

Deleting Custom Attributes
Except for download package custom attributes and file custom attributes, most unused custom attributes can 
be deleted from the Create Custom Attribute page. 

Download package-specific and file-specific custom attributes cannot be deleted. Attributes defined on users, 
accounts, products, entitlements, and line items can be deleted only if they have never been assigned a value on 
any entity. 

Note • Custom host attributes and custom license attributes are managed separately. For details, see Managing 
Custom Host Attributes or Managing Custom License Attributes.

Task To delete a custom attribute

1. In the Producer Portal, click Administer > Custom Attributes to show a list of custom attributes. 

2. On the Custom Attributes page, click the name of the custom attribute you want to delete. The Producer 
Portal shows the attribute’s Create Custom Attribute page. 

3. On the Create Custom Attribute page, click Delete. The Producer Portal prompts you to confirm the deletion.

4. Click OK to confirm the deletion of the selected custom attributes. 

The Producer Portal deletes the selected attributes and refreshes the custom attributes list. 

Managing Custom Host Attributes
You can manage your custom host attributes from the Custom Host Attributes page. 

Custom host attributes apply only to host types of custom license technologies and provide a way for producers 
to capture information that can be used to generate host IDs for custom license technology fulfillments.
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Licenses are usually bound to either a node or a host. Defining a host attribute allows you to create a host ID for a 
host and to use the host as the criteria for capabilities like batch rehosts, searching and sorting on hosts, and 
listing all fulfillments for a given host.

If custom host attributes are defined for a host type, FlexNet Operations displays them to users when they create 
a host of that type. 

Note • You can generate a unique identifier for a host, based on these attributes, by implementing the 
HostIdentifierGeneratorByHostType interface under System Configuration. Also, you can validate whether or not 
the user supplied the appropriate values for these attributes.

The topics below discuss how to add, list, and delete custom host attributes.

Note • For information about entity-specific custom attributes or custom license attributes, see Managing 
Custom Attributes or Managing Custom License Attributes, respectively.

Custom Host Attribute Settings
Custom host attributes have the following settings: 

Table 20-14 • 

Topic Description

Custom Host Attribute 
Settings

Provides details about the settings associated with custom host attributes.

Adding Custom Host 
Attributes

Explains how to add a custom host attribute and specify its name, license 
technology, host type, and data type. 

Listing Custom Host 
Attributes

Describes how to show a list of custom host attributes.

Deleting Custom Host 
Attributes

Shows how to remove custom host attributes.

Table 20-15 • 

Setting Description

Name Type a name to identify this custom host attribute. 

License Technology The type of license technology with which the attribute is to be used. 

Host Type Select a host type from the list provided.
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Adding Custom Host Attributes
Follow the instructions, below, to create a custom host attribute.

Task To add a custom host attribute

1. In the Producer Portal, click Administer > Custom Host Attributes. The Producer Portal opens the Create 
Custom Host Attribute page. 

2. On the Create Custom Host Attribute page, provide a name for the attribute and specify values for its other 
settings. See Custom Host Attribute Settings for setting details.

3. Complete the attribute creation process by clicking Save or Add New:

• Click Save to save the attribute and remain on the current page. 

• Click Add New to save the current attribute and begin creating another custom host attribute.

The custom host attributes you create here are typically assigned values for a given host when that host is 
created.

Listing Custom Host Attributes
The Producer Portal shows all previously defined custom host attributes on the Custom Host Attributes page. 

Required? Choose Yes or No to specify whether this custom attribute is required or 
optional. If required, a value for this attribute must be set when the entity is 
created.

For more information about required and optional custom attributes, see 
Required Attributes and Optional Attributes in About Custom Attributes.

Type The data type of the values the custom attribute accepts. Type cannot be 
changed once set. 

Choose from the following:

• Number

• Text (requires Max. Length and Text Type settings)

• Long Text (requires Display Type setting)

• Boolean

• Date

For details about these data types, see Custom Attribute Data Types in About 
Custom Attributes.

Table 20-15 • 

Setting Description
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Task To list existing custom host attributes

• Click Administer > Custom Host Attributes. 

The Producer Portal shows the Custom Host Attributes page. This page lists attributes with the following 
information:

Click an attribute name to view its details.

Click Create to add a custom host attribute.

Select the box next to an attribute and click Delete to delete it. Custom host attributes cannot be deleted if the 
associated license technology is in Deployed status. 

Deleting Custom Host Attributes
Custom host attributes can be deleted from the Custom Host Attributes page. 

Custom attributes cannot be deleted if the associated license technology is deployed. When a custom attribute is 
deleted from a draft license technology, all references to this attribute are deleted from the corresponding 
generator configuration or license model.

Task To delete custom host attributes

1. On the Custom Host Attributes page, select the check box of the custom host attributes you want to delete 
and then click Delete. The Producer Portal prompts you to confirm the deletion.

2. Click OK to confirm the deletion of the selected custom attributes. 

The Producer Portal deletes the selected attributes and refreshes the custom host attributes list. 

Managing Custom License Attributes
You can manage your custom license generator attributes and custom license model attributes from the Custom 
License Attributes page. 

Table 20-16 • Custom Attributes Information

Field Description

Name Name of the custom attribute.

Type Type of value the custom attribute accepts: Boolean, Date, Text (free form or 
single select), Multi-valued text, Long Text, or Date. 

License Technology Name of the license technology to which the attribute belongs.

Host Type Type of host for the custom attribute.
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Custom license attributes include custom license generator attributes and custom license model attributes. 
License generator attributes provide a way to capture information that can be sent to a custom license generator. 
License model attributes provide a way to capture licensing-related information that might be useful in the 
entitlement lifecycle or even expressed in license text. 

The topics below discuss how to add, list, edit, and delete custom license generator attributes and custom 
license model attributes.

Note • For information about entity-specific custom attributes or custom host attributes, see Managing Custom 
Attributes or Managing Custom Host Attributes, respectively.

Table 20-17 • 

Topic Description

Custom License 
Generator Attribute 
Settings

Provides details about the settings associated with custom license generator 
attributes.

Custom License Model 
Attribute Settings

Provides details about the settings associated with custom license model 
attributes.

Adding Custom License 
Attributes

Explains how to add custom license model and license generator configuration 
attributes. 

• For custom license generator configuration attributes, these instructions cover 
specifying a numeric, text, boolean, or date attribute for a license generator 
configuration associated with a license technology. 

• For custom license model attributes, these instructions cover creating 
attributes for custom license models or creating custom attributes for FlexNet 
Publisher Licensing Toolkit models

Listing Custom License 
Attributes

Describes how to show a list of custom license attributes.

Editing Custom License 
Attributes

Explains how to edit existing custom license generator attributes and custom 
license model attributes.

Deleting Custom 
License Attributes

Shows how to remove custom license attributes.
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Custom License Generator Attribute Settings
Custom license generator attributes have the following settings: 

Custom License Model Attribute Settings
Custom license model attributes have the following settings: 

Table 20-18 • 

Setting Description

Name A name to uniquely identify this custom license generator attribute. This name 
must be unique within a given license technology.

License Technology License technology of which the attribute is a part. Choose from the drop-down 
list. 

Required? Is this a required or optional attribute for license generation? If required, this 
attribute can only be created for a license technology in the draft state.

Type The data type of the values the custom attribute accepts. Type cannot be 
changed after it is set. 

Choose from the following:

• Number

• Text (requires Max. Length and Text Type settings)

• Long Text (requires Display Type setting)

• Boolean

• Date

For details about these data types, see Custom Attribute Data Types in About 
Custom Attributes.

Table 20-19 • 

Setting Description

Name A name to uniquely identify this custom license model attribute. This name 
must be unique within a given license technology.

License Technology License technology of which the attribute is a part. Choose from the drop-down 
list. If you choose FlexNet Licensing from this list, you are setting custom 
attributes on its license models.
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Adding Custom License Attributes
Although you can create custom license generator configuration attributes and custom license model attributes 
as part of the license technology creation wizard, both types of custom attributes can also be created directly 
from the Custom License Attributes page.

When to Request this 
Attribute Value 

The events during which it is possible for to specify the values of this attribute:

• License Model Creation: when creating a license model that enables this 
attribute

• Entitlement: when creating entitlements with license models that enable 
this attribute

• Fulfillment: when activating licenses with license models that enable this 
attribute 

The selected events, above, define the events when the values of this attribute 
may be specified on some license model of the selected license technology. 
When the current license model attribute is enabled on a particular license 
model, one event from the set of possible events must be selected. For more 
information, see Setting Up Custom License Model Attributes. 

Required? Is this a required or optional attribute for license generation? If required, this 
attribute can only be created for a license technology in the draft state.

Type The data type of the values the custom attribute accepts. Type cannot be 
changed after it is set. 

Choose from the following:

• Number

• Text (requires Max. Length and Text Type settings)

• Long Text (requires Display Type setting)

• Boolean

• Date

For details about these data types, see Custom Attribute Data Types in About 
Custom Attributes.

Copy to Data 
Warehouse

If selected, this attribute is included in the data transformation for reporting. 
Otherwise, the custom attribute is not available for reporting. 

Note that some data types cannot be copies to the data warehouse and, as a 
result, cannot be made available for reporting. For details, see Copying to the 
Data Warehouse in About Custom Attributes.

Table 20-19 • 

Setting Description
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This topic explains how to create custom license generator configuration attributes and custom license model 
attributes: 

• For custom license generator configuration attributes, these instructions cover specifying a numeric, text, 
boolean, or date attribute for a license generator configuration associated with a license technology. See 
Adding Custom License Generator Attributes, below. 

• For custom license model attributes, these instructions cover creating attributes for custom license models 
or setting custom attributes for FlexNet Licensing models. See Adding Custom License Model Attributes, 
below.

Adding Custom License Generator Attributes
Custom license generator attributes can be created as part of the license technology creation wizard or they can 
be created independently of that wizard. These instructions start from the Create a License Generator Attribute 
page. 

In the license technology creation wizard, the Create a License Generator Attribute page is step 2. To open the 
Create a License Generator Attribute page independently of that wizard, click Administer > Custom License 
Attributes. Then, click Add a License Generator Attribute. 

Note • When creating a license technology, if you implement your license generator class so that it references the 
license generator executable, you can skip this step.

You can create a license generator attribute for custom license technologies in the draft state. You cannot create 
a license generator attribute for FlexNet Licensing.

Task To add a custom license generator attribute

1. On the Create a License Generator Attribute page, provide a name for the attribute and specify values for its 
other settings. See Custom License Generator Attribute Settings for setting details.

2. Complete the attribute creation process by clicking Save, Add New, Reset, or Next:

• Click Save to save the attribute and remain on the current page. 

• Click Add New to save the current attribute and begin creating another custom license generator 
attribute.

• Click Reset to clear the current form and start again.

• Click Next to save the license technology and move to the Create License Generator Configuration page.

The custom license generator attributes you create here are typically configured for a given license generator 
when that license generator is created. These license generator configurations are set up in the Create a License 
Technology wizard. See Creating a License Generator Configuration for more information.

Adding Custom License Model Attributes
Custom license model attributes can be created as part of the license technology creation wizard or they can be 
created independently of that wizard. These instructions start from the Create a License Model Attribute page. 
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In the license technology creation wizard, the Create a License Model Attribute page is step 4. To open the Create 
a License Model Attribute page independently of that wizard, click Administer > Custom License Attributes. Then, 
click Add a License Model Attribute. 

Task To add a custom license model attribute

1. On the Create a License Model Attribute page, provide a name for the attribute and specify values for its 
other settings. See Custom License Model Attribute Settings for setting details.

2. Complete the attribute creation process by clicking Save, Add New, or Complete:

• Click Save to save the attribute and remain on the current page. 

• Click Add New to save the current attribute and begin creating another custom license model attribute.

• Click Complete to save the license technology and return the License Technologies page.

The custom license model attributes you create here are typically configured for a given license model when the 
license model is created. The license model creation wizard includes a step in which you can set up how the 
available custom license model attributes are to be used (or not) for the current license model. See Setting Up 
Custom License Model Attributes for instructions.

Note • If you create an attribute for a custom technology called “SERIAL_NUMBER,” its label, by default, is 
displayed as “Serial Number.” This is because SERIAL_NUMBER is a FlexNet Licensing attribute for which 
resources are already defined. If you change the label for the custom SERIAL_NUMBER attribute, its FlexNet 
Licensing display label also changes.

Listing Custom License Attributes
The Producer Portal shows all previously defined custom license generator attributes and custom license model 
attributes on the Custom License Attributes page. 

Task To list existing custom license attributes

• Click Administer > Custom License Attributes. 

The Producer Portal shows the Custom License Attributes page. This page lists attributes with the following 
information:

Table 20-20 • Custom Attributes Information

Field Description

Name Name of the custom attribute.

Type Type of value the custom attribute accepts: Boolean, Date, Text (free form or 
single select), Multi-valued text, or Long Text. 
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From this page, you can add a license generator attribute or a license model attribute, edit an existing attribute, 
or delete existing attributes. Producers can also export the attributes the license attributes that appear in the list. 

Click an attribute name to view its details.

• Click Add a License Model Attribute to create a custom license model attribute.

• Click Add a License Generator Attribute to create a license generator configuration attribute.

See Adding Custom License Attributes for instructions.

Tip • If you have many custom license attributes, note that the list of attributes is paginated. Use the page 
controls to view more attributes. Use the search features on the Custom License Attributes page to narrow the 
list. 

Editing Custom License Attributes
Both custom license generator attributes and custom license model attributes can be edited from the Custom 
License Attributes page. (Not all settings for these custom license attributes are editable.) 

Task To edit a custom license attribute

1. On the Custom License Attributes page, click the name of the custom attribute you want to edit. The 
Producer Portal opens the Create a License Generator Attribute or the Create a License Model Attribute page, 
depending on the type of attribute you choose.

2. Edit the settings for the current attribute. For details about these settings, see Custom License Generator 
Attribute Settings or Custom License Model Attribute Settings. 

3. Click Save.

The Producer Portal saves your changes to the attribute settings.

Deleting Custom License Attributes
Both custom license generator attributes and custom license model attributes can be deleted from the Custom 
License Attributes page. 

Custom license attributes cannot be deleted if the associated license technology is deployed. When a custom 
license attribute is deleted from a draft license technology, all references to this attribute are deleted from the 
corresponding generator configuration or license model.

Belongs To Whether the attribute is associated with license models or license generator 
configurations.

License Technology Name of the license technology to which the attribute belongs.

Table 20-20 • Custom Attributes Information

Field Description
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Task To delete custom license attributes

1. On the Custom License Attributes page, select the check box of the custom attributes you want to delete and 
then click Delete. The Producer Portal prompts you to confirm the deletion.

2. Click OK to confirm the deletion of the selected custom attributes. 

The Producer Portal deletes the selected attributes and refreshes the custom license attributes list. 

Administering Domains
User information is obtained from one or more domains in which it is stored. FlexNet Operations users entered 
manually into the application are users in the FlexNet domain. Authentication information for a user in the FlexNet 
domain is stored in the FlexNet Operations database. If FlexNet Operations is configured to support one or more 
directory services, information for a FlexNet Operations user or group of users can be imported from the directory 
service. Only minimal information from the directory service is imported to allow FlexNet Operations to contact 
the service; authentication information for a user in a directory service domain is maintained in the directory 
service. Any user in a configured directory service domain can log in to FlexNet Operations. However, to perform 
any tasks in FlexNet Operations, a directory service user must be imported as a FlexNet Operations user or be a 
member of an imported group and be assigned at least one role.

The following topics cover how to work with domains in the Producer Portal:

Listing Domains
Users assigned roles with the View Domains or View and Manage Domains permission can browse domains.

Task  To browse existing domains

1. Click Administer > List Domains.

2. In the Domains page, you can view the following information:

a. Name: Domain name. 

b. Host: Name of the machine that hosts the directory service. 

c. Status: Whether the domain is active or inactive. 

Table 20-21 • 

Topic Description

Listing Domains Describes how to show a list of domains in the Producer Portal.

Adding a Domain Shows how to add a new domain to FlexNet Operations.

Editing a Domain Explains how to change the settings for an existing domain.
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Adding a Domain
If a directory service domain is configured in FlexNet Operations, users and user groups can be imported from the 
directory service and assigned roles.

Users assigned a role with the View and Manage Domains permission can view, add, and edit domains.

Caution • Before configuring a new domain, you should ensure you understand the directory structure and its 
data. It is strongly recommended that you consult with the LDAP administrator for more information on LDAP 
configuration.

Task To configure access to a directory service

1. Click Administer > Create a Domain.

2. Enter values for the following settings. Defaults may be defined based on the type of directory service: 

Table 20-22 • 

Settings Description Req.

Name Name that uniquely identifies the domain, which is used as an identifier in 
cases such as Single Sign On and web services. The domain name for the 
domain that contains users entered manually into FlexNet Operations is 
FlexNet. Additional domains that are added are directory service domains.

Note • A domain name should not have any spaces.

Yes 

Protocol LDAP and LDAPS protocols are supported. 

LDAPS uses SSL connections. If LDAPS is selected, see the FlexNet 
Operations On-Premises Installation & Implementation Guide for instructions 
to configure secure (SSL) client settings for the FlexNet Platform Server. 

Host Name of the host machine on which the directory service runs. Yes  

Port Port on the host machine on which the directory service listens for requests. 
The default LDAP port is 389; the default LDAPS port is 636. 

Yes  

Domain Login The distinguished user (DN) name of the user that will connect to the 
directory server. If the directory server allows anonymous binding, then leave 
this field blank. The directory server must allow an anonymous login to bind 
as well as perform searches for users and groups. 

Yes  

Domain 
Password 

The password used when binding to the active directory domain to perform 
domain operations. (Password is only required if you configure a valid user to 
connect to the directory server.)

Yes  
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Base 
Distinguished 
Name 

The distinguished name (DN of the node in the directory service) at which to 
start searching for user information. 

Yes  

User Search 
Filter 

The directory service filter condition that is used to identify a user. The syntax 
(include parentheses) is (attribute_name=value), where value is the value of 
the directory service attribute when the object is a user. This filter is used to 
search for users imported from the directory service.

Yes  

Authentication 
Filter

Filter condition used during the authentication process, to find the user who 
is trying to log on to the directory server. The filter condition contains the 
name of an attribute.

UserID Attribute An attribute of the user type entry that contains the user ID identifying the 
user. Used to store the user ID value in FlexNet Operations as user name.

Group Name 
Attribute

Directory service attribute of a user that contains the groups to which that 
user belongs.

User Display 
Name Attribute 

The directory service attribute that contains the display name of a user. Yes  

User Display 
Detail Attribute 

Optional directory service attribute that contains the display detail of a user. 
The value of this property is displayed in the Create User page when you 
create a user from a directory service. If not defined, the default value is the 
User Distinguished Name in the directory service.

User Account 
Unit Attribute

Optional name of the attribute in the directory service that stores the user’s 
account. The value specified in the directory service for this property must be 
the same as that defined by the Account Name in Operations. If these values 
do not match exactly, Operations uses the value defined in the Default 
Account for External Domain property in System Configuration.

User Email 
Attribute

Optional name of the attribute in the directory service that stores the user’s 
email. If this is not defined, the user email will not be populated.

User Locale 
Attribute

Optional name of the attribute in the directory service that stores the user’s 
locale. The Locale ID value specified by this property in the directory service 
must take a format <language code>_<country code>. For example, en_GB 
for Great Britain English or en_US for United States English.

Table 20-22 • 

Settings Description Req.
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3. Click Save. 

User TimeZone 
Attribute

Optional name of the attribute in the directory service that stores the time 
zone defined for that user. The value specified by this property in the 
directory service must take one of the following formats (these are supported 
by Java):

1. Time Zone ID, such as America/New York or America/Los_Angeles

2. GMT standard format :

GMT<+|–><Hours>:<Minutes>

GMT<+|–><Hours><Minutes>

GMT<+|–><Hours>

There are no spaces between each value.

Hours are represented as either single-digit or double-digit.

Minutes are represented as double-digit.

A digit is a number 0 through 9.

For example, valid values could be GMT+05:30, GMT+0500 or GMT+5.

Group Search 
Filter

The directory service filter condition that is used to identify a group. The 
syntax (include parentheses) is (attribute_name=value), where value is the 
value of the directory service attribute when the object is a group. Typically, 
the entry is identified by the objectclass attribute.

Yes  

Group Display 
Name Attribute

Directory service attribute that contains the display name of a group. Yes  

Group Display 
Detail Attribute

Optional directory service attribute that contains the display detail of a group. 
The value of this property is displayed in the Add Group page when you create 
a group from a directory service. If not defined, the default value is the Group 
Distinguished Name in the directory service.

Returned Page 
Size 

If a positive number is specified, FlexNet Operations tries to use paging when 
searching for directory service entries. Paging means that the directory 
service returns no more than the specified number of entries at a time 
instead of all entries in one batch. Set to a number less than or equal to the 
page size limit imposed by the directory service. Not all directory services 
support paging; if your directory service does not, set page size to 0. 

Status An active domain can be used to import or authenticate a user; an inactive 
domain cannot. Leave the status of a new domain Active. (If you do not wish 
to grant access to users from a specific domain, set the value to Inactive. You 
can set it to Active at a later time.)

Table 20-22 • 

Settings Description Req.
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When the new directory service domain is saved, any user in the domain can log in to FlexNet Operations. To 
allow users who are maintained in that directory service to perform tasks in FlexNet Operations, users and 
groups can be imported into FlexNet Operations and granted roles. 

4. Verify in the Domains page that the domain was added. 

Editing a Domain
Users assigned a role with the View and Manage Domains permission can view, add, and edit domains.

Task To edit an existing domain

1. Click Administer > List Domains.

2. In the Domains table, click a domain name to view the Edit Domain page.

3. Edit the values of any of the editable fields. The domain name is never editable; others may not be. See 
Adding a Domain for field descriptions.

4. Click Save to save your changes to the domain. 

Importing and Exporting Entities
You can import and export entities from the FlexNet Operations database into other Operations databases. This 
enables you to migrate data between different FlexNet Operations installations. In addition, data export can be 
helpful when troubleshooting issues. For example, problematic entities can be exported to a file and then sent to 
tech support for review.

Imports can be either contained in packages or Unicode text. Packages are .jar files that contain an XML meta-
file to describe the contents of the package and the order in which the content files should be loaded, and 
content XML files for the entities. Unicode .txt files are saved from Data Import Templates in .xlt format. Blank 
Data Import Templates can be downloaded from the Data Import Templates tab, as described in Using Data 
Import Templates.

Exports can be in either .jar or Data Import Template (.xlt) format. With a Data Import Template, modification of 
the data is simplified with tools designed to ensure compatibility with the FlexNet Operations database. See 
Using Data Import Templates for more information.

Information about importing and exporting entities is described in the following sections:

• Import/Export Package Structure

• Importing and Exporting Entities Overview

• System Configuration

• Exporting Entities

• Importing Entities

• Using Data Import Templates

• Import/Export Job Status
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Import/Export Package Structure
During the import/export process, FlexNet Operations works with an export-import package, which is a .jar file 
containing the following:

• An XML metafile to describe the contents of the package and the order in which the files should be loaded.

Note • For more information, see XML Metafile Structure. 

• A set of content XML files for the entities that are exported. Each file contains entities of one type only. For 
example, products are in one XML file, and license models are in another XML file.

Version • A sample import/export .jar file can be found in the following location:
<ops_install_dir>\release\flexnet-data\site\samples\exportimport

Important • FlexNet Operations does not support the importing or exporting of test entities, such as test 
entitlements. 

XML Metafile Structure
If a package is built by hand, this metafile must be constructed and packaged into a .jar file with the content 
XML files.

The type tag in XML specifies the type of entity being imported. You can set the type to one of the enumerated 
values listed in <ops_install_dir>\release\flexnet-data\site\schema-
public\exportimport\exportimportmetafile.xsd.

A sample metadata file is shown here: 

<fileMetaInfo version="8.3">
    <statusInfo> <!--This tag is optional and it is not used during import-->
       <message>Exported from FNO 8.3 installed on host blind</message>
       <timestamp>03/16/2007 14:30:35</timestamp>
    </statusInfo>
    <fileInfo> 
       <file order="1" type="LIC_TECH">1</file>
       <file order="2" type="MODEL">1</file>
       <file order="3" type="FEATURE">1</file>
       <file order="4" type="PRODUCT">1</file>
       <file order="5" type="ENTITLEMENT">5</file>
    </fileInfo>
    <fileDetails><!-- This tag lists the location of each file and the order it should be loaded -->
   <fileSet type="LICTECH">
      <fileName order="1">lictech_1.xml</fileName>
   </fileSet>
   <fileSet type="MODEL">
      <fileName order="1">licmodel_1.xml</fileName>
   </fileSet>
   <fileSet type="FEATURE">
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      <fileName order="1">feature_1.xml</fileName>
   </fileSet>
   <fileSet type="PRODUCT">
      <fileName order="1">product_1.xml</fileName>
   </fileSet>
   <fileSet type="ENTITLEMENT">
      <fileName order="1">entitlement_1.xml</fileName>
      <fileName order="2">entitlement_2.xml</fileName>
      <fileName order="3">entitlement_3.xml</fileName>
      <fileName order="4">entitlement_4.xml</fileName>
      <fileName order="5">entitlement_5.xml</fileName>
   </fileSet>
    </fileDetails>
</fileMetaInfo>

File Order
The order in which entities are loaded is important. Before an entity is loaded, all of its dependencies must exist 
in the system. There are two points to consider while determining the file order in the metafile:

• Different entity types: For example, before an entitlement is loaded, the product and license model the 
entitlement refers to must exist in the system. So, the product XML files must be loaded before loading the 
entitlement XML files.

• Same entity types: If there is a parent-child relationship between the same entity types, the parent must be 
loaded before the child is loaded. For example, if an entitlement line item is defined as an upgrade of another 
line item. The parent line item must be loaded before the upgraded line item is loaded.

Each content XML file must be of a reasonable size to ensure that the I/O processes proceed smoothly.

Content XML Files
In general, all constants in the content XML files are enumerated types which are defined in the corresponding 
.xsd file. Publishers can refer to the schema definition files in <ops_install_dir>\release\flexnet-
data\site\schema-public\exportimport for details of the content XML files. 

In general, if the user wants to update even one attribute, such as state, the entire XML file must be submitted 
along with all the collections and references. 

For example, if the user wants to import a product, then the entire product definition along with the features, 
bundles, license models, parts, and associated parameters, has to be provided in the XML file. If the product 
already exists in the system, the user is given a choice to either update the record or report an error during the 
import process. If the user selects to update the record, then the entire product definition is replaced by the 
details in the XML imported. This means that the existing features, bundles, license models, parts in the product 
are replaced by the new collections mentioned in the imported XML.

Common specifications for each content XML include:

• Date values must be entered in yyyy-mm-dd format.

• Time Zone must be entered in a format like -7:00, which indicates GMT -7 hours.

• Locales must be entered as en or en_US. A locale's language is specified by the ISO 639 standard and the 
locale's country code is specified by the ISO 3166 standard. If the locale entered does not conform to these 
standards, then a default value of en is stored.
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Importing and Exporting Entities Overview
When importing or exporting, you can select a single entity, specific entities, or all entities of a certain type. For 
example, you can export a single product, selected products, or all products. If you export an entity, you can also 
choose to export its dependent entities (dependencies). For example, if you export an entitlement, and you select 
its dependencies, FlexNet Operations can also export the entitlement’s dependent product, features and other 
associated entities. 

Permission to view an entity also includes permission to export it.

Important • Only the .jar package mechanism supports importing and exporting of feature bundles.

Importable and exportable entities include:

• License Technologies, License Models and License Generator Configurations

• Publishers and publisher identities

• Custom Attributes

• Features and feature bundles

• Part Numbers 

• Transaction Keys

• Products and Suites

• Product relationships to license models, features, feature bundles, license models, part numbers and other 
products

• Simple entitlements and line items

• Bulk entitlements and Web register keys. 

• Fulfillments, including fulfillment vendor names. (Import limitations apply. See Fulfillment Import 
Limitations.)

• Consolidated licenses

• All business objects in FlexNet Operations (including account units, license technologies, products, suites, 
features, feature bundles, license models, entitlements, and fulfillment records).

Important • You cannot import or export test entities, such as test entitlements. 

Note • Administrative entities like roles and domains, and records like history and audit trails cannot be exported 
or imported. 

System Configuration
Imports and exports are processed as background jobs. Before importing or exporting, configure an alert for the 
background queue.
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Task To configure alerts for background queue processing

1. Click Administer > Configure Alerts.

2. Under Export and Import Background Jobs, click Configure.

3. On the Set Alert Handlers page, set your alert handlers.

4. If desired, set a value for the interval at which FlexNet Operations checks for background jobs. The default is 
5 seconds.

5. Click Save.

6. Subscribe to the alert as usual.

Exporting Entities
The following tasks explain how to export entities. 

• Exporting an Entity or Set of Entities as a JAR File

• Exporting the Entire FlexNet Operations Database

• Exporting a Set of Entities as a Data Import Template File

Exporting an Entity or Set of Entities as a JAR File
To export an entity or a set of entities from FlexNet Operations as a JAR file, perform the following steps.

Task To export an entity or set of entities from FlexNet Operations as JAR file

1. On the landing page for the entity, do one of the following:

a. To export selected entities, select one or more entities, then click Export > Selected Items or Selected 
Items With Their Dependencies.

b. To export all entities in the list, click Export > All Items or All Items With Their Dependencies.

2. The selected entities are exported to a jar file. If you chose to include dependencies, the dependencies are 
included.

Exporting the Entire FlexNet Operations Database
To export the entire FlexNet Operations database, perform the following steps.

Task To export the entire FlexNet Operations database

1. Click Administer > Export Data Objects.

2. On the Export Business Objects page, click Export. 

3. Click Yes to confirm export.
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4. All exportable business objects in FlexNet Operations are exported to a .jar file. Your job is assigned a 
request number, and an alert is sent when processing is completed. You can check the job status on the 
Status page. See Import/Export Job Status for more information.

Exporting a Set of Entities as a Data Import Template File
To export the a set of entities as a Data Import Template file, perform the following steps.

Task To export a set of entities from FlexNet Operations as Data Import Template file

1. On the landing page for the entity, click Export > Data Import Template.

Note • For Users and Accounts, click Export > Data Import Template from any tab. All user or all account data 
is exported into the template file. For Download Packages and Files, go to the Products > Search Download 
Packages or Search Files page and click the Search button to access the Search Results page, then click 
Export > Data Import Template. All Download Packages or all Files are downloaded into the template file, 
regardless of the filtering on the search page.

2. A message similar to the following appears:

Request 3137 to export all Products as data import template successfully submitted. An alert will be 
sent after the request is processed.

3. Go to Administer > Import/Export Status.

4. When the request has completed, select the check box next to its Job ID and click the Download exported 
file button. The selected entities are exported to a Data Import Template (.xlt) file. Data for all the tabs in the 
template are included in the downloaded file.

Note • The Products download does not include the Create/Update Product line tab data available in the blank 
Data Import Template. Save each tab of the downloaded .xlt file as a separate Unicode text file for uploading to 
another instance of FlexNet Operations. The Create-Update Features data is included as a separate tab in the 
PackageProducts.xlt export as well as a standalone tab in the FeatureExport.xlt export.

Importing Entities
To import a set of entities into FlexNet Operations, perform the following steps.

Task To import a set of entities into FlexNet Operations

1. Click Administer > Import Data Objects.

2. In the Import Settings tab, under Upload Type, select either Unicode of Data Import Template or Jar file. If 
you select Unicode of Data Import Template, skip to Step 6, otherwise go to Step 3.

3. If you are importing a JAR file larger than 2 MB in size, select the Run job in background? check box.
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• If Run job in background? is selected (default setting), FlexNet Operations processes the import job 
asynchronously. FlexNet Operations submits the job for processing and assigns the job a record number. 
(You can check the status of the import job on the status page. See Import/Export Job Status for more 
information.) 

• If Run job in background? is not selected, FlexNet Operations processes the import immediately. 

See Configuring Alert Behavior for more information on configuring background jobs.

4. For Error handling, select one of the following options:

• Continue with errors—The import process continues even if errors are encountered.

• Stop import job—The import process stops upon encountering an error.

5. For Duplicate record handling, select one of the following options:

• Update record—If the entity already exists in the database, the record is updated with the information in 
the import file.

• Skip and Generate Error—If the entity already exists in the database, it is not updated and an error 
message is generated.

6. For File Name, click Choose File. Browse to the Unicode .txt or .jar file containing the data you want to 
import.

Note • When importing a large number of Web Register Keys, it is recommended that you limit each job to a 
maximum of 1,000 keys to optimize performance. If necessary, split the task into multiple jobs to stay within 
the recommended limit.

7. Click Import. The file is imported into FlexNet Operations.

Import Order
If copying data from one instance of FlexNet Operations to another, dependencies such as Transaction Keys, 
License Technologies, and License Models must be imported first. Use the Selected Items with their 
Dependencies (if available) or Selected items to download JAR files from their respective entity pages and upload 
them before uploading a Product Packing or Entitlement Management Unicode text file. 

Note • See Exporting an Entity or Set of Entities as a JAR File and Downloading a Data Import Template for more 
information.
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The following lists the order each type of entity should be uploaded.

Note • Not all entities have an export option. For any entity page that does not include an Export option, data 
must be manually entered into the new instance of FlexNet Operations

Fulfillment Import Limitations
If updates on import are allowed, the following limitations apply: 

• Existing on-hold fulfillments can be updated only to active by import.

• Existing active fulfillments can be updated only to obsolete by import.

• Existing obsolete fulfillments cannot be updated by import.

Table 20-23 • Upload Order of Entities

Entity Type Upload Order

Dependencies Dependencies must be uploaded in the following order:

1. License Generator

2. License Technology

3. License Model

4. Hosts

5. Accounts

6. Users

7. Product Lines

8. Custom Attributes

9. Custom Host Attributes

10. Custom License Attributes

Product Entities Product entities must be uploaded in the following order:

1. Features

2. Products

3. Maintenance Products

4. Part Number or Product Relationship

Entitlement Entities Entitlement entities must be uploaded in the following order:

1. Simple and Bulk Entitlements

2. Maintenance Line Item

3. Web Reg Keys
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Using Data Import Templates
Data Import Templates enable you to do a batch import of data into FlexNet Operations. You can add new entities 
or modify existing ones. This approach may be preferred if there is a lot of data to be added or modified. 

Templates for entitlements, accounts and users, and products can be downloaded and populated with data that 
can be imported into a FlexNet Operations database using the import function (see the task described under 
Importing Entities). Features of the templates include

• Color coded column headers based on transaction type, account, user, entitlement, line item, product and 
feature.

• Column headings of required fields for a transaction are in bold.

• Column heading comments containing information about the data expected for the column and any other 
column dependencies associated with this column.

Any Custom Attribute fields you have configured will be included in the templates. Unique Custom Attributes and 
License Model Attributes and Policies utilize the following heading name conventions:

• License Model Attribute: LM[<LicenseModelName>|<AttributeName>]

• License Model Policy Attribute: PO[<LicenseModelName>|<AttributeName>|<PolicyAbbreviation]

• Custom Attributes: CA[<Entity>|<AttributeName>] where Entity = USER, PROD, ENT, or LINE

Downloading a Data Import Template
To download a Data Import Template, perform the following steps. 

Task To download a Data Import Template

1. Click Administer > Import Data Objects. 

2. Click the Data Import Templates tab.

3. Click the appropriate Download link for one of the following template types:

• Product Packaging Template—Products, features, and other data associated with product packaging.

• Entitlement Management Template—Entitlements, maintenance line items, bulk entitlements, web 
register keys and other data associated with entitlements.

• Download Packaging Template—Download packages, files and other data associated with download 
packages.

• Account and User Template—Accounts and users.

• Updates Template—Updates.

4. Save the .xlt file

Editing and Saving a Data Import Template
To edit and save a Data Import Template, perform the following steps.
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Task Editing and saving a Data Import Template

1. Open the .xlt file in Excel (or another compatible spreadsheet application). 

2. Fill in the spreadsheet columns as appropriate. 

Important • CreateUpdate transactions can blank existing data. If you upload a file containing transactions of 
these types, FlexNet Operations assumes any columns you include contain the desired value. If a column 
contains no values, then when FlexNet Operations updates the records, any existing data is lost. If you do not 
want to provide values in a column, then remove the column from the spreadsheet. 

When working with spreadsheets, follow these guidelines:

• Do not change heading names. If they are changed, the transactions are processed but values in the 
columns whose names have been changed are not assigned to the corresponding fields in the database.

• Only columns with a heading in bold text are required. 

• Hover over the heading to see comments on how to populate the field and to determine if there is a 
dependency requiring other columns to be completed. If there is more text in the comment that can be 
viewed by hovering over the heading, right click the heading and select Edit Comment to open the 
comment box and use the arrow keys to scroll up or down.

• For Users, see Time Zone Settings for correct construct of the time zone attribute.

• For Accounts, self-registered accounts cannot be imported into the Producer Portal. Also, the following 
restrictions apply to default accounts:

• MYORG: Only the account name can be changed. No other updates are permitted and this account 
cannot be deleted.

• PORTAL_ORG_UNIT: This account cannot be updated or deleted.

• UNKNOWN_ORG_UNIT: This account cannot be updated or deleted.

• Products and Entitlements contain multi-valued attributes such as features and line items. To have 
multiple features and line items, they cannot be set in a single row but must be added on separate rows 
repeating any identifier fields for the product or entitlement. Data that is only needed once for the 
transaction type is taken from the first row and data that can have multiple values is aggregated from 
the succeeding rows, which is why you cannot change a field using multiple rows of data for the same 
product or entitlement in the same Data Import Template file.

• If you want to change a field for products or entitlements, upload it in a separate Data Import Template 
file.

• When importing a large number of Web Register Keys, it is recommended that you limit each job to a 
maximum of 1000 keys to optimize performance. If necessary, split the task into multiple jobs to stay 
within the recommended limit.

3. After all changes are made, save the file as a Unicode .txt file.
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Time Zone Settings
One of the attributes that can be set for creating/updating users is a user’s time zone. Determine the correct time 
zone configuration from the following table. 

Table 20-24 • Time Zone Settings

Time Zone Setting

Midway Island, Samoa GMT-11.0DST0

Hawaii GMT-10.0DST0

Hawaii-Aleutian Daylight Time GMT-10.0DST60

Marquesas Time GMT-9.5DST0

Gambier Time GMT-9.0DST0

Alaska Daylight Time GMT-9,0DST60

Pitcairn Standard Time GMT-8.0DST0

Pacific Time GMT-8.0DST60

Mountain Standard Time GMT-7.0DST0

Mountain Daylight Time GMT-7.0DST60

Central America GMT-6.0DST0

Central Time GMT-6.0DST60

Ecuador, Columbia, Peru Time GMT-5.0DST0

Eastern Time GMT-5.0DST60

Venezuela Time GMT-4.5DST0

Guyana, Bolivia Time GMT-4.0DST0

Atlantic Time (Canada) GMT-4.0DST60

Newfoundland Daylight Time GMT-3.5DST60

Argentine Time, French Guiana, Uruguay Time GMT-3.0DST0

Brazil, Greenland Time GMT-3.0DST60

Mid-Atlantic GMT-2.0DST0
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Cape Verde Time GMT-1.0DST0

Azores Time GMT-1.0DST60

Coordinated Universal Time GMT0.0.DST0

British Time GMT0.0DST60

Antarctica/Troll GMT0.0DST120

Western Africa Time GMT1.0DST0

Western European Time GMT1.0DST60

Central African, South African Standard Time GMT2.0DST0

Israel Daylight Time, Eastern European Time GMT2.0DST60

Arabia Time GMT3.0DST0

Iran Daylight Time GMT3.5DST60

Mauritius, Seychelles Time GMT4.0DST0

Georgia, Armenia, Azerbaijan Time GMT4.0DST60

Afghanistan Time GMT4.5DST0

Uzbekistan, Turkmenistan, Tajikistan, Pakistan, Maldives Time GMT5.0DST0

India Standard Time GMT5.5DST0

Nepal Time GMT5.75DST0

Bangladesh, Sri Lanka, Bhutan Time GMT6.0DST0

Myanmar Time, Cocos Island Time GMT6.5DST0

Indochina, Christmas Island Time GMT7.0DST0

Krasnoyarsk Time GMT7.0DST60

China, Malaysia, Hong Kong, Singapore, Philippines, Western 
Australia Time

GMT8,0DST0

Irkutsk Summer Time GMT8.0DST60

Table 20-24 •  (cont.)Time Zone Settings (cont.)

Time Zone Setting
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Import/Export Job Status
You can view the status of data import or export operations executed in the background on the Import/Export 
Status page. 

Note • You must first configure the Export and Import Background Jobs alert on the Configure Alerts page. The 
default setting for this alert is a Detection and Notification interval of 30 days with a status of inactive. See To 
configure alerts for background queue processing for more information.

Pyongyang Time GMT8.5DST0

Central Western Standard Time (Australia) GMT8.75DST0

Japan, Korea Standard Time GMT9.0DST0

Australia Northern Territory Time GMT9.5DST0

South Australia Time GMT9.5DST60

Papua New Guinea GMT10.0DST0

Tasmania, Victoria, New South Wales Time GMT10.0DST60

Load Howe Summer Time GMT10.5DST30

New Caledonia, Vanuatu, Solomon Island Time GMT11.0DST0

Fiji, Marshall Islands Time GMT12.0DST0

New Zealand Time GMT12.0DST60

Chatham Daylight Time GMT12.75DST60

Phoenix Island Time, Tonga Time GMT13.0DST0

Enderbury, Fakaofo, Tongatapu Island Time GMT13.0DST60

Line Island Time GMT14DST0

Table 20-24 •  (cont.)Time Zone Settings (cont.)

Time Zone Setting
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Task To check the status of an import or export job

1. Click Administer > Import/Export Status.

2. The Export & Import Job Status page opens with a table that includes the following:

3. To delete a job from the historical record, select the job and click Delete.

4. To download a job log to a local file, select the job and click Download Exported File.

Administering License Technologies
In addition to FlexNet Publisher Licensing Toolkit technology, FlexNet Operations supports the use of other 
license technologies with the core product packaging, entitlement generation, and license support capabilities. 

FlexNet Publisher Licensing Toolkit is a feature-based license technology, wherein a software product’s binary 
code is rendered into licensable features. Variations of the product are achieved by combining different licensed 
features using FlexNet Operations product packaging rather than changing the binary code. You can view the 
components of the FlexNet Publisher Licensing Toolkit technology by navigating to Administer > License 
Technologies, and clicking FlexNet Publisher Licensing Toolkit.

Column Description

Job ID Auto generated unique identifier.

Request type Import or Export.

Export type The type of business object being exported. If downloading all business 
objects, the value is FlexNet Operations. 

Submitted by The ID of the user making the import or export request.

Submitted on Date and time of the import or export was submitted.

Input filename Name of the file being imported or exported.

State Failed—All of the entities failed on import. 

Completed—At least one of the entities succeeded on import.

Completed time Date and time the import or export was completed.

Error If some or all of the entity transactions have failed, the following message 
appears: Some of the entities have failed. Please view the error log for 
details. Download Error Log

A link to a zip file contains the download error log in XML format. 

If there were no failures, this column is blank.
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License technology administration can be divided into the following activities.  

Managing License Technologies
This page lists the license technologies registered with FlexNet Operations that can be used to create license 
generator configurations, linked with license models, and associated with products/suites.

Viewing the Details of a License Technology
To view the details of a license technology, perform the following steps.

Task To view the details of a license technology

Click its name from the technologies listed.

Changing the State of a License Technology
To change the state of a license technology, perform the following steps.

Table 20-25 • License Technology Administration Activities

Topic Description

Managing License 
Technologies

Viewing, changing the state of, deleting, and specifying the class files for 
license technologies

• Creating a License Technology

Using External Services with 
License Technologies

Explains how to use Revenera-provided interfaces to generate license keys by 
an external SOAP service.

• External Service Operations

• Creating an External Service

Managing License Generator 
Configurations

Viewing, deleting, and creating license generator configurations

• Creating a License Generator Configuration

• Creating a FlexNet Publisher Licensing Toolkit License Generator (VCG) 
Configuration

Managing License Model or 
License Generator Custom 
Attributes

Viewing, deleting and adding custom license generator configuration and 
license model attributes.

• Creating a License Generator Configuration Custom Attribute

• Creating a Custom License Model Custom Attribute

Managing Custom Host 
Attributes

Viewing, adding, deleting, and creating custom host attributes.

• Creating a Custom Host Attribute
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Task To change the state of a license technology

1. Select the box next to its name.

2. Click Change State.

3. Select a state (Draft or Deploy from the Change State drop-down box). 

Note • A license technology is created in draft state. After it has been deployed, you can continue to add license 
generator configurations. However, these generator configurations cannot be edited once they are used to create 
a (non-test) entitlement. (See Creating an Entitlement.)

Deleting a License Technology
To delete a license technology, perform the following steps.

Task To delete a license technology

Select the box next to its name and click Delete. A license technology can only be deleted in draft state, and if 
there are no license generator configurations, products, suites, or license models (including those in draft state) 
linked to the technology.

Once a license technology is deleted, all custom attributes associated with it are also deleted. You cannot delete 
the FlexNet Publisher Licensing Toolkit technology.

Creating a License Technology
To create a license technology, perform the following steps.

Task To create a license technology

1. Click Administer > License Technologies.

2. Click Add a License Technology.

3. Enter the following information in the Create a License Technology page:

Table 20-26 • Creating a License Technology

Field Description

Name Name to uniquely identify this license technology. This is a required field and 
must be unique.

Description Describe the characteristics of this license technology that make it unique. The 
description can be changed at any time. 
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State A new license technology is always created in a draft state. Any attribute, 
except the name of the license technology, can be edited in this state.

After a license technology is deployed, no attributes can be edited. Its state can 
be changed back to draft only if there are no products, suites, and licenses 
models (entities in draft state excluded) linked to the technology. A license 
technology can only be deleted in the draft state.

Type Select a license technology type:

• Manual: licenses are generated by a customer support representative 
manually using a third-party system. Since this license generator is not 
integrated into FlexNet Operations, when a user generates a license, the 
generated fulfillment is placed on hold and an email address is sent to the 
administrator at the address configured in System Configuration. The 
administrator logs in to the third-party system and generates the license, 
and then returns to FlexNet Operations to set the license on the on-hold 
fulfillment record. The user can then download the license.

• Hands-Free: licenses are generated programmatically using a third-party 
system. After generation, a fulfillment record is placed on hold. Web 
services are used to update the license text on the fulfillment record. 
Please refer to the FlexNet Operations Web Services Guide for more 
information.

• External SOAP Service: licenses are generated by FlexNet Operations, by 
implementing a web service interface. Please refer to the FlexNet 
Operations Web Services Guide for more information.

• Use Generator Interface: licenses are generated by FlexNet Operations, by 
implementing a CustomGenerator interface. Please refer to the FlexNet 
Operations On-Premises Installation & Implementation Guide for more 
information.

Refer to Getting Started with Non-FlexNet Licensing Technologies for additional 
information on these types.

Generator Service End Point Enter the path for this licensing technology’s license generator service 
(required when the license technology type is External SOAP Service; otherwise, 
optional). 

FlexNet Operations expects a URL in the following format. 

protocol://host:port/path

See Using External Services with License Technologies for more information.

Table 20-26 • Creating a License Technology

Field Description
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Generator Service Enter the name of the Java class that generates licenses for this license 
technology. This class must implement the 
com.flexnet.operations.publicapi.LicenseGeneratorService interface. This 
setting appears when you select Use Generator Interface for the license 
technology type.

For instructions on building and correctly placing the class file in your FlexNet 
Operations installation, refer to theFlexNet Operations On-Premises Installation 
& Implementation Guide. 

Generator Validator Enter the name of the Java class that validates products and license models for 
this license technology. This class must implement the 
com.flexnet.operations.publicapi.LicenseGeneratorValidator interface. 

For instructions on building and correctly placing the class file in your FlexNet 
Operations installation, refer to the FlexNet Operations On-Premises Installation 
& Implementation Guide. 

License Consolidator Enter the name of the Java class that consolidates licenses for this license 
technology. This class must implement the 
com.flexnet.operations.publicapi.LicenseConsolidator interface. 

For instructions on building and correctly placing the class file in your FlexNet 
Operations installation, refer to the FlexNet Operations On-Premises Installation 
& Implementation Guide. 

Entitlement Certificate 
Template

The variation name of the email template to use to generate an entitlement 
certificate for this license technology. 

When no path is specified, the default Entitlement Certificate template is used 
instead. 

Entitlement Certificate 
Email Template

The variation name of the email template to use to create the body of the email 
for sending an entitlement certificate email attachment for this license 
technology. 

Note • HTML content is always retrieved for this template. 

When no path is specified, the default Entitlement template is used instead. 

Multiple Consolidated 
Licenses Email Template

The variation name of the email template to use to send a multiple consolidated 
license email attachment for this license technology. 

When no path is specified, the default Multiple Consolidated Licenses template 
is used instead. 

Table 20-26 • Creating a License Technology

Field Description
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Consolidated License Email 
Template

The variation name of the email template to use to send a consolidated license 
email attachment for this license technology. 

When no path is specified, the default Consolidated License template is used 
instead. 

Multiple License Files Email 
Template

The variation name of the email template to use to send a multiple license files 
email attachment for this license technology. 

When no path is specified, the default Multiple Licenses template is used 
instead. 

License File Email Template The variation name of the email template to use to send a license email 
attachment for this license technology. 

When no path is specified, the default License template is used instead. 

Filename Generator Enter the name of the Java class that generates license file names for this 
License Technology. This class must implement the 
com.flexnet.operations.publicapi.MultipleLicenseFilenameGenerator 
interface. For instructions on building and correctly placing the class file in your 
FlexNet Operations installation, refer to the FlexNet Operations On-Premises 
Installation & Implementation Guide. 

Is Counted? Indicate whether or not the user is prompted to provide a fulfillment count 
when activating the license. A license technology that has counted license 
models belonging to it can also be defined as counted. 

For an uncounted license model, a license is generated for only 1 copy at a 
time.

Does this license 
technology generate 
replacement keys (i.e., 
regenerative licensing)

Select whether or not the license technology generates replacement keys. Such 
a license technology is called regenerative.

• Yes—With a regenerative (or replacement) license technology, the last 
license issued overwrites the previous one. Indicate whether or not the 
license technology is replacement or incremental. A master copy of the 
license is stored on the host. For all license lifecycle activities, such as 
returns or repairs, the master license is updated by FlexNet Operations. 
When a user downloads a license for a fulfillment record belonging to a 
replacement technology, the license on the corresponding host is given to 
the user. 

• No—For an incremental license technology, each fulfillment record 
contains its own license.

Is Return Operation 
Allowed?

Indicate whether the technology allows license returns.

Table 20-26 • Creating a License Technology

Field Description
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Is Repair Operation 
Allowed?

Indicate whether the technology allows license repairs.

Is Rehost Operation 
Allowed?

Indicate whether the technology allows license rehosts.

Is Stop Gap Operation 
Allowed?

Indicate whether the technology allows stop gap licenses.

Is Emergency Operation 
Allowed?

Indicate whether the technology allows emergency licensing.

Is Publisher Error Correction 
Operation Allowed?

Indicate whether the technology allows publisher correction operations.

Is Upgrade/Upsell/Renew of 
Fulfillments Allowed?

Indicate whether the technology allows upgrade, upsell, or renewal operations.

File Definitions If the license technology uses multiple license files, you can define multiple file 
types for each fulfillment record. The end user can download multiple files from 
each fulfillment record, or receive multiple files of different types as email 
attachments.

1. Click Add File Definition to add a license file type.

2. In the Create File Definition window, enter a name for the file definition. 

3. Select whether the license file type is text or binary.

4. Optionally, enter a description of the file type.

5. If any custom host type attributes are defined for this type, enter values for 
these attributes. (See Managing Custom Host Attributes.)

6. Click OK.

Table 20-26 • Creating a License Technology

Field Description
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4. Click Save to save your changes, Reset to clear all fields, and Add New to save and specify a different license 
technology.

5. Click Next to specify attributes for a license generator configuration. 

Using External Services with License Technologies
Producers can use Revenera-provided interfaces to deploy external services that provide customized 
functionality within FlexNet Operations. License keys can be generated, for instance, by an external SOAP service 
that implements the LicenseGeneratorService Web Services Description Language (WSDL). 

The server that implements this WSDL is hosted separately from the one that runs FlexNet Operations. It hosts the 
service externally and operates independently of FlexNet Operations, as shown in the figure below. The external 
service is accessed by FlexNet Operations at run time for operations such as product and license model validation 
and license generation. 

Host Type (non-FlexNet) Host type represents a class of device on which the license-enabled code is 
intended to run. When a license is generated for a product, FlexNet Operations 
prompts for the attributes that belong to the product’s host type. The settings in 
the Create Host Type window differ for FlexNet and non-FlexNet licensing 
technologies. 

Host types can be included in a license technology either by adding a new host 
type or selecting an existing host type.

To add a host type

1. Click Add Host Type.

2. In the Create Host Type window, enter a name for the host type. 

3. Optionally, enter a description of the host type.

4. Enter the name of the custom class (Hostid Generator Class) used to 
generate host IDs for the host type. This custom class should implement 
the interface:

com.flexnet.operations.publicapi.HostIdentifierGeneratorByHostTy
pe

5. Click OK.

To select an existing host type

1. Click Select Host Type.

2. In the Select Host Type window, select the check box for a host type, and 
then click OK.

Table 20-26 • Creating a License Technology

Field Description
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Figure 20-1: External License Generator

For information on using external services with license technologies, see the following topics:

• External Service Operations

• Creating an External Service

Note • The availability of certain operations varies with your FlexNet Operations license technology type. To 
customize the way license file names are generated for FlexNet Licensing Technology, implement the 
com.flexnet.operations.publicapi.MultipleLicenseFilenameGenerator interface and enter the name of that Java 
class in Filename Generator on the Create A License Technology page. 

External Service Operations
An external service can be invoked from FlexNet Operations for the following operations: 

• CustomGeneratorService 

• CustomGeneratorValidator 

• CustomLicenseConsolidator 

• CustomFilenameGenerator 

• CustomHostIdGeneration
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External service operations and their descriptions are listed in the following table.  

Creating an External Service

Important • Examples and procedures in this section are based on Java. However, the external service can be 
created in any technology that supports SOAP, such as gSOAP, C#, or Java. You must make the necessary 
modifications and follow the procedures specific to the technology you choose. 

Following are procedures for setting up a sample external service web application, creating the external service 
license technology, and testing the external service. You must have the extgenservice.zip FlexNet Operations 
build archive (download the extgenservice.zip archive from the Product and License Center at 
https://flexerasoftware.flexnetoperations.com), and the application server on which the custom service is to be 
deployed must be running. 

Configuring the License Technology URL
On the FlexNet Operations Create A License Technology page, the license technology end point is called the 
Generator Service End Point. It is required when a license technology Type of External SOAP Service is selected, 
and optional for FlexNet Licensing Technology or when a Manual or Hands-Free technology is selected (manual 
and hands-free technologies rely on an external service for optional consolidators, file name generators, and host 
ID generators). 

Table 20-27 • External Service Operations

External Service Operation Description

generateLicense Generates license

validateProduct Validates product

validateLicenseModel Validates license model

consolidateFulfillments Consolidates licenses for multiple fulfillments

generateConsolidatedLicenseFilenames Generates license file names for consolidated 
licenses

generateFulfillmentLicenseFilenames Generates license file names for single fulfillments

generateCustomHostIdentifier Generates custom host identifier

ping Tests external service availability
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Figure 20-2: Create a License Technology Page

Enter the URL to the custom generator service in this format: protocol://host:port/path.

For existing custom license technology configurations, the old custom license technology URL in the system 
configuration is deleted from the database when the URL is updated. 

Task To set up the sample external service web application 

1. Create a directory on your local machine called C:\TenantTests\ExtLicenseService, for example. 

2. Extract the extgenservice.zip archive, which contains these files: 

• lib – required .jar files 

• src – sample implementation Java files 

• schema – WSDL and XSD files 

• build.xml – ant build file 

• readme.txt – information file 

3. Run the ant build tool to build the flexnet-licgen.war sample application. 

4. Rename the .war file, if necessary, to use a different context path. 

5. Deploy the .war file in the application server. 

6. Start the application server, which deploys the application. 

Task To create the external service license technology 

1. Log in to FlexNet Operations. 

2. Create the external license service technology. (Refer to the Creating a License Technology procedure). 

a. For Type, select the license generator type called External SOAP Service. 
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b. For Generator Service End Point, type this path: 
{CUSTOM_TECH_HOST}/flexnet-licgen/services/LicenseGeneratorService 

3. Click to test the connection. 

4. Deploy the external service license technology. (Refer to the Managing License Technologies procedure). 

5. Create the external service license model. (Refer to the Creating a License Model procedure). 

6. Deploy the external service license model. (Refer to the Deploying a License Model procedure). 

7. Create a product using the external service license technology and license model, then deploy the product. 
(Refer to the Creating a Product and Deploying a Product procedures). 

8. Create an entitlement for a few copies of the product, then deploy the entitlement. (Refer to the Creating an 
Entitlement and Viewing Entitlements procedures). 

9. Ensure that the system configuration specifies the default URL for the external service (System > Configure > 
FlexNet Operations). 

Task To test the external service 

1. Activate a license for one copy of the product to send a request to the external service. 

2. To perform a negative test, stop the application server. Try to activate a license for another copy of the 
product. You should receive an error message because the application server is not running. 

Managing License Generator Configurations
A given license technology may have one, or many associated license generator configurations. For example, 
FlexNet Publisher Licensing Toolkit may have several license generator configurations to support different 
release versions. You may also want different license generator configurations to support different encryption 
levels for generated licenses.

A license generator configuration lets a publisher model any attributes that are specific to the license generation 
toolkit or executable. These are typically not business attributes. For example, with FlexNet technology, an 
example of an attribute could be the encryption strength used to generate a license.

The License Generator Configurations page displays the following information:

Viewing the Details of the License Generator Configuration
To view the details of the license generator configuration, perform the following steps.

Table 20-28 • License Generator Configuration Page

Field Description

Name Name of the license generator configuration.

License Technology License technology to which the license generator configuration belongs.

Description Description of the license generator configuration.
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Task To view the details of the license generator configuration

Click its name.

Deleting a Configuration
To delete a configuration, perform the following steps.

Task To delete a configuration

Select the box next to its name, and click Delete. A configuration cannot be deleted if its associated license 
technology is deployed, or if there are products and suites associated with the configuration.

Creating a New Configuration
To create a new configuration from a page, perform the following steps.

Task To create a new configuration from this page

Click Add a License Generator Configuration.

You can edit a license generator configuration as long as there are no (non-test) fulfillments against it.

Creating a License Generator Configuration 

Note • When creating a license technology, if you do not have any configuration for the license generator 
executable, you can skip this step.

Task To create a license generator configuration for a draft or deployed license technology

1. Navigate to the Create a License Generator Configuration page. 

2. Enter the following fields:

Field Description

Name Name to uniquely identify this license generator configuration. This is a 
required field and must be unique for a given license technology.

Description Describe the characteristics of this license generator configuration that 
make it unique. The description can be changed at any time. 

License Technology License technology for which this license generator configuration generates 
licenses. This field cannot be changed after it is saved.
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3. If the license generator configuration has custom attributes defined, you must specify their values on this 
page. 

4. Click Save to save your changes, Reset to clear all fields, and Add New to specify a different configuration.

5. Click Next to create a custom license model attribute.

To create a license generator configuration for FlexNet Publisher Licensing Toolkit, see Creating a FlexNet 
Publisher Licensing Toolkit License Generator (VCG) Configuration.

Creating a FlexNet Publisher Licensing Toolkit License Generator (VCG) 
Configuration 

A Vendor Certificate Generator (VCG) is an executable built by a publisher using the FlexNet Publisher Licensing 
Toolkit technology. A VCG contains unique encryption seeds used to digitally sign licenses. FlexNet Operations 
can be configured to use multiple VCGs. FlexNet Operations ships with a VCG for a vendor named “demo,” which 
you can use for testing purposes. This is equivalent to lmcrypt in the FlexNet Licensing toolkit. 

FlexNet Publisher Licensing Toolkit license files are encoded using UTF-8. 

Task To configure FlexNet Operations with your own production VCG

1. In the FlexNet Operations Producer Portal, click Administer > License Generators. 

2. Click Add a License Generator Configuration. 

3. From the License Technology drop-down list, select FlexNet Publisher Licensing Toolkit. (To create a license 
generator configuration for a different license technology, see Creating a License Generator Configuration.)

4. View or change the values of the following settings. Required fields are indicated with an asterisk. If a default 
value exists, it is listed as the first choice.

Setting Description

Name Name to uniquely identify this license generator configuration in drop-
down lists.

Description Describe the characteristics of this license generator configuration that 
make it unique. The description can be changed at any time. 

License Technology License technology for which this VCG configuration generates licenses: 
Select FlexNet Publisher Licensing Toolkit.

Name of the VCG Executable The name of the VCG executable. For example, the name of the demo VCG 
executable is “demo,” “demo_vcg,” (UNIX) or “demo_vcg.exe” (Windows 
only). Required. 
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Vendor Daemon Name Name of the vendor daemon for which this VCG generates licenses. If not 
specified, this name is inferred from the name of the VCG executable. 

Note • Vendor daemon name must match the vendor name in the 
publisher.xml file. The name is case-sensitive.

Index to VCG Generator 
Function Table (default is 0) 

Integer index into the custom generator table inside the VCG. 

Index to VCG Crypt Seed Table 
(default is 0) 

Integer index into the key seed array inside the VCG.

License Signature Strength The encryption strength of licenses generated by the VCG: The strength 
configured in the VCG can be overridden on this page. For an explanation 
of the choices, please see the FlexNet Operations On-Premises 
Installation & Implementation Guide.

License Signature 
Compatibility Level 

Used to allow backward compatibility with version 8.0 CRO (TRL). The 
setting in the VCG can be overridden on this page. 

Include License Key Strength 
for pre-TRL Compatibility 

Used to add a 20-character license key along with a SIGN= signature. The 
setting in the VCG can be overridden on this page.

FlexNet Licensing Version for 
Compatibility with Client 
Application

The FlexNet Publisher Licensing Toolkit license file format to use to 
format the generated license: The setting in the VCG can be overridden 
on this page.

Format String for Date-based 
Versions 

When a feature is created in FlexNet Operations, its version is specified to 
be either fixed or date-based. Using date-based versions is a product 
versioning strategy. In this scheme, the version number of the FlexNet 
Publisher Licensing Toolkit feature line is a representation of the 
calendar date when a customer’s maintenance for the product expires. 
The version number that the application asks for when it checks out a 
license is a representation of the date it was built. Therefore, a customer 
has the right to use a version (the build date) of the application less than 
or equal to the date that the maintenance expires (the version in the 
license). The date-based version that the VCG puts in the license varies 
from license certificate to license certificate, whereas a fixed version is 
the same for all licenses generated for that product-version combination. 
If a feature is created that uses a date-based version format, the date 
that is expressed in that format is specified when an entitlement line item 
containing that product is configured. 

For a date of May 15, 2009, yyyy.MM gives 2009.05 and yyyy.MMdd 
gives 2009.0515. 

Setting Description
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5. Click Save to save the configuration for this VCG. 

Managing License Model or License Generator Custom 
Attributes

The Custom Attributes page lists custom attributes with the following information:

Suppress START Date Keyword 
in License Text

Used to suppress the START Date keyword identifying the license start 
date in a feature line. 

Suppress ISSUED Date 
Keyword in License Text

Used to suppress the ISSUED Date keyword identifying the license issue 
date in a feature line. 

Server host ID used for 
Trusted Activations

Fill in applicable data. 

Default Server Port Number in 
License File

Fill in applicable data. 

Version of VCG Version number of the VCG executable used to generate licenses. This 
setting is used to check whether FlexNet Publisher keywords and hostID 
types in a license are supported by the version of the VCG and also to 
deliver appropriate error messages when conflicts are discovered.

If you are using VCG 11.5, for example, then set Version of VCG to 11.5.0. 
Default version: 6.2.1.

Your current VCG version can be identified by executing the VCG with the 
version flag. For example: demo_vcg.exe version. So, if this command 
returns the VCG version (not the vendor version) 12.11.0.0, for instance, 
the Version of VCG value can be 12.11, 12.11.0, or 12.11.0.0. 

Table 20-29 • Custom Attributes Information

Field Description

Name Name of the custom attribute

Type Type of value the custom attribute accepts: Boolean, Date, Text (free form or 
single select), Multi-valued text, or Long Text. 

Belongs To Whether the attribute is associated with a license model or a license generator 
configuration

License Technology Name of the license technology to which the attribute belongs.

Setting Description
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Click an attribute name to view its details.

• Click Add a License Model Attribute to create a custom license model attribute.

• Click Add a License Generator Attribute to create a license generator configuration attribute, as described in 
Creating a License Generator Configuration Custom Attribute. 

Select the box next to an attribute and click Delete to delete it. 

• Custom attributes cannot be deleted if the associated license technology is deployed. 

• When a custom attribute is deleted from a draft license technology, then all references to this attribute are 
deleted from the corresponding generator configuration or license model.

Creating a License Generator Configuration Custom Attribute

Note • When creating a license technology, if you implement your license generator class so that it references the 
license generator executable, you can skip this step. In the flow of the Create a License Technology wizard, this 
step precedes creating the license technology configuration itself.

You can create a license generator configuration attribute for custom license technologies in the draft state. You 
cannot create a license generator configuration attribute for FlexNet Publisher Licensing Toolkit.

Task To create a license generator configuration attribute:

1. Navigate to the Create Custom Attribute page. 

2. Specify the following information for your custom generator attribute:

Field Description

Name Name to uniquely identify this custom license generator configuration attribute: this 
name must be unique within a given license technology.

License 
Technology 

License technology that includes the license generator configuration for this 
attribute. Choose from the drop-down list. This value cannot be changed after it is 
set.

Is Required? Will this be a required or optional attribute for license generation?
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3. Click Save to save your changes, Next to move to the next page without saving, Reset to clear all fields, and 
Add New to specify another attribute.

Note • If necessary, create an attribute for the name of your license generator executable.

4. Click Next to create a license generator configuration. 

Creating a Custom License Model Custom Attribute

Note • In the flow of the Create a License Technology wizard, this step precedes creating the license model itself.

Type Type of value the custom attribute accepts. This cannot be changed after it is set. 

• Number: An integer.

• Text: An alphanumeric string.

• Max Length: Maximum number of characters the text field will accept

• Text Type: this cannot be changed after it is set.

• Free Form: If you select this option, your custom attribute will take a typed-
in alphanumeric string.

• Single Select: If you select this option, your custom attribute will take the 
value of an item from a drop-down list.

• Multi Valued Text: If you select this option, your custom attribute will take 
the value of several selected boxes next to items in a specified list.

• Valid Values: Use to specify a list from which Single Select or Multi Valued 
Text items can be chosen.

• Long Text: A text value that can be up to 16384 characters. The value can 
be typed or pasted into the text box. (The Display Type setting controls how 
a long text value will be displayed.)

• Boolean: A pair of options for mutually exclusive choices, that is, “Yes” or “No”.

• Date: A date that can be selected from a calendar tool.

Field Description
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Task To create a custom license model attribute

1. Navigate to the Create Custom Attribute page. 

2. Fill in the following fields for each attribute you create:

Field Description

Name Name to uniquely identify this custom license model attribute: this name must 
be unique within a given license technology.

License Technology License technology of which the attribute is a part. Choose from the drop-down 
list. If you choose FlexNet Publisher Licensing Toolkit from this list, you will be 
setting custom attributes on its license models.

When Choices When the value of this attribute must be specified:

• License Model Creation—When creating a license model that uses this 
attribute

• Entitlement:—When creating entitlements with license models that use this 
attribute

• Fulfillment—When activating licenses with license models that use this 
attribute 

Is Required? Will this be a required or optional attribute for license generation? If required, 
this attribute can only be created for a license technology in the draft state.
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Type Type of value the custom attribute accepts.

Number An integer (for example, 33452). 

Text An alphanumeric string. If you choose this option, the Producer 
Portal reveals additional controls for Max Length and Text 
Type.

Max Length: Maximum number of characters the text field will 
accept.

Text Type: Choose one of the following:

• Free Form—If you select this option, your custom attribute 
will take a typed-in alphanumeric string. When you select 
this option, you also need to choose a Display Type to 
determine how the text attribute will be displayed: Text 
Field or Text Area. 

• Single Select—If you select this option, your custom 
attribute will take the value of an item from a drop-down 
list. When you select this option, you also need to specify 
Valid Values with Add Value. Valid Values determine the 
list of values a user can choose for this attribute.

• Multi Valued Text—If you select this option, your custom 
attribute will take the value of several selected boxes next 
to items in a specified list. When you select this option, 
you also need to specify Valid Values with Add Value. Valid 
Values determine the list of values a user can choose for 
this attribute.

Important • The Text Type selection cannot be changed after it 
is set.

Long Text An alphanumeric string that can be up to 16384 characters. 
The value can be typed or pasted into the text box. When the 
attribute’s Type is Long Text, also choose a Display Type to 
determine how the text attribute will be displayed: Text Field 
or Text Area.

Boolean A pair of options for mutually exclusive choices, such as Yes or 
No.

Date A calendar date.

Required for Reporting If Yes, then this attribute will be included in data transformation for reporting.

Field Description
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Note • If you create an attribute called “SERIAL_NUMBER,” its label, by default, is displayed as “Serial 
Number.” This is because SERIAL_NUMBER is a FlexNet Publisher Licensing Toolkit attribute for which 
resources are already defined. If you change the label for the custom SERIAL_NUMBER attribute, its FlexNet 
Publisher Licensing Toolkit display label will also change.

3. Click Save to save your changes, Reset to clear all fields, and Add New to specify another attribute, and 
Complete to save and exit this page.

Managing Custom Host Attributes
Licenses are usually bound to either a node or a host. Defining a host attribute allows you to use the host as the 
criteria for capabilities like batch rehosts, searching and sorting on hosts, and listing all fulfillments for a given 
host.

The Custom Host Attributes page lists attributes with the following information:

Click an attribute name to view its details.

Click Add a Host Attribute to create a custom host attribute.

Select the box next to an attribute and click Delete to delete it. Custom host attributes cannot be deleted if the 
associated license technology is in Deployed status. 

Creating a Custom Host Attribute
If custom host attributes are defined for a host type, FlexNet Operations displays them to users when they create 
a host of that type. You define custom host attributes in a manner similar to defining custom license model 
attributes.

Note • You can generate a unique identifier for a host, based on these attributes, by implementing the 
HostIdentifierGeneratorByHostType interface under System Configuration. Also, you can validate whether or not 
the user supplied the appropriate values for these attributes.

Table 20-30 • Custom Attributes Information

Field Description

Name Name of the custom attribute

Type Type of value the custom attribute accepts: Boolean, Date, Text (free form or 
single select), Multi-valued text, or Long Text. 

License Technology Name of the license technology to which the attribute belongs.

Host Type Type of host for the custom attribute.
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Task To create a custom host attribute

1. Navigate to the Create a Custom Host Attribute page.

2. Fill in the following fields for each attribute you create:

Field Description

Name Name to uniquely identify this custom host attribute. This name must be unique 
within a given license technology/host type combination.

License Technology The type of license technology with which the attribute is to be used. FlexNet 
Operations does not report on host attributes for non-FlexNet license 
technologies. 

Host Type Select a host type from the drop-down list.

Is Required? Will this be a required or optional attribute for license generation? Click Yes for 
required attributes. Click No for optional attributes. 

Required attributes can only be created for a license technology in the draft 
state.
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3. Click Save when complete.  

Type Type of value the custom attribute accepts. Type cannot be changed after it is 
set. 

Number: An integer (for example, 33452).

Text: An alphanumeric string. If you choose this option, the Producer Portal 
reveals additional controls for Max. Length and Text Type.

• Max Length: Maximum number of characters the text field will accept.

• Text Type: Choose from Free Form, Single Select, or Multi Valued Text. (This 
cannot be changed after it is set.)

Free Form: If you select this option, your custom attribute will take a typed-
in alphanumeric string. When the Text Type is Free Form, also choose a 
Display Type to determine how the text attribute will be displayed: Text 
Field or Text Area. 

Single Select: If you select this option, your custom attribute will take the 
value of an item from a drop-down list. When the Text Type is Single Select, 
also specify Valid Values with Add Value. Valid Values determine the list of 
values a user can choose for this attribute.

Multi Valued Text: If you select this option, your custom attribute will take 
the value of several selected boxes next to items in a specified list. When 
the Text Type is Multi Valued Text, also specify Valid Values with Add Value. 
Valid Values determine the list of values a user can choose for this 
attribute.

Long Text: An alphanumeric string that can be up to 16384 characters. The 
value can by typed or pasted into the text box. When the attribute’s Type is Long 
Text, also choose a Display Type to determine how the text attribute will be 
displayed: Text Field or Text Area. 

Boolean: A pair of options for mutually exclusive choices, such as Yes or No.

Date: A calendar date.

Required for Reporting If Yes, then this attribute will be included in data transformation for reporting. 
The following custom host attribute types are not available for reporting: 

• Attributes that use a license technology other than FlexNet Licensing

• Long Text type attributes 

• Multi Valued Text type attributes. 

Field Description
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Administering License Models   
This section explains what license models are, and how to create and configure license models. Included are the 
following topics:

About License Models 
A license model defines licensing characteristics that determine how, when, where, and by whom a Flex-enabled 
product or suite can be used. One or more license models are linked with licensed products when the products 
are packaged.

Table 20-31 • 

Topic Description

About License Models Answers the question, “What is a license model?” Subtopics also describe the types 
of license models directly supported by FlexNet Operations and the provide details 
on the use of certain license model attributes.

Managing License 
Models

Briefly describes how to view, add, delete, print, and change the state of a license 
model. 

Creating a License 
Model

Provides a detailed explanation of the license model creation process.

Copying a License 
Model

Explains how to use a copy of a license model to quickly create a new license model 
with settings similar to the original.

Deleting a License 
Model

Shows how to delete license models. 

Deploying a License 
Model

Describes how to change a license model’s state to Deployed. 

Printing a License 
Model

Explains how to print a license model. Printing a license model opens a pop-up 
window with details about the license model. 

Exporting License 
Models

Discusses how to export one or more license models, as .jar files, with or without 
dependencies. 

Copying a License 
Model

Describes how to use predefined substitution variables in a license string.

Setting Up Custom 
License Model 
Attributes

Discusses how to set up custom license model attributes for a license model. 

Setting License Model 
Policies

Provides an overview of the license model policies you can set after you create a 
license model. 
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Additional information about license models and license model attributes is collected in the following topics. 

Important • License models must be deployed before the products with which they are linked are deployed; 
deploying a product does not deploy the linked license models. 

License Model Types 
FlexNet Operations comes with sample license models of each type, and it is possible to create custom license 
models as well.

Table 20-32 • 

Topic Description

License Model Types Discusses the different types of license models. This topic includes the following 
subtopics: 

• Certificate License Models

• Trusted License Models

• Embedded License Models

• Custom License Models

License Model Attribute 
Specification Time

Explains how producers can choose when a license model attribute is specified. 
Typically, attributes can be specified when the license model is created, when an 
entitlement is created, or when a license is fulfilled.

About Overdraft Support Explains how the license model attribute, Overdraft, operates for license models 
that support overdraft. 

Predefined Substitution 
Variables for License 
Strings

Describes the use of predefined substitution variables in license strings and lists 
predefined substitution variables.

Custom Attributes in 
License Strings

Describes the use of custom license model attributes in license strings.
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These license models can be categorized into the following types:  

Certificate License Models  
Certificate license models are used to generate licenses that are distributed as license certificates. After delivery, 
license certificates cannot be securely revoked. The following table describes the four certificate models that are 
delivered with FlexNet Operations.  

Table 20-33 • Types of License Models

License Model Description

Certificate License 
Models

The FlexNet license server uses the contents of a license file, or license certificate, 
to control how a given piece of software can be used. You can vary the contents of a 
license file to provide variations of your application with different licensing needs, 
such as an evaluation version and a full version, without being required to provide 
different binaries or recompile your application. Licensing systems that use license 
files are referred to as certificate-based licensing.

Trusted License Models License information is stored securely in trusted storage rather than in license 
certificates. Trusted storage is a secure location on the target system into which 
FlexNet Publisher Licensing Toolkit can write licensing data. The licensing data 
stored in trusted storage is encrypted and authenticated so that the end user 
cannot read or modify it. Moreover, FlexNet Publisher Licensing Toolkit can detect if 
trusted storage has been deleted or tampered with. 

Embedded License 
Models

For device manufacturers using FlexNet Embedded. The embedded license model 
includes two license types: counted and uncounted. 

Custom License Models FlexNet Operations can be configured with a variety of custom license models. 

Table 20-34 • Certificate License Models

Certificate Models Description

Floating Counted License rights available network-wide from a license server system that can be 
shared by a limited number of simultaneous instances of the FLEXenabled 
application.

Floating Uncounted License rights available network-wide from a license server system that can be 
shared by an unlimited number of simultaneous instances of the FLEXenabled 
application: Very uncommon license model.

Nodelocked Counted License rights to authorize a limited number of instances of a FLEXenabled 
application running on a specific machine identified by a unique machine ID or 
host ID: Uncommon license model.
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Trusted License Models 
FlexNet Publisher Licensing Toolkit version 11 introduced the ability to store license information securely in 
trusted storage rather than in license certificates.

If a product is licensed with any trusted license model, the product must be linked with a transaction key. A 
transaction key is linked with a product at the time the first trusted license model is linked with the product, and 
can be overridden for local trials and short code ASRs. 

The following table describes the four trusted models that are delivered with FlexNet Operations.  

Nodelocked Uncounted License rights to authorize an unlimited number of instances of a FLEXenabled 
application running on a specific machine identified by a unique machine ID or 
host ID.

Table 20-35 • Trusted License Models

Trusted Models Description

Enterprise Activation The first step in the life of these license rights is activation on a license server. From 
there, the vendor daemon can:

• Transfer the licenses to another license server, or 

• Activate those licenses on end-user machines. 

Though the licenses are activated on a license server, they are never floating. Also 
known as Activatable-Server. 

Floating Borrowable The first step in the life of these license rights is activation on a license server. From 
there, the vendor daemon can:

• Transfer the licenses to another license server, 

• Serve them as floating licenses, or 

• Activate those licenses on end-user machines. 

Also known as Hybrid. 

Floating Transferrable The first step in the life of these license rights is activation on a license server. From 
there, the vendor daemon can:

• Transfer the licenses to another license server, or 

• Serve them as floating licenses. 

The vendor daemon cannot activate these licenses on end-user machines. Also 
known as Concurrent. 

Table 20-34 • Certificate License Models

Certificate Models Description
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Note • If you intend to use trusted storage-based licensing, you must build your publisher-specific activation 
utilities. There are two types of activation utilities: application activation utilities and server activation utilities. 

• An application activation utility initiates and manages the installation of license rights into trusted storage 
on an end user’s system. 

• A server activation utility is responsible for initiating and managing the installation of license rights into 
trusted storage on a license server machine, enabling it to serve licenses to clients.

Embedded License Models
Embedded license models are intended for use with software as well as intelligent hardware devices. FlexNet 
Embedded hosts can be standard software hosts as well as devices and servers. 

Devices typically have limited memory and network connectivity, and are manufactured in a variety of types, with 
different licensable features. 

These hardware devices have two license sources to enable their feature set. 

• A pre-installed license enables the device’s default features. 

• An additional license enables the features specific to a particular device model. For example, a manufacturer 
can create a basic camera model with a pre-installed license, and then create any number of additional 
models in the same line that use the same hardware as the basic camera, but include additional licenses that 
enable each model’s features.

The following table describes the four embedded license models that are delivered with FlexNet Operations:

Retail Activation These license rights are activated only on an end-user machine and authorize an 
unlimited number of instances of a FlexEnabled application running on that 
machine. Also known as Activatable-Client. 

Table 20-36 • Embedded License Models

Embedded Models Description

Embedded Counted License rights authorize a limited number of instances of a device feature 
set, identified by a unique device ID or host ID.

Embedded Uncounted License rights authorize an unlimited number of instances of a device 
feature set, identified by a unique device ID or host ID.

Named User Licensing Auto-provisioned model that eliminates borrow period for served devices. 

Concurrent User Licensing Auto-provisioned model for any served device.

Table 20-35 • Trusted License Models

Trusted Models Description
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Note • Models were added as a convenience for those who want to mimic user based licensing scenarios with 
Cloud Licensing Service.

For producers who use FlexNet Usage Management, FlexNet Operations also supports metered license models. 
Metered license models reflect licensing scenarios where usage is flexibly tracked and reported so that, while 
firm limits can still be enforced, end users can consume capacity or counts and later reconcile payment based on 
their actual usage. (See About Usage Management for an introduction to usage management.)

Note • Embedded license models are only available for software publishers and device manufacturers who use 
FlexNet Embedded. 

Custom License Models 
You can also configure FlexNet Operations with a variety of custom license models. Consult the FlexNet 
Operations On-Premises Installation & Implementation Guide for details on configuring and customizing FlexNet 
Operations.

License Model Attribute Specification Time 
To help make an individual license model applicable to a set of products, the value of many license model 
attributes can be set to be specified at one of several times, for example: 

• License Model Time—Fixed when a license model is created 

• Entitlement Time—Set when an entitlement line item is configured 

• Fulfillment Time—Specified when a license is activated 

Additional license models can be created through the Producer Portal, either from scratch or by copying one of 
the existing license models. License models cannot be imported using the Product Packaging Web service. 

About Overdraft Support   
As described in Overdraft, you can enable the Overdraft option to allow a specified number of users to run a 
software package during peak usage times, even after the application’s license limit has been reached. When 
defining overdraft support in a license model, you define a set of rules that govern the total overdraft count 
available per entitlement, and how much may be applied each time a license is activated.
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You specify the overdraft Maximum value as either unlimited, a specific number, a specific percentage, or you 
can choose to specify a number when you create an entitlement based upon this license model. After you specify 
the Maximum overdraft value, you are then prompted to specify a Floor and a Ceiling overdraft value:

The Maximum overdraft value is stored as a property of the item, and it restricts the total overdraft count that can 
be issued for that item. Any license activated for the item is validated such that the total overdraft issued remains 
at or below this maximum value.

Note • The sum of the Overdraft counts issued for every fulfillment against a line item must remain at or below 
the Maximum. This rule takes precedence over the Ceiling and Floor.

Example 1: Overdraft Maximum Applied to Fulfillments of an Entitlement
The Overdraft Maximum represents a limit on the total count of Overdraft that can be issued against each line 
item for this model.

Table 20-37 • 

Field Definition Options

Floor Use to define a per-fulfillment minimum 
overdraft, which is the overdraft count that 
must be issued for each license activated 
using this license model, subject to the 
overdraft Maximum value. The Floor value 
must be a non-negative integer. 

Note • If a license is activated such that 
applying the Floor would violate the overdraft 
Maximum value, then the Maximum value 
takes precedence (and therefore, the issued 
overdraft count may be less than the Floor 
value.) 

Choose one of the following options:

• Unlimited: There is no Floor value; a license 
may have zero overdraft.

• Specify now: The license model defines the 
Floor value for all licenses activated using this 
model.

• Specify now as percentage: The license model 
defines the Floor value as a percentage of the 
fulfillment count. The computed Floor value is 
rounded down (for example, 7.3 would be 
rounded down to 7).

Ceiling Use to define a per-fulfillment maximum 
overdraft, which is the overdraft count that 
must be issued for each license activated 
using this license model, subject to the 
overdraft Maximum value. The Ceiling value 
must be a non-negative integer.

If a license is activated such that applying 
the Maximum would violate the overdraft 
Ceiling value, then the Ceiling value takes 
precedence, and therefore, the issued 
overdraft count may be less than the 
Maximum value. 

Choose one of the following options:

• Unlimited: There is no ceiling.

• Specify now: The license model defines the 
Ceiling for all activations using this model.

• Specify now as percentage: The license model 
defines the Ceiling as a percentage of each 
activation count. The computed Ceiling is 
rounded up (for example, 7.3 would be 
rounded up to 8).
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The license model used in this example is:

The entitlement used in this example is:

The following table lists the results of four customer fulfillments of this entitlement:

Table 20-38 • License Model Example

Value Description

Maximum 10

Floor Unlimited

Ceiling Unlimited

Table 20-39 • Entitlement Example

Value Description

Count 15

Maximum 10 (From Model)

Floor Unconstrained

Ceiling Unconstrained

Table 20-40 • Customer Fulfillments

Request 
Number

Fulfillment 
Request Result

Entitlement 
Remaining

Beginning 
Count

Count = 15

Overdraft = 10

Request 1 Count = 5

Overdraft = 5

Request succeeds. Count = 10

Overdraft = 5

Request 2 Count = 3

Overdraft = 3

Request succeeds. Count = 7

Overdraft = 2

Request 3 Count = 5

Overdraft = 5

Request succeeds, but the returned amounts are Count = 
5, Overdraft = 2 because only 2 Overdrafts are available.

Count = 2

Overdraft = 0

Request 4 Count = 7, 
Overdraft = 0

Request returns an error, because the requested count 
cannot be satisfied. 

Count = 2

Overdraft = 0
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Note • Failure to satisfy the requested count is an error condition, whereas the requested overdraft is simply 
reduced to the amount available.

Example 2: Overdraft Floor and Ceiling Applied to Fulfillments of an Entitlement
The Overdraft Floor and Ceiling represent lower and upper limits on the total overdraft count that can be issued 
against each line item for this model. 

The license model used in this example is:

The entitlement used in this example is:

The following table lists the results of two customer fulfillments of this entitlement:

Table 20-41 • License Model Example

Value Description

Maximum 50%

Floor 5

Ceiling 25%

Table 20-42 • Entitlement Example

Value Description

Count 45

Maximum 45 x 50% = 22.5, which rounds to 23, the nearest whole number.

Floor 5

Ceiling 45 x 25% = 11.25, which rounds up to 12

Table 20-43 • Customer Fulfillment

Request
Number

Fulfillment 
Request Results

Entitlement 
Count 
Remaining

Beginning 
Count

Count = 45

Overdraft = 23

Request 1 Count = 12

Overdraft = 0

Request succeeds with Count = 12, but Overdraft is set to 
5, due to the Floor.

Count = 33

Overdraft = 18
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Example 3: Overdraft Floor and Ceiling Rounding Example
Each of the three Overdraft values (Maximum, Floor, and Ceiling) rounds differently when computed as a 
percentage:

• Maximum: Rounded to the nearest whole number. If the fractional part of the computed value is less than 
0.5, it rounds down; if it is greater than or equal to 0.5, it rounds up. For example, 3.25 rounds down to 3, 
while 3.6 rounds up to 4. 

• Floor: Rounded down to the previous whole number. For example, 3.75 rounds down to 3.

• Ceiling: Rounds up to the next whole number. For example, 3.25 rounds up to 4.

So, if the license model is:

The computed Maximum, Floor, and Ceiling overdraft values for this entitlement would be: 

Request 2 Count = 20

Overdraft = 15

Request succeeds with Count = 20, but Overdraft is set to 
12, due to the Ceiling.

Count = 13

Overdraft = 6

Table 20-44 • License Model Overdraft Values

Value Description

Maximum 50%

Floor 25%

Ceiling 25%

Table 20-45 • Entitlement Overdraft Values

Value Description

Count 15

Maximum 15 x 50% = 7.5, which rounds to 8, the nearest whole number.

Floor 15 x 25% = 3.75, which rounds down to 3.

Ceiling 15 x 25% = 3.75, which rounds up to 4.

Table 20-43 • Customer Fulfillment

Request
Number

Fulfillment 
Request Results

Entitlement 
Count 
Remaining
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About the License Expiration Grace Period 
As described in Grace Period Days, you can enable the Grace Period option to allow a FlexNet Embedded 
application to function, without interruption, after its license has expired. Granting a license expiration grace 
period enables a producer to detect that an end customer’s application is functioning in a grace period, and to 
notify the customer that it is time to renew to prevent disruption of their normal business work flow. 

The license expiration date is the expiration date that is entered and displayed in FlexNet Operations; for license 
models that support it, the grace period is the number of days beyond the license expiration date that an 
application continues to function. When the license is generated, FlexNet Operations uses the expiration date 
plus the grace period to set the entitlement expiration date (in other words, the grace expiration date)—the date 
on which the application stops functioning. For example, if the producer enters a grace period of 14 days for a 
license that expires on March 1st, then the entitlement expiration date is March 15th.

The grace period is configured by the producer at the license model, where the option can be turned on or off (the 
default value). It is supported on local and cloud license servers for metered and concurrent license models. 

Note • If a renewal entitlement is mapped before an application’s parent entitlement expires (to avoid an 
interruption of service), the grace period of the parent entitlement is suppressed to prevent creation of an extra 
entitlement during the grace period. 

Grace Period Handling in the Usage Analytics Service 
When an entitlement line item uses a license model that includes a grace period, notifications about that 
entitlement sent to UAS include the extended grace period in their end date. This ensures that reports accurately 
record any usage during the grace period. Currently, UAS does not highlight grace usage separately in its reports; 
that functionality is planned for a future release. 

Note • It is recommended that producers set the entitlement expiration date right after expiration to prevent gaps 
in usage tracking and enable usage statistics to carry over to the new entitlement. 

Predefined Substitution Variables for License Strings  
Variables can be used as values for supported license strings: VENDOR_STRING, NOTICE, ISSUER, and 
SERIAL_NUMBER. These variables are resolved when the license is generated.

To express a predefined substitution variable in a license string, on the Create a License Model page, specify the 
value of the string as the substitution variable enclosed in curly braces. For example, to use the Sold-to account 
ID use {SoldTo.name} or to use the Sold-to account name use {SoldTo.displayName}. 

Important • Predefined substitution variables can be used with custom license technologies provided the license 
technology implements the GeneratorRequest interface.
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The following substitution variables are defined:

Table 20-46 • Predefined Substitution Variables

Substitution Variable Definition

Sold-to account ID {SoldTo.name}

Sold-to account name {SoldTo.displayName} 

Ship-to address on an entitlement {Entitlement.shipToAddress} 

Order ID on an entitlement line item {EntitlementLineItem.orderId} 

Order line number on an entitlement line item (only for 
simple entitlements)

{EntitlementLineItem.orderLineNumber} 

Activation ID on an entitlement line item {EntitlementLineItem.activationId} 

Product name on an entitlement line item {EntitlementLineItem.productName}

Product version on an entitlement line item {EntitlementLineItem.productVersion}

Part number on an entitlement line item {EntitlementLineItem.partNumber} 

Fulfillment ID {Fulfillment.id} 

Entitlement ID {Entitlement.id}

Feature version {Feature.version}

This variable can only be used in the Vendor String 
field.

The format of the feature version specified using the 
{Feature.version} variable depends on its location:

• The Vendor String field outside of the FlexNet 
Publisher license lists all feature versions that 
are present in the product as comma-separated 
values.

• Inside the FlexNet Publisher license, each 
individual INCREMENT line displays the 
VENDOR_STRING keyword with its feature 
version.

Quantity configured on device {mappedQuantity}

This variable is applicable only to FlexNet Embedded 
licenses.
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Custom Attributes in License Strings  
In addition to explicitly specified strings and predefined substitution variables, a publisher can configure one or 
more custom attributes that can be expressed as the value of one of the four license strings: Issuer, Notice, Serial 
Number, and Vendor String. 

Note • Custom license model attributes are defined as part of the license technology and their use is governed, in 
part, by the way they are set up in the license model. For more information about creating custom license model 
attributes, see Adding Custom License Attributes. For more information about creating other types of custom 
attributes, see Adding Custom Attributes. 

To express a custom attribute in a license string, at the time the license model is created (on the Create a License 
Model page), specify the value of the attribute in the license string as the name of the attribute, with a prefix 
depending on the type of attribute, enclosed in curly braces.  

For example, to use the value of a license model attribute named CPU_CAPACITY in VENDOR_STRING: 

Vendor String | Specify Value Now | {CPU_CAPACITY} 

For example, to use the value of a product attribute named PRODUCT_FAMILY in NOTICE: 

Notice | Specify Value Now | {Product.PRODUCT_FAMILY} 

The name of the attribute as specified in the license string is case sensitive.

If any custom license model attributes have been configured on the license technology, they are displayed in the 
license model wizard in the Set Up Custom Attributes page that appears between the Create a License Model and 
Set Up Policies pages. The Set Up Custom Attributes page is used to select the time that the true value of the 
custom license model attribute is set (license model time, entitlement time, or fulfillment time). 

Other custom attributes are displayed when creating or editing instances of the entities they are defined on. 

Managing License Models 
License models can be managed on the License Model page. 

Table 20-47 • 

Custom Attribute Type Prefix

License Model (no prefix) 

Product Product. 

Line Item EntitlementLineItem. 

Entitlement Entitlement. 

Account SoldTo. 
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Task To open the License Model page

• Click Administer > License Models.

The License Model page automatically displays recently accessed license models, if applicable. To view all 
license models, select License Models from the Search For choice list, and click the Simple Search button. You 
can also search for license models based on specific criteria. 

Several sample license models are delivered with FlexNet Operations. 

From this page, you can

Creating a License Model
A license model defines licensing characteristics that determine how, when, and where a Flex-enabled product 
can be used. 

Tip • A license model can be created from scratch or by editing a copy of an existing license model. To start with 
a copy, select an existing license model on the License Models page and click Copy.

Table 20-48 • Managing License Models

Capability Description

Add a new license 
model from scratch

To add a new license model, click Create New License Model.

Make a new license 
model from a copy of an 
existing license model 

To copy a license model, select exactly one license model and click the Copy 
button. Follow the guidelines to add a new license model. 

Delete a license model To delete a license model, select one or more license models and click the 
Delete button.

Change the state of a 
license model 

To change the state of one or more license models, select the license models, 
click the Change State choice list, and select a state. License models can be in 
one of the following states: Draft, Deployed, Inactive, or Obsolete. 

• Draft: A license model is created and can be edited in the draft state. 

• Deployed: A license model must be deployed to be linked to a product. 

• Inactive: An inactive license model cannot be linked to a product or used to 
create an entitlement. Existing fulfillments using an inactive license model 
can be activated, returned, repaired, and rehosted. 

• Obsolete: An obsolete license model can be deleted.

Print a license model To print a license model, select one or more license models and click the Print 
button. 
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Task To create a license model

1. Click Administer > License Models. This link opens the License Models page.

2. Click Create New License Model. This button opens the Create a License Model page. 

3. If more than one license technology is defined, select the license technology for which this license model is 
valid. 

4. If the license model is for FlexNet Publisher Licensing Toolkit or for a custom license technology, follow these 
steps to define the license model. 

Note • Required fields are indicated with a red asterisk. 

5. Provide a name and a description for the license model, and specify the expiration setting. 

Table 20-49 • Identifying a New License Model

Value Description

Name Name to uniquely identify this license model: The name can contain spaces. 

Description Describe the characteristics of this license model that make it unique. The 
description can be changed after the license model is deployed. 

State A license model can be in one of four states: Draft, Deployed, Inactive, or 
Obsolete:

• Draft: A license model is created as a draft that can be modified or deleted. 

• Deployed: After a license model is deployed to use in production, it cannot 
be deleted or modified. Before a product can be deployed, its linked 
license models must be deployed (deploying a product does not deploy its 
linked license models). A draft license model can be linked to a deployed 
product or suite, but the license model cannot be used in an entitlement 
line item until it is deployed. 

• Inactive: An inactive license model cannot be deleted or modified. An 
inactive license model cannot be used to create an entitlement, but a 
product with an inactive license model on an existing entitlement line item 
can be activated. 

• Obsolete: Deployed and inactive license models can be made obsolete. 
Obsolete license models behave like inactive license models, but can be 
deleted. 
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6. Subsequent steps vary depending on whether you are creating a license model with FlexNet license 
technology or custom license technology: 

• If this is a license model for a custom license technology, configure any custom license model attributes 
and click Save to save the license model or click Next to configure policies on the license model. 

• If this is a FlexNet Publisher Licensing Toolkit or FlexNet Embedded license model, click Next to continue 
defining the license model. FlexNet Operations presents the license model settings as a dynamic set of 
decisions. (Additional information about these attributes is available in FlexNet Publisher Licensing 
Toolkit or FlexNet Embedded documentation.)

a. Is this an Embedded License Model?

b. Will this License Model be Sharable? (FNP toolkit) 

Expiration Should licenses activated using this license model be permanent or should they 
expire?

• None: If you choose None, you defer deciding if these licenses are 
permanent or expiring until the time you configure an entitlement line item.

• Permanent: If you choose Permanent, these licenses never expire.

• Expiring: If you choose Expiring, set a duration of n days, weeks, months, 
or years. 

Table 20-50 • 

Value Description

Yes Identifies the license model intended for devices that use the FlexNet 
Embedded toolkit. 

No Identifies the license model as one intended for software products that use 
the FlexNet Publisher toolkit.

Table 20-51 • 

Value Description

Yes A sharable, or floating license can be used by anyone on the network, up to 
the limit specified in the license. Floating licenses require a license server 
system to be running to count the concurrent usage of licenses. If a license 
is floating, it is most common for it to be counted, allowing only limited 
checkouts. 

No A license that is not sharable, sometimes known as node-locked, can be 
used only on one machine or a specified set of machines.

Table 20-49 • Identifying a New License Model

Value Description
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c. Is this a Counted Model? (FNE toolkit) 

d. Will this License Model allow Unlimited Checkouts? (FNP toolkit) 

e. Is this an Activatable License Model? 

f. Is this License Model Detachable? 

Table 20-52 • 

Value Description

Yes Counts the number of seats deployed to customers.  

No Provides unlimited copies.

Table 20-53 • 

Value Descriptiont

Yes (unlimited) An uncounted license allows unlimited concurrent usage. If a license is 
uncounted, it is most common for it to be nodelocked. The floating 
uncounted certificate license model in FlexNet Operations is implemented 
as a floating counted license with DUP_GROUP=SITE. 

No (limited) A counted license allows usage limited by the count in the license. If a 
certificate license is counted, it is most common for it to be floating. 
However, it is possible to have a nodelocked counted license. 

Table 20-54 • 

Is this license delivered into trusted storage or as a certificate?

Select Yes if license is 
delivered into trusted 
storage.

FlexNet Publisher Licensing Toolkit v11.x can activate trusted licenses. 

Trusted licenses are usually activated automatically and securely with an 
activation utility written by the publisher of the licensed software. 

Products linked with a trusted license model must also be associated with 
a transaction key.   

Select No if license is 
delivered as a 
certificate.

All versions of FlexNet Publisher Licensing Toolkit can generate certificate 
licenses that are emailed or otherwise delivered to a software customer. 

Table 20-55 • 

This license can be transferred among license servers. Is it also detachable to a client machine?

Yes (detachable) Only applicable to trusted license models. Licenses are floating and served 
from a license server, but they can also be removed from the floating group 
of licenses and be activated on an individual client machine. 
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g. Is this License Model for an End User or for an Enterprise? 

h. Is this a Metered Model? (FNE toolkit) 

i. Fill in the Attributes for this License Model. 

Depending on the decisions made above, sets of choices are presented. 

No (not detachable) Only applicable to trusted license models. Licenses are floating and only 
served from a license server. The licenses can be configured to allow them 
to be transferred between vendor daemons. 

Table 20-56 • 

Will this license be activated from FlexNet Operations by a retail client or by a license server in an 
enterprise environment?

End User An end-user license is sold to an individual retail user. Only applicable to 
trusted license models. 

Enterprise A volume license is sold to an enterprise user. Only applicable to trusted 
license models.

Table 20-57 • 

Value Description

Yes Designates the license model as a usage-based model. (Usage-based 
licensing is available to producers who use FlexNet Embedded and FlexNet 
Usage Management.)

No License does not use the usage management feature to track usage.

Table 20-58 • 

Choice Description

Allow Partial 
fulfillments 

If you select Yes, when you Activate Licenses for a customer, FlexNet 
Operations allow syou to activate a portion of the total amount entitled to 
that customer (that is, the total amount that they purchased). If you select 
No, you must activate the total amount in the single transaction. 

Table 20-55 • 

This license can be transferred among license servers. Is it also detachable to a client machine?
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Package Specification 
(for uncounted licenses)

Applicable to all uncounted certificate license models. 

Select None if this license model is to be associated with a product that is 
not defined as a package. 

Select Basic if this license model is used to provide a PACKAGE line as a 
compact, efficient way to distribute a large number of features that share 
most of their feature line arguments.

Package Specification 
(for certificate counted 
licenses)

Applicable to certificate counted licenses. 

• Select None if this license model is to be associated with a product 
that is not defined as a package. 

• Select Basic for the Package Specification if this license model to 
provide a PACKAGE line as a compact, efficient way to distribute a 
large number of features that share most of their feature line 
arguments. 

Select Suite if this license model: 

• Is to be associated with a product that is a package.

• Is counted.

• Allows a license to be shared among the components of the package 
using OPTIONS=SUITE on a PACKAGE line. Within a package suite, a 
license is shared by the components of the package rather than being 
applied to one specific feature.

Select Suite Reserved if this license model: 

• Is to be associated with a product that is a package. 

• Is counted. 

• Specifies Client Uniqueness, most as commonly User. 

• Allows a set of package components to be granted to a fixed number 
of users at any one time using OPTIONS=SUITE_RESERVED on a 
PACKAGE line. In addition, after a user checks out a license for one 
component, licenses for the other package components are reserved 
for that user. A set of package components remain reserved for the 
given user until all licenses for the set are checked back in.
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Package Specification 
(for trusted floating 
licenses)

Applicable to trusted floating (transferable and borrowable) licenses.

Select None if this license model is to be associated with a product that is 
not defined as a package. 

Select Suite Reserved if this license model: 

• Is to be associated with a product that is a package. 

• Is counted. 

• Specifies Client Uniqueness, most as commonly User. 

• Allows a set of package components to be granted to a fixed number 
of users at any one time using OPTIONS=SUITE_RESERVED on a 
PACKAGE line. In addition, after a user checks out a license for one 
component, licenses for the other package components are reserved 
for that user. A set of package components remain reserved for the 
given user until all licenses for the set are checked back in.

Client Uniqueness • Applicable to certificate counted licenses and trusted floating 
transferable and floating borrowable licenses. Also known as 
duplicate grouping. 

• Duplicate grouping allows a vendor-defined combination of users, 
hosts, and displays to be considered in the same group such that 
license requests from any member consumes only one license. Any 
combination of User, Host, Display, and Vendor can be selected. 

• If Vendor is selected, LM_A_CHECKOUT_DATA must be set and all 
requests with the same vendor-defined data use the same license. 
This is useful for sharing licenses among otherwise unrelated 
processes. 

• Setting Client Uniqueness for a package suite affects only its enabling 
feature line. It limits the total number of users of the package to the 
number of licenses, and allows the package to be shared among the 
users that have the suite checked out. Without Client Uniqueness 
constraints specified in the components of package suite, a floating 
license is shared among the components of the package regardless of 
the number of users. 

• Client Uniqueness must be specified to get suite reserved behavior.
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Terminal Server Usage Controls whether a licensed application can be run from a Terminal Server 
client. Choose from 

• Not Used—Prevents Terminal Server client access in the license 
model. This is the default setting for Terminal Server Usage.

• Specify Value Now—Permits Terminal Server client access (for one or 
many clients) in the license model.

• Specify Value at Entitlement Time—Allows Terminal Server Usage to 
be set during entitlement.

• Specify Value at Fulfillment Time—Allows Terminal Server Usage to be 
set when the license is fulfilled.

To permit access from one Terminal Server client (one session), choose 
One Connection Allowed. This adds the ONE_TS_OK keyword to the feature 
line. This setting only applies to Flex-enabled applications built with 
FlexNet Publisher Licensing Toolkit version 11.5 or later.

To permit access from multiple clients (multiple sessions), choose Many 
Connections Allowed. This adds the TS_OK keyword to the feature line. This 
setting only applies to Flex-enabled applications built with FlexNet 
Publisher Licensing Toolkit version 8.0 or later. 

To prevent access from Terminal Server clients, choose Not Used. 

Applications built with versions of FlexNet Publisher Licensing Toolkit prior 
to version 8.0 do not support this license model feature (and thus may 
always run using Terminal Server). Therefore, in licenses for applications 
built with version 8.0 or earlier FlexNet Publisher Licensing Toolkit set 
Terminal Server Usage to Not Used. Similarly, applications built with a 
version of FlexNet Publisher prior to 11.5 do not support the One 
Connection Allowed setting.

These settings apply to applications using a nodelocked uncounted, retail 
activation, or enterprise activation license. FlexNet Publisher Licensing 
Toolkit detects when a nodelocked uncounted license is running under 
Windows Terminal Server.

To allow your Flex-enabled application to run using a Terminal Server 
client, nodelock the license to the Terminal Server.
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Choice Description



Chapter 20 Performing Administrative Tasks
Administering License Models

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 811

FLEXid Sharing This property, which is applicable to nodelocked uncounted licenses, 
enables mobile licensing using a FLEXid with FLOAT_OK for a particular 
feature line.

This feature line must be nodelocked to a FLEXid (a dongle that connects 
to a parallel or USB port). 

One feature line containing the FLOAT_OK keyword and one FLEXid is 
needed for each instance of a license that can be mobile. 

When the FLEXid is attached to a license server, the license floats on the 
network. When the FLEXid is removed from the license server, the license 
is available only on the standalone computer with the FLEXid attached.

This property is supported only on Windows machines.

If a license is to be moved between different Windows machines, it is 
nodelocked to a FLEXid. To move a license to a different machine, the 
dongle must be moved to that machine.

Select one of the following options:

• Not Used: Select to disallow mobile licensing. 

• Allow: Select to allow mobile licensing using a FLEXid with the 
FLOAT_OK keyword (without a server_hostid). The FLOAT_OK keyword 
is generated for each FEATURE line in the license file. The nodelocked 
host ID given at fulfillment time lists the FLEXid to which the license 
should be attached.

• Specify Value At Entitlement Time: Select to prompt the user at 
entitlement time to specify if mobile licensing is allowed. At that time, 
the user would enter the host ID of the license server machine to 
which the FLEXid (specified as the nodelocked host ID) can be 
attached to allow this license to float.

• Specify Value At Fulfillment Time: Select to prompt the user at 
fulfillment time to specify if mobile licensing is allowed. At that time, 
the user would enter the host ID of the license server machine to 
which the FLEXid (specified as the nodelocked host ID) can be 
attached to allow this license to float.
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FLEXid Sharing 
(continued)

When generating a license, specify a FLEXid as the Nodelocked Hostid and 
the server host ID for FLEXid Sharing. A SERVER line is added to the 
generated license certificate and:

• The server_hostid is the same host ID that appears on the SERVER line 
of the license file, or could be a different host ID that refers to the 
same machine. If the SERVER line host ID is ANY, the FLOAT_OK 
server_hostid must be specific to the license server machine.

• The license server can only be run on the machine with the host ID that 
lmhostid returns equal to the server_hostid specified with FLOAT_OK.

• A user can run on the license server machine, but he can use only the 
license being served by the license server, not the nodelocked license. 
Otherwise an extra use for each FLOAT_OK license could occur. Note 
that without the server_hostid specified on the feature line, the 
FLOAT_OK license can be served from any computer, as long as the 
FLEXid is attached to it.

• The host ID on the FLOAT_OK feature line must be only a single host ID. 
For multiple FLEXids, use individual feature lines for each FLEXid. 
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Time Zone Controls whether or not licensing is limited to specified regions (expressed 
as time zones). Choose from

• Not Used—Licenses are not restricted by time zone. This is the default 
setting for Time Zone.

• Specify Value Now—Limits licenses to publisher-defined time zone 
values in the license model. 

• Specify Value at Entitlement Time—Allows Time Zone limitations to be 
set during entitlement.

• Specify Value at Fulfillment Time—Allows Time Zone limitations to be 
set when the license is fulfilled.

To limit usage based on time zone, choose a time zone value from the list. 
Time zone values must be defined by the publisher. For details, see 
Working with Time Zones.

To limit usage to machines running in the same time zone as the license 
server machine (served licenses only), choose Server Time Zone Only. 

To ignore time zones for licensing purposes, choose Not Used.

Time zone-based licensing is supported for licenses generated by FlexNet 
Publisher version 11.7 or later, and applies to the following certificate-
based licenses: floating counted, floating uncounted, and nodelocked 
counted. 

Time zone-based licensing is not available for nodelocked uncounted 
license models (because limiting licenses based on their geographic 
location is not required if an unlimited number of licenses is available). In 
this case, the Time Zone setting will be blank.

The special Time Zone setting, Server Time Zone Only, is not applicable to 
licenses that do not include a SERVER line nor to nodelocked uncounted 
licenses, generally.
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Virtualization 
Restrictions

Controls whether or not licensed applications are restricted to running only 
on physical machines or only on virtual machines. Choose from 

• Not Used—Permits usage on physical and virtual machines the license 
model: no restrictions. This is the default setting for Virtualization 
Restrictions.

• Specify Value Now—Restricts licensed applications to running, either 
on physical machines or on virtual machines, in the license model.

• Specify Value at Entitlement Time—Allows Virtualization Restrictions 
to be set during entitlement.

• Specify Value at Fulfillment Time—Allows Virtualization Restrictions to 
be set when the license is fulfilled.

To limit usage to physical machines only, choose Restrict to Physical 
Machines. This adds VM_PLATFORMS=PHYSICAL to the feature line.

To limit usage to virtual machines only, choose Restrict to Virtual 
Machines. This adds VM_PLATFORMS=VM_ONLY to the feature line.

To operate without restrictions, choose Not Used. 

Virtualization Restrictions are supported for licenses generated by FlexNet 
Publisher version 11.7 or later, and apply to certificate license models: 
floating counted, floating uncounted, nodelocked counted, and 
nodelocked uncounted.

Borrowing Applicable to counted, certificate licenses. To disable borrowing, select 
Not Used. If any other setting is selected, license borrowing is enabled. 

If borrowing is allowed, the maximum number of hours that the license can 
be borrowed for can be specified as the default (168 hours, or one week) 
or can be specified in the license model, during entitlement, or during 
fulfillment. 

The maximum borrow period is limited by the maximum value of a 32-bit 
integer: 2 billion hours. 

Renew Interval How often—if ever—the client attempts to re-contact the local license 
server. Successful contact extends the server-imposed expiration based on 
the borrow period. When using a finite borrow period, for maximum 
effectiveness, the renew interval should be set such that the client 
attempts renewal at least two times per borrow interval. It is set as a 
percentage of the borrow interval in the license model. 

Note • Renew interval is not enforced; it is for the publisher's convenience 
to use as they want.
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Unique Users and Hosts Applicable to certificate counted licenses and trusted floating transferrable 
and floating borrowable licenses. Sets the number of users (User Based) or 
host names (Host Based) that can be specified in INCLUDE statements in 
the end-user options file. 

• Select Not Used if you do not want to include the USER_BASED or 
HOST_BASED keyword.

• Select Use Default Value to use the full license count. 

• Select Specify Value Now to specify the number of users or host 
names in the license model. 

• Select Specify Value At Entitlement Time or Specify Value At 
Fulfillment Time to specify the number of users or host names later.

Reusable Applicable to metered (usage-based) license models, Reusable specifies 
whether the usage counts can be increased and decreased by the usage 
client or only increased. Choose either Yes or No. 

• Yes: Usage counts can be increased when counts are consumed and 
decreased if a feature checkout is canceled or reversed. 

• No: Usage counts can only increase (with possible exceptions 
expressed in the Undo Interval). 

Undo Interval Applicable to metered (usage-based) license models, Undo Interval defines 
a window in which feature checkouts can be canceled even if Reusable is 
set to No. Choose from Not Used, Specify Value Now, and Specify Value at 
Entitlement Time. 

• Select Not Used if Reusable is set to Yes or if Reusable is set to No and 
you do not want to permit counts to be decreased.

• Select Specify Value Now to set the length of time after feature 
checkout when the checkout can be canceled and the usage count 
reverted. Specify a number of seconds, minutes, hours, days, or 
weeks.

• Select Specify Value At Entitlement Time to allow or require the Undo 
Interval setting later.
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Overdraft  Select the Overdraft option to allow, for example, a specified number of 
users to run the software package during peak usage times even after the 
application’s license limit has been reached. 

Usage above the license limit is reported by the FlexNet Manager reporting 
tool, expressed using the OVERDRAFT license keyword. By viewing this 
report on actual usage, you can accurately determine your account’s 
license requirements, and purchase any additional licenses that are 
needed. The Overdraft option is applicable to both certificate and trusted 
counted licenses.

Overdraft is specified as a Maximum value per entitlement line item with 
Floor and Ceiling values per fulfillment against that line item. From the 
Maximum list, select one of the following:

• Not Used: Select if you want to disable Overdraft support. 

• Unlimited: Select if you want to allow unlimited overdrafts. You are 
then prompted to specify a Floor and Ceiling value. (For metered 
license models, Unlimited does not require Floor/Ceiling values.)

• Specify # now: Select if you want to specify a number value for the 
overdraft maximum. After your selection, enter a number in the box to 
specify the overdraft maximum for a line item. For non-metered 
models, you are then prompted to specify a Floor and Ceiling value.

• Specify % now: Select if you want to specify a percentage value for the 
overdraft maximum. The percentage is applied to the entitlement line 
item count to compute the overdraft maximum for a line item. The 
computed value is rounded to the nearest whole number (4.2 would 
be rounded to 4, while 4.8 would be rounded to 5). After your 
selection, enter a percentage value in the box. For non-metered 
models, you are then prompted to specify a Floor and Ceiling value. 
Overdraft licenses are allocated as a percentage of each fulfillment 
count. 

• Specify # at Entitlement Time: Select if you want to specify the 
number value for the overdraft maximum at the time of entitlement. 
For non-metered models, you are then prompted to specify a Floor 
and Ceiling value. For metered models, designate whether or not the 
Overdraft value is required at entitlement time.

If the decision to set the maximum overdraft is deferred until entitlement 
time (FlexNet Operations user interface or Web services), only an absolute 
number can be set, not a percentage. 

See About Overdraft Support for more information.
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Grace Period Days Select the Grace Period Days option to enable a FlexNet Embedded 
application to function for a specified number of days, without 
interruption, after its license has expired. 

Choose from 

• Not Used: Grace period is not used for this license model (default). 

• Specify Value Now: Specify the grace period, in number of days, for 
this license model. 

• Specify Value At Entitlement Time: To defer the decision about grace 
period. Users must choose whether or not to add a grace period when 
they are creating entitlements based on this license model. 

• Select the Required check box if the user must add a grace 
period. 

See About the License Expiration Grace Period for more information. 

Auto Provision For producers who use FlexNet Cloud Licensing Service, FlexNet 
Operations can automatically generate a Cloud Licensing Service license 
server for new customer accounts and automatically map new 
entitlements to an existing Cloud Licensing Service license server for 
existing customer accounts. 

Choose from 

• No: To manually create license servers for entitlements based on this 
license model.

• Yes: To permit the automatic creation of Cloud Licensing Service 
license servers. 

• Specify Value at Entitlement Time: To defer the decision about auto-
provisioning. Users must choose whether or not to use auto-
provisioning when they are creating entitlements based on this license 
model. 

Note • The following limitations exist for auto-provisioned license servers 
that have entitlements mapped for metered features:

• License servers cannot be moved to another account.
• You cannot remove licenses using Licenses > Remove Licenses.
• License servers can be made obsolete, which will remove all licenses 

mapped to the server. However, this is not recommended, because 
future line items will not be mapped automatically to the auto-
provisioned license server. 
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Issuer Issuer of the license: Applicable to all license models. 

Select Not Used if you do not want to include the ISSUER keyword, or select 
Specify Value Now to set the value of ISSUER in the license model. 

Select Specify Value At Entitlement Time or Specify Value At Fulfillment 
Time to specify the ISSUER value later. 

In addition to accepting an explicitly specified string, this field can accept, 
enclosed in curly braces, one of several pre-defined substitution variables 
or the name of a custom attribute. 

Serial Number Serial number used to identify feature lines: Applicable to all license 
models. 

Select Not Used if you do not want to include the SN keyword, or select 
Specify Value Now to set the value of SN in the license model. 

Select Specify Value At Entitlement Time or Specify Value At Fulfillment 
Time to specify the SN value later.

In addition to accepting an explicitly specified string, this field can accept, 
enclosed in curly braces, one of several pre-defined substitution variables 
or the name of a custom attribute. 

Vendor String Vendor string used to identify feature lines: Applicable to all license 
models. 

Select Not Used if you do not want to include the VENDOR_STRING 
keyword, or select Specify Value Now to specify the value of the 
VENDOR_STRING in the license model. 

Select Specify Value At Entitlement Time or Specify Value At Fulfillment 
Time to specify the VENDOR_STRING value later.

In addition to accepting an explicitly specified string, this field can accept, 
enclosed in curly braces, one of several pre-defined substitution variables 
or the name of a custom attribute. 

Notice Notice string used to identify feature lines: Applicable to all license models. 

Select Not Used if you do not want to include the NOTICE keyword, or 
select Specify Value Now to specify the value of the NOTICE in the license 
model. 

Select Specify Value at Entitlement Time or Specify Value at Fulfillment 
Time to specify the NOTICE value later. 

In addition to accepting an explicitly specified string, this field can accept, 
enclosed in curly braces, one of several pre-defined substitution variables 
or the name of a custom attribute. 
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USE SERVER Applicable only to certificate licenses. 

USE_SERVER takes no arguments and has no impact on the server. When 
the application sees USE_SERVER, it ignores everything in the license file 
except preceding SERVER lines and transfers checkout validation to the 
vendor daemon.

For uncounted features, USE_SERVER is used to force logging of usage by 
the daemons. 

You can specify to use or not use USE_SERVER in the license model, or 
specify whether to use it at the time of entitlement or fulfillment.

Platforms Applicable to all license models. Usage is limited to the selected platforms. 

Select No Platform Restrictions if you do not want to specify any platform 
restrictions. 

Select Specify Value Now to specify the allowed platforms in the license 
model. 

Select Specify Value At Entitlement Time or Specify Value At Fulfillment 
Time to specify the allowed platforms later. 

The platforms are selected with check boxes. They are expressed in a 
license using the PLATFORMS keyword. 
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7. Complete the license model creation process by clicking Save, Complete, or Next:

• Click Save to save the license model and remain on the current page. 

• Click Complete to save the license model and return the License Model page.

• Click Next to save the license model settings and continue by setting up custom license model attributes 
(if any have been created) or setting policies for the current license model. (See Setting Up Custom 
License Model Attributes and Setting License Model Policies.)

Client Repair Count % Applicable only to Floating Borrowable and Enterprise Activation license 
models. 

A fulfillment record of a vendor daemon contains a fulfill count and a repair 
count. The fulfill count indicates how many client activations the vendor 
daemon can perform and the repair count indicates the number of repairs 
of those client activations the vendor daemon can perform. After the repair 
count has been used, no more repairs can ever be done against that 
vendor daemon fulfillment record. 

FlexNet Operations license model policies affect only direct transactions 
between FlexNet Operations and a requesting vendor daemon or client 
application; they do not affect transactions between a vendor daemon and 
its clients. Therefore, a parameter has been added to license models to 
restrict the number of repairs that a vendor daemon can perform on 
activations from one of its fulfillment records. 

When a vendor daemon makes an activation request to FlexNet Operations, 
it can request a fulfill count and a repair count against that fulfill count. The 
Client Repair Count % is applied to the requested fulfill count and 
compared to the requested repair count: the minimum of the two values is 
returned to the vendor daemon as the repair count on the fulfillment 
record. 

For example:

• A vendor daemon requests a fulfill amount of 100 and a repair count 
of 20. Client Repair Count % is 100%. FlexNet Operations returns a 
repair count of 20.

• A vendor daemon requests a fulfill amount of 100 and a repair count 
of 200. Client Repair Count % is 100%. FlexNet Operations returns a 
repair count of 100. 

• A vendor daemon requests a fulfill amount of 100 and a repair count 
of 100. Client Repair Count % is 0%. FlexNet Operations returns a 
repair count of 0.

Max Transfers Applicable only to trusted models. If a license is bound to a license server, 
this is the number of transfers of a license allowed between vendor 
daemons.
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After creating a license model, you can continue creating more license models, or start creating features, feature 
bundles, or products. 

Note • After a license model has been saved, the history of its state change can be viewed by clicking the View 
History button. 

Copying a License Model 
A license model can be copied on the License Model page. Typically, you copy a license model as a shortcut in the 
license model creation process. Rather than adding a license model and manually specifying all the license 
model’s settings, you can copy an existing license model that most closely matches the new license model and 
rename and customize the copy.

Task To copy an existing license model

1. Click Administer > License Models. This link opens the License Model page.

2. Locate the license model to copy, and click Copy. This button opens the Create a License Model page. 

3. Provide a name for the copied license model and change license model settings as necessary. (For 
information about particular license model settings, see Creating a License Model.)

Deleting a License Model 
A license model can be deleted from the License Models page. Deleting a license model removes it from FlexNet 
Operations. You cannot delete deployed license models. Only draft license models and obsolete license models 
can be deleted.

Task To delete a license model

1. Click Administer > License Models. This link opens the License Models page.

2. Locate the license model to delete, and click Delete. 

3. Confirm your choice by clicking OK.

The Producer Portal removes the license model and refreshes the License Models page. 

Deploying a License Model 
A license model can be deployed on the License Model page. Deploying a license model makes it active for 
linking to products and suites. You deploy a license model by changing its state from Draft to Deployed.
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Task To deploy a license model

1. Click Administer > License Models. This link opens the License Models page.

2. Locate the license model to deploy, and click Change State > Deploy. 

3. Confirm your choice by clicking OK. 

The License Models page refreshes to show the new state for the license model you changed.

Printing a License Model 
Details about a license model can be printed on the License Model page. 

Task To print a license model

1. Click Administer > License Models. This link opens the License Models page.

2. Locate the license model to print, and click Print.

The Print button starts the print process. The exact behavior varies slightly depending on your browser and 
operating system.

Exporting License Models 
License models can be exported on the License Model page. Exporting a license model creates a file that can 
then be imported into a different instance of FlexNet Operations or modified by a separate program. The Export 
button provides option to create traditional (.jar) export files of all license models or selected license models, with 
or without their dependencies. For more information, see Importing and Exporting Entities. 

Task To export license models

1. Click Administer > License Models. This link opens the License Models page.

2. Locate the license models to export, and click Export, and then choose from the following export options: 

• Selected Items

• Selected Items with their Dependencies

• All Items

• All Items with their Dependencies

The Producer Portal downloads the export file according to the export option you chose. (The exact behavior 
depends on the browser and operating system you are using.)
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Employing a Predefined Substitution Variable 
The following instructions describe how to use a substitution variable for a license model attribute that 
corresponds to a supported license string. 

Task To employ a predefined substitution variable in the license model

1. On the Create a License Model page, locate the license model attribute for which you want to use a 
predefined substitution variable. 

2. For the license model attribute, choose Specify Value Now.

3. In the field provided, enter the substitution variable you want to use. For example, {SoldTo.displayName}. 
(See Predefined Substitution Variables for License Strings for a listing of available substitution variables.)

4. Click Save.

Note • The license model attributes for license strings can also take custom attributes as substitution variables. 
See Custom Attributes in License Strings.

Setting Up Custom License Model Attributes  
After setting license model attributes on the Create a License Model page, producers can set the custom license 
model attributes on the Set Up Custom Attributes page. The Producer Portal shows this page when you click Next 
on the Create a License Model page.

The custom attributes available on the Set Up Custom Attributes page depend on the custom license model 
attributes that have been defined for the license model’s license technology. (See Managing Custom License 
Attributes for more information.)

Task To set up custom license model attributes

1. On the Create a License Model page, click Next. This button opens the Set Up Custom Attributes page.

2. For each custom license model attribute, choose whether to use it in the license model, and the entitlements 
and licenses that use the license model. 

• If the custom license model attribute is used, set the time at which its value is to be specified. Choose 
from

• Specify Value Now

• Specify Value at Entitlement Time

• Specify Value at Fulfillment Time.

• If the custom license model attribute is not used, set it to Not Used.

3. Complete setting up custom license model attributes by clicking Save, Complete, or Next.

• Click Save to save your custom attribute settings and remain on the current page.
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• Click Complete to save your custom attribute settings and return to the License Model page. 

• Click Next to save your custom attribute settings and proceed to the Set Up Policies page. (See Setting 
License Model Policies for more information.)

Setting License Model Policies  
Policies allowed by a license model are configured after the license model attributes are defined. These settings 
affect all entitlement line items using the license model, and they are applied to activation both from the 
Producer Portal and from the End-User Portal. 

All of these policies are applied per entitlement line item. For activations done with a Web register key, policies 
are applied per the entitlement line item in the simple entitlement created when the Web register key is 
redeemed. 

Table 20-59 • License Model Policies

Policy Description

Number of Rehosts The number of times a customer can rehost a license generated from a particular 
entitlement item. 

Number of Returns The number of times a customer can return a license generated from a particular 
entitlement item. 

Number of Repairs The number of times a customer can repair a license generated from a particular 
entitlement item. 

Number of Extra 
Activations 

The number of extra activations allowed for an entitlement line item. This is the 
additional number of unpurchased copies of a product the customer is allowed to 
activate.

Cancel License Policy If Yes, on a return, a returned license is credited back to entitlements.
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Virtualization Policy For trusted or embedded license models, determine whether to allow activations on 
virtual machines. This policy can be set or reset at the license model level or at the 
entitlement level. Selections are:

• Specify Value Now, then click Yes or No 

• Specify Value at Entitlement Time 

If an activation request comes from a virtual machine, FlexNet Operations evaluates 
the product’s virtualization policy. When virtual machine activations are allowed, 
FlexNet Operations attempts to use the product’s virtualization-aware transaction key 
to configure trusted storage. (If no virtualization-aware transaction key exists, FlexNet 
Operations reports an error.) When virtual machine activations are not allowed, the 
activation fails. 

If an activation request comes from a physical machine, the virtualization policy is not 
evaluated at activation time.

The virtualization policy is supported for licenses generated by FlexNet Publisher 
version 11.10 or later.

For trusted license models, if virtual machine activations are allowed, determine 
whether to deny license repair if the virtual machine’s ACPI Generation ID (UMN5) is 
changed. This policy can be set or reset at the license model level or at the 
entitlement level. Selections are:

• Specify Value Now, then click Yes or No 

• Specify Value at Entitlement Time 

By default, this is set to Specify Value Now/Yes. Repair requests from physical 
machines are not impacted.

The repair policy is supported for virtual machine licenses generated by FlexNet 
Publisher version 11.12.1 or later. 

Redundant Server 
Policy

Redundant servers are supported with certificate-based licensing only for floating 
counted, floating uncounted, and nodelocked counted license models.

Do you want to configure redundant servers?

• Yes—The license model supports three-server redundancy for failover support. 
This is a capability available with certificate-based licenses. When you activate 
the license, you define the three-server host IDs that are a part of this 
configuration. For more information about three-server redundancy, see the 
FlexNet Publisher Licensing Toolkit documentation.

• No—The license model does NOT support three-server redundancy.

Table 20-59 • License Model Policies

Policy Description
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Number of Reinstalls If a customer has reinstalled a host’s operating system (for example, due to a system 
crash), the trusted storage on the host is lost. Activation must be reconfigured. In this 
case, you can choose to allow the customer to obtain a license without consuming the 
entitlement count.

FlexNet Operations determines whether a user is reconfiguring activation for a 
specific host using host identifiers like UMN Types 1, 2, 3, and 5 and MID (Machine 
Identifier).

FlexNet Operations tries to match the host using host identifiers according to the FNP 
client version and host identifiers sent in the request. (Not all activation requests 
contain the FNP client version or all of the host identifiers.) If the FNP client version is 
not sent in the request, the order the host identifiers are checked is UMN1, MID, then 
UMN2. For FlexNet Operations to correctly handle requests from a range of FNP client 
versions, UMN values are checked from UMN1 to newer UMN versions, and lastly MID 
is checked.

• You can choose to enforce the same policy for any host identifier received. To 
configure this, click Specify Value Now and provide a value. 

• If you want to specify different policies for each host identifier, click Specify Value 
Now and select Advanced. Then specify the policy for each host identifier.

• If you want FlexNet Operations to always provide the license to the user without 
decrementing count for a reinstall operation, and not enforce any policy, then 
select Ignore Policy.

Note • Depending on the machine that issued the request, FlexNet Operations may 
not receive all identifiers in a given activation request. Refer to the FlexNet Publisher 
Licensing Toolkit documentation for more information on host identifiers.

Table 20-59 • License Model Policies

Policy Description



Chapter 20 Performing Administrative Tasks
Administering License Models

FlexNet Operations User Guide FNO-2021R1-UGOP02 Company Confidential 827

Note • If users who have override policy permission log in, all host types are displayed to them, regardless of the 
policy settings, as they can choose to generate licenses for host types not allowed by policy.

Host ID Policies for 
Producer Portal

A host ID is an identifier used to uniquely identify a specific machine. A host ID policy 
is a rule that defines what type of information about the system is used to identify the 
machine. Example host ID types are host name, IP address, disk serial number, etc. 
This policy allows you to specify which host ID types (for example, the host name and 
IP address) are available when activating a license.

When you activate a license, you can define a server host ID to ensure the license is 
used on only on a specific license server. In addition, you can define a nodelocked 
host ID that allows only a specific client (or user) to check out the feature and run your 
application.

The policies in this section affect activations performed using the Producer Portal. 
These settings do not apply to activations performed in the End-User Portal. See Host 
ID Policies for Portal UI to separately configure host ID policies in the End-User Portal.

There are two policies for you to define: 

• Server Host ID Policies—This policy helps publishers restrict host ID types for 
server hosts.

• Nodelocked Host ID Policies—This policy helps publishers restrict host ID types 
for nodelocked hosts.

For each policy, select a value: 

• Specify Value Now—Define the list of valid host ID types for this license model. All 
licenses generated using this license model can use only these host ID types.

• Specify Value at Entitlement Time—Host ID types must be specified at 
entitlement time. This gives the publisher flexibility to specify different host ID 
types for different entitlements.

• Ignore Policy—Any host ID type can be used.

Notice that host ID types are grouped into families related to their platform/
environment: legacy, virtualization-aware (prefixed with PHY, VM, VMW, HPV, or LMB), 
and cloud-specific (prefixed with AMZN). For more information about the host ID type 
options displayed, see Special Host ID Types.

Host ID Policies for 
Portal UI

Publishers can restrict host ID types used during license generation from the End-
User Portal using this policy. Refer to Host ID Policies for Producer Portal for 
information on policy settings. Also see Special Host ID Types for details about the 
host ID type options displayed.

Table 20-59 • License Model Policies

Policy Description
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Working with Time Zones
Time zone functionality enables publishers to bind license usage to a specified geographic location by identifying 
the time zone of that region. This makes it possible for the publisher to vary license model pricing based on the 
geographic location in which the software is used.

At run time, when a license checkout is requested, the time and time zone of the client machine is read and 
compared to the time zone specified in the license file. If the time zone read from the client machine matches the 
time zone in the license file, the checkout proceeds as usual. If, however, there is a mismatch between the time 
zone read from the client machine and the time zone specified in the license file, the checkout request is denied.

The time zone is expressed in a license file using the TZ keyword to define a region within which license usage is 
permitted. The SERVERTZ time zone setting is preloaded in FlexNet Operations and binds served license usage to 
the time zone of the license server. However, before Producer Portal users can select any other time zone 
settings for a license model (served or nodelocked certificate licenses only), those settings must be configured 
by manually adding rows to the FlexNet Operations database table, PROD_FNP_TIMEZONE. For information about 
adding time zones and supported license models,  see the FlexNet Operations On-Premises Installation & 
Implementation Guide. In the Producer Portal, time zone settings are displayed in a single-select drop-down list.

Important • Time zone licensing is intended for use with customers with whom you have a trusted relationship. 
There is no secure programmatic restriction with time zone licensing functionality: If an end user manually 
changes the time zone to match the time zone specified in the license certificate, a license can be consumed.

Supported License Types
Time zone-based licensing is supported for licenses used by applications built with FlexNet Publisher version 
11.7 or later, and applies to the following certificate-based licenses: floating counted, floating uncounted, and 
nodelocked counted. Licenses that contain the TZ keyword must be generated by a version 12.7 Vendor 
Certificate Generator (VCG) that has its version configured as 12.7 in its license generator configuration. 

Time zone-based licensing is not available for nodelocked uncounted licenses (because limiting licenses based 
on their geographic location is not required if an unlimited number of licenses is available).

FlexNet Publisher supports a time zone range from GMT -12:00 to GMT +12:00 (or GMT -12:00 to GMT +14:00 if 
using FlexNet Publisher 11.15.1 or later).

Administering Device and License Server Setup
Producers who use FlexNet Embedded licensing can manage their device series, device model, and server host 
types using the Administer menu. 

The topics, below, describe FlexNet Embedded licensing administration concepts and tasks.

Table 20-60 • 

Topic Description

About Device and 
License Server Setup

Discusses the device series, device model, and server host type concepts and the 
administration of these elements as well as publishers and identities.
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About Device and License Server Setup 
Device and license server setup includes the management of publishers, publisher identities, device series, 
device models, and server host types. For producers who use FlexNet Embedded licensing to manage features 
and entitlements for intelligent devices, the foundation for devices and license servers that can be created are 
the device series, device model, and server host type.  

Managing Publisher 
Identities

Describes how to create publishers and publisher identities, and how to download 
identity files from the Producer Portal. 

Managing Device Series Covers listing, adding, and editing device series.

Managing Device 
Models

Covers searching, viewing, creating, and editing device models. 

Managing Server Host 
Types

Covers listing, creating, and editing server host types. 

Viewing Request 
History

Describes how to use the Request History link in the Administer menu to view 
request history records based on date-time or request ID criteria.

Monitoring the FlexNet 
Embedded Back Office

Lists exposed FlexNet Embedded back office endpoints for customers who want to 
verify that it is responding as expected.

Table 20-61 • 

Topic Description

About Device Series and 
Device Models

Discusses the role of device series and device models for producers who use 
FlexNet Embedded licensing.

About Server Host Types Discusses the role of server host types for FlexNet Embedded license servers.

Device Series Attributes Describes the attributes of device series.

Device Model Attributes Describes the attributes of device models.

Server Host Type 
Attributes

Describes the attributes of server host types.

About Publishers and 
Publisher Identities

Discusses the role of publishers and publisher identities for FlexNet Embedded 
devices and license servers.

Table 20-60 • 

Topic Description
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About Device Series and Device Models 
To understand the basic concepts of using FlexNet Embedded licensing in FlexNet Operations, use the following 
example use case where Acme Networks, Inc. is a manufacturer that has created a series of VPN devices that 
includes three device models.

Figure 20-3: Device Series and Device Models

• Device Series—A collection of device models that are physically identical but upgradable in the field through 
license changes and additional capabilities. In the figure, above, VPN 5000 is an example of a device series. 

A device series sets the maximum limits for device capabilities and capacities. In this example, all device 
models within the VPN 5000 device series can have

• No more than 10,000 simultaneous users 

• No more than 100 Mbps of throughput

• Redundancy enabled or disabled

• Device Model—A basic model for a device that manufacturers use to create a pre-installed license. A pre-
installed license defines a set of capabilities within the maximum limits for the device series. The device 
model with that particular pre-installed license represents a purchasable configuration for a device. In the 
figure, above, VPN 5005, VPN 5020, and VPN 5050 are all device models and part of the VPN 5000 device 
series. They each define and represent a different set of basic capabilities.

In this example, the VPN 5050 device model includes

• 5,000 simultaneous users

• 50 Mbps of throughput

• Redundancy Enabled
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• Additional Product—A product you create to represent a license change that grants additional capabilities 
for a device. In this example, an additional product might include 1,000 simultaneous users and 10 Mbps of 
throughput.

About Server Host Types 
A server host type works with servers like a device model works with devices; it establishes a default identity and 
a default host ID type for servers created based on the server host type. 

Producer Portal users have a predefined server host type: FLX_SERVER. FLX_SERVER facilitates the creation of 
servers without the need for new users to define their own server host types, and is associated, by default, with 
the first identity that the producer creates. Although FLX_SERVER is initially designated as the default server host 
type, Producer Portal users can later designate any server host type as the default.

Device Series Attributes 
Device series include the following attributes.

Device series can have a number of capabilities as well. Any capabilities added to the device series express the 
maximum capabilities and capacities for devices based on the device series.

Device Model Attributes 
Device models include the following attributes.

Table 20-62 • 

Attribute Description

Name A unique value per producer.

Notes A short description for the device series.

Alias An optional, alternate name for the device series.

Table 20-63 • 

Attribute Description

Model Name Model Name must be unique per producer.

Description An optional description for the device model.

Alias An optional, alternative descriptive name for the device model.

Default Host ID Type Default Host ID Type specifies a host ID type for devices based on this device 
model. Default Host ID Type is used whenever a device of this model is 
created without specifying a host ID Type.
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Server Host Type Attributes 
Server host type attributes are similar to device model attributes. These attributes are used when searching, 
adding, and editing server host types.

License Format The storage format for the pre-installed license and additional capabilities.

• Pre-installed license in file, additional licenses in trusted storage—Any 
features in the pre-installed product are expressed in a license file while 
any additional products applied to the device are expressed in trusted 
storage.

• Pre-installed license and additional licenses in file—All features from 
the pre-installed product and additional products applied to the device 
are expressed in a license file.

• Pre-installed license and additional licenses in trusted storage—All 
features from the pre-installed product and additional products applied 
to the device are expressed in trusted storage. 

Device Series The device series that is the parent of the device model. 

Identity The publisher identity for the device model.

Default A check box that designates the current device model as the default device 
model. If you create a device without specifying a device model, the default 
device model is used for that device.

Pre-installed Product The product that determines the features included in the pre-installed 
license for devices of this device model type. Pre-installed product settings 
also determine the license model, license model attributes, and expiration 
terms used in the pre-installed license for such devices.

When a pre-installed product is specified for a device model, that pre-
installed product is used for devices based on that device model unless a 
different product is specified when the device is created. 

Table 20-64 • 

Attribute Description

Server Host Type Name A unique identifier for the server host type. This value must be unique per 
producer.

Description A description for the server host type.

Alias An alias for the server host type.

Table 20-63 • 

Attribute Description
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About Publishers and Publisher Identities 
Software publishers and device manufacturers can be assigned one or more publisher identities. A publisher 
identity is binary data that contains a publisher or manufacturer name and encryption data. There are two main 
components to a publisher identity: the server component used to sign licenses, and a client component 
(containing public keys) that go into the license-enabled code. In addition, back-office identities facilitate FlexNet 
Embedded trials. 

Public keys for your publisher identity were supplied upon purchase of FlexNet Operations. Please consult the 
FlexNet Publishing Licensing Toolkit documentation for details.

Managing Publisher Identities 
The topics, below, describe procedures for publisher and identity management. 

Default Host ID Type Specifies a default host ID type for servers based on this server host type. 
This host ID type is used if a server is created without specifying a host ID 
Type. 

Two special host types appear in the Default Host ID Type attribute: 
PUBLISHER_DEFINED and EXTENDED. For more information on these host ID 
types, see the FlexNet Embedded License Server Producer Guide.

Identity The publisher identity for the license server.

Default A check box that designates the current server host type as the default 
server host type. If you create a license server without specifying a server 
host type, the default server host type is used for that server.

Pre-installed Product The product that determines the features included in the pre-installed 
license for license servers of this server host type. Pre-installed product 
settings also determine the license model, license model attributes, and 
expiration terms used in the pre-installed license for such license servers.

When a pre-installed product is specified for a server host type, that pre-
installed product is used for license servers based on that server host type 
unless a different pre-installed product is specified when the license server 
is created. 

Table 20-65 • 

Topic Description

Creating a Publisher Describes how to add a publisher to FlexNet Operations via the Producer Portal.

Table 20-64 • 

Attribute Description
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Creating a Publisher 
You can add a publisher from the Administer menu in the Producer Portal.

Task To create a publisher

1. Click Administer > Publishers. The Producer Portal opens the List Publishers page.

2. Click Add Publisher. The Producer Portal opens the Create a Publisher page.

3. In Publisher Name, enter the name of the publisher.

4. In Notes, optionally enter a description of the publisher.

5. In Publisher Keys, enter the vendor keys used by the publisher. 

6. Click Save. You can now add publisher identities for the publisher.

Creating a Publisher Identity 
You can add identities from the Administer menu in the Producer Portal.

Task To create a publisher identity

1. Click Administer > Identities. The Producer Portal opens the List Identities page.

2. On the List Identities page, click Add Identity. The Producer Portal opens the Add Identity page.

3. In Identity Name, enter the identity name.

4. In Notes, optionally enter a description of the publisher identity.

5. In Signature Algorithm, select an algorithm and signature strength combination that will be used to generate 
digital signatures. For example, TRL_163.

6. If you have a custom back office identity to upload, click Choose File and locate the file on your local system. 
(This step is optional, and controls for choosing a file vary depending on the browser you are using.)

7. Click Save. 

Creating a Publisher 
Identity

Shows how to add a publisher identity in the Producer Portal.

Downloading Identity 
Files

Shows how to download client, client-server, and back-office identity files from the 
Producer Portal.

Table 20-65 • 

Topic Description
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Important • Because it is impossible to re-create an identity—even by entering the same input parameters in 
the Creating a Publisher Identity procedure—it is strongly recommended that you save backup copies of your 
identity files in case it is necessary to restore your FlexNet Operations instance.

To save a backup identity file:

a. After you successfully create a publisher identity, the List Identities page is displayed.

b. On the List Identities page, click the identity that you just created to display its View Identity page.

c. In the Identity Files section of the View Identity page, click the Binary File link below Download Back 
Office Identity. 

d. When you are prompted to save the identity file, choose a unique name to differentiate it from other 
publisher identity backup files, and save it in a secure location.

To re-create an identity in the new FlexNet Operations instance from a backup identity file:

a. After you reinstall FlexNet Operations, click Administer > Identities to display the List Identities page. 

b. On the List Identities page, click Create Identity to display the Create Identity page.

c. From the Publisher Name list, select the publisher that the identity belongs to.

d. In the Custom IdentityBackOffice.bin field of the Create Identity page, click Browse... to find and select 
the backup identity file.

e. Click Save to re-create the identity in the restored FlexNet Operations instance.

Downloading Identity Files 
The following instruction sets show how to download client, client-server, and back-office identity files. Identity 
files are a necessary part of your license-enabled code. See your FlexNet Embedded documentation for details.

Task To download a client identity file

1. Click Administer > Identities.

2. On the List Identities page, click on the identity name for the identity you want to download.

3. Click the Download Client Identity link for the format you want to download. 

This file must be compiled into your license-enabled code for client devices.

Task To download a client-server identity file

1. Click Administer > Identities.

2. On the List Identities page, click on the identity name for the identity you want to download.

3. Click the Download Client Server Identity link for the format you want to download. 

This file must be compiled into your license-enabled code for server devices.
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Task To download a back-office identity file

1. Click Administer > Identities.

2. On the List Identities page, click on the identity name for the identity you want to download.

3. Click the Download Back Office Identity link. 

Managing Device Series 
Producers who use FlexNet Embedded licensing can manage device series from the Administer menu. The 
following topics cover device series management tasks.

Listing Device Series 
You can list all the device series available to your account on the Producer Portal. 

Task To list device series

• Click Administer > Device Series.

The Producer Portal opens the List Device Series page. To view an existing device series, click its name in the list.

Viewing a Device Series 
You can view a device series from the List Device Series page.

Task To view a device series

• On the List Device Series page, click the name of the device series you want to view. 

The Producer Portal opens the View Device Series page for the device name you clicked. 

Table 20-66 • 

Topic Description

Listing Device Series Shows how to list all device series for your account.

Viewing a Device Series Shows how to view a device series from the List Device Series page.

Adding a Device Series Explains how to create a new device series.

Editing a Device Series Explains how to edit an existing device series.
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Adding a Device Series 
A device series is a collection of device models that are physically identical but upgradable in the field through 
license changes and additional capabilities. A device series sets the maximum limits for device capabilities and 
capacities. 

Tip • A pre-defined device series, FLX_CLIENT_SERIES, is provided for all producers. Those producers who do not 
require the additional complexity of defining multiple device series and device models can leverage the 
FLX_CLIENT_SERIES instead of creating their own device series.

You can add a device series from the List Device Series page. Use the following steps to add a device series.

Task To Add a Device Series

1. Click Add Device Series. The Producer Portal opens the Add Device Series page. 

2. For Name, type a unique identifier for the device series.

3. Optionally type any information needed in Notes.

4. Optionally, for Alias, type a human-readable name for the device series. 

5. Optionally, add capabilities to the device series: 

• Under Add Capabilities, click the arrow next to the drop-down menu, select a capability, and then click 
Add.

• Type the maximum units for each counted capability for the device series. 

Note • The maximum unit for uncounted capabilities defaults to Enabled.

6. Click Add Device Series.

The Producer Portal adds the device series and opens its View Device Series page. 

Editing a Device Series 
You can edit a device series from its View Device Series page. For an existing device series, you can change the 
notes, alias, and capabilities values. (The device series name cannot be changed.) 

Task To edit a device series

1. On the View Device Series page, click Edit > Edit this Device Series. The Producer Portal opens the Edit 
Device Series page for the current device series.

2. Make any necessary changes.

3. Click Edit Device Series. 

The Producer Portal saves your changes to the device series and opens its View Device Series page.
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Managing Device Models 
Producers who use FlexNet Embedded licensing can manage their device models from the Administer menu.

Searching Device Models 
You can search for device models on the Producer Portal from the Administer menu. 

Task To search for device models

1. Click Administer > Search Device Models. The Producer Portal opens the Search Device Models page. 

2. Type search criteria to match the device models you are looking for. 

3. Click Search. 

The Producer Portal finds device models that match your search criteria and lists them on the Search Device 
Models results page. 

Viewing a Device Model 
You can view a device model from the Search Device Models page.

Task To view a device model

• On the Search Device Models results page, click the model name of the device model you want to view. 

The Producer Portal opens the View Device Model page for the model name you clicked.

Table 20-67 • 

Topic Description

Searching Device 
Models

Shows how to search for device models created for your account.

Viewing a Device Model Shows how to view a device model from the Search Device Models results page.

Creating a Device Model Describes how to create a new device model. 

Editing a Device Model Explains how to edit an existing device model.
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Creating a Device Model
A device model is a basic model for a device that producers use to create a pre-installed license and, optionally, 
define a pre-installed product. A pre-installed license can define a set of capabilities, as defined in the pre-
installed product’s features, within the maximum limits for the device series. The device model with that 
particular pre-installed license represents a purchasable configuration for a device. If a device model has a 
certain capability, that capability can be increased to what is defined as the maximum in the series.

Tip • A pre-defined device model, FLX_CLIENT, is provided for all producers. Those producers who do not require 
the additional complexity of defining multiple device series and device models can leverage the FLX_CLIENT 
instead of creating their own device models.

You can create a device model from the Administer menu.

Task To create a device model

1. Click Administer > Create Device Model. The Producer Portal opens the Create Device Model page. 

2. For Model Name, type a unique identifier for the device model.

3. Optionally, for Description, type a short description of the device model. 

4. Optionally, for Name, type a human-readable name for the device model.

5. For Default Host ID Type, select a host ID type. Choose from

• ETHERNET

• INTERNET

• INTERNET_6

• FLEXID_9

• FLEXID_10

• STRING

• USER

• VM_UUID

• CONTAINER_ID

6. For License Format, select a license format. Choose from 

• Pre-installed license in file, additional licenses in trusted storage

• Pre-installed license and additional licenses in file

• Pre-installed license and additional licenses in trusted storage

7. For Device Series, choose from a list of available device series.

8. For Identity, choose from a list of available publisher identities.
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9. Optionally, select the Default check box. If you select the check box, the current device model becomes the 
default device model for all new devices.

10. Optionally, add a pre-installed product to the device model. 

A pre-installed product defines a set of built-in features for devices based on this device model. (A device 
model with no pre-installed product results in devices with no built-in features. In this case, all features 
would be additional features.) To add a pre-installed product

a. Click Add. The Add Pre-Installed Product page opens in a pop-up window. 

b. On the Add Pre-installed Product page, click By Product. The Select Product page opens in another pop-
up window. The Select Product page lists products with features permitted by the restrictions imposed 
(if any) by the device model’s device series.

c. On the Select Product page, click the option for the pre-installed product and then click OK. The Select 
Product window closes and the product name and version of the selected product are shown on the Add 
Pre-installed Product page. 

d. On the Add Pre-installed Product page, specify a license model, license model attributes (optional), and 
expiration terms. 

e. Click Add. The Add Pre-installed Product window closes and you return to the Create Device Model page. 
Notice that the Pre-installed Product settings show the product you selected as well as its expiration 
terms.

11. Click Create Device Model. The Producer Portal adds the device model you defined and shows its View 
Device Model page. 

Editing a Device Model 
You can edit a device from its View Device Model page. For an existing device model, you can change its 
description, its alias, and whether or not it is the default device model. You cannot change its model name, 
default host ID type, license format, device series, identity, or pre-installed product (if any).

Setting Description

License Model Choose a license model for the pre-installed product. License models 
available are determined by the license models that are linked to the 
selected pre-installed product.

License Model 
Attributes

Optionally, provide settings for license model attributes (such as Notice 
and Vendor String). Any values set here become the default values for 
devices based on this device model.

Expiration Terms Express the Start Date and Expiration for the pre-installed product. 
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Task To edit a device model

1. On the View Device Model page, click Edit > Edit this Device Model. The Producer Portal opens the Edit 
Device Model page for the current device model.

2. Make any necessary changes.

3. Click Edit Device Model. The Producer Portal saves your changes to the device model and opens its View 
Device Model page.

Managing Server Host Types
You can view fulfillment or license information associated with previously-defined hosts.

Listing Server Host Types
You can list all the server host types available to your account on the Producer Portal. 

Task To list server host types

• Click Administer > Server Host Types.

The Producer Portal opens the List Server Host Types page. To view an existing server host type, click its name in 
the list.

Viewing a Server Host Type
You can view a server host type from the List Server Host Types page.

Table 20-68 • 

Topic Description

Listing Server Host 
Types

Shows how to list all server host types for your account.

Viewing a Server Host 
Type

Shows how to view a server host type from the List Server Host Types page.

Creating a Server Host 
Type

Explains how to create a new server host type.

Editing a Server Host 
Type

Explains how to edit an existing server host type.
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Task To view a server host type

• On the List Server Host Types page, click the name of the host type you want to view. 

The Producer Portal opens the View Server Host Type page for the host type name you clicked. 

Creating a Server Host Type
You can create a server host type from the Server Host Types page. 

Task To create a server host type

1. Click Create Server Host Type. The Producer Portal opens the Create Server Host Type page. 

2. For Server Host Type Name, type a unique identifier for the host type.

3. Optionally, type a description for the server host type in Description.

4. Optionally, for Name, type a human-readable name for the server host type. 

5. For Default Host ID Type, select a host ID type. Choose from 

• ETHERNET

• INTERNET

• INTERNET_6

• FLEXID_9

• FLEXID_10

• STRING

• USER

• VM_UUID

• EXTENDED

• PUBLISHER_DEFINED

• CONTAINER_ID

6. For Identity, choose from a list of available publisher identities.

7. Optionally, select the Default check box. If you select the check box, the current host type becomes the 
default host type for all new license servers.

8. Optionally, add a pre-installed product to the server host type. 

A pre-installed product defines a set of built-in features for license servers based on this server host type. (A 
server host type with no pre-installed product results in license servers with no built-in features. In this case, 
all features would be additional features.) To add a pre-installed product:

a. Click Add. The Add Pre-installed Product page opens in a pop-up window. 
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b. On the Add Pre-installed Product page, click By Product. The Select Product page opens in another pop-
up window.

c. On the Select Product page, click the option for the pre-installed product and then click OK. The Select 
Product window closes and the product name and version of the selected product are shown on the Add 
Pre-installed Product page. 

d. On the Add Pre-installed Product page, specify a license model, license model attributes (optional), and 
expiration terms. 

e. Click Add. The Add Pre-installed Product window closes and you return to the Create Server Host Type 
page. Note that the Pre-installed Product settings show the product you selected as well as its 
expiration terms.

9. Click Create Host Type. The Producer Portal adds the server host type and opens its View Server Host Type 
page. 

Editing a Server Host Type
You can edit a server host type from its View Server Host Type page. For an existing host type, you can change its 
description, its alias, and whether or not it is the default server host type. You cannot change its name, its default 
host ID type, or its identity.

Task To edit a server host type

1. On the View Server Host Type page, click Edit > Edit this Server Host Type. The Producer Portal opens the 
Edit Server Host Type page for the current host type.

2. Make any necessary changes.

3. Click Edit Server Host Type. The Producer Portal saves your changes to the server host type and opens its 
View Server Host Type page.

Viewing Request History
Use the following instruction sets to view the history of all device and license server requests and, optionally, to 
filter the request history by date and time or by request ID.

Setting Description

License Model Choose a license model for the pre-installed product. License models 
available are determined by the license models that are linked to the 
selected pre-installed product.

License Model 
Attributes

Optionally, provide settings for license model attributes (such as Notice 
and Vendor String). Any values set here become the default values for 
devices based on this device model.

Expiration Terms Express the Start Date and Expiration for the pre-installed product. 
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Task To View Request History

• Click Administer > Request History. The Producer Portal opens the Request History page. 

The Request History page shows all requests, by default.

Request history results can be filtered by date or by ID.

Task To Filter the Request History Results

1. On the Request History page, enter any date or ID values you want to use to filter the request history results.

• Max Request Time—Determines how recent the requests included in the request history results are. No 
requests that occurred after the specified date are included in the results. 

• Max Request ID—Limits the request history results according to the request ID. No requests with a 
request ID number higher than the specified request ID are included in the results. (Only numbers are 
possible in the Max Request ID field, and wildcards are not permitted.)

2. Click Get History. The Producer Portal refreshes the Request History page to show only the requests that 
match the filters.

Monitoring the FlexNet Embedded Back Office
For customers who want to periodically ping the FlexNet Embedded back office to verify that it is responding as 
expected, the following endpoint URLs are exposed.

Note • For information about the site ID used in these URLs, see About Your Site ID in FlexNet Operations 
Environments.

User Acceptance Testing
The UAT environment is a place to perform configuration, integration development, testing, and training. 

Use URL

End-User Portal https://<siteID>-uat.flexnetoperations.com/flexnet/operationsportal/
deviceservices/ping

Producer Portal https://<siteID>-uat.flexnetoperations.com/flexnet/operationsportal/
deviceservices/ping

License Fulfillment Service https://<siteID>-uat.compliance.flexnetoperations.com/deviceservices/
ping

Cloud Licensing Service https://<siteID>-uat.compliance.flexnetoperations.com/api/1.0/
instances/ping
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Production (PROD)
The Production instance is for customer entitlement management and licenses, usage, and delivery activities. 

Working with Transaction Keys
A product is linked with a transaction key only if the product is licensed with a trusted license model. A 
transaction key is linked with a product at the time the first trusted license model is linked with the product, and 
can be changed later or overridden for local trials and short code ASRs that use the product. Therefore, create at 
least one transaction key before linking a trusted license model with a product. 

Do not define transaction keys if products are licensed only with certificate license models. 

Notification Server https://<siteID>-ns-uat.flexnetoperations.com/ping

Use URL

End-User Portal https://<siteID>.flexnetoperations.com/flexnet/operationsportal/
deviceservices/ping

Producer Portal https://<siteID>-fno.flexnetoperations.com/flexnet/operations/
deviceservices/ping

License Fulfillment Service https://<siteID>.compliance.flexnetoperations.com/deviceservices/ping

Cloud Licensing Service https://<siteID>.compliance.flexnetoperations.com/api/1.0/instances/
ping

Notification Server https://<siteID>-ns.flexnetoperations.com/ping

Table 20-69 • 

Topic Description

About Transaction Keys Discusses the use of transaction keys and anchoring with products that use trusted 
licensing models. 

Managing Transaction 
Keys

Briefly describes the management of transaction keys—including adding, deleting, 
printing, and viewing the history of transaction keys.

Creating a Transaction 
Key

Covers the creation of transaction keys in greater detail. 

Configuring Anchoring Explains how to configure anchoring for a transaction key.

Use URL
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Important • Transaction keys cannot be imported using the Product Packaging web service.

About Transaction Keys
Products that use FlexNet licensing with a trusted license model require at least one transaction key. (Do not 
define transaction keys if products are licensed only with certificate license models. )

A transaction key consists of a trusted ID, a set of transaction key seeds, and a set of bindings. The transaction 
key determines a FlexNet Publisher Licensing Toolkit Trusted ID configuration. FlexNet Operations provides no 
direct access to the Trusted ID configuration. 

Anchoring Types
Anchors record the deletion and restoration of trusted storage. Available anchors are dependent on the operating 
system and provide different levels of security. The following table describes the anchoring types on different 
platforms:

Note • When the transaction key binding type is set to Virtualization-aware Fingerprint, only Windows (registry 
and track zero) and Linux (file based) anchoring are supported. 

Transaction Key Usage
As long as all transaction key seeds are random, no transaction key is intrinsically more secure than another. 
However, if a Trusted ID configuration is compromised, the transaction key that created that Trusted ID 
configuration may be compromised. 

Consider creating several transaction keys to use for different types of activations or products. For example, one 
transaction key could be used for regular activations, one for local trials, and one for short code activations. If you 
support activation of products of different values, consider linking high value, narrowly distributed products with 
one transaction key and lower value, widely distributed products with a different transaction key. 

Linking different transaction keys (and, therefore, different Trusted ID configurations) to different distribution 
mechanisms or products has a security benefit: high value or securely distributed products are not at risk if the 
Trusted ID configuration for lower value or less-securely-distributed products is compromised.

Table 20-70 • Anchors and Supported Platforms

Anchoring Type Description

Registry Windows: Windows registry entry 

Track Zero Windows: Write to track zero 

File Based Macintosh, Solaris, Linux: Anchors written to system files

OSX File Based Macintosh: Anchors written to system files
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Virtualization-Aware Transaction Keys
Similarly, consider using virtualization-aware transaction keys (in addition to default transaction keys) for 
products that may run on virtual machines. A virtualization-aware transaction key binds to the VMID of a virtual 
machine and, therefore, results in a binding that is specific to that instance of the virtual machine. (Clones of a 
virtual machine each have a different VMID.) However, when running on a virtual machine that the licensing client 
does not recognize as a virtual environment, the licensing client uses the default transaction keys, treating the 
machine as if it were a physical machine. 

Note • Virtualization-aware transaction keys require FlexNet Publisher 11.10 or later.

Important • Transaction keys cannot be imported using the Product Packaging web service.

Managing Transaction Keys 
The Transaction Keys page automatically displays recently accessed transaction keys, if applicable. From this 
page, you can add, delete, print or export transaction keys: 

• Add: To add a new transaction key, click Add.

• Save: To save a transaction key to a file, click Save to file.

• Delete: To delete transaction keys, select one or more transaction keys and click Delete.

• Print: To print transaction keys, select one or more transaction keys and click Print.

• Export: To export transaction keys to a .jar file, select one or more transaction keys and click Export.

• Revision History: Shows revisions to transaction keys. 

To search transaction keys, select Transaction Key Name from the Search For choice list, and click Simple 
Search. You can also search for transaction keys based on transaction key name, trusted ID, transaction key 
seed, product, or keys without products. 

Creating a Transaction Key 
Create at least one transaction key before linking a trusted license model with a product. 

Task To create a transaction key

1. Click Administer > Transaction Keys. The Package Products page opens.

2. Click Add a Transaction Key. The Create a Transaction Key page opens. 
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3. Provide values for the following fields. Required fields are indicated with a red asterisk. 

4. Decide if you want to use anchoring.

• Yes - Default 

• No - Not recommended 

5. If you are not using anchoring, click Save to save the transaction key or click Add New Transaction Key to 
save this transaction key and create a new transaction key. Click Reset to reset all the transaction key fields.

6. If you are using anchoring, click Next to continue with Configuring Anchoring.

Table 20-71 • Transaction Key Fields

Field Description

Name Name to uniquely identify this transaction key: The name can contain spaces 
and can be changed at any time. 

Description Describe the characteristics of this transaction key that make it unique. The 
description can be changed at any time. 

Publisher ID Select a publisher ID from the drop-down list to associate with this 
transaction key. 

Transaction Key Seeds Enter 8 unique 32-bit hexadecimal numbers as key seeds. (See example 
below.) Do not specify the same seeds in a transaction key that are specified 
in publisher.xml. These key seeds cannot be edited after the transaction 
key is saved. 

Example 32-bit Hexadecimal Number: 2e24ec82

A single 32-bit hexadecimal number consists of 4 pairs of 2 valid hex digits. 
Valid hexadecimal digits are 0-9 and A-F.

Binding Type Select a binding type for the transaction key. Choose from 

• Default Fingerprint—Binds to supported physical machines and virtual 
machines. The transaction key is used to configure trusted storage by 
the physical machine’s characteristics.

• Virtualization-aware Fingerprint—Binds to supported virtual machines 
only. The transaction key is used to configure trusted storage by the 
virtual machine’s VMID. 

For trusted licensing, a product can have up to two transaction keys—one 
default transaction key and one virtualization-aware transaction key.

Short Code Response 
Strength

Signature strength of the short code response. Choose from 

• Low – Short_21 transaction key, for pre-11.5 FNP kits (default option) 

• Medium – Short_24 transaction key 

• High – Short_26 transaction key 
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Configuring Anchoring 
If you have decided to configure anchoring, the following decisions are presented. Based on these decisions, you 
are presented with additional decisions and finally a set of attributes to select. The usefulness and ramifications 
of these attributes can be further explored in FlexNet Publisher Licensing Toolkit documentation. 

1. Do you want to use the same anchoring for end users and enterprise users? 

License models that apply to end users are retail activation, enterprise activation, and floating borrowable 
license models. License models that apply to enterprise users are enterprise activation, floating transferable, 
and floating borrowable license models.

• Yes - Default: If this transaction key is associated with a product meant to be activated on both end-user 
and license server machines, the same anchoring is used.

• No - Different anchoring is used for the same product when activated on end-user and license server 
machines.

2.  Do you want to use default anchoring for all supported operating systems? 

• Yes - Default. The Default anchoring configuration is displayed but not changeable. See the default 
anchoring configuration in the next table.

• No - You are asked to choose anchoring for each supported operating system from the available 
anchoring. 

Note • When the transaction key binding type is set to Virtualization-aware Fingerprint, only Windows 
(registry and track zero) and Linux (file based) anchoring are supported. 

3. If you answer Yes to Question 1 and Question 2, click the Save button to save the transaction key. If not, 
decide whether to use default anchors for different types of users on different operating systems. 

4. For End Users: Do you want to use default anchoring for supported operating systems? 

• Yes - Default anchoring for end-user machines displayed.

• No - You are asked to choose anchoring for each supported operating system from the available 
anchoring.

5. For Enterprise Users: Do you want to use default anchoring for supported operating systems?

• Yes - Default anchoring for license server machines displayed.

OS Anchoring Type

Windows Registry

Linux File Based

Macintosh File Based and OSX File Based

Solaris File Based
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• No - You are asked to choose anchoring for each supported operating system from the available 
anchoring.

6. If you selected No to either Question 4 or Question 5, configure the anchors for end users and/or enterprise 
users, if necessary.

7. Click the Save button to save the transaction key. 

Working with Application Specification Records 
(ASRs)

Application Specification Records (ASRs) are transactions codes that use shorter length values to support local 
trial and short code activation scenarios.

About Activation Specification Records (ASRs) 
An Activation Specification Record (ASR), which is tied to a product in FlexNet Operations, is a digitally signed 
XML file describing the licensing terms of a particular product. Local trials and short code activations are 
implemented by creating an ASR in FlexNet Operations and bundling the ASR with a product. The activation utility 
for the product uses the bundling ASR to activate a license instead of communicating with the FlexNet Operations 
server.

The two scenarios supported by FlexNet Operations that use ASRs are local trials and short-code activations. 

• A local trial is typically a time-limited license intended for use as an evaluation license or an emergency 
license. The application activation utility reads the license rights from the ASR instead of communicating with 
the server, and installs the rights in trusted storage. A local trial license cannot be returned, repaired, or 
rehosted. See Local Trials for more information.

Note • In the FlexNet Publisher Licensing Toolkit, local trial ASRs are referred to as Embedded Activation. 

• A short-code activation is one intended for customers that do not have the network connection resources 
needed for typical activation transactions, and therefore need to activate a product manually, such as over 
the telephone. Using a short-code ASR, a customer can provide a short request code and receive a short 
response code (to be typed into the application interface, for example) over the telephone, without the 

Table 20-72 • 

Topic Description

About Activation 
Specification Records 
(ASRs)

Discusses what ASRs are and how they can be used for local trials and short code 
activations.

Local Trials Explains how to create, manage, and email ASRs for local trials.

Short Code ASRs Explains how to create, link, email, and otherwise manage ASRs for short code 
activation.
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prohibitively long codes used in typical activations. Unlike a local trial license, a license activated with short-
code activation can be returned, repaired, and rehosted. See Short Code ASRs for more information.

Local Trials
A local trial is one of two kinds of trusted activation that do not require a real-time response from the FlexNet 
Operations server when a product is activated. Local trials usually expire after a short time and are used to: 

• Allow evaluations of a product (trial) 

• Cover a situation in which an application machine loses contact with the license server system machine 
(emergency) 

Local trial licenses cannot be rehosted, returned, or repaired. 

Managing Local Trial ASRs
The Local Trials page automatically displays recently accessed local trials for a product. 

To view all local trials for a product, click the Search button. 

From this page, you can perform several tasks. Among them are

• Creating a Local Trial ASR: To add a new local trial, click Add.

• Deleting a local trial: To delete local trial ASRs, select one or more local trials and click Delete.

Creating a Local Trial ASR
Local Trial ASRs can be created in the Producer Portal on the Local Trial ASRs page.

Task To create a local trial ASR

1. Click Administer > Local Trial ASRs. This link opens the Local Trial ASRs page.

2. Click Add. This button opens the Create a Local Trial ASR page. 

Table 20-73 • 

Topic Description

Managing Local Trial 
ASRs

Briefly discusses viewing, creating, and deleting local trial ASRs.

Creating a Local Trial 
ASR

Provides a more detailed explanation of creating local trial ASRs.

Emailing a Local Trial 
ASR

Describes how to email a local trial ASR.
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3. Provide values for the following fields. Required fields are indicated with a red asterisk. 

Table 20-74 • Local Trial Fields

Field Description

Name Name to uniquely identify this local trial ASR: The name can contain 
spaces, however, you may not want to include spaces because this name 
is used to construct the local trial ASR file name.

Trial Type Select whether this is for a trial or an emergency. 

Description Describe the characteristics of this local trial ASR that make it unique. 

Product Details:

 - Product Name

 - Product Version

 - Part Number

Search for a product by name or part number. 

To search by product name:

• Click By Product. A pop-up window displays a list of products by 
product name and allows you to search for a specific product.

• Search for and select a product. The version number is added to the 
Product Version field automatically. If the product is mapped to more 
than one part number, select the correct one from the Part Number 
drop-down list. 

To search by part number, click By Part Number. A pop-up window 
displays a list of products by part number and allows you to search for a 
specific product.

The product name, product version, and part number fields are populated 
automatically.

Duration Set Duration so an individual local trial activation expires at a fixed time 
from the activation date. If you want to set the duration, enter the units of 
time (Days, Weeks, Months, Years) and enter the number of those units. 

If unlimited activations per computer are allowed by this local trial ASR, the 
local trial can be reactivated up until the expiration date. 

Expiration Date Set the date that this local trial ASR expires. This is the absolute expiration 
date of the license, regardless of when it is activated by the client. No new 
local trial activations can use this ASR after the expiration date, regardless 
of how many activations per computer are allowed.

If a product in the local trial contains a feature with an Expiration Date, set 
the date. 

3. To specify an ExpirationDate date, click the Calendar button next to 
the Expiration Date field and click a date. 

4. Click the Clear button to clear the Expiration Date field. 
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4. Click Save To File to save the local trial to a file (default file name LocalTrial_namexxxxx.asr) that can be 
bundled in a software product, click Email to email this local trial ASR to a customer, or click Complete to 
finish working with this local trial ASR. 

Emailing a Local Trial ASR 
A newly or previously generated local trial ASR can be sent as an email attachment to one or more email 
addresses. The email attachment is sent as a file, by default called LocalTrial_namexxxxx.asr, where xxxxx is a 
random number. The default subject line is: 

Activations per Computer Select whether this local trial ASR allows only one or unlimited numbers of 
activations on a computer. Even if unlimited, no more activations can be 
done after the Expiration date. 

Enable Local Trial Anchors Select whether or not to enable local trial anchors. Trial anchors serve as 
additional identifiers for types of trials, and are numbered from 0 to 255, 
allowing each publisher to support 256 distinct trial types. 

The number shown here is decremented by 1 each time a trial anchor is 
assigned to a Flex-enabled product. If a trial anchor is created in error, 
delete the ASR so its anchor is added back to the pool.

License Model Select one of the trusted license models that is associated with the 
selected product. Specify any entitlement-time license model attributes. 

Virtualization Keyword Specify the Virtualization Keyword associated with this Local Trial ASR. 
This option determines whether or not FlexNet Operations adds a 
Virtualization Policy to the ASR and, if so, whether the trial uses default or 
virtualization-aware binding. Choose from 

• Omitted—No Virtualization Policy added to the ASR. 

• Default—Adds a Virtualization Policy to the ASR and specifies default 
binding for the ASR.

• Virtual—Adds a Virtualization Policy to the ASR and specifies 
virtualization-aware binding for the ASR.

The choice you make here also determines the type of transaction keys 
available in Transaction Key (below).

Transaction Key Select a transaction key to link with this local trial. If a transaction key is 
not specified here, the key associated with the product is used.

The choice you make for Virtualization Keyword determines which 
transaction keys are available for selection. When Virtualization Keyword is 
set to Omitted or Default, only default transaction keys are available. When 
Virtualization Keyword is set to Virtual, only virtualization-aware 
transaction keys are available.

Table 20-74 • Local Trial Fields

Field Description



Chapter 20 Performing Administrative Tasks
Working with Application Specification Records (ASRs)

854 Company Confidential FNO-2021R1-UGOP02 FlexNet Operations User Guide

File containing your activation specification record (ASR) attached

The Ship To Email field contains the email address where the local trial ASR should be sent. Additional email 
addresses can be entered, and multiple email addresses are formatted in a comma-separated list that contains 
no spaces.

Note •  If FlexNet Operations is localized with multiple locales, you can select which language to send the email 
in.

After the email is sent, a confirmation message appears on the page.

Publishers must configure FlexNet Operations before they can successfully email a local trial ASR: 

Task To configure FlexNet Operations

If you are emailing local trial ASRs to customers, in the FlexNet Platform Server configuration settings, set the 
Outbound Mail Server Host to your organization’s mail server and From-Address for Outbound Mail to the email 
address you want to use as the from-address for license emails.

Short Code ASRs
Short code activations are implemented by creating a short code Activation Specification Record (ASR) in FlexNet 
Operations and bundling the short code ASR with the software product. The ASR is tied to an entitlement in 
FlexNet Operations. 

Table 20-75 • 

Topic Description

About Short Code 
Activations

Discusses the intended use of short code activations. 

Managing Short Code 
ASRs

Briefly covers viewing, creating, deleting, and saving short code ASRs.

Creating a Short Code 
ASR

Describes the process of creating a short code ASR in greater detail.

Linking a Short Code 
ASR with a Bulk 
Entitlement

Shows how to link a short code ASR with an existing bulk entitlement.

Viewing Short Code 
Summary

Explains how to view a short code ASR summary. 

Emailing a Short Code 
ASR

Shows how to email a short code ASR.
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Note • The amount of information transmitted in short code transactions is much less extensive than ordinary 
programmatic activations. For example, only part of the UMN is passed. This reduces the security of short code 
transactions.

About Short Code Activations
A short code activation is one intended for customers who do not have the network connection resources needed 
for typical activation transactions, and therefore must activate a product manually, such as over the telephone.   

Using the short code ASR, a customer can provide a short request code and receive a short response code (to be 
typed into the application interface, for example) over the telephone, without the prohibitively long codes used in 
typical activations. 

You can use either pre-loaded Web Reg Keys or dynamic Web Reg Keys and use the Web Reg Key as Activation ID 
while generating the short code. If you use dynamic Web Reg Keys, make sure to enable the Load web reg keys 
as part of activation for trusted type bulk entitlements? property (found in System > Configure > Trusted 
Storage).

Unlike local trial licenses, licenses activated with short code activation can be rehosted, returned, or repaired like 
licenses activated using secure transactions. 

Note • The amount of information transmitted in short code transactions is much less extensive than ordinary 
programmatic activations. For example, only part of the UMN is passed. This reduces the security of short code 
transactions.

Managing Short Code ASRs
The Short Code ASRs page short code ASRs for all products. You can also search the list of short code ASRs by 
name, part number, license model, or product.

From this page, you can create or delete short code ASRs, email them, or save them to an XML file. 

Instructions for deleting a short code ASR and for saving a short code ASR to a file are below. For instructions on 
creating a short code ASR, see Creating a Short Code ASR.

Task To delete a short code ASR

1. Select the short code ASR you wish to delete and click Delete.

2. Click OK to confirm deletion. 

Task To save a short code ASR to a file

1. Select the short code ASR you wish to save and click Save to File.

2. Browse to a location to save the file.
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Creating a Short Code ASR 
Short code ASRs can be created in the Producer Portal on the Short Code ASRs page.

Task To create a short code ASR

1. Click Administer > Short Code ASRs. This link opens the Short Code ASRs page.

2. Click Add. The Create a Short Code ASR page opens.

3. Provide values for the following fields. Required fields are indicated with a red asterisk.

Table 20-76 • Short Code ASR Fields

Field Description

Name Name to uniquely identify this short code ASR. The name can contain spaces, 
however, you may not want to include spaces because this name is used to 
construct the short code ASR file name. 

Description Describe the characteristics of this short code ASR. 

FNP client library 
version

Note • Not available when bulk entitlement linking is enabled in Trusted 
Storage system configuration (System > Configure > Trusted Storage).

Specify which FlexNet Publisher Licensing client library version the short code 
ASR is to be used with. Choose from 

• Pre 11.5? 

• Between 11.5 and 11.14? 

• 11.14 and above? 

For FlexNet Publisher client versions 11.14 and above: 

• A UMN length of 8 to 40 hexadecimal characters is specifiable 

• License server ASR is supported 

• UMN3 is supported for client and server ASRs 
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Generate alphanumeric 
Code?

Note • Only valid for FlexNet Publisher Licensing Toolkit 11.5 and later. Not 
available when bulk entitlement linking is enabled in Trusted Storage system 
configuration (System > Configure > Trusted Storage).

Specify whether to generate alphanumeric or numeric short code values for 
both request and response. (Alphanumeric short codes contain letters and 
numbers and can encode the same information in a shorter string than just 
numeric codes.) Choose either

• Yes. Short codes use alphanumeric values. 

• No. Short codes use numeric values.

Product Details

 - Product Name

 - Product Version

 - Part Number

Search for a product by its name or a part number.

To search by product name:

• Click By Product. A pop-up window displays a list of products by product 
name and allows you to search for a specific product. Search for and select 
a product. The version number is added to the Product Version field 
automatically. If the product is mapped to more than one part number, 
select the correct one from the Part Number drop-down list. 

• To search by part number, click By Part Number. A pop-up window displays 
a list of products by part number and allows you to search for a specific 
product. The product name, product version, and part number fields are 
populated automatically.

Permanent If the license generated using this keyboard (short code) activation must be 
permanent, select Yes. If an individual keyboard activation expires, select No, 
then set Duration or Expiration Date. 

Duration Set either Duration or Expiration Date for an expiring keyboard (short code) 
activation. 

• Set Duration if you want the keyboard activation to expire at a fixed time 
from the activation date. 

If you want to set the duration for an expiring keyboard activation, enter the 
unit of time (Days, Weeks, Months, Years) and enter the number of units. 

Table 20-76 • Short Code ASR Fields

Field Description
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Expiration Date If a license generated from this short code must expire on a certain date, enter 
that date here. 

To specify an Expiration Date, click the Calendar next to the Expiration Date 
field and click a date. 

Click Clear to clear the Expiration Date field. 

The specific Expiration Date Format to use is defined in the FlexNet Operations 
system configuration. 

License Model Select one of the trusted license models that is associated with the selected 
product. 

Transaction Key Select a transaction key to link with this short code ASR. If a transaction key is 
not specified here, the key associated with the product is used.

No. of environment 
aware UMN characters

Note • Only valid for FlexNet Publisher Licensing Toolkit 11.5 and later. Not 
available when bulk entitlement linking is enabled in Trusted Storage system 
configuration (System > Configure > Trusted Storage).

Number of environment aware UMN characters to be used in the short code 
request. A UMN length of 8 to 40 hexadecimal characters is specifiable when 
FNP client library version is set to FlexNet Publisher client version 11.14 and 
above. For older versions, UMN values are hard-coded to 8 chars for activation 
requests and 6 chars for return/repair requests. Environment aware UMN 
means UMN1 on physical machines and UMN3 on virtual machines. 

No. of UMN-2 
characters

Note • Only valid for FlexNet Publisher Licensing Toolkit 11.5 and later. Not 
available when bulk entitlement linking is enabled in Trusted Storage system 
configuration (System > Configure > Trusted Storage).

Number of UMN2 characters to be used in the short code request.

Table 20-76 • Short Code ASR Fields

Field Description
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4. Click Create short code ASR to save the short code ASR. 

After a short code ASR is created, you can use the controls on the Short Code ASRs page to email the short code 
ASR to a recipient or save it to a file for later reference.

Tip • When the Producer Portal is configured to support linking bulk entitlements to short code ASRs, you can 
click Next to show controls for linking the short code ASR to a bulk entitlement. 

Linking a Short Code ASR with a Bulk Entitlement 
When the Producer Portal is configured to support it, short code ASRs can be linked with one or more bulk 
entitlements.

Important • The ability to link short code ASRs with bulk entitlements is controlled by the Enable Bulk Entitlement 
Linking while Creating Short Code system configuration setting. Administrators can change this setting on the 
Trusted Storage system configuration page (System > Configure > Trusted Storage).

Add custom data to 
short code response?

Note • Only valid for FlexNet Publisher Licensing Toolkit 11.5 and later. Not 
available when bulk entitlement linking is enabled in Trusted Storage system 
configuration (System > Configure > Trusted Storage).

Select Yes to add response override keys. Short code response overrides allow 
a publisher to add vendor-specific data to a short code response.

For each row, provide a unique name for the vendor data key and an integer 
number to control the maximum size of the value provided for the key in the 
response.

• Key names must have consistent naming conventions. For example, enter 
key names in upper case, and separate multiple words with an underscore: 
COUNTRY_LIST. 

• Key names must not contain special characters.

• There is no restriction on key name length.

• Provide a suitable minimum size for the length of the response data 
corresponding to the key name. 

• Verify that your key name and size are correctly entered. After a key name 
and its size are saved, they are part of the generated ASR and cannot be 
changed. 

For more information on short code response overrides, consult the FlexNet 
Operations On-Premises Installation & Implementation Guide.

Table 20-76 • Short Code ASR Fields

Field Description
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A bulk entitlement represents a large number of individual entitlements (for the reseller channel, for example) for 
a single product, each of which is expected to be resold to a different customer. The bulk entitlements can 
already exist or can be created now. 

When linking to a bulk entitlement, you must first choose to either create a new bulk entitlement or link an 
existing bulk entitlement containing the product used to create the short code ASR. 

• Creating a New Bulk Entitlement to Link with this Short Code ASR

• Linking an Existing Bulk Entitlement

Creating a New Bulk Entitlement to Link with this Short Code ASR
Use the instructions, below, to create a bulk entitlement during the short code ASR creation process. 

Task To create a new bulk entitlement to link with this short code ASR

1. Click Create a Bulk Entitlement. The Producer Portal shows controls for bulk entitlement creation.

2. Provide values for the following fields. Required fields are indicated with a red asterisk.

Table 20-77 • Create a Bulk Entitlement to Link to the Short Code ASR

Field Description

Order ID ID of an order, perhaps in an ERP system, on which the entitlement is based: 
FlexNet Operations does not validate or use the Order ID; it is included as a 
reference to an external order system. 

Entitlement ID The entitlement identifier uniquely identifies the bulk entitlement: Select Auto 
Generate to let FlexNet Operations assign an entitlement ID, or select User 
Supplied to enter an entitlement ID of your choice. 

When you generate an entitlement, you ship an entitlement ID to the customer. 
The ID is input to FlexNet Operations when generating or activating a license. A 
customer can also use the entitlement ID to log in to the FlexNet Operations 
End-User Portal.

Description Describe the characteristics of this entitlement that make it unique. 

Number of Copies Enter the number of seats that are available per Web register key. 

Sold To Click Search and select the account associated with this entitlement. The Sold 
To account has the right to activate against this entitlement.

Ship To Email This field contains the email address where the short code ASR for this 
entitlement is sent. After the sold-to account is specified, a Search button 
appears next to the Ship To Email field. Click Search to select an email address 
for one of the contacts in the sold-to account. Additional email addresses may 
be entered in a comma-separated list that contains no spaces.
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3. Click Save to save the bulk entitlement. It appears in the list of Associated Bulk Entitlements. 

• This bulk entitlement must be deployed before it can be used for short code activations. Deploy the 
entitlement and load Web register keys from the Entitle Customers to Licenses pages. 

• To delete an associated bulk entitlement, select the bulk entitlement and click Delete. 

4. Click Next to view a summary of short code ASRs. 

Linking an Existing Bulk Entitlement
Use the instructions, below, to link to an existing bulk entitlement during the short code ASR creation process. 

Task To link this short code ASR with one or more existing bulk entitlements

1. Click Link a bulk entitlement. The Producer Portal shows controls for finding a bulk entitlement.

2. Click Search. The Producer Portal opens the Select Entitlements page in a pop-up window. Bulk entitlements 
containing the same product as the short code ASR appear in the new window. 

3. On the Select Entitlements page, select bulk entitlements to link with the current short code ASR. Click one or 
more bulk entitlements and then click OK. The Producer Portal closes the Select Entitlements page. The 
selected entitlements appear in the list of Associated Bulk Entitlements.

Note • You can also remove bulk entitlements from the Associated Bulk Entitlements list. To remove an 
associated bulk entitlement, select its check box and then click Delete. 

4. Click Next to view a summary of short code ASRs. (See Viewing Short Code Summary.)

Note • After a short code ASR is linked to a bulk entitlement, it can only be used with web register keys belonging 
to that bulk entitlement.

Viewing Short Code Summary  
The short code summary page shows bulk entitlements associated with the selected short code ASR. 

Click Save To File to save the short code ASR to a file (default file name SC_namexxxxx.asr) that can be bundled in 
a software product, click Email License to email this short code ASR to a customer, or click Complete to finish 
working with this short code ASR. 

Ship To Mail Enter the mailing address where the short code ASR for this entitlement is sent. 
It may be the mailing address of one of the contacts in the account.

Table 20-77 • Create a Bulk Entitlement to Link to the Short Code ASR

Field Description
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Emailing a Short Code ASR  
A newly or previously generated short code ASR can be sent as an email attachment to one or more email 
addresses. The email attachment is sent as a file, by default called SC_namexxxxx.asr, where xxxxx is a random 
number. The subject of the ASR email cannot be edited; the subject line is: 

File containing your activation specification record (ASR) attached 

The Ship To Email field contains the email address where the short code ASR is sent. Additional email addresses 
can be entered, and multiple email addresses are formatted in a comma-separated list that contains no spaces. 

After the email is sent, a confirmation message appears on the page.

Publishers must configure FlexNet Operations before they can successfully email a short code ASR.

Task To configure FlexNet Operations

If you are emailing short code ASRs to customers, in the FlexNet Platform Server configuration settings, set the 
Outbound Mail Server Host to your organization’s mail server and From-Address for Outbound Mail to the email 
address you want to use as the from-address for license emails. 

View and Manage Trusted Activation Requests
You can view and edit information on trusted storage requests made by users. 

Task To manage trusted storage requests

1. Click Administer > Trusted Activation Requests.

2. On the Trusted Activation Requests page, click Publisher XML Details to view the publisher ID, the vendor 
name, the vendor encryption seeds, and the publisher XML file path. You can search the list of requests by 
Activation ID or Fulfillment ID.

Table 20-78 •  Trusted Storage Requests

Field Description

Request # Unique identifier of the trusted storage request. 

MID/UMN Machine ID (MID) and Unique Machine Identifiers (UMNs) of the host that 
made the request. 

Submitted On Date and time the request was submitted.

Status Updated On Date and time the request was processed. 

Status Indicates whether or not the request was processed successfully.

Completed Indicates whether or not the request was completed.
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Other options include:

• To view a request in detail, click the request number.

• To download the trusted activation response to a local XML file, select the trusted activation request and 
click Download Response.

• To delete a trusted activation request, select the request to be deleted and click Delete.

• To email a response, select the request to be emailed and click Email Response.

Managing Email and Email Templates
The Producer Portal can send email messages to your customers and create email templates for your account to 
use to communicate about new entitlements, or other events. 

Email messages can be generated automatically based on certain event triggers or generated manually as 
needed. Through the Administer menu, you can send email messages and also create, modify, or delete email 
templates.

Processed By Host that processed the request.

Request Type Type of trusted storage request.

Activation ID Activation ID of the request.

Fulfillment ID Fulfillment ID of the request.

Table 20-79 • 

Topic Description

Managing Email Explains how to manage the email messages sent via the Producer Portal. 
Managing Email includes the following subtopics: 

• Creating a Download Package Notification

• Creating a File Notification

• List Sent Emails

• View Sent Emails

• Resend Email

Table 20-78 •  Trusted Storage Requests

Field Description
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Managing Email 
Use the following topics to manage your account’s email messages.

Tip • Email messages can also be sent from other pages in the Producer Portal. For example, you can create 
notifications from the View Download Package page or the View File page for a download package or file. You can 
also send an email from pages like the Activatable Line Items page and the Local Trial ASRs page. 

Creating a Download Package Notification
You can create an email notification for one or more download packages on the Create Update Notification Email 
by Download Package page. There, you can enter the download package IDs of the download packages, directly, 
or search for download packages to which the email pertains. 

Managing Email 
Templates

Shows how to manage your account’s email templates. Managing Email Templates 
includes the following subtopics: 

• About Email Templates

• Listing Email Templates

• Adding Email Templates

• Viewing Email Templates

• Editing an Email Template

Table 20-80 • 

Topic Description

Creating a Download 
Package Notification

Describes how to create an email to send to all the customers entitled to a particular 
download package.

Creating a File 
Notification

Describes how to create an email to send to all the customers entitled to download 
a specified file.

List Sent Emails Describes how to view a list of sent emails.

View Sent Emails Describes how to get a detailed view of a sent email.

Resend Email Describes how to resend a previously sent email.

Table 20-79 • 

Topic Description
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Tip • To successfully send an email notification for a download package, the default variation of the Update 
Notification Email template must be active and permitted to send messages (Will Email Be Sent set to Yes). 

Task To send a download package notification email

1. Click Administer > Send Download Package Notification. This link opens the Create Update Notification 
Email by Download Package page.

2. Identify the download packages for which you want to send an email. Choose whether to enter download 
package IDs or to search for download packages: 

• Enter download package IDs when you already know their download package IDs or system download 
package IDs. 

a. In the download package IDs field, type the download package IDs as a comma-separated list or 
enter them one per line. Note: If you enter system download package IDs, remember to select the 
Use System IDs check box.

b. Click Create Email.

• Search for download packages by entering search criteria if you do not know the IDs of the download 
packages.

a. Type your search criteria into the download package search fields. 

b. Click Search. The Producer Portal shows a list of download packages that match your criteria. 

c. Select download packages and click Save.

The Producer Portal shows the Distribution List Options and Choose an Email Template settings.

3. Set Distribution List Options for the email message. 

Setting Description

Effective Date The first date (inclusive) that this entitlement is available to the end user.

Include Expired 
Entitlements

Determines whether or not to include expired entitlements in the distribution 
list. By default, only users with active entitlements are included in the 
distribution list.

Exclude Email Filters Allows you to identify specific email addresses or email address ranges to 
exclude from the distribution list. For a single address, type the address in the 
space provided. For multiple addresses, add a comma-separated list of email 
addresses in the space provided. Use an asterisk as a wildcard to exclude 
ranges of email addresses. For example, *@somedomain.com, *.edu. 
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4. Choose an Email Template variation for this message. 

Download Package notification messages use the Update Notification Email template. Select any active 
variation of that template for the download package notification. 

Tip • You can manage your email templates in the Producer Portal. For more information about email 
templates, see Managing Email Templates. 

5. Click Create. The Producer Portal creates the email message for the download packages you specified, using 
the settings you provided, and shows the View Email page.

6. On the View Email page, click Edit > Send Email. The Producer Portal opens the Send Email page. 

7. On the Send Email page, choose to send the email or schedule its delivery. 

• To send immediately, click Send. 

• To schedule delivery for a later date, 

a. Click Queue to be sent at. 

b. Set the Send Date. 

c. Specify the Send Time (24-hour format). 

d. Click Send.

The Producer Portal sends the email notification. 

Creating a File Notification
You can create an email notification for customers of one or more files on the Create Update Notification Email by 
File page. There, you can enter the file IDs of the files, directly, or search for files to which the email pertains. 

Limit to Countries Restricts the delivery of notifications to countries identified by their two-
character country code. Use a comma-separated list of country codes to 
permit delivery to multiple countries. For example, specifying US,FR permits 
notification delivery to users in the United States and France.

When no country codes are specified, FlexNet Operations places no 
notification delivery restrictions based on the recipient’s country.

Send Separate Email for 
Each Download Package

Determines whether to send a single message for all download packages 
(when multiple download packages have been selected) or to send a separate 
message for each download package. 

Send Email Immediately Determines whether the message is sent as soon as it is created or sent later. 
If you select this check box, the Producer Portal sends the message as soon as 
you click Create on this page. Do not use this option if you want to modify the 
message before it is sent.

Setting Description
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Task To send a file notification email

1. Click Administer > Send File Notification. This link opens the Create Update Notification Email by File page.

2. Identify the files for which you want to send an email. Choose whether to enter file IDs or to search for files: 

• Enter file IDs when you already know their file IDs or system file IDs. 

a. In the File IDs field, type the file IDs as a comma-separated list or enter them one per line. Note: If 
you enter system file IDs, remember to select the Use System IDs check box.

b. Click Create Notification.

• Search for files by entering search criteria if you do not know the IDs of the files.

a. Type your search criteria into the file search fields. 

b. Click Submit. The Producer Portal shows a list of files that match your criteria. 

c. Select files and click Create.

The Producer Portal shows the Distribution List Options and Choose an Email Template settings.

3. Set Distribution List Options for the email message. 

Setting Description

Effective Date The first date (inclusive) that this entitlement is available to the end user.

Include Expired 
Entitlements

Determines whether or not to include expired entitlements in the distribution 
list. By default, only users with active entitlements are included in the 
distribution list.

Downloaded Status Identifies the accounts and users (members) who are to receive the 
notification based upon whether or not the file on which the notification is 
based has been downloaded. Choose from 

• All Members to deliver the notification regardless of whether or not the 
file has been downloaded. 

• Members with Download Activity to deliver the notification only to users 
who have downloaded the file. 

• Accounts with Download Activity to deliver the notification only to users in 
an account that has downloaded the file.

Exclude Email Filters Allows you to identify specific email addresses or email address ranges to 
exclude from the distribution list. For a single address, type the address in the 
space provided. For multiple addresses, add a comma-separated list of email 
addresses in the space provided. Use an asterisk as a wildcard to exclude 
ranges of email addresses. For example, *@somedomain.com, *.edu. 
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4. Choose an Email Template variation for this message. 

File notification messages use the Update Notification Email template. Select any active variation of that 
template for the file notification message. 

Note • For localized email template variations, if either the Text  and HTML Content fields or the Subject field 
is left blank, the default locale (US English) variation will be used when sending emails. If the Subject, Text, 
or HTML content fields are not empty, then the localized template variation will be used.

Tip • You can manage your email templates in the Producer Portal. For more information about email 
templates, see Managing Email Templates. 

5. Click Create. The Producer Portal creates the email message for the files you specified, uses the settings you 
provided, and shows the View Email page.

6. On the View Email page, click Edit > Send Email. The Producer Portal opens the Send Email page. 

7. On the Send Email page, choose to send the email or schedule its delivery. 

• To send immediately, click Send. 

• To schedule delivery for a later date, 

a. Click Queue to be sent at. 

b. Set the Send Date. 

c. Specify the Send Time (24-hour format). 

d. Click Send.

The Producer Portal sends the email notification. 

Limit to Countries Restricts the delivery of notifications to countries identified by their two-
character country code. Use a comma-separated list of country codes to 
permit delivery to multiple countries. For example, specifying US,FR permits 
notification delivery to users in the United States and France.

When no country codes are specified, FlexNet Operations places no 
notification delivery restrictions based on the recipient’s country.

Send Separate Email for 
Each File

Determines whether to send a single message for all files (when multiple files 
have been selected) or to send a separate message for each file. 

Send Email Immediately Determines whether the message is sent as soon as it is created or sent later. 
If you select this check box, the Producer Portal sends the message as soon as 
you click Create on this page. Do not use this option if you want to modify the 
message before it is sent.

Setting Description
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List Sent Emails
The Producer Portal allows you to list, view, and resend emails previously sent. Email retention is defined by a 
retention policy set in the system configuration. To prevent performance issues, sent email has a set number of 
days that it is retained. See Configuring the FlexNet Platform Server for more information on setting this 
configuration.

You can show all emails sent by clicking the Sent Emails link in the System menu.

Note • Email is only retained for a limited number of days as set by the email retention policy. See Configuring the 
FlexNet Platform Server for more information. 

Task To list all sent emails

1. Click Administer > Sent Emails.

The Producer Portal opens the Sent Emails page. By default, the emails are listed by the Sent date (most recent 
first).

The table contains the following columns:

Task To search sent emails

1. Use the drop-down menu to select the search criteria. Options include:

• Email

• Template Name

• Sent Before

Table 20-81 • 

Column Description

Subject Lists the subject of the email with a link to view the details of the email.

Note • If the template used to create the email has the View Email in Sent history 
setting turned off, the subject line does not contain a link and the details of the 
email cannot be viewed, nor can the email be resent.

Email Type Lists the template used to create the email. 

Recipients List of the recipients on the To list of the email. If there is more than one, they are all 
displayed in a comma separated list.

Sent The date the email was sent. 
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• Sent After

• Sent On

2. Enter a value to search on. 

Task To download a list of sent emails

1. From the Sent Emails page, click the   download icon to download a list of the sent emails.

2. The downloaded file is in the format: SentEmails-timestamp.csv. For example: .SentEmails-2017-03-28-12-
14-11.csv. The CSV file contains the following columns: 

View Sent Emails
To view an email, click the link in the Subject column of the Sent Email screen. The View Sent Email screen is 
displayed. Any email created from a template that has the View Email in Sent history unselected does not have a 
link and cannot be viewed. 

The View Sent Email page lists the From, Reply To, Subject, original Sent date and the Template used to generate 
the email. In addition it contains the following::

Table 20-82 • 

Column Description

Email Type The template used to generate the email.

Subject The subject of the email.

TO Recipient The address(es) the email was sent to.

CC Recipient The address(es) the email was CC’d to.

From The address that sent the email.

Sent The timestamp the email was sent.

Table 20-83 • 

Column Description

Type Lists if the recipient was a “To,” “CC,” or “BCC” recipient.

Email Lists the email of the recipient. 

Account Lists the account of the recipient.

Sent Language Lists the language selected for the email. English is the default.
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Resend Email

Task To resend an email

1. On the View Sent Email screen, click the Resend button. A pop-up screen appears and lists the Email To: 
field. This is the only editable field. Enter a comma separated list of emails to resend the email to.

2. Click either Save to send the email or click Cancel to cancel the operation.

Managing Email Templates
The Producer Portal allows you to change the templates that are used by FlexNet Operations to send email to your 
end users. 

The following topics discuss email template management in detail.

About Email Templates
The Producer Portal offers you flexibility in editing your email templates. This topic includes short discussions and 
examples on the following subjects: 

• Email Template Types

Text Content Lists the content of the email in ASCII text.

HTML Content Lists the content of the email with any HTML formatting.

Table 20-84 • 

Topic Description

About Email Templates Discusses email templates, email template concepts, and email template examples. 

Listing Email Templates Shows how to list all the existing email templates. From the List Email Templates 
page, you can view and edit existing email templates and create new email 
template variations. 

Adding Email Templates Explains how to add new email template variations. 

Viewing Email 
Templates

Describes how to use the options in the View menu of the View Email Template 
page. 

Editing an Email 
Template

Describes how to edit email template definitions and email template content. 
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• About Email Template Status Settings

• Email Template Attributes

• More About Email Template Content

• Merge Tag Example: Repeating Blocks

• Merge Tag Example: Selected Contact

• Merge Tag Example: Maintenance Line Items

• Merge Tag Example: Using IF to Display Conditional Text

• Merge Tag Example: Custom Attributes

• Merge Tag Example: Custom Attributes for Accounts and Users

• Merge Tag Example: CHILD-ONLY

• Special Handling of Alert Email Templates

• Common Email Template Questions

Email Template Types
The Producer Portal includes a number of email template types for producers to use with FlexNet Operations, 
such as the Entitlement Certificate template and the Update Notification Email template. 

Initially, the set of email templates includes only the default variation of each template type. Producers can 
choose to edit the default variation—creating new versions of the default email template—or to add new 
variations of an existing email template type. For some emails that FlexNet Operations sends, users can choose 
from active variations of an email template prior to sending the message. Multiple active variations of a given 
email template type can exist, but each email template variation can only have one active version. (See About 
Email Template Status Settings.) 

There are a number of built-in email template types in FlexNet Operations. You can create one or more variations 
for each email type, but not all template types support the use of custom variations. Custom email template 
variations are supported for only the following email template types: Entitlement, Entitlement Certificate, 
License, Multiple Licenses, Consolidated License, Multiple Consolidated Licenses, Update Notification Email, 
and Product Upgrade Job Email. The original (and in most cases, the only usable) email template for each type 
has a variation name of DEFAULT. 

Template variations must be set to Active and their Send indicators set to true to be used.
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Email Template Types Notes

Approve Entitlement On 
Hold (Portal Admin) 

Entitlements that are created as the result of transferring an entitlement in the End-
User Portal are created with an on-hold status. On-hold entitlements must be 
approved by a producer user before they are deployed. 

An email using this template is triggered when a producer user approves the on-
hold entitlement from the Producer Portal. The email is sent to the partner or 
customer user that initiated the transfer.

Only the default variation of this template is used by FlexNet Operations. 
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Consolidated License FNP certificate or custom technology licenses can be consolidated and downloaded 
or emailed. 

An email using this template is triggered when a single consolidated fulfillment is 
selected and its consolidated license attachment is emailed to the specified email 
addresses from the End-User or Producer Portal, or via web services 
(emailConsolidatedLicenses).

If multiple active variations of this template exist, producers can choose which 
email template variation to use for each license technology. 

Create Entitlement On 
Hold (Portal Admin) 

Entitlements that are created as the result of transferring an entitlement in the End-
User Portal are created with an on-hold status. On-hold entitlements must be 
approved by a producer user before they are deployed. 

An email using this template is triggered and sent to the partner or customer user 
that initiated the transfer when an on-hold entitlement is created in the End-User 
Portal.

Only the default variation of this template is used by FlexNet Operations. 

Create Entitlement On 
Hold (Publisher)

Entitlements that are created as the result of transferring an entitlement in the End-
User Portal are created with an on-hold status. On-hold entitlements must be 
approved by a producer user before they are deployed. 

An email using this template is triggered and sent to a producer email address 
when an on-hold entitlement is created, to notify the producer that the entitlement 
is waiting to be approved. The producer email address is specified in the System 
Configuration setting, System > Configure > FlexNet Operations > General > Email 
for On-Hold Fulfillments or On-Hold Entitlements. 

Only the default variation of this template is used by FlexNet Operations.

Entitlement This email template is used for the body of the email message sent for either a 
single line item or entire entitlement. An entitlement certificate, which uses a 
separate template, can be optionally attached to the entitlement email. 

An email using this template is triggered when an entitlement email is sent to the 
specified email addresses from the End-User or Producer Portal, or via web services 
(emailActivatableItem or emailEntitlement). See the web services documentation 
that describes how email addresses can be specified, validated, and filtered in the 
web service request. 

If multiple active variations of this template exist, producers can choose which 
email template variation to use for each license technology or entitlement.

Note • One or more variations of both this entitlement template and the entitlement 
certificate template must be set to active for FlexNet Operations to send out 
entitlement emails.
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Entitlement Certificate Entitlement emails as described above can optionally include an entitlement 
certificate attachment, depending on the System Configuration setting which is 
enabled by default, System > Configure > FlexNet Operations > General > Always 
Attach Entitlement Certificate in Email. This email template is used for that 
certificate attachment. 

An email with an attachment using this template is triggered when an entitlement 
email is sent to the specified email addresses from the End-User or Producer Portal, 
or via web services (emailActivatableItem or emailEntitlement) if certificate 
attachments are enabled. See the web services documentation that describes how 
email addresses can be specified, validated, and filtered in the web service request.

If multiple active variations of this template exist, producers can choose which 
email template variation to use for each license technology.

Note • One or more variations of both this entitlement certificate template and the 
entitlement template must be set to active for FlexNet Operations to send out 
entitlement emails.

Entitlement Split Partner users can split entitlements to related partner or customer accounts. 

An email with an attachment using this template is triggered when an entitlement is 
split from the End-User Portal, or via web services, if the System Configuration is 
enabled to System > Configure > FlexNet Operations > General > Send Email When 
New Entitlement is Created after Split. The recipient of the email is the contact that 
is specified in the target account distributor tier. If no contact is specified in the 
target tier, no email is sent.

Only the default variation of this template is used by FlexNet Operations.  

Fulfillment License Set Fulfillments for some custom technologies, for example manual technologies, are 
created in FlexNet Operations and license files are generated outside of FlexNet 
Operations. These fulfillments are created with on-hold status and license files are 
set later. 

Emails using this template are triggered when a license generated outside of 
FlexNet Operations is set on a fulfillment and the Send Email is selected when the 
license is set and if the System Configuration setting System > Configure > FlexNet 
Operations > General > Send Email on Set License for On-Hold Fulfillments is 
enabled. The emails are sent to the ship-to email address on the fulfillment and to 
the producer email address is specified in the System Configuration setting, 
System > Configure > FlexNet Operations > General > Email for On-Hold 
Fulfillments or On-Hold Entitlements.

Only the default variation of this template is used by FlexNet Operations. 
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Fulfillment On Hold Fulfillments for some custom technologies, for example manual technologies, are 
created in FlexNet Operations and license files are generated outside of FlexNet 
Operations. These fulfillments are created with on-hold status and license files are 
set later. 

An email using this template is triggered and sent to a producer email address 
when an on-hold fulfillment is created, to notify the producer that the fulfillment is 
waiting for a license to be set. The producer email address is specified in the 
System Configuration setting, System > Configure > FlexNet Operations > General 
> Email for On-Hold Fulfillments or On-Hold Entitlements.

Only the default variation of this template is used by FlexNet Operations. 

License This email template is used for the body of the email message sent with a FlexNet 
Publisher certificate or custom technology license file attachment for a single 
fulfillment. 

An email using this template is triggered when one fulfillment is selected and an 
email is sent to the specified email addresses from the End-User or Producer Portal, 
or via web services (emailLicense). See the web services documentation that 
describes how email addresses can be specified, validated, and filtered in the web 
service request.

If multiple active variations of this template exist, producers can choose which 
email template variation to use for each license technology.

Local Trial An email using this template is triggered when a user Producer Portal sends a 
notification for a FlexNet Publisher Local Trial ASR. (For example, a user can click 
Administer > Local Trial ASRs. Select the check box of the local trial ASR, click 
Email, and specify email addresses.)

Only the default variation of this template is used by FlexNet Operations. 

Multiple Consolidated 
Licenses 

FlexNet Publisher certificates or custom technology licenses can be consolidated 
and downloaded or emailed. 

An email using this template is triggered when multiple consolidated fulfillments 
are selected and their consolidated license attachments are emailed to the 
specified email addresses from the End-User or Producer Portal, or via web services 
(emailConsolidatedLicenses). See the web services documentation that describes 
how email addresses can be specified, validated, and filtered in the web service 
request.

If multiple active variations of this template exist, producers can choose which 
email template variation to use for each license technology.
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Multiple Licenses This email template is used for the body of the email message sent with a FlexNet 
Publisher certificate or custom technology license file attachments for more than 
one fulfillment. 

An email using this template is triggered when multiple fulfillments are selected 
and an email is sent from the End-User or Producer Portal, or via web services 
(emailLicense). See the web services documentation that describes how email 
addresses can be specified, validated, and filtered in the web service request.

If multiple active variations of this template exist, producers can choose which 
email template variation to use for each license technology. 

Order Media An email using this template is triggered when a user in the End-User Portal places 
an order for physical media for files from a selected download package. 

An email is sent to a producer email address configured in System > Configure > 
End-User Portal Setup > Downloads Page > Order media request recipient.

Only the default variation of this template is used by FlexNet Operations. 

Product Upgrade Job 
Email

Used to send email messages to end users for whom FlexNet Operations has 
automatically created upgrade line items. (FlexNet Operations only creates these 
upgrade line items automatically when you have qualifying products and line items 
and have scheduled the Product Version Upgrade job.)

This email template is only triggered by upgrades that result from running the 
Product Version Upgrade job. It is not triggered for manual upgrades nor for bulk 
upgrades.

For details about the Product Version Upgrade job, see FlexNet Operations Alert 
Types.

Producers set the variation of this email template to be used on the Create a 
Product page. (Only active variations of this template can be selected. Draft 
variations are not shown.)

For instructions about specifying a variation to use, see Creating a Product.

Reject Entitlement On 
Hold (Portal Admin) 

Entitlements that are created as the result of transferring an entitlement in the End-
User Portal are created with an on-hold status. On-hold entitlements must be 
approved by a producer user before they are deployed.  

An email using this template is triggered when a producer user rejects the on-hold 
entitlement from the Producer Portal. The email is sent to a partner or customer 
user.

Only the default variation of this template is used by FlexNet Operations. 
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Renewal Intent for End 
Customer

Allows an end user to let the producer know they want to renew an entitlement. 

Emails using this template are triggered when an end user clicks the Request 
button on the End-User Portal Expiring Entitlements page. Copies of the intent-to-
renew email are sent to the end user who initiated the request and also to the 
producer at the address specified for the system configuration setting, System > 
Configure > FlexNet Operations > Renewals > Request Renewal Notification Email.

Unlike other email templates, Renewal Intent for End Customer does not use the 
From address. Instead, the value for From is always the email address of the end 
user who initiates the message. 

Only the default variation of this template is used by FlexNet Operations.

Renewal Reminder If a producer has configured and runs the Expired Entitlements job, producers can 
send Renewal Reminder emails to end users for entitlements that expires in the 
near future. For an end user to receive these emails, they must have the View 
Expiring Entitlements permission and subscribe by selecting the Expiring 
Entitlements Email check box in their user profiles. 

The frequency that this email is sent to a user is based on Configure > FlexNet 
Operations > Renewals > Expiring email frequency. 

Only the default variation of this template is used by FlexNet Operations.

See More About the Expiring Entitlements Job for details.

Renewal Reminder for 
Expired Entitlements

If a producer has configured and runs the Expired Entitlements job, producers can 
send Renewal Reminder emails to end users for entitlements that have expired. For 
an end user to receive these emails, they must have the View Expiring Entitlements 
permission and subscribe by selecting the Entitlements Email check box in their 
user profiles.

The frequency that this email is sent to a user is based on Configure > FlexNet 
Operations > Renewals > Expired email frequency. Each expired entitlement 
appears in only one email message.

Only the default variation of this template is used by FlexNet Operations. 

See More About the Expired Entitlements Job for details.
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Reset Password Used to send email messages when FlexNet Operations must send a system-
generated, temporary password to any user in the FlexNet domain (that is, not LDAP 
users), for logging into either the End-User or Producer Portal.

Emails using this template are triggered when new users request a password, when 
existing active or inactive users forget their password, or when administrators reset 
a user’s password.

Tip • Producers who use single sign-on can prevent FlexNet Operations from 
sending Reset Password email messages by setting Will Email Be Sent? to No on 
the Edit Email Template Definition page.

Only the default variation of this template is used by FlexNet Operations.

Note • This template must always be set to Active unless single sign-on is used.

Short Code An email using this template is triggered when a user Producer Portal sends a 
notification for a FlexNet Publisher Short Code ASR. (For example, a user can click 
Administer > Short Code ASRs. Select the check box of the short code ASR, click 
Email, and specify email addresses.)

Only the default variation of this template is used by FlexNet Operations.

Trusted Activation An email using this template is triggered when a user in the Producer Portal sends a 
notification for a trusted activation request. (For example, a user can click 
Administer > Trusted Activation Requests. Select the check box of the activation 
request, click Email response, and specify email addresses.)

Only the default variation of this template is used by FlexNet Operations.

Update Notification 
Email

An email using this template is triggered when a user in the Producer Portal sends a 
notification email for a download file or download package. (For example, a user 
can click Administer > Send File Notification or Administer > Send Download 
Package Notification.)

If multiple active variations of this template exist, producers can choose which 
email template variation to use for each file or download package notification.
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About Email Template Status Settings
Each email template variation can have one or more versions. There are three possible status settings for an 
email template version: 

• Active—This version is used by the application to send an email. Only one version (per variation) can be 
active at any given time.

• Draft—This version is in the process of edit and review. Changes have been made but it is not ready to be 
used as the active version yet. Only one version (per variation) can be in draft status at any given time.

• Archived—These versions were once the active or draft version of an email template variation but have been 
replaced by newer versions. The system keeps these archived versions of your email template variations, and 
you can always revert to an old version if necessary. 

User Enabled An email using this template is triggered when a user is reactivated through the UI. 
If this template has not been configured with any content, an email with default 
content is sent from FlexNet Operations when the user is reactivated. [Email is 
currently not sent when user is reactivated using the updateUser web service 
operation.]

Only the default variation of this template is used by FlexNet Operations.

Note • This template must always be set to Active unless single sign-on is used.

Welcome Email for End 
Users 

Welcome emails are sent to new users created in the FlexNet domain (that is, not 
LDAP users). An email using this template is triggered when a customer, partner, or 
self-registered user is created in the End-User or Producer Portals, or via web 
services (createUser). 

Producers who use single sign-on typically make this template inactive. Otherwise, 
the default variation of this template must be active to support basic functionality of 
FlexNet Operations. 

Producers who want to offer trial registration to their end users can create a 
variation of this template to use specifically for trial registrations. This variation 
name is then used in the custom content page, based on the TrialRegistration 
custom content template, in place of {{formData.emailTemplate}}. 

See About Product Trial Registration Support and About Trial Products for more 
information.

Welcome Email for 
Producers

Welcome emails are sent to new producer users created in the FlexNet domain 
(that is, not LDAP users). An email using this template is triggered when a producer 
user is created in the Producer Portal or via web services (createUser). 

Only the default variation of this template is used by FlexNet Operations, and the 
default variation of this template must be active to support basic functionality of 
FlexNet Operations.
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Email template versions are set to Active or Draft status, depending on how they are saved on the Edit Email 
Template page. There is no separate status-setting control in the Producer Portal. 

When you create or edit an email template, you can choose to save it as the Active version or the Draft version of 
that template variation. If version of the same template variation already exists in the same state, its state 
becomes Archived. To return an archived email template version to Draft or Active status, open its Edit Email 
Template page and save it as the Active or Draft template according to your needs. 

Email Template Attributes
An email templates consist of

• Email Address:

• From: Whom the email is sent from. The application uses an email alias specific to your site for this.

• TO: The email address that appears as the addressee in the To field of the actual email message.

• Reply To: Typically the same as the From. When the user replies to the email sent out by the system, this 
is the email address to which the email is sent.

• CC: Who is copied on outgoing emails. Typically used for all people who want to monitor the correct 
working of your site.

• BCC: Same as CC, except that the recipients are not visible to each other.

• Email Template Content:

• Subject: The subject of the email, you can change this field.

• Text Content and HTML Content: The message content of the email. The body of the email can be HTML 
content or text content. Depending on your preferences, you can use one or the other, or both. When you 
use HTML, make sure you enter valid HTML. (You can write this content with an external HTML editor and 
then copy it into the body field). If you choose to fill out both types of content, the recipient, your 
customer, receives both types of content as well.

More About Email Template Content
The text of the email template body (Text Content and HTML Content) and the Subject can be of two types:

• Fixed text: Text that is the same for all the receivers of the email; this is text that you can change.

• Merge tags for user-dependent information: Information that is different for each receiver of the email, such 
as first and last name, company name, and order number. In an email template, this information is shown as 
a merge tag. You can place the merge tags in the body and the subject of the email. Before an email is sent, 
these merge tags are replaced with the data specific to the recipient of the email. When you edit an email 
template, the Producer Portal shows the merge tags that are available for the current email template in the 
Merge Tags List. (Some email templates require specific merge tags, meaning that you must use the tag at 
least once in the body of the email.) Not all merge tags are available for all email templates. The list varies by 
template.

Tip • To avoid errors, copy the merge tag from the Merge Tag List and paste it in the body or subject area. 
Merge tags must be opened and closed with double square brackets, like this: [[MERGE_TAG]]. 
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Note • The merge tags [[AcctId]] and [[FOR-EACH TAG=”SoldToAcct”]] and [[OrgName]] and [[FOR-EACH 
TAG=”SoldToOrg”]] tags are functional duplicates. [[AcctId]] and [[FOR-EACH TAG=”SoldToAcct”]] are the 
preferred tags. [[OrgName]] and [[FOR-EACH TAG=”SoldToOrg”]] are deprecated tags that have been retained 
for backward compatibility. 

See the merge tag examples in the following sections. 

Merge Tag Example: Repeating Blocks
The Producer Portal allows you to set up repeating blocks of content to, for example, display an order with 
multiple order lines. To do this, start by creating the content that you need for one order line. Then put the [[for-
each]] tag at the beginning of this block and the [[end for-each]] at the end of the block. 

[[FOR-EACH TAG="EntitlementLineItem"]]
            [[OrderID]]
            Activation ID: [[ActivationID]]
            Quantity: [[SeatCount]]
            Start Date: [[StartDate]]
            Expiration: [[ExpirationDate]]
[[END FOR-EACH]]

Merge Tag Example: Selected Contact
The SelectedContact merge tag enables users to include additional criteria when defining contact information for 
an entitlement.

[[FOR-EACH TAG="Entitlement" child-only="true"]]
      [[FOR-EACH TAG="ChannelPartners" child-only="true"]]
          [[FOR-EACH TAG="ChannelPartner"]]
               Partner Tier Name: [[PartnerTierName]]
               Acct Display Name: [[Name]]
               Acct Name : [[AcctId]]
               [[FOR-EACH TAG="SelectedContact" child-only="true"]]
                    Contact Name: [[ContactName]]
                    Firstname: [[Firstname]]
                    Lastname: [[Lastname]]
                    Country: [[Country]]
                    Email: [[Email]]
               [[END FOR-EACH]]
          [[END FOR-EACH]]
     [[END FOR-EACH]]
[[END FOR-EACH]]

Important • Only use the Contact merge tag inside the FOR-EACH entitlement loop to populate the contact. Do not 
use the Contact merge tag to populate all organization contacts.

Merge Tag Example: Maintenance Line Items
The LinkedMaintenanceLineItems and MaintenanceLineItem merge tags enable users to iterate through 
maintenance line items.

[[FOR-EACH TAG="Entitlement" child-only="true"]]
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     [[FOR-EACH TAG="ChannelPartners" child-only="true"]]
          [[FOR-EACH TAG="ChannelPartner"]]
               Partner Tier Name: [[PartnerTierName]]
               Acct Display Name: [[Name]]
               Acct Name : [[AcctId]]
               [[FOR-EACH TAG="SelectedContact" child-only="true"]]
                    Contact Name: [[ContactName]]
                    Firstname: [[Firstname]]
                    Lastname: [[Lastname]]
                    Country: [[Country]]
                    Email: [[Email]]
               [[END FOR-EACH]]
          [[END FOR-EACH]]
     [[END FOR-EACH]]
     [[FOR-EACH TAG="EntitlementLineItems" child-only="true"]]
          [[FOR-EACH TAG="EntitlementLineItem" child-only="true"]]
               ActivationID: [[ActivationID]]
               Order ID: [[OrderID]]
               Quantity: [[SeatCount]]
               Start Date: [[StartDate]]
               Expiration Date: [[ExpirationDate]]
               Permanent: [[Permanent]]
               Duration :
               Length: [[Length]]
               Units: [[Units]]
               [[FOR-EACH TAG="LinkedMaintenanceLineItems" child-only="true"]]
                    [[FOR-EACH TAG="MaintenanceLineItem" child-only="true"]]
                         Maintenance Activation Id: [[ActivationID]]
                         Order ID: [[OrderID]]
                         Quantity: [[SeatCount]]
                         Start Date: [[StartDate]]
                         Expiration Date: [[ExpirationDate]]
                         Permanent: [[Permanent]]
                         State: [[Status]]
                         [[FOR-EACH tag="Product"]]
                              Maintenance Product: [[Name]]
                         [[END FOR-EACH]]
                    [[END FOR-EACH]]
               [[END FOR-EACH]]
          [[END FOR-EACH]]
     [[END FOR-EACH]]
[[END FOR-EACH]]

Merge Tag Example: Using IF to Display Conditional Text
You can make some email content conditional with the use of IF tags. 

[[IF TAG="OrgType" value="PUBLISHER"]] 
You can now login to your FlexNet Producer account by clicking this link: https://<siteID>-fno-
uat.flexnetoperations.com/flexnet/operations/logon.do 
 [[ELSE]] 
You can now login to your FlexNet End User Portal account by clicking this link: https://<siteID>-fno-
uat.flexnetoperations.com/flexnet/operationsportal/logon.do 
[[END ELSE]]  
After your initial login, you will be prompted to change this password. 
If you have problems with your account, please contact your Administrator. 
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Best Regards,  
Administrator

[[END IF]]

Using the "no value" clause:

[[IF TAG="ServerIDs" VALUENOT=""]]
                 Server Ids : [[ServerIDs]]
[[END IF]]
[[IF TAG="NodeLockedIDs" VALUENOT=""]]
                 Node Locked Ids : [[NodeLockedIDs]]
[[END IF]

Merge Tag Example: Custom Attributes
If you use custom attributes, you can also use them in your email templates. 

Look in the list of Merge Tags and see if you find a tag like this "[[ENT_CA]]". If that tag is in the list of allowed 
tags, you can add any custom attribute (CA) that is defined on that level in your Email Template (in the example, 
that would mean you can use Entitlement CAs but not Member CAs). 

Because you can have many custom attributes, you must add the CA-ID to properly identify the custom attribute 
to use. If you do not know the value of the CA-ID, go to the Custom Attributes page in the Producer Portal. 

Here is the login and password to [[ACCOUNT_NAME]]'s XXXXXXXX Download Center 
site:

[[IF TAG="ENT_CA" CODE="SHIP_LANGUAGE" VALUE="US"]]
Dear [[DisplayName]]

Thank you for your order. 

Your Activation ID is: [[ActivationID]]

The Activation ID will be required to login. You will also need the Hostid of the computer with which 
this license will be associated.

If you have any questions, contact your local XYZ Corporation office.
[[END IF]]

[[IF TAG="ENT_CA" CODE="SHIP_LANGUAGE" VALUE="FR"]]
Cher [[DisplayName]],

Nous vous remercions de votre commande.
 
Votre code d’activation : [[ActivationID]]
 
Le code d’activation est nécessaire pour vous connecter. Vous aurez également besoin de l’adresse d’hôte 
de l’ordinateur pour lequel la licence sera associée.
 
Si vous avez des questions, n’hésitez pas à contacter le bureau XYZ corp le plus proche.
[[END IF]]
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Merge Tag Example: Custom Attributes for Accounts and Users
The Welcome Email templates for end users and producers can also be customized using custom attributes for 
accounts and users. Look in the Merge Tag List for  the tags [[ACCOUNT_CA]] and [[USER_CA]].

The following example shows how to use the FOR-EACH tag to iterate through accounts:

Dear [[DisplayName]],

[[FOR-EACH TAG="Accounts"]]  
[[FOR-EACH TAG="Account"]]

[[IF TAG="ACCOUNT_CA" CODE="REGION" VALUE="EU"]]

Welcome to XXXXXXXX

[[END IF]]

[[END FOR-EACH]]
[[END FOR-EACH]]

Please note that your FlexNet account UserID: [[UserId]] password has been set to [[Password]].

You can now login to your FlexNet Producer account by clicking this link: https://<siteID>-fno-
uat.flexnetoperations.com/flexnet/operations/logon.do 

After your initial login, you will be prompted to change this password. 
If you have problems with your account, please contact your Administrator. 

Best Regards,  
XXXXXXXX

Note • The custom attribute for accounts (tag [[ACCOUNT_CA]]) can also be used with the Reset Password, 
Entitlement, and Entitlement Certificate templates.

Merge Tag Example: CHILD-ONLY
Useful when the logical flow of the merge tags in an email template encompasses multiple FlexNet Operations 
entities (such as entitlements and entitlement line items, accounts and members, and the like) and the same 
attribute is present in two or more of the entities, CHILD-ONLY, allows you to restrict the evaluation of a condition 
to a particular entity. 

For example, the Status tag exists for both entitlements and entitlement line items. In a FOR-EACH loop of 
entitlement line items, you might want to force the parser to look for the Status tag only in the entitlement line 
item rather than allowing it to consider the Status tag value in the parent entitlement. 

[[FOR-EACH TAG="EntitlementLineItem"]]
[[IF TAG="Status" VALUE="Deployed" CHILD-ONLY="true"]]
...
[[END IF]]
[[END FOR-EACH]]
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Special Handling of Alert Email Templates
Email templates for alerts are managed differently from most other email templates. While the templates for 
sending license certificates, entitlement certificates, shortcode ASRs, and so forth are managed through the 
Producer Portal UI, the alert email templates can be customized only by directly accessing the alert email 
template files.

Alert email templates are located in the <ops_install_dir>/webapp/templates directory. The name of an alert 
email template is usually composed of the following elements: 

• The FlexNet module in which the alert is defined, for example, operations

• A name that reflects the purpose of the alert, such as expiringEntitlements or 
userDeactivationAlertTemplate

For example, the template operations.changedProductsTemplate.xsl is defined in FlexNet Operations to send 
alert messages when a product’s features or feature bundles change (Updated Products alert). 

FlexNet Operations enables you to manage each alert email template individually. You can customize one 
template while leaving the other templates untouched, and FlexNet Operations uses the custom alert email 
template you provided while employing the default templates for the other alert emails. 

Table 20-86 • Alert Email Templates

Template Name Description

genericAlert.xsl Used if an alert has no named template of its own.

genericAlert.xsl is used in place of the templates listed in the 
FlexNet Operations user interface for emailing the Info Available and 
Update Available alerts. These are 
platform.updates.infoAvailableAlertTemplate.xsl and 
platform.updates.updateAvailableAlertTemplate.xsl. If you want to 
customize these alert emails, create files with these names.

operations.changedProduct
Template.xsl

Email template for Updated Products alert. 

Configurable Properties:

<alerts>
<alert> 

<properties>
<suiteName>
<suiteVersion>
<suiteState>
<lastUpdated>
<productInfo>

</properties>
</alert>

</alerts>
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operations.expiringEntitlements
Template.xsl

Email template for Expiring Entitlements alert.

Configurable Properties:

<alerts>
<alert> 

<properties>
<activationId>
<soldToAcct>
<soldToOrg>
<product>
<expireDate>

</properties>
</alert>

</alerts>

operations.importBulkWebRegKeys
Template.xsl

Email template for Importing Bulk Entitlement Web Register Keys 
alert.

Configurable Properties:

<alerts>
<alert> 

<properties>
<importWebRegKeysFailed>  // yes or no strings
<importWebRegKeysRequestID>
...
<numberOfWebRegKeysAdded>  
...
<importWebRegKeysError>

</properties>
</alert>

</alerts>

Note: <importWebRegKeysError> is populated only if you set 
<importWebRegKeysFailed> to yes.

operations.importSkusTemplate.xsl Email template for Importing Part Numbers alert. 

Configurable Properties:

<alerts>
<alert> 

<properties>
<importPartNumbersRequestID>
<numberOfPartNumbersAdded>
<numberOfPartNumbersFailed>

</properties>
</alert>

</alerts>

platform.userDeactivationAlert
Template.xsl

Email template for the User Deactivated alert.

Table 20-86 • Alert Email Templates

Template Name Description
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Common Email Template Questions
Here are some common questions about email template management:

• The extra white space (like returns and extra lines) is not showing. Why? 

You are writing HTML mail and therefore you must use the <br> and <p> tags to create your line breaks and 
paragraph breaks.

• I want to include an image from my company, how can I do that? 

Use the image tag like you would on an HTML page, but ensure that the SRC parameter is a full path that 
points to the image on your own web server. There is no need to upload these images to FlexNet Operations.

• Why do I still see a merge tag when I preview email template content? I thought all merge tags would be 
replaced. 

There is probably an error in the brackets and therefore the application does not consider it a merge tag and, 
as a result, leaves it unchanged. Merge tags must be opened and closed with a double square bracket like 
this: [[MERGE_TAG]].

Read the email carefully and verify that all the merge tags are replaced with preview values. Ensure that the 
sentences make sense when the merge tags are replaced with real content. If you are satisfied with the 
result you can save the email template as an Active or as a Draft template. 

Listing Email Templates 
You can show all email templates by clicking the Email Templates link in the System menu. 

Task To list all email templates

• Click Administer > Templates.

The Producer Portal opens the Templates page. From this page, you can click on the ID of an email template 
variation to view or modify that variation. See About Email Templates for a list of email template types. 

Adding Email Templates 
You can add email template variations from the Administer menu.

Tip • FlexNet Operations supports the use of custom email template variations only for license technology emails.

Before saving an email template variation, you preview the way the final mail message will appear to its 
recipients. Prior to showing the preview page, the system validates any merge tags included in the email 
template content. If any invalid merge tags are used, the Producer Portal returns you to the edit page. Otherwise, 
the preview page shows how the email appears for recipients, replacing the merge tags with preview values. 
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Task To add an email template

1. Click Administer > Add Email Template. The Producer Portal opens the Add Email Template Variation page. 

2. For Variation Name, type a short description (maximum 25 characters) for this email template variation. 
The original email template has a variation name of DEFAULT. 

3. Choose an Event Type. The event type reflects the email template type name shown on the List Email 
Templates page. 

4. Click Add Template. The Producer Portal opens the Edit Email Template Content page. 

5. In Email Template Content, insert a subject line plus text content or HTML content (or both). 

Email template content can make use of merge tags to substitute specific values at the time the email 
message is generated. For examples of merge tag use, see About Email Templates. 

Tip • To avoid errors, copy the merge tag from the Merge Tag List and paste it in the body or subject area. 
Merge tags must be opened and closed with double square brackets, like this: [[MERGE_TAG]]. 

6. Click Validate Template. The Producer Portal validates the merge tags in the template content and opens the 
preview page for the email template variation. 

Tip • When you click Validate Template, the Producer Portal only validates the merge tags in the template 
content. It does not validate your HTML. 

7. Complete the email creation process by saving the variation or returning to the edit page for additional 
changes. 

• Click Save to save the current version as the Active template for this email template variation. 

• Click Save Draft to save the current version as the Draft template for this email template variation.

• Click Back to Edit to return to the edit page.

When you save it as a Active template, the Producer Portal uses it for all the email of that variation from then on. 
If you save it as Draft, you can go back to this version at a later time, change it, and save it as the Active version. 
If you want to make more changes, click Back to Edit.

Tip • The name you provide for Variation Name distinguishes your variation from the default variation of that same 
template type. When you create or edit a license technology, you can specify customized variations of selected 
template types to use with that license technology by providing their variation names. See Creating a License 
Technology. 
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Viewing Email Templates 
You can view an email template in the Producer Portal and, from its View Email Template page, you can also 
choose to view as an active template, view as draft, or list all versions of that template (archived, active, and 
draft). 

Viewing Active and Viewing Draft
From the List Email Templates page, you can view any of the listed template versions by clicking its template ID. 

The Producer Portal clearly identifies whether the email template version you are viewing is in draft status versus 
active status. Links for opening the View Email Template page also reflect the template’s status. When a template 
is in draft status, its view page is View Draft Email Template and the link in the View menu to return to the basic 
view page is View Draft.

When working with email templates, you can return to the basic view page by clicking View Active or View Draft in 
the on-page View menu. 

Task To view an email template

• From the View Email Template page, click View > View Active or View > View Draft. 

The Producer Portal shows the View Email Template page for the current email template.

Listing All Versions
There can be a number of versions for each email template variation. A variation can have one active version, one 
draft version, and several archived versions. 

Task To view all versions of an email template

• On the View Email Template page, click View > List All Versions. 

The Producer Portal opens the List All Versions page. From this page, you can click the status of any listed email 
template version to open its View Email Template page.

Editing an Email Template 
From the View Email Template page, you can edit an email template. Editing is divided into two primary tasks:

• Editing an Email Template Definition 

• Editing Email Template Content

Editing an Email Template Definition
An email template’s definition includes its email template ID, its email type, its variation name, and its send 
indicator. Only the variation name and the send indicator are editable on this page. 
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Task To edit an email template definition

1. On the View Email Template page, click Edit > Edit Definition. This link opens the Edit Email Template 
Definition page.

2. Make email template definition changes as necessary: 

• Variation Name—Change the name of the email template variation.

• Will Email Be Sent—Choose whether email messages based on this template is sent. 

• Click Yes to enable email messages for this template to be sent. When the send indicator is Yes, the 
Producer Portal’s default behavior is to attempt to send the email. (Email can be suppressed on 
certain transactions or by the preferences of the recipients.)

• Click No to prevent email messages based on this template from being sent.

• View Email in Sent history—Choose whether the content of an email is visible from the View Sent Email 
page of the Producer Portal.

• Click Yes to enable the content to be viewed.

• Click No and only the “To,” “CC,” and “BCC” fields are visible.

Note • The Welcome Email and Reset Password templates default to No and, because they contain sensitive 
password information, are not permitted to be viewed.

3. Click Save Template.

The Producer Portal saves your definition changes to the email template. (No changes occur to the email 
template’s status. Active templates remain active. Draft templates remain in Draft status.)

Editing Email Template Content
Email template content includes the template’s subject line, text content, and HTML content. 

Task To edit email template content

1. On the View Email Template page, click Edit > Edit Draft Content or Edit > Edit Active Content. This link 
opens the Edit Email Template Content page.

2. In Email Template Content, insert a subject line plus text content or HTML content (or both). 

Email template content can make use of merge tags to substitute specific values at the time the email 
message is generated. For examples of merge tag use, see About Email Templates. 

Tip • To avoid errors, copy the merge tag from the Merge Tag List and paste it in the body or subject area. 
Merge tags must be opened and closed with double square brackets, like this: [[MERGE_TAG]]. 

3. Click Validate Template. The Producer Portal validates the merge tags in the template content and opens the 
preview page for the email template variation. 
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Tip • When you click Validate Template, the Producer Portal only validates the merge tags in the template 
content. It does not validate your HTML. 

4. Complete the email creation process by saving the email template or returning to the edit page for additional 
changes. 

• Click Save to save the current template as the Active template for this email template type. 

• Click Save Draft to save the current template as the Draft template for this email template type.

• Click Back to Edit to return to the edit page.

When you save it as a Active template the Producer Portal uses it for all the email of that type from then on. If you 
save it as Draft, you can go back to this version at a later time and change it and save it as the Active template. If 
you want to make more changes click Back to Edit.
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