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Introduction
This Release Notes document summarizes the features, enhancements, and updates delivered with 
FlexNet Operations 2025 R1 On-Premises in October 2025. The document includes the following 
information:

• Resources

• Features and Enhancements

• System Requirements

• Resolved Issues

• Known Issues

• Special Notes

• Legal Information

Resources
These resources are available for more information about FlexNet Operations and other Revenera 
products:

• Revenera Resources

• FlexNet Operations Videos

Revenera Resources
The following resources can help you stay up to date with FlexNet Operations news and product 
knowledge:

• In addition to providing case management, the Revenera Community site can help you quickly find 
answers to your questions by searching content from other customers, product experts, and 
thought leaders. You can also post questions on discussion forums for experts to answer. For 
each of Revenera’s product solutions, you can access forums, blog posts, and knowledge base 
articles. You can also access the Product and License Center from the Community’s Other 
Resources menu to download Revenera products.

• You can find documentation for FlexNet Operations and all other Revenera products on the 
Revenera Product Documentation site.

• The Revenera Learning Center offers free, self-guided, online videos to help you quickly get the 
most out of your Revenera products. You can find a complete list of these training videos in the 
Learning Center. 

• Customers who have purchased a maintenance contract for their product(s) can submit a support 
case or check the status of an existing case by making selections on the Get Support menu of the 
Revenera Community:

https://community.revenera.com

https://community.revenera.com
https://docs.revenera.com
https://learning.revenera.com
https://community.revenera.com
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FlexNet Operations Videos
These brief, informative videos walk you through the getting-started exercises found in the FlexNet 
Operations User Guide (online help or PDF version). We recommend that you first read the appropriate 
“Getting Started” section in the User Guide to gain an understanding of the concepts it covers, and 
then click the section title in the table below to view the video.  

Features and Enhancements
Features and enhancements were added to the following areas of FlexNet Operations On-Premises in 
the 2025 R1 release:

• Account and User Management Enhancements

• Entitlement Management Enhancements

• Electronic Software Delivery Features & Enhancements

• Embedded Devices Enhancement

• Export and Import Enhancements

Guide Topics

Getting Started with 
Entitlement Management

Creating an account, a user, a product, and an entitlement. 

Getting Started with FlexNet 
Embedded Licensing

Setting up a publisher, identity, and a licensed product. Creating a 
device and activating its license. Creating and provisioning FlexNet 
Embedded license servers. 

Getting Started with 
Electronic Software Delivery

Creating a producer and download packages, associating 
download packages with a product, creating files, associating files 
with download packages, and viewing and downloading files from 
the FlexNet Operations End-User Portal. 

Getting Started with Usage 
Management

Creating a usage-based license model, a feature, a product, and an 
entitlement. Obtaining the license server URL to which the usage 
data is sent. Running a usage-capture client. Viewing usage 
information graphs and gauges.

Getting Started with FlexNet 
Publisher License File-Based 
Licensing

Activating and returning a certificate license.

Getting Started with Cloud 
Licensing Service

Creating a cloud-hosted license server. 

Getting Started with FlexNet 
Customer Growth

Customer growth concepts and configuring notifications for 
expiring entitlements and expired entitlements. 

https://youtu.be/L_DJynsiCRs
https://youtu.be/6-juN9F9OBo
https://www.youtube.com/watch?v=VGnH8dFj_bE
https://youtu.be/1rPRl-NKgJY
https://youtu.be/-OHqqD62fyk
https://www.youtube.com/watch?v=MNX5bgFHPVg
https://youtu.be/u0oCCN-iXJU
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• Device Management Enhancements

• SOAP and REST Web Services Enhancements

• Security Enhancements

• User Experience Enhancements

Account and User Management Enhancements
The following enhancement involving the management of accounts and users was added in the 2025 
R1 release.

Removing Metered Features Used Count from CLS Instance
(Cases 02821334, 02830341, 02830896, 02863229; SWM-19670) 

A new configuration option Allow removing used count (under System > Configure > FlexNet 
Operations > Embedded Device Settings) has been introduced which enables producers to allow the 
removal of used counts for a metered feature from a Cloud License Server (CLS) instance.

By default, the new configuration option is disabled, meaning that removing used counts for a metered 
feature is not allowed. 

The new configuration gives producers flexibility during license migration, where they need to unmap 
the full count of activation IDs and re-map them to a new device.

Entitlement Management Enhancements
The following enhancements to entitlement management were added in the 2025 R1 release:

• Marking Custom License Attributes as Inactive

• New Merge Tag for Line Item Creation Date in Email Templates

• Merge Tags Added to Fulfillment On Hold Email Template to Improve Communication

• Grouping Product Information in Entitlements Email Template

• Instance ID Merge Tag Now Available in Entitlement Email Template

• “/features” Endpoint Returning Product Information

• Retaining Filtered Products When Configuring Line Items

• Ability to Limit Activation of FlexNet Embedded Nodelocked Licenses to Servers and/or 
Standalone Devices

• CONTAINER_ID Host ID Now Available for Docker Containers

• Advanced Search for Entitlements Includes Custom License Models

• Allow Renewal License to Start Upon Expiry of Parent License

• New “Features” Column on List Entitlements Page

• Inactive Line Items Can Now Be Changed to Draft to Allow Editing
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• Warning Message When Activating Licenses for Upgrade Line Items

• Confirmation Message Displayed After Merging Entitlements

• Error Message When Activating Obsolete/Inactive Line Items

• Visibility of Product Lines Created by Other Producer Users

• Changing the Prefix for Trial Activation IDs

• Overhaul of the “Show Line Items with Zero Copies by Default” Configuration Option

Marking Custom License Attributes as Inactive
(Case 02760824, SWM-20139)

Custom license attributes—either license generator attributes or license model attributes—can now be 
marked as Inactive. Producers might want to make custom license attributes inactive if they should no 
longer be available for selection when creating an entitlement or fulfillment.

License generator attributes and license model attributes can have their status set on the Create A 
License Generator Attribute or Create A License Model Attribute page, respectively. Producers can set 
the status when creating or editing the custom license attribute. 

The Custom License Attributes page (under Administer > Custom License Attributes) displays the 
attribute status in the new Status column. By default, the Custom License Attributes page shows only 
active attributes. To display all attributes, click the Show All link.

Note • Attributes that are predefined in FlexNet Operations cannot be made inactive.

New Merge Tag for Line Item Creation Date in Email Templates
(Case 02866308, SWM-21436)

A new merge tag [[LineItemCreationDate]] has been added to the Entitlement, Entitlement 
Certificate, and License email templates. This tag enables producers to insert the line item’s creation 
date into the relevant email.

Merge Tags Added to Fulfillment On Hold Email Template to Improve 
Communication
(SWM-25684)

When an on-hold fulfillment is created, an email can be triggered to notify the producer that the 
fulfillment is waiting for a license to be set. The Fulfillment On Hold template, on which such an email 
would be based, has now been enhanced to include additional merge tags to include relevant details. 
(Previously, the only merge tag available in this template was [[FulfillmentID]].)
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List of Merge Tags in Fulfillment On Hold Template

The following table lists all merge tags currently available in the Fulfillment On Hold template. 

Sample Code for Fulfillment On Hold Template

This sample shows how the merge tags could be used in the Fulfillment On Hold template.  

Merge Tag Description Example Preview Value

[Acctld]] Account ID ACME

[[AcctName]] Account Name MYORG

[ACTIVATION_DATE]] Activation Date Feb 28, 2007

[[ActivationID]] Activation ID 9e8f-8b6f-0fbf-4488-950b-
e4a5-1bfe-e73c

[[EntitlementID]] Entitlement ID bf1a-1191-4957-46aa-4f7f-fe

[[EXPIRATION_DATE]] Order Line - Last day that 
the object is effective 
(exclusive)

2/1/2003

[[FulfillmentCount]] Fulfillment Count < FulfillmentCount >

[[FulfillmentID]] Fulfillment ID < FulfillmentID >

[[LICENSE_MODEL_ATTRIBUTES]] License Model Attributes < LICENSE_MODEL_ATTRIBUTES >

[[LICENSE_MODEL_NAME]] License Model Name < LICENSE_MODEL_NAME >

[[LicenseTechnology]] License Technology FlexNet Licensing

[[OverdraftCount]] Overdraft Count < OverdraftCount >

[[PartnerTierName]] Partner Tier Name End Customer

[[PartNumber]] Part Number PartNumberOne

[[PRODUCT_NAME]] Product Name Test Product

[[PRODUCT_VERSION]] Product Version 7.6

[[ShipToAddress]] Ship To Address < ShipToAddress >

[[ShipToEmail]] Ship To Email < ShipToEmail >

[[START_DATE]] Start Date < START_DATE >
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License text has not been set for the following generated fulfillment. The administrator was 
notified. You will receive an email when the license is ready to download. <br/>
------------------------------------------------------------------------------<br/>
Fulfillment On Hold<br/>
------------------------------------------------------------------------------<br/>
FulfillmentID = <b>[[FulfillmentID]]</b><br />
Activation ID: [[ActivationID]]<br />
Entitlement ID: [[EntitlementID]]<br />
------------------------------------------------------------------------------<br/>
Sold to AccountName:  [[AcctName]]<br />      
Sold to AccountID:  [[AcctID]] <br/>
ChannelPartnerDetails: <br/>
[[PartnerTierName]]: <br /> 
------------------------------------------------------------------------------<br/>
ProductName:  [[PRODUCT_NAME]] <br/>       
ProductVersion: [[PRODUCT_VERSION]] <br/>
PartNumber: [[PartNumber]] <br/>
LicenseTechnology: [[LicenseTechnology]] <br/>
LicenseModel: [[LICENSE_MODEL_NAME]] <br/> 
------------------------------------------------------------------------------<br/>
LicenseModelAttributes: <br/>
[[LICENSE_MODEL_ATTRIBUTES]] <br/>
------------------------------------------------------------------------------<br/>
StartDate: [[START_DATE]] <br/>
ExpirationDate: [[EXPIRATION_DATE]] <br/>
FulfillmentDate: [[ACTIVATION_DATE]] <br/>
------------------------------------------------------------------------------<br/>
OverdraftCount :[[OverdraftCount]] <br/>
FulfillmentCount : [[FulfillmentCount]] <br/>
------------------------------------------------------------------------------<br/>

Sample Email Based on the Fulfillment On Hold Template

The code above would result in an email similar to the following:
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Figure 1: Example of an email with detailed fulfillment information, based on the Fulfillment On Hold 
template. 

Grouping Product Information in Entitlements Email Template 
(Cases 02749254, 02956269; SWM-21546)

This release introduces a new merge tag [[FOR-EACH tag="EntitledProductLine"]] for the 
Entitlement email template. This tag can be used to group all the products from a product line along 
with information about each product in the Entitlement email that customers will receive. 

Use of the new merge tag is controlled by the configuration option Allow grouping of product 
information based on product line in entitlement email template (under System > Configure > FlexNet 
Operations > General Options). By default, this option is disabled.

This enhancement gives producers more flexibility when structuring their entitlement emails. 
Depending on whether the configuration option is selected or unselected, the Entitlement email can 
either:

• iterate the product line and print product information, or

• iterate the product and print product line information. 
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The following examples illustrate the different Entitlement emails that can be generated:

• Configuration Option Selected, Iterating Product Lines

• Configuration Option Unselected, Iterating Products

Configuration Option Selected, Iterating Product Lines  

The following example code shows how to use the merge tag [[FOR-EACH 
tag="EntitledProductLine"]] to iterate through product lines and then iterate the products for each 
product line, along with sample output.

[[FOR-EACH TAG="Entitlement" child-only="true"]]
[[FOR-EACH TAG="EntitlementLineItem"]]

[[IF TAG="LicenseGenerator" VALUE="demo"]]
[[FOR-EACH tag="EntitledProductLine"]]

Product Line - [[ProductLine]]
[[FOR-EACH tag="EntitledProduct"]]

Product Name: [[Name]]
Product Description: [[Description]]

[[END FOR-EACH]]
[[END FOR-EACH]]

Part Number: [[PartNumber]]
Permanent: [[Permanent]]
Start Date: [[StartDate]]
Expiry Date: [[ExpirationDate]]
ActivationID: [[ActivationID]]

[[END IF]]
[[END FOR-EACH]]

[[END FOR-EACH]]

A resulting Entitlement email might look like this:
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Figure 2: Entitlement email using the [[FOR-EACH tag="EntitledProductLine"]] merge tag

Configuration Option Unselected, Iterating Products

When the configuration option Allow grouping of product information based on product line in 
entitlement email template is unselected, the merge tag [[FOR-EACH tag="EntitledProduct"]] 
iterates through products and includes product line information. Below is some sample code and an 
example of a resulting Entitlement email.

[[FOR-EACH TAG="Entitlement" child-only="true"]]
[[FOR-EACH TAG="EntitlementLineItem"]]

[[IF TAG="LicenseGenerator" VALUE="demo"]]
[[FOR-EACH tag="EntitledProduct"]]

Product Name: [[Name]]
Product Description: [[Description]]
Product Line: [[ProductLine]]

[[END FOR-EACH]]
Part Number: [[PartNumber]]
Permanent: [[Permanent]]
Start Date: [[StartDate]]
Expiry Date: [[ExpirationDate]]
ActivationID: [[ActivationID]]

[[END IF]]
[[END FOR-EACH]]

[[END FOR-EACH]] 

A resulting Entitlement email might look like this:
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Figure 3: Entitlement email using the [[FOR-EACH tag="EntitledProduct"]] merge tag.

Instance ID Merge Tag Now Available in Entitlement Email Template
(Case 02875263, SWM-21918)

Previously, the merge tag [[DEFAULT_GLS_INSTANCE_ID]] (available in the Entitlement email template)  
could only be included above the email text, but not in the email within LicenseModel or 
EntitlementLineItem tags. 

In the 2025.01 release, the merge tag [[DEFAULT_GLS_INSTANCE_ID]] can be nested inside the 
LicenseModel or EntitlementLineItem tag, and producers can now insert the Cloud Licensing Service 
(CLS) instance ID into the table in an Entitlement email. (This allows an Entitlement email, for example, 
to contain a table with rows for each line item, and to specify the CLS ID in the rows related to the CLS.)

The following sample shows how the merge tag [[DEFAULT_GLS_INSTANCE_ID]] is nested inside the 
EntitlementLineItem tag:

[[FOR-EACH TAG="EntitlementLineItem"]]
[[DEFAULT_GLS_INSTANCE_ID]]

[[END FOR-EACH]]

“/features” Endpoint Returning Product Information
(SWM-19716) 

Previously, any licensing information that is passed between FlexNet Operations and a FlexNet 
Embedded license server was feature centric. This could make it difficult for producers and their 
customers to see which products are currently licensed, and which licenses are available on the 
license server. 
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To address this challenge, the 2025 R1 release includes an enhancement where a number of 
endpoints for FlexNet Embedded license servers (local license servers and Cloud License Server 
instances) now return additional product-related information. 

Returned Product Information

The following product information can be returned:

• Product Name

• Product Version

• Activation ID

• Entitlement ID

List of Endpoints

The following endpoints can return product information:

• /api/1.0/instances/{instanceid}/features 

• /api/1.0/instances/{instanceid}/features/{id}

• /api/1.0/instances/{instanceid}/features/{id}/clients

• /api/1.0/instances/{instanceid}/features.stream

• /api/1.0/instances/{instanceid}/clients/

• /api/1.0/instances/{instanceid}/features/summaries

• /api/1.0/instances/{instanceid}/partitions (under feature slices)

• /api/1.0/instances/{instanceid}/partitions/{id} (under feature slices)

• /api/1.0/instances/{instanceid}/clients/{id}/features

• /api/1.0/instances/{instanceid}/clients/id

Query Parameter to Return Product Information

To return product information in the /features endpoint, pass the query parameter 
includeEntitlementInfo=true.

Example:  https://hostName/GlobalLicensingService/api/1.0/instances/DeviceId/
features?includeEntitlementInfo=true

Retaining Filtered Products When Configuring Line Items 
(Case 02166366, SWM-4796)

When creating or updating entitlements, while configuring line items, users can now select products 
across multiple searches. Products selected from each search will be retained and all products 
selected from each search can be linked to the line item that is being configured.

This new functionality is available as part of the standard search; it is not available for the advanced 
search.
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Ability to Limit Activation of FlexNet Embedded Nodelocked Licenses to 
Servers and/or Standalone Devices 
(Cases 02793847, 02992811; SWM-19823, SWM-24434)

Producers can now specify whether a nodelocked FlexNet Embedded license can only be activated on 
license servers, standalone devices, or both. This enhancement increases a producer’s control over 
license activation, and prevents license leakage caused by uncounted licenses being activated on a 
license server. 

Controlling the activation of FlexNet Embedded licenses is done during license model creation 
(Administer > License Models > Create new license model). When selecting the license model type 
Embedded, producers can select where the license model can be activated using the new option, 
Hosted On. The following options are available:

• License Servers—Licenses can only be activated on license servers. Attempts to activate a license 
on a standalone device will fail.

• Standalone Devices—Licenses can only be activated on standalone devices. Attempts to activate 
a license on a license server will fail.

• Both—Licenses can be activated on license servers and on standalone devices. This is the default 
option.
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Figure 4: The Hosted On property is set during license model creation.

The above controls apply to online and offline activations and are enforced regardless of activation 
type (Producer Portal, Web services, capability requests).

Behavior when changing a license model for a product

To explain the behavior, consider that you have the following license models defined: 

• License model 1: HostedOnServerOnly, Hosted On property set to License Servers

• License model 2: HostedOnStandalone, Hosted On property set to Standalone

When the license model of an existing product is changed—for example, the license model is changed 
from HostedOnServerOnly to HostedOnStandalone—FlexNet Operations will correctly validate license 
applicability based on device type.

While the entitlement line items are not removed automatically, once the license model is changed, 
licenses with HostedOnStandalone are no longer shown for Cloud License Server (CLS) instances or 
local license servers. Users must manually remove entitlements if they are no longer valid for the 
device.



FlexNet Operations 2025 R1 On-Premises Release Notes  (October 2025)  15

This behavior ensures that licenses meant only for standalone devices won't mistakenly appear for 
license servers, reducing confusion and helping enforce correct usage.

CONTAINER_ID Host ID Now Available for Docker Containers
(Case 02758504, SWM-19930)

The list of hostid types available for Flexnet Publisher certificate-based licensing now also includes the 
host ID type CONTAINER_ID. The CONTAINER_ID is used to node-locking a license server and feature 
licenses to a docker container host ID. 

Figure 5: The CONTAINER_ID can be selected in the Create License Host window.

Producers wanting to use CONTAINER_ID as a host ID must build a new version of the Vendor Certificate 
Generator (VCG) executable and need to change the generator configuration to version 16.2.3.0. 
Instructions on how to build a new version can be found in the Flexnet Operations User Guide, topic 
Creating a FlexNet Publisher Licensing Toolkit License Generator (VCG) Configuration.

Advanced Search for Entitlements Includes Custom License Models
(Case 02987224, SWM-25152)

On the List Entitlements page, the Advanced Search now allows users to filter entitlements by custom 
license models. This enhancement is available in both the Producer Portal and the End-User Portal.

https://docs.revenera.com/fno_CURRENT/producer/Content/helplibrary/opsCreateVcgConfig.htm
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Figure 6: The Advanced Search window now includes custom license models when searching for 
entitlements.

Allow Renewal License to Start Upon Expiry of Parent License
(Case 02679546; SWM-21239) 

Currently, mapping a renewal license to a device can result in the parent license being unmapped, 
temporarily leaving the device without a license. 

This issue occurs when a renewal relation is set up between the parent and the child line items, and 
the renewed (child) line item has a future start date. When the renewed line is activated, it replaces the 
parent line mapped to the device. It is possible to create a renewal line item without linking to the 
parent line item; in this case there is no gap in license coverage. 

To address this issue, the 2025.04 release introduces a configuration which allows producers to 
change the behavior when mapping renewal licenses to devices. The new configuration called Retain 
mapping of the parent activation to the devices when mapping a child activation is available under 
System > Configure > Embedded Devices > Host Options. By default, the option is unselected, 
maintaining the behavior of previous releases.

When this option is selected, the parent license remains mapped to the device even when a child 
license (for a renewal, upgrade or upsell) is applied. This means that the parent license continues to be 
available after the child line item has been mapped. 

This enhancement allows producers to issue renewal licenses well before the parent license expires, 
and it enables customers to apply the renewal license early. This ensures uninterrupted license 
coverage throughout the device's activation lifecycle, preventing any interruptions.
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There has been no change to the user experience. Activations are mapped as before: 

• Producer Portal—On the View Device or View Server page (under Devices > Devices, click a 
hyperlinked device name), click Licenses > Map Entitlements or Map by Activation IDs.

• SOAP web services—Using the the incrementAddonLineItems and linkAddonLineItems operations 
of the ManageDeviceService web service.

Note • Producers are responsible for explicitly unmapping unused/expired activations.

New “Features” Column on List Entitlements Page 
(Case 02982636, SWM-25094) 

In the Producer Portal and the End-User Portal, the List Entitlements page can display an additional 
Features column, which would show the name and the version of the feature that is associated with a 
product. If a product includes more than one feature, a more... link is displayed. Pointing to the link 
lists all features that are linked to the product. 

This enhancement makes it easier for producers and their customers who might be more familiar with 
feature names than product names to identify and manage the features associated with a product. 

Displaying the Features Column

This enhancement is disabled by default. Producers who would like the Features column to be 
displayed should send a request to Revenera support. Revenera strongly recommends that producers 
ensure that displaying the Features column does not interfere with the way they currently use the List 
Entitlements page.

Figure 7: The List Entitlements page with the Features column displaying feature information in the 
Producer Portal 
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Figure 8: The List Entitlements page with the Features column displaying feature information in the 
End-User Portal 

Inactive Line Items Can Now Be Changed to Draft to Allow Editing
(Case 02552542, SWM-25355)

The 2025.03 release now allows producers to change the state of line items from Inactive to Draft. 
Previously, to edit an inactive line item, its status had to be changed to Deployed. This enhancement 
means that producers can edit or re-use previously inactive line items, without the need to deploy 
these line items first. 

Example: A producer wants to update the part number for a certain product. The products are already 
associated with entitlements, some of which are inactive. The producer can now change a line item’s 
status from Inactive to Draft, which then makes the line item editable. The producer can update the 
part number and then change the status back to Inactive.

The following screenshots show the Line Items section, where a line item has its status changed to 
Inactive, and the Customers to Licenses page with the subsequent success message.
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Figure 9: Changing the line item status from Inactive to Draft in the Line Items section of the Entitle 
Customers to Licenses page

Figure 10: The Entitle Customers to Licenses page shows a confirmation message after changing the 
line item’s status.

Warning Message When Activating Licenses for Upgrade Line Items
(Case 02733304, SWM-19396)

In FlexNet Operations, when a base line item is associated with an upgrade line item, and the upgrade 
line item is activated, the quantity is consumed on the parent line. Returning the upgrade line item will 
not free up the count on the base line item. This is to prevent license leakage. 

However, customers who are not aware of this behavior might be frustrated. Imagine the following 
scenario: a customer upgrades to a new product version and activates the upgraded version. For some 
reason, the upgraded version of the product does not live up to their expections. When the customer 
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tries to return the upgraded line item, in the hope of being able to use the previous product, they find 
that this is no longer possible. They now have no choice but continue using the upgrade that they do 
not like. 

To help users make conscious decisions when upgrading, FlexNet Operations now includes a new 
configuration option Display warning message when activating upgrade line item linked to parent line 
item (under System > Configure > FlexNet Operations > General Options). The option controls the 
behavior of the Producer Portal and the End-User Portal: 

• When the configuration option is selected, and a user tries to activate an upgrade line item that is 
linked to the parent line item (by navigating to the List Entitlements page, selecting an 
entitlement and clicking Activate), the following warning is displayed: 

“If you activate the selected upgrade line item, you will no longer be able to activate previous 
versions of that line item. Are you sure you want to activate the upgrade line item?“

This message makes it clear to the user that they cannot revert back to the previous version after 
the upgrade.

• When the configuration option is unselected, and a user tries to activate an upgrade line item that 
is linked to the parent line item, no warning message is be displayed. The Generate Licenses page 
opens for activating the license. (It is the Current Behaviour).

Figure 11: Example of the warning message in the End-User Portal

Confirmation Message Displayed After Merging Entitlements
(Case 02974495, SWM-24762) 

Previously, when a user initiated a merge operation by selecting the assets to be merged and clicking 
Complete on the List Entitlements By Order | Merge Entitlements page, the Producer Portal redirected 
the user to the List Entitlements By Order page which then listed the merged assets. This behavior was 
confusing, because the user had no immediate way of knowing whether the merge was successful.

To improve the user experience, the List Entitlements By Order | Merge Entitlements page now 
displays a confirmation message which indicates whether the merge was successful. In the event of 
an error, a meaningful error message is displayed. 

The following screenshot shows the List Entitlements By Order | Merge Entitlements page with a 
confirmation message for a successful merge operation: 
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Figure 12: The confirmation message after a merge on the List Entitlements By Order | Merge 
Entitlements page

After the merge, users can navigate away from the page using the options in the top navigation bar. 

This enhancement applies to operations for merging entitlements and fulfillments and for merging 
users. 

Error Message When Activating Obsolete/Inactive Line Items
(Case 02954549, SWM-23892)

Previously, attempting to activate an obsolete or inactive line item on a device using a FlexNet 
Embedded toolkit failed as expected, but no error message was displayed. This lack of error messages 
while activating obsolete or inactive line items made it difficult for producers to notice and resolve 
errors in a timely manner. 

From the 2025.02 release onwards, attempting to activate an obsolete or inactive line item will result 
in an error being displayed. For example, the response might include a status like this:

Status=("Activation ID not permitted": 5f4d-123e-a456-7894-b123-66f4-88h7-56f3)

This screenshot shows a sample response: 
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This enhancement enables producers to identify the cause of the error and take corrective action, if 
required.

Visibility of Product Lines Created by Other Producer Users
(Cases 02774078, 02848224; SWM-20402)

In previous FlexNet Operations releases, a producer user could only access the product lines they 
created. However, this could create issues when system administrators left and new staff had to take 
over their responsibility for product lines. Product lines that were created by the previous 
administrator were not visible to the new administrators, making product line management very 
difficult. 

The 2025.03 therefore introduces a new configuration option Enable visibility of all product lines for 
system administrators (under System > Configure > FlexNet Operations > General Options). If 
enabled, the Product Lines section on the Create a User and Create an Account pages in the Producer 
Portal displays all product lines, including those created by other producer users. The Link product 
lines button in that section, which was previously limited to product lines created by the logged-in 
user, now allows linking of product lines created by other producer users. 

By default, the Enable visibility of all product lines for system administrators option is disabled.

Note that the configuration option Enable Product Lines for Products, Users, and Accounts (also under 
System > Configure > FlexNet Operations > General Options) must be selected for the new 
configuration option Enable visibility of all product lines for system administrators to be effective.
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Figure 13: When Enable Product Lines for Products, Users, and Accounts is selected, the Product 
Lines section on the Create a User page (pictured) and the Create an Account page displays all product 
lines, including those created by other producer users.  

Figure 14: Clicking Link product lines in the Product Lines section on the Create a User page and the 
Create an Account page displays the Select Product Lines for the User window, where producer users 
can link or remove a product line, including those product lines created by other producer users. 
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Changing the Prefix for Trial Activation IDs
(Case 02461881, SWM-21200)

The 2025.03 release allows producers to customize the short string that is used as a prefix for trial 
activation IDs. 

Previously, customization was not allowed. When a trial entitlement was created, its activation ID had 
the fixed prefix “Act”, which was a limitation when the entitlement needed to match or validate old or 
existing licenses and made trial conversions or renewals difficult. A configurable prefix gives 
producers the flexibility to match the activation IDs in these various phases.

Producers wanting to change the prefix can do so in the configuration option Custom pre-fix string 
from Trial License Activation ID (under System > Configure > FlexNet Operations > General Options). 

Overhaul of the “Show Line Items with Zero Copies by Default” 
Configuration Option
(Case 02876825, SWM-24336)

In previous releases, the configuration option Show Line Items with Zero Copies by Default (under 
System > Configure > FlexNet Operations > General Options) did not work as expected. It has now 
undergone an overhaul to fix functional issues and broaden its scope:

• In previous releases, even if the configuration option was disabled, the List Entitlements in the 
End-User Portal page erroneously displayed line items with zero copies remaining. This has now 
been resolved.

• The previous description of the configuration was misleading, because it referred to the page 
names “Activatable Items” and “Entitlements” that do not exist in the End-User Portal. The 
wording has now been corrected to refer to the “List Entitlements” page.

• The scope of the configuration option has been broadened. Whereas previously it controlled only 
which entitlements would be displayed on the List Entitlements page in the End-User Portal, it 
now also controls which entitlements are displayed on the List Entitlements page of the Producer 
Portal. To reflect this, the description has been changed as follows: “Select to show line items 
with zero copies by default in the List Entitlements page in the Producer Portal and End-User 
Portal.”

This enhancement gives producers and their end-users greater control over the content displayed 
on the List Entitlements pages.

How the option affects which line items are displayed in 2025.02 

When Show Line Items with Zero Copies by Default is selected, the Producer Portal and the End-User 
Portal show line items with zero copies remaining on their List Entitlements pages. The List 
Entitlements page is available in the Producer Portal under Entitlements > List Entitlements and in the 
End-User Portal under Activation & Entitlements > List Entitlements. 

When Show Line Items with Zero Copies by Default is unselected (the default), line items with zero 
copies are hidden on the List Entitlements pages.
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Electronic Software Delivery Features & 
Enhancements

The following Electronic Software Delivery (ESD) features were added in the 2025 R1 release.

Ability to Restrict Visibility of Expired Software or Maintenance Entitlements 
in End-User Portal
(Case 02801561, SWM-19597) 

This release offers producers who use FlexNet Operations with Electronic Software Delivery more 
control about the visibility of expired software entitlements and maintenance.  

Previously, software downloads were available for life to entitled end-users. End-users could 
download software from expired entitlements, but could not activate that software if it was controlled 
by license activation because the licenses would have expired. 

The 2025 R1 release now enables producers to offer only software mapped to active entitlements for 
download. This means that in the End-User Portal, end-users can no longer see or download software 
or maintenance that has expired.

Producers can control visibility of expired software and maintenance using the new configuration 
option Hide downloads for expired entitlements (under System > Configure > End-User Portal Setup > 
Downloads Page). By default, this option is unselected, meaning that software and maintenance from 
expired downloads remains visible to end-users. 

Embedded Devices Enhancement
The following enhancement has been made for the management of Embedded Devices in the 2025 R1 
release.

• New Configuration for Future End-User Portal Enhancement

• Supporting Multiple Signature Strengths for Standalone Devices

New Configuration for Future End-User Portal Enhancement
(SWM-21147)

A new configuration option Show three level product hierarchy (under System > Configure > End-User 
Portal Setup > General Options) has been introduced in anticipation of new functionality that will be 
made available in a future release. At present, the configuration option has no underlying functionality. 

Supporting Multiple Signature Strengths for Standalone Devices
(FNE-19494)

With technology and computational power evolving rapidly, algorithms and key sizes that are 
considered secure today may be considered vulnerable in the future. Therefore, software producers 
may decide that they would like to migrate to a different signature strength. 
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To enable migration to a different signature strength, the Publisher Identity utility for FlexNet 
Embedded has been enhanced to allow producers to add one additional signature strength to the 
already existing signature strength. Existing clients in the field will continue to support the existing 
identity using the original signature strength, while new clients that have been built using the updated 
identity use the additional, higher signature strength to validate communication with the back office.

Note • Adding a signature strength is currently only supported for standalone devices.

Managing Signature Strengths

Publishers can add or delete a signature strength using the updated Publisher Identity utility either in 
UI or console mode. 

The Publisher Identity utility UI has been changed as follows: 

• To create a new identity, publishers no longer need to specify different paths for the identity files 
(back office, server, and client identity). Instead, when they click Save or Save and Exit in the 
updated UI, they are prompted to specify a folder. Upon confirming the folder location, the 
Publisher Identity utility creates a subfolder with a file name in the format YYYY-MM-DDThh-mm-ss-
sss (for example, 2024-06-12T09-30-24-064), which will hold the new set of identity files.

• To add or delete a signature strength, publishers specify the existing back-office identity that they 
want to modify in the Identity File section. Clicking Enable Multiple Signature Strengths displays 
controls for adding, deleting or validating a signature strength. Again, clicking Save or Save and 
Exit prompts the publisher to specify a folder. This folder will hold a subfolder with a file name in 
the format YYYY-MM-DDThh-mm-ss-sss which will contain the updated set of identity files. 
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The following screenshot shows the updated Publisher Identity utility UI:

The following new commands have been introduced to add or delete a signature strength in console 
mode:

pubidutil -silent [-backOffice backofficeidfile.bin] [-addSignatureStrength sig-type 
sig-strength]

pubidutil -silent [-backOffice backofficeidfile.bin] [-delSignatureStrength sig-type 
sig-strength]

For detailed information about adding or deleting a signature strength using the UI or the command-
line, refer to the FlexNet Embedded documentation.

Client Behavior for Validating Messages

When an additional signature strength is added to an identity, existing clients will continue to validate 
any downstream messages, such as capability responses, using the original signature strength. Any 
new clients that are built using the updated identity will validate downstream messages using the 
added signature strength. 
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The following diagrams visualize the behavior. 

 

Figure 15: Initial scenario where the identity used for the client software and in the back office has 
only one signature strength. 

Figure 16: In scenario 2, the publisher identity in the back office has an additional signature strength. 
Existing devices running the client software that was built using the original, unchanged identity use 
the original signature strength to validate downstream messages.
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Figure 17: In scenario 3, the publisher has launched a new product which was built using the identity 
that includes the additional signature strength. This client will always use the added, higher signature 
strength to validate downstream messages. 
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Figure 18: In scenario 4, the publisher has launched another new product which has also been built 
using the updated identity. It is installed on the same device as the PhotoPrint product. However, both 
clients use their own trusted storage. PhotoPrint will use the original signature strength, while  
SignPrint will use the higher signature strength to validate downstream messages. 

Export and Import Enhancements
The following enhancement involving the Data Export and Import functionality was added in the 2025 
R1 release.

Exporting Users with Roles and Permission Information
(Case 01282499, SWM-21007) 

Previously, FlexNet Operations did not provide functionality for creating a report of the permissions 
assigned to each role. While the Data Import template could extract the roles of users, these reports 
did not include details of the permissions included in each role. The Producer Portal was the only way 
for producers to identify the permissions selected for a role.
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In the 2025 R1 release, producers can now use the Data Import template to create a report detailing 
the permissions that are applied for each role. When exporting users (Accounts & Users > All Users > 
Export > Data Import Template), the exported CSV file, UserExport.xlsx, includes a new Permission 
column.

Note • This enhancement does not affect the User Data Extract job. 

Device Management Enhancements
The following enhancements to device management were added in the 2025 R1 release.

• Bulk Updating Account Information for Devices

• Device History Now Listing Users Who Triggered Events

• Reassigning Returned Standalone Devices

Bulk Updating Account Information for Devices
(Case 02880444, SWM-25969) 

Producers can now use the newly introduced Devices Template to assign an account to multiple 
devices at a time. This offers an easier and faster UI-based way to perform bulk transfers of 
entitlements between accounts, including stock returns and the transfer of faulty appliance 
entitlements.

To download the Devices Template (XLSX format), click Administer > Import Data Objects and select 
the Data Import Templates tab. 

Figure 19: The Devices Template can be downloaded from the Import Data Objects page.

In the template, the following properties must be provided to update account information for devices: 
host id, publisher name, host class, host id type and account ID. 



FlexNet Operations 2025 R1 On-Premises Release Notes  (October 2025)  32

This screenshot shows an example of a populated template:

Figure 20: Example of a populated XLSX template.

Once the Devices Template has been populated, it must be saved as a Unicode .txt file before it can be 
imported into FlexNet Operations, using the Import Settings tab on the Import Data Objects page.

Device History Now Listing Users Who Triggered Events 
(Cases 02685529, 02869243; SWM-13895) 

The Device History page (available by clicking View > View Device History on a Device or View Server 
page) now includes a User Details column, which lists the name of the user who triggered an event (for 
example, creating a device or mapping entitlements). 
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 This improvement enhances transparency by identifying who performed particular actions on a 
device, making it easier to troubleshoot issues. 

Figure 21: Example of the Device History page with the User Details column.

Reassigning Returned Standalone Devices
(Case 01948947, SWM-20276) 

This release includes an enhancement for returned standalone devices.

Returning a device is intended for devices that no longer receive capability responses or license files, 
or servers that no longer serve devices or communicate with the FlexNet Operations back office. 
Previously, returning a device was an irreversible action. When a device was returned, it was 
permanently disassociated from its account. 

The 2025.01 release introduces the ability to reassign returned standalone devices to an account and 
reactivate such devices. This enables producers to take returned standalone devices back into service.

Reassigning a Device Using the Producer Portal 

Producers can reassign a returned device to an account using the menu item Reassign Account from 
the Edit menu on the Device page. (To access the Device page for a returned device, click Devices > 
Devices  > click a hyperlinked device name.) 
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Note • Returned devices have a status of Returned and are by default not listed on the Devices page 
(under Devices > Devices) even when searched. To display returned devices on the Devices page, 
select the option Inactive in the filter above the devices list.

The following screenshot shows the new menu item Reassign Account on the Device page:

Clicking Reassign Account opens the Assign account page, where you can select a new account for 
the device. 
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After a standalone device has been reassigned to an account, the device status is changed to Active. 
The device can now have entitlements mapped to it. 

Reassigning a Standalone Device Using Web Services

Returned standalone devices can also be reassigned using the updateDevice operation of the 
ManageDeviceService web service. 

The following code snippet illustrates how to use the updateDevice operation:

<urn:updateDeviceRequest>
<urn:device>
<urn:deviceIdentifier>
<urn:deviceType>CLIENT</urn:deviceType>
<!-- Note: This is the device to be updated, currently in RETURNED state -->
<urn:deviceId>Test123</urn:deviceId>
<urn:deviceIdType>STRING</urn:deviceIdType>
<urn:publisherName>fnepublisher</urn:publisherName>

</urn:deviceIdentifier>
<urn:updateChannelPartners>
<urn:channelPartners>
<urn:channelPartner>
<!-- Note: Only END CUSTOMER is supported as per existing functionality-->
<urn:tierName>bo.constants.partnertiernames.endcustomer</urn:tierName>
<!-- Note: This is the account to which the device is to be reassigned -->
<urn:accountUnit>
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<urn:primaryKeys>
<urn:name>MyAccount</urn:name>

</urn:primaryKeys>
</urn:accountUnit>

</urn:channelPartner>
</urn:channelPartners>
<!-- Note: Only REPLACE is supported as per existing functionality-->
<urn:opType>REPLACE</urn:opType>

</urn:updateChannelPartners>
</urn:device>

</urn:updateDeviceRequest>  

There have been no changes to any of the .wsdl or .xsd files for SOAP services.

Reassigning a Standalone Device Using the End-User Portal 

To use a returned standalone device in the End-User Portal, the device must first be reassigned to an 
account using the Producer Portal. Once it has been assigned to an account, an end user can claim the 
device in the End-User Portal by clicking Devices > Claim and Activate.

Note • The Claim and Activate option only appears in the Devices menu of the End-User Portal for 
users with roles specifically granted the End-User Portal permissions Claim Device and Activate and 
Generate Licenses.

SOAP and REST Web Services Enhancements
The following enhancements were added to the SOAP and REST Web Services module in the 2025 R1 
release.

• Zero Mapping of Activation IDs on Cloud License Servers Using ManageDevice SOAP Web Service 
(Version 7)

• Returning Fulfillment and License Information for Non-Embedded Technologies Using 
LicenseService Web Service (Version 2)

• New Operation for Getting Host Count in LicenseService Web Service (Version 2)

• getEntitlementLineItemPropertiesQuery Returning Licenses for Multiple Accounts in 
EntitlementOrderService Web Service (Version 8)

• Managing Upgrade Relationship Using EntitlementOrderService Web Service (Version 7)

• Returning Users from All Related Accounts Using UserAcctHierarchyService (Version 6)

• UserAcctHierarchyService Version 6: Returning User Information for Multiple Accounts Using 
UserAcctHierarchyService (Version 6)

• Event Notification API: Device Event Notifications Published to Webhook

• Event Notification Service REST API Supporting Event Notifications for Device Events

• Product Packaging Data Extract Now Includes Product Version
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Zero Mapping of Activation IDs on Cloud License Servers Using 
ManageDevice SOAP Web Service (Version 7)
(SWM-25022) 

The 2025 R1 release introduces version 7 of the ManageDevice SOAP web service. The new version 
contains a new operation, zeroCountAddonLineItems, which enables producers to explicitly set an 
activation ID with a zero allocation mapping on a Cloud License Server (CLS) instance. 

This enhancement enables customers to clearly distinguish between activation IDs that are fully 
entitled for allocation (full count) and those that are restricted for allocation on the CLS.

Previously, when querying activation IDs via SOAP services like searchDevices, there was no easy way 
to identify activation IDs that were intentionally restricted from allocation. Such activation IDs simply 
did not appear, making it difficult for customers to differentiate between no mapping and full 
allocation from the master entitlement.

By explicitly creating a zero allocation mapping, producers can track and manage entitlement behavior 
accurately, improving license compliance and allocation control across their deployments.

Notes for Using zeroCountAddonLineItems

• The configuration option Allow mapping zero counts to FlexNet Embedded devices (under System 
> Configure > FlexNet Operations > Embedded Device Settings) must be selected.

• Values submitted in the web request are not validated. As long as the request contains a valid 
device ID and line item details, the relevant mapping will be updated.

• No validation takes place. Whatever mapping line item customer provides is mapped to a 
particular device, regardless of e.g. whether the license model is supported. 

• Information related to calling the zeroCountAddonLineItems operation will be tracked and can be 
reviewed on the Search Transactions page in the Producer Portal (under System > Transaction 
History).

Example Request for zeroCountAddonLineItems

The sample code, below, shows a request to allocate zero counts from activation ID 83a2-9824-c72b-
488t-bbde-9bbb-fce3-1344 to the device with ID devicel_type.

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-
instance">
<soapenv:Header/>
<soapenv:Body>
<urn:zeroCountAddonLineItemsRequest>
<!-- 1 or more repetitions: -->
<urn:requestList>
<urn:deviceIdentifier>
<urn:deviceType>SERVER</urn:deviceType>
<!-- Optional: -->
<urn:deviceId>devicel_type</urn:deviceId>
<!-- Optional: -->
<urn:serverIds>
<!-- 1 or more repetitions -->
<urn:serverId>device1_type</urn:serverId>

</urn:serverIds>
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<!-- Optional: -->
<urn:deviceIdType>ETHERNET</urn:deviceIdType>
<!-- Optional: -->
<urn:publisherName>FLEXERA</urn:publisherName>

</urn:deviceIdentifier>
<!-- 1 or more repetitions: -->
<urn:lineItem>
<urn:lineItemIdentifier>
<!-- Optional: -->
<urn:activationId>83a2-9824-c72b-488t-bbde-9bbb-fce3-1344</urn:activationId>
<!-- Optional: -->
<urn:count>0</urn:count>
<!-- Optional: -->

</urn:lineItemIdentifier>
</urn:lineItem>

</urn:requestList>
</urn:zeroCountAddonLineItemsRequest>

</soapenv:Body>
</soapenv:Envelope>

Example Response for zeroCountAddonLineItems

The sample code, below, shows a response for a successful request.

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-
instance">
soapenv:Body
<zeroCountAddonLineItemsResponse xmlns="urn:v7.fne.webservices.operations.flexnet.com">
<statusInfo>
<status>SUCCESS</status>

</statusInfo>
<responseData>
<deviceIdentifier>
<deviceType>SERVER</deviceType>
<deviceId>device1_type</deviceId>
<serverIds>
<serverId>device1_type</serverId>

</serverIds>
<deviceIdType>ETHERNET</deviceIdType>
<publisherName>FLEXERA</publisherName>

</deviceIdentifier>
</responseData>

</zeroCountAddonLineItemsResponse>
</soapenv:Body>

</soapenv:Envelope>

Returning Fulfillment and License Information for Non-Embedded 
Technologies Using LicenseService Web Service (Version 2)
(Case 02370066, SWM-22714) 

In the Producer Portal, producers can list fulfillment or license information for non-embedded 
licensing technology (such as FlexNet Publisher) for specific hostids on the Support Licenses and 
Maintenance page (under Licenses > Hosts). The following screenshot shows the Support Licenses 
and Maintenance page along with the search options:
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To provide the same functionality using web services, the 2025 R1 release now introduces version 2 of 
the LicenseService SOAP web service. This enhancement enables producers to do the following:

• Collect all hostids to provide a list of current hostids for new activations

• Collect all active fulfillments for a dedicated server in preparation to create "emergency" licenses 
for that server

• Collect fulfillment and license information in preparation to rehost a server

Implementation of getHostQuery

Version 2 of the LicenseService SOAP web service includes the new operation getHostQuery. The 
following XML fragment illustrates a getHostQuery message:

<operation name="getHostQuery">
<input message="tns:getHostQueryRequest"/>
<output message="tns:getHostQueryResponse"/>

</operation>

The operation getHostQuery extracts the same information as that available on the Support Licenses 
and Maintenance page: Host ID, Sold To, Account, License Technology, and Host Type. In addition, 
producers can filter for hosts that have active or inactive fulfillments.

Tip • For pagination, producers can use the getHostCount operation to determine the number of hosts 
and specify that number in the batchSize parameter (see New Operation for Getting Host Count in 
LicenseService Web Service (Version 2)).

The following snippet shows sample XML code: 

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:urn="urn:v2.webservices.operations.flexnet.com">
   <soapenv:Header/>
   <soapenv:Body>
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      <urn:getHostQueryRequest>
         <!--Optional:-->
         <urn:queryParams>
            <!--Optional:-->
            <urn:hostId>
               <urn:value>?</urn:value>
               <urn:searchType>?</urn:searchType>
            </urn:hostId>
            <!--Optional:-->
            <urn:soldTo>
               <urn:value>?</urn:value>
               <urn:searchType>?</urn:searchType>
            </urn:soldTo>
            <!--Optional:-->
            <urn:licenseTechnology>
               <urn:value>?</urn:value>
               <urn:searchType>?</urn:searchType>
            </urn:licenseTechnology>
            <!--Optional:-->
            <urn:hostType>
               <urn:value>?</urn:value>
               <urn:searchType>?</urn:searchType>
            </urn:hostType>
            <!--Optional:-->
            <urn:account>
               <urn:value>?</urn:value>
               <urn:searchType>?</urn:searchType>
            </urn:account>
            <!--Optional:-->
            <urn:fulfillmentState>
               <urn:value>?</urn:value>
               <urn:searchType>?</urn:searchType>
            </urn:fulfillmentState>
         </urn:queryParams>
         <urn:pageNumber>?</urn:pageNumber>
         <urn:batchSize>?</urn:batchSize>
      </urn:getHostQueryRequest>
   </soapenv:Body>
</soapenv:Envelope>

New Operation for Getting Host Count in LicenseService Web Service 
(Version 2) 
(Related to Case 02370066, SWM-25245)

Along with the getHostQuery operation (see Returning Fulfillment and License Information for Non-
Embedded Technologies Using LicenseService Web Service (Version 2)), version 2 of the 
LicenseService SOAP web service also introduces the getHostCount operation. getHostCount returns 
the number of hosts that match specified criteria. 

This operation is equivalent to displaying the number of hosts that fit certain criteria by filtering hosts 
using the Search for option in the Producer Portal in the Support Licenses and Maintenance page:
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Implementation of getHostCount

The following XML fragment illustrates a getHostCount message:

<operation name="getHostCount">
<input message="tns:getHostCountRequest"/>
<output message="tns:getHostCountResponse"/>

</operation>

The operation getHostCount returns the number of hosts that fit specified criteria. The following 
search criteria are available: Host ID, Sold To, Account, License Technology, and Host Type. 

Tip • The returned number can be used as the batch size input for getHostQuery (see Returning 
Fulfillment and License Information for Non-Embedded Technologies Using LicenseService Web 
Service (Version 2)).

The following snippet shows sample XML code: 

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:urn="urn:v2.webservices.operations.flexnet.com">
   <soapenv:Header/>
   <soapenv:Body>
      <urn:getHostCountRequest>
         <!--Optional:-->
         <urn:queryParams>
            <!--Optional:-->
            <urn:hostId>
               <urn:value>?</urn:value>
               <urn:searchType>?</urn:searchType>
            </urn:hostId>
            <!--Optional:-->
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            <urn:soldTo>
               <urn:value>?</urn:value>
               <urn:searchType>?</urn:searchType>
            </urn:soldTo>
            <!--Optional:-->
            <urn:licenseTechnology>
               <urn:value>?</urn:value>
               <urn:searchType>?</urn:searchType>
            </urn:licenseTechnology>
            <!--Optional:-->
            <urn:hostType>
               <urn:value>?</urn:value>
               <urn:searchType>?</urn:searchType>
            </urn:hostType>
            <!--Optional:-->
            <urn:account>
               <urn:value>?</urn:value>
               <urn:searchType>?</urn:searchType>
            </urn:account>
            <!--Optional:-->
            <urn:fulfillmentState>
               <urn:value>?</urn:value>
               <urn:searchType>?</urn:searchType>
            </urn:fulfillmentState>
         </urn:queryParams>
      </urn:getHostCountRequest>
   </soapenv:Body>
</soapenv:Envelope>

getEntitlementLineItemPropertiesQuery Returning Licenses for Multiple 
Accounts in EntitlementOrderService Web Service (Version 8)
(Case 02877724, SWM-23429)

The EntitlementOrderService web service has been updated to v8, with a modified 
getEntitlementLineItemPropertiesQuery which now allows searching by multiple account names. The 
<urn:value> element of the complex element <urn:accountUnitName> can be repeated multiple times 
to search by multiple account names. 

This change enables producers to retrieve the licenses and detailed licensing information for specified 
accounts. 

The number of accounts to search for can be limited using a new configuration option called Maximum 
number of Account names accepted to search for Entitlement Line Item Properties (under System > 
Configure > FlexNet Operations > General Options).

If the number of <urn:value> elements in the request exceeds the configured limit, an error message 
will be returned.

Using multiple <urn:value> elements

The following limitations apply when supplying multiple <urn:value> elements as search parameters:

• If the query also includes other search parameters, then for those parameters only the default 
values are considered. 
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• The <urn:searchType> parameter is optional. If used, it accepts only EQUALS. Any other value 
passed for <urn:searchType> will result in an error message.

• The <urn:partnerTier> will not be used and a default of search by ANY partner tier will be 
applied.

Note • The limitations only apply when using multiple elements. If a single <urn:value> element is 
provided, then the behavior of the search is the same as in v7 (meaning that all allowed values for 
<urn:searchType> or <urn:partnerTier> can be used as search criteria).

Snippet of a sample request
<urn:searchEntitlementLineItemPropertiesRequest>
<urn:queryParams>
<urn:accountUnitName>
<!--1 or more repetitions:-->
<urn:value>MyAccount01</urn:value>
<urn:value>MyAccount02</urn:value>
<urn:value>MyAccount03</urn:value>
<urn:value>MyAccount04</urn:value>
<urn:value>MyAccount05</urn:value>

</urn:accountUnitName>
</urn:queryParams>

</urn:searchEntitlementLineItemPropertiesRequest>

Effects on Entitlement Order REST Endpoints

Note the following changes to the request object for Entitlement Order REST endpoints. 

Entitlement Order REST endpoints have two objects in the request: accountId and accountUnitName. 
No changes have been made to the accountId (PartnerTierQueryTypeDTO) object. However, the 
accountUnitName (AccountNamesQueryTypeDTO) object now accepts a string array for the field value. 
Currently, only a single value is supported. Searching by multiple account names is enabled only in the  
getEntitlementLineItemPropertiesQuery webservice operation.

Usage Example

{
"queryParams": {

"accountUnitName": {
"value": ["ACME"],
"searchType": "STARTS_WITH"

}
}

}

Managing Upgrade Relationship Using EntitlementOrderService Web Service 
(Version 7)
(Case 02860233, 02746301; SWM-20708, SWM-21094)
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Version 7 and later versions of the EntitlementOrderService SOAP web service enable producers to 
add or remove an Upgrade relationship between two valid line items. In the 
updateEntitlementLineItem method, the parentLineItem element now includes the element 
lineItemType, which supports the new value NEW. 

This functionality was already available in the Producer Portal, and this enhancement now creates 
parity between the Producer Portal and SOAP web services. 

Sample code for creating an Upgrade relationship

Provide valid activation IDs for the lineItemData and parentLineItem elements, and specify the value 
UPGRADE for lineItemType, as shown in the following example:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:urn="urn:v7.webservices.operations.flexnet.com">
<soapenv:Header/>
<soapenv:Body>
<urn:updateEntitlementLineItemRequest>
<urn:lineItemData>
<urn:entitlementIdentifier>
<urn:primaryKeys>
<urn:entitlementId>8380-7252-e0fc-4ddf-a203-0170-7120-de80</urn:entitlementId>

</urn:primaryKeys>
</urn:entitlementIdentifier>
<urn:lineItemData>
<urn:lineItemIdentifier>
<urn:primaryKeys>
<!-- Activation ID of line item that should be linked to a parent-->
<urn:activationId>6e37-c975-5c79-47c9-a312-59ed-dafb-d872</urn:activationId>

</urn:primaryKeys>
</urn:lineItemIdentifier>
<urn:description>Upgrade relationship added</urn:description>
<urn:parentLineItem>
<urn:uniqueId/>
<urn:primaryKeys>
<!-- Activation ID of line item that that will become a Parent reference -->
<urn:activationId>5fe9-3acb-9b1a-4eec-8dc4-7792-9dc1-6fb7</urn:activationId>
</urn:primaryKeys>
<!-- New element added. Upgrade relation to be set with the Parent reference -->
<urn:lineItemType>UPGRADE</urn:lineItemType>

</urn:parentLineItem>
</urn:lineItemData>

<urn:autoDeploy>false</urn:autoDeploy>
</urn:lineItemData>

</urn:updateEntitlementLineItemRequest>
</soapenv:Body>

</soapenv:Envelope>

Sample code for removing an Upgrade relationship

Provide valid activation IDs for the lineItemData and parentLineItem elements, and specify the value 
NEW for lineItemType, as shown in the following example:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:urn="urn:v7.webservices.operations.flexnet.com">
<soapenv:Header/>
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<soapenv:Body>
<urn:updateEntitlementLineItemRequest>
<urn:lineItemData>
<urn:entitlementIdentifier>
<urn:primaryKeys>
<urn:entitlementId>8380-7252-e0fc-4ddf-a203-0170-7120-de80</urn:entitlementId>

</urn:primaryKeys>
</urn:entitlementIdentifier>
<urn:lineItemData>
<urn:lineItemIdentifier>
<urn:primaryKeys>
<urn:activationId>9875-c692-7e64-4c80-89ab-9c8e-adcc-4f5b</urn:activationId>

</urn:primaryKeys>
</urn:lineItemIdentifier>
<urn:description>Unlink parent relation</urn:description>
<urn:parentLineItem>
<urn:uniqueId/>
<urn:primaryKeys>
<urn:activationId>5fe9-3acb-9b1a-4eec-8dc4-7792-9dc1-6fb7</urn:activationId>

</urn:primaryKeys>
<urn:lineItemType>NEW</urn:lineItemType>

</urn:parentLineItem>
</urn:lineItemData>
<urn:autoDeploy>false</urn:autoDeploy>

</urn:lineItemData>
</urn:updateEntitlementLineItemRequest>

</soapenv:Body>
</soapenv:Envelope>

Returning Users from All Related Accounts Using UserAcctHierarchyService 
(Version 6) 
(Case 02809222, SWM-21120)

In the UserAcctHierarchyService web service (newly introduced version 6), producers can use the 
new optional field usersFromLinkedAccount to provide one account ID to return all users belonging to 
that account and to any of its direct sub-accounts.

The field usersFromLinkedAccount is available for the getUsersQuery and getUsersCount operations. 

The following example describes the behavior. Assume an organization has the following accounts:

• Account A1 is the parent of sub-accounts a1 and a1.1

• Account a1.1 is the parent of sub-account a1.2
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A query for account ID or account name A1 with usersFromLinkedAccount = true would return users 
from all three accounts—A1, a1, and a1.1—that are directly linked to A1:

When searching for account ID or account name a1.1, users from accounts a1.1 and a1.2 will be listed 
in the response, but no users from A1:
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When usersFromLinkedAccount is set to true, only one account ID and/or account name can be 
provided as search parameter. A search using more than one account ID returns the following error: 
“Multiple Account Ids cannot be provided in the request when usersFromLinkedAccount is set to true.”

UserAcctHierarchyService Version 6: Returning User Information for 
Multiple Accounts Using UserAcctHierarchyService (Version 6) 
(Case 02809222, SWM-20374)

Producers can now use version 6 of the of the SOAP web service UserAcctHierarchyService to 
retrieve user information for multiple accounts using a single API call. This enhancement reduces the 
number of API calls required to return user information. To retrieve information for multiple accounts, 
producers specify the 10 account IDs in the getUsersQuery API request. 

By default, the number of account IDs that can be specified is limited to 10 accounts. The limit is 
controlled by a new configuration option, Number of accounts and associated user information to 
retrieve via SOAP API (under System > Configure > FlexNet Platform Server > General Options), which 
allows producers to modify this limit. Setting the option to -1 allows querying an unlimited number of 
accounts. Producers should bear in mind that specifying -1 might have a negative impact on system 
performance.

Event Notification API: Device Event Notifications Published to Webhook
(SWM-23427) 

Producers can now use the Event Notification Service API to trigger an event notification whenever a 
change is made to a license server. Real-time data about the event is delivered to a specified webhook 
URL where the data can be consumed programmatically to update the producer’s upstream or 
downstream systems.

Changes that can now trigger an event notification include the following: 

• Changes to license server attributes like device name, site name, notes, device owner, set of line 
items mapped to it, or the quantities mapped.

• Certain events on the license server, such as:

• Return license server

• Move license server

• Mapping entitlements to license server

• Removing license from license server

• Mapping activation ID to license server

Event Notification Service REST API Supporting Event Notifications for 
Device Events
(SWM-20802)

Producers can now use the Event Notification Service API to trigger an event notification whenever a 
specific event related to devices occurs. Real-time data about the event is delivered to a specified 
webhook URL where the data can be consumed programmatically to update the producer’s upstream 
or downstream systems.
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The following parameters have been added to the /notificationService endpoint:

• deviceSubscription—Set to true to subscribe to event notifications for device changes.

• deviceWehookUrl—Webhook endpoint that receives the information about device events.

Product Packaging Data Extract Now Includes Product Version 
(Case 02488178, SWM-19920)

When exporting a set of products using the Product Packaging Data Extract job (controlled by the Data 
Extract REST APIs), the resulting ProductsLicenseModel-<date and time>.csv file now includes a 
ProductVersion column which specifies the product version for each product listed in the file.

Inclusion of the ProductVersion column in the CSV file is controlled by a new configuration option 
called Show product version in extract file (under System > Configure > FlexNet Operations > General 
Options). By default, the option is not selected (meaning that the CSV file does not include product 
version information).

This enhancement enables producers to differentiate between products that have different versions.

Security Enhancements
The following enhancement related to FlexNet Operations security was made in the 2025 R1 release.

Token-Based Authentication in REST and SOAP APIs
(SWM-19491)

Previously, FlexNet Operations REST and SOAP APIs used Basic Authentication as their authentication 
scheme. While Basic Authentication is simple, it is considered less secure. The 2025 R1 release 
therefore introduces token-based authentication, which is more secure than basic authentication. 

In token-based authentication, the client first authenticates with their credentials. If successful, they 
receive an access token, which must then be included as a Bearer token in the Authorization HTTP 
header for subsequent requests.

Access Tokens are provided as an alternative way to authenticate and authorize web service calls to 
FlexNet Operations, so that integrations do not have to embed user credentials for Basic 
authentication.

In token-based authentication for FlexNet Operations APIs, producers and system administrators call 
the access-token-controller REST web service to request an access token with a limited expiration 
from FlexNet Operations. The token that is returned by the web service must then be added to the 
header of the API request when firing requests to a FlexNet Operations API (REST or SOAP).

Producers can also obtain access tokens using the new option Manage Access Tokens (available from 
the Accounts & Users menu) in the Producer Portal or the End-User Portal. Producers who do not want 
to allow customer users and partner users to create access tokens in the End-User Portal can select 
the configuration option Hide Access Tokens (under System > Configure > End-User Portal Setup > 
Manage Accounts & Users).

The access token not only authenticates the requester but also defines the permissions of how the 
requester can use the API, depending on the token type: 
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• NORMAL tokens can be requested by any FlexNet Operations user to authenticate themselves at a 
FlexNet Operations API. 

• IMPERSONATED tokens can be requested by system administrators to impersonate other FlexNet 
Operations users. 

Token-based authentication is currently available for the following APIs:

• SOAP Web Services 

• Data Extract REST API

• Application REST API

User Experience Enhancements
The following user experience enhancements were added in the 2025 R1 release. 

• Improved Transaction Visibility in Producer Portal

• Transaction History Includes Details of Device Creation and Modification Events

• Selecting Individual Line Items in Entitlement Notification Email

• Removed Security Question

• New Configuration Hides Menu Options for Making Entities Obsolete

• Larger Announcements Section on Home Page

• Meaningful Labels For Search in “List Entitlements” Page in End-User Portal

• Displaying All Active Custom Line Item Attributes

• Enhanced Expiration Information on View Server and View Device Pages

• Sorting Features on the Products Page in the Producer Portal

• Fewer Clicks Required to Change Line Items’ Start or Expiration Dates

• Entitlement ID and Start Date Now Displayed on Key Pages

• Easier Login to Revenera Registry

Improved Transaction Visibility in Producer Portal 
(SWM-24573, SWM-24811, SWM-24812, SWM-24813, SWM-24817, SWM-24818) 

Producers can now view all transactions performed on a device—whether initiated via web services or 
in the Producer Portal or End-User Portal—on the Search Transactions page in the Producer Portal 
(under System > Transaction History). 

There are three exceptions to the webservice-based transactions reported:

• Returning a device when it is no longer in use

• Any changes initiated using generateCapabilityResponse

• Any requests to generate a clone detection report
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Previously, only transactions performed through the Producer Portal or the End-User Portal interface 
were tracked in the Transaction History. 

This enhancement provides a comprehensive audit trail, enabling better tracking of past actions for 
compliance and troubleshooting purposes.

For more details, see the following sections:

• Tracked Operations

• Use Case Example

• Viewing Transaction Details

Tracked Operations

Transactions are tracked for standalone devices, Cloud License Server instances and local license 
servers. The following table lists the operations of the ManageDeviceService web service that are now 
racked: 

Transaction Web Service Operation Event Type Description

Deleting a line item 
from a device

deleteAddOnLineItemsReq
uest

UPDATE Tracks transactions where an 
entitlement line item was deleted 
on a device. 

Obsoleting the 
host for a device 

obsoleteHostRequest DELETE Tracks transactions where a host 
for a device was deleted.

Removing add-on 
line items

decrementAddonLineItems
Request

UPDATE Tracks transactions where an add-
on line item was removed from a 
device. 

Moving a device to 
a different account

moveDeviceRequest UPDATE Tracks transactions where a device 
is moved to a different account. 

Deleting a device deleteDeviceRequest DELETE Tracks transactions where a device 
is deleted. 

Creating a device createDeviceRequest CREATE Tracks all successful and failed 
attempts to create a device. 

Linking 
entitlement line 
items to a device

linkAddonLineItems UPDATE Tracks transactions where an 
entitlement line item was linked to 
a device, or where a metered 
license was removed from a 
device. 

Incrementing 
entitlement line 
items to devices

IncrementAddonLineItems UPDATE Tracks transactions where an 
entitlement line item was 
incremented on a device. 
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Use Case Example

Your company  provides industrial software licenses via FlexNet Operations. A customer complains 
that their software has stopped working. Your support team checks the Transaction History in the 
Producer Portal and sees that your customer’s own IT administrator mistakenly deactivated the 
license. Instead of escalating the issue, you can immediately guide them to reactivate their license, 
saving time and frustration.

Viewing Transaction Details

To view transaction details for a device, click System > Transaction History. On the Search Transaction 
History page, select the entity type Device, and enter any other search criteria. The Search 
Transactions: Results page displays a list of transactions. Click the View details link to see the details 
of a particular transaction. The details will look similar to this: 

Updating a device updateDevice UPDATE Tracks transactions where a device 
was updated.

Transaction Web Service Operation Event Type Description
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Figure 22: The Transaction Details page showing updates made to a device

Transaction History Includes Details of Device Creation and Modification 
Events
(SWM-23109, SWM-21003, SWM-23110)

FlexNet Operations users can now view the details for device creation and modification activity in the 
transaction history. Device modification activity includes, for example, changing a device name, user, 
site name or description. Tracking modification activity for devices provides valuable insights for 
ensuring accountability, identifying unauthorized changes, and maintaining a clear audit trail for 
security and compliance purposes. 

Users can access the transaction history in the following ways:

• Click System > Transaction History. For Entity type, select Device and specify any other search 
parameters as required. Clicking Search opens the Search Transactions: Results page which 
shows the events for the Device entity.
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• Click Accounts & Users > All Users. Click a hyperlinked user name. On the Create a User page, 
click View Transaction. FlexNet Operations displays the Search Transactions: Results page which 
shows all events for the selected user. The table can be sorted as required, to focus on particular  
event types or entity types.

On the Search Transactions: Results page, the creation of a new device is logged as CREATE in the 
Event type column, whereas edits to a device are logged as an UPDATE event. Clicking the View details 
link for an event shows the following metadata (non-exhaustive list): 

• Device ID/name

• Producer’s user ID and username

• Timestamp of creation or modification

• Any attributes

• Activity related to removing a device

• Activity related to returning a license for a device

• Activity related to making a device obsolete.

For edits to devices, the transaction details show the old as well as the new field values.

Note • The transaction history for devices only lists modifications to devices made through the 
Producer Portal. It does not list modifications made using web services. 

Selecting Individual Line Items in Entitlement Notification Email 
(Case 02971350, SWM-24682) 

On the List Entitlement By Orders page, producers can now select individual line items to be included 
in the entitlement notification email, instead of including all line items in the email. This is useful in 
scenarios where only some of an entitlement’s line items have been added or updated. 

To include only certain line items from an entitlement, a producer needs to select the desired line 
items on the List Entitlement By Orders page and click the Email button, as shown in this screenshot:
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The next screen will show the entitlement notification email, which only contains the selected line 
item. The notification email might look like this: 

Previously, if an entitlement contained more than one line item, the entitlement notification email 
would always include all of the entitlement’s line items.

Removed Security Question
(Case 02954443, SWM-24008)
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When users set or change their password for the Producer Portal or the End-User Portal, they need to 
select a security question as an additional authentication factor. In previous releases, the list of 
security questions included the question “Where were you when you first heard about 9/11?”. In the 
2025.03 release, inclusion of this question has changed because it could be distressing for some 
users:

• New users and users who did not use 9/11 as a security question will no longer see the question 
“Where were you when you first heard about 9/11?” when they are setting their password and 
security question. 

• Existing users who had already selected “Where were you when you first heard about 9/11?” as 
their security question are not forced to select a different security question. Instead, they will see 
a warning message, “This security question is deprecated and is recommended to be changed.” 
This approach gives existing users time to select a new security question. Once they selected a 
different security question, the message is no longer displayed.

The following screenshot shows the screen presented to existing users: 

Figure 23: Existing users are informed that the 9/11 security question is deprecated.

These changes apply to the Producer Portal and End-User Portal.

New Configuration Hides Menu Options for Making Entities Obsolete 
(Case 02902521, SWM-22852)

In FlexNet Operations, the status "Obsolete" is typically used to remove entities (for example, products, 
features, feature bundles, devices, suites, and license models) from use permanently. This status 
helps distinguish outdated or superseded entities from those currently in use, without completely 
deleting them from the system.

However, producers need to use great care when setting an entity’s status to Obsolete, because the 
status Obsolete is permanent and cannot be reverted. The 2025.01 release therefore introduces the 
configuration option Allow state change of entities to obsolete (under System > Configure > FlexNet 
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Operations > General Options), which enables producers to hide the Obsolete or Make Obsolete menu 
options in the Producer Portal. Specifically, when the option is unselected, the Obsolete or Make 
Obsolete menu options are no longer displayed in the following locations in the Producer Portal:

• Entitlements > List Entitlements By Order > Change State menu

• Entitlements > Create  > Line Items and Maintenance Line Items tabs > Change State menu

• Devices > Devices > clicking the hyperlinked device name opens the Device or View Server page > 
Edit menu

• Products > Products > Change State menu

• Products > Features > Change State menu

• Products > Feature Bundles > Change State menu

• Products > Suites > Change State menu

• Administer > License Models >  Change State menu

Unselecting Allow state change of entities to obsolete prevents users from—accidentally or 
intentionally—changing the state of products, features, feature bundles, devices, suites, license 
models, and similar entities, to Obsolete using the user interface. However, entities can still have their 
status changed to Obsolete using an API web service call.

By default, Allow state change of entities to obsolete is selected.

Note • Operations that involve changing an entity’s state to Obsolete as part of a transfer or upgrade 
process are not impacted.

Larger Announcements Section on Home Page
(Case 02893461, SWM-22764)

On the Producer Portal home page, the Announcements section has been enlarged and can now 
display more information without the need to scroll. Scrolling is only required for very long 
announcements.

Meaningful Labels For Search in “List Entitlements” Page in End-User Portal
(Case 02782395, SWM-21306)

In the End-User Portal, on the List Entitlements page, two of the labels in the Search drop-down menu 
have been changed to more meaningful names, which now also match the equivalent labels used in 
the Producer Portal:

Old Label New Label

Sold-to display name Sold-to Account Name

Sold-to ID Sold-to Account ID
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Note • The change only applies to the English locale. Label changes for other languages will be 
implemented in a future release. 

Displaying All Active Custom Line Item Attributes 
(Case 02870375, SWM-21901)

The Producer Portal and End-User Portal now display all active custom line item attributes that have a 
value defined on the Line Item Details and Entitlement Details pop-up windows. 

Enhanced Expiration Information on View Server and View Device Pages 
(Case 02860395, SWM-20463)

In the Producer Portal and End-User Portal, the View Server and View Device pages have been 
enhanced to provide a better overview of the mapped line items’ expiration status. 

The table in the Licenses section contains a new column, Expiration Status, which shows whether a 
line item is active or has expired. By default, the table is sorted to list all active line items first, followed 
by the expired line items. Within these groups, active and expired line items are sorted by expiration 
date in ascending order. The line item closest to its expiration date is displayed at the top. 

Producers can change the sort order by clicking the column headers, Expiration Status and Expiration 
Date.

Sorting Features on the Products Page in the Producer Portal
(Case 02858726; SWM-20353, SWM-22618)

On the Package Products page in the Producer Portal, the product’s features are sorted by creation 
date. By default, the oldest feature is displayed at the top of the list.

Fewer Clicks Required to Change Line Items’ Start or Expiration Dates 
(Cases 02802470, 02875676; SWM-20060)

A new button Change Start/Expiration Date has been added to the Entitle Customers To Licenses 
page. It enables producers to change the start and/or expiration date for multiple line items in an 
entitlement in one step. 

In addition, also on the Entitle Customers To Licenses page, the table under Line Items now includes a 
Start date column, giving producers visibility over all start dates for all activation IDs.  

Entitlement ID and Start Date Now Displayed on Key Pages
(Case 02869264; SWM-20273, SWM-20592) 

In the Producer Portal, a number of pages have been updated to optionally display additional 
information, which enables producers to see relevant information at one glance without having to 
navigate to other pages.

This enhancement affects the following pages of the Producer Portal::

• Device Details
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• Map Entitlements

• Remove Licenses

• Map by Activation IDs

These pages can now display the following information: 

• The column Entitlement ID displays the hyperlinked entitlement IDs. Clicking a link opens the 
Entitle Customers To Licenses page with the entitlement details in a new browser tab. 

• The column Start Date shows the start date of the line-item. 

The following system configurations (under System > Configure > FlexNet Operations > Embedded 
Device Settings) control the display of a line item’s start date or its entitlement ID on the pages listed 
above:

• Display start date—Displays or hides the Start Date column on the Device Details, Map 
Entitlements, Map by Activation IDs, and Remove Licenses pages while viewing a license server 
(local license server or Cloud Licensing Service instance) or standalone device. Default: disabled.

• Display entitlement ID—Displays or hides the Entitlement ID column on the Device Details, Map 
Entitlements, Map by Activation IDs, and Remove Licenses pages while viewing a license server 
(local license server or Cloud Licensing Service instance) or standalone device. Default: disabled.

Note • You access the Device Details and Map Entitlement pages as follows: 

• Device Details page: click Devices > Devices > select a device. The new columns are displayed in 
the Licenses section.

• Map Entitlements page: click Devices > Devices > select a device. On the Device page, click 
Licenses > Map Entitlements. The new columns are displayed in the Entitlements Available 
section.

• Map by Activation IDs page: click Devices > Devices > select a device. On the Device page, click 
Licenses > Map by Activation IDs. The new columns are displayed in the Entitlements Available 
section.

• Remove Licenses page: click Devices > Devices > select a device. On the Device page, click 
Licenses > Remove Licenses. The new columns are displayed in the Licenses Currently Mapped 
section.

Easier Login to Revenera Registry
(SWM-20249)

An end customer wanting to pull a container image must first log into the registry. However, this 
presumes that the customer already knows the registry URL, which is not always the case. 

To make this process easier for customers, on the Downloads page, the End-User Portal now contains 
a new button, Container Registry login, which will copy the Docker login command with the 
appropriate tenant URL to the clipboard. Customers can then easily paste the command into the 
Docker command-line interface to log into the registry.
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Figure 24: The Downloads page of the End-User Portal with the new Container Registry login button.

System Requirements
Detailed system requirements for FlexNet Operations 2025 R1 On Premises include the following.

Requirement Description

Supported Operating Systems • Microsoft Windows Server 2022 

• Microsoft Windows Server 2019 

• Microsoft Windows Server 2016 

• Red Hat Enterprise Linux 8.4 (64-bit)

• Virtual appliance: Linux (64-bit) based on CentOS-7

Important • All Linux platforms must be Linux Standard Base 
(LSB) compliant.

Supported databases • SQL Server 2019

• SQL Server 2017
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Servers

Note • For best performance, availability, and reliability, install 
each FlexNet Operations component on a separate host.

For Windows servers (each) 

• Dual core

• 8 GB of RAM for each component (FlexNet Operations, Cloud 
Licensing Service, Usage Analytics Service) 

• Minimum of 10 GB free disk space 

For Linux servers (each) 

• Dual core 

• 8 GB of RAM for each component (FlexNet Operations, Cloud 
Licensing Service, Usage Analytics Service) 

• Minimum of 10 GB free disk space 

• Current directory (.) must be in the path of the user who 
starts the FlexNet Operations server 

For Virtual Appliance 

• 8 GB of virtual RAM

• 8 GB of virtual disk space

• VMware requires about three times as much hard disk space 
at Open Virtualization Format package deployment time

Application server WildFly version 8.2.0, with default configured heap space 
minimum of 4 GB and maximum of 8 GB 

Message broker software RabbitMQ version 3.10.6 (with Erlang/OTP v13.0.2 (25))

Supported Java development 
kits

• Oracle JDK 1.8

• OpenJDK 1.8

Web browsers • Microsoft Edge 

• Mozilla Firefox 75.0 

• Google Chrome 80.0.3987.163 

Requirement Description
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Resolved Issues
The following sections describe the issues that have been resolved in the FlexNet Operations 2025 R1 
On-Premises release to date:

FlexNet licensing module • FlexNet Publisher Toolkit 11.12.0 or later 

• FlexNet Embedded Toolkit 2015 R2 or later 

Note • FlexNet Operations supports these FlexNet Embedded 
host ID types: ETHERNET, INTERNET, INTERNET_6, FLEXID9, 
FLEXID10, STRING, USER, VM_UUID, EXTENDED, 
PUBLISHER_DEFINED, and CONTAINER_ID.

Vendor certificate generator The current versions of the VCG kit are 12.11.0 and 16.2.2.0. 

These VCGs were tested with the following compilers: 

• Windows—Visual Studio 2010 Professional Edition 

• Linux—gcc 4.1.2 (RHEL 5.0) 

• Linux—gcc 4.4.4 (RHEL 6.0) 

Note • The 12.11.0 VCG is built with FlexNet Publisher 11.11.1 
and shares the same minimum C compiler requirements on each 
supported platform. (See the FlexNet Publisher 11.11.1 release 
notes for C/C++ compiler support.) 

Supported upgrade paths You can upgrade from the following previous FlexNet Operations 
versions to the current version:

• 2018 R1

• 2020 R1.1 

• 2021 R1 

• 2022 R1

• 2023 R1

• 2024 R1

LDAP directory server Windows 2012 Active Directory

High Speed File Upload If you intend to use the High Speed Upload option to upload files, 
the following plug-in is required:

Aspera Connect 3.10.0 or later

Requirement Description
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• Installation and Upgrade Issues Resolved

• Account and User Management Issues Resolved

• Entitlement Management Issues Resolved

• Electronic Software Delivery Issues Resolved

• Export and Import Issues Resolved

• SOAP and REST Web Services Issues Resolved

• Security Issues Resolved

• User Experience Issues Resolved

Installation and Upgrade Issues Resolved
The following issues were resolved for the installation of FlexNet Operations On-Premises in the 2025 
R1 release.

• Initial Login Failure and Password Reset Failure in Offline Environments

• Database Upgrade Error When Using Custom Schema

Initial Login Failure and Password Reset Failure in Offline Environments
(SWM-23876)

After installing FlexNet Operations 2024 R1 On-Premises in an environment without internet access, 
an issue was encountered during the initial login process. Specifically, when attempting to log in with 
default credentials, the system attempted to redirect to the FlexNet Operations password reset page. 
However, the following error is thrown before the redirection completes:

org.apache.tiles.definition.DefinitionsFactoryException: I/O Error reading definitions.

This problem is commonly observed during version upgrades of FlexNet Operations and may also 
occur when selecting the "Forgot Password" option.

This issue has been resolved in the current release. The login and password reset functionality now 
works as expected in environments without internet connectivity.

Database Upgrade Error When Using Custom Schema 
(Case 02906417, SWM-25061)

When migrating FlexNet Operations 2020R1 to 2024R1, a database upgrade error occurred when the 
database was configured with a custom schema name instead of the default dbo schema.

The upgrade scripts have now been corrected, and the issue has been resolved in this release.

Account and User Management Issues Resolved
The following issue involving the management of accounts was resolved in the 2025 R1 release.

• Users With Expired Accounts No Longer Fail to Update
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• Partners Can Now Filter Devices by Account Name and ID in End-User Portal

Users With Expired Accounts No Longer Fail to Update
(Case 02917771, SWM-24640)

In previous releases, when an account was linked to a user whose association with a different account 
had expired, the account could not be updated. When attempting to update such an account, FlexNet 
Operations returned an error message. The following example illustrates the scenario in which the 
error was displayed:

1. The following two end-customer accounts exist: account ACME and account INDIGO.

2. User A is linked to account ACME. The expiry date was set using the Data Import template; and the  
association between user A and account ACME is set to expire on January 10. 

3. On January 28, you want to link user A to the INDIGO account. This fails with the error message 
“Expiry date should be either today or after date”

If the user expiry was set via web services or the Producer Portal user interface, and the date has 
passed, the user could be linked to another account. The problem occurred only when the expiry date 
was set via the Data Import template.

This issue has now been resolved. Users whose expiry dates are set using the Data Import template 
are allowed to be linked to other accounts when those expiry dates have passed. If a user is expired on 
one account, this does not prevent the linking on another account.

Partners Can Now Filter Devices by Account Name and ID in End-User Portal 
(Cases 02114107, 02908843; SWM-6311) 

Previously, when a channel partner logged in to the End-User Portal and tried to filter the Devices page 
for devices by account ID or account name, the query did not return any devices. This limitation made it 
difficult for partners to assist their customers with license allocation and troubleshooting.

In the 2025.03 release, this limitation has been addressed, and channel partners can now filter the 
Devices page for devices by account ID or account name.
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Figure 25: Example screenshot showing filtering devices by account name 

Entitlement Management Issues Resolved
The following issues were resolved for entitlement management in the 2025 R1 release.

• Creating Entitlements and Accounts in Offline Environment

• Product and Line Item Description in Email No Longer Showing “<br>” Instead of Line Breaks

• Resolved Issue with Invalid Characters in Entitlement Emails Sent Using Web Services

• Deselecting Boolean Entitlement Custom Attributes With Names Containing More Than 30 
Characters

• Displaying License Issue Date in UTC

• Harmonizing the Behavior to Allow Mapping of Expired Line Items

• Updating Start or Expiration Date No Longer Fails When Start Date Option Is Not “Specify Value 
Now”

• Start Date No Longer Changes When FlexNet Publisher Licenses Are Rehosted

• New Configuration to Limit Device Search to Device Owner

• Automatic Renewal No Longer Causing Spurious Error Message

• Resolved End-User Portal Login Issue

• Bulk Upgrade Jobs With Auto-Fulfill No Longer Failing

• Corrected Wording of Warning Message When Removing Users

• Controlling Behavior When Transferring Entitlements With New Activation ID and Entitlement ID

• Bulk Operations Email Now Includes Entitlement Line Item Custom Attribute Information

• Configuration Option “Show Line Items with Zero Copies by Default” Now Working as Expected
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• Transferring Entitlements with Linked Maintenance to New Account

• Changing a Line Item’s Start Date No Longer Updates Its Expiration Date

• Offline License Return Requiring Confirmation

• Resolved Error in License Model Creation Process

• Feature Overrides Now Propagated to CLS Instances

• Updates to License Model Attributes Can Be Propagated to Cloud Licensing Service

• Request Button Now Triggering Renewal Email

• Entitlement Line Item Start or Expiry Updated Using "Change Start/Expiration Date" Button Now 
Reflected on CLS

• Confirmation Step No Longer Skipped During License Count Update

• Restrict Activations on Expired Line Items for FlexNet Publisher Products

• Google reCAPTCHA Challenge Now Displays Complete Set of Pictures, Allowing to Send 
Entitlement Emails

• Saving a Feature with Space in Version Number Triggers Meaningful Error Message

• Rearranging Features on the Products Page in the Producer Portal

• Filter "Is remaining copies more than zero?" Now Working as Expected in Producer Portal

• Resolved Discrepancy Between Number of Entitlements in End-User Portal and Producer Portal

• Download Now Link in End-User Portal Now Working As Expected

Creating Entitlements and Accounts in Offline Environment 
(Case 02906417, SWM-23875)

In the 2024 R1 On-Premises release, an error occurred when attempting to create entitlements and 
accounts in environments without internet connectivity.

This issue has been resolved. The functionality now works in both online and offline environments.

Product and Line Item Description in Email No Longer Showing “<br>” 
Instead of Line Breaks
(SWM-20718)

When using the Producer Portal for sending an entitlement email for a product with multiple line items, 
the line items are now presented on separate lines. Previously, they were erroneously presented in a 
continuous paragraph, where the line breaks were indicated by <br>.

Resolved Issue with Invalid Characters in Entitlement Emails Sent Using 
Web Services
(Cases 02745509, 02863731; SWM-18974)
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When entitlement emails are sent using the web service operation emailEntitlement and the product 
description contains any line breaks, these line breaks are now reflected as expected in the line item 
description. In previous releases, line breaks could be rendered as invalid characters when the HTML 
Content section (in the Email Template Content section of the Entitlement Email template) contained 
the [[DESCRIPTION]] merge tag and if the relevant product description included line breaks.

In the 2024.07 release, line breaks are now reflected as expected in the line item description.

Deselecting Boolean Entitlement Custom Attributes With Names Containing 
More Than 30 Characters 
(SWM-20454)

Previously, during entitlement creation, certain custom attributes could not be deselected once the 
entitlement had been saved. This issue occurred for custom attributes that matched the following 
criteria: 

• Name contains more than 30 characters

• Entity type Entitlement

• Type Boolean

The issue only occurred when creating and saving an entitlement in the Producer Portal. It did not 
occur when using web services or the Data Import Template.

This issue has now been resolved.

Displaying License Issue Date in UTC 
(Case 02795034, SWM-19471)

By default, the issue date that is returned by the /features endpoint is always calculated in Pacific 
Time. In certain scenarios, this can result in mismatched dates for issued and receivedTime in the 
/features endpoint response. 

To avoid these mismatched dates, this release introduces a new configuration Use UTC timezone for 
license issue date (under System > Configure > Embedded Devices > Host Options). When the 
configuration is selected, the issue date of a license is displayed in Coordinated Universal Time (UTC).

Harmonizing the Behavior to Allow Mapping of Expired Line Items
(Case 02814955, SWM-20627)

Previously, the behavior for allowing or denying the mapping of expired line items to a license server 
was inconsistent.

The following configuration options (under System > Configure > Embedded Devices > Host Options) 
control whether mapping expired line items using web services or activating expired line items using a 
FlexNet Embedded client is allowed: 

• Allow expired line items to be mapped to devices or servers—If selected, expired line items can 
be mapped to a device or server

• Allow Duration License Decrease AND/OR Allow Duration License Decrease for Producer—If 
selected, licenses with duration-based features can have their copies reduced by a non-producer 
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user or a producer, respectively. (Normally, licenses using durations only allow increasing the 
number of copies.) 

The following table specifies whether mapping expired line items using web services or activating 
expired line items using a FlexNet Embedded client is allowed, depending on the combination of 
selected configuration options:

Updating Start or Expiration Date No Longer Fails When Start Date Option Is 
Not “Specify Value Now”
(SWM-21795)

Previously, changing the start date and/or expiration date using the Change Start/Expiration Date 
button failed if during entitlement creation, a line item’s start date was set to any option other than 
Specify Value Now. The resulting issue depended on the selection for the expiration date: 

• If the expiration date is set to Specify Value Now, the start date value on the Configure Line Item 
panel is not updated accordingly. 

• If the expiration date is set to Permanent or Specify Expiration Date, FlexNet Operations returns 
an application error.

This issue no longer occurs.

Start Date No Longer Changes When FlexNet Publisher Licenses Are 
Rehosted
(Case 02849875, SWM-19963)

When rehosting duration-based FlexNet Publisher licenses with the start date option Use Each 
Activation Date, the start date no longer resets to the date when the rehost operation occurs. Equally, 
the licenses’ end date remains unchanged when they are rehosted. 

New Configuration to Limit Device Search to Device Owner
(SWM-20241)

Previously, a search for devices by device owner (account ID or account name) would also return 
devices that were not owned by the account specified in the search, if the device had add-on license 
entitlements mapped from the account specified in the search. 

Allow expired line items 
to be mapped to devices 
or servers

Allow Duration License 
Decrease AND/OR Allow 
Duration License 
Decrease for Producer

Mapping expired line items to server or 
device (using web services or FlexNet 
Embedded client)

Unselected OFF Not allowed

Selected OFF Allowed

Unselected ON Not allowed

Selected ON Allowed
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This release introduces a configuration called Limit device search by device owner (under System > 
Configure > FlexNet Operations > Embedded Device Settings), which allows producers to restrict 
search results only to devices owned by the account specified in the search.

By default, the option is unselected (preserving the previous behavior, whereby search results can also 
include devices that are not owned by the account specified in the search but have add-on license 
entitlements mapped from the account specified in the search).

The configuration option controls the behavior for device searches in the Producer Portal, End-User 
Portal, and using the ManageDeviceService web service.

Automatic Renewal No Longer Causing Spurious Error Message
(SWM-22055)

If a line item is configured to automatically renew, and the Auto Renew option is later deactivated, 
FlexNet Operations no longer erroneously displays an error when changing the expiration date in the 
Change Start/Expiration Date dialog to a new date that would be later than the original renewal 
expiration date.

Resolved End-User Portal Login Issue
(Case 02779816, SWM-22469)

Previously, users could log in to the End-User Portal using an activation ID from an inactive or obsolete 
entitlement. This issue no longer occurs, and users can no longer access the portal with such IDs. 

Bulk Upgrade Jobs With Auto-Fulfill No Longer Failing
(SWM-21435)

Bulk upgrade jobs that have auto-fulfill set to Yes no longer fail. 

Corrected Wording of Warning Message When Removing Users
(Case 02867154, SWM-20939)

When removing an end customer or channel partner from an entitlement, the Producer Portal now 
displays an appropriate prompt, Do you want to remove the selected account(s)?.

Controlling Behavior When Transferring Entitlements With New Activation ID 
and Entitlement ID
(Case 02549610, SWM-21073)

When transferring an entitlement containing a line item where some line item copies have already 
been activated and specifying that a new entitlement ID and activation ID are generated, the new 
account will receive the entitlement with the full amount of line item copies. However, the copies that 
have previously been activated are still mapped to the previous device and can be used to generate 
licenses. 
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To avoid such a scenario, this release introduces a new element to the EntitlementOrderService 
SOAP web service, called returnRemainingLineItems, and a new configuration option Transfer 
entitlement with remaining quantity only (under System > Configure > FlexNet Operations > General 
Options), which help producers control the behavior when transferring entitlements with a new 
entitlement ID and activation ID to another account. 

If the configuration option Transfer entitlement with remaining quantity only is selected, transferring 
the entitlement with a new entitlement and activation ID will transfer only the number of undeployed 
line items. 

The returnRemainingLineItems setting is used during the transfer of entitlements using SOAP services 
when the configuration option Transfer entitlement with remaining quantity only is selected. If the 
configuration is unselected, the returnRemainingLineItems setting has no impact on the transfer 
process. 

• When returnRemainingLineItems is enabled (true): During an entitlement transfer, if some line 
items are already deployed, the remaining undeployed line items will be transferred to the target 
entitlement.

Example: Suppose entitlement E1 with activation AC1 has a quantity of 100, and 20 line items 
have been deployed. If returnRemainingLineItems is enabled, the remaining 80 undeployed line 
items will be transferred to the target entitlement.

• When returnRemainingLineItems is disabled (false): During an entitlement transfer, if some line 
items are already deployed, an error message will be returned, indicating that the entitlement 
cannot be transferred because certain line items are already deployed.

Example: Suppose entitlement E1 with activation AC1 has a quantity of 100, and 20 line items 
have been deployed. If returnRemainingLineItems is disabled, an error message will be returned 
as part of the response.

By default, returnRemainingLineItems is set to false. 

Bulk Operations Email Now Includes Entitlement Line Item Custom Attribute 
Information 
(Case 02884242, SWM-22636) 

Entitlement line items that are associated with custom attributes are now displayed as expected in 
bulk operation notification emails. 

Configuration Option “Show Line Items with Zero Copies by Default” Now 
Working as Expected
(Cases 02553109, 02843547, 02876825, 02905595; SWM-13867)

In previous releases, the End-User Portal displayed line items with zero copies remaining on the 
Activatable Items and the Manage Entitlements pages even if the configuration option Show Line 
Items with Zero Copies by Default was unselected, meaning that such line items should be hidden. 
This has now been resolved, and the option, if unselected, hides line items that have zero copies 
remaining.

Transferring Entitlements with Linked Maintenance to New Account
(Case 02767923, SWM-20253)
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Previously, when transferring an entitlement with a linked maintenance to another account, the linked 
maintenance was not transferred. Only the entitlement line items for the entitlement were transferred 
to the new account. This could cause the Product Version Upgrade job to fail.

To address this, release 2025 R1 introduces a new configuration Transfer maintenance line items 
from other entitlements (under System > Configure > FlexNet Operations > General Options). If 
selected, when transferring an entitlement to another account, any maintenance line items are also 
transferred, if these maintenance line items are linked to a line item belonging to the entitlement being 
transferred. If the linked maintenance line item is linked to a different entitlement (that is, not the 
entitlement that is being transferred), the transfer is not performed and an error message is displayed.

By default, the configuration option is unselected (meaning that only the entitlement line items for the 
entitlement are transferred to the new account).

Changing a Line Item’s Start Date No Longer Updates Its Expiration Date
(SWM-22987)

When updating a line item’s start date in the Change Start/Expiration Date widget, the line item’s 
expiration date is no longer erroneously also updated. 

Offline License Return Requiring Confirmation 
(Cases 02857961, 02880341, 02900219, 02904405; SWM-20700)

In previous releases, if the configuration option Skip Confirmation or Skip Confirmation for Producer 
(under System > Configure > Embedded Devices > License Generation) was not selected, the system 
erroneously did not require confirmation for reducing the number of copies via an offline activation 
request. The capability response included the following parameter: 

{
"confirmationRequestNeeded" : false
}

This issue was addressed in the 2024.10 release. Now, when the option Skip Confirmation or Skip 
Confirmation for Producer is unselected, and an offline activation file for reducing license counts is 
uploaded to FlexNet Operations, the capability response that is subsequently generated and loaded 
into the local license server will show the following:

{
"confirmationRequestNeeded" : true
}

Resolved Error in License Model Creation Process  
(SWM-22881)

During license model creation, the setting “Is this a counted model” is now working as expected. This 
means that if it is set to Yes, a counted license model is created. Previously, even if “Is this a counted 
model” was set to Yes, the created license model erroneously was uncounted.

Also, the field isCounted in the getLicenseModelIdentifier operation of the ProductPackagingService 
web service now shows the correct value. 
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Feature Overrides Now Propagated to CLS Instances
(SWM-23755) 

In previous releases, when changing a substitution value of a feature override for a feature, the 
changes were not populated to the relevant Cloud Licensing Service (CLS) instances and were not 
included in the response when calling the /features endpoint.

In this release, this issue no longer occurs and feature overrides are propagated to the CLS instances. 
This fix ensures reliable and consistent license data and simplifies the process of updating and 
managing licenses, reducing manual errors. 

In addition, a new configuration option called Maximum number of products to be updated following 
an attribute change was introduced (under System > Configure > FlexNet Operations > Embedded 
Device Settings). The option enables producers to specify the maximum number of products that 
should be updated on CLS instances whenever an attribute value for a feature has been changed.

The default setting is 200. Producers who want to specify a higher number should consider that the 
more products a feature is associated with, the more changes are propagated to CLS instances, which 
may negatively impact performance.

Updates to License Model Attributes Can Be Propagated to Cloud Licensing 
Service
(Case 02917977, SWM-23727) 

Previously, changes to license model attributes were not propagated to the relevant Cloud Licensing 
Service (CLS) instance and the devices it served. 

The 2024.12 release introduces functionality that enables producers to update license model 
attributes and have them reflected on existing devices in the field. To allow the propagation of license 
model attributes, producers must select the newly introduced configuration option Trigger Product 
Notifications when License Models are updated as well as the existing configuration option Allow 
Editing of Deployed Entities (both are located under System > Configure > FlexNet Operations > 
General Options). 

Effects on Performance

If Trigger Product Notifications when License Models are updated is selected, all devices using a 
product that is linked to the updated license model are updated. For each affected product, one 
notification is passed to the Cloud Licensing Service and License Fulfillment Service, which then pass 
the notification to the device running the product. The large number of notifications sent negatively 
affects performance of all functionality served by the Cloud Licensing Service and License Fulfillment 
Service. 

Revenera therefore recommends not to select Trigger Product Notifications when License Models are 
updated.

Producers should also note that the updates to license model attributes take time to propagate, 
especially if they have a large number of products and devices. Depending on the number of products 
and devices, an update might take 1-5 minutes to be reflected.

Request Button Now Triggering Renewal Email 
(Case 02890657, SWM-22556)
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On the End-User Portal’s Expiring Entitlements page, end users can click a Request button to send an 
email message to the producer about their intent to renew selected entitlements. 

In previous releases, the End-User Portal failed to send such renewal emails. In the 2025.01 release, 
this issue has been resolved. When an end user clicks the Request button, the End-User Portal sends a 
renewal email to the email address specified in the configuration option Request Renewal Notification 
Email (under System > Configure > FlexNet Operations > Renewals). That email address is also used 
to populate the From field. The end user requesting the renewal will receive receive a copy of the 
renewal email, as their email address is included in the Cc field. 

Important • Renewal emails are sent only if the following conditions are fulfilled:

• An email address is specified in the configuration option Request Renewal Notification Email 
(under System > Configure > FlexNet Operations > Renewals).  

• The email address specified in Request Renewal Notification Email has been verified in the 
Producer Portal on the Email/Domain Verification page (available from the Administer menu in 
the Email group). 

Entitlement Line Item Start or Expiry Updated Using "Change 
Start/Expiration Date" Button Now Reflected on CLS
(Case 02913332, SWM-24187) 

Previously, when an entitlement was mapped to a Cloud Licensing Service (CLS) instance and one of 
its line items had its start or expiration date changed using the Change Start/Expiration Date button on 
the Entitle Customers to Licenses | Create an Entitlement page (under Entitlements > List 
Entitlements by Order > click the entitlement’s hyperlinked ID), the new start or expiration date was 
not reflected on the CLS instance. This means that served clients' subsequent capability requests were 
not aligned with the new start or expiration date.

This issue no longer occurs. An entitlement line item’s changed start or expiration date is now 
immediately reflected on the mapped CLS instance, and can be viewed as follows:

• On the View Server page (Devices > Devices > click a hyperlinked device name > View > View 
Response) in the Capability Response section.

• Calling the /features endpoint.

Confirmation Step No Longer Skipped During License Count Update
(Case 02912962, SWM-24195)

Previously, when removing line items mapped to a local license server or a standalone device, FlexNet 
Operations was not enforcing the step where a confirmation of changes is needed before quantities on 
the device are updated, even though the configuration option Skip Confirmation or Skip Confirmation 
for Producer was unselected. 

The bug occurred when Generate Response was triggered on the View Server or Device page (under 
Devices > Devices > click hyperlinked name of a device), which changed the license status to License 
generated and decreased the license count on the device without waiting for the device to confirm the 
changes. This bypassed the expected Waiting for confirmation status, which should remain until the 
device explicitly sends a confirmation request.  
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This has been fixed in the 2025.01 release. Clicking Generate Response now changes the license 
status to Waiting for confirmation. The license count is only updated on the device after it has sent a 
capability request to confirm the changes. 

The following table shows the behavior and license status when a user clicks Generate Response after 
a license count change, depending on the selection of the Skip Confirmation and Skip Confirmation for 
Producer configuration options.

Restrict Activations on Expired Line Items for FlexNet Publisher Products 
(Case 02144139, SWM-23877)

Previously, when an end user attempted to activate an expired FlexNet Publisher line item (using web 
services or the appactutil utility) and that line item had previously been activated on a client, the 
request erroneously succeeded. The reason for this behavior was that FlexNet Operations located the 
relevant fulfilment record and treated the activation as a reinstall. However, this behavior resulted in 
clients being able to continue using the software beyond the license expiration date.

To address this issue, FlexNet Operations now checks the line item expiration date before activation. If 
a line item has expired then the activation request is denied and an error message is shown. 

This change applies to all types of activations (online, offline, manually, or via web services). Other 
license lifecycle operations such as return, repair, or rehost are not affected.

Google reCAPTCHA Challenge Now Displays Complete Set of Pictures, 
Allowing to Send Entitlement Emails
(Case 02552507, SWM-20758)

Skip Confirmation
Skip Confirmation
for Producer Behavior in 2025.01

Unselected Unselected Status changes to Waiting for confirmation. Once a 
capability request is sent or uploaded, the status changes 
to License generated and the license count is updated on 
the device.

Selected Selected Status changes to License generated. Once a capability 
request is sent or uploaded in the Producer Portal and the 
End User Portal, the license count is updated on the 
device.

Selected Unselected Status changes to License generated. Once a capability 
request is sent or uploaded in the Producer Portal or the 
End User Portal, the license count is updated on the 
device.

Unselected Selected Status changes to License generated. Once a capability 
request is sent or uploaded in the Producer Portal (and 
optionally in the End User Portal), the license count is 
updated on the device.



FlexNet Operations 2025 R1 On-Premises Release Notes  (October 2025)  74

In the Producer Portal, if the Google reCAPTCHA challenge is active, the Google reCAPTCHA challenge 
now displays a complete set of pictures when attempting to send entitlement emails from the List 
Entitlements page. 

To send an email from the List Entitlements page (under Entitlements > List Entitlements), select an 
entitlement and click Email. On the next page, click I’m not a robot. The Google reCAPTCHA challenge 
displays a set of pictures and prompts you to select certain pictures to prove that you are human 
before sending the email.

Previously, some of the pictures were missing, making it impossible for users to complete the 
challenge and send emails from the List Entitlements page (by selecting an entitlement and clicking 
Email). 

The following screenshots show an example of the reCAPTCHA screen with missing pictures and the 
same page with the fix:

Figure 26: Entitlement email with corrupted reCAPTCHA panel
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Figure 27: Entitlement email with fixed reCAPTCHA panel, showing all pictures. 

Note • To use Google reCAPTCHA, the following configuration options must be set: 

• Recaptcha Site key and Recaptcha Secret password (under System > Configure > FlexNet 
Platform Server > General Options)

• Use Recaptcha validation when sending entitlement emails (under System > Configure > FlexNet 
Operations > General Options) must be selected.

Saving a Feature with Space in Version Number Triggers Meaningful Error 
Message
(Case 02990348, SWM-25307)

In previous releases, when a feature was created with the Version Format Type set to Fixed and the 
Version field included a space (for example, “1.0 “), the feature was created successfully. However, 
adding such features to a product later failed with the following error message:  

The version string "2.0  " for feature "TestSpaceInVersionField" is not a valid 
FlexNet version: must be <number>.<number> [Incident# 9379-0620915R]

To be able to map the feature to a product, producers had to return to the feature and modify the 
version to remove spaces, which caused frustration and wasted producers’ time.
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New Behavior

In the 2025.03 release, producers are alerted during the feature creation process that a feature with 
the Version Format Type set to Fixed cannot have a version number containing spaces. If a feature’s 
Version Format Type is set to Fixed and the Version field contains a space, upon saving the feature the 
following error message is displayed: 

The version format is invalid. Please follow the standard format and avoid any spaces. 

The following screenshot shows the Package Products | Create a Feature page with the red banner 
and the error message, because the version includes a space (“1.0 “):

Figure 28: The Package Products | Create a Feature page with the red banner and error message 

Rearranging Features on the Products Page in the Producer Portal
(Case 02858726, SWM-22618)

On the Products page (under Products > Product > click a product name), features and feature 
bundles (on the Features tab) can now be sorted based on the date they were added to the product. By 
default, they are arranged in ascending order (the oldest feature or feature bundle is displayed at the 
top of the list). The order can be reversed by clicking the header of the Feature or Feature Bundle 
Name column.

The following screenshot shows the Feature or Feature Bundle Name column where the order of 
features can now be changed.



FlexNet Operations 2025 R1 On-Premises Release Notes  (October 2025)  77

Figure 29: On the Package Products | Create a Product page, the order of features can now be 
changed.

Note • When exporting feature information (using either .jar or Data Import template (.xlt) format), 
the feature to product linkage is reset to have the timestamp of the import.

Filter "Is remaining copies more than zero?" Now Working as Expected in 
Producer Portal
(Case 02905595, SWM-25218)

This release resolves an issue with the option Is remaining copies more than zero? that is available in 
the Advanced search panel on the List Entitlements page. In previous releases, regardless of whether 
the option was set to Yes or No, the List Entitlements page showed entitlements with copies greater 
than 0 as well as those with 0 copies. 

In the 2025.03 release, the option Is remaining copies more than zero? works as expected:

• Yes—The List Entitlements page shows only entitlements with copies greater than 0.

• No—The List Entitlements page shows only entitlements with 0 copies.

• None—The List Entitlements page shows entitlements with copies greater than 0 and those with 0 
copies.

The following screenshot shows the option Is remaining copies more than zero?:
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Figure 30: The Advanced search panel on the List Entitlements page

Resolved Discrepancy Between Number of Entitlements in End-User Portal 
and Producer Portal
(Cases 02979909, 02553109; SWM-24947, SWM-23317)

Previously, when the configuration option Show Line Items with Zero Copies by Default (under System 
> Configure > FlexNet Operations > General Options) is unselected, there was a discrepancy between 
the number of entitlements listed on the List Entitlements page in the Producer Portal and on the List 
Entitlements page in the End-User Portal. The reason was a synchronization issue, which meant that 
entitlements with an available quantity of zero were erroneously displayed on the List Entitlements 
page in the End-User Portal. 

This issue no longer occurs, and the List Entitlements page shows the correct number of entitlements 
in both portals. 
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Figure 31: The List Entitlements page in the Producer Portal shows entitlements with zero available 
quantity only when the configuration option Show Line Items with Zero Copies by Default is selected.

Figure 32: An example of the List Entitlements page in the End-User Portal showing entitlements with 
zero available quantity.

Download Now Link in End-User Portal Now Working As Expected
(Case 02989988, SWM-25688)

In the End-User Portal, download packages could previously not be downloaded from either the New 
Versions or Previous Versions tab on the Download Order page. (The Download Order page is available 
by selecting Activation & Entitlements > List Entitlements and clicking the Download Now link for an 
entitlement). Instead of a download link, both tabs showed the error message “There are currently no 
available downloads defined for your account.” However, downloads were indeed available, as 
confirmed on the List Downloads page.

This problem has now been resolved. If a user has an entitlement that has download packages 
associated, they will be able to download the download packages from the New Versions tab. 
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In addition, expired or archived download packages are now displayed and can be downloaded from 
the Previous Versions tab. 

Figure 33: The Download Order page now shows expired or archived download packages on the 
Previous Versions tab. 

Electronic Software Delivery Issues Resolved
The following issues were resolved for Electronic Software Delivery (ESD) in the 2025 R1 release.

• DownloadPackagingService Web Service No Longer Returning Duplicate Results

• Resolved Display Issues for Download Packages and File Notifications

• Note in Import Data Template for Entitlement Management Now Showing Warning

• Improved Bulk Upgrade Job Performance

• Download Package Search No Longer Returns Duplicate Counts

• Uploading New File Versions Will Update Existing Content

DownloadPackagingService Web Service No Longer Returning Duplicate 
Results
(Case 02853877, SWM-19967)

The getDownloadPackageQuery operation of the DownloadPackagingService web service no longer 
returns duplicate values if a download package has multiple values set for a multi-value text custom 
attribute. This fix applies to all versions of the DownloadPackagingService web service.

Resolved Display Issues for Download Packages and File Notifications
(Case 02817693, 02820710; SWM-19544)
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Previously, when navigating to pages related to Electronic Software Delivery functionality (download 
packages and file notifications), the ?authtype=external parameter was not appended to the URL. As 
a result, some UI elements (Create Email button, check boxes for selecting packages) were not 
displayed properly. This issue no longer occurs. 

Note in Import Data Template for Entitlement Management Now Showing 
Warning
(SWM-23642)

The note for the ActivationId and ActivationState columns in the Entitlement Management template 
Excel file (on the Create-Update Entitlement and Create-Update MaintenanceLine sheets) now warns 
against deleting these columns to prevent unwanted behavior.

Note • Users need to be aware that even though providing a value is optional, they should not delete 
these columns because doing so means that no line items are created in FlexNet Operations. For more 
information about the import behavior when deleting the columns, refer to the FlexNet Operations User 
Guide, section Using Data Import Templates.

Improved Bulk Upgrade Job Performance 
(SWM-23963)

The execution time of bulk upgrade jobs has been reduced.

Download Package Search No Longer Returns Duplicate Counts 
(Case 02988915, SWM-25228)

When retrieving download package counts using the getDownloadPackageCount operation of the 
DownloadPackagingService web service or using the Search Download Packages page in the Producer 
Portal, the query could return incorrect counts. This issue occured in the following scenarios:

• The getDownloadPackageCount operation returned an incorrect count if a download package had 
multiple values set for a multi-value text custom attribute.

• The Search Download Packages page returned duplicate values when searching for a download 
package using a wildcard character (*) in a custom attribute. 

https://docs.revenera.com/fno_CURRENT/producer/Default.htm
https://docs.revenera.com/fno_CURRENT/producer/Default.htm
https://docs.revenera.com/fno_CURRENT/producer/Content/helplibrary/Using_Data_Import_Templates.htm
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Figure 34: Previously, using a wildcard (*) in a custom attribute when searching for download 
packages could cause the Producer Portal to return duplicates.

This issue has now been resolved. The fix for the getDownloadPackageCount operation applies to all 
versions of the DownloadPackagingService web service.

Uploading New File Versions Will Update Existing Content
(Cases 02225917, 02567912, 02680773, 02834194, 02918066, 02918272, 02995536, 03003837, 
03008991; SWM-19909) 

Previously, when uploading a new version of a file (or package) whose previous version existed in the 
Software Delivery system, it was recommended to use a new file name. This best practice prevented 
the delivery of “stale” file content to customers, because uploading a new file with the same file name 
would not reliably overwrite the existing file. 

Now, you can upload new content using an existing file name, which will replace the existing content. 

Export and Import Issues Resolved
The following issues related to the Data Export and Import functionality were resolved in the 2025 R1 
release.

• End-Users No Longer Denied Access After Importing Entitlements When “Allow Portal Login” 
Column Deleted

• Resolved Issue with Import and Export of Bulk Entitlements

• Resolved Issue with Data Import Template

• Import/Export Jobs Terminated Upon Job Server Restart

• Import/Export Jobs No Longer Getting Stuck on Job Server Restart

• Retriggering Stuck Jobs for Bulk Upgrade Operations

• Account Data Export



FlexNet Operations 2025 R1 On-Premises Release Notes  (October 2025)  83

End-Users No Longer Denied Access After Importing Entitlements When 
“Allow Portal Login” Column Deleted
(SWM-20500)

When the AllowPortalLogin column on the Create-Update Entitlement sheet in the Entitlement 
Management template has been deleted, the end customer is now allowed to log into the End-User 
Portal using the entitlement ID or activation ID. Previously, access was erroneously denied.

Resolved Issue with Import and Export of Bulk Entitlements
(SWM-21129)

Importing and exporting data using the Create-Update Entitlement and Create-Update 
BulkEntitlement sheets in the Entitlement Management template no longer fails if the data includes 
custom license model attributes of type Multi-valued text which contain no values.

Resolved Issue with Data Import Template
(Case 02775871, SWM-21434)

When exporting a set of entities as a Data Import Template file, the Data Import Template for Selected 
Items now pulls the correct value as given in the line item detail for the License Model Custom 
Attribute set during entitlement time. For example, if the License Model Custom Attribute name is 
Return_Allowed, which is set to false upon updating or creating a line item during entitlement time, 
the same value is reflected in the Data Import Template file upon downloading.

Import/Export Jobs Terminated Upon Job Server Restart 
(Cases 02820494, 02818923, 02823312, 02823629, 02842880; SWM-19548)

In this release, any import/export jobs and bulk operation jobs that hang when the job server is 
restarted are terminated, and the following error message is displayed: Job Server was restarted. 
Please submit the job again. 

This fix removes the lock on the scheduler to prevent follow-up jobs from getting stuck and enables 
customers to identify and resubmit jobs that failed due to a restart.

Import/Export Jobs No Longer Getting Stuck on Job Server Restart 
(Cases 02874418, 02902735, 02909549; SWM-21535)

In previous releases, when an import/export job was running and at the same time the job server was  
restarted, the job was stuck in the "in Process" state and never completed until it was resubmitted.

This behavior was problematic, because producers had to resubmit those stuck import/export jobs, 
which took up extra time. 

This has now been resolved. If an import/export job is in process while a job server restart occurs, that 
job will be moved to a waiting state so that the next run can pick it up. Producers no longer need to 
manually resubmit the hanging job.

Retriggering Stuck Jobs for Bulk Upgrade Operations
(Case 02969947, SWM-24096)
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In the past, jobs for bulk upgrade operations could get stuck with the status “Submitted” or “In 
Progress”. There was no indication of whether the job was running. Restarting the job server had no 
impact on the job; it would remain stuck. The only solution for producers was to manually retrigger the 
job. 

This issue has now been resolved. If a job for a bulk upgrade operation gets stuck, restarting the job 
server triggers a new job which will pick up the work from the original job. This new job is scheduled to 
run within 2 minutes of the server restart.

Account Data Export
(Cases 03030706, 03032924; SWM-26609)

In this release, the functionality for exporting accounts information has been restored. 

In its Export menu, the Manage Accounts page (available from Accounts & Users > All Accounts) now 
shows the correct option, Data Import Template. Clicking Export > Data Import Template triggers an 
export job, which creates a downloadable Data Import Template (.xlt) file containing the relevant 
entities.

The image below shows the option Data Import Template which is used to export accounts 
information: 

Figure 35: The Export menu now contains the correct option, Data Import Template, for exporting 
accounts information.

Previously, in its Export menu, the Manage Accounts page showed the options Selected Items and 
Selected Items with Their Dependencies, which had no underlying functionality (.JAR export is not 
available for accounts and users). 

Device Management Issues Resolved
The following issue with device management was resolved in the 2025 R1 release.

Replacing Control Characters in Device Names
(Cases 02845338, 02845338; SWM-21484, SWM-22488) 
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This resolved issue is a continuation of the issue Devices Page Now Loading Correctly When Device 
Name Includes Invalid Control Characters that was addressed in the 2023 R1 release. For more 
information, see the FlexNet Operations 2023 R1 On-Premises Release Notes that are available on the 
Revenera Product Documentation site.

Previously, when a device was created using a capability request and the “Device ID” or “Alias” field 
contained a control character, the Devices page did not load as expected. As part of the initial fix, 
made in the 2023 R1 release, control characters in the “Device ID” or “Alias” field were replaced with 
an empty string (for example, the device name Test^BName was saved as TestName).

The behavior is controlled by the configuration option Retain Non-Printing Characters in Device ID and 
Alias (located under System > Configure > Embedded Devices > Host Options), introduced in 2023 R1. 

As an unintended consequence of this change, if an invalid character was used in the “Device ID” or 
“Alias” field and subsequently replaced by an empty string by FlexNet Operations, the license was not 
processed by the FlexNet Embedded toolkit. 

To fix this, in the 2025 R1 release, all control characters are replaced with their respective 
hexadecimal values if the configuration option Retain Non-Printing Characters in Device ID and Alias is 
unselected (the default setting). For example, the device name Test^BName will be saved as 
Test&#x2;Name. 

Here is a list of the control characters that will be replaced with a hexadecimal string if Retain Non-
Printing Characters in Device ID and Alias is unselected:

^B, ^D, ^E, ^G, ^N, ^O, ^P, ^Q, ^R, ^S, ^T, ^U, ^W, ^X, ^Y, ^[, ^\, ^], ^F, ^C, ^^, ^A, 
^V, ^_ 

The following table shows examples of control characters and their referenced hexadecimal values:

Changed Behavior of Configuration Option Controlling the Character Replacement

The 2023 R1 release introduced the configuration option Retain Non-Printing Characters in Device ID 
and Alias (located under System > Configure > Embedded Devices > Host Options). Note the following 
changes in behavior since the 2023 R1 release: 

• When Retain Non-Printing Characters in Device ID and Alias is selected: Any control characters in 
the “Device ID” or “Alias” field are retained when the device is created. This behavior is the same 

Control Character in 
Caret Notation Symbol Code Hexadecimal Code

^F ACK("\u0006" ( CTRL+F )) &#x6;

^C ETX("\u0003"(CTRL+C)) &#x3;

^^ RS("\u001e" ( CTRL+~ )) &#x1e;

^A SOH("\u0001" ( CTRL+A )) &#x1;

^V SYN("\u0016 " ( CTRL+V )) &#x16;

^_ US("\u001f "( CTRL+? )) &#x1f;

https://docs.revenera.com/fno2023r1_onprem/rn/Content/helplibrary/Device_Management_Issues_Resolved.htm#fno_op_releasenotescontent_322661009_2215710
https://docs.revenera.com/fno2023r1_onprem/rn/Content/helplibrary/Device_Management_Issues_Resolved.htm#fno_op_releasenotescontent_322661009_2215710
https://docs.revenera.com/fno2023/rn/Default.htm
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in 2023 R1 through 2025 R1. Customers should note that in this case, if the “Device ID” or “Alias” 
field contains an invalid character, the Devices page will not load correctly.

• When Retain Non-Printing Characters in Device ID and Alias is unselected: 

• Behavior in 2023 R1 and 2024 R1: Control characters in the “Device ID” or “Alias” field are 
replaced with an empty string. 

• Behavior in 2025 R1: Control characters in the “Device ID” or “Alias” field are replaced with 
their respective hexadecimal values. 

Note that by default, Retain Non-Printing Characters in Device ID and Alias is unselected. 

SOAP and REST Web Services Issues Resolved
The following issues related to FlexNet Operations Web Services were addressed in the 2025 R1 
release.

• Updating Line Item Quantity with EntitlementOrderService v7 No Longer Failing

• GetProductCategories Now Returning Product Line Attributes

• Resolved Issue With Recording CREATE Events

• SOAP Operation getLicenseModelIdentifiers Now Returning License Model

• getEntitlementsQuery and getEntitlementCount Operations Strictly Adhering to expirationDate 
Parameter

• Activation ID Updates Using EntitlementOrderService Web Service Only Allowed in Draft State

Updating Line Item Quantity with EntitlementOrderService v7 No Longer 
Failing
(Case 02872466, SWM-21506)

Attempting to update the total quantity (numberOfCopies parameter) of a line item using the 
createSimpleEntitlement operation with an opType of CREATE_OR_UPDATE no longer results in a stack 
overflow error. This issue previously occurred for the EntitlementOrderService SOAP web service, 
version 7.

GetProductCategories Now Returning Product Line Attributes
(Cases 01964245, 02502505; SWM-21024)

In the ProductPackagingService web service, the getProductCategories operation now returns the 
product line attributes if the product is associated with a product line.

Sample Request
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:urn="urn:v3.webservices.operations.flexnet.com">
   <soapenv:Header/>
   <soapenv:Body>
      <urn:getProductCategoriesRequest>
         <!--Optional:-->
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         <urn:pageNumber>1</urn:pageNumber>
         <urn:batchSize>10</urn:batchSize>
         <urn:returnContainedObjects>true</urn:returnContainedObjects>
      </urn:getProductCategoriesRequest>
   </soapenv:Body>
</soapenv:Envelope>

Sample Response
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-
instance">
<soapenv:Body>
<getProductCategoriesResponse xmlns="urn:v3.webservices.operations.flexnet.com">
<statusInfo>
<status>SUCCESS</status>

</statusInfo>
<responseData>
<productCategory>
<name>ALL</name>
<description>ALL</description>

</productCategory>
<productCategory>
<name>ProductLine</name>
<description>ProductLine</description>
<categoryAttributes>
<categoryAttribute>
<attributeName>ProductLineAttribute1</attributeName>
<isRequired>true</isRequired>
<dataType>BOOLEAN</dataType>

</categoryAttribute>
<categoryAttribute>
<attributeName>ProductLineAttribute2</attributeName>
<isRequired>true</isRequired>
<dataType>TEXT</dataType>
<maxLength>128</maxLength>

</categoryAttribute>
</categoryAttributes>

</productCategory>
<productCategory>
<name>Uncategorized Products</name>
<description>Uncategorized Products</description>

</productCategory>
</responseData>

</getProductCategoriesResponse>
</soapenv:Body>

</soapenv:Envelope>

Resolved Issue With Recording CREATE Events
(SWM-21703)

Previously, when an entitlement was created using the SOAP web service request 
createSimpleEntitlement and autoDeploy was set to true, the CREATE event type was not listed on 
the Search Transactions: Results page for entitlements.
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This issue no longer occurs and all event types are displayed on the Search Transactions: Results 
page. 

SOAP Operation getLicenseModelIdentifiers Now Returning License Model
(Case 02880643, SWM-21742)

The getLicenseModelIdentifiers operation of the ProductPackagingService web service now returns 
the license model as expected. Previously, it returned a null value even if the license model existed in 
FlexNet Operations.

getEntitlementsQuery and getEntitlementCount Operations Strictly 
Adhering to expirationDate Parameter 
(Case 02905739, SWM-23097)

In previous releases, the search parameter expirationDate in the getEntitlementsQuery and 
getEntitlementCount operations of the EntitlementOrderService web service also returned 
entitlements containing line items where the expiration was specified as a duration, and where such 
line items had not yet been activated. 

In the 2025 R1 release, such searches using expirationDate return only entitlements that strictly 
match the specified expiration dates. 

If none of the line items in an entitlement meet the criteria for expirationDate or have an empty 
expiration date, then such entitlements will not be returned.

Examples

When <urn:expirationDate> is passed in the request, at least one of the line items for an entitlement 
must strictly match the search type for that entitlement to be returned in the response.

expirationDate with searchType ON

The following search criteria return only entitlements that have at least one line item with the 
expiration date 2024-01-30.

<urn:expirationDate>
<urn:value>2024-01-30</urn:value>
<urn:searchType>ON</urn:searchType>

</urn:expirationDate>

expirationDate with searchType AFTER

The following search criteria return only entitlements that have at least one line item with the 
expiration date later than 2024-01-30.

<urn:expirationDate>
<urn:value>2024-01-30</urn:value>
<urn:searchType>AFTER</urn:searchType>

</urn:expirationDate>

Activation ID Updates Using EntitlementOrderService Web Service Only 
Allowed in Draft State 
(Case 02180694, SWM-22403)
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Previously, the updateEntitlementLineItem method in the EntitlementOrderService allowed 
producers to change the activation ID of an entitlement in a deployed state. This behavior was 
inconsistent with the Producer Portal UI which did not allow such a change.

Starting in 2025 R1, the activation ID of an entitlement can only be changed if the line item is in a draft 
state, and this behavior is consistent with the Producer Portal UI.

Security Issues Resolved
The following issues related to FlexNet Operations security were addressed in the 2025 R1 release.

• Security Fixes Related to FlexNet Embedded . JAR Files

• Security Fixes Related to Apache Tomcat

• Improved Handling of Potentially Sensitive URLs

• Enforced Authentication in Public Services API

• Fixed Insecure Direct Object Reference Vulnerability in End-User Portal

• Enforcing Account Access Permissions for Portal Users

• Improved Error Handling for Status 500 Errors

• Upgraded Chart.js

Security Fixes Related to FlexNet Embedded . JAR Files
(Cases 02263480, 02263480, 02545209, 02578008; SWM-14175) 

We have addressed several security vulnerabilities identified in the National Vulnerability Database 
(NVD). The following CVEs have been fixed in this release by using the latest .JAR files from FlexNet 
Embedded:

• CVE-2019-1543 (CVSS 7.4)

• CVE-2019-1551 (CVSS 5.3)

• CVE-2019-1549 (CVSS 5.3)

• CVE-2019-1563 (CVSS 3.7)

• CVE-2019-1547 (CVSS 4.7)

• CVE-2019-1552 (CVSS 3.3)

Security Fixes Related to Apache Tomcat
(SWM-24993) 

Apache vulnerabilities were identified in FlexNet Operations 2024 R1 on-premise. These have been 
addressed in FlexNet Operations 2025 R1 on-premise by upgrading Apache Tomcat to version 
9.0.104. The following vulnerabilities were resolved:

• CVE-2024-34750 (CVSS 7.5)—Fixed in Apache Tomcat version 9.0.90

• CVE-2025-24813 (CVSS 9.8)—Fixed in Apache Tomcat version 9.0.99

https://nvd.nist.gov/vuln/detail/CVE-2019-1543
https://nvd.nist.gov/vuln/detail/CVE-2019-1551
https://nvd.nist.gov/vuln/detail/CVE-2019-1549
https://nvd.nist.gov/vuln/detail/CVE-2019-1563
https://nvd.nist.gov/vuln/detail/CVE-2019-1547
https://nvd.nist.gov/vuln/detail/CVE-2019-1552
https://nvd.nist.gov/vuln/detail/cve-2024-34750
https://nvd.nist.gov/vuln/detail/cve-2025-24813
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Improved Handling of Potentially Sensitive URLs
(Case 02916672, SWM-23701) 

During a security scan, the following URLs were identified as potentially exposing sensitive information 
in FlexNet Operations On-Premises:

• /flexnet/%2522ns%253D%2522netsparker%25280x00011F%2529

• /flexnet/c%3a%5cboot.ini

• /flexnet//r87.com/.html

To address this, all listed URLs now redirect to the login page, with the exception of  
/flexnet/c%3a%5cboot.ini. Previously, accessing this URL resulted in a 500 Internal Server Error with 
visible error details. This has been resolved by implementing proper exception handling, and the 
request now redirects to the sitedown.html page:

Figure 36: Under Maintenance page (sitedown.html) displayed when trying to access the URL 
/flexnet/c%3a%5cboot.ini.

Resolved XXE Vulnerability in Public Services API 
(Case 03287621, SWM-27698)

Revenera has addressed an unauthenticated XML External Entity (XXE) vulnerability in its public 
services APIs that previously allowed unauthorized access to server files through specially crafted XML 
requests. 

Enforced Authentication in Public Services API
(SWM-22672)

Flexnet Operations has a public API hosted at the following URLs:

• https://<site-id>.flexnetoperations.com/flexnet/pubservices/lineitemdetails

• https://<site-id>.flexnetoperations.com/flexnet/pubservices/entitlementdetails
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• https://<site-id>.flexnetoperations.com/flexnet/pubservices/registeruser

• https://<site-id>.flexnetoperations.com/flexnet/pubservices/mapentitlement

Previously, these endpoints could be accessed without any sort of authentication, which is now 
categorized as a security flaw. In line with modern security practices, these API endpoints now require 
authentication. 

To ease the transition to enforced authentication, the 2024.10 release introduces the configuration 
Enable authentication for Public Webservices (under System > Configure > FlexNet Operations > 
General Options). By default, the option is selected and authentication is enforced. Producers who 
need time to adjust and do not want to enforce authentication for a transition period can unselect the 
option. 

However, Revenera recommend that producers change their systems to enable authentication at the 
earliest. The Enable authentication for Public Webservices configuration option will be removed in a 
future release to avoid security exposure and authentication will be fully enforced.

Fixed Insecure Direct Object Reference Vulnerability in End-User Portal 
(Case 02889128, SWM-22283)

Unauthorized users can no longer navigate to the Edit Account page (which shows account details) of 
an account that they do not belong to by changing the ID in the URL of the End-User Portal.

Enforcing Account Access Permissions for Portal Users
(SWM-25459)

Previously, users with the Portal User role could access information that they are not entitled to see, by 
manipulating URL parameters.

In the 2025 R1 release, it is no longer possible to access information without the necessary 
permissions, by manipulating URL parameters.

Improved Error Handling for Status 500 Errors
(Case 2889182, SWM-22287) 

Previously, status 500 errors could reveal the server hostname in the fault details of the response, 
which is considered a security risk. Such an error could be triggered by sending a bad request using 
web services—for example, by attempting to update a user with a typo in the request, like 
<urn:lastNam>?</urn:lastName>. 

This issue has now been addressed, and status 500 errors no longer reveal implementation details.

Upgraded Chart.js
(Case 02999121, SWM-25776)

The Chart.js library has been upgraded to version 2.9.4 to address potential security vulnerabilities.

User Experience Issues Resolved
The following issues involving user experience were resolved in the 2025 R1 release. 
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• Announcements Not Visible on End-User Portal Home Page

• Duplicate Configuration Options After Upgrade

• Sorting Licenses Table on Device Page

• Resolved Date Format Issue in Served Devices Data Extract

• Avoiding Consolidation Error in End-User Portal

• Sorting Licenses Table on Devices Page in End-User Portal

• Confirmation Message for Configuration Changes

• Configuration Changes Now Updated After Saving

• Increased Download Speed in End-User Portal

• Updated Link to Customer Community

• Removed Truncation in End-User Portal on View Server Page

• System Roles No Longer Visible in Portals

• Resolved Issue of Incorrectly Formatted Page in End-User Portal

Announcements Not Visible on End-User Portal Home Page 
(Case 02991834, SWM-25522)

The Announcements section on the Home page of the End-User Portal did not display any content, 
despite announcements being configured. 

Figure 37: Empty Announcements section in the End-User Portal.

This issue has been resolved in the 2025 R1 release.
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Duplicate Configuration Options After Upgrade
(Case 02841988, SWM-25848)

Following an upgrade from FlexNet Operations On-Premises 2021 R1 to 2024 R1, some users 
observed duplicate configuration entries appearing in the system, as shown in the following 
screenshot:

Figure 38: Duplicate options on the System Configuration page

This issue has been resolved. In the latest release, configuration data will no longer be duplicated 
during the upgrade process.

Sorting Licenses Table on Device Page
(SWM-22619)
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On the View Server or Device page in the Producer Portal, the Licenses table can now be sorted by 
Expiration or Expiration Status using the toggle icon in the column header. Also, the headers of the 
Expiration and Expiration Status columns are now properly aligned.

Resolved Date Format Issue in Served Devices Data Extract 
(SWM-22841)

The Served Devices Data Extract now shows the correct expiration dates. 

Avoiding Consolidation Error in End-User Portal
(Case 02234869, SWM-21264)

When end users are consolidating line items and the list contains inactive line items, the inactive line 
items are automatically ignored. This means that inactive line items are no longer causing 
consolidation errors, improving the overall user experience.  

Sorting Licenses Table on Devices Page in End-User Portal
(SWM-22619)

Previously, on the View Server or Device page in the End-User Portal, none of the columns of the 
Licenses table could be sorted. 

Now, the Licenses table can be sorted by Expiration or Expiration Status using the toggle icon in the 
column header for all types of devices. Also, the headers of the Expiration and Expiration Status 
columns are now centered vertically.

Confirmation Message for Configuration Changes 
(SWM-22817)

When changing any configuration (under System > Configure), the Producer Portal now shows a 
confirmation message: The configuration was updated successfully.

Previously, such a confirmation message was only displayed when changing a configuration value in 
the section Embedded Devices > Host Options.

Configuration Changes Now Updated After Saving
(SWM-22817)

In previous releases, when changing a configuration setting under Embedded Devices (under System 
> Configure) and clicking Save Configs, the previous setting (either the previous value or 
selected/unselected state of the check box) was still shown. The updated setting was only visible after 
clicking Save Configs a second time. In addition, after saving changes, the confirmation message “The 
configuration was updated successfully” was formatted differently to other FlexNet Operations 
confirmation messages (using a white background instead of a blue banner). 

Both issues have been resolved in the 2025.01 release. Changes to configuration settings are now 
saved and visible after clicking Save Configs once, and the confirmation message is formatted as a 
blue banner. 
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Increased Download Speed in End-User Portal
(Case 02776698, SWM-19906) 

In the End-User Portal, end users associated with several accounts can now download content more 
quickly. The syncing process has been optimized, allowing users to access downloads shortly after 
their accounts and entitlements are provisioned.

Updated Link to Customer Community
(SWM-24485) 

Following the recent introduction of the new Revenera Community, the link Customer Community 
(available in the Producer Portal from the System menu) has been updated to point to the Community’s 
new URL, https://community.revenera.com. 

Any users attempting to access the previous URL, http://flexeracommunity.force.com/customer/, will 
be redirected to the new URL.

Removed Truncation in End-User Portal on View Server Page
(Case 02981114, SWM-24922) 

Previously, the menu options available from the View menu on the View Server page in the End-User 
Portal were truncated on the left side of the screen and not readable. To access the View Server page, 
click Devices > Devices, then click the hyperlinked name or ID for a server (Cloud License Server 
instance or local license server). 

The following screenshot shows the fixed menu of the View Server page, with the menu options fully 
visible:

https://community.revenera.com
http://flexeracommunity.force.com/customer/
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System Roles No Longer Visible in Portals
(Cases 03009399, 03009414, 3011796; SWM-26277)

The system roles Default Producer Role and Manage Impersonated Access Tokens PP, and Default 
Portal Role and Manage Impersonated Access Tokens EP are no longer visible in the Producer Portal 
and the End-User Portal, respectively.

These roles are not intended for selection by producers or end users. To avoid that they are mistakenly 
assigned they are now hidden from the Producer Portal and End-User Portal.

Note • The roles Manage Impersonated Access Tokens PP and Manage Impersonated Access Tokens 
EP contain permissions for issuing so-called impersonated access tokens, which are a means to 
securely authorize SOAP and REST web service calls to FlexNet Operations. While the term 
“impersonated” might sound concerning, it simply refers to a mechanism where a privileged user can 
securely act on behalf of another user with limited permissions.

Resolved Issue of Incorrectly Formatted Page in End-User Portal 
(Case 02411062, SWM-26279)

In the End-User Portal, when associating an existing user to an account, the page for selecting users 
was not correctly formatted. 

The issue could be seen by following these steps: 

1. Click Accounts & Users > List Accounts. 

2. On the Accounts page, click a hyperlinked account ID. 

3. In the Account Users section, click Actions > Link existing users.  

4. Click the pagination arrow to see the next set of users.
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5. You will see the page with formatting issues:

This issue no longer occurs. 

Known Issues
The following describes known issues in the current FlexNet Operations release.

SWM-26718: Custom Logo Not Displayed in End-User Portal “View Server” 
or “Device” Page
In the End-User Portal, the Device or View Server page (available from the Devices menu) does not 
display a custom logo (if a custom logo has been specified). Instead, these pages display the Revenera 
logo and “FlexNet Operations” product name, as shown in this screenshot:  
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Customers who experience this issue can contact Revenera support who can implement a workaround 
until the problem has been resolved.

Note • Producers can upload an image file to serve as custom logo in the End-User Portal using the 
Upload Company Logo configuration option (under System > Configure > End-User Portal Setup > 
Custom Branding). 

SWM-26045: Using Incorrect Country Codes in createUser API
Revenera identified an issue with the createUser API of the UserAcctHierarchyService web service 
that impacts users created without a supported country code. In such cases, the createUser API 
assigns a default country code, which results in incorrect data. These users are not synced with the 
Electronic Software Delivery (ESD) system and are therefore unable to access their software 
downloads in the End-User Portal.

For example, if "US" is the required country code and an unsupported variant like "USA" is provided, 
the API will successfully create the user but assign an incorrect default country code instead of "US." 
As this process does not return an error, customers may be unaware of the discrepancy. Consequently, 
the affected user is not properly synced with the ESD system and is unable to access downloads.

To avoid interruptions in software delivery access, Revenera strongly recommends using only 
supported country codes when calling the createUser API.

SWM-23586: Hanging Bulk Operation Jobs Not Showing “Failed” Status
A fix made in the 2024.11 release (see description Import/Export Jobs Terminated Upon Job Server 
Restart) has been reverted for bulk operations. The fix remains in place for import/export jobs.

https://docs.revenera.com/fno2024/rn/Content/helplibrary/Export_and_Import_Issues_Resolved_in_2024_11.htm
https://docs.revenera.com/fno2024/rn/Content/helplibrary/Export_and_Import_Issues_Resolved_in_2024_11.htm
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This means that any bulk operation jobs that hang when the job server is restarted are not terminated 
and are not automatically retriggered. 

SWM-19547: Download Search Page in End-User Portal Not Filtering Expired 
Accounts
In the End-User Portal, on the Download Search page (available from Downloads > Search Downloads), 
the Choose Account dropdown list does not filter out expired accounts. Instead, it erroneously displays 
expired and non-expired accounts. 

Note • The Choose Account dropdown list is only displayed if the user belongs to more than one 
account that is entitled to downloads.

SWM-20454: Cannot Deselect Boolean Entitlement Custom Attributes With 
Names Containing More Than 30 Characters 
During entitlement creation, certain custom attributes cannot be deselected once the entitlement has 
been saved. This issue occurs for custom attributes that match the following criteria: 

• Name contains more than 30 characters

• Entity type Entitlement

• Type Boolean

This issue only occurs when creating and saving an entitlement in the Producer Portal. It does not 
occur when deselecting a Boolean custom attribute for entity type Entitlement whose name is more 
than 30 characters long using web services or the Data Import Template.

SWM-15171: Auto-Fulfill Failing During Large Bulk Upgrade Jobs
Auto-fulfill might fail in bulk upgrade jobs that contain more than 2200 line items.

SSRE-20257: Upload of Large File Images Failing 
The upload of file images that exceed 1 GB using HTTP upload fails. For large file images, Revenera 
recommends using FTP upload.

SWM-18974: Invalid Characters in Entitlement Emails
In some scenarios, when Entitlement emails are sent using web services, the product description in 
the email can contain invalid characters. These appear when the Text Content section (in the Email 
Template Content section of the Entitlement Email template) contains the [[DESCRIPTION]] merge tag 
and if the relevant product description includes line breaks. 

SWM-19052: Feature Count Aggregation Not Working As Expected
If a feature’s aggregation type is changed, the relevant instance of the Cloud Licensing Service might 
not update the aggregated feature counts according to the new aggregation type. 
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However, if the entitlement for the product that contains the features is mapped to a new Cloud 
Licensing Service instance, the feature counts are aggregated correctly as per the new aggregation 
type. 

FNO-69836: Variables in Vendor String Causing License Activation Issues
License activation fails for product upgrades or normal license activation when the product to be 
upgraded or activated is associated with a feature that has a vendor string which contains substitution 
variables that are enclosed in double quotes (for example, 
"activationId":"{EntitlementLineItem.activationId}").

FNO-69338: Navigation in Package Products Pages Skipping Review 
Features Page
When the user navigates through the Package Products pages (under Products > Features) using the 
Next button at the bottom of each page, the Review Features and Review Feature Bundles pages are 
erroneously skipped. 

As a workaround, users who want to review the features and feature bundles that they just added can 
click the Review Features and Review Feature Bundles links, respectively, in the Packaging Guide 
section at the bottom of the page to access the Review Features page. 

SWM-15870: Mismatch Between User Name and Email Address Causing 
Issues with ESD (UserOrgHierarchyService)
When creating a user via the UserOrgHierarchyService web service (the predecessor of the User 
Account Hierarchy Service web service), it is possible to have different values for user name and email 
address. However, users whose user name and email address do not match cannot access downloads 
in the End-User Portal. 

Producers who use the UserOrgHierarchyService should use the methods from the User Account 
Hierarchy Service web service to avoid a mismatch between the user name and email address. 

FNO-69182: Incorrect Email Format Accepted When Creating User Via 
Import Template 
It is possible to create or update a user with an invalid email address format by importing user 
information using the Account and User import template (downloadable from Administer > Import 
Data Objects > Data Import Templates in the Producer Portal). Email addresses of the format abcd@ef 
(that is, an email address consisting of a recipient name, @ symbol and domain name but without top-
level domain) are erroneously accepted. 

SWM-10701: Search Functionality in End-User Portal Erroneously Displays 
Download Link 
In the End-User Portal, users who should be denied access to a file based on their geographical 
location are able to display the download link for a restricted file when searching for the file name 
(using the Search function with the Files option on the Download Search page). However, users are not 
able to download the restricted file. 
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FNO-66018: Errors in UI Updated for Download Package Selection Across 
Multiple Pages
In 2021.09, the Download Packages window was updated to allow package selection across multiple 
pages. The following errors currently exist for the updated UI.

• Incorrect error message for EULA license on Review & Resolve page

• Search string not properly clearing

• No option to return to full (unfiltered) Download Package list when “failed validation” message 
displays

• Failed validation error displayed for search results

• Pagination control fields not showing correct information

• Inappropriate message displayed for already downloaded packages

Incorrect error message for EULA license on Review & Resolve page

When you attempt to download packages that fail validation, the following message is displayed: 
“Some of the selected packages failed validation. You need to review and resolve the validation 
errors.” Then, on the Failed Packages window that is displayed if you click the “review and resolve” 
link in the message, the error for an unaccepted EULA incorrectly shows the following:

 “EULA has not been accepted. To accept EULA, click on the Download package ID.” 

Instead of “click on the Download Package ID”, the message should instruct the user to “...click ‘I 
Agree’”. 

Search string not properly clearing 

After you filter the package list on the Download Packages window, the message “Results for 
Download package name: <name>” is appropriately displayed. However, if you then click the Clear link 
at the end of message, the search string used to filter the package list remains, the list remains 
filtered (even if you move to the next page), and the “Results for the Download package name...” 
message is still displayed. You must manually delete the search string and click Search to clear the 
filter.

No option to return to full (unfiltered) Download Package list when “failed validation” 
message displays

If the “failed validation” message is displayed after you attempt to download packages from a filtered 
list on the Download Packages window, no mechanism exists to clear the filter to display all packages. 
You must manually delete the search field contents and click Search.

Failed validation error displayed for search results

After searching for and attempting to download a package containing an unaccepted EULA, the 
expected message “Some of the selected packages failed validation...” is displayed on the Download 
Packages window. However, if you then search for a package that does not contain an EULA (but do 
not attempt to download the package), you received the “failed validation” message instead of the 
correct message describing the filter results: “Results for Download package name: <name>”.
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Pagination control fields not showing correct information

The pagination control fields on the Download Packages window are not displaying the correct totals 
for a filtered list of packages.

Inappropriate message displayed for already downloaded packages

When you select an entitlement line item whose packages have already been downloaded, the 
Download Packages window is displayed with incorrect message “Files sent for download. Please 
monitor the download manager pop up”. The message should be removed altogether or displayed only 
as package files are being sent to the Download Manager (before the actual Download Manager 
window is displayed).

SWM-7952: Not All Applicable Download Links Available on “List 
Downloads” Page in End-User Portal
When end-users are logged in with an activation ID for an entitlement line item that is associated with 
multiple products, the Downloads page (accessed from Downloads > List Downloads) in the End-User 
Portal does not always show links to all applicable product downloads.

SWM-7786: SHA2 Checksum Value of Previous File Shown
If a user has provided a file’s expected SHA2 checksum value for an upload and the file image is 
subsequently deleted, the Upload File page, when opened again, might show the SHA2 checksum 
value of the previously loaded file image.

FNO-65909: Download Files Not Visible For Self-registered And Trial Users
Download files might not be visible in the End-User Portal for self-registered users and those users 
registered through the “Try Before You Buy” registration.

FNO-61266: Translation Issues with Localization
Per a previous enhancement in 2020 R3 to add more language support for End-User Portal 
localization, certain strings—such as alerts and validation messages—are not being translated 
properly when localization is in effect. These issues will be addressed in an upcoming release.
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Special Notes
This section contains special information pertaining to FlexNet Operations.

Plug-in Upgrade Needed for High-Speed File Uploads
If you intend to use the high-speed upload option to upload files, upgrade the Aspera plug-in to Aspera 
Connect 3.10.0 or later. 

Best Practice for Uploading New File Versions for Software Delivery
The following practice helps to prevent the delivery of “stale” file content to your customers.

When you upload a new version of a file (or package) whose previous version exists in the Software 
Delivery system, best practice is to give the new file version a unique name, different from the name of 
the existing file version. (For example, use a version number in the file name.) Try to avoid uploading a 
file using the same name as the existing file so that the existing file is overwritten. 

If you must upload a new file using the same name as the existing file, delete the existing file and wait 
10-15 minutes before uploading the new version. This process will reduce the probability of re-
caching the old content.

Handling UI Conflicts When Using a Custom CSS for the End-User Portal
When you use your own CSS to customize the look of the End-User Portal, sometimes your custom CSS 
code conflicts with existing Revenera CSS code that is used to define certain buttons, pages, and other 
UI elements. When conflicts occur, handle each case individually, determining the basis of the conflict 
and adjusting the custom CSS as needed. If you require assistance, contact Revenera Technical 
Support (see Revenera Resources).
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Legal Information
Copyright Notice
Copyright © 2025 Flexera Software

This publication contains proprietary and confidential information and creative works owned by 
Flexera Software and its licensors, if any. Any use, copying, publication, distribution, display, 
modification, or transmission of such publication in whole or in part in any form or by any means 
without the prior express written permission of Flexera Software is strictly prohibited. Except where 
expressly provided by Flexera Software in writing, possession of this publication shall not be construed 
to confer any license or rights under any Flexera Software intellectual property rights, whether by 
estoppel, implication, or otherwise.

All copies of the technology and related information, if allowed by Flexera Software, must display this 
notice of copyright and ownership in full.

FlexNet Operations incorporates software developed by others and redistributed according to license 
agreements. Copyright notices and licenses for these external libraries are provided in a 
supplementary document that accompanies this one.

Intellectual Property
For a list of trademarks and patents that are owned by Flexera Software, see 
https://www.revenera.com/legal/intellectual-property.html. All other brand and product names 
mentioned in Flexera Software products, product documentation, and marketing materials are the 
trademarks and registered trademarks of their respective owners.

Restricted Rights Legend
The Software is commercial computer software. If the user or licensee of the Software is an agency, 
department, or other entity of the United States Government, the use, duplication, reproduction, 
release, modification, disclosure, or transfer of the Software, or any related documentation of any kind, 
including technical data and manuals, is restricted by a license agreement or by the terms of this 
Agreement in accordance with Federal Acquisition Regulation 12.212 for civilian purposes and 
Defense Federal Acquisition Regulation Supplement 227.7202 for military purposes. The Software was 
developed fully at private expense. All other use is prohibited.

https://www.revenera.com/legal/intellectual-property.html
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